ActiveMIL Glossary

acquisition path
An acquisition path is a path that has the components to digitize or capture a video input signal.
auxiliary display
An image selected to an auxiliary display is displayed without a windowed border or frame, at the top-left corner of a screen that is not used to display the Windows desktop. This screen is referred to as an auxiliary screen.
band
A band is one of the surfaces of an image. A grayscale image requires only one band. A color image requires three bands, one for each component.
camera
See input device.
CCD
A CCD (Charge Coupled Device) is used to change light into an electrical signal.
child image
A child image is an image corresponding to either a rectangular region within another image or a specific band of a multi-band image. A child image can be used in the same way as any other image.
color space
A color space is the way color information in a color image is represented. Common color spaces are RGB and HLS.
DCF
DCF is the acronym for Digital Configuration Format. A DCF defines the input data format and, among other things, how to accept or generate video timing signals such as horizontal sync, vertical sync, and pixel clock.
default settings
Controls are created such that their initial properties match your default settings. To view and/or change your default settings, use the Default Values tab of the MILConfig utility, (MILConfig.exe). This utility can be accessed from the Windows Start menu under the Matrox Imaging Tools folder or the \Matrox Imaging\Tools directory. Note that your initial default settings are the ones you specified at installation.
design-time
Design-time specifies the time during which you build an application in the development environment by adding controls, setting control or form properties, and so on.
digitizer
A digitizer is the acquisition path or set of acquisition paths with which to grab from one camera of the specified type on a frame grabber.
double buffering
Double buffering means alternating the destination of an operation between two images. Double buffering allows you, for example, to process one image while grabbing into the other image.
dynamic range
The range of values actually present in an image. For example, an unsigned 8-bit image has an allowable range of 0 to 255; its dynamic range can be any range within these values.
exposure signal
An exposure signal is generated by a programmable timer of the grab hardware. The signal can be used to control external hardware.
field
One of the two halves that make up an image, as grabbed from an interlaced camera. One half consists of the image’s odd lines (known as the odd field); the other half consists of the image’s even lines (known as the even field).
fixed-point
Fixed-point is a format for representing non-integer values. It contains a fixed number of digits for the integer and fractional parts. For example, a 16-bit fixed-point image might contain 8 integer bits and 8 fractional bits. Fixed-point images are a compromise between floating-point and integer images, since they offer the speed of integer processing with some of the precision of floating-point processing.
floating-point
Floating-point is a format for representing numbers. It contains two parts, a mantissa and an exponent. The mantissa specifies the digits in the number, while the exponent expresses the magnitude of the number. This format provides a constant number of significant digits of precision over a very large dynamic range. However, floating-point images take longer to process than integer images.
frame
A frame is a single image grabbed from a video camera.
frame buffer
A frame buffer is a dedicated storage area often used for data transfers between devices of differing speeds. For example, since a computer sends out data faster than a screen can display it, the data is temporarily stored in the frame buffer (typically, that of the VGA). The image is generally thought of as a two-dimensional surface with a certain pixel depth.
frame grabber
A frame grabber is a type of imaging board which can acquire video data from a camera.
gain and offset correction
Gain and offset correction means to offset and multiply each pixel in an image by specified values: new pixel value = (old pixel value - offset) * gain The offset and gain values can be constant for the whole image or they can be different for each pixel. The latter can be useful when performing shading corrections.
grab
To grab is to acquire an image from a camera.
HLS
HLS is a color space that represents color using components of hue, luminance, and saturation. The hue component describes the actual color of a pixel. The luminance component describes the combined brightness of the primary colors. The saturation component describes the concentration of that color.
horizontal sync
The horizontal sync is the part of a camera signal that indicates the end of a line and the start of a new one.
input device
The input device used for grabbing is generally a video camera. Therefore, our documentation generally uses the word “camera” to represent an input device.
interlaced scanning
Interlaced scanning is a transfer of data in which the odd-numbered lines of the source are written to the destination image first, then the even-numbered lines are written (or vice-versa). (See progressive scanning )
interpolation
Interpolation is a neighborhood operation that estimates the intensity at a point in an image between pixel positions. The weighted-sum of the point’s neighboring pixel values is used to estimate the intensity. Two common interpolation modes are bicubic interpolation and bilinear interpolation.
kernel
A kernel is the set of numbers that are used by a neighborhood operation to determine new pixel values. The type of neighborhood operation determines how the kernel is used.
keying
Keying is a display effect, available on some boards, that switches between two display sources according to pixel values in one of the sources. It is often used to make portions of an overlay frame buffer transparent so that corresponding areas of the main frame buffer can show through it.
LUT mapping
Look-up table mapping is a point-to-point operation that uses a table to define a replacement value for all possible pixel values in an image.
multi-processing
Multi-processing is the process of executing two or more operations in parallel. It is also known as parallel processing.
neighborhood operation
A neighborhood operation replaces a pixel’s value according to the values of its surrounding pixels (called its neighborhood). The size of the neighborhood is determined by the operation’s kernel or structuring element. The type of operation determines how the new pixel value is determined. Convolutions and morphological operations are two types of neighborhood operations.
normalization
Normalization is the adjustment of results of a processing operation so that they have the correct magnitude. For example, after multiplying an image by a fixed-point integer, normalization is needed to right-shift results to remove the fractional bits.
overlay frame buffer
The overlay frame buffer is used to annotate (non-destructively) the main frame buffer. On systems that support keying if keying is enabled, portions of the overlay frame buffer that have a specified color allow the corresponding areas of the main frame buffer to show through.
progressive scanning
Progressive scanning is a transfer of data in which the lines of the source are written sequentially into the destination image. (See interlaced scanning)
property pages
Most properties of a control can be set from its property pages. To access a control's property pages at design time, right-click on the control, then select Properties from the presented menu.
raw image
A raw image is a file containing unformatted data values, optionally preceded by a number of header bytes and possibly followed by a number of footer bytes.
RGB
RGB is a color space that represents color using the primary colors (red, green, and blue) as components. This color space is generally used for most display hardware since it best matches the three-colored phosphors of display monitors. It is also the color space of many cameras and input devices.
run-time
Run-time specifies the time during which a program is being executed. During run time, you can't edit the code.
signed
A signed image can have negative values. For example, a signed 8-bit image can have values between -128 and 127. (See unsigned)
structuring element
See kernel.
synchronization event
A synchronization event occurs at the end of the execution of a procedure.
thread
A thread is an execution queue. Threads execute independently of one another, allowing operations to run in parallel.
unsigned
An unsigned image can have only positive values. For example, an unsigned 8-bit image has values between 0 and 255. (See signed)
VCF
A VCF is a Video Configuration Format.
vertical sync
The vertical sync is the part of a camera’s signal that indicates the end of a frame and the start of a new one.
Windowed display
An image selected to a windowed display is displayed with a windowed border on the Windows desktop screen(s).
Windows desktop screen(s)
A windowed display is not affected by whether or not your desktop is displayed using one screen or multiple screens. We refer to these screens, either one or many, as the Windows desktop screen(s).