1. 数据包格式说明

请求 {"F":"Login_C2S","password":"123456"}#

返回 {"F":"Login_S2C","password":"123456"}#

注：(1) F表示调用的远端函数，一定以#结束符

(2) Login_C2S中的C2S表示客户端发送给服务端

(3) Login_S2C中的S2C表示服务端发送给客户端

(4) 打标机作为服务端


2.1 登录

请求 {"F":"Login_C2S","password":"123456"}#

返回 {"F":"Login_S2C","status":"返回值"}#

注：1、此指令为验证指令，连接成功后必须发送此指令，才能发其他指令；

2、返回值: "success" 、"fail"；


2.2 获取所有设备

请求 {"F":"GetAllDevices_C2S"}#

返回 {"F":"GetAllDevices_S2C","Devices":["板卡1名称","板卡2名称"],"status":"返回值"}#

注：返回值: "success"、 "fail"；


2.3 获取所有文档

请求 {"F":"GetAllDocs_C2S"}#

返回 {"F":"GetAllDocs_S2C","Docs":["文档名1","文档名2"],"status":"返回值"}#

注：返回值: "success"、 "fail"；


2.4 打开绝对路径文件

请求 {"F":"OpenDocPath_C2S","docPath":"D:\\code\\5.2.1\\Debug\\1.orzx"}#

返回 {"F":"OpenDocPath_S2C","doc":"文档名","status":"返回值"}#

注：绝对路径需要\\来表示\ ；返回值: "success" 、"fail"；


2.5 关闭文档

请求 {"F":"CloseDocTitles_C2S","titles":["文档名1","文档名2"]}#

返回 {"F":"CloseDocTitles_S2C","titles":["文档名1","文档名2"],"status":"返回值"}#

注：1、titles是请求中的关闭成功则会添加进入;

2、返回值: "success"、 "fail"；


2.6 文档关联设备

请求 {"F":"DocAssociateDev_C2S","doc":"文档名","dev":"设备名"}#

返回 {"F":"DocAssociateDev_S2C","status":"返回值"}#

注：返回值: "success"、 "fail"；


2.7 清除设备关联文档

请求 {"F":"ClearDevAssociateDoc_C2S","devs":["设备名1","设备名2"]}#

返回 {"F":"ClearDevAssociateDoc_S2C","status":"返回值"}#

注：返回值: "success"、 "fail"；


2.8 获取指定设备关联的文档

请求 {"F":"GetDevAssociateDoc_C2S","dev":"设备名"}#

返回 {"F":"GetDevAssociateDoc_S2C","docs":["文档名1","文档名2"],"status":"返回值"}#

注：返回值: "success"、 "fail"；


2.9 开始标刻

请求 {"F":"DevsMark_C2S","devs":["设备名1","设备名2"]}#

返回 {"F":"DevsMark_S2C","status":"返回值"}#

标刻结束返回 {"F":"DevsMark_S2C","markdonestatus":"返回值"}#

注：1、如果是多卡标刻，需要启动启动哪些板卡开启标刻；

2、返回值: "success"、"fail"；


2.10 获取标刻状态

请求 {"F":"GetMarkStatus_C2S"}#

返回 {"F":"GetMarkStatus_S2C","status":"返回值","MarkStatus":"标刻状态"}#

注：1、标刻状态:"MarkComplete"、"Mark"；

2、返回值: "success" 、"fail"；


2.11 立刻停止标刻

请求 {"F":"NowStopMark_C2S"}#

返回 {"F":"NowStopMark_S2C","status":"返回值"}#

返回值: "success"、 "fail"；


2.12 设置指定位置 文本信息

请求 {"F":"SetTextInfo_C2S","Doc":"1.orzx","PosIndex":0,

"Text":"123","PosX":10,"PosY":10,"RA":10}#

返回 {"F":"SetTextInfo_S2C","status":"返回值"}#

参数：1、"Doc"表示文档名称,"1.orzx"双引号表示具体的文档名;

2、"PosIndex"表示图形在文档中列表中的序号,0表示第一个图形;

3、"Text"表示文本要替换的内容, "123"双引号内替换内容;

4、"PosX","PosY"，表示X,Y移动到的位置坐标的值,为浮点型数据;

5、"RA"，表示图形旋转的角度值,为浮点型数据;

6、返回值: "success" 、"fail";

使用说明：

1、文本与坐标值可以缺省，缺省时，不用传入对应的字段;

如：{"F":"SetTextInfo_C2S","Doc":"1.orzx","PosIndex":0,

"Text":"123"}# 表示只是替换文本，坐标不变;

{"F":"SetTextInfo_C2S","Doc":"1.orzx","PosIndex":0,

"PosX":10,"PosY":10,"RA":10}# 表示坐标变，图形内容不变;

2、图形本身的位置与旋转角度会变化;


2.13 设置旋转、偏移值

请求 {"F":"SetOffsetRotate_C2S","Doc":"1.orzx","DX":10,"DY":10,

"RA":10,"CenterX":10,"CenterY":10}#

返回 {"F":"SetOffsetRotate _S2C","status":"返回值"}#

参数：1、"Doc"表示文档名称,"1.orzx"表示具体的文档名;

2、"DX","DY","RA"分别表示偏移值X,Y的值与旋转值,为浮点型数据;

这三个值必须要设置;

3、"CenterX","CenterY"为旋转的中心点坐标,值为浮点型;

参数不传入,不需要加此字段,默认参数为中心点坐标;

4、返回值: "success" 、"fail"；

使用说明：

1、 图形本身的位置与旋转角度会变化;


2.14 获取输入口状态

请求 {"F":"GetIoStatus_C2S","devs":["设备1",”设备2”] }#

返回 {"F":"GetIoStatus_S2C","status":"返回值",”devs”:[“设备名”:端口状态]}#

注：1、输入端口默认状态0xff，默认高电平。输入口接通状态为0。0是电平，1是高

电平；

2、返回值: "success" 、"fail"；


2.15 写输出端口状态

请求 {"F":"SetIoStatus_C2S","devs":[{"port":端口,"dev":"设备名"}]}#

返回 {"F":"SetIoStatus_S2C","status":"返回值"}#

注：1、输出端口默认状态0x00，默认是低电平。0是电平，1是高电平；

2、返回值: "success" "fail"；


2.16 查询文本内容

请求 {"F":"GetContentsByTextName_C2S","doc":"文档名","shapeName":"文本名"}#

返回 {"F":"GetContentsByTextName_S2C","Contents":["内容1","内容2"],"status","返回值"}#

参数：1、"doc"表示文档名,"文档名"表示具体文档名;

2、"shapeName"表示文本图元名称,"文本名"表示具体的文本图元名称;

3、"Contents"表示文本内容;

4、"内容1","内容2"表示查询返回的实际内容;

5、返回值: "success" 、"fail";

使用说明：

1、文档名如果没有省略则查询指定文档下的指定文本内容;

2、如果文档名省略则查询活动目录下的文本内容;


3. 使用示例

替换列表中的某一个图元的内容，发送指令打标。

1、 登录验证

发送：{"F":"Login_C2S","password":"123456"}#

注：123456为验证密码，只有先验证才可以发送其他指令

2、 保存模板文件或者打开一个文件

发送：{"F":"OpenDocPath_C2S","docPath":"D:\\code\\5.2.1\\Debug\\1.orzx"}#

3、 替换内容

发送：

{"F":"SetTextInfo_C2S","Doc":"1.orzx","PosIndex":0,"Text":"123","PosX":1,"PosY":1,"RA":45}#

注： 1、 “1.orzx”为已打开文档名

2、 0 表示文本在文档中图元列表中的序号

3、"Text":"123"表示序号为0的图形是文本时替换内容为123

4、"PosX":1，"PosY":1表示移动序号为0图形至坐标（1,1）位置。X、Y坐标需成对使用。

5、"RA":45 表示对图形进行旋转45°;

4、 标刻

发送：{"F":"DevsMark_C2S","devs":["设备名"]}#