欢迎使用精雕软件

JDPaint是精雕科技多年来一直致力研制开发的、具有自主版权的、功能强大的专业雕刻CAD/CAM软件。JDPaint是精雕CNC数控雕刻系统正常运作的保证，也是有效提高CNC雕刻系统使用效率和产品质量的源泉。

JDPaint专业雕刻软件经过多年的发展完善，功能日趋丰富强大，不仅突破了如曲面浮雕、等量切削等多项关键雕刻设计及加工技术，也充分保证了软件产品的易用性和实用性，极大地增强了精雕CNC雕刻机的加工能力和对雕刻领域多样性的适应能力。在应用领域上，JDPaint软件已经彻底突破了适合标牌、广告、建筑模型等较为传统的雕刻应用范畴，在技术门槛更高的工业雕刻领域，如滴塑模、高频模、小五金、眼镜模、紫铜电极等制作业，表现同样出色，成为国内最优秀的雕刻软件。

目前，JDPaint已由较为单一的雕刻设计加工软件，逐步走向面向CNC产品加工的一整套解决方案。

产品服务:

精雕科技网址 www.jingdiao.com

问题反馈E-mail： soft@jingdiao.com

软件开发部电话：010-60803959, 010-60803960

精雕科技总机： 010-60801188

销售热线：010-51922006/7　　E-mail：market@jingdiao.com


JDPaint 5

JDPaint 5.0 新增功能

JDPaint5.0软件是精雕科技有限公司最新开发的专业雕刻CAD/CAM软件，它继承了精雕软件JDPaint4.0易学好用的特色，同时大范围的扩展了刀具路经、曲面造型、浮雕设计等方面的功能。

JDPaint V5.0升级历史：

JDPaint V5.18升级说明

JDPaint V5.16升级说明

JDPaint V5.14升级说明

JDPaint V5.13升级说明

与JDPaint V4.0 相比较，JDPaint V5.0 新增了以下功能：

曲面造型新增功能

浮雕设计新增功能

刀具路径新增功能


JDPaint 5.13 升级说明

JDPaint 5.13于2004年3月16日升级。升级后的软件具有以下特点：

一、刀具路径功能

1． 修改的错误包括：

a. 修正5.12版本在计算平行截线、等高线路径时出现的错误；

b. 修正锥度牛鼻刀、牛鼻刀在计算投影路径、投影加深粗加工路径时的错误；

c. 修正提取轮廓组合的分组错误；

d. 修正刀具库不能保存的错误;

2． 新增的功能包括：

a. 改进材料表示方式，支持最大去除量等参数；

b. 改进曲面边界方式，支持自动向内、自动向外半径补偿；

c. 改进曲面加工范围，支持自动提取曲面高度；

d. 改进路径分析功能，支持余量设置、过切点统计；

e. 改进区域粗加工的边界方式，允许关闭半径补偿；

f. 增加路径颜色的修改功能；

二、几何曲面造型

1. 新增的功能包括：

a. 可根据当前文件名对自动备份文件进行命名, 同时打开多个文件时自动备份文件不会相互覆盖；

b. 可以捕捉到曲线延伸的穿插点；

c. 能兼容JDPaint 5.04以前版本的几何曲面设计文件；

d. 新增正交直线(水平线/竖直线)功能；

e. 新增曲线倒尖角功能；

f. 增强空间曲线点延伸、点打断、点裁剪功能；

g. 增强空间曲线的二维变换功能；

h. STL文件可读入到2D环境功能中；

i. 尺寸标注文字可以设置字体；

2. 修改错误:

a． 改正UCS偏移旋转中的错误；

b． 改正有些直纹面镜象的错误；

c． 改正有些曲线不能进行多线修剪的错误；

d． 改正曲线不能按长度等分的错误；

e． 改正测量两点距离时第二点不能捕捉垂足点的错误；

f． 改正曲线扫掠功能中的错误；

g． 改正转为非裁剪面功能中的错误；

h． 改正三面倒圆角中的错误；

i． 改正旋转扫掠中的错误；

j． 改正双向蒙皮中的错误；


JDPaint 5.14 升级说明

JDPaint 5.14于2004年4月15日升级。本次升级以修改JDPaint5.13版本的错误为主，修改的错误包括：

一、刀具路径功能

1. 修改输入NC时刀具编号错误；

2. 修改平底刀计算投影路径时可能出现的扎刀现象；

3. 修改平底刀计算平行截线路径时可能出现的扎刀现象；

4. 修改陡峭曲面计算等高路径、分层区域粗加工路径时可能出现的过切现象；

5. 修改投影清根路径可能出现的过切现象；

6. 路径编辑后重算视图包围盒；

7. 添加路径的2d平移、旋转、镜像；

8. 修改非俯视图加工面出现的路径裁减错误；

9. 修改路径旋转后的出现的裁减错误；

10.路径编辑后添加修改标记；

11.修改复杂边界线加工时的死机现象；

12.修改复杂曲面加工时的掉角现象；

13.修改路径高度裁剪后结果没有保留的错误；

14.修改平行截线平坦面加工中的遇到直侧面抬刀的缺陷；

15.修改单线雕刻分层不抬刀的错误；

16.修改隐藏曲面添加刀具路径时出现的曲面高度不准确的现象；

17.修改开槽环切时出现的直接下刀的现象；

18.修改环切并清角路径可能出现的过切现象；

19.修改JDSimu不能读取ENG5X格式加工数据的错误；

20.取消JDSimu的加密设置，用户可以在控制计算机上安装JDSimu。

21.修改计算灰度图片路径时可能出现的图片错位、图片被修改、计算死机的错误，

二、几何曲面造型

1. 纠正3D环境中计算圆弧包围盒尺寸不准确；

2. 修改图像扫描功能使用后，插件失效的错误；

3. 修改显示精度低于0.01时系统可能出现的不稳定现象；


JDPaint 5.15 升级说明

JDPaint 5.15于2004年5月16日发布，本版本是测试版。升级后的软件具有以下特点：

一、JDPaint系统功能

1. 提供菜单命令快捷键机制，按F4键（或者同时按下鼠标左右键）弹出快捷菜单，用户可以自定义快捷菜单命令；

2. 按Tab键+Ctrl键或者Shift+1键实现节点编辑工具与曲线编修工具之间的快捷切换。

3. 能兼容JDPaint 2.0、JDPaint 3.0、JDPaint 4.0文件的读取。

4. DXF接口读入建筑图形遇到大尺寸文件时进行提示，给出建议输入比例

5. 提供软件在线帮助；所有命令在执行期间，按F1键可弹出帮助信息。

二、 刀具路径功能部分

1． 增加了JDPaint4.0的路径计算界面。

该版本在选择工具界面下增加了JDPaint4.0的“钻孔雕刻、单线雕刻、轮廓切割、区域雕刻、曲面雕刻、投影雕刻、图片雕刻”菜单，兼容现有客户的使用习惯。

2． 提高了投影路径的计算速度。

该版本优化了投影的计算方法，路径投影的速度提高了50%~100%，同时径向放射走刀路径的计算速度也得到了相应的提高。

3． 改进了计算下刀路径时可能存在的不安全性。

使用下刀路径计算失败时，可以采用"缩短下刀长度方式"再计算。如果再计算算失败后,系统自动采用"沿轮廓下刀方式"，从而避免小区域出现扎刀现象。

4． 提高曲面精加工路径的质量

该版本优化处理的曲面的外部边界、内部边界等，在边界过渡位置的刀具路径较以前的版本更加光滑，特别是在平底刀、牛鼻刀、锥刀表现较为明显。

5． 在路径分析和干涉检查中扩展了毛坯面的生成方式，将最初的比较区域扩展为三种方式，即长方体形状毛坯、用精加工刀具生成毛坯和选择毛坯曲面三种方式。该扩展特别适用于对已部分加工后的工件进一步加工时对路径进行干涉检查。

6. 修改了路径连接功能，可以对整体路径或者单条路径进行连接，有三种连接方式：局部高度连接、安全高度连接和沿着曲面连接。在连接的时候引入了干涉检查模型，提高连接的可靠性。

三、几何曲面造型部分

改进命令交互方式

SURFMILL系统3D环境中带有导航条的命令的交互方式作了较大修改。

1. 完善辅助工具命令，主要有：拾取工具，点工具，方向工具，斜率工具，平面工具和轴线工具；

2. 将轴线，平面，方向的定义作为一个拾取步骤，并在导航条上用一个按钮表示，按钮前用一个图标表示该拾取步骤是否已成功进行。

3. 命令中一些经常需要输入的参数（例如“等距面”中的等距距离，“曲面流线”中的流线参数。“曲面倒角”中的倒角半径等）也定义为一个输入步骤。

4. 命令流程定义为鼠标右键进入下一个拾取步骤，最后一步点击右键弹出右键菜单，由用户确定命令结束方式。

5. 为命令中的拾取步骤和参数选项增加快捷键

6. 当一个命令有两个以上拾取步骤时，通过不同颜色将其对应的拾取对象区分开

SURFMILL系统功能改进

新增了一些功能，对原有功能进行了巩固和稳定。一些命令重新组合或拆分，使功能结构更为清晰合理。

环境功能

1. 曲面线框显示条数可修改；可重建模型的显示模型；

2. 图形显示\隐藏切换；

3. 修改UCS创建与编辑中的错误，并改进其交互方式；

4. 增加视角定义以及视角管理功能；

5. 增加系统当前状态提示；

6. 增强系统对象拾取过滤器；

7. 增加曲面构建，曲面编辑，曲面上线工具条

曲线绘制功能

8. 增强直线、圆弧绘制功能，支持组合曲线操作；

9. 增强倒角、修剪、打断、延伸功能，支持组合曲线编辑；

10. 增强曲线组合功能：（1）可转为样条曲线；（2）可进行光顺处理

11. 增强曲线投影功能：可投影到平面；

12. 将“曲线投影”细化拆分为“吸附到面”与“投影到面”两个功能：

13. 增强等距功能，支持组合曲线编辑；

14. 完善区域等距功能

15. 增强曲线毗连功能，可转为组合曲线或者转为样条曲线

16. 增加“法向等距”功能，可以将曲面上线沿曲面的法向进行等距

17. 增加“曲面平面交线”功能

图形变换功能

18. 改进2D变换功能，使图形可分别在当前坐标系的三视图平面上进行变换操作；

19. 修改3D镜象中的错误

20. 改进3D变换功能交互操作，提供命令快捷机制；

21. 新增图形翻转功能

22. 增强二维图形转三维图形功能，提供多种转换选项

曲面绘制功能

23. 直纹面增加“两轮廓”和“轮廓+点”两种生成方式。对组合截面线可以自动调整方向和起始段，避免生成扭曲的曲面。并对组合截面线段数不相等的情况作了处理。

24. 双向蒙皮功能的增强与稳定

25. 扫掠曲面功能的稳定与增强，改进扫掠曲面交互；

a). 扫掠面功能进行了重新整理和组织，将六个子功能合并为“单轨扫掠”和“双轨扫掠”两个菜单入口。

b). 增强“自动调向”功能，自动调整轨迹线和截面线的方向；

c). 增强“双轨扫掠”中的“点+轨迹线”方式。

d). 修改了扫掠曲面功能中的一些错误

26. 曲面裁剪功能的稳定与增强

a). 改进并增强曲面裁剪功能，增加多种选项。所有裁剪功能增加“快速裁剪”方式，根据拾取曲面的位置确定曲面片的取舍。对于组合面，拾取其中任意一张曲面，即可确定组合面所有曲面的取舍情况。

b). 对裁剪功能中“拾取裁剪域”方式的交互界面进行了简化。

c). 增加“平面裁剪”曲面功能

d). 将“线面裁剪”细化拆分为“投影裁剪”和“吸附裁剪”两个功能

e).“流线分割”扩充为“流线裁剪”，可以直接利用流线进行裁剪

f).“流线分割”和“曲面流线”增加“UV双向”选项

g). 加强对图层的支持，即使图形编辑后与原始图形落在同一个图层内。

27. 曲面倒角功能与曲面等距的稳定与增强，简化了曲线反向操作

a). 用鼠标点击已选中曲面即可对其进行反向，无需在列表框中进行。

b). 还可以对相邻曲面进行统一反向，也就是点中其中任意一张曲面，所有与之相邻的曲面都将方向。

28. 多面拼接功能的稳定与增强

29. 改进组合曲面功能。“曲面组合”改为只有相邻的曲面才允许组合。组合时自动判断曲面是否相邻，将相邻曲面归为一组并将其曲面方向自动调整为一致。

四、浮雕造型部分

艺术曲面部分:

1. 增加了“OBJ”文件的输入接口，命令位置“艺术曲面--标准曲面--读取Obj文件”。Obj文件是多边形模型的常用的格式之一，如Poser 5.0的人体/动物库是以OBJ文件存储的。

2. 增加了“矩形网格分割”及“同源矩形网格合并” 命令，命令位置“艺术曲面--修剪--矩形网格分割/同源矩形网格合并”。矩形网格分割及合并可无损分割及合并矩形网格。对于超大型网格曲面（顶点数300万—2000万）可利用无损分割命令把网格曲面分为多个小的矩形网格，然后选择一个小的矩形网格（单模型整体操作模式）进入虚拟雕塑操作；或选择多个小的矩形网格（多模型多分辨率操作模式）进入虚拟雕塑操作。各小矩形网格修改完毕后，可用“同源矩形网格合并” 命令把小矩形网格无损合并，然后重新无损分割后修补原小矩形网格曲面的边界接合处。利用无损分割及合并技术，可处理超大型浮雕壁画。矩形网格分割命令亦可用分割矩形网格以加快路径计算。

3. 增加了“调整网格曲面方位”命令，命令位置“艺术曲面--标准曲面--调整网格曲面方位”。调整网格曲面方位命令把网格曲面的三点所构成的平面转置成水平状态，并移动到XOY平面上，常用于测量数据处理。

4. 矩形网格（大型网格曲面）在着色状态的显示速度得到了极大的提高。

5. 所有命令在执行期间，按F1键可弹出帮助信息。

虚拟雕塑部分：

1．引入了“参考雕塑模型”的概念，虚拟雕塑环境同时只能存在一个工作雕塑模型，可有零个或多个参考雕塑模型，工作雕塑模型及参考雕塑模型之间可相互转换。

2．增加了二种操作模式“单模型局部操作模式”及“多模型多分辨率操作模式”，加上原有的“单模型整体操作模式”，系统有三种操作模式。

3．增加了“重置雕塑模型”，“设定操作范围”，“操作整个模型” 命令，修改了“截取模型” 命令以实现系统的三种操作模式。

4．几何曲面命令独立出来组成了一组工具—“几何工具”，并增加了七个命令“绘制截面线”，“Z向移动曲线”，“旋转曲线”，“平面”，“拉伸面”，“旋转曲面”，“插值曲面”。在5.15以后的版本中，“几何工具”的功能将得到较大的加强。

5．增加了“平坦面填色” 命令。

6．修定了说明书。并增加了测量数据编修及利用外部资源造型等文字材料。

7. 所有命令在执行期间，按F1键可弹出帮助信息。


JDPaint 5.16 升级说明

JDPaint 5.16于2004年6月16日发布，本版本是正式版。和JDPaint5.14比较，升级后的软件具有以下特点：

一、JDPaint系统功能

1. 提供菜单命令快捷键机制，按F4键（或者同时按下鼠标左右键）弹出快捷菜单，用户可以自定义快捷菜单命令；

2. 在节点编辑状态，按Q键实现节点编辑工具与曲线编修工具之间的快捷切换。

3. 能兼容JDPaint 2.0、JDPaint 3.0、JDPaint 4.0文件的读取。

4. DXF接口读入建筑图形遇到大尺寸文件时进行提示，给出建议输入比例

5. IGES输入能支持平面单元,部分支持143裁剪曲面。

6. 修改 IGES 颜色输出的错误（314）,否则其他软件接收时会报错;

7. 修正曲面显示时出现破洞的现象。

8. 修改平面环境下绘制线宽<2.0的双线时出现的曲线变形现象。

9. 修正二维环境打印错误。

10. 提供软件在线帮助；所有命令在执行期间，按F1键可弹出帮助信息。

二、 刀具路径功能部分

1． 增加了JDPaint4.0的路径计算界面。

该版本在选择工具界面下增加了JDPaint4.0的“钻孔雕刻、单线雕刻、轮廓切割、区域雕刻、曲面雕刻、投影雕刻、图片雕刻”菜单，兼容现有客户的使用习惯。

2． 提高了投影路径的计算速度。

该版本优化了投影的计算方法，路径投影的速度提高了50%~100%，同时径向放射走刀路径的计算速度也得到了相应的提高。

3． 改进了计算下刀路径时可能存在的不安全性。

使用下刀路径计算失败时，可以采用"缩短下刀长度方式"再计算。如果再计算失败后,系统自动采用"沿轮廓下刀方式"，从而避免小区域出现扎刀现象。

4． 提高曲面精加工路径的质量

该版本优化处理的曲面的外部边界、内部边界等，在边界过渡位置的刀具路径较以前的版本更加光滑，特别是在平底刀、牛鼻刀、锥刀表现较为明显。

5． 在路径分析和干涉检查中扩展了毛坯面的生成方式，将最初的比较区域扩展为三种方式，即长方体形状毛坯、用精加工刀具生成毛坯和选择毛坯曲面三种方式。

  该扩展特别适用于对已部分加工后的工件进一步加工时对路径进行干涉检查。

6. 修改了路径连接功能，可以对整体路径或者单条路径进行连接，有三种连接方式：局部高度连接、安全高度连接和沿着曲面连接。

在连接的时候引入了干涉检查模型，提高连接的可靠性。

7. 路径模板的编辑增加了对雕刻范围的整体编辑。

8. 修正读取NC钻孔路径时出现的高度错误。

9. 提高了分层区域粗雕刻中毛坯模式的计算精度，减少空跑路径；修改了有表面余量的时候的边界补偿值。

10. 修改在路径编辑时候，对螺旋线的处理产生的错误。

11. 在所有加工命令中或在与加工命令有关的所有对话框中，按下F1键，都能得到和该命令或对话框中的当前状态参数相关的帮助。

三、几何曲面造型部分

SURFMILL系统3D环境中带有导航条的命令的交互方式作了较大修改。

1. 完善辅助工具命令，主要有：拾取工具，点工具，方向工具，斜率工具，平面工具和轴线工具；

2. 将轴线，平面，方向的定义作为一个拾取步骤，并在导航条上用一个按钮表示，按钮前用一个图标表示该拾取步骤是否已成功进行。

3. 命令中一些经常需要输入的参数（例如“等距面”中的等距距离，“曲面流线”中的流线参数。“曲面倒角”中的倒角半径等）也定义为一个输入步骤。

4. 命令流程定义为鼠标右键进入下一个拾取步骤，最后一步点击右键弹出右键菜单，由用户确定命令结束方式。

5. 为命令中的拾取步骤和参数选项增加快捷键

6. 当一个命令有两个以上拾取步骤时，通过不同颜色将其对应的拾取对象区分开

SURFMILL系统功能改进

新增了一些功能，对原有功能进行了巩固和稳定。一些命令重新组合或拆分，使功能结构更为清晰合理。

环境功能

1. 曲面线框显示条数可修改；可重建模型的显示模型；

2. 图形显示\隐藏切换；

3. 修改UCS创建与编辑中的错误，并改进其交互方式；

4. 增加视角定义以及视角管理功能；

5. 增加系统当前状态提示；

6. 增强系统对象拾取过滤器；

7. 增加曲面构建，曲面编辑，曲面上线工具条

曲线绘制功能

8. 增强直线、圆弧绘制功能，支持组合曲线操作；

9. 增强倒角、修剪、打断、延伸功能，支持组合曲线编辑；

10. 增强曲线组合功能：（1）可转为样条曲线；（2）可进行光顺处理

11. 增强曲线投影功能：可投影到平面和网格面；将投影线在可见性转折点处断开；

12. 将“曲线投影”细化拆分为“吸附到面”与“投影到面”两个功能：

13. 增强等距功能，支持组合曲线编辑；

14. 完善区域等距功能

15. 增强曲线毗连功能，可转为组合曲线或者转为样条曲线

16. 增加“法向等距”功能，可以将曲面上线沿曲面的法向进行等距

17. 增加“曲面平面交线”功能

图形变换功能

18. 改进2D变换功能，使图形可分别在当前坐标系的三视图平面上进行变换操作；

19. 修改3D镜象中的错误

20. 改进3D变换功能交互操作，提供命令快捷机制；

21. 新增图形翻转功能

22. 增强二维图形转三维图形功能，提供多种转换选项

曲面绘制功能

23. 直纹面增加“两轮廓”和“轮廓+点”两种生成方式。对组合截面线可以自动调整方向和起始段，避免生成扭曲的曲面。并对组合截面线段数不相等的情况作了处理。

24. 双向蒙皮功能的增强与稳定，支持闭合蒙皮曲面，自动调整截面线起点，自动调整边界切矢。

25. 扫掠曲面功能的稳定与增强，改进扫掠曲面交互；

a). 扫掠面功能进行了重新整理和组织，将六个子功能合并为“单轨扫掠”和“双轨扫掠”两个菜单入口。

b). 增强“自动调向”功能，自动调整轨迹线和截面线的方向；

c). 增强“双轨扫掠”中的“点+轨迹线”方式。

d). 修改了扫掠曲面功能中的一些错误

26. 曲面裁剪功能的稳定与增强

a). 改进并增强曲面裁剪功能，增加多种选项。所有裁剪功能增加“快速裁剪”方式，根据拾取曲面的位置确定曲面片的取舍。对于组合面，拾取其中任意一张曲面，即可确定组合面所有曲面的取舍情况。

b). 对裁剪功能中“拾取裁剪域”方式的交互界面进行了简化。

c). 增加“平面裁剪”曲面功能

d). 将“线面裁剪”细化拆分为“投影裁剪”和“吸附裁剪”两个功能

e).“流线分割”扩充为“流线裁剪”，可以直接利用流线进行裁剪

f).“流线分割”和“曲面流线”增加“UV双向”选项

g). 加强对图层的支持，即使图形编辑后与原始图形落在同一个图层内。

27. 曲面倒角功能与曲面等距的稳定与增强，简化了曲面反向操作

a). 用鼠标点击已选中曲面即可对其进行反向，无需在列表框中进行。

b). 还可以对相邻曲面进行统一反向，也就是点中其中任意一张曲面，所有与之相邻的曲面都将方向。

28. “两面拼接”功能增加自动调整方向和闭合边界起点功能

29. 多面拼接功能的稳定与增强

30. 改进组合曲面功能。“曲面组合”改为只有相邻的曲面才允许组合。组合时自动判断曲面是否相邻，将相邻曲面归为一组并将其曲面方向自动调整为一致。

31. 增加了“坏面检测”功能,将曲面法线方向突变的曲面用颜色标记,方便用户在计算刀具路径时能差错。

32. 增加“拉伸到平面”功能

33. 增加“鞋模放码”功能

四、浮雕造型部分

艺术曲面部分:

1. 增加了“OBJ”文件的输入接口，命令位置“艺术曲面--标准曲面--读取Obj文件”。Obj文件是多边形模型的常用的格式之一，如Poser 5.0的人体/动物库是以OBJ文件存储的。

2. 增加了“矩形网格分割”及“同源矩形网格合并” 命令，命令位置“艺术曲面--修剪--矩形网格分割/同源矩形网格合并”。矩形网格分割及合并可无损分割及合并矩形网格。对于超大型网格曲面（顶点数300万—2000万）可利用无损分割命令把网格曲面分为多个小的矩形网格，然后选择一个小的矩形网格（单模型整体操作模式）进入虚拟雕塑操作；或选择多个小的矩形网格（多模型多分辨率操作模式）进入虚拟雕塑操作。各小矩形网格修改完毕后，可用“同源矩形网格合并” 命令把小矩形网格无损合并，然后重新无损分割后修补原小矩形网格曲面的边界接合处。利用无损分割及合并技术，可处理超大型浮雕壁画。矩形网格分割命令亦可用分割矩形网格以加快路径计算。

3. 增加了“调整网格曲面方位”命令，命令位置“艺术曲面--标准曲面--调整网格曲面方位”。调整网格曲面方位命令把网格曲面的三点所构成的平面转置成水平状态，并移动到XOY平面上，常用于测量数据处理。

4. 矩形网格（大型网格曲面）在着色状态的显示速度得到了极大的提高。

5. 修正网格显示模式下，矩形网格,拓扑矩形网格，单向周期网格不能显示的错误。

6. 网格优化时，可选择删除零平面上的多边形。

7. 清除网格拼合时的一个错误。

8. 改进了随手绘制命令。

虚拟雕塑部分：

1. 新增了“参考雕塑模型”的概念，虚拟雕塑环境同时只能存在一个工作雕塑模型，可有零个或多个参考雕塑模型，工作雕塑模型及参考雕塑模型之间可相互转换。

2. 增加了二种操作模式“单模型局部操作模式”及“多模型多分辨率操作模式”，加上原有的“单模型整体操作模式”，系统有三种操作模式。

3. 增加了“重置雕塑模型”，“设定操作范围”，“操作整个模型” 命令，修改了“截取模型” 命令以实现系统的三种操作模式。

4. 几何曲面命令独立出来组成了一组工具—“几何工具”，并增加了七个命令“绘制截面线”，“Z向移动曲线”，“旋转曲线”，“平面”，“拉伸面”，“旋转曲面”，“插值曲面”。在5.16以后的版本中，“几何工具”的功能将得到较大的加强。

5. 增加了“平坦面填色” 命令。

6. 并增加了测量数据编修及利用外部资源造型等文字材料。

7. "导动堆料/去料----累加效果"结果不均的问题----已修改。

8. 加载图象体素, 如果改变尺寸后,尺寸范围内的顶点数大于40万,出错----已修改。

9. 第一次进入JDVirs, 没有颜色的参考网格曲面不能显示----已修改。

10. 构造直纹面可选3D点。

11. 去掉了"几何--绘制截面曲线"命令。

12. 增加了"几何--平面上绘制曲线"命令，可在空间任何平面上绘制3D点，直线,圆，样条曲线。

13. 在JDVirs下，用'e'键隐藏图形时，不允许选择图形。

14. 整理并充实了安装盘中的随机图例, 增加了练习素材库。

15. 增加了"虚拟雕塑造型方法之四----利用几何工具造型"，"镶钻孔的构造"，"鹿蹄的构造"等文字材料。


JDP5.18升级说明

JDPaint 5.18 升级说明

JDPaint 5.18于2004年7月9日发布，本版本是正式版。和JDPaint5.16比较，升级后的软件具有以下特点：

一、JDPaint设计功能部分

1. 修改封套变形节点编辑的拾取错误；

2. 修改节点编修工具中，节点编辑和修编工具相互进行切换的快捷键为“Q”字母键；

3. 修改点投影到曲面功能的错误；

4. 修改输出bmp图像时的错误；

5. 3D环境下可以输入DXF文件中的图层信息，2D环境下输入DXF文件增加自动居中选项

二、刀具路径功能部分

1. 在输入NC圆弧时,镜像、旋转变换存在错误，现已修改;

2. JDPaint5.16版本修改锥刀具参数时出现的角度错误;

3. 修改JDPaint5.16在计算网格路径时出现的错误;

4. 修改4.0路径计算功能中的钻孔路径不能投影的错误;

5. 修改执行重算、删除等操作时，操作树自动展开的错误;

6. 修改200个以上环执行"三维清角 +　忽略外边框"时出现的非法操作;

7. 在以前的版本中，在“选择工具”下输出刀具路径时，如果使用点选方式选择刀具路径，路径的输出次序总是按照选择的次序输出。在JDPaint5.18中将改正为按照原始的次序输出，而与选择次序无关。

三、几何曲面造型部分

1. 增强曲面单独渲染功能，可选择指定的曲面对象按指定显示模式显示;

2. 修改单轨扫掠面中的错误, 加强单轨扫掠面的精度处理。

3. 拉伸面可以在曲线所在平面内进行拉伸

4. 快速裁剪时可以通过点击一选中曲面重设保留区域，修正组合面保留区域提示点的显示错误

5. 修正组合面自动调向的一些错误

6. 曲线吸附和曲线裁剪速度有所加快

7. 将投影曲线在可见转折点处断开

四、艺术曲面造型造型部分

1. 改正网格曲面重构(高点+外环,低点+外环,中点+外环)的一个错误.

2. 改正平面修剪网格曲面时不能输入负数的错误.

五、虚拟雕塑部分

1. 增加了18个二键快捷键（Shift+'Q/W/E/R/T/Y', Shift+'A/S/D/F/G/H', Shift+'Z/X/C/V/B/ N')，参见命令菜单后的提示.

2. 导动时可选结合对象,效果如多选单个对象.

3. 帮助文档中增加了"虚拟雕塑作品选集"

4. Z向移动曲线可处理2d/3d点.

5. 导动堆去料命令,颜色浮雕命令可记忆参数.

6. 增加了一个功能键'G'可隐藏/显示模型颜色.

7. 移去了"雕塑工具箱"及"颜色工具箱"命令.

8. 在有关命令中,'2'键可改变颜色模板的选项; '3'键可改变拼合方式的选项;'4'键可改变高度模式的选项.

9. 在堆去料/导动堆去料命令中, '5'键可把半衰直径置为0.01mm 或 直径的25% 或 直径的150%。


浮雕设计新增功能

JDPaint V5.0在浮雕设计方面新增功能包括:

1. 新增浮雕生成和编辑方式，进一步拓展了浮雕设计功能

2. 特色功能——虚拟浮雕

扩展和新增的浮雕生成和编辑方式

1) 浮雕生成方式的扩展，新增了单线浮雕、颜色浮雕等浮雕生成方式；

单线浮雕可把闭合的区域或不闭合、自交、互交的单线或文字转为浮雕，降低了生成浮雕的门坎及图形预处理的工作量。颜色浮雕可把由颜色定义的区域转换为浮雕曲面，省略了矢量化处理或描图的步骤。

2) 浮雕编辑方式的拓展，新增了点击编辑、几何浮雕等直观的浮雕编辑功能；

点击编辑包括冲压、追加等造型方法，其中冲压功能可把浮雕面上二维区域中的顶点置成所要求的高度；追加功能可把浮雕面的一部分顶点同时进行双向变形。几何浮雕借用了几何曲面的概念创建或编辑浮雕曲面，主要包括直纹面、延伸、扫掠、融接等功能。

3) 纹理功能的扩展，新增了数百种图像纹理单元；

利用JDPaint5.0中新增的图像纹理功能组以及随机所带的数百种图像纹理单元库，可以构造出各种各样的纹理图像，并可方便地转为浮雕曲面。利用“表面填充纹理”命令，可在浮雕模型表面叠加各种纹理。利用JDVirs模块中的涂抹纹理功能，可交互式在浮雕模型上涂抹三维几何纹理。结合柱面/锥面辊轮功能组，可构造出各种各样的无接缝的纹理辊轮。

4) 浮雕修剪功能的拓展，可以用二维区域等修剪浮雕；

JDPaint5.0中对浮雕曲面的编辑引入了修剪的概念，可以用二维区域、浮雕曲面、平面或浮雕曲面上的线来修剪浮雕曲面。浮雕修剪功能也可以结合拼合、冲压、追加等功能使用，从而保留精细浮雕的特色。

5) 空间曲线功能在浮雕造型中的拓展，增加了交线、投影线等曲线生成方式

可生成浮雕曲面之间、或平面与浮雕面之间的交线。浮雕曲面边界线可转为2D/3D曲线，可直接在浮雕曲面上画线，或把平面或空间曲线投影到浮雕曲面上。

6) 浮雕的整体编辑功能的拓展，增加了网格加密、细分、磨光等工具；

可对浮雕曲面网格进行加密、磨光或细分操作，亦可对其网格进行优化以减少数据量。网格可以重构，选择适当的网格划分，可把浮雕曲面转换为几何曲面。

特色功能----虚拟雕塑：

JDPaint5.0中新增的虚拟雕塑模块，提供了一个全新的交互式创建、编辑、修饰浮雕模型的环境，其主要功能特色如下：

1) 独立的设计环境,艺术造型过程简洁直观；

虚拟雕塑可以以平面图象、素描手稿或二维图形为起点, 创建三维模型。在三维环境中高保真的着色模型上，实时动态地创建、修改、修饰海量数据的多边形模型（多边形顶点通常在50万到400万之间）。多种显示模式任意切换，其中地图方式、套色方式、图象方式、形方式可以满足不同阶段的造型需求。造型支持擦除，取消/重做等辅助工具，使得虚拟雕塑的灵活性高于现实雕塑。

2) 多种浮雕直接叠加，浮雕造型的更加快捷；

虚拟雕塑环境保留了区域浮雕、单线浮雕、单线冲压、几何浮雕等传统的浮雕造型方式，同时采用直接拼合的方式编辑浮雕基面，浮雕生成效率更高。

3) 独特的点击编辑方式，包含了磨光、堆料、漂移等多种编辑工具

点击编辑方式包括堆料、擦除、磨光、漂移、透镜等编辑工具。这些工具的使用方式式分类似于图像编辑，同时又具有3D空间高度，操作过程实时现实，从而形成一种虚拟雕塑的艺术造型流程。

4) 颜色浮雕功能，颜色可以直接生成浮雕，也能限定其他操作的作用范围；

系统新增了涂色、擦色、并色的等编辑方法，颜色可以作为区域生成浮雕，也能限定点击编辑等操作的作用范围。

5) 局部变换功能，用户可以对局部的浮雕进行拉高、扭曲等细节变换；

通过颜色定义变换区域，可把模型的一部分定义为特征，对特征执行阵列，变换，单/双向变形，保存，重载等操作。

6) 浮雕层功能，流动层和固化层的方便浮雕设计的反复过程；

层概念的引入及层模型的实现为模型的创建及编辑提供了较大的便利。在虚拟雕塑环境中，雕塑模型是固化层及流动层叠加后的结果。所有操作都是在流动层或模型层（固化层及流动层叠加后得到的层）上进行的。

固化命令可以限定将编辑的结果便可把刷子经过处流动层顶点的高度置为零, 固化层顶点的高度等于其自身加上流动层对应顶点的高度。整体固化命令把雕塑模型烧结固化, 把流动层顶点的高度置为零。擦除命令把刷子经过处流动层顶点的高度置为零, 整体擦除命令把流动层所有顶点的高度置为零。


刀具路径新增功能

JDPaint V5.0刀具路径生成方面新增功能包括：

1． 提供了许多新的工具，进一步方便了刀具路径的计算

2． 新增了曲面残料补加工等雕刻加工方法

3． 特色雕刻加工功能

4． 拓展了雕刻加工功能

进一步方便了刀具路径的计算

1） 刀具路径操作树，刀具路径可以重算

路径操作数记录了刀具路径的创建次序、加工图形和路径参数，当修改局部图形或修改局部参数后，只要点击路径重算，刀具路径便自动更新。该功能特别适合于新模具或新材料的试加工。

2） 刀具路径模板，单个刀具路径参数可以定制

成熟的刀具路径参数可以被当作模板保留下来，不用每次修改路径参数，减少误操作，提高刀具路径计算速度。该功能特别适合于标识制作、文字切割、高频模制作等。

3） 刀具路经工艺，加工工艺可以保存成工艺过程

雕刻加工工艺一般包含了不同的图形分组、不同的雕刻方法和多把刀具。成熟的加工工艺可以被当作一种工艺流程保存成文件，类似的工件只要重新更新加工图形即可。该功能特别适合于工业模型制作、鞋底模型加工等。

4） 刀具路径向导，一步步引导用户生成刀具路径

雕刻路径向导共分选择雕刻图形、设定雕刻范围、选择雕刻刀具、选择雕刻材料、雕刻参数汇总五步，一步步引导用户生成初步的刀具路经。该功能特别适合初学者掌握刀具路径的生成过程。

5） 刀具路径模拟集成在设计环境

新的刀具路径模拟工具集成JDPaint5.0的设计环境中，用户不需要输出ENG文件，便可以模拟加工过程。该功能特别适合于新产品的试加工，刀具路径的模拟操作过程由以前的7步操作降低到现在的1步操作。

6） 浮雕、曲面路径的计算速度更快

100万点的浮雕计算速度由60分钟提高到10分钟左右，曲面路经的计算时间平均缩短70%；模型越复杂，提高速度的比例越高。该功能特别有助于提升烫金模、滴塑模、工业模型等加工领域。

新增的雕刻加工方法

1） 曲面残料补加工

曲面粗加工为了追求加工效率，往往采用较大的刀具和分层深度，它留在模型上的残料是很不均匀的。直接进行精加工或半精加工时，往往因为一些局部的残料导致加工过程无法正常进行。曲面残料补加工能根据粗加工参数自动计算残料区域，生成残料补加工的路径，从而保证了后续加工的顺利进行。

2） 残料投影清根

精加工完成后，待加工的残料主要集中在模型的边边角角，常规的精加工方法去除这些残料的效率很低而且效果也不理想。残料投影清根方法就是根据模型的边界曲线生成投影清根路经。

3） 旋转雕刻加工

异型旋转工件加工通常采用多面旋转定位加工，受夹具精度的影响，不同加工方向之间总是存在接痕。旋转雕刻加工采用转轴整体方式，生成自动封闭的旋转雕刻加工路径，杜绝了加工定位接痕。该功能特别适合于雕刻加工笔模电极、起子把电极等。

4） 成组平面加工

常规的平面加工需要选择加工边界，当模型的平面区域被分割成许许多多小平面片时，搜索这些边界十分耗时间，而成组平面加工可以自动搜索平面区域，生成无干涉的平面路径。该功能主要用于工业模型加工的平面精加工。

5） 毛坯识别功能

在模具加工中，雕刻加工经常配合其他的加工方法。雕刻加工的毛坯形状不再是一块规则的方料。如果采用常规的方法加工，必然造成许多的空切路经。毛坯识别功能可以识别已经加工完成的毛坯表面，在路径计算过程中自动过滤空切路径。目前，曲面分层粗加工和残料补加工都支持毛坯识别功能。

特色雕刻加工功能

1) 路径节点工具，用于路径节点的删除、添加和修改

曲面加工过程中，如果曲面存在缺陷，将可能引起刀具路径出现掉刀或过切现象。在传统的加工软件中，只能通过修补曲面校正错误。JDPaint5.0提供的路径节点工具可以象图形节点一样删除无效路径段。

2) 路径分析工具，用于检查刀具路径是否过切及其过切位置

刀具路径计算过程是一个容易出错的过程，图形选择错误、路径参数设置等都可能造成路径过切。路经分析工具将刀具路径的加工结果和设计模型比较，分析路径是否出现过切，以及过切位置，并用颜色显示过切量的大小。

3) 刀杆干涉检查，用于检查刀具刃长、螺母干涉、电机干涉

在深型腔加工、大模具清根加工过程中，螺母尺寸、电机端面都可能引起干涉。新增的刀杆干涉检查可以根据加工模型和刀具路径的加工范围确定不同刀具的装卡长度和刀刃长度，为正确加工提供计算依据。

拓展的雕刻加工功能

1） 拓展了环切走刀方式，增加了折线连刀

环切走刀总是能保持顺铣或逆铣，是开槽式等量切削的主要走刀方式。相邻两环之间的连接路经通常用最短距离连接的，是双边切削路径，容易造成小刀具断刀现象。折线连刀有效的避免了双边切削，提高了刀具的使用寿命。

2） 拓展了分层方式，增加了拷贝分层

锥刀是雕刻加工的常用刀具，在常规分层加工时，如果实际刀具角度与理论刀具角度相差超过1度时，侧面就会留下明显的分层台阶，而拷贝分层可以消除刀具角度引起的分层台阶。

3） 拓展了三维清角功能，增加了清角补加工

清角补加工是提高三维清角效率的一种常用技巧，但它容易在内角处剩余残料。而新增的清角补加工功能可以根据上把刀具自动清除内角的残料。

4） 区域优先模式拓展到三维清角、残料补加工、曲面粗加工

区域优先模式可以缩短定位的长度，提高加工的效率。JDPaint5.0进一步拓展了区域优先模式的使用范围，平均雕刻加工效率可以提高10%~20%。

5） 下刀方式的拓展，曲面粗加工、轮廓切割、开槽等加工都可以使用多种下刀方式

合理的下刀方式可以提高刀具的耐用度，不同刀具、不同材料的下刀方式和下刀参数也存在区别。新的下刀方式提供了螺旋下刀、折线下刀、沿轮廓下刀（斜线下刀）、垂直下刀等下刀方式，并且增加了对表面预留和侧边预留控制，增加了多种路径计算失败处理方式。

6） 进刀方式的拓展，进刀位置、进刀长度可以自动设置

在轮廓切割中，为了避免在下刀位置留下疤痕，通常采用进刀方式将下刀位置移出轮廓边界。但是，如果进刀位置和进刀长度选择不当，往往会引起进刀路径与切割路径之间出现干涉。JDPaint5.0可以自动搜索进刀位置，也可以根据图形自动调整进刀路径的长度，从而更大可能的生成进刀路径。

7） 拓展了等高外形走刀，增加了加工次序、定界加工、连刀方式等控制

新的等高外形走刀路径可以加工任意角度的陡斜面，路径光滑，加工侧壁质量高。新增的从下向上走刀可以提高侧壁的加工质量和刀具耐用度。新增的定界加工可以用于局部区域的等高补加工；新增的圆弧连刀消除了相邻层之间连刀路径引起的连刀痕。

8） 拓展了路径过滤功能，自动删除重复切削路径

在曲面精加工中，在等高外形路径主要用于45度以上坡度的精加工，而平行截线路径主要用于45度以下坡度的精加工。当加工模型既有45度以上坡度的曲面，又有45度以下坡度的曲面时，经常采用等高外形路径加平行截线路径的混合加工方式，这时必然有部分路径属于重复加工，效率较低。JDPaint5.0引入了路径的自动过滤功能，在平行截线路径中删除陡峭部分的路径，而在等高外形路径中删除平坦部分的路径，从而可以将精加工效率提高10%左右。


曲面造型新增功能

JDPaint V5.0在三维几何曲面造型方面新增功能包括：

1． 完整的三维图形设计环境

2． 丰富的曲线绘制和编辑功能

3． 强大的曲面绘制和编辑功能

完整的三维图形设计环境

1) 新增了用户坐标系(UCS)与绘图平面，用户可以直接绘制空间曲线

在空间绘制圆等几何对象时，需要确定绘图平面，而用户坐标系可以将绘图平面固定在任何空间位置。在绘图过程中，用户还可以定义临时绘图平面，从而方便平行线、垂直线的绘制效率。

2) 新增了图层管理功能，提高了复杂模型的操作效率和方便性

当对象类型丰富，而且数量比较庞大时，图形的管理占用了不少的设计时间。而图层管理可以实现对象的分级管理，从而提高对象的操作效率。在几何曲面设计中，当曲面的个数超过1000个时，最好使用图层管理。

3) 对象属性拓展，提高了造型过程的直观性

JDPaint5.0拓展了对象的显示属性，用线型和线宽区分辅助线、中心线、剖面线、边界线等；用点的形状区分中心点、曲线点、重心等不同特征的点；用颜色区分加工面、毛坯面、分型面等不同作用的曲面。这些显示属性可以有效的提高对象操作的直观性。

4) 图形选择功能的拓展，提供了动态导航和图形过滤功能

JDPaint5.0的支持三维对象动态导航功能，当鼠标移动到对象附近时，对象自动变亮，再次点击鼠标，对象将被选中；用户可以使用对象类型、对象颜色等属性整体选择；在造型过程中，也支持对曲线的串链选择功能。

5) 拓展了图形的显示与隐藏功能，显示隐藏的效率更高

图形对象的显示与隐藏功能进一步加强，通过鼠标右键导航菜单的隐藏命令可隐藏当前被选对象；用户也可以通过类型、颜色等属性过滤显示或隐藏指定的图形对象。JDPaint 5.0提供了四种图形显示模式（线框模式、渲染模式、边界模式和网格模式），用户可在设计过程中直接观察到曲面图形的真实效果。

6) 支持对象的查询和测量，方便用户了解对象的个数、尺寸等几何信息

JDPaint5.0提供了多种查询工具，用于查询或测量距离、尺寸、半径、曲率半径等及何信息，用于判断设计的正确性以及刀具的最小尺寸。

7) 拓展了点捕捉功能，曲面点也可以被捕捉

点的捕捉方式包括了最近点、存在点、曲面点、路径节点捕捉功能；同时新增了图形特征点强制捕捉与自动捕捉选项；新增了图形特征点是否投影到当前绘图面选项。

8) 文件转换功能更加丰富，曲面对象可以输出

增强了IGES文件的输入与输出功能，数据接口更加稳定。同时也增强了DXF 3D、EPS、AI等文件的输入与输出功能。

丰富的曲线绘制和编辑功能

1) 曲线绘制功能的拓展，用户可以直接绘制空间曲线

用户可以通过用户坐标系绘制空间直线、圆弧、椭圆、样条、抛物线等空间曲线。同时提供了多种绘制方法，如角度线、两点线、垂线、三点弧、相切弧等，绘制效率更高。

2) 曲面曲线功能的拓展，用户可以提取或直接使用曲面的特征曲线

曲面边界曲线作为一种特殊的曲线类型，可以被直接拾取参与曲面构造和曲面编辑操作；同时用户可以生成投影曲线、曲面交线、曲面边界线、曲面流线、曲面分模线等特征曲线。

3) 曲线编辑功能的拓展，空间曲线可以打断等编辑操作

空间曲线可以象平面曲线一样实现倒角、延伸、等距、组合、打断、修剪、编修等操作。同时新增了曲线光顺功能，它能可按给定的允许偏差和边界约束条件对曲线进行光顺处理，使曲线更为光滑顺眼；新增了曲线毗连功能，它能将两条曲线（或者组合曲线）的指定端点按约束条件进行连接处理。

4) 新增的特色功能，包括图形聚中、曲线展平、曲线包裹等

新增了图形聚中功能，该功能主要应用于将整个模型对象平移到世界坐标系中的原点位置，它可以提高模型的整体平移的效率；曲线展平、曲线包裹功能主要空间曲线的按照特定的规律实现形状变换。

强大的曲面绘制和编辑功能

１) 曲面的绘制方式更加丰富，新增了平面等曲面绘制方法

JDPaint5.0的曲面绘制包括了简单的几何曲面如球面、柱面等，也包含了多种通过曲线生成曲面的方法，如边界平面、拉伸面、旋转面、放样面、扫掠面、管道面等。新增了变半径等距面，该功能按给定的等距方向对曲面的四个角点赋予不同的等距距离，生成与原始曲面距离平滑变化的曲面。

２) 曲面的编辑方式更加丰富，增加了曲面裁剪和倒角功能

曲面裁剪和曲面倒角是最常用的编辑方式，JDPaint5.0新增了多种曲面裁剪功能，包括线面裁剪、面面裁剪、流线裁剪等方式；新增了多种曲面倒角形式, 包括等半径倒角、变半径倒角、三面倒角、曲线曲面倒角方式。

３) 新增了曲面修补功能，包括曲面补洞、提取原始面、删除裁剪环等常用方法

设计模型与加工模型在一些局部细节上经常会出现冲突，修补设计模型以满足加工要求是加工之前必需完成的工作。JDPaint5.0的曲面修补功能提供了曲面补洞等多种修补方式，提高了曲面的修补效率。

４) 新增了曲面延伸、融接、光顺等高级编辑方法

通过曲面延伸功能可以提高曲面裁剪、曲面过渡对曲面尺寸的要求。而曲面光顺、曲面融接功能可以满足创意设计或逆向设计对曲面形状的要求。