欢迎使用精雕软件

JDPaint是精雕科技多年来一直致力研制开发的、具有自主版权的、功能强大的专业雕刻CAD/CAM软件。JDPaint是精雕CNC数控雕刻系统正常运作的保证，也是有效提高CNC雕刻系统使用效率和产品质量的源泉。

JDPaint专业雕刻软件经过多年的发展完善，功能日趋丰富强大，不仅突破了如曲面浮雕、等量切削等多项关键雕刻设计及加工技术，也充分保证了软件产品的易用性和实用性，极大地增强了精雕CNC雕刻机的加工能力和对雕刻领域多样性的适应能力。在应用领域上，JDPaint软件已经彻底突破了适合标牌、广告、建筑模型等较为传统的雕刻应用范畴，在技术门槛更高的工业雕刻领域，如滴塑模、高频模、小五金、眼镜模、紫铜电极等制作业，表现同样出色，成为国内最优秀的雕刻软件。

目前，JDPaint已由较为单一的雕刻设计加工软件，逐步走向面向CNC产品加工的一整套解决方案。

产品服务:

精雕科技网址 www.jingdiao.com

问题反馈E-mail： soft@jingdiao.com

软件开发部电话：010-60803959, 010-60803960

精雕科技总机： 010-60801188

销售热线：010-51922006/7　　E-mail：market@jingdiao.com


0 前言

前 言

自由曲面造型技术经过几十年的发展，理论上及系统的易用性方面日趋成熟，已成为现代制造业的基石。尽管如此，传统的自由曲面造型技术在人物，动植物，工仔模，饰品，手工艺品及雕塑品等的造型方面，虽不能说是无能为力，但至少可以说非常困难。造型手段的缺乏在某种程度上限制了这些行业数字化的进程。北京精雕科技有限公司于2003年推出的虚拟雕塑软件JDVirs 1.0将较好地解决二维半的人物，动植物，工仔模，饰品，手工艺品及雕塑品等的造型问题，为这些传统的手工艺行业带来数字化时代的东风。

去料谓之雕，堆料谓之塑，在电脑三维数字化模型上实施交互式堆去料等操作之过程谓之虚拟雕塑（Vir tual Sculpting）。JDVirs以现实雕塑为隐喻，其部分功能源于现实雕塑，但又常常高于现实雕塑。JDVirs吸取了图形/图象/曲面系统的精华,它利用图形/图象/曲面系统的概念及操作方法, 实时动态地创建, 修改, 修饰海量数据的三维几何模型, 非常适合构造尺寸要求不严, 形状复杂,二维半的艺术曲面。使用JDVirs完成的作品，可经上色处理之后存为图象，利用图象输出设备，如喷绘仪等输出，这样得到的图象立体层次感非常强，呼之欲出；或者可使用快速成型设备或CNC雕刻机单件或批量地加工出来，实现手工与自动化机器的完美结合。

JDVirs 1.0作为JDPaint软件产品家族中全新的一员，是JDPaint中艺术浮雕曲面造型功能和技术的一个重大的发展和延伸。JDVirs 1.0的主要功能特色如下：

1. 以二维图形, 平面图象或素描手稿为起点, 创建三维模型。

2. 在三维环境中高保真的着色模型上，实时动态地创建, 修改, 修饰海量数据的多边形模型（多边形顶点通常在50万到1000万之间）。

3. 多种显示模式（地图方式/灰度方式/图象方式/图形方式）满足造型过程中不同阶段的需求。地图方式把高度的细微差异以人眼易于识别的颜色形式表现出来。图形方式时可把图象套色于雕塑模型上显示，可用于描图，检查模型与原始图象区域边缘匹配的程度及出效果图。

4. 三种操作模式可用于三种不同的场合, 单模型整体操作模式可用于顶点数较少的模型, 单模型局部操作模式可用于顶点数较多的模型或机器速度较慢的场合, 多模型多分辨率操作模式可用于模型一个或多个局部要求比较精细的场合。

5. 层概念的引入及层模型的实现方便了模型的构造过程。

6. 堆料，去料，擦除，磨光等操作模拟现实雕塑过程，简单直观。

7. 颜色模板，限高保低，高度模式，擦除，取消/重做等辅助工具，使得虚拟雕塑在某些方面高于现实雕塑。

8. 灵活的浮雕生成方式（区域浮雕/单线浮雕/颜色浮雕/单线冲压/位图转浮雕/图象浮雕/融接）为造型过程中堆去大料提供方便。

9. 几何曲面的造型方法亦被有机地结合进来（插值/旋转/扫掠/直纹/延伸/融接）。

10. 漂移，螺旋，凸透镜/凹透镜及各种纹理效果等常见于高端图象软件的功能，在JDVirs中得到了很好的应用。

11. 可把模型的一部分定义为特征，对特征执行阵列，变换，单/双向变形，保存，重载等操作。

12. 导动工具可控制刷子沿着轨迹运动, 并自动相应地改变模型。可实现虚拟投影雕刻及虚拟投影塑形。

13. 直接在模型上涂色及各种填色方法为模型上色提供了便利。

14. 用户可自由扩充的纹理库，库中丰富的纹理资源及实时动态在模型上涂抹三维纹理功能，为修饰模型提供了便利。

本书共分十一章，各章主要内容如下：

第一章 概述部分，简单介绍了虚拟浮雕软件，并讲解了软件中的基本概念，包括矩形网格、层模型、操作模式、高斯分布、限高保低、刷子、拼合方式等概念。

第二章 介绍了模型工具的使用方法，包括新建模型、位图转浮雕、存为位图、图象浮雕等内容。

第三章 介绍了橡皮工具的使用方法，包括撤消或重做、擦除或整体擦除、固化修改等命令功能。

第四章 介绍了雕塑工具的使用方法，包括堆料、去料、抖动、区域浮雕、颜色浮雕、单线浮雕功能的使用方法。

第五章 介绍了几何工具的使用方法，包括扫掠面、直纹面、延伸、融接功能的使用方法

第六章 介绍了导动工具的使用方法，包括导动堆料/去料、导动冲压、导动抖动、导动擦除、导动涂色、导动磨光等功能。

第七章 介绍了特征工具的使用方法，包括对所选特征进行移动、缩放、旋转、对称、变形以及追加造型、阵列、保存特征的讲解。

第八章 介绍了变形工具的使用方法，包括推移、推拉、凸透镜、凹透镜、螺旋、漂移等功能。

第九章 介绍了颜色工具的使用方法，包括涂抹颜色、单线填色、种子填色、区域填色、当前颜色等命令。

第十章 介绍了效果工具的使用方法，包括磨光、整体磨光、糙化、拼贴画、马赛克、墙砖、过程纹理、印象派、雨中池塘、纹理填充等功能。

第十一章 介绍了选项菜单中的几个命令，包括显示方式、限高保低、模型属性等功能。


1.1 简介

去料谓之雕，堆料谓之塑，在电脑三维数字化模型上实施交互式堆/去料等操作之过程谓之虚拟雕塑（Virtual Sculpting）。虚拟雕塑是图形/图象/曲面系统的有机结合，它利用图形/图象/曲面系统的操作方法，交互式创建，修改，修饰海量数据的三维几何模型，非常适合构造尺寸要求不严，形状复杂，二维半的艺术曲面，如图1-1。使用虚拟雕塑完成的作品，可经上色处理之后存为图象，利用图象输出设备，如喷绘仪等输出，这样得到的图象立体层次感非常强，呼之欲出；或者可使用快速成型设备或CNC电脑雕刻机单件或批量地雕刻出来，实现手工与机器的完美结合。

图1-1 模型


1.2 基本概念


1.2.1 矩形网格

按照组成网格曲面的多边形分类，网格曲面可分为如下几类：

普通网格 | 由四边形及三角形组成。
矩形网格 | 由M×N个按顺序水平放置的矩形组成。
拓扑矩形网格 | 由M×N个按顺序放置的四边形组成，如放样等生成的网格。
单向周期网格 | 拓扑矩形网格的一个特例，常用于表示滚筒。

虚拟雕塑的对象是一张特殊的矩形网格--由M×N个按顺序水平放置的正方形组成。水平及垂直方向分辨率相同的图象可以转换为一正方形网格。普通网格可以通过艺术曲面中曲面重构功能转化为矩形网格或正方形网格。


1.2.2 雕塑模型

雕塑模型是虚拟雕塑的对象，是一张水平放置的正方形网格曲面。虚拟雕塑环境同时只能存在一个工作雕塑模型及零个或多个参考雕塑模型，工作雕塑模型及参考雕塑模型之间可相互转换。

初始雕塑模型的创建方法有：

a. 在艺术曲面模块环境中选择一个或多个矩形网格，然后点击屏幕右侧工具条中虚拟雕塑工具。

b. 进入虚拟雕塑环境，点击模型工具中的新建模型命令。

c. 进入虚拟雕塑环境，点击模型工具中的位图转浮雕命令。

d. 进入虚拟雕塑环境，点击模型工具中的图像浮雕命令。

e. 进入虚拟雕塑环境，点击模型工具中的加载雕塑模型命令。

雕塑操作完成之后，点击选择工具，工作雕塑模型及参考雕塑模型以矩形网格的形式出现于选择工具环境中，此时所针对网格网曲面的操作同样也适用于该雕塑模型。

雕塑模型中顶点的总数决定了系统的运行速度。一般该参数在100万之内，在当前的P4机器上，速度较快，在高配置的机器上，使用局部操作模式顶点数可达1000万左右。若模型由图像转化而来，模型顶点数 = X方向的像素数 * Y方向的像素数。若模型由艺术曲面中曲面重构功能转化而来，模型顶点数 = (X方向尺寸/X方向步长) * (Y方向尺寸/Y方向步长)。“选项”中“模型属性” 命令可显示工作雕塑模型中顶点的总数。

在虚拟雕塑过程中，可以增加或减少工作模型顶点数。在构造模型的大面时，可以减少顶点数以提高速度，在大面构造好之后，构造模型的表面细节时，再增加顶点数，以便精细控制。

如果模型某个或多个局部比较精细，系统提供了截取模型功能，可以以较少的顶点（较大的步长）构造整个模型以提高速度，再截取需要精细控制的局部，然后调小步长重构可实现局部精细控制。截取模型时可把截取区域下的基面压低到一个指定高度，从而省去了拼合的过程。


1.2.3 操作模式

三种操作模式可用于三种不同的场合：

单模型整体操作模式可用于顶点数较少的模型，是系统缺省的操作模式，也是最常用的操作模式。

单模型局部操作模式可用于顶点数较多的模型或机器速度较慢的场合。

多模型多分辨率操作模式可用于模型一个或多个局部要求比较精细的场合。

系统缺省的操作模式为单模型整体操作模式，利用设定操作范围命令可把单模型整体操作模式转为单模型局部操作模式，利用截取模型命令可把单模型整体操作模式转为多模型多分辨率操作模式。

选择工具中艺术曲面的“矩形网格分割”及“同源矩形网格合并” 命令可把矩形网格曲面无损分割及合并。对于超大型网格曲面（顶点数300万—2000万）可利用无损分割命令把网格曲面分为多个小的矩形网格，然后选择一个小的矩形网格（单模型整体操作模式）进入虚拟雕塑操作；或选择多个小的矩形网格（多模型多分辨率操作模式）进入虚拟雕塑操作。各小矩形网格修改完毕后，可用“同源矩形网格合并” 命令把小矩形网格无损合并，然后重新无损分割后修补原小矩形网格曲面的边界接合处。利用无损分割及合并技术，可处理超大型浮雕壁画。


1.2.4 层

虚拟雕塑环境下只有一个工作模型，但该模型是由两个独立的层构成的——流动层及固化层。流动层及固化层叠加在一起，构成屏幕上见到的模型（复合层）。

固化层及流动层都是一张与的工作模型尺寸等同的网格曲面。固化层是一个基准曲面，除固化及流化命令外其它命令不能修改它。所有的命令都是修改复合层或流动层，缺省为复合层。固化层存在的一个理由之一在于相当一部分命令，如冲压、堆料-自然效果、涂抹纹理等等，必须有一个相对稳定的基准曲面。

由位图转浮雕、图像浮雕，JDP文件读入的对象，或选择工具下构造的对象进入虚拟雕塑环境时，其流动层为一零平面，固化层等于复合层为屏幕上见到的模型。由虚拟雕塑环境下保存及载入“VSM”文件时，固化层、流动层及复合层的信息可保存及重载。

显示控制命令可分别控制只显示流动层、固化层及复合层。但操作时应该处于复合层显示状态，否则速度较慢。功能键“B”可把流动层上顶点高度不为零处以绿色显示出来。

擦除命令就是把流动层上高度不为零的顶点置为零。固化命令把流动层上的对象移到固化层，并把流动层相应的部位置为零。流化命令把固化层上的对象移动到流动层，并把固化层相应的部位清零。

层是虚拟雕塑的一个重要概念，没有理解层的概念就不能解释命令操作过程中的一些怪现象，就不能真正体会虚拟雕塑的好处。


1.2.5 取消/重做

在虚拟雕塑环境中，有两套取消/重做机制。对图形的生成、编辑、变换等操作，其取消/重做机制与选择工具中的取消/重做机制相同。对虚拟雕塑操作，考虑到雕塑模型数据量太大，系统缺省只提供了单步取消/重做机制，即可以取消最近的一次鼠标左键按下到抬起期间对模型高度或颜色的改变。但如果系统内存允许，取消/重做步数可增加到30步。如果用户输入了较大的步数，系统自动依照内存大小计算出一最大可能的步数。70万的顶点在1G的内存的机器上，取消/重做步骤一般可设到30步。连做多步取消/重做操作时，可用功能键“C”把显示模式置为粗糙模式，以提高速度。

除了取消/重做功能外，系统提供了擦除和整体擦除功能。擦除命令可擦除模型指定区域的修改。擦除是恢复特定区域最近一次模型固化时的状态。整体擦除恢复整个模型最近一次模型固化时的状态。


1.2.6 刷子/体素/纹理单元

刷子是限定操作影响范围的一个区域。通常刷子为圆形或长方形。除了系统提供的预定义刷子之外，用户可利用网格曲面或图象自定义刷子。通常刷子还有三个参数：X、Y向尺寸及高度。虚拟雕塑中，堆/去料、体素、纹理填充等操作中都利用了刷子的概念。在磨光等操作中，刷子高度的概念变为力度的概念，力度变化范围为0.0---1.0，1.0表示力度最强。

在虚拟雕塑中刷子,体素及纹理单元是通用的, 所有的刷子都可用作体素及纹理单元,同理所有的纹理单元都可用作刷子及体素。

系统预定义的刷子有十类：

图1-2 预定义刷子

1、高斯分布

参见1.2.7

2、圆柱

如图1-2 (a)。参数定义如下：

直经 | 圆柱直径。
直径 | 无效。
高度 | 圆柱高度。

3、锥体/锥台

如图1-2 (b)。参数定义如下：

直经 | 锥底直径。
锥高 | 锥高。
限高 | 刷子实际高度。

4、半球/半椭球

如图1-2 (c)。参数定义如下：

直经 | X方向直径。
直径 | Y方向直径。
高度 | 刷子高度。

5、长方体

如图1-2 (d)。参数定义如下：

长度 | X方向尺寸。
宽度 | Y方向尺寸。
高度 | 刷子高度。

6、半圆柱

如图1-2 (e)。参数定义如下：

直经 | 圆柱直径。
长度 | 半圆柱长度。
高度 | 刷子实际高度。

7、棱锥体/棱锥台

四棱锥体/棱台刷子， 如图1-2 (f)。参数定义如下：

边长 | 底边长。
锥高 | 锥高。
限高 | 刷子实际高度。

8、半圆环

如图1-2 (g)。参数定义如下：

大直经 | 圆环大直径。
小直径 | 圆环小直径。
高度 | 刷子实际高度。

9、自定义

利用特征工具或艺术曲面中保存特征命令保存的扩展名为“bru”的文件。参数定义如下：

X尺寸 | X方向尺寸。
Y尺寸 | Y方向尺寸。
高度 | 刷子高度。

10、图象

自定义的图象刷子，如图1-3。纹理库中所有图象都可以当做刷子，体素，纹理单元使用。参数定义如下：

X尺寸 | X方向尺寸。
Y尺寸 | Y方向尺寸。
高度 | 刷子高度。

图1-3 图象刷子


1.2.7 高斯分布

高斯分布是堆/去料时最常用的一种刷子。高斯分布是一XY向等价的类似奶嘴的一指数函数，它共有三个定义参数，如图所示：

图1-4高斯分布

直径定义刷子的大小。

衰减直径是高度值衰减到一半时的直径，它控制奶嘴的陡峭程度， 衰减直径可以大于直径。衰减直径相对直径的比例越大， 衰减越慢，曲线越平坦；反之衰减越快，曲线越陡峭。

高度是其最高点的高度值。刷子的实际高度小于最高点的高度值，衰减直径相对直径的比例越大，实际高度比最高点的高度值小得越多。

通常堆/去料时，如果累加的话，其高度取值都比较小， 一般在0.01-0.05mm的范围。

图1-5显示了不同参数值时，高斯分布的形态。

图1-5高斯分布刷子

衰减直径/直径 = 6/12，12/12， 18/12， 24/12 高度= 5mm

衰减直径/直径 = 6/12，12/12， 18/12， 24/12 高度= 1mm

高斯分布是把神奇的刷子，调整半衰直径相对其直径的比值，可以实现不同的效果。

堆去料大面起鼓时，可把半衰直径设为与直径相等或直径的150%,这样可保证堆去料的区域比较光滑。

构造比较细小的特征时，可把半衰直径设为直径的25%左右。

构造特别细小的特征时，不要把刷子下直径调得很小，可保留刷子直径较大，而把半衰直径设为最小值0.01mm，这样就能构造出精细的特征。

会不会依照不同的要求调整半衰直径，是虚拟雕塑是否入门的标志之一。


1.2.8 限高保低

设计模型前，一般对模型的高度有一个估计。比如说将要设计的模型高度不超过15 mm，这时可设其限高值为15mm，保低值为0mm。这样修改模型时，一旦高度超过15mm，系统自动裁去超过部分，该部位将出现一15mm高的平顶，反之当某处的高度值低于0mm时，系统自动裁去低于0mm的部分，该部位将出现一0mm的平底。

在命令操作过程中，可随时重新设定限高保低值，这样可把该命令对模型的改变限定在一特定的高度层次上。


1.2.9 颜色模板

修改模型时，为了只改变特定区域，可把该区域涂上颜色，然后利用颜色模板功能达到操作只影响特定区域的目的。只有当前颜色可以充当颜色模板，如果颜色模板中的颜色不是当前颜色，可用当前颜色命令把其颜色置为当前颜色。

图1-6颜色模板

颜色无效 | 修改模型时，不考虑颜色模板的影响。
颜色内 | 仅修改颜色模板内的曲面顶点。
颜色外 | 仅修改颜色模板外的曲面顶点。


1.2.10 高度模式

大部分操作都是对模型中顶点的高度的修改， 即高度的升高及降低， 高度模式可以限定操作时只升高或只降低刷子范围中的顶点。比如磨光时，正常操作是高点降低，低点升高，有时为了达到特殊的效果，可选用仅补低或仅去高选项。图1-7中为了去掉圆形沟，而不降低周围顶点的高度，可使用磨光命令的仅补低选项。

图1-7高度模式

去高补低 | 高点降低，低点升高。
仅补低 | 仅补低，不去高。
仅去高 | 仅去高，不补低。


1.2.11 拼合方式

虚拟雕塑许多命令都用到拼合方式选项，有关拼合方式的详细介绍请参考艺术曲面部分。

图1-8 拼合方式


1.3 功能键定义

虚拟雕塑专用功能键定义如下：

“1”：刷子直径设为4mm，半衰直径(若为高斯分布)设为1mm。

“2”：刷子直径设为20mm，半衰直径(若为高斯分布)设为30mm。

“Q”：刷子高度/力度减少5%。

“W”：刷子高度/力度增加5%。

“S”：刷子直径(X方向尺寸)及半衰直径(Y方向尺寸)缩小5%。

“A”：刷子直径(X方向尺寸)及半衰直径(Y方向尺寸)增大5%。

“D”：刷子半衰直径(Y方向尺寸)缩小5%。

“F”：刷子半衰直径(Y方向尺寸)增大5%。

“Z”：取消最近一次鼠标左键按下到松开期间对模型的修改。

“X”：恢复取消操作。

“E”：隐藏/显示二维图形。

“R”：隐藏/显示雕塑模型。

“C”：粗糙/精细显示雕塑模型。

“T”：单模型局部操作模式或多模型多分辨率操作模式时隐藏/显示模型的非工作区。

“V”：绘制多义线。

“B”: 流动层整体着色。

“N”：整体擦除颜色。


第一章 概述


11.1 显示方式

设置模型的显示方式，系统提供了四种显示方式：

1. 灰度图象方式。

2. 地图方式。

3. 图象方式。

4. 图形方式。


11.1.1 显示方式>>灰度图象方式

以灰度图象的方式显示雕塑模型。可加光照效果以图形图象结合的方式显示，或去掉光照效果以纯图象的方式显示。

图11-2灰度图象方式显示

* 操作步骤：

选择命令“选项--灰度图象方式显示”。

在灰度图象方式显示时，与颜色有关的命令不能使用，但颜色模版依然有效，这时看不见充当颜色模版的颜色区域，可转为图形显示方式，用“颜色--颜色区域矢量化” 命令把模版颜色区域矢量化，然后再转为灰度图象显示方式。


11.1.2 显示方式>>地图方式

色彩的变化反映高度的变化，如图11-3。

图11-3 地图显示方式

* 操作步骤：

选择命令“选项--地图方式”。系统用从白---红---兰12种颜色表示模型的高度层次。白色最高，兰色最低。修改模型时，高度的变化，即时反映到颜色的变化。人眼对颜色变化的敏感程度远远超过对高度层次变化的敏感程度，特别是当模型的高度比较小时，效果更明显。

在地图方式显示时，与颜色有关的命令不能使用，但颜色模版依然有效，这时看不见充当颜色模版的颜色区域，可转为图形显示方式，用“颜色--颜色区域矢量化” 命令把模版颜色区域矢量化，然后再转为地图显示方式。


11.1.3 显示方式>>图象方式

颜色的饱和度及光照处理反映高度变化，如图11-4。

* 操作步骤：

选择命令“选项--图象方式”。图象方式下，高处颜色明亮一些，低处颜色灰暗一些，模型的立体感较强。

图11-4 图象显示方式


11.1.4 显示方式>>图形方式

纯光照处理反映高度变化，如图11-5。

* 操作步骤：

选择命令“选项—图形方式”。图形方式是系统的缺省显示方式，比较真实。如果模型由图象转化而来，可用“模型—加载模型颜色”命令把图象套色显示于模型之上，套色方式显示主要有三个用途：

a. 套色之后在虚拟雕塑下直接做颜色浮雕，描图等等。

b. 检查修改后的模型与原始图象区域边缘匹配的程度。

c. 出效果图。

图11-5 图形显示方式


11.2 显示控制

控制当前的显示对象，显示对象可为流动层或固化层或复合层，系统缺省显示复合层。操作时应处于复合层显示状态，否则速度会较慢。

显示流动层或固化层的目的仅仅是为了帮助理解流动层，固化层及复合层的概念。


11.3 定义刷子

不同种类的刷子对漂移等命令的效果是有影响的，但漂移等命令没有定义刷子种类对话框选项。定义刷子种类对话框是一标准对话框，多个命令都引用它，所以把它单独提取出来作为一个独立的命令。


11.4 限高保低

修改模型的限高保低值和/或对模型做一次限高保低操作。

* 操作步骤：

1）选择命令“选项--限高保低”

系统弹出如图11-6所示对话框。

2）设置参数，点击确定按钮即可：

参数包括限高和保低，在参数定义中会详细说明。

图11-6 限高保低参数设置

限高保低参数定义

最大Z坐标 | 当前模型顶点的最大Z座标。
最小Z坐标 | 当前模型顶点的最小Z座标。
限高 | 当前限高值。
保低 | 当前保低值。
模型限高保低 | 是否立即对模型执行一次限高保低操作。


11.5 模型属性

显示有关模型的一些参数

* 操作步骤：

选择命令“选项--模型属性”

系统弹出如图10-7所示对话框显示模型属性

图11-7 模型属性参数框

模型参数定义

撤消次数 | 可设置撤消次数。
顶点数 | 模型中顶点的总数。这是一重要参数，它基本上决定了系统的运行速度。
X顶点数 | X方向顶点数。若模型由图像转化而来，即X 方向的像素数。
Y顶点数 | Y方向顶点数。若模型由图像转化而来，即Y 方向的像素数。
X尺寸 | X方向尺寸。
Y尺寸 | Y方向尺寸。
Z尺寸 | Z方向尺寸。
X步长 | X方向顶点间间距。
Y步长 | Y方向顶点间间距。
限高 | 模型的限高值。
保低 | 模型的保低值。
浮雕度 | 反映浮雕凸凹程度的一个参数。


第十一章 选项

选项中（图11-1）包括系统的一些辅助功能与显示方式，限高保低等。

图11-1 选项菜单栏


2.1 新建模型

创建一个高度为零的矩形网格平面。

* 操作步骤：

1）选择或不选择二维图形。

2）选择菜单命令“模型--新建模型”，设置参数 ，输入完参数后按确定即可完成模型的创建。 如果选择菜单命令前选择了二维图形，系统自动把二维图形包围盒的长宽值设置于对话框中的长宽输入框中。

新建模型参数设置对话框如图2-2所示。

图 2-2

长(X)： | 水平方向尺寸。
宽(Y)： | 垂直方向尺寸。
XY步长： | 水平及垂直方向网格点间距。
边界余量： | 左右及上下边界的加宽量
限高： | 模型的限高值。
保低： | 模型的保低值。


2.2 保存雕塑模型

把虚拟雕塑下的工作模型以VSM文件格式保存。JDP文件及位图文件没有把雕塑模型分层保存，重新加载JDP文件或位图文件后，流动层上的材料都合并到固化层上去了。而VSM文件分层保存流动层及固化层上的内容，重新加载后可完整恢复保存前的状态，VSM文件不保存二维及三维图形。

* 操作步骤：

1）选择命令“模型--保存雕塑模型”， 系统弹出文件保存对话框，输入文件名后确定。


2.3 加载雕塑模型

把VSM文件格式加载进来，创建雕塑模型。VSM文件分层保存了流动层及固化层上的内容，重新加载后可完整恢复保存前的状态。

* 操作步骤：

1）选择命令“模型--加载雕塑模型”， 系统弹出文件加载对话框，输入文件名后确定。


2.4 位图转浮雕

把一灰度位图或颜色位图图象转换为一矩形网格曲面。如图2-3所示。

(a) 原始位图 (b) 转为浮雕之后

图2-3 位图转浮雕

* 操作步骤：

1）选择命令“模型

--位图转浮雕”

从“模型”菜单下选取。

2）设置参数 | 系统弹出两个对话框，其一为打开文件对话框（图2-4），用于查找位图文件，找到文件后按打开，导航区出现其参数对话框如图2-5。
3）设置完参数，点击 确定按钮： | 各参数意义见图2-5的参数定义

图2-4 打开文件对话框

位图转浮雕参数定义：

长(X)： | X方向尺寸，不能修改，由图象的分辨率及水平方向的点数决定。
宽(Y)： | Y方向尺寸，不能修改，由图象的分辨率及垂直方向的点数决定。
高(Z)： | 曲面高度。可根据要求输入数值。
黑色最高： | 图象中黑色区域转化为高点，白色区域转化为低点。
白色最高： | 图象中白色区域转化为高点，黑色区域转化为低点。
限高： | 模型的限高值。
保低： | 模型的保低值。

说明：目前该命令仅处理.BMP图象，对其它格式的图象文件必先转化为.BMP格式。对彩色图象，系统内部先转化为灰度图象，然后转为浮雕曲面。


2.5 存为位图

把模型的高度信息或颜色信息存为位图。

* 操作步骤：

1）选择命令“模型--存为位图”。

2）设置参数。系统弹出两个对话框，其一为保存文件对话框，按保存，导航区出现其参数对话框如图2-6所示。

图 2-6

存为位图参数定义：

高度存为位图 | 把模型的高度值存为灰度位图。
颜色存为位图 | 把模型的颜色存为位图。


2.6 加载模型颜色

执行位图转浮雕或图象浮雕命令时，系统把图象的颜色信息转化为模型的高度信息，加载模型颜色命令可把模型的颜色信息加载进来作为雕塑模型的颜色套色显示于三维雕塑环境。

* 操作步骤：

选择命令“模型--加载模型颜色”，统弹出对话框，如图2-7所示

图2-7 加载文件

这是一个标准的打开文件对话框 ，一般选择生成当前模型时的位图文件，按打开后即加载了位图颜色信息，并套色显示于模型之上，如图2-8所示。可在这种模式下描图或做颜色浮雕等操作。

图2-8 套色显示


2.7 图象浮雕

把一线条图象或色块图象按照颜色浮雕的规律直接转为浮雕曲面，如图2-9所示。

（a）位图(线条图象) (b) 浮雕

（c）位图(色块图象) (d) 浮雕

图2-9图象浮雕

* 操作步骤：

1）选择命令“模型--图象浮雕”。系统弹出两个对话框，其一为打开文件对话框，用于查找位图文件，找到文件后按打开，导航区出现其参数对话框如图2-10所示。

2）设置完参数，点击确定按钮：各参数意义见参数定义。

图像浮雕参数定义：

自由高度 | 图象中任一点高度由边界角度，截面形式及该点到区域边界的距离完全确定。
实际高度 | 该图象转为浮雕后的最大高度由高度值参数确定，此时边界角度将不起作用。
限定高度 | 该图象转为浮雕后，若高度超出由高度值参数确定限定值则会出现平顶。
高度 | 用于设定实际高度及限定高度的高度值。
截面>>直线 | 截面形状为直线。
截面>>圆弧 | 截面形状为圆弧。
边界角度 | 边界切线与水平面的夹角，应为0---90之间。
磨光 | 生成浮雕后，系统内部对该浮雕进行光顺的次数。
线条图象 | 图象是由宽度较窄的线条及背景组成。对线条图象，线条所在位置高度值为零，仅改变背景处的高度值。
色块图象 | 图象是由一块一块的彩色区域及背景组成。对色块图象，背景处象素的高度值为零，仅改变非背景处象素的高度值。
背景颜色 | 指定背景颜色的R，G，B值。


2.8 截取模型

系统运行速度取决于雕塑模型的顶点数。在其他参数不变的情况下, 雕塑模型的顶点数与其在XOY平面上的投影面积成正比。如果删除原始模型，截取模型命令可截取模型的一部分作为新的雕塑模型, 以达到减少模型顶点数和提高系统运行速度的目的。如果不删除原始模型，原始模型变为一参考模型，系统进入多模型多分辨率操作模式。

图2-11(a) 顶点数 = 202万，X步长 = 0.07mm ，Y步长 = 0.07mm。

图2-11(b) 截取模型并删除原始模型之后：顶点数 = 99万， X步长 = 0.07mm，Y步长 = 0.07mm。

图2-11(c) 截取需要修改的部分并删除原始模型之后：顶点数 = 37万，X步长 = 0.07mm，Y步长 = 0.07mm。

(a)

(b)

(c)

图2-11

* 截取模型的操作步骤：

1）选择命令“模型--截取模型”，系统弹出对话框如图2-12所示，并提示"拾取二维图形, 右键结束命令"。

2）设置参数。

3）移动鼠标到模型上的二维图形处，当其改变颜色时，单击鼠标左键。

4）该命令把拾取的二维图形的包围盒当作剪裁框，如果删除原始模型，截取模型命令可截取模型的一部分作为新的雕塑模型，保留框内部分，去掉框外部分；如果不删除原始模型，框内部分变为新的工作模型，原始模型变为一参考模型，系统进入多模型多分辨率操作模式。工作模型与参考模型之间可以通过设置雕塑模型命令相互转换。

图2-12截取模型对话框

截取模型参数定义：

删除原模型 | 是否删除原始模型
压低区域内顶点高度 | 是否把原始模型剪裁框内顶点高度压低
高度压低到 | 如果压低，压低到多高


2.9 调整步长

调整雕塑模型的步长，以达到减少顶点或增加顶点的目的。

图2-12（a）顶点数194万，X步长0.08，Y步长0.08。

图2-12（b）截取模型后：顶点数133万，X步长0.08，Y步长0.08。

再调整步长后：顶点数59万，X步长0.12，Y步长0.12。

(a) （b）

图2-13调整步长

* 调整步长的操作步骤：

1）选择命令“模型—调整步长”： 系统弹出对话框，如图2-14所示。

2）设置新参数后确定，完成操作。

图2-14


2.10 Z向镜像

模型的高度值相对零平面镜像，可由凸模生成凹模，或由凹模生成凸模。

* 操作步骤：

1）选择命令“模型—Z向镜像”，完成操作。


2.11 重置雕塑模型

重置雕塑模型命令仅在多模型多分辨率操作模式下有效，用于切换当前工作模型。

* 操作步骤：

选择命令“模型—重置雕塑模型”。

如果系统中当时只有一个工作模型及一个参考模型，系统自动把工作模型及参考模型互换，工作模型变为参考模型，参考模型变为工作模型；如果系统中当时有一个工作模型及多个参考模型，系统提示“左键选择雕塑模型，右键退出命令”。

多模型多分辨率操作模式下，执行全部观察命令，显示的是当前工作模型。

多模型多分辨率操作模式下，功能键T可隐藏或显示参考模型。


2.12设定操作范围

设定操作范围命令仅在单模型整体或部分操作模式下有效，用于设定部分操作模式下的操作范围。

* 操作步骤：

选择命令“模型—设定操作范围”。

系统提示“拾取二维图形，或右键退出命令”。移动鼠标到二维图形处，当其改变颜色时，单击鼠标左键。二维图形可为任何图形，但常用的还是矩形，系统把二维图形的包围盒内的区域设定为当前操作范围，执行雕塑操作时，刷子运动区域不能超出当前操作范围。

设定操作范围命令成功完全后，系统即进入单模型部分操作模式。在单模型部分操作模式下，执行全部观察命令，显示的是当前操作范围内的模型。

在单模型部分操作模式下，功能键T可隐藏或显示当前操作范围外的模型。

（a）模型及其分区 （b）龙头设为当前操作范围

图2-15 设定操作范围


2.13 操作整个模型

操作整模型命令仅在单模型部分操作模式下有效，它把操作模式重置为单模型整体操作模式。

* 操作步骤：

选择命令“模型—操作整个模型”。

1） 系统把操作模式重置为单模型整体操作模式。


第二章 模型工具

模型工具主要用于创建初始的雕塑模型，模型整体特性的修改，及操作模式的转换。图2-1是模型工具菜单栏。

图 2-1 模型工具菜单栏


3.1 撤消雕塑

撤消上次鼠标左键按下到抬起期间对模型顶点高度或颜色的修改。

* 操作步骤：

1）按快捷键“Z”或选择命令”橡皮---撤消雕塑” 。

2）系统缺省的撤消步数为一步，如果内存足够或模型顶点数不多，可在“选项--模型属性”中设置一较大的撤消步数。在1G内存的机器上，70万顶点的模型，如果没有其他程序或图形占用较大的内存，撤消步数可设为30步。

3）撤消多步前，最好用“C” 键把显示模式置为粗糙显示模式，以提高速度。


3.2 重做雕塑

取消撤消雕塑操作。

* 操作步骤：

1）按快捷键“X”或选择命令“橡皮---重做雕塑”。

2）多步重做前，最好用“C” 键把显示模式置为粗糙显示模式，以提高速度。


3.3 擦除

擦除对模型顶点高度或颜色的修改。如图3-2所示。

(a) 原图 (b)下吧部位堆料后 (c)部分擦除后

图3-2 擦除

* 操作步骤：

1）选择命令“橡皮---擦除”

从“橡皮”菜单下选取。

2）设置擦除参数，进行擦除处理。

擦除参数设置如图3-3所示

图3-3擦除参数设置

擦除参数定义：

擦除修改 | 是否擦除修改。
擦除颜色 | 是否擦除颜色。
颜色模板 | 操作时如何利用颜色模板。

说明：擦除操作就是流动层上刷子经过之处清零，恢复成最近一次模型固化时的状态。擦除操作是对撤消命令的补充和加强。黄色是模型的基色，擦除颜色就是把刷子所经过的区域置为基色。


3.4 整体擦除

流动层整体清零， 整体恢复上次模型固化时的状态。

* 操作步骤：

1）选择命令“橡皮---整体擦除”。

2）设置参数，点击确定按钮。参数设置如图3-4所示。

图3-4 整体擦除参数设置

整体擦除参数定义：

擦除修改 | 整体恢复上次模型固化时的状态。
擦除颜色 | 把模型置为基色。


3.5 固化

固化命令把刷子经过之处流动层上的对象移到固化层，并把流动层相应的部位置为零。擦除，整体擦除，冲压、堆料-自然效果、涂抹纹理等命令都是相对最近一次固化而言的。

* 操作步骤：

1） 选择命令“橡皮---固化” 。

按下鼠标左键在需要固化的地方移动刷子。


3.6 整体固化

整体固化命令把流动层上的对象移到固化层，并把流动层置为零平面。擦除，整体擦除，冲压、堆料-自然效果、涂抹纹理等命令都是相对最近一次固化而言的。

* 操作步骤：

1） 选择命令“橡皮---整体固化” 。


3.7 流化

流化命令把刷子经过之处固化层上的对象移到流动层，并把固化层相应的部位置为零。

* 操作步骤：

1） 选择命令“橡皮---流化” 。

2） 按下鼠标左键在需要流化的地方移动刷子。


3.8 整体流化

整体流化命令把固化层上的对象移到流动层，并把固化层置为零平面。

* 操作步骤：

1） 选择命令“橡皮---整体流化” 。


第三章 橡皮工具

橡皮工具包括取消/重做、擦除、固化及流化等命令，主要用于误操作恢复，固化层及流动层的管理。如前所述，虚拟雕刻中有两套取消/重作机制，对雕塑对象误操作的取消必须使用橡皮工具的取消/重做命令。

图3-1


4.1雕塑工具箱

常用雕塑命令的集合，包括堆料，去料，擦除，磨光，漂移五个命令。

* 操作步骤：

1). 选择命令“雕塑----雕塑工具箱”。

2). 导航区出现菜单如图4-1。

3). 左手按相应的数字键，即可进入相应的命令，命令操作完毕，鼠标右键退出命令，左手再按其他的数字键，即可进入另外的命令。省去了选菜单的过程。

图4-1


4.2 堆料/去料

交互式地在模型上添料或去料。

图4-2堆料/去料

* 操作步骤：

1）选择命令“雕塑----堆料/去料”。

2）设置参数，进行堆料/去料操作。参数设置如图4-4所示。

图4-3 雕塑工具菜单 图4-4堆料/去料参数设置

堆料/去料参数定义：

刷子形状 | 选择刷子。
效果>>累加效果 | 每当按下鼠标左键移动时，或不移动但定时作业开关打开时，刷子所在位置高度不断地升高/降低。使用该选项时刷子高度值一般应设置得比较小，0.005mm—0.05mm之內才好控制。累加效果如图4-5所示。 (a) 原图 (b) 下巴累加堆料后 图4-5 累加堆料
效果>>自然效果 | 相对上次固化而言，刷子所经过处最多叠加/切除一个刷子的形状。使用该选项时刷子高度值一般应设置得比较大，0.2mm以上效果才明显。自然堆料/去料效果如图4-5a所示。 (a) 原图 (b) 自然堆/去料后 图4-5a 自然堆料
效果>>截顶去底 | 每当按下鼠标左键移动时，刷子所在位置高度不断地升高/降低，但当任何一点相对上次固化而言，其升高值大于刷子高度时将被截顶形成平顶；去料时当其高度降低值大于刷子高度时，将被去底形成平底。截顶去底效果能保证堆/去料的同时边缘比较光滑，对高斯分布刷子调整衰减直径的大小可控制边缘的陡峭程度。使用该选项时刷子高度值一般应设置得比较大，0.2mm以上效果才明显。截顶去底效果如图4-5b所示： (a) 原图 (b) 截顶去底去料后 图4-5b 截顶去底
只操作流动层 | 仅去料时有效。如果选上，只去流动层上的材料，否则去复合层上的材料。
定时作业 | 鼠标左键按下时，即使不移动鼠标，系统每隔20毫秒自动在当前位置堆/去料一次。
颜色模板 | 利用颜色模板界定操作范围。
直经变化 | 操作时刷子直经自动按变化因子改变。
直经变化方式>>等比 | 刷子直经自动按直经变化因子等比变化。
直经变化方式>>等差 | 刷子直经自动按直经变化因子等差变化。
直经变化因子 | 刷子直经按变化因子变化。
高度变化 | 操作时刷子高度按变化因子改变。
高度变化方式>>等比 | 刷子高度按高度变化因子等比变化。
高度变化方式>>等差 | 刷子高度按高度变化因子等差变化。
高度变化因子 | 刷子高度按高度变化因子变化。


4.3 冲压

交互式改变刷子所经过区域的高度。

(a) 原图 （b）压平右上角及右下角后

图4-6a 冲压

* 操作步骤：

1）选择命令“雕塑----冲压”。

2）设置参数，进行冲压处理。参数设置如图4-6b所示

图4-6 b 冲压参数设置

冲压参数定义

冲压效果>>均等 | 刷子所经过区域曲面高度相对最近一次固化升高冲压参数规定的高度，即实现曲面区域等距偏移，如图4-7所示。 (a) 原图 (b) 冲压后 图4-7冲压效果>>均等
冲压效果>>绝对 | 刷子所经过区域曲面高度都设置为冲压参数规定的高度，即出现一平台。
冲压效果>>高点 | 鼠标左键按下时，取刷子范围内最近一次固化曲面的最高点为基准，刷子所经过区域的高度再升高（如果冲压为正值）或降低（如果冲压为负值）冲压参数规定的高度，冲压之后将出现一平台。
冲压效果>>低点 | 鼠标左键按下时，取刷子范围内最近一次固化曲面的最低点为基准，刷子所经过区域的高度再升高（如果冲压为正值）或降低（如果冲压为负值）冲压参数规定的高度，冲压之后将出现一平台。
冲压效果>>中心 | 鼠标左键按下时，取刷子范围内最近一次固化曲面的中心点为基准，刷子所经过区域的高度再升高（如果冲压为正值）或降低（如果冲压为负值）冲压参数规定的高度，冲压之后将出现一平台。
冲压深度 | 冲压时，曲面上顶点相对基准升高或降低的高度数值。
流化 | 仅“冲压效果>>均等”有效，如果选上，冲压后并不把材料移走，仅仅把本该移走的材料移动到流动层上，并把冲压区域置上流动层的颜色--绿色。
颜色模板 | 利用颜色模板界定操作范围。

说明：冲压边缘轮廓有锯齿现象，网格步长越大，锯齿现象越明显，一般应对冲压边缘轮廓再实行磨光处理。


4.4 注塑

模拟注塑过程的一种堆料方法。

* 操作步骤：

1) 选择命令“雕塑----注塑”。 系统弹出对话框如图4-7。系统提示“选择特征，或右键结束命令”。在待注塑的颜色区域单击鼠标左键选择特征。

2）系统提示“设定注塑孔位置及高度,右键开始注塑(ESC键结束命令)”。设置各注塑孔的高度参数及位置，右键结束设置开始注塑，ESC结束注塑过程。

图4-7 注塑对话框


4.5 抖动

快速缩小刷子所经过区域的高度差，如图4-8。

(a) 原图 （b）添料后 (c) 抖动后

图4-8 抖动

* 操作步骤：

1）选择命令“雕塑----抖动”。

2）设置参数，进行抖动处理。参数设置如图4-9所示

图4-9 抖动参数定义

抖动参数定义：

粗料 | 抖动之后表面比较粗糙
细料 | 抖动之后表面比较细腻
只操作流动层 | 如果选上，只抖动流动层上的材料，否则抖动复合层上的材料。
颜色模板 | 利用颜色模板界定操作范围。

说明：抖动可以看作是磨光操作的粗加工过程，如果要磨光区域高度差比较大，可先用抖动操作，再用磨光操作。


4.6 体素

交互式拼合预定义图形元素，如图4-10所示。

图4-10手臂及前额饰物为体素

* 操作步骤：

选择命令“雕塑----体素”。

选择体素，设置参数，并交互式地放置体素。

体素参数定义

体素类型 | 刷子与体素完全通用。
体素尺寸 | 作为刷子时，高度值一般比较小，作为体素时高度值可按实际要求设定。
拼合方式 | 规定体素与雕塑模型的拼合方式，


4.7 区域浮雕

由闭合的二维图形区域或区域的结合生成浮雕元素并拼合到雕塑模型上，如图4-12所示。

图4-12区域浮雕

* 操作步骤：

1）选择命令“雕塑----区域浮雕”。

2）设置参数（图4-13），移动鼠标到雕塑模型上的二维图形，当其改变颜色时按下鼠标左键，即可完成浮雕构造及拼合过程。

* 区域浮雕参数定义

图4-13 区域浮雕参数定义

截面形状 | 规定浮雕截面类型，参见艺术曲面。
基准高度 | 浮雕基高。
高度类型 | 参见艺术曲面。
边界角度 | 截面边界切线与水平面的夹角。
拉高比例 | 浮雕在高度方向变换的比例因子。
形状系数: | 控制浮雕饱满程度的参数。
表面特点 | 生成整体光滑的浮雕还是棱角清晰的浮雕。
颜色模板 | 利用颜色模板界定操作范围。
拼合方式 | 新产生的浮雕与雕塑模型的拼合方式。

说明：

1） 所选图形必须为严格闭合的区域或区域的结合，所选图形必须至少部分位于雕塑模型上。

2）构造区域浮雕时，若要多选图形，方法如下：

a) 选择命令之前，把要选的对象或其一部分选上。

b) 进入命令之后，设定参数。

c) 如果所有对象都已选上，按右键结束命令即可；如果还有对象没有选上，移动鼠标到待选对象上，当其改变颜色时，单击左键即可。


4.8 颜色浮雕

利用颜色区域生成浮雕并拼合到雕塑模型上，如图4-14所示。

图4-14 颜色区域及颜色浮雕

* 操作步骤：

1）选择命令“雕塑----颜色浮雕”。

2）设置参数，选择一个或多个颜色区域，按右键结束，生成浮雕并完成拼合。

颜色浮雕参数定义：

高度>>自由高度 | 区域中任一点高度由边界角度，截 [image] 面形式及该点到区域边界的距离完全确定。
高度>>实际高度 | 颜色区域转为浮雕后的最大高度由高度值参数确定，此时边界角度将不起作用。
高度>>限定高度 | 颜色区域转为浮雕后，若高度超出由高度值参数确定限定值则会出现平顶。
高度 | 当高度类型为限定高度或实际高度时，规定高度值。
截面>>直线 | 截面形状为直线。
截面>>圆弧 | 截面形状为圆弧。
边界角度 | 截面边界处切线与水平面的夹角。
基高 | 所产生浮雕的基准高度。
磨光次数 | 生成浮雕并拼合后，系统内部对该区域磨光的次数。
拼合方式 | 规定拼合方式。

说明：如果区域由单一的颜色表示，点选该颜色区域按右键结束选择生成浮雕即可。如果颜色区域中还有其它颜色区域，并且希望他们作为一个整体区域生成浮雕，可点选所有的颜色区域，按右键结束选择生成浮雕。


4.9 单线浮雕

由不封闭的或封闭二维图形或图形结合生成浮雕并拼合到雕塑模型上去，如图4-16所示。

* 操作步骤：

1）选择命令“雕塑----单线浮雕”。

2）设置参数后选择图形，右键结束命令。参数设置如图4-17，参数意义在参数定义中说明。

图4-16 单线浮雕 图4-17单线浮雕参数定义

单线浮雕参数定义：

高度>>自由高度 | 区域中任一点高度由边界角度，截面形式及该点到区域边界的距离完全确定。
高度>>实际高度 | 转为浮雕后的最大高度由高度值参数确定，此时边界角度将不起作用。
高度>>限定高度 | 转为浮雕后，若高度超出由高度值参数确定限定值则会出现平顶。
高度 | 当高度类型为限定高度或实际高度时，规定高度值。
截面>>直线 | 截面形状为直线。
截面>>圆弧 | 截面形状为圆弧。
边界角度 | 截面边界处切线与水平面的夹角。
基高 | 所产生浮雕的基准高度。
磨光次数 | 生成浮雕并拼合后，系统内部对该区域磨光的次数。
边界处理>>只做闭合区域 | 自动在所选择的二维图形中搜索闭合区域，只有闭合区域才生成浮雕并拼合到模型上。
边界处理>>包围盒约束 | 在所选二维图形的包围盒内生成浮雕，而且自动在所选二维图形中添加包围盒图形。
边界处理>>自由边界 | 在所选二维图形的包围盒内生成浮雕。
线条看作>>整体 | 所有选择的对象看作是一个整体，生成浮雕。
线条看作>>个体 | 每一个选择的对象单独生成浮雕。
颜色模板 | 利用颜色模板界定操作范围。
拼合方式 | 新产生的浮雕与雕塑模型的拼合方式。

说明：

1、二维图形可闭合或不闭合。

2、允许线条自交，互交，悬边，或互不相交。

3、线条越多、越密,计算速度越快，尤其适合把一些纹理图案转化为纹理浮雕。

4、构造单线浮雕时，若要多选图形，方法如下：

a) 选择命令之前，把要选的对象或其一部分选上。

b) 进入命令之后，设定参数。

c) 如果所有对象都已选上，按右键结束命令即可；如果还有对象没有选上，移动鼠标到待选对象上，当其改变颜色时，单击左键即可。


4.10 单线冲压

把带重量的线条按压在软性的雕塑模型上留下的痕迹，如图4-18所示。

（a）外衣上的花纹系单线冲压后磨光的结果 （b）

图4-18 单线冲压

* 操作步骤：

1）选择命令“雕塑----单线冲压”。

2）移动鼠标到模型上的二维图形处，当图形颜色改变时按下鼠标左键即可完成单线冲压操作。

单线冲压参数定义：

图4-19 单线冲压参数设置

高度：单线在模型上留下的沟槽深度或凸起的高度。

说明：

1、图形必须至少部分位于雕塑模型上。

2、冲压产生的沟槽或凸起有锯齿现象，一般需经过磨光等后续处理。

3、沟槽或凸起的宽度是一个网格曲面的步长。若要加宽可先等距图形（等距距离不超过一个步长），或加大高度，后续的磨光操作会把沟槽变宽且变浅。


第四章 雕塑工具

雕塑工具（图4-3）命令在模型上添料或去料。


5.11 融接

5.13 融接

在二条2D曲线之间生成一过渡面并拼合到模型上。

图 5-11 融接

* 操作步骤：

1）选择命令“几何----融接” 。

2）融接：

a、移动鼠标到雕塑模型上的2D曲线，当其改变颜色时按下鼠标左键选择曲线1。

b、重复步骤a，选择曲线2。

c、设置参数

d、预览

说明：

1.系统自动把二维曲线投影到模型表面。

2. 融接前通常要用导动磨光或磨光命令沿线磨光。

融接参数定义：

图5-12 融接参数设置

过渡方式>>直纹面 | 在二曲线之间生成一直纹过渡面。
过渡方式>>三次曲面 | 在二曲线之间生成三次曲面过渡面。
切矢长度比例 | 控制过渡面的饱满程度。
切矢1方向 | 定义曲线1处过渡面的切矢方向。
切矢2方向 | 定义曲线2处过渡面的切矢方向。
拼合方式 | 规定过渡面拼合到雕塑模型上的方式。


5.4 曲线投影

5.1 曲线投影

2D曲线或3D曲线沿Z轴投影到模型上， 生成一模型表面上的3D曲线；或3D曲线沿Z轴投影到XOY平面，转为2D曲线。

图5-2 曲线投影

* 操作步骤：

1）选择命令“几何----曲线投影”。

2) 移动鼠标到雕塑模型上的2D曲线或3D曲线，当其改变颜色时按下鼠标左键，即可完成曲线投影过程。


5.2 Z向移动曲线

5.5 平面上绘制曲线

在空间任意平面上绘制3D点，直线，圆，样条曲线及平面的法线，为曲面构造准备素材。平面定义方式有三种：

1） 模型上任意一点的切平面。

2） 空间二点（平面法线）定义的平面。

3） 空间三点定义的平面。

* 操作步骤：

1） 选择命令“几何----平面上绘制曲线”。

2） 选择平面定义方式并定义平面。

3） 选择要绘制的曲线种类并绘制曲线。


5.10 延伸

5.12 延伸

模型表面的曲线沿水平方向或切向延伸生成一延伸面并拼合到模型上。

图5-9 延伸

图5-10延伸参数设置

* 操作步骤：

1）选择命令“几何----延伸”。

2）移动鼠标到雕塑模型上的2D曲线，当其改变颜色时按下鼠标左键即可完成延伸过程。

说明：

1、系统自动把二维曲线投影到模型表面。

2.、延伸前通常要用导动磨光或磨光命令沿线磨光。

延伸参数定义：

延伸方式>>水平延伸 | 沿水平方向延伸。
延伸方式>>向延伸 | 沿切向延伸。
延伸长度 | 延伸长度， 正值沿线的右侧延伸，负值沿线的左侧延伸。
拼合方式 | 规定延伸面拼合到雕塑模型上的方式。


5.5 提取截面

5.2 提取截面

提取模型的断面， 可以以水平方位二维图形的形式，以2D截面线为轴旋转90度的二维图形的形式，以3D截面的形式显示出来。

(a) (b)

图5-3 提取截面

* 操作步骤：

1）选择命令“几何----提取截面”。

2）移动鼠标到雕塑模型上的单段直线，当其改变颜色时按下鼠标左键，即可完成提取截面过程。

说明：

1、单段直线至少部分位于雕塑模型上。

2、水平方位二维图形截面可用于检查截面形状及与扫掠结合使用修改模型形状，如图5-3（b）。

3、以2D截面线为轴旋转90度的二维图形截面可用于检查截面形状，利用节点编辑工具修改后，再转回3D截面线，构造曲面，修改模型。


5.2 Z向移动曲线

5.7拉伸面

空间的一条曲线沿一矢量方向拉伸生成一曲面，并拼合到模型上。

* 操作步骤：

1） 选择命令“几何----拉伸面”。

2） 设置参数。

3） 如果所选曲线为平面曲线，按右键结束那么生成一沿平面法线方向的拉伸并拼合到模型上，或者指定二点确定拉伸方向。


5.8 插值曲面

5.10 插值曲面

由至少三条二维/三维曲线（点），生成一插值曲面并拼合到模型上。

图5-6插值曲面

* 操作步骤：

1） 选择命令“几何----插值曲面”。

2） 移动鼠标到雕塑模型上的2D曲线（点）或3D曲线（点），当其改变颜色时按下鼠标左键选择曲线（点）。顺序选择至少三条方向一致的曲线（点），右键结束命令。


5.2 Z向移动曲线

5.6 平面

利用空间任意三个不相同的点构造一平面，并拼合颜色区域内的顶点。

* 操作步骤：

1） 选择命令“几何----平面”。

2） 选择颜色区域并设置拼合方式。

3） 选择三点定义平面。


5.7 旋转曲面

5.9 旋转曲面

由一条2D/3D曲线绕空间的二点构成的直线旋转，生成一旋转曲面并拼合到模型上。

图5-5旋转曲面

* 操作步骤：

1） 选择命令“几何----旋转曲面”。

2） 移动鼠标到雕塑模型上的2D曲线或3D曲线，当其改变颜色时按下鼠标左键选择曲线。

3） 设置参数。

4） 指定旋转轴线基点。

5） 指定旋转轴线方向点。旋转方向遵守右手法则，大拇指指向旋转轴的方向，其他四指的方向即旋转方向。如果旋转轴线基点及旋转轴线方向点是同一点，那么绕过基点并平行于Z轴的轴线旋转。


5.3 旋转曲线

2D曲线或3D曲线绕空间的二点构成的直线旋转，生成3D曲线，为曲面构造准备素材。

* 操作步骤：

1） 选择命令“几何----旋转曲线”。

2） 移动鼠标到雕塑模型上的2D曲线或3D曲线，当其改变颜色时按下鼠标左键。

3） 指定旋转轴线基点。

4） 指定旋转轴线方向点。旋转方向遵守右手法则，大拇指指向旋转轴的方向，其他四指的方向即旋转方向。


5.6 直纹面

5.8 直纹面

由二条2D/3D曲线生成一直纹面并拼合到模型上。

图5-4 直纹面

* 操作步骤：

1）选择命令“几何---直纹面”。

2）移动鼠标到雕塑模型上的2D曲线或3D曲线，当其改变颜色时按下鼠标左键选择曲线1。

3）重复步骤2 选择曲线2。


5.9 扫掠

5.11 扫掠

一个或多个截面线沿一条或二条轨迹线扫掠生成曲面并拼合到雕塑模型上，如图5-7所示。

图5-7扫掠

* 操作步骤：

1）选择命令“几何----扫掠”。

2）扫掠处理：

a、点选一条或两条轨迹上，放置于轨迹线选择框中。

b、选择一条或多条水平放置的截面线，放置于截面线选择框中。

c、如果截面线数大于1，点击“截面位置”按纽然后顺序指点截面位置。

d、设定参数，然后按“效果预览”按纽，即可观察到拼合到雕塑模型的扫掠面。

e、若需修改，修改参数后重新预览，满意后确定即可。

扫掠参数定义：

轨迹线 | 一条或两条轨迹线。
截面线 | 一条或多条截面线。
截面位置 | 如果有多条截面线，需顺序在主轨迹上指点截面位置。
效果预览 | 预览
截面基点>>起点 | 起点位于主轨迹上
截面基点>>中点 | 中点位于主轨迹上
截面基点>>末点 | 末点位于主轨迹上
截面基点>>左上 | 左上位于主轨迹上
截面基点>>左中 | 左中位于主轨迹上
截面基点>>左下 | 左下位于主轨迹上
截面基点>>中上 | 中上位于主轨迹上
截面基点>>中中 | 中中位于主轨迹上
截面基点>>中下 | 中下位于主轨迹上
截面基点>>右上 | 右上位于主轨迹上
截面基点>>右中 | 右中位于主轨迹上
截面基点>>右下 | 右下位于主轨迹上
截面高度效果>>等高 | 截面扫掠过程中，宽度有可能改变，高度不会发生变化。
截面高度效果>>相似 | 截面扫掠过程中，高度及宽度等比例变化。
网格精度>>轨迹方向 | 轨迹方向的精度。
网格精度>>截面方向 | 截面方向的精度。
拼合方式 | 规定扫掠面拼合到雕塑模型上的方式。


5.2 Z向移动曲线

5.4 Z向移动曲线

2D曲线或3D曲线沿Z轴移动， 生成3D曲线，为曲面构造准备素材。

* 操作步骤：

1） 选择命令“几何---- Z向移动曲线”。

2） 移动鼠标到雕塑模型上的2D曲线或3D曲线，当其改变颜色时按下鼠标左键，即可完成曲线移动过程。


6.1 导动堆料/去料

刷子沿着轨迹运动， 并自动堆料/去料（如图 6-2所示）

(a) 头发及胡须可用导动生成 (b) 导动笔刷类型

(c) 象毯及花草可用导动生成 (d) 蛇鳞可用导动生成

图 6-2导动堆料/去料

预操作：

利用绘制功能在模型上绘制一些二维图形，文字。

* 操作步骤：

1. 1）选择命令“导动--导动堆料/导动去料”。

2. 2）选择刷子类型，调整刷子大小。移动鼠标到二维图形处，当其改变颜色时，单击鼠标左键，即可完成导动堆料/去料。单击鼠标右键退出命令。

图 6-3导动堆料/去料参数设置

导动堆料/去料参数定义：

本部分解释在导动堆料/去料功能中用到的参数变量（如图 6-3），对话框中大部分参数与雕塑工具中堆料/去料的参数相同， 在此仅介绍新增的参数。

步长 |  | 刷子沿线运动时， 步伐的大小，以跨过的顶点数度量。
重复次数 |  | 刷子沿线运动的次数。
显示过程 |  | 是否当刷子在任一位置完成操作后，立即显示结果。
笔画类型 |  | 规定刷子在运动过程中， 刷子直径的改变规律。
笔画类型 | 等粗 | 运动过程中， 刷子直径不变，如图 6-2(b)-a。
 | 首粗 尾细 | 运动过程中， 刷子直径变小。起点处刷子直径是操作开始时刷子的直径。末点处刷子直径由”直径比率.尾” 设定， 缺省值为起点处刷子直径的20%。如图 6-2(b)-b。
 | 首细 尾粗 | 运动过程中， 刷子直径变大。末点处刷子直径是操作开始时刷子的直径。起点处刷子直径由”直径比率.首” 设定， 缺省值为末点处刷子直径的20%。如图 6-2(b)-c。
 | 首粗 | 起点处刷子直径是操作开始时刷子的直径。可设定末点及中间某一位置处刷子直径的大小。如图 6-2(b)-d。
 | 中粗 | 中间某一位置处刷子直径是操作开始时刷子的直径。可设定起/末点位置处刷子直径的大小。如图 6-2(b)-e。
 | 尾粗 | 末点处刷子直径是操作开始时刷子的直径。可设定起点及中间某一位置处刷子直径的大小。如图 6-2(b)-f。
过渡方式 |  | 当笔画类型为”首粗尾细/首细尾粗”的时候， 规定刷子直径在起末点之间的变化规律。
 | 直线 | 直径线性变化。
 | 圆弧 | 直径依照二次曲线变化。
直径比率 |  | 起末点及中间某一位置处刷子直径之间的比例百分数。
 | 首 | 起点处刷子直径相对于最大直径的比例百分数。
 | 中 | 中间某一位置处刷子直径相对于最大直径的比例百分数。
 | 尾 | 末点处刷子直径相对于最大直径的比例百分数。
 | 位置 | 中间某一位置相对于轨迹长度的比例百分数。

说明：

1. 所选图形或文字必须至少部分位于雕塑模型上。

2.导动堆料/去料时，若要多选图形，方法如下：

a) 选择命令之前，把要选的对象或其一部分选上。

b) 进入命令之后，设定参数。

c) 如果所有对象都已选上，按右键结束命令即可；如果还有对象没有选上，移动鼠标到待选对象上，当其改变颜色时，单击左键即可。


6.2 导动冲压

刷子沿着轨迹运动， 并自动冲压，如图 6-4所示。

图 6-4 导动冲压

预操作：

利用绘制功能在模型上绘制一些二维图形元素，文字。

* 操作步骤：

1）选择命令“导动--导动冲压”。

2）调整刷子大小，移动鼠标到二维图形处，当其改变颜色时，单击鼠标左键，即可完成冲压。单击鼠标右键退出命令。

导动冲压参数定义：

本部分解释在导动冲压功能中用到的参数变量（如图 6-5），对话框中大部分参数与雕塑工具中冲压的参数相同， 在此仅介绍新增的参数。

图6-5 导动冲压参数设置

步长 | 刷子沿线运动时， 步伐的大小，以跨过的顶点数度量。
显示过程 | 是否当刷子在任一位置完成操作后，立即显示结果。
笔画类型 | 参见6.1的说明。
过渡方式 | 参见6.1的说明。
直径比率 | 参见6.1的说明。

说明：所选图形或文字必须至少部分位于雕塑模型上。


6.3 导动抖动

刷子沿着轨迹运动， 并自动抖动。

预操作：

利用绘制功能在模型上绘制一些二维图形元素，文字。

* 操作步骤：

1）选择命令“导动--导动抖动”。

2）导动抖动：

a 、调整刷子大小。

b 、移动鼠标到二维图形处，当其改变颜色时，单击鼠标左键，即可完成导动抖动。

c 、单击鼠标右键退出命令。

导动抖动参数定义：

本部分解释在导动抖动功能中的新增参数：

图6-6 导动抖动参数设置

步长 | 刷子沿线运动时， 步伐的大小，以跨过的顶点数度量。
重复次数 | 刷子沿线运动的次数。
显示过程 | 是否当刷子在任一位置完成操作后，立即显示结果。
笔画类型 | 参见6.1的说明。
过渡方式 | 参见6.1的说明。
直径比率 | 参见6.1的说明。

说明：所选图形或文字必须至少部分位于雕塑模型上。


6.4 导动擦除

刷子沿着轨迹运动， 并自动擦除。

预操作：

利用绘制功能在模型上绘制一些二维图形元素，文字。

* 操作步骤：

1）选择命令“导动--导动擦除”。

2）导动擦除

a 、调整刷子大小。

b 、移动鼠标到二维图形处，当其改变颜色时，单击鼠标左键，即可完成导动擦除。

c 、单击鼠标右键退出命令。

导动擦除参数定义：

本部分解释在导动擦除功能中的新增参数：

图6-7导动擦除参数设置

显示过程 | 是否当刷子在任一位置完成操作后，立即显示结果。
笔画类型 | 参见6.1的说明。
过渡方式 | 参见6.1的说明。
直径比率 | 参见6.1的说明。

说明：选图形或文字必须至少部分位于雕塑模型上。


6.5 导动涂色

刷子沿着轨迹运动， 并自动涂色（如图 6-8所示）。

图 6-8 导动涂色

预操作：

利用绘制功能在模型上绘制一些二维图形元素，文字。

* 操作步骤：

1）选择命令“导动--导动涂色”。

2）导动涂色：

a、调整刷子大小。

b、移动鼠标到二维图形处，当其改变颜色时，单击鼠标左键，即可完成导动涂色。

c、单击鼠标右键退出命令。

导动涂色参数定义：

本部分解释在导动涂色功能中的新增参数：

图6-9 导动涂色参数设置

显示过程 | 是否当刷子在任一位置完成操作后，立即显示结果。
笔画类型 | 参见6.1的说明。
过渡方式 | 参见6.1的说明。
直径比率 | 参见6.1的说明。

说明：所选图形或文字必须至少部分位于雕塑模型上。


6.6 导动磨光

刷子沿着轨迹运动， 并自动磨光。

预操作：

利用绘制功能在模型上绘制一些二维图形元素，文字。

* 操作步骤：

1）选择命令“导动--导动磨光”。

2）导动磨光：

a 、调整刷子大小。

b 、移动鼠标到二维图形处，当其改变颜色时，单击鼠标左键，即可完成导动磨光。

c 、单击鼠标右键退出命令。

导动磨光参数定义：

本部分解释在导动磨光功能中的新增参数：

图6-10 导动磨光参数设置

步长 | 刷子沿线运动时， 步伐的大小，以跨过的顶点数度量。
重复次数 | 刷子沿线运动的次数。
显示过程 | 是否当刷子在任一位置完成操作后，立即显示结果。
笔画类型 | 参见6.1的说明。
过渡方式 | 参见6.1的说明。
直径比率 | 参见6.1的说明。

说明：所选图形或文字必须至少部分位于雕塑模型上。


第六章 导动工具

导动工具控制刷子沿线运动，并相应地改变模型。导动去料可以看作是虚拟投影雕刻，刷子运动的轨迹投影到模型上，可以看作是投影后的雕刻路径。刷子类型就相当不同的刀具类型，半球是球刀，圆柱是柱刀，圆锥是锥刀等。刷子沿线运动后留下的残料，即是改变后的模型，导动去料对话框中的各种选项使得虚拟雕刻比实现雕刻灵活得多，刀具半径在运动过程中可以改变等。

同理导动堆料可以看作是虚拟投影塑形。导动工具的优点在于能够比手工控制刷子运动更精确地改变模型，并且刷子的参数更好控制。如图 6-1为系统中的导动菜单栏。

所有导动操作都要求模型的XY步长相等，如果不相等刷子运动的轨迹会偏离所选图形或文字。这时可用“调整步长” 命令使XY步长相等后再做导动操作。

图 6-1 导动工具菜单


7.1 移动特征

移动或复制特征（如图7-3所示）。

预操作：

用涂色或颜色命令定义特征。

* 操作步骤：

1）选择命令“特征----移动特征”。

2）移动鼠标左键到一非基色界定的特征区域，按下鼠标左键移动，即可实现移动/复制特征。

移动特征参数定义：

图7-2 移动特征参数设置

拼合方式 | 移动或复制特征时，被移动特征与雕塑模型的拼合方式。
复制特征 | 是否复制特征。
只操作流动层 | 如果选上，只移动或复制流动层上的特征，否则移动或复制复合层上的特征。

图7-3中， 利用扫掠在外围定义了嘴唇及眼球，并把它们分分别定义为特征，利用抖动/冲压/磨光把嘴唇及眼球部位抹平， 然后移动复制嘴唇及眼球到其相应的位置。

图7-3 移动特征


7.2 缩放特征

按比例动态放大/缩小特征。

预操作：

用涂色或颜色命令定义特征。

* 操作步骤：

1）选择命令“特征----缩放特征”。

2）缩放特征

1、按下鼠标左键往右移动，水平方向放大特征。

2、按下鼠标左键往左移动，水平方向缩小特征。

3、按下鼠标左键往上移动，垂直方向放大特征。

4、按下鼠标左键往下移动，垂直方向缩小特征。

5、按下鼠标左键往右上移动，水平/垂直方向放大特征。

6、按下鼠标左键往左下移动，水平/垂直方向缩小特征。

7、按下鼠标左键往左上移动，水平方向缩小，垂直方向放大。

8、按下鼠标左键往右下移动，水平方向放大，垂直方向缩小。

3）如果选上“只操作流动层”，只缩放流动层上的特征，否则缩放复合层上的特征。

说明：若缩小特征，在原特征边界与现特征边界之间的曲面顶点高度为零，需后续处理把该沟槽填上。若放大特征，新特征边缘处可能出现台阶，需后续处理。


7.3 旋转特征

顺时针及逆时针方向动态转动特征。

预操作：

用涂色或颜色命令定义特征。

* 操作步骤：

1）选择命令“特征----旋转特征”。

2）旋转特征：

a、按下鼠标左键上移，逆时针转动特征。

b、按下鼠标左键下移，顺时针转动特征。

3）如果选上“只操作流动层”，那么只旋转流动层上的特征，否则旋转复合层上的特征。

说明：特征旋转后，特征边缘处有可能有沟槽，需后续处理把沟槽填上。


7.4 对称特征

特征镜像或雕塑模型整体/部分水平/垂直镜像（如图7-5所示）。

预操作：

如果进行特征镜像，用涂色或颜色命令定义特征。

* 操作步骤：

1）选择命令“特征工具----对称特征”： 从“特征工具”菜单下选取

2）对称特征

a、左右部分对称

系统提示：指点对称基准

在雕塑模型的右(左)半部位单击鼠标左键，则单击点到雕塑模型的右(左)边缘部分被垂直镜像到雕塑模型的左(右)半部。

b、左右完全对称

系统提示：指点对称基准

在雕塑模型的右(左)半部位单击鼠标左键，则雕塑模型的右(左)半部被垂直镜像到雕塑模型的左(右)半部。

c、上下部分对称

系统提示：指点对称基准

在雕塑模型的上(下)半部位单击鼠标左键，则单击点到雕塑模型的上(下)边缘部分被水平镜像到雕塑模型的下(上)半部。

d、上下完全对称

系统提示：指点对称基准

在雕塑模型的上(下)半部位单击鼠标左键，则雕塑模型的上(下)半部分被水平镜像到雕塑模型的下(上)半部分。

e、特征左右对称

系统提示：选择特征（颜色区域）

在一非基色定义区域单击鼠标左键选择特征。

系统提示：指点对称基准

单击鼠标左键，特征将关于通过单击点处的垂直线镜像。

f、特征上下对称

系统提示：选择特征（颜色区域）

在一非基色定义区域单击鼠标左键选择特征。

系统提示：指点对称基准

单击鼠标左键，特征将关于通过单击点处的水平线镜像。

对称特征参数定义：

本部分解释在对称特征功能中用到的参数变量。对称特征参数设置如图7-4所示。

图7-4 对称特征参数设置

对称方式>>左右部分对称 | 雕塑模型左/右的一部分做垂直镜像。
对称方式>>左右完全对称 | 雕塑模型左/右半部做垂直镜像。如图7-5所示。
对称方式>>上下部分对称 | 雕塑模型上/下的一部分做水平镜像。
对称方式>>上下部分对称 | 雕塑模型上/下半部做水平镜像。
对称方式>>特征左右对称 | 特征垂直镜像。
对称方式>>特征上下对称 | 特征水平镜像。

说明：镜像后边缘有可能有台阶，需后续处理。

(a) 原图 (b) 左右完全对称

图7-5 左右完全对称


7.5 特征变形

将选择的特征按变形曲线变形。

（a） （b）

图7-6 特征变形

* 操作步骤：

1）选择命令“特征----特征变形” 。

2）特征变形：

① 移动鼠标到一非基色界定的特征区域，

按下鼠标左键。

② 对话框中” X尺寸” 显示特征X尺寸，” Y尺寸” 显示特征XY尺寸，”高度差” 显示特征的高度差。

③ 设置参数。

④ 拾取水平基线。

⑤ 拾取变形曲线。

特征变形参数定义：

本部分解释在高度放缩功能中用到的参数变量。

X尺寸 | 显示特征的X尺寸。
Y尺寸 | 显示特征的Y尺寸。
高度差 | 显示特征的高度差。
X 方向 | X 方向变形。
Y 方向 | Y 方向变形。


7.6 高度放缩

将选择的特征的高度值按比例放缩。

（a） （b）

图7-8 高度放缩

预操作：

用涂色或颜色命令定义特征。

* 操作步骤：

1）选择命令“特征----高度放缩”。

2）高度放缩

① 移动鼠标左键到一非基色界定的特征区域，按下鼠标左键。

② 对话框中”高度差” 显示特征的高度差。

③ 设置参数。

④ 预览。

⑤ 单击鼠标右键退出命令。

对称特征参数定义：

高度差 | 显示特征的高度差。
放缩比例 | 以特征中的低点为基准，按比例在高度方向放缩特征。
放缩到 | 特征放缩后的实际高度差。
只操作流动层 | 如果选上，只放缩流动层上的特征，否则放缩复合层上的特征。


7.7 追加造型

将选择的特征按X 方向及Y 方向二条变形曲线变形。

（a） （b）

( C ) 鸟嘴可用追加造型构造 (d)

图7-10 追加造型

* 操作步骤：

1）选择命令“特征----追加造型”。

2）追加造型：

① 移动鼠标左键到一非基色界定的特征区域，按下鼠标左键。

② 对话框中” X尺寸” 显示特征X尺寸，” Y尺寸” 显示特征Y尺寸，”高度差” 显示特征的高度差。

③ 拾取水平基线。

④ 拾取水平变形曲线。

⑤ 拾取垂直基线。

⑥拾取垂直变形曲线。

追加造型参数定义：

本部分解释在追加造型功能中用到的参数变量。

X尺寸 | 显示特征的X尺寸。
Y尺寸 | 显示特征的Y尺寸。
高度差 | 显示特征的高度差。


7.8 矩形阵列

将选择的特征按照矩形的方式分别在水平方向和竖直方向上进行拷贝拼合。

图7-12 矩形阵列 图7-13 矩形阵列示意图

实现方法：

1、点击菜单项；

2、在对话框中定义阵列的参数和选项。

3、选择要进行变换的特征；

* 操作步骤。

1）点击菜单项： | 点击“特征工具”>> “矩形阵列”菜单项。
2）在对话框中定义阵列的参数和选项： | 在弹出的对话框中输入水平方向和竖直方向上的特征复制个数和间距以及其它阵列选项。
3）选择要进行变换的特征： | 在屏幕上拾取要阵列的特征。

参数选项：

图7-14 矩形阵列对话框

横向间距 | 水平方向上特征阵列的间距，即为阵列特征的列间距。 间距值达大于零在正向阵列，小于零在正负阵列。
纵向间距 | 竖直方向上特征阵列的间距，即为阵列特征的行间距。 间距值达大于零在正向阵列，小于零在正负阵列。
复制数目 | 横向或纵向特征阵列个数，即为阵列特征的列数和行数。
间距计算方法 | 有按偏移距离和按特征间距计算两种方法。图7-13中的间距为按特征间距计算，图7-15 为按偏移距离计算。

图7-15 按偏移距离计算的间距


7.9 圆形阵列

将特征沿圆周按照逆时针或顺时针方向以一定的角度间距来进行阵列拼合。

7-16 圆形阵列

图7-17 圆形阵列示意图

实现方法：

1、点击菜单项；

2、在对话框中定义阵列参数和选项；

3、选择要进行变换的特征对象；

4、输入阵列中心点。

* 操作步骤：

点击菜单项 | 点击“特征工具”-> “圆形阵列(A)”菜单项。
在对话框中定义阵列参数和选项 | 在弹出的对话框中定义圆形阵列的有关参数和选项，包括阵列起始角度、角度间距、特征复制数目等。
选择要进行变换的特征对象 | 在屏幕上拾取要阵列的特征。
请输入圆形阵列中心点： | 用鼠标输入圆形阵列中心点。

参数选项：

顺时针阵列 | 选中该选项，起始角度和角度间距是按照顺时针方向计算的。不选该选项，则是按照逆时针方向来进行计算的。
旋转特征 | 选中该选项，特征沿着圆周阵列的同时绕阵列中心进行旋转； 不选该选项，则特征仍沿圆周按照水平方向排列，此时须指定原始特征的基准点。
起始角度 | 指原始特征的基准点和阵列中心点的连线与阵列的第一个特征基准点和阵列中心点的连线的夹角。它确定了圆形阵列第一个特征的位置。
角度间距 | 阵列特征之间的角度偏移量
复制数目 | 圆形阵列特征个数


7.10 曲线阵列

将特征沿着一路径曲线方向进行阵列拷贝拼合。

图7-19 曲线阵列

* 实现方法：

1、点击菜单项；

2、在对话框中定义阵列参数和选项；

3、选择要进行阵列的特征对象；

4、拾取路径曲线；

* 操作步骤：

1）点击菜单项： | 点击“特征工具”->“曲线阵列”菜单项。
2）在对话框中定义阵列参数和选项： | 在弹出的对话框中定义图形沿曲线阵列的间距和要复制的个数以及其它一些参数和选项。
3）选择要进行变换的特征对象： | 在屏幕上拾取要阵列的特征。
4）拾取阵列图形路径： | 拾取做为阵列路径的曲线

图7-20 曲线阵列对话框

参数选项

特征间距 | 阵列拷贝特征中相邻两个特征中心之间的曲线距离
复制数目 | 阵列拷贝后的个数
旋转特征 | 选择此项，阵列时特征进行旋转，沿着曲线的切向排列，否则按照水平方向排列


7.11 保存特征

把特征区域存入文件（扩展名--.bru）在后续操作中，可以以自定义的形式作为刷子，体素，纹理单元使用。

预操作：

用涂色或颜色命令定义特征。

* 操作步骤：

1）选择命令“特征工具--保存特征”：从“特征工具”菜单下选取

2）保存特征：在要保存的特征颜色区域单击左键，系统弹出对话框，输入文件名后保存，如图7-21。

图7-21 保存特征


第七章 特征工具

特征是雕塑模型上用颜色界定的一块区域。对特征可以进行动态的平移，复制，放缩，旋转，对称， 阵列，单/双向变形操作。可以把特征存入文件，在后续的操作中作为刷子，体素，纹理单元使用。特征菜单栏如7-1所示。

图7-1 特征菜单栏


8.1 推移

材料搬家，把刷子处每一时刻的材料搬到刷子下一时刻的位置。

* 操作步骤：

1）选择命令“变形--推移”，系统弹出如图8-2所示对话框。

2）调整能刷子大小，在待推移处按下鼠标左键并移动。

推移参数定义：

本部分解释在推移功能中用到的参数变量。

宽窄 | 控制推移范围的宽窄。
阻力 | 控制推移衰减快慢程度，阻力越小，推移距离越大，反之推移距离越短。
光滑次数 | 推移过程中，系统内部对推移区域光顺的次数。0次不光滑 ，可看到推移的原始效果。光滑次数越大，推移的结果越模糊。
高度模式 | 推移时高度改变模式。
颜色模板 | 推移时如何利用颜色模板界定操作范围。

图8-2 推移参数设置


8.2 推拉

材料光滑衰减搬家（如图8-4所示）。

* 操作步骤：

1）选择命令“变形--推拉”，系统弹出如图8-3所示对话框。

2）推拉变形：

a、实时推拉：调整刷子大小，刷子直径不宜太大，一般不超过4mm，因为只有当鼠标移动距离超过一个刷子半径时系统才进行推拉操作，刷子直径太大时，交互性能不好。

按下鼠标左键快速移动，即可实现推拉操作。一般从料多的地方到料少相对平坦的地方推拉，或从料少平坦的地方往料多的地方推。如果推拉的起点及轨迹处都比较平坦，则推拉效果不明显。

b、非实时推拉：推拉过程中，系统不动态显示结果，只有在鼠标左键抬起后才显示结果。推拉起点处的材料将推拉倒鼠标左键抬起时的位置，中间光滑过渡。常用于某一特定区域扩大或缩小。

推拉参数定义：

图8-3 推拉参数设置

实时推拉 | 实时推拉/非实时推拉模式。
高度模式 | 高度改变模式。
颜色模板 | 颜色如何界定推拉操作的影响范围。

如图8-4左边及右上角的图形分别为图中“1”“2” 特征经推拉后得到。

图8-4 推拉


8.3 凸透镜/凹透镜

产生透过刷子大小的凸/凹透镜产生的变形效果（图8-6）。

* 操作步骤：

1）选择命令“变形--凸透镜/凹透镜”，系统弹出如图所示对话框。

2）调整刷子大小，刷子直径大一些效果才明显，可按功能键“2”把刷子直径设为20mm。

按下鼠标左键不动或移动，即可见刷子边缘不动，相对中心非线性缩放的凸/凹透镜效果。常用于放大/缩小特征。

凸透镜/凹透镜参数定义：

图8-5 凸透镜/凹透镜参数设置

高度模式 | 高度改变模式。
颜色模板 | 颜色如何界定凸/凹透镜操作的影响范围。

图8-6中， 鸟头部位进行了凸透镜变形， 原鸟头被移动到左上角。右边的凸字及下边的凹字分别进行了凸/凹透镜变形。

图8-6 凸/凹透镜


8.4 螺旋

刷子范围内的材料发生螺旋变形（图8-8）。

* 操作步骤：

1）选择命令“变形 --顺时针内螺旋”

--顺时针外螺旋”

--逆时针内螺旋”

--逆时针外螺旋”

系统弹出如图8-7所示对话框。

2）调整刷子大小，刷子直径大一些效果才明显，可按功能键“2”把刷子直径设为20mm。

按下鼠标左键不动或移动，即可见刷子边缘不动，相对中心螺旋变形效果。“Q”及“W”功能键可控制螺旋速度，移动鼠标可产生螺旋漂移的效果。

螺旋参数定义：

图8-7 螺旋参数设置

高度模式 | 高度改变模式。
颜色模板 | 颜色如何界定螺旋操作的影响范围。

图8-8陈列了各种螺旋变形效果， 其中左半边是原图， 右半边是螺旋变形后的效果。

图8-8 螺旋效果


8.5 漂移

磁力作用下，材料漂移（图8-10）。

* 操作步骤：

1） 选择命令“变形--漂移（运动方向）

--漂移（运动方向左侧）”，系统弹出如图8-9所示对话框。

图8-9 漂移参数设置

2）漂移变形处理

先调整刷子大小。接下来：

a、运动方向漂移

按下鼠标左键移动，就象运动方向与刷子轮廓的交点处有磁力，刷子中的材料被吸引过去，并光滑过渡。

b、运动方向左侧漂移

按下鼠标左键移动，刷子左侧有磁力，材料往从运动方向看刷子的左侧漂移，该命令常用于外扩或内收一特征区域的边缘。

说明：漂移命令一般应用于材料不均的区域，若区域过于平坦，漂移效果不明显。调节力度（Q键及W键）可控制磁力大小。

图8-10 漂移

图8-10中，左右上角及右下角的物体都是由右边的半椭球经 漂移操作变形而来。


第八章 变形工具

变形工具对雕塑模型的局部进行动态的艺术化的变形，包括螺旋，漂移，透镜及推拉等功能。变形菜单栏如图8-1所示。

图8-1 变形菜单栏


9.1 颜色工具箱

常用颜色命令的集合，包括单线填色，种子填色，区域填色，等高填色，涂抹颜色五个命令。

* 操作步骤：

1．选择命令“颜色----颜色工具箱”。导航区出现菜单如图9-1a。

2．左手按相应的数字键，即可进入相应的命令，命令操作完毕，鼠标右键退出命令，左手再按其他的数字键，即可进入另外的命令。省去了选菜单的过程。

图9-1a


9.2 涂抹颜色

在模型上随手涂抹颜色。如图9-2所示。

图9-2涂抹颜色

* 操作步骤：

1）选择命令“颜色--涂抹颜色”。

2）调整刷子大小。在右侧的颜色工具条上选择一颜色， 然后在雕塑模型上按鼠标左键涂抹即可。命令中间若要改变颜色，可在右侧颜色工具条上重新选择。擦除/整体擦除命令可擦除部分或全部颜色，取消/重做操作对颜色命令有效。


9.3 单线填色

单线以当前颜色的形式沿Z轴投影到雕塑模型上，如图9-3所示。

图9-3 单线填色

预操作：

利用绘制功能在模型上绘制一些二维图形元素。

* 操作步骤：

1）选择命令“颜色--单线填色”。

2）在右侧的颜色工具条上选择当前颜色。移动鼠标到二维图形处，当其改变颜色时，单击鼠标左键，即可完成单线填色。单线填色常与种子填色配合使用，先用单线填色，然后再用种子填色。这样对描图的要求比较低，即使图形不构成封闭的区域，甚至出现自交，互交等情况，亦能把其中的区域填上要求的颜色。


9.4 种子填色

把相邻同色顶点置为当前颜色，如图9-4所示。

图9-4 种子填色

预操作：

模型上有不同颜色分割的一些区域。

* 操作步骤：

1）选择命令“颜色--种子填色”。

2）首先在颜色工具条上选择当前颜色。接着在一个颜色区域中单击左键，系统把单击处曲面顶点置为当前颜色，如果其相邻顶点的颜色与单击处顶点的原始颜色相同，亦置为当前颜色，重复这一过程，直到没有满足条件的顶点。种子填色可用于填色，亦可用于替换一个颜色区域的颜色。


9.5 区域填色

把一闭合区域的内部或外部填上当前颜色，如图9-5所示。

图9-5 区域填色

预操作：

在模型上绘制一些二维闭合区域。

* 操作步骤：

1）选择命令“颜色--区域填色”。

2）首先在颜色工具条上选择颜色。接着移动鼠标到二维闭合区域，当其改变颜色时，单击左键以选择该区域。如果填充区域的内部，在其内部单击左键，如果填充区域的外部，在其外部单击左键。


9.6 等高填色

把整个模型或模型的一个局部高于或低于某一高度值的顶点置为当前颜色，如图9-6所示。

图9-6 等高填色

* 操作步骤：

1）选择命令“颜色--等高填色”。

2）设置参数，然后在模型上某处单击鼠标左键。

等高填色参数定义

高于 | 把整个模型或模型的一个局部不低于鼠标单击处顶点高度值的顶点置为当前颜色。
低于 | 把整个模型或模型的一个局部不高于鼠标单击处顶点高度值的顶点置为当前颜色。
整体 | 搜索整个模型。
局部 | 仅仅搜索鼠标单击处单连通的一个局部。
流化 | 仅对‘高于’选项有效。把整个模型或模型的一个局部不低于鼠标单击处顶点高度值的顶点置为当前颜色，并把填色的这一部分材料从固化层移到流动层上，以方便后续处理。

图9-7 等高填色对话框


9.7 平坦面填色

把相邻顶点之间高度落差小于一给定的数值的顶点集合置为当前颜色，如图9-8。

图9-8平坦面填色

* 操作步骤：

1）选择命令“颜色--平坦面填色”。

2）设置参数，然后在模型上待填色处单击鼠标左键。

图9-9平坦面填色对话框

平坦面填色参数定义

相邻顶点之间高度落差

定义落差大小，可依照实际情形调整大小。


9.8 流动层特征种子填色

把流动层上高度不为零的一个连通区域内的顶点置为当前颜色。

* 操作步骤：

1）选择命令“颜色--流动层特征种子填色”。

2）在待填色的流动层特征上单击鼠标左键。


9.9 流动层整体着色

把流动层上高度不为零的所有顶点置为当前颜色，如图。

图9-10流动层整体着色

* 操作步骤：

1） 按快捷键‘B’或选择命令“颜色--流动层整体着色”。


9.10 颜色区域膨胀/收缩

颜色区域膨胀或收缩。

* 操作步骤：

1） 选择命令“颜色--颜色区域膨胀/收缩”。

2） 设置参数----膨胀或收缩。

3）在待膨胀或收缩的颜色区域内单击鼠标左键。


9.11 颜色区域矢量化

用二维曲线拟合颜色区域的边界，如图9-11。

图9-11颜色区域矢量化

* 操作步骤：

1） 选择命令“颜色--颜色区域矢量化”。

2） 设置参数。

3）在待矢量化的颜色区域内单击鼠标左键。


9.12 高度层次调整

刷子范围内，特征范围内或整个模型的顶点的高度值不同比例变换，如图9-12。

（左）调整后的特征（低层迅降） （中）原始特征 （右）调整后的特征（高层速升）

图9-12高度层次调整

* 操作步骤：

1） 选择命令“颜色--高度层次调整”。

2） 设置参数。

3）在待变换的区域内单击鼠标左键。


9.13 高度层次变换

特征范围内或整个模型的顶点的高度值按所选择的曲线变换，如图。

（左）变换后的特征 （中）原始特征 （右）变换后的特征

图9-12高度层次变换

* 操作步骤：

1） 选择命令“颜色--高度层次变换”。

2） 设置参数。

3） 在特征范围内或模型上单击鼠标左键。


9.14 当前颜色

在雕塑模型上拾取曲面顶点颜色作为当前颜色。

预操作

模型上有一些颜色区域。

* 操作步骤：

1）选择命令“颜色--当前颜色”。

2）在模型上单击左键，单击处曲面顶点的颜色即被设置为当前色，并显示于颜色工具条的右上方。

说明：只有当前颜色所定义的区域才能充当颜色模板。所以当前颜色命令是颜色模板功能的配套功能。


第九章 颜色工具

颜色在虚拟雕塑中的作用体现在四个方面（颜色工具菜单栏如图9-1所示）：

a、颜色模板，界定操作的影响范围。

b、定义区域，利用颜色区域生成浮雕。

c.、定义区域，利用颜色区域定义特征。

d.、给模型上色，观察效果。

图9-1 颜色工具菜单栏


10.1 磨光

交互式光顺模型，如图10-2所示。

(a) 去高补低磨光

(b) 原图　 (c) 仅补低磨光去掉左枝及上枝接合处的深沟

(d) 原图 (e) 仅去高磨光去掉测量或重构引起的飞点

图10-2 磨光

* 操作步骤：

1）选择命令“效果--磨光”。

2）设置参数，参数设置对话框如图10-3所示。

图10-3 磨光参数设置

3）调整刷子大小及磨光力度，在需要磨光处按下鼠标左键不动或移动鼠标，即可实现磨光。

磨光参数定义：

高度模式>>去高补低 | 磨光时，高点降低，低点升高。
高度模式>>仅补低 | 磨光时，高点不动，低点升高。
高度模式>>仅去高 | 磨光时，高点降低，低点不动。
颜色模板 | 规定颜色模板如何影响磨光的范围。


10.2 整体磨光

雕塑模型整体自动光顺一次。

* 操作步骤：

选择命令“效果--整体磨光”。


10.3 糙化

磨光的逆操作，交互式粗糙化模型。

* 操作步骤：

1）选择命令“效果--糙化”。

2）设置参数，参数设置对话框如图10-4所示。调整刷子大小及高度值，参数意义在参数定义中说明。

图10-4 糙化参数设置

3）在需要糙化处按下鼠标左键不动或移动鼠标，即可实现糙化。

糙化参数定义：

高度 | 糙化颗粒的高度值。
高度分布>>上 | 糙化颗粒叠加拼合于模型表面上。
高度分布>>中 | 糙化后，模型表面高度增加值及降低值皆为颗粒高度值的一半。
高度分布>>下 | 糙化颗粒切除拼合于模型表面上。
磨光次数 | 糙化后，系统内部对糙化区域磨光的次数。


10.4 拼贴画

交互式生成由小正方形平面逼近模型的效果。

* 操作步骤：

1）选择命令“效果--拼贴画”。

2）设置参数，参数设置对话框如图10-5所示。参数意义在参数定义中说明。

图10-5 拼贴画参数设置

拼贴画参数定义：

单元大小：小正方形边长，单位为模型XY方向的步长。一般取值范围为2—100个步长。

图10-6 右图为左图的拼贴画效果


10.5 马赛克

交互式生成马赛克纹理效果。

* 操作步骤：

1）选择命令“效果--马赛克”。

2）设置参数，参数设置对话框如图10-7所示。参数意义在参数定义中说明。

图10-7 马赛克参数设置

3）调整能刷子大小及有关参数。在需要马赛克纹理处按下鼠标左键不动或移动鼠标，即可实现马赛克效果， 如图10-9。

马赛克参数定义：

单元大小 | 小正方形边长，单位为模型XY方向的步长。
沟宽 | 相邻马赛克之间沟的宽度，以模型步长为单位。
沟深 | 沟的深度。


10.6 墙砖

交互式生成三维墙砖纹理。

* 操作步骤：

1）选择命令“效果--墙砖”。

2）设置参数，参数设置对话框如图10-8所示。参数意义在参数定义中说明。

3）调整能刷子大小及有关参数。在需要墙砖纹理处按下鼠标左键不动或移动鼠标，即可实现墙砖效果， 如图10-9。

墙砖参数定义：

水平宽度 | X方向砖的尺寸， 以模型步长为单位。
垂直高度 | Y方向砖的尺寸， 以模型步长为单位。
沟宽 | 沟的宽度， 以模型步长为单位。
沟深 | 沟的深度。

图10-9 糙化/马赛克/墙砖


10.7 过程纹理

生成各种纹理并叠加于模型上。

* 操作步骤：

1）选择命令“效果--过程纹理”。

2）设定参数后按确定系统生成纹理并叠加于模型之上。

过程纹理参数定义

纹理类型>>地形 | 生成地形纹理。
纹理类型>>木纹 | 生成木纹。
纹理类型>>大理石 | 生成大理石纹理。
选代次数 | 控制表面细节。
碎裂程度 | 控制纹理碎裂程度。
X周期数 | 控制X方向纹理密度。
Y周期数 | 控制Y方向纹理密度。
高度 | 纹理的高度值。
拼合方式 | 规定所生成纹理如何拼合到模型上。

选代次数= 4

碎裂程度= 0.5

X周期数 = 10

Y周期数 = 10

高 度 = 1

图10-11 地形纹理

选代次数= 6

碎裂程度= 0.5

X周期数 = 10

Y周期数 = 10

高 度= 1

图10-12 地形纹理

选代次数= 4

碎裂程度= 0.8

X周期数= 10

Y周期数= 10

高 度= 1

图10-13 地形纹理

选代次数= 4

碎裂程度= 0.5

X周期数= 10

Y周期数= 50

高 度= 1

图10-14 地形纹理

选代次数= 4

碎裂程度= 0.5

X周期数=50

Y周期数= 50

高 度= 1

图10-15 地形纹理

选代次数= 4

碎裂程度= 0.5

X周期数=6

Y周期数=6

高 度= 0.2

图10-16 木纹

选代次数= 4

碎裂程度= 0.5

X周期数=10

Y周期数=300

高 度= 0.6

图10-17 地形纹理(纸纹)


10.8 印象派

把高度差较大的模型转变为近似平面(一般新模型高度小于0.5mm)的，由纹理走向及纹理密度反映原模型高度变化的新模型，如图10-18、图10-19所示。

选代次数= 4 碎裂程度= 0.25 X周期数=8 Y周期数=8 Z周期数=8 高 度= 0.3

图10-18木纹印象效果

选代次数=6 碎裂程度= 0.6 X周期数=8 Y周期数=8 Z周期数=8 高 度= 0.5

图10-19印象派效果

图10-20 印象派参数设置

印象派参数定义

其参数与过程纹理中的参数类似。

说明：印象派效果生成时间比较长。


10.9 雨中池塘

模拟下雨时，池塘的水面效果。

* 操作步骤：

1）选择命令“效果--雨中池塘”。

2）设置参数。

图10-21 雨中池塘参数设置

3）在模型上按下鼠标左键，即可观察到雨中池塘的效果。刷子高度参数控制雨滴大小，刷子半径控制雨滴密度。按下鼠标左键移动，能看到水面有一条鱼游动的效果。

雨中池塘参数定义

水波衰减系数：控制水波在向外扩散时衰减的快慢程度，大于1.0将产生共振，等于1.0不衰减，小于1.0衰减。

说明：

1、雨中池塘命令常用于演示及娱乐目的，实际应用很少。

2、雨中池塘是定义在整个模型上的操作，模型的顶点数不能太多，一般不能超过1万个顶点，否则响应速度较慢。可用新建模型命令生成一个不超过1万个顶点的平面，然后在该模型上体会雨中池塘的效果。顶点数=（长/步长）X（宽/步长）。


10.10 凹版画

把高度差较大的模型转变为近似平面，轮廓边缘带沟槽的版画效果，如图10-22所示。

图10-22 版画效果

* 操作步骤：

1）选择命令“效果--凹版画”。

2）设置参数后点击确定按钮。

图10-23 凹版画参数定义

凹版画参数定义

深度 | 转为版画后，模型的实际高度差。
说明 | 如果高度差较小，宜使用地图方式显示。


10.11 纹理填充

交互式在雕塑模型涂抹各种预定义的纹理，如图9-24所示。

(a) 原图 (b)填充纹理后

图9-24 纹理填充

* 操作步骤：

1）选择命令“效果--纹理填充”。

2）调整刷子大小， 设置参数后按下鼠标左键在模型上涂抹即可。

纹理填充参数定义

纹理类型 | 纹理单元与刷子，体素完全通用。
单元尺寸 | 纹理单元尺寸。
单元间距>>X间距 | 纹理单元填充于模型上后，X方向相邻纹理单元中对应点之间在水 [image] 平方向的间距，通常与纹理单元X方向尺寸相同。
单元间距>>Y间距 | 纹理单元填充于模型上后，Y方向相邻纹理单元中对应点之间在垂直方向的间距，通常与纹理单元Y方向尺寸相同。
单元间距>>行间错位 | 纹理单元填充于模型上后，Y方向相邻纹理单元中对应点之间在水平方向的间距， 通常为零或为纹理单元X方向尺寸的一半。
拼合方式 | 纹理单元与雕塑模型的拼合方式。
颜色模板 | 颜色如何界定操作的影响范围。


第十章 效果工具

效果工具（如图10-1）主要用于模型的后期处理，添加各种纹理。

图10-1 效果工具菜单栏