欢迎使用精雕软件

JDPaint是精雕科技多年来一直致力研制开发的、具有自主版权的、功能强大的专业雕刻CAD/CAM软件。JDPaint是精雕CNC数控雕刻系统正常运作的保证，也是有效提高CNC雕刻系统使用效率和产品质量的源泉。

JDPaint专业雕刻软件经过多年的发展完善，功能日趋丰富强大，不仅突破了如曲面浮雕、等量切削等多项关键雕刻设计及加工技术，也充分保证了软件产品的易用性和实用性，极大地增强了精雕CNC雕刻机的加工能力和对雕刻领域多样性的适应能力。在应用领域上，JDPaint软件已经彻底突破了适合标牌、广告、建筑模型等较为传统的雕刻应用范畴，在技术门槛更高的工业雕刻领域，如滴塑模、高频模、小五金、眼镜模、紫铜电极等制作业，表现同样出色，成为国内最优秀的雕刻软件。

目前，JDPaint已由较为单一的雕刻设计加工软件，逐步走向面向CNC产品加工的一整套解决方案。

产品服务:

精雕科技网址 www.jingdiao.com

问题反馈E-mail： soft@jingdiao.com

软件开发部电话：010-60803959, 010-60803960

精雕科技总机： 010-60801188

销售热线：010-51922006/7　　E-mail：market@jingdiao.com


前 言

数控加工是CAD/CAM技术最能明显发挥效益的生产环节之一。它可以保证产品达到极高的加工精度和稳定的加工质量，操作过程容易实现自动化，生产效率高；生产准备周期短，可以大量节省工艺设备，能够满足产品快速更新换代的需求；它与CAD衔接紧密，能够使用CAD设计的数字模型直接生成数控加工的指令，从而驱动数控机床进行生产制造。

JDPaint5.0本着简单、实用、易用的原则开发实现了生成刀具路径的CAM部分功能。在生成路径时，它能够让用户仅从加工工艺的需求出发生成路径，从而大大地降低了对数控编程需求的门槛，降低了对使用者所需基础知识的要求。对于初学用户，它允许用户仅输入几个关键数据或使用一些缺省值方便的生成路径。对于一些水平较高的用户，它能够提供一些非常精细的参数接口，以便用户能够生成加工效率很高的路径。

针对加工模型的复杂程度不同，以及加工工艺的成熟度不同，JDPaint5.0提供了两种生成路径的方法，即：加工向导和路径模板。加工向导适用于新工艺或复杂模型的加工，而路径模板更适用于成熟工艺或简单模型的加工。二者也可以结合使用，先使用路径模板生成一些常规路径，再用加工向导生成一些精修路径。利用加工向导，用户既可以只输入几个常用参数，也可以对高级参数进行精细调整，从而生成路径。而使用路径模板，用户应当根据需要先调整好若干套工艺方法，而后只用选择加工图形，再选择一组路径模板，无需输入任何参数便能生成一组路径。

在3D环境下生成刀具路径的流程如图0-1所示。在仔细阅读了这个流程以后，相信读者对生成路径的过程就有了大概的认识。

图0-1 流程图

相对2D下的加工而言，SurfMill的最大特点是利用工艺树管理加工路径、利用路径编辑功能修改路径以及利用加工面生成复杂模型的多个面上的路径。工艺树是应用程序界面右侧的一个树状结构。它记录了整个路径的生成过程，各路径所使用的参数、图形等。用户可以方便地编辑路径所用的参数和图形。路径编辑功能为用户提供了随意修改或调整路径的手段。利用该功能，用户可以根据需要适当修改路径，使加工更为合理有效。有许多模型都需要多面同时生成路径以便加工，譬如首版、鞋模等。通常，在生成这些路径时，用户需要反复翻转、对齐模型，然后生成加工路径。而SurfMill提供了加工面，它允许用户在不旋转模型的情况下，通过定义加工平面，生成各方向上的加工路径。

SurfMill1.0是北京进取者软件技术有限公司基于JDPaint 5.0软件平台开发的曲面设计与加工软件。本说明书为SurfMill 1.0使用手册，分上下两册，上册是曲面设计部分，下册是曲面加工部分。

本书是下册，主要讲述了曲面加工的内容。本书共分十章，各章主要内容如下：

第一章介绍了如何使用路径向导生成刀具路径。本章旨在让用户了解生成路径的过程。其中也简要的介绍了一些参数的意义，而对这些参数用法的详细了解需要在后续的章节中获得。

第二章介绍了刀具和刀具库。这一章先对刀具的类型、用途等作了较详细的介绍，然后讲述了如何管理应用刀具库。

第三章介绍了如何编辑和管理材料库。不同的材料有不同的加工属性，对应不同的切削用量。材料库中提供了在雕刻加工中常用的材料。在生成刀具路径时，用户仅需选择材料，系统便能自动设置一些与材料有关的切削参数。

第四章介绍了SurfMill 1.0提供的各种加工方法、走刀方式。任何加工方法都有其特点和适用范围。它们应当结合使用，以便最大限度的发挥加工的效能。本章详细介绍了SurfMill 1.0的各种加工方法的特点、适用范围以及各种加工方法所特有参数的精确含义和用法。

第五章介绍了SurfMill 1.0中各种加工方法的公共参数，如：雕刻深度、雕刻余量、下刀方式、进刀方式、刀具参数、雕刻精度、雕刻顺序等。尽管各种加工方法的差异较大，但它们有许多参数却是相同的。这里对一些公共参数作了较详细的说明。用户在学习完本书后还应当反复阅读第四章和第五章，结合实际加工反复琢磨，相信能领会到很多高效的加工方法。

第六章介绍了如何使用计算模板生成路径，如何创建、编辑适合自己使用的计算模板。在未来的日子里，精雕科技公司将根据用户的需求情况，提供更多的成熟工艺的计算模板，以方便广大用户的使用。

第七章介绍了如何将刀具路径转换成加工文件，加工文件是驱动雕刻机工作的数据文件。

第八章介绍了加工模拟的用法。加工模拟在加工过程中有着举足轻重的作用。在用生成的路径进行加工前必须进行加工模拟，以便尽早发现错误，避免不必要的损失。

第九章介绍了如何使用路径节点编辑功能对路径进行修剪、编辑，它包括对路径节点的增删修改，对路径的删除和排序等，以便满足加工的需要。

第十章介绍了如何使用工艺树。运用应用程序右侧的工艺树，用户可以一目了然地看到路径的加工顺序，能够方便地增加、删除路径，能够方便地编辑生成路径所涉及的参数。总之，利用工艺树，用户可以方便地访问与路径有关的所有命令。

第十一章介绍了平面路径的一些功能。包括平面路径的排序、变换、分离和组合等。


选择加工材料

1.5 选择加工材料

雕刻加工材料是雕刻加工中很关键的因素，它影响雕刻加工的切削用量，如主轴转速、走刀速度等等。路径向导对话框的设定切削用量页面如图1-22所示。该对话框主要包括雕刻材料和切削用量两组参数。

图1-22 “设定切削用量”对话框

1.5.1 选择雕刻材料

“设定切削用量”对话框的左侧为系统材料库列表，每种材料都记录了相应的加工性能。选择一种加工材料，右侧的用刀参数都会有相应的变化。用户可以根据经验修改这些切削用量，也可以将一些常用材料的切削用量设置到自己的材料库中。

在“设定切削用量”对话框页面的材料树状列表中，用户也可以单击鼠标右键，系统弹出浮动菜单，如图1-23所示。通过该菜单，用户可以方便地访问材料库。具体的操作方法请参见第三章材料库。

图1-23快速访问材料库

1.5.2 设置切削用量

右上角的图片为关于进刀参数的示意图片。右下角为切削用量参数，它包括：

主轴转速 | 加工时主轴的旋转速度，以“转/分”为单位。对同一把刀具，该值越大，加工时的切削速度越大。
进给速度 | 切削加工时刀具的移动速度，以“米/分”为单位。
吃刀深度 | 该参数在分层加工中有用。对切削深度与该值的商值取紧邻的上限整数即为分层的层数。在需要分层加工时，设置该值系统可以自动设置分层参数。
开槽深度 | 该参数在粗加工中有用。当需要开槽时，设置某个开槽深度，系统会自动设置与开槽有关的所有参数。若不需要开槽，将该值设置为0即可。
路径间距 | 平行截线加工的路径间距，或其他行切走刀时的路径间距。
下刀角度 | 主要在粗加工时防止扎刀，添加下刀路径时使用。在设置若干度的下刀角度后，系统会根据实际情况自动生成下刀路径。当该参数被设置为0时，便不会生成下刀路径。
进刀方式 | 该参数用于生成切入切出的路径。它只在曲线雕刻、轮廓雕刻、修边雕刻以及三维清角雕刻时有用。对于切入切出，共有四个选项，即：关闭、直线连接、直线相切、圆弧相切。选择一种进刀方式，系统会首选该方法来切入切出。若该方法不能生成无干涉的切入切出路径，系统会自动匹配其他方法，直至生成进刀路径为止。如果所有方法都不能生成，就没有进刀路径。

吃刀深度、开槽深度、路径间距、下刀角度在某些加工方法和走刀方式下没有意义，会被置灰。

在设定切削用量页面中，我们使用缺省参数，点击“下一步”，系统会根据雕刻加工方法、雕刻刀具和雕刻材料自动匹配生成一套加工参数。


选择雕刻加工方法

1.3 选择雕刻加工方法

在图1-5所示的构建加工域导航对话框中，单击“下一步”按钮，出现加工向导对话框，如图1-6所示。

图1-6 设定雕刻范围对话框

在加工向导对话框的前三个页面中集中了各种加工方法的最常用参数，而且它可以根据用户的选择自动匹配随后的部分参数，基本可以让用户仅从加工工艺出发，由系统自动匹配生成路径所需的计算参数。而在加工向导对话框的第四个页面中列出了与用户所选加工方法相关的所有参数。这便能让那些已经熟练掌握JDPaint5.0加工的用户自由地设置参数。我们建议，初学者不要修改第四页加工参数对话框中的内容。

根据所选图形类型的不同，系统会自动匹配对这类图形最常用的加工方法。若自动匹配的加工方法不是用户打算使用的，用户可以从左侧的加工方法树中方便的挑选适合的加工方法。

在选择某种加工方法和该加工方法所对应的某种走刀方式后，对话框右上角的预览图片会自动的变化。对话框右下角的部分参数同样会根据加工方法和走刀方式的不同而出现相应的变化。

1.3.1 雕刻加工图形

SurfMill中的各种雕刻加工方法被分列在钻孔雕刻、轮廓雕刻、区域雕刻、曲面雕刻和投影雕刻等五个雕刻方法组中。不同的雕刻方法所需的雕刻图形和应用范围也不尽相同。

JDPaint5.0提供的各种加工方法、所需图形及其应用范围，请参见表1.1。

表1.1 JDPaint5.0中的各种加工方法

类别 | 雕刻组 | 雕刻方法 | 所需图形 | 应用范围
平面雕刻 | 钻孔雕刻组 | 钻孔雕刻 | 点、曲线 | 对孔进行加工。
 |  | 扩孔雕刻 | 点、曲线
 | 轮廓雕刻组 | 单线雕刻 | 曲线、文字 | 沿某条曲线进行切割。
 |  | 轮廓切割 | 轮廓曲线、轮廓文字 | 沿某个轮廓进行切割。
 | 区域雕刻组 | 区域粗雕刻 | 轮廓曲线、轮廓文字 | 用于除去平面加工中的大量材料。
 |  | 残料补加工 | 轮廓曲线、轮廓文字 | 用小刀对大刀加工未到达的位置加工处理
 |  | 区域修边 | 轮廓曲线、轮廓文字 | 对区域的侧壁进行加工处理。
 |  | 三维清角 | 轮廓曲线、轮廓文字 | 用大头刀或锥刀清除多条线交点附近的区域，以便棱角分明。
曲面雕刻 | 曲面雕刻组 | 分层区域粗雕刻 | 曲面、轮廓边界 | 一种曲面加工，大量去除材料，使用广泛。
 |  | 投影加深粗雕刻 | 曲面、轮廓边界 | 曲面加工中去除大量材料，使毛坯接近模型。
 |  | 曲面残料补加工 | 曲面、轮廓边界 | 是分层区域粗雕刻的补加工，去除残余料，为精雕刻作准备。
 |  | 曲面精雕刻 | 曲面、轮廓边界 | 对粗加工后的毛坯进行精修处理，以便达到零件的精度要求。
 |  | 成组平面加工 | 曲面 | 对一组比较平坦的曲面进行精加工。
 |  | 残料清根 | 曲面、曲线 | 用小刀对大刀加工的残留部分进行处理加工。
 |  | 旋转雕刻 | 曲面 | 用于雕刻柱状零件。
 | 投影雕刻组 | 投影雕刻 | 曲面、路径 | 将路径或曲线投影到曲面上进行加工。一般用于在曲面上刻字或沟槽。
 |  | 包裹雕刻 | 曲面、路径 | 将路径按长度不变原则包裹在一些形体上进行加工。

有关雕刻加工方法的详细介绍，请参考第四章“雕刻加工方法”。

1.3.2 雕刻加工范围

雕刻加工范围用于界定雕刻加工中的高度范围等相关参数，主要包括：

表面高度 | 决定路径起始的位置。缺省值为所选图形最高点的高度。平面图形为0或上次使用该方法加工的表面高度。
雕刻深度 | 决定加工的深度范围。缺省值为所选图形最高点与最低点的高度差。对于平面图形，该值被设置为1.0或上次使用该方法加工的雕刻深度。在加工过程中，用户应当根据需要设置深度值。
侧面角度 | 该参数决定由曲线构成边界处侧壁的倾斜角度。当边界曲线不存在时，该参数没有意义。
雕刻余量 | 主要是为后续加工预留一些切削量，以便保证最后生成零件的表面质量。对于曲面雕刻，该参数为曲面的表面余量；对于区域雕刻或者轮廓切割，该参数为雕刻的侧边余量。

不同的雕刻方法，限定雕刻加工范围的四个参数也不尽相同，请参考表1.2。

表1.2 JDPaint5.0中的各种加工方法的雕刻范围

类别 | 雕刻组 |  |  | 表面高度 | 雕刻深度 | 侧面角度 | 雕刻余量
平面雕刻 | 钻孔雕刻组 |  |  | √ | √ | — | —
 | 轮廓雕刻组 |  | 允许半径补偿 | √ | √ | √ | √
 |  |  | 关闭半径补偿 | √ | √ | — | √
 | 区域雕刻组 |  |  | √ | √ | √ | √
曲面雕刻 | 曲面雕刻组 | 残料清根、旋转雕刻 |  | √ | √ | — | √
 |  | 其他 |  | √ | √ | √ | √
 | 投影雕刻组 |  |  | √ | √ | — | √

1.3.3 雕刻方法参数

各种雕刻方法都有各自的常用雕刻参数。为了便于用户访问修改这些参数，这些参数被集中在了路径向导对话框中。当用户选择不同的加工方法时，路径向导对话框中的这些常用参数就会跟随着变化。下面介绍一下这些常用参数。

1、扩孔雕刻

扩孔雕刻需要输入扩孔方式和扩孔直径，如图1-7所示。扩孔直径是孔的直径尺寸，如果扩孔直径比刀具直径小，那么系统就不能生成刀具路径。

图1-7 扩孔雕刻参数

2、单线雕刻

单线雕刻通常关闭半径补偿，也就是说刀具沿着曲线运动。用户也可以设置半径补偿方向，如图1-8所示。

图1-8 单线雕刻参数

3、轮廓切割

轮廓切割的半径补偿方向通常向外偏移，也就是说刀具在轮廓外部运动。用户也可以设置半径补偿方向，如图1-9所示。

图1-9 轮廓切割参数

4、区域粗雕刻

区域粗雕刻通常采用行切走刀方式，行切方向和X轴正向的夹角称为路径角度，如图1-10所示。在一些规则区域中也可以使用环切或螺旋走刀方式，以便提高雕刻效率。点击走刀方式下拉列表框，用户可以改变区域粗雕刻的走刀方式。

图1-10 区域粗雕刻参数

5、残料补加工

残料补加工要求用户输入上把刀具的直径，如图1-11所示。残料补加工主要针对锥刀和平底刀，刀具直径指刀具的底直径。计算残料时，系统默认为上把刀具和当前刀具的类型相同。

图1-11 残料补加工参数

6、分层区域粗雕刻

分层区域粗雕刻是最常用的曲面粗加工方法。主要参数包括走刀方式和边界处理方式。这里的走刀方式和区域加工中的含义完全一致。当用户没有选择边界时，系统可以按照三种方式处理刀具路径，参见图1-12。

图1-12 分层区域粗雕刻参数

7、投影加深粗雕刻

投影加深粗雕刻用于较平缓曲面的粗雕刻，主要参数包括走刀方式和路径角度，如图1-13所示。

图1-13 投影加深粗雕刻参数

8、曲面残料补加工

曲面残料补加工是一种半精加工方式。当使用分层区域粗雕刻加工时，可能在内角位置或者相邻两层之间留下很大的残留量。如果直接使用精雕刻，那么对刀具的损害比较大，甚至折损刀具。这时可以使用曲面残料补加工方式。主要参数如图1-14所示，其中无边界时的参数一定要与分层粗加工的一样。走刀方式在系统中默认为环切。

图1-14 曲面残料补加工参数

9、曲面精雕刻

曲面精雕刻提供了多种走刀方式，用于不同的雕刻场合。各种走刀方式中数平行截线走刀方式的应用范围最广。图1-15为选择曲面精雕刻时显示的参数页面。

在选择平行截线走刀时，最后一行的“无边界时”参数可以选择不用边界或提取边界。

图1-15 曲面精雕刻参数

最后一行的提示会随着走刀方式的改变而有所不同。当选择曲面流线走刀时，最后一行提示流线的方向，用户可以选择沿着U向或是V向；而在选择等高外形走刀时，最后一行的“无边界时”参数有三种选择，即：用实体零件边界、型腔模具边界和自动提取边界。这些边界对加工路径的影响请参见第四章中的相关说明。

10、成组平面雕刻

成组平面的走刀方式和区域粗雕刻的走刀方式完全一致，参见图1-16。

图1-16 成组平面雕刻参数

11、残料清根

残料清根包括三种不同的清根方式。点击清根方式，用户可以选择合适的清根方式，如图1-17所示。

图1-17 残料清根参数

12、投影雕刻

投影方式用于确定投影路径的高度。选择保留原有深度，系统将保留原有路径的相对深度关系。图1-18为投影雕刻的参数页面。

图1-18 投影雕刻参数

13、包裹雕刻

包裹雕刻是投影雕刻的拓展。除了投影方式外，包裹雕刻还包括包裹中心和包裹方向，如图1-19所示。

图1-19 包裹雕刻参数

在设定雕刻范围页面中，我们选择区域雕刻组中的区域粗雕刻。设定完成后，点击“下一步”，系统进入路径向导的刀具选择页面。


选择雕刻刀具

1.4 选择雕刻刀具

在路径向导的刀具选择页面中，用户可以选择雕刻加工刀具，并设定加工的一些常用参数，如雕刻加工精度等，如图1-20所示。该对话框主要包括雕刻刀具和路径计算设置两组参数。

图1-20“选择雕刻刀具”对话框

1.4.1 选择雕刻刀具

在左侧的树状列表框中列出了系统中的所有刀具。用户只需选择一把刀具进行加工即可。目前系统为我们选择的缺省刀具为ф2的球头刀。因为是曲面精加工，系统优先选择使用球头刀进行加工。

雕刻刀具大致分为以下几类：

平底刀 | 又叫柱刀，主要依靠侧刃进行雕刻，底刃主要用于平面修光。柱刀的刀头端面较大，雕刻效率高，主要用于轮廓切割、铣平面、区域粗雕刻、曲面粗雕刻等。
球头刀 | 球刀的切削刃呈圆弧状，雕刻过程中受力均匀，切削平稳。球刀的刀刃在雕刻过程中形成一个半球体，带有一定的弧度，所以特别适合于曲面雕刻，常用于曲面半精雕刻和曲面精雕刻。球刀不适合于铣平面。
牛鼻刀 | 牛鼻刀是柱刀和球刀的混合体，它一方面具有球刀的特点可以雕刻曲面，另一方面具有柱刀的特点可以用于铣平面。
锥度平底刀 | 简称锥刀。锥刀在整个雕刻行业的应用范围最广。锥刀的底刃，俗称刀尖，类似于柱刀，可以用于小平面的修光，锥刀的侧刃倾斜一定的角度，在雕刻过程中形成倾斜的侧面。锥刀在构造上的特点可以使得它能够实现雕刻行业特有的三维清角效果。锥刀主要用于单线雕刻、区域粗雕刻、区域精雕刻、三维清角、投影雕刻、图像灰度雕刻等。
锥度球头刀 | 简称锥球刀。锥球刀是锥刀和球刀的混合体，它一方面具有锥刀的特点，具有很小的刀尖，另一方面又有球刀的特点，可以雕刻比较精细的曲面。锥球刀常用于浮雕曲面雕刻、投影雕刻、图像浮雕雕刻等。
锥度牛鼻刀 | 锥度牛鼻刀是锥刀和牛鼻刀的混合体，它一方面具有锥刀的特点，可以具有较小的刀尖，雕铣比较精细的曲面，另一方面又有牛鼻刀的特点，所以锥度牛鼻刀常用于浮雕曲面雕刻。
大头刀 | 实质为头部锥角较大的锥刀。主要用于三维清角。
钻孔刀具 | 主要用于钻孔。当孔比较浅时，可以用平底刀钻孔。

1.4.2 快速访问刀具库

在“选择雕刻刀具”对话框页面的刀具树状列表中单击鼠标右键，会弹出浮动菜单，如图1-21所示。在该菜单中，用户可以创建、编辑或删除雕刻刀具。关于对刀具库的具体操作，请参见第二章刀具和刀具库中的说明。

图1-21快速访问刀具库

1.4.3 修改计算设置

在对话框的右下角为与计算设置相关的参数，它包括：

逼近方式 | 可以在此选择圆弧或线段逼近。
加工精度 | 该值为弓高误差，可以决定路径拟合时的精度。
走刀方向 | 可以选择顺铣或逆铣。一般粗加工用逆铣，精加工用顺铣。
雕刻顺序 | 主要对分区域加工的情况有效。可以是区域优先，或是高度优先。
平坦系数 | 生成曲面加工路径时使用的网格精度。该值越小，生成路径的精度越高，但是，所耗费的内存越多，计算时间越长。该值一般不得小于0.05。


构建或选择加工域

1.2 构建或选择加工域

所谓加工域是指用二维图形、三维曲线或曲面等各种图形构成的加工范围。它是由模型的部分元素和一些边界构成的。启动路径向导命令后，在应用程序右侧的导航工具栏中会出现关于图形选择功能的窗口，如图1-3所示。通过选择加工图形，可以获得加工域。

用户有两种方法选择图形，构成加工域。一种是用新建的方法，通过选择图形构成；另一种是选择原有的加工域，作为新生成路径的加工域。这里，由于是生成第一个路径，系统中无其他加工域，故“选择”单选按钮处于灰色的无效状态。

在生成新的加工域时，可以先在名称编辑框中输入加工域的名称，也可以使用缺省名称，之后选择图形构成加工域。为了方便用户选择，系统将各种类型的图形区分开，每次只能选择同一种类型的图形，即导航对话框中当前选中的图形类型。系统中可供选择的加工图形共有五种类型：点、曲线、曲面、路径和毛坯表面。当某类型复选框是选中状态时，则该类型图形便可以被选择或者去掉。

图1-3 选择生成路径的图形

在选中某类图形时单击“全选”按钮，则当前显示的该类图形被全部选择。若单击“清除”按钮，则被选中类型的图形全部被清除，处于未被选中状态。除此之外，系统还提供与CAD系统中完全一致的图形拾取方法，即对各种类型图形的选择方式都包括单个拾取和窗口拾取，对曲线还提供串链拾取的方法。下面仅简要的介绍这三种拾取方法的用法，具体的可以参见图形拾取。

单个拾取 | 选择该选项，鼠标逐个点击欲拾取的对象，选中的对象将变换颜色显示。若需要去掉某个误选的对象，则按住Ctrl键，拾取误选的对象，即可从当前选择集中去除误选的对象。
窗口拾取 | 按下鼠标左键，移动鼠标，将出现一个随鼠标位置变化的方框。按照方框绘制的方式的不同，可以分为正选和反选两种方框。当先绘制方框左上角的顶点时，绘制的方框为正选方框，其余的为反选方框。被正选方框完全框住的图形和被反选方框碰到的图形将被选择。
串链拾取 | 只对曲线的拾取起作用。选择该选项时，用鼠标单击某条曲线，则凡是和该曲线两端点相接的线，以及与相接线另一端点相接的线都被选中。注意，串链拾取曲线时，新连接线的另一端点会作为新的连接点一直连下去，直到没有可连接的线为止。但当连接线的某端点处有两段或两段以上相联接的线时，串链拾取将在该点处结束。

当有多个加工域存在时，可以选择“选择”单选框，通过选择已有的某个加工域构成当前加工域。在选择“选择”单选框后，右侧的导航对话框如图1-4所示。在列表框中会列出已有的加工域。

图1-4 选择已存在的加工域

图1-5 选择所有曲面构成加工域

这里，我们选择所有曲面构成加工域。选中“曲面”复选框，单击“全选”按钮。所有曲面变为被选中颜色，在曲线复选框后会出现数字10，这表明有10个曲面被选择，如图1-5所示。


生成刀具路径

1.7 生成刀具路径

在如图1-24所示的“雕刻路径参数”对话框中单击“完成”按钮，出现计算进度条对话框，如图1-25所示。

图1-25 计算进度条对话框

在计算结束时，计算进度条对话框被关闭，路径生成，同时在右侧的加工工艺树中添加一个表示该路径的结点项，如图1-26所示。关于加工工艺树的用法请参见第十章“工艺树的使用”。

图1-26 成功生成一组路径

使用不同的雕刻方法，获得的刀具路径差异很大。用户可以尝试着使用路径向导生成各种路径。


路径计算参数表

1.6 路径计算参数表

系统自动匹配的加工参数，以树状结构的形式列举在路径向导的雕刻路径参数页面中，如图1-24所示。

图1-24 “雕刻路径参数”页面

“雕刻路径参数”页面的左侧为按照树状结构分类的各种参数，右上角为示意图，右下角为一组相关的参数区域。右上角的示意图和右下角中的参数都会随着用户选择左侧的不同参数节点而变化。系统中的雕刻参数主要包括五个方面：

雕刻方法 | 用于设定不同雕刻方法的走刀控制参数；
雕刻范围 | 用于设定雕刻加工的范围；
进给设置 | 用于设定雕刻加工的路径间距、分层控制、开槽控制、进刀方式、下刀方式等；
雕刻刀具 | 用于设定雕刻加工的刀具形状、走刀速度、操作设置；
计算设置 | 用于设定路径的计算精度、尖角方式、轮廓设置、走刀方向等；

点击左边的参数节点，系统自动刷新右边的参数对话框。用户修改对话框中的值将作为最终的计算参数。在进入路径向导的雕刻路径参数页面后，便不能再返回到前面的页面。在该页面中用户可以随意的设置与选择的雕刻方法相关的所有参数，也可以修改前面已经设置过的参数。对于右下角参数页面中各参数的含义及用法请参见第四章“雕刻加工方法”中的相应说明。


刀具路径计算向导

第一章 刀具路径计算向导

路径向导是最常用的刀具路径计算器，它能够非常方便地引导用户一步步生成刀具路径。使用路径计算向导共分为6个步骤，如图1-1所示。

图1-1 路径计算过程

不同步骤完成的主要任务是：

1、选择雕刻加工图形，选择需要雕刻加工的几何对象，包括点、曲线、文字、曲面、图片等。所有能被选择的对象都有对应的雕刻方法；

2、选择雕刻方法，系统根据选择的图形匹配合适的雕刻方法，并请求用户输入雕刻的深度范围、雕刻余量、侧面角度等参数；

3、选择雕刻刀具，系统根据雕刻方法和雕刻范围自动匹配合适的雕刻刀具，并请求用户输入常用的计算设置，如雕刻精度、雕刻次序、走刀方向等；

4、选择雕刻材料，请求选择雕刻加工材料，并根据材料和刀具计算一些切削参数，如主轴转速、走刀速度、吃刀深度、路径间距等；

5、生成雕刻加工参数，系统根据以上四步的参数匹配出一套比较合理的雕刻加工参数，熟练的用户可以修改不满足要求的参数；

6、生成刀具路径，系统根据选择的图形和设定的参数计算出具体的雕刻加工路径，并设置路径操作树。如果计算失败，系统将提示失败的原因，方便用户排错。

下面将以输入的一个IGES图形为例，具体介绍刀具路径的生成过程。


启动路径向导命令

1.1 启动路径向导命令

在构建好加工模型，准备生成路径时，首先切换到3D加工环境下。选择“刀具路径>>路径向导”菜单项，如图1-2所示。

图1-2 选择菜单项启动路径向导命令

路径向导命令启动后，系统会要求用户构建或选择一个加工域。


常用刀具

2.3.5 常用刀具

在刀具库中常用刀具的具体操作步骤如下：

（1）选择一把经常使用的刀具；

（2）点击“常用刀具”按钮，便将这把刀复制到常用刀具组中，如图2-14所示。

图2-1常用刀具

常用刀具组一般标记了用户加工时经常使用的几把刀，里面的刀具可以添加、删除。


刀具参数

2.2刀具参数

刀具参数分为刀具的几何形状参数和加工控制参数。这些参数分别在刀具对话框的几何参数页面和加工参数页面中。在创建新刀具或修改某刀具时都会使用刀具对话框。

2.2.1刀具的几何参数

在如图2-2所示的几何参数页面中，用户可以修改刀具的类型和几何参数。对话框中显示的几何参数会根据刀具类型的不同而变化。刀具的名称也会根据刀具的类型和几何参数自动生成。在“备注”编辑框中，用户可以对该刀具进行一些注解说明。

图2-2刀具对话框的几何参数页面

数控雕刻机使用的刀具类型包括柱刀、锥刀、球刀、牛鼻刀、锥球刀和各种成型刀等。不同类型的刀具具有不同的雕刻特点，适合于不同的雕刻场合。

1、平底刀

平底刀又称柱刀，主要依靠侧刃进行雕刻，底刃主要用于平面修光，如图2-3所示。柱刀的刀头端面较大，雕刻效率高，主要用于轮廓切割、铣平面、区域粗雕刻、曲面粗雕刻等。但是，柱刀的底刃切削能力差，在雕刻金属材料时尽量不要采用直线下刀方式，最好采用斜线下刀或螺旋下刀方式。

图2-3 平底刀

2、锥度平底刀

锥度平底刀简称锥刀，在整个雕刻行业的应用范围最广，这是雕刻行业的特点决定的。雕刻行业以精细加工为主，这就需要比较细小的刀具同时具有一定的强度。锥刀正好迎合了雕刻行业的这种需求。锥刀的底刃，俗称刀尖，它类似于柱刀，可以用于小平面的修光。锥刀的侧刃倾斜一定的角度，在雕刻过程中形成倾斜的侧面。锥刀的几何特点决定它可以实现雕刻行业特有的三维清角效果。锥刀主要用于单线雕刻、区域粗雕刻、区域精雕刻、三维清角、投影雕刻、图像灰度雕刻等。锥度刀的外形如图2-4所示。

图2-4锥度刀

3、球头刀

球刀的切削刃呈圆弧状，雕刻过程中受力均匀，切削平稳。球刀的刀刃在雕刻过程中形成一个半球体，带有一定的弧度，所以特别适合于曲面雕刻，常用于曲面半精雕刻和曲面精雕刻。球刀不适合于铣平面。球刀的外形如图2-5所示。

图2-5球头刀

4、牛鼻刀

牛鼻刀是柱刀和球刀的混合体，它一方面具有球刀的特点可以雕刻曲面，另一方面具有柱刀的特点可以用于铣平面。牛鼻刀的外形如图2-6所示。

图2-6牛鼻刀

5、锥度球头刀

锥度球头刀简称锥球刀，是锥刀和球刀的混合体，它一方面具有锥刀的特点，具有很小的刀尖，另一方面又有球刀的特点，可以雕刻比较精细的曲面。锥球刀常用于浮雕曲面雕刻、投影雕刻、图像浮雕雕刻等，其外形如图2-7所示。

图2-7锥球刀

6、锥度牛鼻刀

锥度牛鼻刀是锥刀和牛鼻刀的混合体，它一方面具有锥刀的特点，可以具有较小的刀尖，雕铣比较精细的曲面，另一方面又有牛鼻刀的特点，所以锥度牛鼻刀常用于浮雕曲面雕刻，其外形如图2-8所示。

2-8锥度牛鼻刀

2.2.2刀具的加工参数

切换到“加工参数”页面中，如图2-9所示。在该页面中，用户可以指定该刀具的材料类型，并根据加工工件材料的类型设定加工的一些系数和进给量。单击“自动计算”按钮，可以计算出加工速度参数。用户可以根据计算值和经验适当调整加工速度、冷却方式等。若此处未指定材料的类型，用户可以单击“加工材料”按钮，由弹出的材料库对话框中选择一种材料。这里设定的加工参数，将作为该刀具的缺省加工工艺参数出现在选择该刀具加工的运动工艺参数中。下面具体介绍各参数的意义。

图2-9 刀具参数对话框的加工参数页面

刀具材料 | 刀具的材料构成。加工不同材料的产品应当使用不同材料的刀具。刀具材料不同，加工性能也有较大的差异。
切削速度系数 | 对切削速度进行修正。一般而言，加工能力强的刀具切削速度系数较大。一般的刀具都取1.0。
进给量系数 | 对进给速度进行修正。和切削速度系数一样，加工能力强的刀具进给量系数较大。一般的刀具都取1.0。
刀具齿数 | 也叫刀具的刀刃数目。刀具齿数越多，进给速度就可以越大。
每齿每转进给量 | 由材料的每齿每转进给量、刀具形状和刀具的进给量系数共同影响决定。
侧向进给量 | 该值决定单边切削时的路径间距。该值由材料属性和刀具直径共同决定。
深度进给量 | 一般指粗加工时的切削深度。
开槽深度进给量 | 开槽双边切时的切削深度。该值由刀具直径和材料属性决定。
加工材料 | 用户可以单击“加工材料”按钮，从材料库中选择加工的毛坯材料。加工材料和刀具共同决定了切削用量。
主轴转速 | 加工时刀具的旋转速度。该值由切削线速度和刀具直径决定。
切割速度 | 单边切割时的走刀速度。该值由主轴转速、刀齿数目和每齿每转进给量决定。
下刀速度 | 指慢速下刀范围内的走刀速度。
进刀速度 | 指轮廓切割或单线加工时切入切出路径上的走刀速度。
开槽速度 | 开槽双边切时的走刀速度。
冷却方式 | 用户可以选择水冷却、油冷却或风冷却。
落刀延时 | 下刀后刀具停留该值设置的时间，之后再接着加工，主要是为了保护刀具。
慢速下刀距离 | 在靠近毛坯面时，应当降低落刀的速度。该距离值决定了从何处以较低的速度靠近零件。
自动计算 | 单击该按钮，系统会根据用户所选的刀具和材料计算进给量和加工速度组合框中的参数。用户可以对计算后的值根据需要进行适当调整。


刀具和刀具库

第二章　刀具和刀具库

使用CNC雕刻机加工产品使用的刀具型号多种多样，而且雕刻的材料非常广泛，硬到各类金属、大理石，软到PVC、发泡板、有机玻璃等。一句话，雕刻什么材质的产品，就要使用什么样的刀具。加工一个好的产品，只有一把好的刀具是不够的，还要看看刀具的型号、尺寸、刀具、材质、参数是否合适。所以用户需要了解刀具。

目前，雕刻机加工的产品越来越复杂，最终用户对产品的要求越来越高。要完成一个产品的加工，一般都需要使用多把刀具、多个工序才能实现。因此，用户需要对许多刀具进行管理。JDPaint5.0为用户提供了刀具库，以便用户能够方便的管理自己的刀具。下面，就从JDPaint5.0的刀具库开始，介绍刀具和刀具库。


刀具库

2.1刀具库

在JDPaint5.0系统中有一个刀具库。它使用一个缺省的文件来记录系统中的刀具。在JDPaint5.0系统启动时，JDPaint5.0安装目录中，Cfg目录下的ToolLib.tst文件会被自动加载。若该文件不存在，系统会自动创建缺省的刀具库。在退出刀具库对话框时，系统会自动更新缺省的刀具库文件，以便及时保存系统的刀具库。

系统共有以下几种方式访问刀具库：

1、在曲面加工环境下选择“刀具路径>>刀具库”菜单项。

2、在路径向导对话框的选择刀具页面中，对刀具库的树状结构单击鼠标右键访问。

3、在雕刻参数对话框的刀具形状页面中，选择“刀具库”按钮。

选择刀具库功能，会出现如图2-1所示的刀具库对话框。

图2-1 刀具库对话框

在刀具库对话框中选中某把刀具，单击“编辑”按钮，用户可以对该刀具进行编辑；单击“复制”按钮，会对当前选择的刀具进行复制；若单击“删除”按钮，则当前选中的刀具将被删除；单击“添加”按钮，可以在当前刀具组下面添加一种新的刀具；单击“添加组”按钮，可以在当前刀具组下面添加一个新的刀具组。在添加刀具或刀具组时，需要在刀具或刀具组的属性对话框中先设置属性参数，再单击“确定”按钮，便能添加相应的刀具或刀具组。单击“常用刀具”按钮，系统会在常用刀具库中为当前选中的刀具建立一份快捷索引。常用刀具库与系统刀具库并列，它保存系统刀具库中常用刀具的快捷索引。接下来，先结合刀具对话框对刀具参数进行一个简要的解释，再对刀具库的具体操作进行介绍。

注意：如果用户对常用刀具库中的刀具进行修改，则系统库中的该刀具被修改。如果用户删除常用刀具库中的某刀具，则删除的仅是快捷索引。系统库中的该刀具仍然存在。


添加刀具

2.3.2添加刀具

* 在刀具库中添加刀具的过程是：

1）选中新添刀具欲加到的刀具组或该刀具组下的某把刀具；

2）点击“添加”按钮，系统会弹出刀具对话框；

3）修改刀具参数的相关内容，点击“确定”退出。

图2-11为添加一把ф4.5的平底刀的过程示意图。

图2-11添加刀具


复制刀具

2.3.4复制刀具

* 在刀具库中复制刀具的过程是：

1）选中欲复制的刀具；

2）点击“复制”按钮，便复制一把刀具，如图2-13所示。

图2-13复制刀具

注意，有一把新的ф4平底刀添加在了平底刀刀具组的最后。于是该对话框下有两把同名的刀具。为了防止混淆，建议用户不要创建同名的刀具。一般而言，对于复制的刀具都应当进行编辑处理，以防止同名刀具的出现。


删除刀具

2.3.3删除刀具

* 在刀具库中删除刀具的过程是：

1）选中欲删除的某把刀具；

2）点击“删除”按钮，系统会弹出要求用户确认删除某刀具的对话框，如图2-12所示；

3）点击“确定”按钮，删除刀具。

图2-12删除刀具


编辑刀具

2.3.1编辑刀具

* 编辑刀具库中的刀具的过程是：

1）选中需要编辑的刀具；

2）点击“编辑”按钮，系统会弹出刀具对话框，如图2-10所示；

3）修改刀具参数的相关内容，点击“确定”退出。

图2-10编辑刀具


修改刀具

2.3修改刀具

对刀具的修改包括编辑或复制现有刀具、添加新的刀具以及删除现有的刀具。注意，在刀具库中，被使用的刀具呈加锁状态，它们不能被编辑或删除。


添加刀具组

2.4.2添加刀具组

* 在刀具库中添加刀具组的过程是：

1）选中新添刀具组欲加到的刀具组或该刀具组下的某把刀具；

2）点击“添加组”按钮，系统会弹出刀具组对话框；

3）修改刀具组的相关内容，点击“确定”退出。

图2-16添加刀具组

图2-16为添加一个刀具组的过程示意图。


删除刀具组

2.4.3删除刀具组

* 在刀具库中删除刀具的过程是：

1）选中欲删除的刀具组；

2）点击“删除”按钮，系统会弹出要求用户确认删除某刀具组的对话框，如图2-17所示；

3）点击“确定”按钮，删除刀具组。

图2-17删除刀具组


编辑刀具组

2.4.1编辑刀具组

* 编辑刀具库中的刀具组的过程是：

1）选中需要编辑的刀具组；

2）点击“编辑”按钮，系统会弹出刀具组对话框；

3）修改刀具组的名称或备注信息，点击“确定”退出。

图2-15为对大头刀刀具组进行编辑时出现的刀具组对话框。在该对话框中可以设定刀具组的名称，并写一些备注信息。

图2-15 刀具组对话框


修改刀具组

2.4修改刀具组

对刀具组的修改包括编辑现有刀具组、添加新的刀具组和删除现有刀具组三个功能。


材料

3.1 材料

加工材料设置主要设定加工零件的毛坯的材料类型。根据材料不同、加工性能不同，系统会为各种加工方法添加诸如下刀、进刀、开槽等辅助路径，会为粗加工自动设置分层加工，并为各种类型的走刀给出合理的走刀速度。

材料属性对话框共有两个页面，即基本属性和扩展属性。对于一般用户而言只需关心基本属性页面中的参数即可。图3-1为材料属性对话框的基本属性页面。

图3-1材料属性对话框的基本属性页面

在该页面中的参数有：

材料名称 | 为当前材料的名称。未设置材料的为未命名材料“No Name”。
单边切削深度/切削直径 | 该参数的大小可以决定刀具单边切削时的切削深度。
限定最大吃刀深度 | 选中改选项，可以限制切削的最大深度。当刀具直径较大，它与上述参数的乘积大于该值时，则使用该值。
开槽深度/切削直径 | 该参数决定了刀具作开槽加工时的开槽深度。
限定最大开槽深度 | 选中改选项，可以限制最大的开槽深度。当刀具直径较大，它与上述参数的乘积大于该值时，则使用该值。
侧向进给量/切削直径 | 该参数可以决定路径间距的大小。一般而言，材料越硬，该值越小，侧向进给越小。
下刀角度 | 为了保护刀具，防止扎刀，在下刀时需要使用螺旋或折线下刀。根据材料硬度不同，该参数大小也不同。一般而言，对于较软的非金属，无需下刀路径，该参数值设为0。对于黄铜、紫铜这样的较软的金属，下刀角度一般为3~5度。而对于较硬的钢材，下刀角度一般为1~2度。
限定最大切除率 | 切除率表达了加工效率的高低。对单边行切而言，切除率=切削深度*侧向进给量*走刀速度（立方厘米/分）。不同型号机床根据刚性不同，对不同材料有不同的最大切除率。它是机床切削能力的特性参数。当切削效率大于最大切削率时，机床处于超负荷工作状态。长时间处于超负荷工作状态，机床的精度等性能会大大下降。通过该参数限定计算路径的切除率，可以起到保护机床，防止蛮干的目的。
切削用量优化模式 | 有加工效率优先和刀具耐用度优先两种模式。根据所选模式不同，系统自动匹配不同的加工选项。
备注 | 在这里可以写一些提示性的注释文字。

切换到扩展属性页面中，如图3-2所示。在扩展属性页面中，有一些关于基本切削量的参数和对刀具材料和前后角建议值的参数。

图3-2 材料属性对话框的扩展属性页面

切削线速度 | 根据加工方法不同，刀具的切削量不同，切削线速度也应当在基本切削速度的基础上调节。一组关于加工方法的比例系数在列表中出现。用户可以根据需要单击某项的比例系数进行修改。
每齿每转切削量 | 根据刀具形状不同，每齿每转的切削量也可以不同，这也是通过一组比例系数进行调整。
推荐刀具 | 扩展属性页面的下部为推荐使用刀具的材料和前后角参数。


材料库

3.2 材料库

一般情况下，加工材料应当从材料库中选择。在材料对话框的基本属性页面中，单击“材料库”按钮，会弹出材料库对话框。此时，程序会访问JDPaint5.0安装目录中，Tool目录下的Material.mst文件，获取材料。如果该文件不存在，系统将创建缺省的材料库。用户可以根据需要新建材料和材料组。在退出材料库对话框时，系统会自动更新缺省的材料库文件，以便及时保存系统的材料库。

系统提供以下几种方式访问材料库：

1）在三维加工环境下选择“刀具路径>>材料库”菜单项。

2）在材料属性对话框中单击“材料库”按钮，调用材料库对话框。

3）在路径向导对话框中的材料树状列表框中通过鼠标右键访问材料库。

调用材料库功能，会出现如图3-3所示的材料库对话框。

选中某项材料，单击“编辑”按钮，用户可以对材料进行编辑；单击“复制”按钮，会对当前选择的材料进行复制；若单击“删除”按钮，则当前选中的材料将被删除；单击“添加”按钮，可以在当前材料组下面添加一种新的材料；单击“添加组”按钮，可以在当前材料组下面添加一个新的材料组。在添加材料或材料组时，需要在材料或材料组属性对话框中先设置属性参数，再单击“确定”按钮，便能添加相应的材料或材料组。

图3-3“雕刻材料库”对话框


材料和材料库

第三章 材料和材料库

加工材料对加工工艺的设定有举足轻重的影响。不同的材料在硬度、切削性等方面有很大差别。目前常用的加工材料分为金属和非金属。金属材料包括黄铜、铝合金、锌合金、紫铜、合金钢、不锈钢等，非金属材料主要有有机玻璃、PVC、ABS工程塑料、双色板、树脂、木材等。

一般来说，材料的硬度越大，等量切削需要的切削力就越大，刀具所需的强度就越大，刀具的磨损速度也越快。当刀具磨损比较严重时，切削力会明显增加，很容易断刀。因此，在金属加工中断刀现象比较常见。

在切削加工中，常用切削线速度来衡量材料的加工性能。相同的刀具在雕刻不同的材料时，总是有一个最大的切割线速度。在雕刻过程中，当切削线速度超过最大切削线速度时，刀具磨损会明显增加。切削线速度除了和加工材料有关外，还和刀具本身的材料有关，优质的刀具材料会明显提高切割线速度。另外，刀具的表面涂层处理也能提高刀具的切割线速度。但是，切削线速度也不能太低。因为切削速度太低，材料不易被切削掉。常用材料的切削速度范围如表3.1所示。

表3.1 常用材料的切削线速度范围

材料名称 | 最小切削速度(m/min) | 最大切削速度(m/min)
钢材 | 50.0 | 200.0
紫铜 | 70.0 | 300.0
黄铜 | 150.0 | 600.0
铝合金 | 170.0 | 1200.0
有机玻璃 | 170.0 | 1200.0

此外，不同的加工方法对切削线速度的要求也有所不同。譬如开槽时刀具双边受力，切削线速度就不宜过高。而区域粗加工时，刀具单边受力，切削速度就应当大一些。


添加材料

3.3.2 添加材料

* 在材料库中添加材料的过程是：

1）选中新添材料欲加到的材料组或该材料组下的某种材料；

2）点击“添加”按钮，系统会弹出材料对话框；

3）修改材料参数的相关内容，点击“确定”退出。

图3-5为添加一种“新添材料”的过程示意图。

图3-5添加材料


复制材料

3.3.4 复制材料

* 在材料库中删除材料的过程是：

1）选中欲复制的材料；

2）点击“复制”按钮，便复制一种材料，如图3-7所示；

图3-7复制材料

注意，有一种新的有机玻璃材料添加在了非金属材料组的最后。于是该对话框下有两个同名的材料。为了防止混淆，建议用户不要创建同名的材料。一般而言，对于复制的材料都应当进行编辑处理，以防止同名材料的出现。


删除材料

3.3.3 删除材料

* 在材料库中删除材料的过程是：

1）选中欲删除的某种材料；

2）点击“删除”按钮，系统会弹出要求用户确认删除某材料的对话框，如图3-6所示；

3）点击“确定”按钮，删除材料。

图3-6删除材料


编辑材料

3.3.1 编辑材料

* 编辑材料库中的材料的过程是：

1）选中需要编辑的材料；

2）点击“编辑”按钮，系统会弹出材料对话框，如图3-4所示；

3）修改材料参数的相关内容，点击“确定”退出。

图3-4编辑材料


修改材料

3.3 修改材料

对材料的修改包括编辑或复制现有材料、添加新的材料和删除现有的材料。


添加材料组

3.4.2 添加材料组

* 在材料库中添加材料的过程是：

1）选中新添材料组欲加到的材料组或该材料组下的某种材料；

2）点击“添加组”按钮，系统会弹出材料组对话框；

3）修改材料参数的相关内容，点击“确定”退出。

图3-9为添加一个材料组的过程示意图。

图3-9添加材料组


删除材料组

3.4.3 删除材料组

* 在材料库中删除材料组的过程是：

1）选中欲删除的材料组；

2）点击“删除”按钮，系统会弹出要求用户确认删除某材料组的对话框，如图3-10所示；

3）点击“确定”按钮，删除材料组。

图3-10删除材料组


编辑材料组

3.4.1 编辑材料组

* 编辑材料库中的材料组的过程是：

1）选中需要编辑的材料组；

2）点击“编辑”按钮，系统会弹出材料组对话框；

3）修改材料组的名称或备注信息，点击“确定”退出。

图3-8为对金属材料组进行编辑时出现的材料组对话框。在该对话框中可以设定材料组的名称，并写一些备注信息。

图3-8 材料组对话框


修改材料组

3.4 修改材料组

对材料组的修改包括编辑现有材料组、添加新的材料组和删除现有材料组三个功能。


加工方法

雕刻JDPaint5.0提供了多种雕刻方法，实现不同的雕刻加工效果。表4.1分类列举出了JDPaint5.0提供的所有雕刻加工方法。

表4.1 JDPaint5.0提供的各种雕刻加工方法

类型 | 组名称 | 雕刻方法 | 加工效果说明
平面雕刻类 | 钻孔雕刻组 | 钻孔雕刻 | 加工通孔、盲孔、定位孔、下刀孔等；
 |  | 扩孔雕刻 | 扩孔加工，也用于高速加工大直径通孔；
 | 轮廓雕刻组 | 单线雕刻 | 沿曲线进行雕刻，也用于不封闭边界修边；
 |  | 轮廓切割 | 切割封闭轮廓；
 | 区域雕刻组 | 区域粗雕刻 | 用于除去平面凹槽内的材料；
 |  | 残料补加工 | 用较小直径刀具修补上道工序雕刻残留的区域；
 |  | 区域修边 | 精修区域侧壁，提高边界的尺寸精度；
 |  | 三维清角 | 利用锥刀的特点最大程度的清除尖角部分的材料；
曲面雕刻类 | 曲面雕刻组 | 分层区域粗雕刻 | 复杂曲面模型的粗加工方法，去除材料效率高；
 |  | 投影加深粗雕刻 | 光滑曲面的粗加工方法，加工残留量小；
 |  | 曲面残料补加工 | 是分层区域粗加工的补加工，去除大的残料；
 |  | 曲面精雕刻 | 曲面模型的成型加工；
 |  | 成组平面加工 | 对一组比较平坦的曲面进行精加工；
 |  | 残料清根 | 用小刀对大刀加工的残留部分进行处理加工；
 |  | 旋转雕刻 | 用于雕刻柱状零件；
 | 投影雕刻组 | 投影雕刻 | 将现有的刀具路径投影到曲面上；
 |  | 包裹雕刻 | 将现有的刀具路径包裹到曲面上；

下面分别介绍各种加工方法的用途及特点。


轮廓切割

4.2.2 轮廓切割

轮廓切割的图形或文字必须是严格的轮廓曲线组，所有的曲线满足封闭、不自交、不重叠三个条件。轮廓切割的雕刻加工参数如图4-10所示，包括半径补偿和定义补偿值两个。

图4-10 轮廓切割参数

半径补偿 | 含义和单线加工的半径补偿一样，补偿方式有关闭、向外偏移和向内偏移三种。 1）关闭，表示不进行刀具补偿； 2）向外偏移，轮廓向外偏移一个值； 3）向内偏移，轮廓向内偏移一个值。 如图4-11所示，轮廓曲线为粗线，路径为细线，圆代表刀具。则图4-11左面的图为向内补偿，中间的图为向外补偿，图4-11右面的图是关闭补偿。选用向内补偿时，刀具路径落在轮廓内部，切割轮廓的内部形状与设计形状吻合；选用向外补偿时，刀具路径落在轮廓外部，切割轮廓的外部形状与设计形状吻合；关闭半径补偿时，刀具沿轮廓曲线切割，它能最大程度的同时保证内部和外部形状。 图4-11半径补偿方向
定义补偿值 | 通常情况下，补偿值由选用的刀具和雕刻形状自动计算。当然用户也可以选中这个复选框，定义一个固定的半径补偿值。当半径补偿方式为线上时，该项不可用。


单线雕刻

4.2.1 单线雕刻

单线雕刻功能用于雕刻加工各种形式的曲线，雕刻的图形可以不封闭、可以自交。单线雕刻的参数包括半径补偿、定义补偿值、延伸曲线端点、反向重刻一次、最后一层重刻和保留曲线高度，参考图4-8。

图4-8 单线雕刻参数

半径补偿 | 任何切割刀具都有一定的直径，如果把轮廓曲线直接当作刀具轨迹进行切割，必然造成实际外形尺寸和设计尺寸之间存在一个刀具半径的偏差，外轮廓偏小，内轮廓偏大，这个时候，需要半径补偿。半径补偿的方式有线上、向左和向右三种。 1）线上表示不进行补偿； 2）向左表示路径向左偏移一个值； 3）向右表示路径向右偏移一个值。 如图4-9所示，在用平底刀加工一个平面曲线（图A）时，刀具可以根据需要向左偏移（图B），或向右偏移（图C），或不偏移（图D）。 图4-9 半径补偿
定义补偿值 | 通常情况下，补偿值由选用的刀具和雕刻形状自动计算的。当然用户也可以选中这个复选框，定义一个固定的半径补偿值。当半径补偿方式为线上时，该项不可用。
延伸曲线端点 | 将不封闭的曲线两端延伸一段距离，以便改变下刀及抬刀的位置。
反向重刻一次 | 当分层雕刻时，每层雕刻路径都会反向重刻一次。
最后一层重刻 | 当分层雕刻时，在雕刻最后一层反向重刻一次。
保留曲线高度 | 系统将三维曲线转换成刀具路径，保留原有的曲线高度，将平面曲线转换成高度等于0的刀具路径。


扩孔雕刻

4.1.2 扩孔雕刻

扩孔雕刻用于扩大现有圆孔直径，也可用于切割比刀具直径大的通孔。扩孔的雕刻参数如图4-4所示。

图4-4 扩孔雕刻参数

扩孔方式 | 扩孔雕刻一共有两种进刀方式，即步进扩孔和螺旋扩孔，如图4-5所示，左边的图为步进扩孔，右边的图为螺旋扩孔。步进扩孔每一层的路径在一个水平面上，在某位置处下刀或抬刀排削。螺旋扩孔以螺旋线方式下刀到某层的深度，再在该深度兜一个圆扩孔。 图4-5 扩孔雕刻方式
扩孔直径 | 扩孔直径大小应当为孔的最终直径大小。当扩孔直径比刀具直径小时，系统不能生成扩孔路径。
过滤重点 | 将位置重复点过滤掉，只留下不重合的点。


钻孔雕刻

4.1.1 钻孔雕刻

钻孔雕刻方法用于生成钻孔路径。雕刻参数如图4-1所示。

图4-1 钻孔雕刻参数

贯穿距离 | 加工通孔时，钻头去除刀尖补偿后多钻出的距离，即图4-2中的H1。
刀尖补偿 | 由于钻孔刀具的顶部为锥形，为了保证在某深度范围内所钻孔的直径都是钻头的直径，故需要多往下钻刀具锥形部分的高度值H2。 图4-2贯穿距离和刀尖补偿
排屑高度 | 在分层钻孔时，为保证排屑，钻孔到一个深度位置时，刀具需要向上提刀，脱离加工工件。排屑高度表示刀具距离材料表面的高度，如图4-3所示。 图4-3排屑高度
过滤重点 | 将位置重复点过滤掉，只留下不重合的点。
保留原始高度 | 选择这个复选框，则在钻孔的时候，为各孔保留各自的高度，主要用于加工空间点。


特征取点

4.1.3 特征取点

为了方便的获得钻孔或扩孔的圆心点，扩孔雕刻和钻孔雕刻都提供特征取点功能。特征取点的参数包括取点方式、过滤直径、包括圆弧、中心距离和通过末点等，如图4-6所示。

图4-6 特征取点的参数

取点方式 | 特征取点的方式主要有关闭、线上取点和圆心取点三种，示意图如图4-7所示。 1）关闭，不提取任何特征点； 2）线上取点，按一定的间距在线上取点； 3）圆心取点，按照半径大小和高度位置过滤圆或圆弧的中心点作为钻孔或扩孔中心。 关闭 线上取点 圆心取点 图4-7 取点方式
过滤直径 | 用于提取圆心，如果过滤直径 <= 0.0，系统将不过滤圆弧直径。否则系统仅仅提取直径等于过滤直径的圆心。点击“过滤直径”按钮，提取示例圆弧的直径。
包括圆弧 | 用于提取圆心钻孔，提取点在圆弧的中心。
中心距离 | 用于线上取点，指定点在曲线上的距离。
通过末点 | 用于线上取点，能够均匀处理中心距离，使得最后一个点正好通过曲线的末点。


区域修边

4.3.3 区域修边

区域修边一般是在区域粗雕刻之后使用的，因为粗雕刻后的区域的侧面效果不好，可能有毛刺。为了获得良好的边界效果和尺寸精度，一般都要采用区域修边。

区域修边的雕刻参数有修边量、修边次数、模糊修边、最少抬刀和忽略外边框，参考图4-23。

图4-23 区域修边参数

修边量 | 此项大于0，则可以修边。该值为总的修边量。 每次修边量 = 总修边量 / 修边次数。
修边次数 | 此项大于0，则可以修边。该值为总的修边次数。 每次修边量 = 总修边量 / 修边次数。
模糊修边 | 指对于刀具加工不到的窄缝，可以强行让刀具通过，获得分割开的轮廓形状。这一选项主要用于一些非精确雕刻行业，如标牌等，如图4-24所示。 图4-24(a)常规雕刻 图4-24(b)模糊雕刻
最少抬刀 | 多次修边时减少刀具抬刀。当区域修边次数只有一次时，最少抬刀无效。如图4-25所示，左边路径为关闭最少抬刀，右面路径为打开最少抬刀。 关闭最少抬刀 打开最少抬刀 图4-25 最少抬刀
忽略外边框 | 当加工凸出来的字或者图形时，有时在外边加一个辅助的边框，如图4-26所示。当选中忽略外边框复选框，在修边时，就不需要修辅助的边框了。因为加工这种零件只要保证字体的效果就可以了。 图4-26 忽略外边框


残料清根

4.4.6 残料清根

曲面清根主要用于加工多个曲面相连接处。这些位置一般都有较清晰的轮廓线。为了将这些位置的形状加工出来，需要使用曲面清根功能。残料清根的雕刻参数如图4-64所示。

图4-64 残料清根

清根方式 | 清根方式共有三种，分别为垂直扫描清根、曲线偏移清根和轮廓偏移清根，如图4-65所示。 图4-65 垂直扫描清根、曲线偏移清根和轮廓偏移清根 1）垂直扫描清根，指沿着曲线的垂线方向走刀进行加工。 2）曲线偏移清根，指沿着曲线的方向走刀进行加工。 3）轮廓偏移清根，是指沿着曲线的延伸方向走刀进行加工。它与曲线偏移清根的差别在于它只对封闭的轮廓曲线进行清根。
左侧延展 | 在选择垂直扫描清根方式时有效，指路径在清根曲线左侧延伸的路径长度。
右侧延展 | 在选择垂直扫描清根方式时有效，指路径在清根曲线右侧延伸的路径长度。
偏移方向 | 在选择轮廓偏移或曲线偏移方式时有效，指走刀相对该清根曲线的偏移，共有关闭、向左和向右三种方式。
偏移值 | 在选择轮廓偏移或曲线偏移方式时有效，指曲线或轮廓的偏移距离。


三维清角

4.3.4 三维清角

三维清角是一种特殊的区域修边方式，它利用锥刀的几何特征最大限度的去除区域内部需要雕刻的材料，保证清晰的区域形状。

三维清角的雕刻参数有清角方式、修边量、修边次数、上次刀尖直径、禁止向下清角和忽略外边框，参考图4-27。

图4-27 三维清角的参数

清角方式 | 包括清角修边、清角补加工和模糊清角三种方式。
修边量和修边次数 | 清角方式为清角修边方式时有效，该参数的意义同区域修边中一致。
上次刀尖直径 | 在选择清角补加工时有效，该参数用于设置该区域上次加工时使用刀具的刀尖直径。
禁止向下清角 | 在选择清角补加工时有效，如果选中该复选框，在生成清角路径时，只允许刀具从下向上清角，减少清角时的崩刀现象，从而增加刀具的使用寿命。
最小深度 | 在选择模糊清角时有效，表示模糊清角路径的高度。
忽略外边框 | 忽略外边框生成的清角路径，只有在选择的图形有而且只有一个外边框时有效。


残料补加工

4.3.2 残料补加工

在雕刻复杂区域的过程中，为了提高雕刻效率，通常需要用大直径刀具完成粗雕刻。但是大直径刀具会在内角位置留下很大的残留量。有些窄小的区域，刀具也无法雕刻。在精雕刻过程中，残料补加工功能可以根据粗雕刻刀具和精雕刻刀具的大小关系自动计算出残料位置，生成清除残料的补加工路径，如图4-21所示。

图4-21 大刀加工留下残料

残料补加工的雕刻参数有残料定义方式、上把刀具、上把刀具直径、上次吃刀深度、上次侧边余量和上次底面余量，如图4-22所示。

图4-22 残料补加工参数

残料定义方式 | 残料有三种定义方式包括: 1、 指定上次路径，点击这个选项，系统会让用户从雕刻路径中寻找上次加工的路径，然后从这个路径中得到下面五个参数； 2、设定刀具直径，系统认为上把刀具的类型与当前刀具相同。该加工方法主要使用平底刀和锥刀。刀具直径指刀具的底直径，系统根据直径差计算残料； 3、指定上把刀具，不要求刀具类型相同，需要用户从刀具库中指定上把刀具。系统由两把刀具就可以计算出残料加工的区域。
上把刀具 | 当残料定义方式为指定上把刀具时，该参数项可用。点击“上把刀具”按钮，可以从刀具库中选择上次粗加工时使用的刀具。
上把刀具直径 | 仅仅在使用设定刀具直径的方式下有效，指上一次区域加工时使用的刀具直径，主要用于平底刀和锥刀；
上次吃刀深度 | 上一次区域加工时的吃刀深度，它会影响残料的计算；
上次侧边余量 | 上一次区域加工时设置的侧边余量，它会影响残料的计算；
上次底面余量 | 上一次区域加工时设置的底面余量，它会影响残料的计算；


环切走刀

4.3.1.2 环切走刀

环切走刀是沿边界曲线环绕走刀。环切走刀的参数包括最少抬刀、从内向外走刀、环切并清角，参考图4-17。参数中的最少抬刀同行切走刀中的最少抬刀的意义是一样的。

图4-17 环切走刀参数

从内向外走刀 | 环切方向包括“从内向外”和“从外向内”两种。选择该项为“从内向外”，加工时，在加工走刀过程中刀具在区域中间下刀，在整个切削过程中切削量比较均匀；不选该项，则为“从外向内”，刀具从最外面开始雕刻，逐步向内走刀，它主要用于一些薄壁件的雕刻，如图4-18所示。 图4-18 环切方向
环切并清角 | 当刀具路径重叠率低于50%时，选中这个复选框，加工时将尽量清除内角残留材料，否则在区域内部容易留下残料。
折线连刀 | 在进行环切走刀的时候两个环之间如果直接用直线连过去，会损伤刀具，应该沿着加工方向画一个Z形折线连过去，效果就比较好，如图4-19所示，坐标的路径没有选择折线连刀，右边的选择了折线。 图4-19 折线连刀


区域粗雕刻

4.3.1 区域粗雕刻

用户通过绘图、扫描描图等方式得到一个区域的边界曲线。有了这个边界曲线，就可以使用区域粗雕刻功能了。适合区域雕刻的图案可以是任何图形或文字，但是这些图形必须是一个个的轮廓曲线，满足封闭、不自交，不重叠的原则，否则生成的路径可能会出现偏差。

图4-12 区域粗雕刻的走刀方式

区域雕刻加工的参数包括走刀方式及其相应的走刀参数。区域粗雕刻的走刀方式有三种，如图4-12所示，分别为行切走刀、环切走刀和螺旋走刀。区域雕刻下面有一个参数为关闭半径补偿。

关闭半径补偿

当选择区域进行区域雕刻的时候，有的时候需要刀具走在选择的边界上，这个时候只要选择关闭半径补偿，就可以实现，如图4-13所示，左侧的为不选关闭半径补偿，右侧的是选择了关闭半径补偿。

4-13 半径补偿


行切走刀

4.3.1.1 行切走刀

行切走刀是按照行切角度以直线运动来进行切削。行切走刀参数有兜边一次、兜边量、路径角度、往复走刀、最少抬刀和优化走刀方向，参看图4-14。

图4-14 行切走刀参数

兜边一次 | 一般行切走刀完成后，都要沿着边界再切削一次，用于切除行与行在轮廓边界位置的残留量，如图4-15所示。该复选框一般都被选中。 图4-15兜边一次和兜边量
兜边量 | 直线路径端点和兜边路径之间的距离称为兜边量。兜边量的大小在行切走刀时会预留，以便兜边时切除。在区域雕刻时一般都要选择“兜边一次”，兜边量一般在0.01~0.03之间，如图4-15所示。。
路径角度 | 直线路径和水平直线之间的夹角称为行切角度，调整行切角度可以增大直线路径的长度，提高加工效率，如图4-16所示。 图4-16 行切角度
往复走刀 | 选择往复走刀，则会走Z字形的路径，来回切削；否则为单向走刀，往一个方向走刀时加工，之后提刀走到起点，再加工。往复走刀的效率要比单向走刀要高，是雕刻加工中最常用的走刀方式。
最少抬刀 | 选择最少抬刀复选框，系统会尽量减少抬刀的次数。
优化走刀方向 | 选择该复选框，走刀方向会尽量沿着加工域较宽的方向走刀。


螺旋走刀

4.3.1.3 螺旋走刀

螺旋走刀是指以螺旋进刀方式来切削。螺旋走刀的参数有兜边一次、兜边量、最少抬刀、从内向外和优化走刀次序，参见图4-20。

图4-20 螺旋走刀参数

兜边一次 | 一般螺旋走刀完成后，都要沿着边界再切削一次，用于切除在轮廓边界位置的残留量。该复选框一般都被选中。
兜边量 | 直线路径端点和兜边路径之间的距离称为兜边量。兜边量的大小在行切加工时会预留，以便兜边时有加工量。在区域雕刻时一般都要选择“兜边一次”，兜边量一般在0.01~0.03之间。
最少抬刀 | 选择最少抬刀复选框，系统会尽量减少抬刀的次数。
从内向外走刀 | 环切方向包括“从内向外”和“从外向内”两种。选择该项为“从内向外”，加工时，在加工走刀过程中刀具在区域中间下刀，在整个切削过程中切削量比较均匀；不选该项时为“从外向内”，刀具从最外面开始雕刻，逐步向内走刀，它主要用于一些薄壁件的雕刻。
优化走刀次序 | 选择该复选框，系统将优化雕刻的次序，改善切削状态，但会降低雕刻效率。


投影雕刻

4.5.1 投影雕刻

投影雕刻是按照加工面的垂直方向将路径投影到曲面上，主要用于在曲面上刻字或者划线，或者雕刻一些图案。

投影雕刻的雕刻参数有三个，分别为保留原有深度、关闭半径补偿和删除原始路径，如图4-69所示。

图4-69 投影雕刻参数

保留原有深度 | 选择该项，投影路径将保留原有的深度变化。该选项可以将平面雕刻路径投影到曲面上，实现曲面加工。
关闭半径补偿 | 选中这个参数，可以加快计算速度，但会降低加工的精度。
变换原始路径 | 选择该选项，投影雕刻不生成新的刀具路径，而仅仅完成选择路径的投影变换。系统不改变原有路径的次序，也不改变原有路径的刀具。选择该选项后，本次操作选择的刀具无效。


包裹雕刻

4.5.2 包裹雕刻

包裹雕刻是按照长度不变原则将路径投影到曲面上。当投影的曲面较平坦时，投影雕刻和包裹雕刻没有太大区别。但是，当投影曲面较陡峭时，投影雕刻将导致在曲面陡峭处的路径严重变形。而包裹雕刻却不会，它就象是把路径放在一张橡皮膜上，而后将橡皮膜卷在被包裹曲面上一样。如果曲面不能展开，包裹路径也会存在变形。通过调整包裹中心和包裹方向可以减小路径变形。

包裹雕刻的雕刻参数如图4-70所示。

图4-70 包裹雕刻参数

包裹中心 | 包裹中心是包裹过程中的基点。通过它建立起基准曲面和刀具路径的位置关系，它必须落在曲面上。调整包裹中心可以减小路径的变形，一般选择路径的中心为包裹中心。
包裹方向 | 包裹方向是包裹过程中的主方向。路径在主方向上的变形最小，所以主方向一般选择与路径最长的方向一致。
保留原有深度 | 包裹路径保留原有的深度值。
变换原始路径 | 选择该选项，包裹雕刻不生成新的刀具路径，而仅仅完成选择路径的投影变换，系统不改变原有路径的次序，也不改变原有路径的刀具。选择该选项后，本次操作选择的刀具无效。


成组平面精加工

4.4.5 成组平面精加工

当模型凸凹处较明显，侧壁接近竖直壁，底面接近平面时，成组平面精加工就特别适合于对底面的加工。由于被加工面接近于水平面，可以方便的将平面加工的方法引入到模型底面的加工。在加工过程中，成组的水平面可以统一的生成路径；又能够相对独立的生成路径。该方法既能提高生成路径的效率，又能够保证各面的加工质量。该方法对于部分被覆盖的面或者较狭长的面无法生成精加工路径，需要用其他方法生成路径。

成组平面加工的雕刻参数如图4-63所示。

图4-63 成组平面加工

走刀方式 | 包括行切走刀、环切走刀和螺旋走刀。这些走刀方式与区域粗雕刻加工的参数完全一致，请参考区域粗雕刻的说明。
加工平坦面 | 对比较平坦的曲面也按照平面的方法进行加工。
与水平面的最大夹角 | 选中加工平坦面复选框时，该项有效。通过设置与水平面的最大夹角，可以加工斜度小于该夹角的平坦面。该夹角值一般取在15度到25度之间。


旋转面雕刻

4.4.7 旋转面雕刻

旋转加工主要用于加工旋转体工件。在生成路径时，需要首先通过坐标变换，以便让模型的旋转轴和X轴平行。之后，分别生成旋转加工的粗加工路径和精加工路径。譬如，图4-66为一个起子把模型，通过旋转变换，再生成旋转加工路径，如图4-67所示。

图4-66 起子把

图4-67 生成的路径

旋转加工的雕刻参数有往复走刀、连刀高度、起始X位置、终止X位置、起始角度和终止角度，如图4-68所示。

图4-68 旋转面加工参数

往复走刀 | 选择该选项，加工时刀具会在两相邻路径间一来一往走动加工，不存在空行程。否则，刀具将往某一方向走刀时加工，之后空程走回，再进行加工。
连刀高度 | 连接两行路径的线段相对路径位置的高度，避免因为连刀而过切工件。
起始X位置和终止X位置 | 通过这两个参数可以确定旋转体所在范围。这两值一般取加工模型在X方向上的最小值和最大值。
起始角度和终止角度 | 指加工模型绕X轴旋转的加工范围。


分层区域粗雕刻

4.4.1 分层区域曲面粗雕刻

分层区域粗雕刻是一层一层的切削工件，在加工过程中，控制刀具路径在固定深度切削，像等高线一般，和精加工中的等高外形加工相对应。该方法主要用于曲面较复杂、侧壁较陡峭或者较深的场合。由于分层区域在加工过程中高度保持不变，所以该加工方法能够大大地提高切削的平稳性。

分层区域曲面粗雕刻的雕刻参数如图4-28所示。

图4-28 分层区域粗雕刻参数

走刀方式

分层区域粗加工提供了三种走刀方式，分别为行切走刀、环切走刀和螺旋走刀。这三种走刀方式的参数和区域粗雕刻的完全一致，请参考区域粗加工的说明。

无边界时

在未指定边界时可以使用实体零件边界、型腔模具边界或自动提取边界。

1）实体零件边界，会生成零件最外轮廓的路径，以便将外形加工出来，外轮廓可以是用户指定的。如果没有指定，则系统会参考零件的最大包围盒和刀具半径来生成一个轮廓作为最外轮廓。

2）对于型腔模具边界，不要生成最外轮廓的路径，以便保证模具与毛坯材料相连。需特别注意的是，对于某些侧壁不整齐、有缺口的产品模型在加工时不能单纯的用零件类型来区分是否需要保留或删除最外轮廓的路径。此时，需要通过提取曲面边界来限定路径的范围。

3）提取曲面边界会由系统自动计算曲面的边界线来限定走刀的范围。在使用该选项时，用户不应该选择边界线。该功能在粗加工中特适用于边界较复杂的零件。

自动提取边界有两个参数，如图4-29所示。侧壁的铅垂角表示生成路径的侧壁同Z方向的夹角a；边界向外偏移表示将系统生成的边界线向外偏移的距离H。

图4-29 自动提取边界

如图4-30所示，加工一个把手，使用实体零件边界时，生成如图4-31的路径，而使用自动提取边界，生成如图4-32的路径。从生成的路径可以看出，加工边界复杂的零件，使用提取曲面边界的方法要比实体零件边界生成的路径要少很多，可以大大的提高加工效率。

图4-30 门把手

图4-31 加工效果（实体零件边界）

图4-32 加工效果（提取曲面边界）

型腔模具边界一般应用于加工如图4-33所示零件的内部区域，生成的路径如图4-34所示。

图4-33 型腔零件

图4-34 模具型腔的路径

毛坯模式

在加工的过程中，经常遇到一些零件先用其他机床加工了一部分，然后再使用JDPaint加工。这种已被部分加工的工件就称为毛坯零件。使用传统的加工方法加工这种零件，生成的路径中会有很多空走路径。为了减少空跑路径，JDPaint提出了毛坯模式的加工方法。这种加工方法需要在拾取加工图形时将毛坯面拾取上。拾取了毛坯面后，分层区域粗加工参数中的毛坯模式会被自动选上。4-35就是一个毛坯零件，它的上表面是一个被线切割加工后的曲面。如图4-36所示，左边的路径是不使用毛坯模式生成的，空跑路径很多；右边的是使用毛坯模式生成的路径，这个路径比较合理的，它将空跑的路径裁减了。

图4-35 毛坯零件

图4-36 毛坯零件的路径


曲面残料补加工

4.4.2 曲面残料补加工

曲面残料补加工是针对于分层区域粗加工来说的。在使用分层区域粗加工雕刻复杂区域的过程中，为了提高雕刻效率，我们通常需要用大直径刀具完成粗雕刻。但是大直径刀具会在内角位置留下很大的残留量，并且有些窄小的区域大刀具也无法雕刻。此外，在分层加工时可能在较平坦的曲面上留下大量的因为分层而出现的台阶状残料。而在精加工的时，使用的刀具一般比较小，在切削比较大的残留量的时候有些力不从心。因此，有可能因为残料过大而折损刀具。此时，就需要使用曲面残料补加工。

这种加工方法使用介于粗加工和精加工之间的刀具，利用粗加工的参数自动计算出残料的位置，生成清除残料的补加工路径。曲面残料补加工的参数如图4-37和4-38所示。其中图4-38中的参数同区域雕刻组中残料补加工的参数一致，请参考4.3.2节。

图4-37 残料补加工的边界参数

曲面残料补加工中的参数有三个，分别为无边界时的边界类型、补加工模式和毛坯模式。

无边界时 | 这个参数的意义同分层区域粗加工的参数是一样的。在进行补加工的时候，这个参数应该同上把刀具进行分层区域粗加工的无边界类型值一致，不然可能导致计算残料的错误。
毛坯模式 | 毛坯模式同分层区域粗雕刻里面的毛坯模式的含义是一致的。

图4-38残料补加工的上次加工参数

补加工的参数和区域雕刻组中的残料补加工的参数是一样的，这里不再讲述。


投影加深粗雕刻

4.4.4 投影加深曲面粗雕刻

投影加深区域粗雕刻也是一层一层的切削工件，在每一层的加工过程中，根据曲面形状的不同，采用不同的走刀方式。一般用来加工整体比较平缓的零件。

投影加深粗加工有三种走刀方式，如图4-62所示，分别为平行截线粗加工、径向放射粗加工和曲面流线粗加工。投影加深粗加工也有毛坯模式。

图4-62 走刀方式

走刀方式的含义和曲面精雕刻的参数完全一致，请参考曲面精雕刻的相关内容。

毛坯模式和分层区域粗雕刻里的毛坯模式的意义是一样的，请参考分层区域粗雕刻。


分区域加工

4.4.3.7 分区域加工

分区域加工方法用于等高外形的加工优化参数。对话框页面如图4-58所示。

图4-58分区域加工参数

加工范围 | 加工范围由各个环状路径所包围区域的面积大小决定。根据区域大小的不同，等高加工可以分为加工较大的区域或较小的区域，或者所有区域三种，示意图如图4-59所示。 所有区域 大区域 小区域 图4-59 加工范围 1）所有区域，生成所有的路径； 2）大区域，只生成面积比较大的路径； 3）小区域，只生成面积比较小的路径。 注意这里对区域的判断完全是由路径环的面积决定的，不是用户选择的边界。
区域面积 | 这个值是用来划分大小路径的。凡面积大于该值的路径皆为大区域的路径，反之为小区域的路径。
最大深度 | 在对大区域路径进行合并时，由于受刀刃长度的限制，不能将非常深的多条路径合并到一起。这个值用来限制合并路径的最大深度。譬如，最大深度设置为2，而高度间距为0.2、深度范围为9mm内的路径都相同可以合并，则将这些路径合并为[9/2+1]=5层，各层路径的间距为1.8。 对于小区域进行抬刀的时候，用来限制每加工多深的距离抬刀、排削一次。
大区域路径合并 | 对于大区域，若上下多层路径完全重合，则可以根据需要将这些路径合并，从而减少加工时间。当加工范围为小区域的时候，该选项不可用。
小区域路径抬刀 | 对于小区域，需要在加工的时候不断的抬刀，以便于排削。当加工范围为大区域的时候，该选项不可用。


等高外形走刀

4.4.3.2 等高外形走刀

等高外形走刀主要用于加工曲面较复杂、侧壁较陡峭的场合。由于等高加工在加工过程中高度保持不变，不会出现扎刀的现象，而且可以大大地提高机床的稳定性，从而提高加工工件的质量。该加工方法常和平坦面加工（平行截线加工的一种模式）结合使用，特别适用于现代高速加工。在用等高外形走刀方式加工时机床运行特别稳定，刀具受力均衡，加工过程中加工（顺逆铣）方向保持不变，能够获得加工质量较高的侧壁。另外，对于侧壁有缺口的情况，需要填补缺口，缺口处的加工路径处于空跑状态。但是，如果限定边界，则可能在缺口处掉头走下一条路径，这破坏了加工方向的一致性，但不会在缺口处空跑。

等高外形的走刀参数如图4-45所示。

图4-45等高外形走刀

无边界时 | 无边界时的处理方法可以参考分层区域粗雕刻的无边界时的处理方法。图4-46所示模型为电熨斗手柄的基底模型。该模型三边封闭，一边开口。当加工凹面时，不希望路径走到凸面上。此时就可以提取曲面的边界。该边界会对路径进行裁剪，以便使边界内部的路径留下。由图4-47可见，所有路径都在曲面边界的内部，开口边不存在路径。 图4-46 电熨斗手柄模型 图4-47 提取曲面边界限定走刀范围
下刀位置 | 从顶视图方向看，下刀位置是指下刀点相对于一个加工零件矩形包围盒的位置。该选项对于单个凸起（或单个凹坑）的零件在决定下刀、连刀位置时影响较大。（但对于较复杂零件的下刀或连刀位置的影响不大。） 譬如，对一个一端较陡峭、一端较平缓的单个凸起的零件进行加工时，就应该将下刀位置指定在较陡峭一端的附近。这样就能使连刀路径在零件的陡峭处，连刀距离较短。如图4-48所示模型，用等高外形加工时，希望上下层路径的连结处出现在较陡峭的面上，以便减少刀具在模型表面上划过过长的距离。该模型较陡峭面在该模型俯视图的左中位置附近。令连刀位置选择左中点，以便生成的等高路径在曲面的最陡峭处，如图4-49所示。 图4-48 用等高加工方式加工侧壁曲面 图4-49 选择图形的左中点为连刀位置
从下向上走刀 | 选择该复选框，每个刀具路径将从最下面走到最上面。这主要用于用平底刀作等高精加工时保护平底刀的底刃。该复选框未被选中时，按照常用的从上向下走刀的方法加工。
沿边界走刀 | 当加工图形中有边界线，或者提取了曲面边界线时，选择该选项，对于被边界限制后不封闭的路径会沿着边界走刀，让路径成为一个个封闭的环。否则，某些路径被打断，不封闭。
仅连接上下层不干涉路径 | 当用小刀具以精加工的方法切削还有大量材料的小区域时，为了控制每条路径的切削量，防止刀具因切削量过大而折断，应当选择该选项。此时，本可相连的上下层路径，可能会因为下层路径会切到上层其他某条路径会加工的材料（导致切削量增大），而先走同一层的其他路径。选择该选项后，在一些小区域附近会增加许多抬刀，可能会使这些路径的加工效率显得较低。但它保护了刀具，避免了不必要的断刀和换刀，最终提高了加工效率。
删除平坦面路径 | 选择该复选框，下面的“最大投影距离”编辑框会变为可用状态。SurfMill会根据最大投影距离来删除平坦面上的路径。较平坦面上相邻两层的路径在XY平面上的投影间距较大，若该间距值大于最大投影间距，则这段间距较大的路径会被裁减掉。选择该选项能适当提高路径的加工效率。
最大投影距离 | 该值设置的越大，被删除的路径越少，否则越多。该值一般取路径间距的2-5倍。

对等高加工而言，还有一个参数是非常重要的，即雕刻精度页面中的曲面平坦系数。该值为计算时构造的网格模型的网格精度，这个值一定是大于0的。在加工的时候，应该注意到以下几点：

1）当模型有较多细节时，例如和刀具直径相当的槽或小夹角缝隙时，需要适当调小该值，以便计算较精确的路径。否则，会在上述位置出现较混乱的路径。缺省情况下该值为0.5，用户在需要调小该值时一般取0.5、0.2。

2）该值最好不要小于0.1。当模型确实太小，刀具也很小，需要加工到其中的细节时，可以考虑使用将模型和刀具同时放大10（n）倍，在生成路径后再将路径缩小为1/10（1/n）倍的方法。

3）注意在网格精度过小（<0.05）时，内部计算允许的误差将与有效数值相当，这样会导致计算失败。

当该值过小时，会大大的增加对内存的需求，增加计算量，可能导致计算时间很长。

等高外形走刀方式在精加工的过程中，会经常遇到，在很多情况下要结合其它方法使用。为了能够很好的掌握这种走刀方式，下面介绍一些使用技巧：

1、当模型整体为型腔模具而模具中央有高出最外轮廓的凸台时，需要将上层突出部分按照实体零件加工，下层能明显看到最外轮廓的部分用型腔模具方法加工。

2、当对凸起零件作等高外形加工，可能要将加工好的零件切出来时，应当将等高外形加工分为两步完成。一步为对上层部分的加工，另一步（也是最后一步）为剩余4-2毫米的等高加工，以便将零件切下来。

3、对于部分有台阶凸缘的零件，可以使用等高外形加工方法加工凸缘。此时最好用平底刀加工，并使用节点编辑删除内部多余路径，以便留下加工凸缘的路径。


径向放射走刀

4.4.3.3 径向放射走刀

径向放射精加工主要适用于顶视图类似于圆形、圆环状模型的加工，路径呈扇形分布。径向放射精加工的雕刻参数如图4-50所示。

图4-50 径向放射走刀参数

放射中心 | 放射走刀路径收缩处的位置，就是生成放射路径的中心。用户可以自己指定，也可以选择图形的中心作为放射中心。放射中心必须落在边界曲线中间。一般情况下，用户可以选用一些特征点，如曲面中心或边界中心作为放射加工的中心。
起始角度 | 第一条放射路径与X轴正向之间的夹角，一般在 0–360 度之间。
角度范围 | 用于确定雕刻的角度区间，是起始路径沿逆时针方向旋转，到达终止路径时经过的角度范围。该值必须小于360度。
从里向外 | 参数仅仅在单向走刀方式时有效（不选往复走刀参数时，系统认为是单向走刀）。加工时选中这个复选框，刀具总是从放射中心开始向外雕刻。


曲面流线走刀

4.4.3.4 曲面流线走刀

曲面流线精加工主要用于曲面数量较少、曲面相对较简单的场合。加工过程中刀具沿着曲面的流线运动，运动较平稳，路径间距疏密适度，加工零件表面的质量较高。当多张曲面边界相连时，可以联合在一起沿着曲面的流线加工。当曲面较小、较多时，不适宜用曲面流线加工。因为此时各面很可能会分别加工，路径的走向较混乱。

曲面流线走刀方式有关的参数页面如图4-51所示。

图4-51曲面流线走刀

切削方向 | 指刀具路径沿曲面流线的走向，用户可以选择U向或V向作为走刀方向。选择U向走刀时，刀具路径与曲面流线的U方向相同；选择V向走刀时，刀具路径与曲面流线的V方向相同。
偏移方向 | 指路径相对于加工曲面的方向。该方向可以由系统计算时自动确定，也可以指定为法矢的正方向或负方向。该选项仅对单个面（或一组不存在边界关系的面）加工时有用。当选中的一组加工面存在边界连结关系时，该选项无效。
起点 | 指刀具路径起点的位置，调整走刀方向和路径起点可以获得更好的走刀次序，并对表面质量、雕刻效率等没有影响；在曲面流线精雕刻方式中，我们可以选择曲面的四个角点作为路径起点。曲面角点可以用曲面流线的起末点标定，其中起点用0表示，末点用1表示，那么四个角点对应的位置(U,V)可以分别表示成（0,0）、（1,0）、（1,1）、（0,1），如图4-52所示, 单击起点列表框，用户可以选择曲面的任何一个角点作为路径的起点。 图4-52 路径起点


曲面精雕刻

4.4.3 曲面精雕刻

JDPaint5.0提供的曲面精加工方法有5种，对应的走刀方式页面如图4-39所示。曲面精雕刻仅有一个参数，即为走刀方式，如图4-39所示。

图4-39曲面精雕刻参数

走刀方式

包括平行截线走刀、等高外形走刀、径向放射走刀、曲面流线走刀、环绕等距走刀五种类型。


连刀方式

4.4.3.8 连刀方式

用于等高外形和曲面流线走刀的连刀设置。雕刻参数包括连刀方式、引出长度、圆弧半径，如图4-60所示。

图4-60 连刀方式

连刀方式 | 用于调整相邻环绕路径之间的路径连刀方式，包括沿曲面连接、折线连接、圆弧连接和光滑连接等，如图4-61所示。 沿曲面连接 折线连接 圆弧连接 光滑连接 图4-61 连刀方式 1）沿曲面连接，连刀路径在XY平面上投影为两连刀点连接的直线，高度方向随曲面的高度变化，保证不过切即可； 2）折线连接，形成台阶状的连刀路径； 3）圆弧连接，形成螺旋线形的连刀路径； 4）光滑连接，两连刀点根据切出时的切矢用样条曲线光滑连接。
引出长度 | 在光滑连接时可用，限制连接曲线的大致长度。
圆弧半径 | 在圆弧连接时可用，限制圆弧连接的螺旋线圆弧的半径。

在连刀时以不过切模型为原则。在用某种连刀方法无法生成无干涉的连刀路径时，系统会自动选择其他方法来连刀。引出长度和圆弧半径，这些连刀参数只是生成连刀路径时使用的一个参考值。连刀路径无法也不必严格遵守这些参数值。


平行截线走刀

4.4.3.1 平行截线走刀

平行截线精加工在曲面精加工中使用最为广泛，特别适用于曲面较复杂但陡峭面不太多的场合。参数如图4-40所示。

图4-40平行截线走刀

修边一次 | 使用该方法能够方便的保证加工域侧壁的质量。
修边量 | 当选中边界精修一次选项时，该项有效。
路径角度 | 路径和X轴正方向的夹角。
往复走刀 | 选择该选项，刀具将往复走刀。
优化走刀方向 | 选择该选项可以对分块区域的走刀方向进行优化，使得走刀方向在该区域较长边的方向上。图4-41为使用平行截线走刀加工一个面，在没有选择优化走刀方向时生成的，而图4-42的路径是选了优化走刀方向时生成的。对比两个路径可以看到，图4-42中路径的走刀方向进行了优化，提高了加工效率。 图4-41 优化走刀方向前的路径 图4-42 优化走刀方向后的路径
自动提取 曲面边界 | 选择该选项会由系统自动计算曲面的边界线来限定走刀的范围。该功能特适用于边界较复杂、边界附近为较陡峭的面构成的情况。因为在这种情况下由用户构造边界线特别复杂费时。但是若没有边界线，会导致在加工时扎刀。图4-43使用提取曲面边界选项。在未选择矩形边界的情况下，由系统自动计算加工曲面的边界。图4-44为未提取曲面边界，且未指定加工边界时的走刀情况。 图4-43 提取曲面边界 图4-44 不提取曲面边界且不指定边界时


陡斜面加工

4.4.3.6 陡斜面加工

在平行截线曲面精雕刻中，为了避免出现陡峭路径，可以使用陡峭面加工参数来限定加工范围。

陡斜面加工是平行截线精加工的补充参数，其雕刻参数如图4-54所示。

图4-54 陡斜面参数

加工模式 | 平行截线加工共用三种模式：即所有面、平坦面和陡峭面，如图4-55所示。 所有面模式 平坦面模式 陡峭面模式 图4-55加工模式 1）所有面模式，缺省情况下为加工所有面，不过滤陡峭路径； 2）平坦面模式，雕刻加工比较平坦的曲面部分，删除比较陡峭的路径； 3）陡峭面模式，雕刻加工比较陡峭的曲面部分，删除比较平坦的路径。
与水平面夹角 | 当使用平坦面和陡峭面加工时有效，这个值表示路径与水平面夹角。在加工平坦面时，加工路径与水平面的夹角不得超过该角度，超过的陡峭部分被截断去掉。在加工陡峭面时，加工路径与水平面的夹角必须超过该角度，未达到该角度的平坦部分被截断去掉。
最短路径长度 | 当使用平坦面和陡峭面加工时有效，指被截断留下路径的最小长度。 图4-56、图4-57分别使用平行截线的平坦面模式和陡峭面模式生成的加工路径。 图4-56 平行截线精加工的平坦面加工模式 图4-57 平行截线精加工的陡峭面加工模式
路径延长长度 | 当使用平坦面和陡峭面加工时有效，表示将留下的路径的两端向外延长的长度。该值过大可能导致本该分开的两条路径相连。长度小于该值的路径段都被去掉。


环绕等距走刀

4.4.3.5 环绕等距走刀

环绕等距走刀方式可以生成环绕状的刀具路径。根据路径环绕的特点，环绕等距还可以再细分为Z向投影等距、曲面外形等高、曲面外形等距等三种不同的等距效果。这些方法用在不同的场合，系统主要采用Z向投影等距的方法。

环绕等距走刀方法生成的路径的空间距离基本相同，适合雕刻既有陡峭位置又有平缓位置的表面形状，参数如图4-53所示。这些参数同环切走刀的参数是一样的，请参考区域粗雕刻中的环切走刀参数的介绍。

图4-53 环绕等距走刀


公共参数

路径计算的公共参数包括很多方面，如雕刻范围、进给设置、雕刻刀具和计算精度等。这些参数对路径的计算、加工效果、加工时间以及加工效率都有很大的影响。如果能够合理的使用这些参数，可以获得最优的刀具路径，加工出完美的工件。下面对这些参数作一个详细的说明。


深度范围

5.1.1 深度范围

深度范围是指在Z方向上的一些加工深度参数，有表面高度、底面高度、雕刻深度，如图5-1所示。表面高度和底面高度决定了加工的深度范围，即从表面高度位置起加工到底面高度位置为止。雕刻深度D与表面高度C、底面高度B存在计算关系，即D=C-B。也就是说在确定表面高度后，任意给定底面高度或雕刻深度都可以决定加工的深度范围。

图5-1深度范围参数

表面高度 | 表面高度指加工区域上表面距离零平面的高度，如果高度<0.0时，表示零件的上表面在零平面（Z=0.0）以下, 如果高度>0.0时，表示零件的上表面高度在零平面以上。
底面高度 | 底面高度指加工区域下表面距离零平面的高度，底面高度不能大于表面高度。
雕刻深度 | 雕刻深度指实际的雕刻深度，雕刻深度 = 表面高度 – 底面高度(见下图5-2)，雕刻深度不能小于0。
重设加工深度 | 根据选择图形的高度范围自动重设雕刻的深度范围。
自动重设曲面深度范围 | 在生成路径后，如果将加工域中的曲面进行了移动（高度方向），这时再重算路径，则路径的高度是错误的。如果选中该项，则它会在重算的时候重新更新曲面的高度，生成正确的路径。


雕刻余量

5.1.3 雕刻余量

在使用多把刀具雕刻、刀具尺寸不准或者雕刻完成后需要其他后续处理时，需要设定雕刻余量。雕刻余量的参数包括侧边余量、表面余量和曲面边界补偿三个参数，如图5-6所示。

图5-6 雕刻余量参数

侧面余量 | 侧面余量是模型侧面的预留量，表示一把刀具雕刻完成后理论边界与实际边界之间的差值，如图5-7所示。雕刻余量可以大于0，也可以小于0。 图5-7 侧面余量
表面余量（底面余量） | 在平面雕刻加工中，可以设定雕刻的底面余量，通过调整底面余量可以调节雕刻的深度范围，如图5-8所示。比如设定雕刻深度为4.0，如果底面余量等于0.2，那么实际雕刻的深度等于4.0–0.2 = 3.8 。 图5-8 底面余量 在曲面雕刻加工中，可以设定表面余量。表面余量是模型表面的预留量，其值为雕刻完成后的曲面表面和设计曲面之间的最短距离，如图5-9所示。 图5-9 表面余量
曲面边界补偿 | 顾名思义，这个参数只有在曲面雕刻中使用，而且只有在选择了边界的时候才起作用。边界补偿有三种类型，如图5-10所示： 1、 关闭：加工的时候刀具走在边界上； 2、 自动向内：按照刀具半径向内偏移，刀具走在边界以内； 3、 自动向外：按照刀具半径向外偏移，刀具走到边界的外部。 图5-10a 关闭 图5-10b 自动向内 图5-10c 自动向外


侧面角度

5.1.2 侧面角度

侧面角度用于定义带侧面的曲面雕刻效果，如果曲面模型没有选择边界，则不需设置侧面角度。侧面角度包括的参数有侧面角度和底面尺寸基准两个，如图5-3所示。

图5-3 侧面角度参数

侧面角度 | 指轮廓的侧面同Z向的夹角，如图5-4和5-5中的A所示。侧面角度的范围是0―89度。角度等于0表示直侧面。
底面尺寸基准 | 如果存在侧面角度，并且轮廓边界表示的是表面的轮廓形状，则被称为表面尺寸基准，如图5-4所示。否则，轮廓边界表示的是底面的轮廓形状，则被称为底面尺寸基准，如图5-5所示。

图5-4表面尺寸基准　　　　　　　 　　　　图5-5底面尺寸基准


轮廓设置

5.4.4 轮廓设置

轮廓设置有三个参数，分别为轮廓自交检查、轮廓自动结合和轮廓自动连接，参考图5-34。

图5-34轮廓设置

轮廓自交检查 | 选择该复选框，系统会自动排除轮廓相交的部分。在进行轮廓切割和区域雕刻时，如果图形轮廓出现自交，有时候无法生成路径。如果使用“轮廓自交检查”功能就可以解决这种问题。
轮廓自动结合 | 该选项用于将用户选择的图形结合成一个轮廓组进行雕刻，系统自动判断实际的雕刻区域。
轮廓自动连接 | 有时候，绘制或者“输入”的图形是多段曲线组成的非连接或不闭合的轮廓曲线，这种轮廓图形原则上是无法生成刀具路径的，如图5-35所示： 图5-35 如果遇到这类图形轮廓，选择“轮廓自动连接”复选框就可以解决这种问题。


尖角过渡方式

5.4.3 尖角过渡方式

定义区域的轮廓曲线通常都是由首尾相接的线段组成的。刀具在雕刻这些尖角时可以按照圆弧轨迹走刀，也可以按照直线延长的方式走刀。尖角过渡设置包括过渡方式、最小尖角和最大尖角三个参数，如图5-30所示。

图5-30 尖角过渡方式

过渡方式 | 尖角的过渡方式一般分为三种方式，分别为直线延长、直线截断和圆弧过渡，如图5-31所示。直线延长是使用直线延长方式过渡尖角，直线截断是使用直线截断方式过渡尖角，圆弧过度是使用圆角方式过渡尖角。 a、直线延长 b、直线截断 c、圆弧过渡 图5-31 过渡方式 例：使用锥刀雕刻字时，雕刻区域的侧面会产生倾斜角度。不同的过渡方式将影响区域的形状。如果需要生成棱角清晰的侧面效果，请使用“直线延长”方式；如果需要生成比较圆滑的侧面效果，请使用“圆弧过渡”方式，二者效果如图5-32所示。 图5-32 过渡效果
最小尖角 | 当尖角角度很小时，使用圆弧过渡方式既缩短不了多少路径，还增加了路径的点数，这时系统总是采用延长方式加工尖角，我们称这个角度为最小尖角，一般在10~45度之间。
最大尖角 | 当尖角角度很大时，使用延长过渡方式加工尖角的路径过长，这时系统总是采用圆弧方式加工尖角，我们称这个角度为最大尖角，一般在135~175度之间。 使用圆弧过渡方式生成的刀具路径长度最短，是最常用的尖角过渡方式。而使用延长过渡方式生成的路径点数最少。另外，使用锥刀雕刻时，延长过渡形式可以雕刻出比较尖的底角，如图5-33所示。 图5-33


雕刻次序

5.4.2 雕刻次序

雕刻次序包括刀具的走刀方向、加工时的分层次序和路径中的轮廓排序，如图5-26所示。

图5-26 雕刻次序

走刀方向 | 在铣削加工中，存在一个加工方向问题，即顺铣和逆铣。对于正螺纹的刀具（主轴正转），当刀具旋转的切削线速度方向与走刀方向一致时，产生顺铣，否则，产生逆铣，如图5-27所示。 判断正铣、逆铣的方法很简单，就是看切削刃是迎着走刀方向切削还是背对走刀方向切削。迎着切削的是逆铣，背对走刀方向切削的是顺铣。但加工方向又很难判断。因为它受刀刃的螺旋方向、主轴转向、走刀方向以及加工面的凸凹性影响。在同一条刀具路径中就可能同时存在顺铣和逆铣，譬如往复折线走刀。 图5-27 走刀方向
分层次序 | 分层雕刻时，如果有几个独立的区域，我们可以选择两种雕刻方式，即高度优先和区域优先。使用“高度优先”功能雕刻时，总是先加工完所有区域的第一层，再去加工所有区域的第二层，直到最后一层；使用“区域优先”功能雕刻时，总是先一层一层地加工完一个区域，再去加工另一个区域，直到最后一个区域，如图5-28所示。 图5-28 分层次序
轮廓排序 | 当区域内部包含小区域，即出现区域嵌套时，有三种次序加工嵌套区域，即从内向外、从外向内或最短距离。采用从内向外雕刻次序时，先雕刻最里面的区域，然后逐步向外雕刻；采用从外向内雕刻次序时，先雕刻最外面的区域，然后逐步向里雕刻；采用最短距离的雕刻次序时，刀具路径总是按照最短距离雕刻轮廓，保证刀具在区域之间的移动距离最短。 轮廓排序适用于轮廓切割和区域雕刻。图5-29是三种轮廓排序的示意图，其中数字表示雕刻的先后次序。 图5-29 轮廓排序


雕刻精度

5.4.1 雕刻精度

雕刻精度设置包括逼近方式、弦高误差、角度误差和曲面平坦系数四个参数，如图5-24所示。

图5-24 雕刻精度

逼近方式 | 路径的逼近方式一般包括两种，分别为“圆弧逼近方式”和“直线逼近方式”。刀具在雕刻过程中只能走直线段或圆弧（即直线逼近和圆弧逼近）。如果用户绘制的图形包含其他类型的曲线，系统需要将它们离散成直线段或圆弧之后才能计算刀具路径。在离散过程中原始图形和离散图形之间有误差。一般用弦高误差和角度误差表示，如图5-25所示。 图5-25 逼近方式
弦高误差 | 折线段、圆弧与原始曲线之间的误差被称为弦高误差。图5-25中的Ｔ为弦高误差。弦高误差应该在0.01~0.08之间。
角度误差 | 折线段之间的角度变化为角度误差，图中Ａ为角度误差，角度误差一般在5~30度之间。
曲面平 坦系数 | 生成曲面加工路径时使用的网格精度。该值越小，生成路径的精度越高，但所耗费的内存越多，计算时间越长。该值一般不得小于0.05。 一般来说，图形比较小时，主要依赖角度误差，当图形比较大时，主要依赖弦高误差。需要注意的是，在“圆弧逼近方式”下，系统会使用圆弧和直线逼近曲线，而在“直线逼近方式”的方式下，系统只会用直线段逼近各种曲线（包括圆弧段）。


分层雕刻

5.2.2 分层雕刻

分层雕刻用于控制每层的深度，及其分层方式。其参数有分层方式、路径层数、吃刀深度、拷贝层数和减少抬刀五个，如图5-14所示。

图5-14开槽方式

分层方式 | 分层方式共有三种处理方法，即关闭下刀方式、限定深度和限定层数。 1）关闭下刀方式：路径不分层。当加工深度不超过吃刀深度时，可以不分层。 2）限定深度： 路径层数随着雕刻深度的变化而变化，但每层的吃刀深度不超过限定深度。 3）限定层数：每层深度随着雕刻深度的变化而变化，但路径层数总是不超过限定的层数。
路径层数 | 路径层数是指分层加工的层数，在分层方式为限定层数时可用。
吃刀深度 | 吃刀深度是分层加工的吃刀深度，在分层方式为限定深度时可用。
拷贝分层 | 在斜侧面加工或用锥刀加工时，不同深度的半径补偿值并不相同，于是在侧面容易残留小台阶。为了避免产生不光滑的侧面，可用拷贝分层方式。
减少抬刀 | 选择这个复选框，在分层雕刻的时候将相邻层之间的路径连接成一条路径，从而可以减少抬落刀的次数，如图5-15所示。

图5-15 减少抬刀


进刀方式

5.2.5 进刀方式

在轮廓切割或区域修边加工中，增加进刀退刀路径可以避免刀具在进刀或提刀过程中切伤侧壁。进刀控制参数包括进刀方式及其相应的参数，如图5-19所示。

图5-19 进刀设置参数

进刀方式 | 包括关闭、直线连接、直线相切、圆弧相切四种，如图5-20所示。其中： 1）关闭进刀方式用于一些对侧面要求不高但讲究效率的加工中。 2）直线连接方式用于一些复杂图案、文字的切割中。 3）直线相切主要用于一些规则的外轮廓加工中。 4）圆弧相切可以用于比较规则的轮廓加工。 关闭 直线连接 直线相切 圆弧相切 图5-20进刀方式
直线长度 | 使用直线连接或直线相切方式时，直线长度用于控制进刀退刀路径段的长度。
圆弧角度 | 使用圆弧相切方式时，用于控制圆弧的角度，一般在30~180度之间。
圆弧半径 | 使用圆弧相切方式时，用于控制圆弧的半径。圆弧半径一般不小于刀具直径。
计算失败时 | 如果进刀路径和轮廓边界相交，系统认为进刀路径计算失败。一旦遇到这种情况，系统按照用户设定的下面几种方式处理： 1）忽略进刀； 2）使用直线连接； 3）缩短进刀距离，减小圆弧半径或直线长度。


下刀方式

5.2.4 下刀方式

刀具垂直落刀过程容易造成刀尖崩裂，而改变下刀方式可以降低下刀冲击，提高刀具的使用寿命。下刀参数包括下刀方式、下刀角度、直线长度（螺旋半径）、表面预留和侧边预留，如图5-17所示。

图5-17 下刀参数

下刀方式 | 系统提供的下刀方式有：竖直下刀、轮廓下刀、螺旋下刀和折线下刀四种，如图5-18所示。用户也可以使用关闭下刀方式，这样便不会生成下刀路径。不同下刀方式的控制参数也不尽相同。 竖直下刀 轮廓下刀 折线下刀 螺旋下刀 图5-18 下刀方式 1）关闭下刀方式：不生成下刀路径。在加工雕刻深度小于0.05或雕刻比较软的非金属材料或使用球刀时，一般使用关闭下刀方式。 2）竖直下刀方式：和关闭下刀方式近似，但系统会增加一段竖直下刀路径，通过低速通过下刀路径的方式优化下刀过程。 3）轮廓下刀方式：如果使用开槽加工方式、或加工小区域、或用轮廓切割方式加工时，可以采用轮廓下刀方式。另外在有机玻璃切割时也用轮廓下刀方式避免材料飞崩。 4）折线下刀方式：主要用于比较规则区域的粗加工或分层区域粗加工中。 5）螺旋下刀方式：主要用于比较复杂区域的粗加工或分层区域粗加工中。 需要注意的是，在计算刀具路径时，如果遇到下面的情况，一般需要采用下刀方式： 1）使用刀具的类型是平底刀、牛鼻刀，以及底直径超过0.5的锥刀； 2）同时采用了轮廓切割、区域粗铣、或分层区域粗加工计算刀具路径； 3）加工材料是金属或比较硬的非金属（如水晶、大理石等）； 4）每次吃刀深度超过0.1毫米。
下刀角度 | 1）选择螺旋下刀时，下刀角度就是螺旋角，也就是螺旋线与水平面之间的夹角； 2）选择折线下刀时，下刀角度指折线与水平面之间的夹角； 3）选择轮廓下刀时，下刀角度指斜线与水平面之间的夹角。 下刀的角度一般在0.5-5度之间，材料越硬，角度越小；但使用轮廓下刀方式切割有机玻璃的下刀角度一般在40~50度之间。
直线长度 (螺旋半径) | 1）螺旋下刀时，为下刀时的圆弧半径。 2）折线下刀时，为构成下刀路径的折线段的投影长度。 下刀的直线长度（或螺旋半径）一般与刀具直径相同，范围在0.4~3.0之间。
表面预留 | 下刀时顶部的预留量，指下刀路径超出材料表面的高度。增加表面预留可以提高下刀的安全性，一般不超过0.1。
侧边预留 | 下刀时边界的预留量，也表示螺旋下刀时路径距离轮廓的距离。增加侧面预留量可以避免在下刀过程中切伤侧壁。该数值一般不超过0.05。
计算失败时 | 使用螺旋下刀或折线下刀方式时有效。使用这两种下刀方式时，如果下刀路径和轮廓边界相交，系统认为下刀路径计算失败。一旦遇到这种情况，系统将按照用户设定的下面几种方式处理： 1）忽略下刀； 2）使用竖直下刀； 3）使用轮廓下刀； 4）缩短下刀距离，这是通过减小圆弧半径或直线长度实现的。


开槽雕刻

5.2.3 开槽雕刻

开槽雕刻用于控制开槽加工时的开槽深度。它的参数包括开槽方式、开槽层数、开槽深度、减少抬刀、切削量均匀和斜侧面开槽，如图5-16所示。

图5-16 开槽方式

开槽方式 | 同分层方式一样，开槽方式也有三种处理方法，即关闭开槽方式、限定深度和限定层数。 1）关闭开槽方式：当单边吃刀深度和开槽吃刀深度接近时，一般不用开槽。 2）限定深度：开槽的层数随着雕刻深度的变化而变化，但每层的开槽深度不超过限定深度。 3）限定层数：开槽的深度随着雕刻深度的变化而变化，但开槽的层数总是等于限定的层数。
开槽层数 | 开槽层数是指开槽路径的层数，在开槽方式为限定层数时可用。
开槽深度 | 开槽深度是开槽加工的深度，在开槽方式为限定深度时可用。
减少抬刀 | 选择该复选框，会多层开槽不抬刀。
切削量均匀 | 选择该项，它能保证每层的切削量相同，但深度不一定相同。
斜侧面开槽 | 选择该项，它能保证每层开槽路径沿侧面走刀。


侧向进给

侧向进给主要用于设置路径间距，评估重叠率和残料高度。主它包括三个参数，分别为路径间距（重叠率）、水平残留高度和45度面残留高度，如图5-11所示。

图5-11 路径间距参数

路径间距和重叠率 | 路径间距和重叠率是互锁的，主要用于控制侧向进给量。路径间距在数值上等于侧向进给量。路径重叠率表示相邻两条路径的重复程度，路径重叠率越高，路径间距越小，路径越密。它们的关系如图5-12所示。 图5-12 路径间距 路径间距 = 刀具直径×( 1.0 – 重叠比例 / 100 )
水平残留高度 | 在刀具加工的时候，两行路径之间留有残留量（尤其是在使用球头刀的时候），水平残留高度是指在水平面上加工时的残料高度。
45°面残留高度 | 刀具沿相邻两条路径走过后，所残留的部分距离零件表面的高度，如图5-13中H所表示的距离。45°面残留高度是指在与水平成45°角的面附近的残留量。 当路径间距值过大时，水平残留高度或45度方向面的残留高度值为-1，即路径间距大于刀具半径，残留高度会很大，估算已失去意义。 图5-13 残料高度


操作设置

5.3.3 操作设置

为了较好的描述加工过程中刀具在Z向的运动情况，在操作设置页面中，制定了一些参数，如图5-23所示。这些参数包括安全高度、定位高度、慢速下刀距离、落刀延迟和冷却方式。

图5-23 操作设置页面

安全高度 | 该参数一般为整个零件最高点之上一点的高度值。在此高度上，刀具可以随意平移，不会碰到工件和卡具。系统使用相对于工件表面高度的距离值来设定安全高度。
定位高度 | 该参数一般取某些路径所在局部区域模型的最高点往上一点的高度。在加工这些区域时，刀具可以在该高度上自由移动，不会碰到工件和卡具。系统使用相对局部区域最高点的高度值来设定定位高度。
慢速下刀距离 | 在刀具靠近毛坯表面或竖直切入零件时，应当以较慢的速度靠近，以防止扎刀。这段慢速下刀的距离即为慢速下刀距离。该值一般等于吃刀深度+0.1。
落刀延迟 | 下刀完成后的暂停时间。该值等于–1时，表示无效，加工时将使用加工软件设置的落刀延时。
冷却方式 | 表示加工时冷却液的使用状态，可以选择关闭、油冷和风冷三种。
速度模式 | 速度模式包括三个选项，分别为速度优先、质量优先和质量最优。速度优先表示加工时尽可能地高速雕刻，以便节省加工时间；质量优先表示加工时要考虑加工质量方面的因素，这样会得到比较好的表面效果，但加工速度比较慢；质量最优表示要得到最好的表面质量，不考虑速度、加工时间方面的因素，因此，加工速度最慢。


加工速度

5.3.2 加工速度

刀具在加工运动过程中可以用一组参数来表示其切削情况，包括主轴转速、切割速度、下刀速度、进刀速度、开槽速度和连刀速度，如图5-22 所示。

图5-22 雕刻速度

主轴转速 | 刀具的转速。雕刻机的主轴转速一般为20000转/分，转速最高可达24000转/分，最低也应当在15000转/分以上。该值等于-1时，表示无效，加工时会使用加工时设定的参数。
切割速度 | 雕刻时的走刀速度，等于-1时，表示无效，加工时会使用加工时设定的走刀速度。
下刀速度 | 下刀过程中的走刀速度。
进刀速度 | 切入切出路径靠近加工零件时的加工速度。
开槽速度 | 开槽雕刻路径的走刀速度，等于-1时，表示无效，加工时将使用加工时设定的走刀速度。
连刀速度 | 在连刀路径上的走刀速度。一般而言，连刀路径都较短，它用于将相邻的路径连结，在加工中基本不起切削作用，主要用于使刀具转向，进入下一条路径。连刀速度一般设置的较小，以便走刀更平稳。


刀具几何形状

5.3.1 刀具几何形状

在计算路径的时候，刀具的几何形状对路径有很大的影响，这些几何信息如图5-21所示。

图5-21 刀具的几何信息

名称 | 显示当前加工使用刀具的名称。点击名称后面的按钮，系统会弹出系统的雕刻刀具库。
刀具的类型 | 当前使用刀具的类型。
顶直径 | 刀具的刀头部分的最大直径。
底直径 | 刀具刀尖部分的最小直径。
圆角半径 | 刀具的刀刃部分的圆角半径，一般牛鼻刀才有。
刀具锥度 | 刀具的两个刀刃之间的夹角，一般锥刀、大头刀才有这个参数。


雕刻模板库中的缺省雕刻模板

6.4 雕刻模板库中的缺省雕刻模板

在雕刻模板库中，系统已经根据用户的使用情况预定义了一组加工方法。它们是文字切割、标牌制作、高频模制作、滴塑模制作和冲头制作。在了解这些雕刻模板后，用户应当根据需要定义自己的雕刻模板。

6.4.1 文字切割

根据常用有机玻璃板的厚度不同，可以预定义5.00、10.00、15.00和20.00毫米厚度的有机玻璃板的文字切割方法。它们都使用轮廓切割，这些加工方法的唯一差别就在于切割深度不同。为此，JDPaint5.0预定义了有机玻璃板的文字切割方法组。

6.4.2 标牌制作

在对标牌进行加工时一般需要两步工序完成，即先进行区域雕刻，最后进行轮廓切割。在JDPaint5.0中预定义了关于标牌制作的方法组。

6.4.3 高频模制作

高频模一般按照两步进行制造，即区域粗加工和三维清角。JDPaint5.0提供的缺省的高频模雕刻为2.50mm深度的雕刻。

6.4.4 滴塑模制作

滴塑模雕刻深度一般在2.50mm左右，使用的刀具是20度左右的锥刀，雕刻方法包括区域粗加工、三维清角和单线雕刻。JDPaint5.0提供了缺省的滴塑模雕刻方法。

6.4.5 冲头制作

冲头雕刻使用80度左右的刀具，雕刻方法有区域粗加工、三维清角等。JDPaint5.0提供了缺省的冲头雕刻方法。


路径计算模板

6.1 使用路径模板库计算路径

路径模板就是一组预先定义了加工参数的雕刻方法集合。利用路径模板库，用户可以非常方便的生成一组路径。一般而言，有许多加工除了图形不同，整个加工工艺和参数是完全相同的。利用路径模板，用户可以把成熟的加工工艺存储在路径模板库中。在后来需要加工该类型产品时，便能够非常方便的利用路径模板库来进行加工。

JDPaint5.0使用一个缺省的文件来记录系统中的路径模板。在JDPaint5.0系统启动时， JDPaint5.0安装目录的Cfg\ Method.mth文件会被自动加载。若该文件不存在，系统会自动创建缺省的路径模板库。在退出路径模板库对话框时，系统会自动更新缺省的路径模板库文件，以便及时保存系统的路径模板库。


路径计算过程

6.1.1 路径计算过程

使用路径模板计算路径的流程包括以下三步：

图6-1 路径计算过程

* 不同步骤完成的主要任务是：

1）选择雕刻加工图形，所有能被选择的对象都有对应的雕刻方法；

2）选择雕刻加工模板，根据加工的特点选择合适的雕刻模板；

3）生成刀具路径，系统根据选择的图形和选择模板生成一组雕刻加工路径。

特别注意的是，模板生成的是一组路径，可能包含多种雕刻加工方法，也可能使用多把雕刻加工刀具。

* 下面将以一个圆的切割为例，具体介绍刀具路径的生成过程。

1）选择“刀具路径>>路径模板”菜单项，如图6-2所示。

图6-2启动路径模板

2）选中雕刻加工的图形。这里，我们选择圆，如图6-3所示。选择图形的具体操作可以参考第一章路径向导构建加工域的方法。

图6-3 选择雕刻图形

3）系统弹出“雕刻路径模板”对话框，选择雕刻加工组，如图6-4所示。

图6-4 雕刻路径模板

4）点击“确定”按钮，生成刀具路径，如图6-5所示。注意工艺树中已有相应的路径节点。

图6-5 雕刻路径


路径计算使用技巧

6.1.2 路径计算使用技巧

在用雕刻模板计算路径时，一定要注意以下几点：

1、一个模板包含了一组雕刻方法，选择该组的任何一种方法，表示选择了该路径模板。生成的刀具路径也是该组中所有方法对应的刀具路径。如果路径模板包含多个雕刻方法，系统将一次生成这些雕刻方法对应的刀具路径，如图6-6所示。

图6-6 路径模板一次生成一组路径

2、当雕刻模板包含子模板时，如图6-7所示，系统只计算当前模板所包含的刀具路径，而不计算子模板包含的路径。

图6-7 路径模板包含子模板

这时，路径模板只会生成区域粗雕刻、三维清角-0.3、三维清角-0.２三个雕刻路径，而不会生成单线雕刻路径。


添加雕刻方法

6.2.2 添加雕刻方法

路径模板中也可以添加新的雕刻方法，如图6-9所示，在某加工方法组下，单击“添加”按钮。

* 添加的过程和启动路径向导的过程完全一样，包括以下四个步骤：

1）选择雕刻方法，并设定雕刻加工范围；

2）选择雕刻刀具，并设定路径计算设置；

3）选择雕刻材料，并设定切削用量；

4）系统自动匹配雕刻参数，用户可以做最后的修改。

图6-9 添加雕刻方法


复制雕刻方法

6.2.4 复制雕刻方法

在加工方法对话框中选择一个加工方法，单击“复制”按钮，即在该加工方法所在加工方法组下面添加一个复制的加工方法。图6-11为对一个区域粗雕刻进行复制后的情况。注意，有一个新的“区域粗雕刻”方法添加在了“平面滴塑雕刻”组的最后。于是该对话框下有两个同名的加工方法。为了防止混淆，建议用户不要创建同名的加工方法。一般而言，对于复制的加工方法都应当进行编辑处理，以防止同名加工方法的出现。

图6-11 复制加工方法


删除雕刻方法

6.2.3 删除雕刻方法

路径模板的雕刻方法也可以被删除，如图6-10所示。

* 删除的步骤包括：

1）选择需要删除的方法；

2）点击对话框右上部的“删除”按钮；

3）系统弹出删除确认对话框，点击“确定”，表示删除。

删除后的方法不能恢复，所以删除雕刻方法一定要倍加小心。下图就是删除一个单线雕刻路径的提示。

图6-10 删除雕刻方法


编辑雕刻方法

6.2.1 编辑雕刻方法

* 编辑模板中雕刻方法的过程是：

1）选中需要编辑的雕刻方法；

2）点击“编辑”按钮，系统弹出雕刻路径参数对话框，如图6-8所示；

3）修改路径参数的相关内容，点击“确定”退出。

图6-8 编辑雕刻加工方法

雕刻路径参数的编辑方法和“雕刻加工方法”一章的内容完全一致，请参考第四章。


修改雕刻方法

6.2 修改雕刻方法

对路径模板中雕刻方法的修改，包括编辑现有的方法、添加新方法或删除现有的某些方法。


添加路径模板

6.3.2 添加路径模板

* 添加路径模板的过程是：

1）选择新模板所在组的位置；

2）点击“添加组”按钮；

3）系统自动添加新的模板。

图6-13为在“我的雕刻模板”下添加新的模板组的情况。

图6-13 添加新的路径模板


删除路径模板

6.3.3 删除路径模板

路径模板的雕刻方法也可以被删除。

* 删除的步骤包括：

1）选择需要删除的路径模板；

2）点击对话框右上部的“删除”按钮；

3）系统弹出删除确认对话框，点击“确定”，表示删除。

删除后的模板不能恢复，所以删除模板一定要倍加小心。此外，删除模板的过程中，系统将自动删除它包含的所有方法和子模板。图6-14显示了删除一个雕刻模板的过程。

图6-14 删除路径模板


编辑路径模板

6.3.1 编辑路径模板

选择待编辑的路径模板组，单击“编辑”按钮，会出现方法组对话框，如图6-12所示。在弹出的对话框中对所选项进行编辑后，选择“确定”按钮，便完成对路径模板的编辑。路径模板允许用户修改名称和备注说明。

图6-12 编辑路径模板


修改路径模板

6.3 修改路径模板

路径模板中的所有模板也可以被修改，修改的方法包括编辑现有模板、添加新模板或删除现有模板。


刀具路径输出

第七章 刀具路径输出

这一章主要介绍路径的输出，顺便介绍路径的打印和加工工艺的输入。


输入加工工艺

7.3 输入加工工艺

在生成路径的时候，如果有比较好的加工工艺，可以通过输入加工工艺命令导入加工工艺。这样可以节省设计刀具路径的时间。

* 输入过程是:

1）选择菜单命令；

选择“加工项目(T) >>输入工艺过程”菜单项，弹出如图7-15所示的对话框。

图7-15 输入加工工艺

2）选择要输入加工工艺的文件。

点击“浏览”按钮，从硬盘上选择要输入的文件，选中的文件显示在文本框中，项目名称显示在下拉框中，而该项目下的加工域则显示在列表框中。点击“确定”按钮，就可以把这个文件中的加工工艺加到工艺树中，如图7-16所示。工艺树的使用方法将在第十章介绍。

7-16 导入加工工艺


输出流程

7.1 输出流程

刀具路径是不能直接控制雕刻机进行加工的，它要经过输出转化为控制软件可识别的文件格式后，才能由控制计算机转化为控制信号，通过电器控制部分，驱动机床进行加工。精雕软件生成的刀具路径必须输出成ENG格式的文件后才可以被雕刻控制软件识别，从而驱动雕刻机完成雕刻加工运动。刀具路径的输出过程如下：

图7-1输出流程

* 输出的详细步骤是：

1）显示当前加工面下需要输出的加工路径，如图7-2所示。

图7-2选择刀具路径

2）选择菜单“刀具路径(P) >>输出刀具路径(E)”，启动“刀具路径输出”命令，如图7-3所示。

图7-3　启动“输出刀具路径”命令

3）启动命令后，系统弹出文件对话框，请求用户输入加工文件的名称，如图7-4所示。

图7-4输入加工文件名称

4）设置加工文件的格式，如图7-5所示。

图7-5设置文件格式

5）点击“确定”按钮，系统将选择的刀具路径保存成加工文件。


输出设置

7.2 输出设置

设置加工文件的格式，如图7-5所示。

图7-5设置文件格式

ENG格式的加工文件是精雕控制软件专用的文件格式。该文件类型是加密格式的，不能被其他软件编辑，这一点和标准的NC格式并不相同。

输出参数对话框允许用户设定一些通用格式信息，包括控制软件的版本、使用的刀具和输出的加工原点等。此外，该对话框也列举了待输出路径的信息，如路径范围、路径长度等。

7.2.1 路径信息

路径输出信息包括雕刻范围、路径长度、估计加工时间、使用刀具等基本信息。

雕刻范围 | 显示刀具路径在X、Y、Z三个方向极限位置的绝对坐标值与相应方向的走刀范围。X向显示刀具路径在X方向最左端和最右端的绝对坐标值。这里显示为“-139.55 152.64”。这两个坐标值的差值292.19就是X向的加工范围。YZ向的雕刻范围道理同X向加工范围一样。 注意：Z向加工范围并不是实际的加工深度。一般在平面雕刻中实际的加工深度是Z方向的最小坐标值。
路径长度 | 显示待输出路径的总长度。
估计雕刻时间 | 粗略地计算了待输出路径用于加工所需时间。
使用刀具 | 在使用刀具的列表框中列出了待输出的路径所使用的全部刀具。

7.2.2 文件格式

输出格式包括控制软件的版本、输出二维路径、输出次序和曲线输出误差等参数。

l 控制软件版本

JDPaint V5.0可以输出三种ENG版本，分别是EN3D 3.X、EN3D 4.x和EN3D 5.x三种格式。它们的区别如下：

ENG版本 | 设计软件版本 | 运动插补方式 | 速度指令
EN3D.3X | JDPaint V3.X | 钻孔、直线 | 不支持
EN3D.4X | JDPaint V4.X | 钻孔、直线、圆弧 | 单条路径可以变速
EN3D.5X | JDPaint V5.X | 钻孔、直线、圆弧、螺旋线、样条 | 每段路径可以变速

高版本的设计文件可以输出低版本的加工文件，但低版本的设计软件不能输出高版本的加工文件。

l 输出次序

只有在使用刀具出现交叉的情况下有效。如果同一把刀具不能连续使用，我们称出现刀具交叉使用现象，如图7-6所示。

图7-6刀具使用出现交叉

出现交叉现象后，系统允许用户按照生成路径的先后次序输出刀具路径（上图结果为1、2、3），也允许用户按照刀具的使用次序输出刀具路径（上图结果为1、3、2）。

l 输出二维路径

输出二维路径是一个复选框。选中该复选框，就将路径转换成二维输出。一般而言，生成的刀具路径都是三维路径，也就是说路径都有雕刻深度。把三维路径变为二维路径之后，雕刻深度就不存在了。如果路径是分层加工的，则在输出二维路径后，这些路径将叠在一起。除了个别的铣面、单层雕刻和切割路径外，一般情况下都不要把三维路径转化为二维路径。特别是采用了分层加工、三维清角、分层开槽等功能生成的刀具路径千万不要转化为二维路径。

l 曲线输出误差

设计软件的刀具路径用多种曲线形式表示，包括直线、圆弧、螺旋线、样条等。当刀具路径里面含有控制软件不能识别的路径段时，在输出的过程中，需要将这些路径段离散成直线段或者圆弧段输出。在离散的过程中，用这个参数控制离散精度。

7.2.3 输出原点

输出原点的坐标有三种方式设置：特征点、拾取点（二维点或三维点），也可以自己定义。在输出刀具路径过程中，最重要的概念就是“输出原点”。下面我们就输出原点的问题作一些详细说明。

1、工件坐标系的“原点”

生成刀具路径的最终目的是控制刀具进行雕刻。而雕刻又是在毛坯材料上进行的，那么，如何把刀具路径准确的定位到毛坯材料上呢？这就需要在路径、机床和毛坯材料之间建立一种关系。这种关系是通过一个共同的参照点来建立的。这个参照点被称为“工件坐标系的原点”：

1）实际雕刻的对象是工件，工件在设计和雕刻过程中都存在定位问题；JDPaint 5.0软件是通过工件坐标系的原点来定位的。

2）工件坐标系就是以工件的装卡方向为坐标轴，以工件上的一点为原点建立的坐标系，如图7-7所示。

图7-7 工件原点

3）工件在设计并生成刀具路径过程中总是存在的，只是没有显示出来，如图7-8所示。

图7-8 工件原点在绘图坐标系的位置就是输出原点

4）在输出路径时，为了保证装卡，一定要指定工件坐标系原点的位置，如图7-8所示。

5）在工件装卡之后，工件坐标系原点在工作台面上的位置，被称为起刀点。

2、输出原点——定义工件坐标系的原点

提起原点就应该想到坐标系。原点亦即坐标系的0点。这里的坐标系是三维坐标系，也就是说在前面讲到的X、Y二维坐标系上加上一个垂直于屏幕方向并过原点的Z轴。定义刀具路径的原点，就是定义刀具路径的相对坐标系。一旦相对原点确定了，那么这个刀具路径在这个相对坐标系中的位置就确定了，如图7-9所示。

图7-9输出原点

在前面讲路径信息时提到了“加工范围”，那么“加工范围”中的坐标值与输出原点有什么关系呢？

区别 | 加工范围中显示的X、Y、Z三个方向的坐标值是刀具路径在绘图区的绝对坐标系中的坐标值，输出原点是相对坐标系的原点在绝对坐标系中的坐标值。
联系 | 通过定义刀具路径原点在绝对坐标系中的坐标来定义刀具路径原点的位置，如图7-10所示。

图7-10 加工范围坐标与输出原点的关系

例如：图7-11将输出原点的X、Y坐标定义为“路径左下角”，输出原点的Z坐标是 “0”点。

图7-11 特征点

定义完后，可以发现X、Y处显示的坐标就是刀具路径的左下角的绝对坐标。在前面讲“路径信息”中提到“Z方向的范围不是雕刻深度”。其实雕刻深度等于输出原点Z的绝对坐标值减去刀具路径在“路径信息”中Z方向的最小坐标值的差值。

l 为什么要定义刀具路径的原点呢？

原点是刀具运动的一个参照点。假如把刀具路径的原点定义为X、Y的左下角、Z方向定义为0点，如图7-9所示，那么刀具路径上的其它点就以这个点为参照点来确定相对位置。刀具在雕刻中就以这些点相对于原点的参数进行加工。

l 原点与雕刻起刀点的关系

在进行雕刻时，首先要定义X、Y、Z三个方向的起刀点，那么起刀点与原点有什么关系呢？

它们是一一对应的关系。起刀点的位置就是刀具路径加工文件的原点位置。起刀点的位置定义好了，那么这个刀具路径的原点就确定了，加工时，刀具就以起刀点为参照点进行雕刻。

l 原点、起刀点与材料之间的关系

刀具路径的输出是为了雕刻。雕刻一定是在材料上进行的，那么原点与材料之间有什么关系呢？其实，它们也是一一对应的关系。如果把原点定义为X、Y的左下角、Z方向定义为0点，那么从俯视图看，起刀点就应当定义在材料的左下角，起刀点的Z值应当定义在材料的上表面，如图7-12所示。

图7-12 雕刻加工效果

l 原点的确定

原点的确定有四种方法：

第一种：选择“特征点”的方法。

定义X、Y坐标的特征点可以选择坐标原点、路径左下角点或路径中心；定义Z坐标的特征点可以选择坐标原点、路径最高点或路径最低点。

第二种：自定义的方法。

使用自定义的方法可以在X、Y或者Z所对应的方框中任意输入数值。使用自定义的方法确定输出原点时，必须对刀具路径的加工范围、加工深度与起刀点的坐标的关系有了较深刻的理解之后，才能使用这种方法。否则，很容易出现问题。特别是有多组路径同时输出时，更要注意这种关系。一般情况下，平面雕刻路径输出时，原点的X、Y选择“特征点”、Z选择“自定义”0点位置，这样比较容易理解和把握。

第三种：使用“拾取二维点”的方法。

二维点是指X、Y两个方向的坐标点，点击一下“拾取二维点”按钮，在刀具路径对应的默认原点位置出现如图7-13所示的标记。这时提示条提示“选取路径输出原点（二维）”，用鼠标捕捉图形上的点或者某位置点击。这里我们捕捉图形下边的中点，如图7-13所示。

图7-13 拾取二维点

图7-14 捕捉特征点

点击鼠标，弹出导航菜单，提示“已捕捉到一个中点”,如图7-14所示。点击“确定”，又回到“刀具路径输出”对话框，继续操作。

第四种：使用“拾取三维点”的方法。

三维点指具备X、Y和Z三个方向坐标值的点。Z坐标不一定是0。三维点的拾取方式和二维点的拾取方法相同。

注意：在三维状态下，输出的路径是当前加工面上的可见路径。


路径打印

7.4 路径打印

路径打印功能是将选中的刀具路径组的属性和一些参数打印出来，以便于加工和管理。当系统中没有路径的时候该命令不可用。

* 操作过程如下：

1）选择菜单命令。

选择 “加工项目(T) >>路径打印(P)”菜单项。在应用程序的右边会弹出一个导航窗口，如图7-17所示。

图7-17路径打印的导航窗口和路径

2）选择要打印的路径并设置参数。

选择要打印的路径，路径的名字将显示在导航窗口的列表框中。用户可以填写设计师的名字。点击“打印”按钮，弹出如图7-18所示的窗口。

图7-18 打印窗口

3）打印文件。

窗口中列出了路径的各项信息，包括路径文件的地址和路径组的个数，之后是每一个路径的基本信息。这些基本信息包括路径组的名称、含有路径的个数、路径组的X、Y、Z三个方向的尺寸，路径组的长度、使用的刀具及编号，加工时的进给速度、下刀速度、安全高度、主轴转速、表面余量、侧边余量和加工时间等。在这个窗口里，可以通过选择“文件(F) >>打印(P)”菜单项，将这些信息打印出来。

* 在打印窗口的“格式”菜单下，可以作如下操作：

1）选择“格式(O) >>字体(F)”菜单项，弹出“字体”对话框，如图7-19所示。用户可以设置打印的字体。

图7-19 打印字体设置

2）选择“文件(F) >>保存(S)”菜单项，可以将打印的内容保存到一个文本文件中，如图7-20所示。

图7-20 打印信息保存

3）选择“文件(F) >>打印设置(R)” 菜单项，可以设置打印的参数。

4）选择“文件(F) >>打印预览(V)” 菜单项，可以打印预览，如图7-21所示。如果前面填写了设计师的名字，便可以将这个名字打印在页眉里。

图7-21 打印预览


加工模拟与校验

第八章 加工模拟与校验

在用生成的路径驱动机床加工前，通常都需要先对路径进行加工模拟和校验。在确定路径正确、工艺规划合理后，才能用于加工。加工模拟和校验在整个加工过程中非常重要。它可以帮助我们提前发现错误、纠正错误，避免在加工过程中造成不必要的损失。

JDPaint 5.0提供了三个验证加工路径的功能：

加工模拟 | 以实时动画的形式模拟加工过程。该方法较形象，适用于察看所选路径的加工顺序是否合理等。但是不太适用于察看模拟模型的细节效果。
路径分析 | 通过比较以不同方法生成的两个模型的差别来分析路径的加工效果。该比较计算速度较快，能够方便快捷的察看模型的细节，能在一定范围内作定量分析。但是该方法不能实时显示加工过程，也无法发现路径在加工过程中的顺序是否合理。
干涉检查 | 用于对刀杆和卡头是否发生干涉进行检查，以便及时发现不合理的路径，防止粘刀、断刀、撞上卡头、损坏机床等。


加工模拟

8.1 加工模拟

加工模拟，也叫加工仿真，是指用计算机以真实感图像动画的方式模拟加工过程。通过加工仿真，用户可以查看切削是否正确，观看最后生成的模型大体上是否正确。有许多加工路径的错误是通过加工仿真发现的。

图8-1 选择菜单项启动加工模拟命令

8.1.1 启动加工模拟命令

在曲面加工环境下选择“刀具路径>>加工模拟”菜单项，如图8-1所示。在启动该命令前，用户一定要把需要加工模拟的路径设置为显示状态，并且通过路径排序功能排列好这些路径的加工顺序。因为加工模拟命令会对当前刀具平面下显示的路径按照它们的加工顺序依次进行走刀加工模拟，最后可以获得一张最终的加工效果图。除了通过选择系统菜单项启动加工模拟命令外，用户也可以在工艺树的当前加工面项上单击鼠标右键。在弹出的浮动菜单中选择“加工模拟”菜单项来启动加工模拟命令。

加工模拟命令启动后，在应用程序右侧出现的导航工具栏如图8-2所示。

图8-2加工模拟命令的导航工具栏

需要注意的是：

1）如果没有刀具路径或者刀具路径被全部隐藏了，系统提示“没有刀具路径，不能模拟！”，并自动退出加工模拟命令；

2）如果用户已经选择了刀具路径，系统提示“只模拟选择路径？”，如果选择“是”，加工模拟命令仅仅模拟选中的路径，否则模拟全部可见的路径。

加工命令提供了一组按钮，用以控制加工过程，其中“关闭”按钮用于退出加工模拟命令，“模拟设置”按钮用于设置模拟参数，“开始、暂停”等用于控制模拟的中间过程。

8.1.2 控制加工模拟过程

单击“开始”按钮，开始进行加工模拟。在加工之前，可以单击“模拟设置”按钮，设置模拟参数。在模拟过程中，用户可以通过单击“暂停”时加工模拟暂停，以便观察。单击“停止”可以使加工模拟过程停止。停止后，只能在单击“开始”按钮启动。单击“加速”和“减速”按钮可以调整加工模拟的速度。

“开始”按钮 | 单击该按钮，可以启动加工模拟。在模拟过程中，该按钮自动变灰；
“模拟设置”按钮 | 单击该按钮，可以设置模拟参数。
“暂停”按钮 | 在模拟状态下，单击该按钮可以让加工模拟过程暂停，以便察看细节；在暂停状态下，单击该按钮，可以让加工模拟过程继续。
“加速”按钮 | 单击该按钮，可以加快模拟显示的速度。受计算机处理能力的限制，当速度达到机器的极限速度时，按加速按钮将不再起作用。
“减速”按钮 | 单击该按钮，可以降低模拟显示的速度。
“停止”按钮 | 单击该按钮，可以令加工过程停止。
模拟进度条 | 在该导航窗口的最下面一行为模拟进度条。它能够显示当前模拟的进展情况。

特别注意的是，加工模拟的结果不能放大缩小，也不能旋转平移。如果在加工过程中启动类似的观察命令，加工模拟过程自动中断。


设置模拟参数

8.1.3 设置加工模拟的参数

在加工模拟前，用户应当先设置加工模拟的参数。单击“模拟设置”按钮，系统弹出“加工模拟设置”对话框，如图8-3所示。

图8-3“加工模拟设置”对话框

按参数的性质划分，该对话框共有4类参数。在对话框左上角的毛坯设置组合框内，主要是对毛坯尺寸进行设置。左下角的“模型设置”组合框内主要是对模型的显示方式进行设置。对话框右上角的“颜色设置”组合框主要对刀具的切削颜色进行设置。右下角的“刀具设置”组合框内列出了待模拟路径所用的刀具。下面分别介绍各类参数。

8.1.3.1 设置毛坯尺寸

毛坯设置主要是对毛坯的尺寸及位置进行设置。用户可以在“毛坯设置”组合框内设定毛坯在X、Y、Z三个方向上的范围。在预留编辑框中可以输入在三个方向原范围的基础上再向外扩展的范围。

“路径尺寸”按钮 | 通过单击该按钮，可以根据当前加工面下显示的路径的尺寸大小来设置毛坯的外形尺寸。一般而言，在对模型的某些局部路径进行加工模拟时，单击该按钮来设置毛坯的尺寸。
“毛坯尺寸”按钮 | 通过单击该按钮，可以根据模型的尺寸大小来设置毛坯的外形尺寸。一般而言，在对整个模型的路径进行加工模拟时，单击该按钮来设置毛坯的尺寸。 这里单击“毛坯尺寸”按钮，根据鞋模的大小设置毛坯尺寸。

8.1.3.2 设置模拟方式

用户可以在“模型设置”组合框中设置模拟方式、刀具显示等参数。

模拟方式 | 对加工模拟显示方式进行设置。模拟方式下拉列表框中共有三种方式： 1）线框模拟，将以线条显示刀具的走刀加工过程。 2）实体模拟，将以具有真实感的实体模型显示加工模拟过程。 3）快速预览，将以具有真实感的实体模型快速显示加工模拟过程，快速预览方式主要用于俯视图模拟，在其它视图状态下，加工的效果存在不同程度的变形。
刀具显示 | 用于控制刀具的显示方式，下拉列表框中共有三个选项，包括： 1）线条，在加工模拟过程中，将用一组线条显示刀具。 2）渲染，在加工模拟过程中，将以具有真实感的图形显示刀具。 3）隐藏，在加工模拟过程中，刀具被隐藏不显示，有助于提高显示速度。
每步步长 | 每步步长的大小将决定模拟速度的初始值。该值越大，模拟加工的速度越快。在控制模拟速度时单击“加速”或“减速”按钮，实质是修改了该值，从而引起刀具的快速或慢速运动，以调整模拟加工的速度。
每步时间 | 每步时间决定间隔多长时间刷新一次屏幕。该值越大，模拟速度越快。但是用户会觉得动画效果差，画面有明显的跳动现象。

8.1.3.3 设置显示颜色

设置显示颜色主要是对背景色、材料的内部及外部颜色以及各把刀具的切削颜色进行设置。

颜色列表框 | 在“设置颜色”组合框中有一个颜色列表框。颜色列表框列举了所有可以控制的颜色，变换选中的颜色项，右边的颜色条显示该项的当前颜色；
修改颜色 | 单击“颜色”按钮或双击颜色条，系统弹出标准颜色对话框，从而可以修改对应项的颜色。
变换刀具切削颜色 | “变换刀具切削颜色”复选框被选中后，可以在刀具变换时用不同的刀具切削颜色来显示加工模型。各刀具的切削颜色按顺序设置在“刀具切削颜色#n”（n代表1、2、3等数字）中。如果不选该选项，刀具切削颜色统一采用“刀具颜色”项设定的颜色值。

8.1.3.4 模拟刀具列表

在“加工模拟设置”对话框右下角的“刀具设置”组合框中列出了加工模拟路径所用的刀具。选中“自动调整刀具长度”复选框，系统会根据切削深度自动调整刀具的长度，以便用户可以看到刀具的切削情况。否则，当刀具较短、材料较厚时，刀具可能走在毛坯内部，毛坯表面会遮挡刀具，从而用户看不到某些路径的加工模拟效果。


干涉检查

8.3 干涉检查

干涉检查用于对刀杆和卡头是否发生干涉进行检查，以便及时发现不合理的路径，防止出现粘刀、断刀、撞上卡头、损坏机床等现象。

在加工环境下选择“刀具路径>>路径干涉检查”菜单项，或在导航工具栏的加工刀具面树状列表项上单击鼠标右键，弹出上下文菜单，选择“路径干涉检查”菜单项，便进入路径干涉检查命令。

选择该命令后，在导航工具条中会出现如图8-12所示的导航工具条。在用户指定检查类型、检查路径和比较区域大小后，单击“干涉检查”按钮，便开始对路径进行干涉检查。对于刀杆检查，凡加工材料厚度大于刀刃长度的路径都认作发生刀杆干涉。对于卡头检查，凡是卡头会触及毛坯材料的都认为发生卡头干涉。在干涉检查后，会在“干涉检查”按钮下显示发生干涉位置的数目。通过单击“上一处”和“下一处”按钮，可以逐个察看干涉的深度和位置。干涉的路径会在屏幕中用红色表示。

图8-12路径干涉检查命令的导航工具条

* 干涉检查命令的使用过程如下：

1）选择干涉检查路径。单击“选择路径”按钮，会出现选择路径对话框，具体用法参见刀具路径分析的选择路径部分。

2）选择检查区域。单击“检查区域”按钮，会出现“选择比较区域”对话框，具体用法参见刀具路径分析的选择比较区域部分。

3）干涉检查。如果检查类型是“刀杆检查”，可以对刀刃是否够长进行检查。单击“干涉检查”按钮，系统弹出“刀刃长度检查参数”对话框，用户可以在该对话框中设置刀刃长度。退出该对话框后，出现进度条对话框，系统开始计算发生干涉的路径。有一点需要指出，在做刀杆检查时，如果直接用平行截线精加工路径进行干涉检查，可能会查出许多干涉的路径。这是因为JDPaint认为用户直接用精加工对一个毛坯件一刀到底进行加工，而通常情况下应当先分层进行粗加工。而且在进行干涉检查时，还必须按照正常的加工顺序调整加工域和加工路径的顺序，否则，同样可能出现上述情况。

如果检查类型是“卡头检查”，此时主要卡头螺母和电机机头是否撞到工件上进行检查。单击“干涉检查”按钮，系统弹出“刀杆长度检查参数”对话框。在这个对话框中可以设置刀杆长度、卡头直径，也可以设置电机干涉检查。退出这个对话框，出现进度条对话框，系统开始计算发生干涉的路径。

4）察看干涉路径。若发生干涉，从屏幕和“干涉检查”按钮下的控件可以看到各干涉处的具体情况。根据干涉的深度和区域，用户需要考虑添加、删除或修改一些路径，以防止干涉出现。

注意，路径是否发生干涉和路径的先后顺序以及刀刃长度、刀杆长度的设置有关。加工是必须先做粗加工，再做精加工。否则，就会撞刀。干涉检查也如此。如果精加工路径在粗加工路径的前面，将导致绝大部分精加工路径发生干涉。为此，用户必须在进行干涉检查之前用路径排序功能对路径的顺序进行调整。此外，刀刃长度必须在使用刀具以前设置。该值的大小对刀杆干涉与否的影响较大。而刀杆长度在系统内部是根据刀刃长度加2计算的。如果发生了卡头干涉，用户可以看到干涉的长度，从而在加工时使用较长的刀，或者用路径节点功能修改路径。


刀刃长度检查

8.3.1 刀刃长度检查

图8-13是 “刀刃长度检查参数”对话框，用户可以在该对话框中设置一个数字来增长或缩短计算干涉时使用的刀刃长度。

图8-13“刀刃长度检查参数”对话框


干涉检查结果

8.3.3 干涉检查结果

图8-15是“干涉检查结果”对话框。该对话框中列出了各刀具是否发生干涉，以及加工各路径所需刀刃的长度。

图8-15 “干涉检查结果”对话框


刀杆长度检查

8.3.2 刀杆长度检查

图8-14是“刀杆长度检查参数”对话框。在该对话框中可以通过“增加刀杆长度”参数来增长或缩短计算干涉时使用的刀杆长度，“所用卡头直径”参数可以设置卡头直径。选择“电机干涉检查”复选框，还可以对电机机头是否干涉进行检查。此时需要在设置两个关于电机位置和形状的参数。

图8-14 “刀杆长度检查参数”对话框


路径分析

8.2 路径分析

分析加工路径功能主要用于分析加工后的模型与最终模型的一致程度，是欠切或是过切，以及过欠切量的大小；可以分析各种走刀路径的加工效果，查看分析前后两把刀具的切削量大小，从而帮助用户寻找出合理的加工工艺方法

8.2.1.1 启动路径分析命令

在加工环境下选择“刀具路径>>分析加工路径”菜单项，或在导航工具栏的加工刀具面树状列表项上单击鼠标右键，弹出上下文菜单，选择“分析加工路径”菜单项，便进入分析加工路径命令。

图8-4 分析加工路径命令的导航工具条

选择该命令后，在导航工具条中会出现如图8-4所示的导航工具条。在用户指定两个比较模型的来源，设定好网格大小、误差表示方法以及比较区域大小后，单击“比较验证”按钮，便开始生成比较模型A和比较模型B。比较模型A的各网格点的高度减去比较模型B对应点的高度，便得到两模型的偏差。根据该值的大小和误差表示的范围来显示该点的颜色，从而以彩色模型的方式形象的体现两模型的偏差，达到比较加工路径的效果。

8.2.1.2 选择比较模型A和B

比较模型A可以是由路径生成的，也可以直接由毛坯来构成。比较模型B可以是加工零件的CAD模型，即最终模型，也可以由路径生成。在选择由路径生成模型后，“选择路径”按钮会变为有效状态，单击该按钮会弹出“选择路径”对话框。

当AB模型的来源不同时，该功能能够分析出模型的加工质量或吃刀量大小等状态。

1）当比较模型A为毛坯模型，B为最终模型时，通过该功能可以看到模型各处的切削量大小。

2）当A为路径生成模型，B为最终模型时，可以看到用A中所选路径加工，距离最终模型的差距。根据加工精度要求，从而可以确定所生成路径是否可以达到加工精度要求，是否需要改用其他刀具，或其他加工方法。

3）当A为毛坯模型，B为路径生成模型时，可以看到B中路径在模型各处的加工量大小。

4）当A、B同时为两组加工路径时，可以看到路径的切削量。具体来说，当B中路径包括A中路径，且比A多一个路径时，则可以分析B中所多的这个路径的切削量。譬如:A中为粗加工路径，B中为粗加工路径再加上一平行截线精加工路径，则可以分析平行截线精加工路径在加工时各处的吃刀量大小，可以分析出吃刀量过大或未接触材料的走刀路径。另外，AB中各有一组加工路径，可以比较两组路径的加工效果，以便选择一组更适合的路径加工。

8.2.1.3 设置毛坯面

在设定好比较模型后，用户可以通过单击“设置毛坯”按钮，在弹出如图8-6所示的“设置毛坯面”对话框中指定毛坯面。

8.2.1.4 比较验证

在选择好比较模型的生成方法，设定好比较区域后，单击“比较验证”按钮。如果比较模型B选择的是“路径生成”，系统弹出计算进度条开始比较验证。否则，系统会弹出表面余量对话框。用户可以在该对话框中设置最终模型的表面余量。

在比较验证计算过程中，系统出现如图8-5所示的计算进度条。它表明了计算的进度。在计算完成后，进度条消失，系统会根据用户设定的显示状态显示比较模型。“误差分析”按钮变为可用状态，用户可以查看比较模型各点高度差的分布情况。

图8-5计算进度条对话框

8.2.1.5 显示隐藏模型、路径和图形

分析加工路径功能提供了显示隐藏模型、路径或者图形的功能，以便用户能更清楚的观察路径、比较模型或者CAD图形。对于比较模型，用户可以选择模型下拉列表框中的显示A、显示B或不显示选项。对于路径，用户可以选择显示比较模型A中的路径、B的路径、AB共有的路径、全部显示或者全部隐藏。对于图形，可以选择全部显示或者全部隐藏。

8.2.1.6 误差分析

为了较形象的显示比较模型AB对应网格点的高度差，这里使用不同颜色来表示不同的高度差。单击“误差分析”按钮，会出现“设置分析”对话框，对误差进行分析。

8.2.1.7 结果汇总

如果系统调整了过切路径，“结果汇总”按钮就会变成可用状态。单击该按钮，弹出 “调整路径”对话框，可以对过切的路径进行调整

注意：分析加工路径功能只是提供了一种便于观察路径加工效果、分析切削量的一种手段。它能够帮助用户预先确定加工工艺是否合理、最终效果是否理想，提前发现错误，及时改进加工工艺。在观察比较模型时，用户可以使用诸如平移、旋转、缩放的视图变换的任何手段。在发现模型局部有异常时，应尽量将其放大，反复的显示隐藏路径、模型或图形，直至找到问题为止。在路径出现扰动时，可能是由于设计模型中的某曲面存在奇异变化、缝隙等引起，也可能是计算误差导致计算出错引起。此时，应当通过测量的方法找到路径偏差的多少。若在误差范围内，可以忽略。若偏差过大，可以使用路径节点编辑功能对路径进行修改。


误差分析

8.2.5 误差分析

图8-9是误差分析对话框。为了较形象的显示比较模型AB对应网格点的高度差，这里使用不同颜色来表示不同的高度差。

图8-9“误差分析”对话框

在对话框中央为域值和颜色列表框。每个列表项由一个颜色、一个下限值、一个上限值、该范围内的点数以及这些点的比率组成。高度差属于某范围的网格点，都用该范围的颜色表示。列表框中各项的上限值、下限值以及项数的多少，是通过修改偏差范围内的上偏差（a）、下偏差（b）以及细分格数(n)编辑框中的值来指定的。系统控制了细分格数的范围（1-10个）。在指定这偏差范围值后，单击“设置偏差值”按钮，系统会用上下偏差的范围(a-b)除以细分格数(n)，从而计算并设置列表框中各项的范围大小。

列表框中各项的颜色可以通过双击列表项，在弹出的标准颜色对话框中修改。若需要使用系统的缺省颜色，则单击“恢复缺省色”按钮即可。

在选择列表框中的某类型点后，选中对话框右上角的“显示选中类型点”复选框。在关闭该对话框后，系统会用同种颜色显示用户所选择类型的点。运用这种方法，用户可以非常方便的查看某类点的位置或范围。

注意：由于这些点和比较模型非常靠近，不是特别直观。用户可以在隐藏模型后，缩小观察所选择类型的点，再显示模型，查看这些点在模型上的大致位置。

当视野范围较大，屏幕上可以显示许多网格时，系统会优化显示，即间隔若干点显示一个点。此时需要对这些跳过点的颜色进行处理，以便用户能更轻易的查看到欲查找属性的区域。这可以通过优先使用颜色组合框中的单选项来选择。当用户欲查看过切区域或切削量较大的区域时，应当选择优先使用上偏差颜色。当用户欲查看欠切区域或刀具根本切削不到的区域时，应当优先使用下偏差颜色。若用户在查看时想同时看到上述情况，可以使用混合插值色选项。不过由于网格由颜色插值显示，必须在图形放的较大时才比较明显。

为了更清楚地看到某偏差范围内的区域，可以通过将该范围的颜色改为特别醒目颜色（譬如红色）的方法来查看。为了看清楚某位置的偏差大小，可以通过缩小上下偏差范围的方法来获得该区域的较精确的偏差值。

自动调整过切路径

当比较模型A是路径生成模型，比较模型B是最终模型时，在“误差分析”对话框的底部会出现“自动调整过切路径”按钮。如果红色（缺省情况下，即过切量在下偏差值之外的部分）区域的点成片存在，单击“自动调整过切路径”按钮，系统会自动计算这些过切的路径，并将它们自动调整到一个不过切的位置。当用户确认无严重过切路径，或者系统提示不存在过切路径时，便不再查找过切路径。

注意：自动调整过切路径功能特别适用于平行截线精加工掉刀的情况。如果路径存在大量过切，多次调用自动调整过切路径功能，路径能够有所改善。但此时路径可能存在欠切的现象，加工效果可能不理想。


设置表面余量

8.2.4 设置表面余量

图8-8是图形表面余量对话框。用户可以在该对话框中设置最终模型的表面余量。用户可以直接输入表面余量，或者单击“所选路径的最大余量”或“所选路径的最小余量”按钮，根据所选路径的余量设置。对于加工表面余量的处理方法，用户可以选择“较高精度”、“正常精度”或“较低精度”方法处理。缺省情况下，用“正常精度”方法处理表面余量。设置好表面余量后，单击“确定”按钮，开始比较计算。若单击“取消”按钮，则不予比较验证。

图8-8 图形表面余量对话框


选择比较路径

8.2.2 选择比较路径

如下图8-6所示，是“选择路径”对话框。

图8-6 选择路径对话框

在该对话框的树状列表中会显示当前刀具面下的所有路径。用户可以直接在树状列表中选择生成该比较模型的路径，也可以通过右侧的按钮按照路径的一些特性选择。当用户单击“按刀具选择”按钮时，会弹出刀具库对话框，选择一把刀具，则凡是由该刀具生成的路径都被选中。单击“选择可见路径”，则可见的路径全部被选中。单击“清除不可见路径”按钮，所有不可见路径都变为未选择状态。单击“所有路径”按钮，所有路径被选中。单击“全部清除”按钮，所有路径都变为未选择状态。


路径过滤

8.2.7 路径过滤

图8-11是“路径过滤”对话框。在该对话框中，用户可以设置显示待调整量是大于或小于某值的节点和路径。

图8-11“路径过滤”对话框


结果汇总

8.2.6 结果汇总

图8-10为“调整路径”对话框。

图8-10 “调整路径”对话框

“调整路径”对话框列出了被修改的路径和节点。左侧的树状结构列出了被修改路径的名称，以及被修改的路径段编号和节点编号。SurfMill根据路径、路径段以及节点的所属关系，将它们以树状结构的方式显示。

在对话框的右侧有待调整量、已调整量文本框。它们显示了用户所选中的树状节点以及该节点下所有节点的待调整量（通过计算获得）范围 和已调整量范围。

注意：这里所说的当前选择的路径或路径节点是指树状列表中所选节点及其下面的所有节点所对应的路径、路径段或（和）路径节点。

显示待调整路径复选框和显示选中路径复选框用来控制是否显示待调整路径和当前选择的路径。若处于显示状态，这些路径将以复选框后面的颜色显示。而显示颜色可以通过单击颜色框，在弹出的颜色对话框中进行选择设置。

用户可以通过三种方式对当前所选择的路径或节点的Z坐标进行修改，即手动调节、自动调节和恢复原始状态。其中，手动调整是根据Z微调量边界框中设置的值对所选择树状节点下的所有路径节点的Z坐标进行修改，即一起加上微调量值。自动调整是根据计算的调整量对所选择树状节点下的所有路径节点进行调整。而恢复原始状态是恢复到最初的状态，即调整前的原始路径的状态。该功能主要用于查看一些点的调整量。

注意：在调整过程中，用户可以在打开“调整路径”对话框的状态下显示或隐藏各种图形对象，可以任意缩放或移动显示的图形，以便于观察。

在“调整路径”对话框的有上角还有一个置灰的按钮（“待调整量>0.05”）。选中该按钮前的复选框，该按钮变成可用状态。此时，系统会根据调整量的大小范围对待调整的路径节点进行过滤显示。一般而言，用户可能不必关心一些调整量较小的路径。通过该功能将那些路径节点过滤掉，以便显示用户需要关心的路径节点。

单击“待调整量”按钮，会弹出“路径过滤”对话框。在该对话框中，用户可以设置显示待调整量是大于或小于某值的节点和路径。


设置毛坯面

8.2.3 设置毛坯面

图8-7所示是“设置毛坯面”对话框中。

图8-7“选择比较区域”对话框

毛坯面共有三种生成方式，即由长方体形状的块状材料构成，或者由某把刀对一些面（当前的可视面）进行平行截线精加工后构成，或者是由用户选择一些曲面构成。一般而言，使用长方体材料构成毛坯面。当用户是在被加工过的某工件上做清根或某种加工时，可以选择先前做加工所用的刀具来设置当前的毛坯面。如果用户有毛坯曲面，则可以直接选择这些毛坯面生成路径分析所用的毛坯面。在使用后两种方法生成毛坯面时，首先选择相应的毛坯面生成方式。如果是由精加工刀具生成，则“选择精加工刀具”按钮会变为有效状态。单击该按钮，在弹出的刀具库对话框中选择一把精加工刀具，所选刀具的名称会出现在该按钮后的文本框中。如果是由毛坯曲面生成，则“选择毛坯面”按钮会变为有效状态。单击该按钮，系统会提示用户选择曲面，选择结束时所选曲面的数目会出现在该按钮后的文本框中。（组合面中的曲面会按照分离为单张面时曲面的个数计算。）注意，凡是在毛坯面中出现的曲面将不再作为最终模型的曲面使用。需要特别指出的是，毛坯面的后两种生成方式特别适用于类似情况的干涉检查功能。因为有长方体材料构成的毛坯面在进行干涉检查时，时常会发现很多干涉的路径。而实际的材料并非长方体类型，在实际加工中不会发生干涉。

对于毛坯面，还可以在原有的基础上按法矢方向变厚一点或变薄一点，这是通过设置毛坯量参数实现的。该参数为正时，材料会在原有基础上再增厚一层；反之，则变薄一层。

图8-7所示对话框中角点1、角点2参数设置了比较区域的大小。比较区域大小可以通过单击“拾取”按钮，以拾取点的方式指定，也可以单击“模型尺寸”按钮，以模型的大小为比较区域。当用户知道欲比较区域的范围时，也可以直接输入坐标值。

注意两角点的Z坐标会决定毛坯上下表面的位置。用户在使用时，应当保证这两值一个大于等于比较区域内模型的最高点，另一个小于等于比较区域内模型的最低点。


路径节点编辑

9.1 概述

在讲述路径编辑之前，首先介绍一下路径的构成。每一种加工方法都会生成一个路径组。一般而言，路径组中含有许多条刀具路径，每一条刀具路径又是由一些路径段组成的，如直线段、圆弧段、折线段和快速抬刀等，而路径段又是由一些刀位点（以下称为节点）组成的。

路径编辑既包括对路径进行旋转、平移和镜像等变换操作，也包括对路径进行反向、裁剪、排序、分离、连接等操作，还包括对路径节点（刀位点）进行增加、删除、修改等编辑操作和路经子段的速度修改等。路径编辑的对象是三维的刀具路径。这部分提供的功能主要如表9.1所示，这些命令在界面中的位置如图9-1所示。当没有路径生成的时候这些命令是不可用的。

表9.1 路径编辑的方法

2D平移 | 在二维平面内将路径组从一个位置移到另一个位置。
2D旋转 | 在二维平面内将路径组按照一定的方向和角度旋转。
2D镜像 | 在二维平面内将路径组按照一定的轴线进行镜像。
路径平移 | 将路径组从一个位置移到另一个位置。
路径旋转 | 将路径组按照一定的方向和角度旋转。
路径镜像 | 将路径组按照一定的轴线进行镜像。
路径分离 | 将路径组中的某些路径分离开。
路径删除 | 删除路径组或者其中的某些路径。
路径反向 | 将路径组中的某条路径反向。
路径排序 | 对路径组中路径的先后顺序进行修改。
路径裁剪 | 用一个区域对路径组进行裁剪。
 | 用高度对路径组进行裁减。
路径节点 | 对路径中的节点进行编辑，包括删除、插入等。
路径连接 | 可以对两条路经进行连接。
路径子段 | 可以修改路经段的速度，并且插入任意点。

图9-1 路径编辑菜单命令


路径组的编辑

9.4 路径组的编辑

路径编辑的操作对象为刀具路径组和其中的刀具路径，它包括路径的分离、删除、反向、排序和裁剪和连接6个部分。

路径分离、删除和反向这三个功能的导航窗口和操作方法基本上是一致的。导航窗口如图9-18所示，只是每个窗口的复选框的名字不一样。

图9-18 路径分离、反向和删除的导航窗口


路径连接

9.4.6 路经连接

路径连接功能可以将两个距离比较近的路经连接起来，这样在加工的时候就避免频繁的抬刀，提高加工速度。

* 操作步骤：

1）选择菜单命令；

选择界面的“路径编辑(E)”>>“路径连接(C)”命令，操作界面的右边会弹出如图9-38所示的导航窗口。该导航窗有连接类型、连接方式和连接操作两组参数。连接类型分为整体连接和逐个连接两种类型；连接方式有三个按钮，分别为“局部高度连接”、“安全高度联机”和“沿着曲面连接”；连接操作有两个按钮，分别为“路经反向” 和“取消拾取”。

图9-38 路经连接的导航窗口

2）选择路径组；

当连接类型选择整体连接的时候，系统会提示选择一个路径组，这个命令会将路径组中的单条路径连接起来。

当连接类型为逐个连接的时候，系统将提示拾取一个单条路径。。当选择第二个单条路经的时候，“路径反向”和“取消拾取”两个按钮可用。“路经反向”按钮可以控制第二个路经的方向，也就是控制两个路经的连接方式（第一个路经的末端连接第二个的首端还是末端）；如果第二个路经选错了，点击“取消拾取”按钮就可以取消选择的第二个路径。如果不点击确定按钮，可以一直连接下去。

参数定义：

“局部高度连接”：第一条路径末点和第二条路径的首点相连，生成一条路径，然后将这条路径进行干涉检查，取出最高点的Ｚ坐标，然后将这条路径的高度抬高到Ｚ。

“安全高度连接”：第一条路径末点和第二条路径的首点相连，生成一条路径，然后将这条路径的高度抬高到安全高度。

“沿着曲面连接”：第一条路径末点和第二条路径的首点相连，生成一条路径，然后将这条路径进行干涉检查，得到无过切的连刀路径。

举例：

1、逐个连接：

如图9-39所示的两个路径。图9-40为局部高度连刀，图9-41为安全高度连刀，图9-42为沿着曲面连刀。

图9-39 连接前

图9-40 局部高度连刀

图9-41 安全高度连刀

图9-42 沿着曲面连刀

2、整体连接：

如图9-43所示的路径组，采用单向走刀，加工效率很低。图9-44为局部高度连刀，图9-45为安全高度连刀，图9-46为沿着曲面连刀。

图9-43 连接前 图9-44 局部高度连刀

图9-45安全高度连刀 图9-46 沿着曲面连刀


路径删除

9.4.2 路径删除

路径删除功能是删除路径组中的某条或者多条刀具路径。一般用来删除不需要加工的路径。

* 操作步骤：

1）选择菜单命令；

选择界面的“路径编辑(E)”>>“路径删除(D)”命令，操作界面的右边会弹出如图9-18所示的导航窗口。该导航窗口有两个列表框，第一个提示用户拾取路径组，第二个提示用户拾取该路径组中的路径。

2）选择路径组；

选择要删除的一个路径组，也可以用鼠标点左键点击第一个列表框，激活这个命令，重新选择路径组，路径组的名字显示在第一个列表框中。

3）选择路径组中的路径。

选择完路径组后，点击第二个列表框，激活该命令，选择路径；或者在选择完路径组后，点击鼠标右键，也能切换到这个命令，以便拾取单条路径。用户只能选中被选中路径组中的路径，选中的路径列在第二个列表框中。选择完毕后，点击“确定”按钮，就可实现这个操作。

参数定义：

路径组删除复选框：选中这个复选框，是删除整个路径组，而且第二个列表框中的选项都被清除掉，并且这个列表框变为不可用状态。

注意：其注意事项与路径分离的一样。

举例：

拾取的路径组如图9-19所示，选择上面的那条路径进行删除，效果如图9-22所示。如果选择了删除路径组复选框，则会删除整个路径组。

图9-22 删除单条路径


路径反向

9.4.3 路径反向

路径反向是对刀具路径组中单条或者多条路径的走向进行反向，以实现加工中顺逆铣的互换。

* 操作步骤：

1）选择菜单命令；

选择界面的“路径编辑(E)”>>“路径反向(V)”命令，操作界面的右边会弹出如图9-18所示的导航窗口。该导航窗口有两个列表框，第一个提示用户拾取路径组，第二个提示用户拾取该路径组中的路径。

2）选择路径组；

选择要反向的路径组。也可以用鼠标点左键点击第一个列表框，激活这个命令，重新选择路径组，路径组的名字显示在第一个列表框中。

3）选择路径组中的路径。

选择完路径组后，点击第二个列表框，激活该命令，选择路径；或者在选择完路径组后，点击鼠标右键，也能切换到这个命令，拾取单条路径。只能选中该路径组中的路径，选中的路径列在第二个列表框中。选择完毕后，点击“确定”按钮，就可实现这个操作。

参数定义：

路径组反向复选框：选中这个复选框，是将整个路径组的顺序反过来，而且第二个列表框中的选项都被清除掉，并且这个列表框变为不可用状态。

注意：注意事项与路径分离一样。

举例：

1、路径的反向：将某条或者多条路径的走刀顺序反过来。如图9-23所示，ａ图为反向前的路径和走刀方向，ｂ图为反向后的路径和走刀方向。

2、路径组的反向：将路径组的走刀顺序反过来。

如果将图9-19所示的路径组反向，则非但单个路径的加工顺序反过来，而且路径组中路径的排列顺序也将反过来。

图9-23


路径分离

9.4.1 路径分离

路径分离功能可以清除路径组中的被选中路径的快速抬刀路径。抬刀路径是连接两条路径的路径，用绿线表示。

* 操作过程如下：

1）选择菜单命令；

选择界面的“路径编辑(E)”>>“路径分离(P)”命令，操作界面的右边会弹出如图9-18所示的导航窗口。该导航窗口有两个列表框，第一个提示用户拾取路径组，第二个提示用户拾取被选中路径组中的路径。

2）选择路径组；

选择一个要分离的路径组。也可以用鼠标左键点击第一个列表框，激活这个命令，重新选择路径组。路径组的名字显示在第一个列表框中，如图9-18所示。

3）选择路径组中的路径。

选择完路径组后，点击第二个列表框，激活该命令，可以选择路径；也可以在选择完路径组后，点击鼠标右键，切换到这个命令中，以便拾取单条路径。用户只能选中被选中路径组中的路径。被选中的路径列在第二个列表框中。选择完毕后，点击“确定”按钮，就可实现这个操作。

参数定义：

路径组分离复选框：选中这个复选框，是分离整个路径组，而且第二个列表框中的选项将被清除掉，并且这个列表框变为不可用状态。

注意：

1）操作顺序只能是先拾取路径组，然后再拾取该路径组中的路径。

2）复选框的级别高于第二个列表框。即，如果选中路径组分离复选框，第二个列表框将不起作用。

3）路径组只能拾取一个。用户可以在拾取路径组状态下拾取其它的路径组。

举例：

当拾取到如图9-19所示的路径组后，该路径组变成绿色，第一个列表框中会出现这个路径组的名称，这个路径组有两层路径。然后点击第二个列表框，这时系统提示用户拾取该路径组中路径。选择下面的那条路径，该路径的名字会出现在第二个列表框中。选择“确定”按钮，就将该路径中的快速抬刀删除了，效果如图9-20所示。如果选择了路径组分离复选框，则会删除整个路径组中的快速抬刀，效果如图9-21所示。

图9-19 路径组

9-20 单条路径分离

图9-21 路径组分离


路径排序

9.4.4 路径排序

路径排序功能可以更改路径组中路径的加工顺序。

* 操作步骤：

1）选择菜单命令；

选择界面的“路径编辑(E)”>>“路径排序(O)”命令，操作界面的右边会弹出如图9-24所示的导航窗口。该导航窗口的第一行是五个按钮，从左到右分别表示删除、向上移动一位、向下移动一位、移到最上面和移到最下面。之后是两个列表框，第一个提示用户拾取路径组，第二个列表框则列出了该路径组中的所有路径。

2）选择路径组；

选择一个需要排序的路径组。也可以用鼠标左键点击第一个列表框，激活这个命令，重新选择路径组，路径组的名字显示在第一个列表框中。

3）对路径的顺序进行修改。

选择完路径组后，路径组中的路径就列在第二个列表框中。利用这五个按钮，对第二个列表框中的路径顺序进行修改或者删除路径。操作完毕后，点击“确定”按钮，就可实现这个操作。

图9-24排序前 图9-25 排序后

举例：

图9-26路径组

图9-26是一个路径组，它含有5条路径，加工顺序是从上到下一条一条加工。选中该路径后，导航窗口如图9-24所示。删除第3条路径，将第1条和第2条移到最下边，如图9-25所示。确定后，路径组如图9-27所示，这样在加工的时候，先从4条开始，然后是第5条和第1、第2条。排完序后，可以使用系统的加工模拟功能来观察排序后的结果。

图9-27 排序后的结果


区域裁减

9.4.5.1 区域裁减

区域裁减就是用一个闭合的区域对路径组进行裁剪，以得到在其内部或者外部的路径，也可以使用这个闭合区域将路径打断。

* 操作步骤：

1）选择菜单命令；

选择界面的“路径编辑(E)”>>“路径裁剪(T)”>>“区域裁减(A)”命令，操作界面的右边会弹出如图9-28所示的导航窗口，该导航窗口有一个列表框和两个复选框。列表框提示用户选择一个路径组。两个复选框分别为去掉内部路径和去掉外部路径，缺省的情况下为路径打断。如果没有选择曲线进行裁剪或者裁剪没有成功，则复选框是不可用的。

图9-28 导航窗口

2）选择路径组；

选择要裁剪的一个路径组。也可以用鼠标点左键单击列表框，激活这个命令，重新选择路径组，路径组的名字显示在列表框中。

3）选择封闭的曲线进行裁剪。

选中一个路径组以后，导航窗口下面会出现如图9-28所示的三个按钮，分别为对象过滤、取消拾取和结束拾取。这时，系统会提示用户选择封闭的曲线。如果曲线不封闭，系统会继续提示用户拾取曲线，直到拾取的曲线闭合为止。点击结束拾取按钮，系统会进行裁剪计算，用户可以通过选择复选框来决定裁剪的结果。

参数定义：

“去掉内部路径”复选框：选中后，删除环内的那部分路径。

“去掉外部路径”复选框：选中后，删除环外的那部分路径。

“结束拾取”按钮：表示曲线拾取结束，系统开始进行裁减计算。

“取消拾取”按钮：则取消拾取的曲线。

“对象过滤”按钮：点击该按钮，弹出拾取过滤对话框，这里可以筛选拾取的对象。

注意：

1、裁减是这样进行的：系统将闭合曲线投影到路径组所在加工面上，构成封闭的环，然后将每条路径段也投影在该加工面上，同环进行裁减运算。

2、两个复选框为一个组，最多只有一个被选中。如果两个复选框都没有选中，系统将路径用拾取的曲线进行打断处理，分成环内和环外的两个路径组。

举例：

拾取的路径组如图9-29所示，导航窗口如图9-28所示。拾取该图中的闭合曲线作为裁减线，可以观察裁减的结果。图9-30是默认的“路径打断”的结果，图9-31是选择“去掉内部路径”按钮的结果，图9-32是选“去掉外部路径”按钮的结果。

图9-29 路径组和闭合的曲线

图9-30 路径组打断

图9-31 去掉内部路径

图9-32 去掉外部路径


高度裁减

9.4.5.2 高度裁减

高度裁减就是用一个高度值对路径组进行裁剪，以得到在这个高度之上或者之下的路径，也可以使用这个高度将路经分为两部分。

* 操作步骤：

图9-33 导航窗口

1）选择菜单命令；

选择界面的“路径编辑(E)”>>“路径裁剪(T)”>>“高度裁减(Z)”命令，操作界面的右边会弹出如图9-33所示的导航窗口，该导航窗口有一个列表框、一个文本框、一个按钮和两个复选框。列表框提示用户选择一个路径组。文本框中输入裁减的高度。点击裁减计算按钮，就开始对路经进行裁减（会弹出进度条显示裁减的进度）。两个复选框分别为去掉上部路径和去掉下部路径，缺省的情况下为路径分开。如果高度裁剪没有成功，则复选框是不可用的。

参数定义：

“Z向高”：填写裁减的高度。

“去掉上部路径”复选框：选中后，删除Z向高度之上的那部分路径。

“去掉下部路径”复选框：选中后，删除Z向高度之下的那部分路径。

注意：

1、两个复选框为一个组，最多只有一个被选中。如果两个复选框都没有选中，系统将路径用给定的高度值分成上下两部分。

举例：

拾取的路径组如图9-34所示，导航窗口如图9-33所示，给定的裁减高度为20，可以观察裁减的结果。图9-35是默认的“路径打断”的结果，图9-36是选择“去掉上部路径”按钮的结果，图9-37是选“去掉下部路径”按钮的结果。

图9-34 拾取的路径组

图9-35 路径组分开为上下两部分

图9-36 去掉上面路经的结果

图9-37 去掉下面路经的结果


路径节点

9.5 路径节点

路径节点的操作对象主要是路径中的路径段，也可以是刀具路径。主要包括删除当前选中路径、删除单个、多个和区域内的节点、单条路径的反向、修改和插入路径的节点以及节点处打断等功能。如果是封闭的路径，还可以重新定义路径的起点。所有这些操作可以分为对路径的操作和对路径段（路径节点）的操作。下面，首先介绍对路径的操作。

9.5.1 对路径的操作

对路径的操作包括隐藏其余的路径、显示隐藏的路径和删除当前路径３个部分。

* 操作步骤：

1）选择菜单命令；

选择界面的“路径编辑(E)”>>“路径节点(N)”命令，操作界面的右边会弹出一个导航窗口。该窗口含有多个按钮，没有拾取路径时，这些按钮大都是不可用的。

2）拾取刀具路径；

拾取一条路径后的导航窗口如图9-47所示。系统将路径上的刀位点用一个个的黑色立方体画出来，路径的起点用红色的箭头画出来，末点用蓝色的箭头画出，如图9-48所示。

图9-47 路径节点导航窗口

图9-48 路径节点

3）三项操作功能。

隐藏其余的路径 | 这个按钮可以隐藏当前路径所在路径组的其余路径，以便于对当前选择的路径进行操作。
显示隐藏的路径 | 只有当有路径被隐藏时，该命令才可用。显示被隐藏的路径组。
删除当前路径 | 删除选中的那条路径。

9.5.2 对路径节点的操作

选中一条路径后，就可以对路径节点进行操作了。这部分内容包括节点删除、区域节点删除、路径节点反向、定位路径起点、修改路径节点、插入路径节点和节点处打断等功能。在拾取节点个数的文本框中显示当前拾取的节点的个数。下面将分别进行介绍。

9.5.2.1 节点删除

节点删除功能是删除选中的节点。一般用于删除错误的刀位点。

* 操作步骤：

1）选择节点；

选择节点的方式有两种，一种为单选，另一种为框选。系统会将选中的节点用红色的立方体画出来，按shift键是追加选中的节点，按ctrl键是减少选中的节点。

2）删除节点。

选中节点以后，按键盘的“Delete”键，就可以删除选中的节点。点击导航窗口的节点“删除设置”按钮，可以设置删除节点后的连接方式。删除后的连接方式有直接连接和圆弧连接两种方式。

注意：节点删除的时候要保证重新连接的路径不会发生过切。

举例：

直线连接：选择路径中的一个节点，如图9-49所示，删除这个节点后，路径采用直线连接方式，如图9-50所示。

图9-49 拾取节点

图9-50 直线连接

圆弧连接：如图9-51所示，选择一个节点，删除节点后，路径能够采用圆弧连接，效果如图9-52所示。

图9-51 拾取节点

图9-52圆弧连接

9.5.2.2 区域节点删除

区域节点删除是删除某一个区域内的节点。

* 操作步骤：

1）选择命令；

选择导航窗口的区域节点删除命令。

2）画闭合的区域；

选择命令之后，系统提示画一个闭合的区域，点击右键结束。则在这个闭合区域中的节点都被选中了。在画区域的过程中，不要作旋转操作。因为这个时候的选择节点是由视线的方向决定的。

选择完节点之后，按下键盘的“Delete”键，选中的节点就被删除了

举例：

图9-53为一个路径组，图9-54为画的区域，图9-55为选中的路径节点，图9-56为删除节点后的结果。

图9-53原始路径组

图9-54画闭合区域

图9-55 使用闭合拾取的节点

图9-56 删除节点的结果

9.5.2.3 路径节点反向

同路径反向的作用一样，将一条路径的走向进行反向。

* 操作步骤：

直接选择命令。

在选中一条路径的条件下，直接选择导航窗口的路径节点反向功能即可。

9.5.2.4 定为路径起点

定为路径起点实现的功能是改变一条封闭路径的起始位置。

* 操作步骤：

1）选择一个节点；

选择封闭路径上的一个节点后，这个命令才可以使用。

2）选择命令。

选择一个节点后，单击导航窗口中的定为路径起点按钮，就可以实现这个功能。

注意：该路径必须是封闭的，而且选择的节点必须只有一个。

举例：

选择的路径和节点如图9-57所示，操作后的路径如图9-58所示。

图9-57 路径和拾取的节点

图9-58 重新定端点的路径

9.5.2.5 修改路径节点

这项功能可以修改节点的坐标。

* 操作步骤:

1）选择节点；

选择路径上的一个节点。

2）选择命令；

选中节点以后，选择导航窗口的“修改路径节点”命令，弹出如节点坐标对话框，可以对坐标进行修改。在修改的同时就可以看到修改的效果。

注意：

1）该项功能只有在选择一个节点的时候才能使用。

2）要保证修改后的节点不会发生过切。

举例：

选择如图9-59所示的路径和节点，节点的坐标是（-47.303，-7.970，0.000），修改后的坐标是（0.000，0.000，50.000），结果如图9-60所示，在修改坐标的过程中，用户可以观看修改的效果。

图9-59 路径和节点

图9-60 修改后的节点

9.5.2.6 插入路径节点

这个命令实现的功能是在选中的路径中插入一些节点。

* 操作步骤：

1）选择命令；

选择导航窗口的“插入路径节点”命令，节点插入对话框。在该对话框中，设置参考点的坐标、插入点的位置和坐标，就可以插入一个节点。在插入节点的过程中，可以随时观察效果。

注意：要保证插入的节点不会发生过切。

举例：

如图9-59所示，拾取的点为参考点，坐标为（-47.303，-7.970，0.000），插入点的位置选择插入点前，插入点的坐标输入为（0.000，0.000，50.000），结果如图9-61所示。在插入节点的过程中，可以实时地观察插入的效果。

图9-61 插入一个节点

9.5.2.7 节点处打断

这个命令实现的功能是将路径在选择的节点处打断，一分为二。

* 操作步骤：

1）选择节点；

在路径上选择一个节点，这时节点处打断命令变为可用状态。

2）选择命令。

选中节点以后，选择导航窗口的节点处打断命令，就可以实现该功能，也可以使用键盘的“B”键。

注意：该项功能也只有在一个节点被拾取的时候才可以使用。

举例：

如图9-62所示的一条路径，选中其中的一个节点。在点击“节点处打断”后，生成如图9-63和图9-64所示的两条路径。

图9-62 路径和节点

图9-63一条路径

图9-64 另一条路径


节点连接方式

9.5.3 节点连接方式

图9-65是节点连接方式对话框，该对话框在节点删除之前使用的，用来设置节点删除后的连接方式。

直线连接 | 是指删除节点后，该节点的前后节点之间用直线连接上。
圆弧优先 | 是指当该删除的点位于圆弧上的时候，该点前后两边的点可以采用三点圆弧的方式进行连接。

图9-65 节点连接方式对话框


节点坐标

9.5.4 节点坐标

图9-66所示的对话框是节点坐标对话框。利用这个对话框可以对节点的坐标进行修改。

图9-66 节点坐标

参数定义：

参数设置：步长文本框用于设置每次移动的距离大小。如果选择的是闭合路径的端点（首末点重合点），可以通过选择单选按钮来确定选择的是首点还是末点。

节点坐标：显示要修改的节点的坐标。用户可以直接修改数字，也可以按每个坐标后面的微调按钮，按步长修改点的位置。


插入节点

9.5.5 插入节点

图9-67所示的对话框是节点插入对话框，使用这个对话框，可以在路径中添加节点。

图9-67 节点插入

参数定义：

“参考点”按钮：参考点是路径上的某个节点。用户可以通过首末点单选按钮直接选择路径的首末端点，也可以通过点击“参考点”按钮选择参考点。

首末点：有两个单选按钮，分别选择首点和末点。对于闭合路径，如果用户选择了端点，则可以通过这两个单选按钮来区分选择的是首点或末点。

参考点坐标：显示参考点的坐标，这个坐标是不可编辑的。

插入位置：可以指定在参考点之前插入一个点，或是在参考点后面插入。

“插入点”按钮：点击该按钮，选择插入点。

插入点坐标：显示插入点的坐标。用户可以直接编辑点的坐标。


路径子段

9.6 路径子段

路经子段的操作对象是组成路经的一些直线段或者圆弧段。它是针对高级用户制定的功能，可以对每个子段的速度进行编辑，控制机床的加工速度，也可以将某个子段分割成任意多个子段，对每一段进行速度控制。

9.6.1 命令讲解

* 操作步骤：

1）选择菜单命令；

选择界面的“路径编辑(E)”>>“路径子段(S)”命令，操作界面的右边会弹出一个导航窗如图9-68所示。该窗口含有两个复选框、三个文本框、两个旋钮和多个按钮，没有拾取路径时，这些按钮大都是不可用的。

图9-68导航窗口

2）拾取刀具路径；

拾取一条路径后，系统将该路经的第一个路径段上的刀位点用一个个的黑色立方体画出来，路径的起点用红色的箭头画出来，末点用蓝色的箭头画出，如图9-69所示。

图9-69拾取一条路经

参数定义：

“只显示当前路经”：默认状态下，这个复选框是选中的。当有多条路经的时候，为了便于观察和操作，只显示当前拾取的路经，别的路经都会被隐藏起来。

“只显示当前路径段”：默认状态下，这个复选框没有被选中。为了方便操作当前的路径段，可以选中该复选框，这样，屏幕上就只显示当前操作的路经段。

路经序号：显示当前操作的路经在整个路径组中的序号，当有多条路经的时候，后面的旋钮可以使用，通过按动旋钮，可以编辑这个路径组中别的路径。

路经子段：显示当前编辑的路经子段在路经中的序号，当有多个子段的时候，可以使用后面的旋钮来选择要边界的子段。

进给速度：这个文本框是不可写的，显示当前边界的子段的加工速度，单位是米/分钟。

9.6.2 子命令

路经子段这个命令提供五个功能，分别是参看路经参数、编辑速度参数、固化快速连刀、节点处断开和插入节点等。下面一一介绍。

9.6.2.1 察看路经参数

察看路经参数可以提供用户当前编辑的路径子段的加工信息，包括进给速度范围和主轴转速范围等。

* 操作步骤：

1）选择路经；

选择一路经组之后，利用路经序号后面的旋钮，找到要察看的那条子段所在的路经。

2）选择路经子段。

选择一路经之后，利用路经子段后面的旋钮，找到要察看的那条子段，点击下面的察看路经参数按钮即可。

举例：

如图9-69所示的一条路径，选中其中第7个子段，点击“察看路经参数”按钮，就可弹出路径参数对话框。

9.6.2.2 编辑速度参数

边界路经参数功能可以修改当前路经子段的速度。

* 操作步骤：

1）选择路经；

选择一路经组之后，利用路经序号后面的旋钮，找到要修改速度的那条子段所在的路经。

2）选择路经子段。

选择一路经之后，利用路经子段后面的旋钮，找到要修改速度的那条子段，点击下面的编辑速度按钮即可。

举例：

如图9-69所示的一条路径，选中其中第7个子段，点击编辑速度参数按钮，就可弹出“速度变量”对话框，对进给速度进行编辑。

9.6.2.3 固化快速连刀

固化快速连刀功能可以将路经中的快速抬刀段变成路经段，然后提高这个子段的速度，这样可以避免快速抬刀，提高加工效率。

* 操作步骤：

1）选择路经；

选择一路经组之后，利用路经序号后面的旋钮，找到要快速抬刀的那条子段所在的路经。

2）选择路经子段。

找到当前路经中的快速抬刀，这时固化快速连刀按钮可用，点击这个按钮，就可以实现快速抬刀的固化。

举例：

如图9-69所示的一条路径，该路经中的第16个子段是快速抬刀路经，点击路经子段后面的旋钮，将其序号调到16，这时固化快速连刀按钮可以使用，点击该按钮，就将这个子段转换成路径段，如图9-70所示。

9-70固化快速连刀

9.6.2.4 节点处断开

节点处断开功能就是将该条路经在拾取的节点处打断，分成两条路经，这个功能同路经节点中的节点处打断是一样的，这里不再讲述。

9.6.2.5 插入节点

插入节点功能同路经节点的插入节点还不一样。路经子段中插入的节点不是空间的任意点，而是选择该的路经子段上的点。

* 操作步骤：

1）选择路经；

选择一路经组之后，利用路经序号后面的旋钮，找到路经子段所在的路经。

2）选择路经子段。

利用路经子段后面的旋钮，找到相应的路经子段。

3）选择当前子段中的一个节点（不要选择末点），这个时候插入节点按钮可以使用。点击该按钮，其它按钮都变会，这个按钮的状态为按下。当鼠标在路经子段上活动的时候，会出现一个导航符号，表示当前位置可以插入一个节点，如图9-71所示，点击鼠标左键，就在该点处插入一个节点。然后可以在选中节点和插入的节之间继续插入节点，点击鼠标右键，退出这个命令。

9-71固化快速连刀

举例：

在如图9-71所示的位置，插入一个节点，得到的结果如图9-72所示。

9-72固化快速连刀


路径子段参数

9.6.3 路经参数

图9-73是路径参数对话框，这个对话框列出了加工这个子段的进给速度和主轴转速的范围。这个对话框里面的参数都是不能边界的。

图9-73察看路经参数


编辑速度参数

9.6.4 编辑速度参数

图9-74的对话框为速度变量对话框，修改这个对话框中的值，可以改变当前编辑的那个子段的进给速度。

图9-74编辑速度参数


路径组的坐标变换

9.3 路径组的坐标变换

路径坐标变换的操作对象是刀具路径组，它包括路径组的平移、旋转和镜像，有二维和三维之分。路径的二、三维变换的操作方法同平面中的二、三维变换的使用方法是一致的，可以参考平面里面的二、三维变换，在这里就不再赘述。


2D镜像

9.3.1.4 镜像变换

对选择的路径以某一条直线为对称轴，进行对称映像或对称拷贝。镜像变换的导航工具栏选项如图9-8所示。

图9-8 镜像变换导航工具栏选项

参数定义：

水平镜像：对路径在水平方向上进行镜像。

竖直镜像：对路径在竖直方向上进行镜像。

复制图形：选择此选项为镜像拷贝，不选择此选项则为镜像移动。

根据对称轴的不同，镜像变换可分为以下三种方式：

1、任意角度镜像：所定义的对称轴为任意角度方向的直线；

2、水平镜像：对称轴为过路径的中心且与X轴平行的直线；

3、竖直镜像：对称轴为过路径的中心且与Y轴平行的直线。

1、任意角度镜像

定义任意一角度的直线为对称轴来对选择的路径进行镜像。如图9-9所示。

图9-9 任意角度镜像变换

实现方法：

（1）选择路径对象；（2）启动镜像命令；

（3）输入基点；（4）输入镜像角度。

* 操作步骤：

1） 择路径对象：在屏幕上拾取要进行镜像变换的路径，可拾取多个路径对象。

2） 启动镜像命令：点击“路径编辑(E)”->“2D镜像(M)”菜单项，启动命令。

3） 请输入基点：定义镜像轴的基点。

4） 请输入镜像角度：定义镜像轴的角度，可直接输入角度值，也可移动鼠标确定一点，通过基点与这个点之间的方向矢量来定义角度。角度值为绕基点从X轴正向逆时针转过的角度。

5） 请输入基点：定义下一次镜像的基点，或单击右键结束。继续输入坐标，可对选中的路径进行多次镜像操作。

2、水平和竖直镜像

以过路径中心且与X/Y轴平行的直线作为对称轴来对选择的路径进行镜像。

(a) 水平镜像 (b) 竖直镜像

图9-10 水平镜像和竖直镜像

实现方法：

（1）选择镜像对象；（2）启动水平镜像或竖直镜像命令。

* 操作步骤：

1） 选择镜像对象：在屏幕上拾取要镜像的路径，可拾取多个路径对象。

2） 启动水平镜像或竖直镜像命令：点击“路径编辑(E)”->“2D镜像(M)”菜单项，启动命令，点击导航工具栏中的“水平镜像”或者“竖直镜像”按钮。


2D平移

9.3.1.1 平移变换

将路径从一个位置移动或复制至另一位置。平移变换导航工具栏中的选项如下图9-2所示。

图9-2 平移变换导航工具栏选项

距离平移 | 通过直接定义路径在X和Y方向上的平移距离来进行平移变换。
【复制图形】 | 选择该选项，可将路径在目标位置上进行复制；否则进行移动。

路径有两种平移方法：两点平移法和距离平移法。其中两点平移法是系统默认的方法。

1、两点平移

定义平移的基点和移动点，通过这两个点定义平移的距离和方向来进行平移变换。如图9-3所示。

图9-3 两点法平移变换

实现方法：

（1）选择要平移的路径；

（2）启动平移变换命令；

（3）输入平移基点和移动点。

* 操作过程如下：

1） 选择要平移的路径：在屏幕上拾取要平移的路径，可拾取多个路径对象。

2） 启动平移变换命令：点击“路径编辑(E)”->“2D平移(L)”菜单项，启动命令。

3） 输入基点和移动点：用鼠标直接输入坐标或者在输入窗口输入点的坐标，在输入完移动点坐标后，路径就实现了平移。继续输入坐标，可以实现多次平移。

2、距离平移

通过定义路径在X和Y方向上的偏移距离确定出路径的新位置。如图9-4所示。

图9-4 距离平移变换

实现方法：

（1）选择要平移的路径；

（2）启动距离平移命令；

（3）定义路径在横向和纵向的偏移量。

* 操作步骤：

1） 选择要平移的路径：在屏幕上拾取要平移的路径，可拾取多个路径对象。

2） 启动距离平移命令：点击“路径编辑(E)”->“2D平移(L)”菜单项，启动命令，然后点击导航工具栏中的“距离平移”按钮。

3） 定义路径在横向和纵向的偏移量：在弹出的“距离偏移”对话框中定义路径在横向和纵向的偏移距离。


2D旋转

9.3.1.3 旋转变换

将选择的路径绕一指定点（旋转基点）旋转一定的角度。如图9-6所示。

图9-6 旋转变换

实现方法：

（1）选择旋转对象； （2）启动旋转变换命令；

（3）输入旋转基点和参考点； （4）输入旋转角度。

* 操作步骤：

1） 选择旋转对象：在屏幕上拾取要旋转的路径，可拾取多个路径对象。

2） 启动旋转变换命令：点击“路径编辑(E)”->“2D旋转(R)”菜单项，启动命令。

3） 请输入基点：输入旋转基点。

4） 请输入参考点：输入旋转参考点。

5） 请输入旋转角度：输入旋转角度。可直接输入旋转角度，或移动鼠标拾取一点来确定。继续输入，可以进行多次的旋转变换。

参数定义：

复制图形：是否进行旋转拷贝。选中该选项，可将选择的路径在新的角度位置处进行复制；不选择该选项，则对选择的路径进行旋转移动。

说明：旋转基点和参考点定义了旋转变换的0角度方向；旋转角度是绕基点从此0角度方向上逆时针转过的角度（如图9-7）；

图9-7 旋转角度


距离偏移

9.3.1.2 距离偏移

图9-5所示的对话框为距离偏移对话框，用于定义图形在横向和纵向的偏移距离，点击“拾取>>”按钮可以启动“长度-距离发生器”来定义偏移距离。

图9-5 图形偏移量定义对话框


3D镜像

9.3.3.3 三维镜像

将选中的路径在三维空间中相对某一平面进行对称映像。

图9-15 3D镜像变换

实现方法：

（1）启动三维镜像变换命令；（2）拾取要进行镜像变换的图形；

（3）定义镜像平面的基点和法矢；（4）定义其它镜像参数。

* 操作步骤：

1） 启动三维镜像命令：点击“路径编辑(E)”-〉“路径旋转(M)”菜单项。

2） 选择曲线或曲面：拾取要进行镜像的路径对象。

3） 定义镜像平面的基点和法矢量：定义镜像平面，包括平面基点和平面法矢。可以在参数定义页(图7-7)中直接输入平面基点(Sx、Sy和Sz)和平面法矢(Vx、Vy和Vz)，或通过矢量选项组来定义。

4） 定义其它镜像参数：定义是否删除原始路径选项。

5） 结束命令：点击参数定义页中的“确定”按钮，实现该命令。

参数定义：

三维镜像变换的参数和选项如图9-16：

图9-16 3D镜像参数定义　　　　　　　　图9-17 镜像平面的定义

镜像平面基点：定义平面的基点(Sx、Sy和Sz)。

镜像平面的法矢：定义平面法矢(Vx、Vy和Vz)。如图9-17所示。

保留原始路径：选择此选项，则为镜像拷贝，镜像后保留原始路径；不选此选项，则镜像后原始路径将被删除掉。


3D平移

9.3.2.1 三维平移

将选中的路径在三维空间中沿着一方向从一个位置移动到另一个位置。

图9-11 三维平移

实现方法：

（1）启动三维平移变换命令； （2）选择要进行平移的曲线或曲面对象；

（3）定义平移方向矢量； （4）输入平移距离等平移参数和选项。

* 操作步骤：

1） 启动三维平移变换命令：点击“路径编辑(E)”-〉“路径平移(L)”菜单项。

2） 拾取路径：拾取要进行平移的路径对象。

3） 定义平移方向矢量：定义三维空间中平移方向矢量。可直接输入方向矢量分量值(Vx,Vy和Vz)，也可以通过矢量选项组进行定义。

4） 输入平移距离等参数定义：输入平移距离、定义是否删除原始路径选项。

5） 结束命令：点击参数定义页中的“确定”按钮，实现平移操作。

参数定义：

三维平移的参数和选项如图9-12所示。

图9-12 三维平移参数和选项

平移距离（Dx,Dy,Dz）：若为正值，则为图形沿着所定义的平移方向进行移动的距离；若为负值，则为图形沿着平移方向的反方向进行移动的距离。

保留原始图形：选中此选项，则将原始路径在新的位置进行拷贝；不选此选项，则在平移后将原始路径删除掉。

数目：将选择的路径在给定的方向上，按照给定的数目进行复制，路径之间的距离就是用户设定的距离。


3D旋转

9.3.2.2 三维旋转

将选中的路径在三维空间中绕某一轴线旋转一定的角度。

图9-13 三维旋转

实现方法：

（1）启动三维旋转变换命令； （2）拾取要进行旋转的图形；

（3）定义旋转轴的基点和方向； （4）输入旋转角度；

（5）定义其它旋转参数。

* 操作步骤：

1） 启动3D旋转变换命令：点击“路径编辑(E)”-〉“路径旋转(R)”菜单项。

2） 选择曲线或曲面：拾取一个或多个要旋转的图形，单击鼠标右键结束旋转图形拾取。

3） 定义旋转轴的基点和方向：定义旋转轴基点和方向。

4） 输入旋转角度：可直接输入角度值，也可以拖动下面的滑杆来调节旋转角度值。旋转角度值的范围为(-360~360)，并且相对于旋转轴满足“右手定则”。

5） 定义其它旋转参数：定义是否删除原始图形选项。

6） 结束命令：点击参数定义页中的“确定”按钮，实现这个操作。

参数定义：

三维旋转变换的参数和选项如图9-14：

图9-14 3D旋转参数

旋转轴基点：旋转轴的基点坐标。

旋转轴方向：旋转轴的方向矢量值。

保留原始路径：选择此选项，则在新的角度处对原始图形进行拷贝；不选此选项，旋转变换后原始图形将被删除掉。

旋转角度：图形相对于旋转轴的旋转角度。

数目：将拾取的路径从给定的位置，旋转复制给定的数目，每个路径之间的角度就是已知角度。


工艺树的使用

第十章 工艺树的使用

在界面的右边，是一个导航窗口，如图10-1所示。该窗口中有一个树状控件。这个树状控件记录了用户的加工工艺，称之为工艺树。

工艺树有两大作用，一个是记录用户生成的刀具路径，另一个是用户可以在工艺树上对生成的路径进行编辑。

工艺树的父结点是“加工项目”，两个子结点分别为“项目设置” 和“加工面（顶视图）”。如果系统添加了新的加工面，则新的加工面也加在“加工项目”这个结点下。

图10-1 导航窗口


加工面节点

10.2 加工面结点

系统默认的加工面是顶视图。如果需要，用户可以使用“加工面”命令添加用户需要的加工面或者加工模式。新的加工面也放在加工项目结点下，同顶视图加工面属于同一等级。各个加工面的使用方法是一样的。

系统在任何情况下，都至少有一个加工面，而且只有一个加工面为当前操作的加工面，当前生成的刀具路径都加在当前加工面的下面。当前加工面前面的图标上有一个红色的勾，如 [image] 。下面讲述一下在某个加工面下的加工方法。

为了能够更好的讲述该节点下的操作，首先生成一组加工路径。如图10-10所示，加工一个环面，图中的矩形是辅助线。加工域曲面选择图10-10中的环面，曲线选择辅助矩形，加工域的名字定为分层区域粗雕刻，选择分层区域粗雕刻命令，行切走刀，生成一个分层区域粗雕刻路径。然后加工域选择图10-10中的环面，不选曲线，加工域的名字定为等高外形精加工，选择曲面精雕刻，生成一个等高外形精加工路径，导航窗口中的树如图10-11所示。生成的路径如图10-12所示。

图10-10 加工图形

图10-11

图10-12 生成的刀具路径

可以看到在加工面结点下添加了两个新的结点，分别为“分层区域粗雕刻-1”和“等高外形精加工-2”。这两个结点说明用户选择了不同的加工域。两个加工域的子结点就是生成的刀具路径，它们分别为分层区域粗雕刻路径和曲面精雕刻路径。不管用户选择的加工域是否相同，系统都会按照序号依次把新加的加工域记录在这个加工面的结点下面。

由上面的例子可以看出：加工面的子结点是选择的加工域，加工域的子结点是使用该加工域生成的加工路径。针对某个加工面的所有加工操作都会记录在这个加工面的结点下面，成为其子结点。加工面结点、加工域结点和加工路径结点都可以进行编辑。


删除短路经

10.2.3.13 删除短路经

图10-33所示的对话框为删除短路经对话框。其中有一个路径最小长度参数，默认值为1mm。该命令可以删除当前路径组中小于该长度的路径。

图10-33 删除短路径


编辑刀具路径

10.2.3 编辑加工路径

功能：提供的功能很多，包括修改路径的加工参数，编辑生成该路径的加工域，观察路径的属性，重新排列路径的顺序，删除路径组中比较短的路径，显示或者隐藏该路径，重算、清空、删除、拷贝和分析该路径，对该路径的坐标变化和打印功能。

操作有两种方式，一种是鼠标双击编辑，另一种是右键编辑。

操作１：鼠标双击树中的任何一个刀具路径，都可以弹出生成该刀具路径的雕刻路径参数对话框，可以对参数进行修改，包括路径的颜色和名字。修改完后，该刀具路径前面的图标会出现红色标记，以告知用户，生成该路径的参数已经修改，路径应该重新计算。雕刻路径参数对话框在前面已经介绍过，这里不再讲述。

操作２：在该路径上单击鼠标右键，弹出如图10-29所示的菜单，这个菜单共有12个命令，下面一一讲述这些命令。

图10-29 编辑路径

10.2.3.1 加工参数

和双击该刀具路径的效果是一样的，用于修改加工参数。

10.2.3.2 加工域

是对生成该路径的加工域进行编辑，可以重新拾取要加工的曲面和曲线。如果对加工域进行了修改，则该路径前面的图标会有红色标记，表示生成该路径的参数发生了变化，需要重新生成路径。

10.2.3.3 路径属性

选择该命令，可以弹出“刀具路径信息”对话框。在该对话框中记录了刀具路径的一些信息，如该路径组中路径的条数、路径组的坐标范围、定位高度、安全高度、路径段数和长度等。

10.2.3.4 路径排序

是对当前刀具路径组中路径的顺序进行排列，同路径编辑中的“路径排序”命令相同。

10.2.3.5 删除短路径

选择该命令，弹出“删除短路经”对话框。该命令可以删除当前路径组中小于一定长度的路径。

10.2.3.6 路径显示和隐藏

这两个命令可以显示或者隐藏当前操作的路径组。

10.2.3.7 路径重算、路径清空和路径删除

路径重算：是重新计算生成当前刀具路径组；

路径清空：是将该路径从显示界面上删掉，而加工方法仍然在树上保留，清空的路径需要重算才能恢复；

路径删除：是删除当前的路径组，但加工域保留。

10.2.3.8 路径拷贝

这个命令是将当前选中的路径再复制一个，放到这个路径的后面。将图10-23中加工域“分层区域粗雕刻-1”下的分层区域粗雕刻路径拷贝一个，可以看到这个加工域下面多了一个路径，如图10-30所示。

图10-30 拷贝路径

10.2.3.9 路径分析

自动调用菜单“刀具路径(P)”->“分析刀具路径(A)”命令，对当前选中的路径进行路径分析。

10.2.3.10 坐标变换

这是一个弹出式菜单，如图10-31所示。

图10-31 坐标变换命令

它包括路径平移、路径旋转、路径镜像和路径结点。这些命令的操作对象都是当前的路径组，其方法同“路径编辑”菜单中的对应命令相同。

10.2.3.11 打印路径

自动调用菜单“加工项目(T)”->“路径打印(P)”命令，打印当前操作的路径组信息。


刀具路径信息

10.2.3.12 刀具路径信息

图10-32所示的对话框为刀具路径信息对话框。在该对话框中记录了刀具路径的一些信息，如该路径组中路径的条数、路径组的坐标范围、定位高度、安全高度、路径段数和长度等。

图10-32 刀具路径信息


添加加工域

10.2.1.10 添加加工域

图10-21所示的对话框为加工域对话框，下拉框中有多个可供选择的加工域，如图10-22所示。选择一个未定义的加工域，点击“确定”按钮，就将该加工域加到“加工域列表”对话框中。

图10-21 “加工域”对话框

图10-22加工域的类型


编辑加工面

10.2.1 编辑加工面

功能：可以在加工面下添加路径、加工域。设定一个加工面为当前操作的加工面后，可以对该加工面下的加工域排序，显示、隐藏或者重算该加工面下的所有路径，可以删除加工面、路径或者加工域，还可以调用加工模拟、分析刀具路径、路径干涉检查、输出刀具路径和打印路径等功能。

操作：右键点击加工面结点，弹出一个浮动菜单，如图10-13所示。该菜单中共有12个命令，使用这些命令可以对这个加工面进行编辑。下面逐一介绍这些命令的功能。

图10-13 编辑加工面

10.2.1.1 路径向导

该命令可以往这个加工面下添加路径，它和菜单“刀具路径(P)”->“路径向导(W)”的命令是一样的，都是调用路径向导命令。

10.2.1.2 当前加工面

用于设定这个面为当前操作的加工面，生成的路径也会显示在这个加工面下。当前加工面只能有一个，其图标上有红色勾。

10.2.1.3 加工域排序

这个命令可以修改该加工面下加工域的顺序。点击该命令，弹出“加工域列表”对话框，使用这个对话框，可以对加工域进行排序，也可以添加新的加工域。

举例：

点击这个命令，弹出如图10-14所示的“加工域列表”对话框，这个对话框中有两个加工域，将这个加工的顺序进行调换，并添加一个“未定义－3”的加工域，如图10-15所示，点击确定后，工艺树变成如图10－16所示。加工域下面的加工路径也跟着加工域移动。

图10-14 加工域

图10-15在加工域列表

图10-16 排序结果

10.2.1.4 全部显示和全部隐藏

生成的刀具路径组是可以隐藏的，“全部显示”和“全部隐藏”命令是全部显示或者全部隐藏当前加工面下的所有路径组。路径显示的时候，它前面的图标是蓝色的，隐藏的时候，前面的图标是灰色的。

10.2.1.5 全部重算

用于重新计算当前加工面下的路径组，它包含三个子命令，如图10-17所示，分别为所有路径、所有可见路径和所有过时路径。分别讲解如下：

图10-17全部重算命令

１、所有路径：全部重算当前加工面下的所有路径；

２、所有可见路径：计算当前加工面下的所有可见路径；

３、所有过时路径：计算当前加工面下的所有参数被编辑过的路径。

10.2.1.6 删除

删除命令是一个弹出式菜单，如图10-18所示。弹出菜单有三个命令，分别为所有路径、所有加工域和加工面。删除所有路径命令是删除该加工面下的所有路径，但加工域保留，即“分层区域粗雕刻-1”和“等高外形精加工-2”还存在，如图10-19所示；删除所有加工域是删除该加工面下的所有加工域，包括路径；删除加工面是删除当前操作的加工面。但是，如果只有一个加工面，则不能删除。

图10-18删除命令 图10-19 删除所有路径

10.2.1.7 加工模拟、分析刀具路径、路径干涉检查和输出刀具路径

加工模拟是调用菜单“刀具路径(P)”->“加工模拟(U) …”命令。

分析刀具路径是调用菜单“刀具路径(P)”->“分析刀具路径(A)”命令。

路径干涉检查是调用菜单“刀具路径(P)”->“干涉检查(C)”命令。

输出刀具路径是调用菜单“刀具路径(P)”->“输出刀具路径(E)”命令。

10.2.1.8 打印面内路径

这个命令是调用菜单“加工项目(T)”->“路径打印(P)”命令，打印当前加工面内所有路径的信息。


加工域排序

10.2.1.9　加工域排序

图10-20所示的对话框为“加工域列表”对话框，使用这个对话框可以对加工域进行排序，也可以添加新的加工域。

图10-20 加工域

这个对话框的工件栏里有6个按钮，第一个按钮为添加新的加工域按钮，点击该按钮，弹出“加工域”对话框，定义新的加工域。后面5个按钮的功能依次是删除加工域、加工域向上移动一位，加工域向下移动一位、加工域移到最上面和加工域移到最下面。


编辑加工域

10.2.2 编辑加工域

在上面讲述的例子中有两个加工域，选择在“分层区域粗雕刻-1”加工域下进行介绍。

功能：包括修改加工域、在加工域下添加路径、删除该加工域和打印加工域下的路径信息等。

操作：鼠标右键点击“分层区域粗雕刻-1”结点，弹出菜单如图10-23所示。该菜单有十个命令，分别为编辑加工域、添加路径、路径组排序、全部显示、全部隐藏、全部重算、全部分析、删除加工域、拷贝加工域和打印路径组，下面分别介绍。

图10-23 编辑加工域

10.2.2.1 编辑加工域

选择这个命令，弹出拾取加工域的导航窗口，并且当前加工域所选择的图形都用绿色显示。可以对加工域进行编辑，添加、去掉、或者重新拾取要加工的曲面和曲线。如果对加工域进行了修改，则该加工域下面的所有路径前面的图标都变成有红色小叉的标记。这表示生成该路径的参数发生了变化，需要重新计算路径。

10.2.2.2 添加路径

同 “刀具路径”菜单下的“路径向导”命令一样，可以在该加工域下添加新的加工路径。

图10-24添加路径

图10-24就是在加工域“分层区域粗雕刻-1”下面添加了一个等高外形精加工路径。在生成该路径的时，没有选择加工域，使用的加工域是“分层区域粗雕刻-1”。

10.2.2.3 路径组排序

这个命令调用“路径组排序”对话框，可以将这个加工域下的路经组重新进行排序。将图10-24分层区域粗雕刻-1加工域下面的两个路经组的顺序换过来，其操作过程同加工面下面的加工域排序的操作过程是一样的，参看上面的就可以了。结果如图10-25所示。

图10-25路径组排序

10.2.2.4 全部隐藏、全部显示和全部重算

全部隐藏：全部显示当前加工域下面的路径组；

全部显示：全部隐藏当前加工域下面的路径组；

全部重算：全部重算当前加工域下面的路径组。

10.2.2.5 全部分析

自动调用菜单“刀具路径(P)”->“分析刀具路径(A)”命令，对该加工域下的路径进行自动分析。

10.2.2.6 删除加工域

可以删除当前操作的加工域以及该加工域下的所有路径组。

图10-26 删除加工域

点击图10-23中加工域“分层区域粗雕刻-1”下的删除加工域命令，可以看到只剩下一个加工域――“等高外形精加工-2”，如图10-26所示。

10.2.2.7 拷贝加工域

点击这个命令，可以将当前选中的加工域自动复制一份，放到当前加工域的下面。点击图10-23中加工域“分层区域粗雕刻-1”下的拷贝加工域命令，可以看到多了一个“分层区域粗雕刻-1”的加工域，如图10-27所示。

图10-27 拷贝加工域

10.2.2.8 打印路径组

调用菜单“加工项目(T)”->“路径打印(P)”命令，打印加工域下所有刀具路径组的信息。


路径组排序

10.2.2.9 路径组排序

图10-28所示的对话框是路径组排序对话框，这个对话框的列表框中列出了当前加工域下的所有路径，使用对话框中的五个按钮，可以重新对这些路径进行排序或者删除一些路径。

图10-28 路径组排序

这个对话框的工件栏里有5个按钮，功能依次是删除加工路径、路径向上移动一位，路径向下移动一位、路径移到最上面和路径移到最下面。


项目节点设置

10.1 项目设置结点

项目设置结点下有工件、材料和加工面三个子结点。项目设置结点本身不能进行编辑，只能编辑它下面的三个子结点。项目设置结点和它下面的三个子结点都不能被删除。


可用加工平面

10.1.4.2 可用加工平面

图10-9所示的对话框为“可用加工平面”对话框，这个对话框中列有6个常用视图平面作为加工平面，用户可以任选其中的一个作为加工平面。

图10-9　可用加工平面


加工面

10.1.4 加工面

功能：用户可以不旋转模型，通过设置加工平面的方法为模型生成多个方向的加工路径。

操作方式同工件结点一样。

操作１：鼠标左键双击该命令，弹出“刀具平面列表”对话框，其作用同选择菜单“加工项目(T)”>>“加工面(R)”的命令的效果是一样的。

操作２：在该节点上点击鼠标右键，弹出如图10-4所示的菜单。这个菜单有一个编辑命令，也是弹出“刀具平面列表”对话框。

用户可以用“刀具平面列表”对话框为待加工零件添加多个加工面。

举例：

在启动设置加工平面命令后，弹出“刀具平面列表”对话框。从下拉框中选择鞋模加工模式（夹具在左面），可以看到系统预先的五个加工面，如图10-5所示。点击“确定”按钮，这些加工面就被加到工艺树上，如图10-6所示。

图10-5 鞋模加工模式

图10-6 工艺树


刀具平面列表

10.1.4.1 刀具平面列表

图10-7为 “刀具平面列表”对话框。单击加工模式下拉列表框，可以看到系统预先设置的各种加工模式，如图10-8所示。

图10-7 “刀具平面列表”对话框

图10-8 系统预设的各种加工模式

这些加工模式分别为：

缺省 | 只有顶视图刀具面。用于单面零件的加工，如一些模具、标牌、有机玻璃字等。
首版加工模式 | 有上下两个加工面。用于加工ABS首版。
鞋模加工模式 | 共有五个加工面，分别为底面、前面、后面、左面和右面，用于加工鞋模。夹具在前和夹具在左的加工面都是一样的。
旋转体加工模式 | 共有三个互成120度的加工面。用于加工旋转体。
自定义 | 用户设定的加工模式，可以添加6个常用视图平面的任何一个或者几个作为加工面。

用户可以根据下拉框中的选项为待加工的零件选择合适的加工面，也可以通过点击 “添加…”按钮，从弹出的“可用加工平面”对话框中选择添加6个常用视图平面作为加工平面。


材料

10.1.3 材料

功能：编辑系统的材料库。

操作方式有两种，同工件的一样。

操作１：鼠标左键双击该命令，弹出“材料属性”对话框，其作用同选择菜单“加工项目(T)”>>“加工材料(M)”的命令的效果是一样的。

操作２：在该节点上点击鼠标右键，弹出如图10-4所示的菜单，这个菜单有一个编辑命令，点击“编辑”菜单，同样弹出“材料属性”对话框。

图10-4编辑菜单


工件设置

10.1.2 工件设置

图10-3为工件设置对话框。在这个对话框中可以设置工件的名称、模型的位置和大小，以及走刀速度等一些控制参数。

图10-3“工件设置”对话框

工件名称 | 设置当前加工工件的名称。
工件原点 | 点击“工件原点”按钮，可以从图中选择一个点作为工件的原点，也可以直接填写工件原点的坐标。
工件尺寸 | 显示工件的尺寸大小。
模型尺寸 | 点击“模型尺寸” 按钮，系统可以根据零件尺寸计算出加工模型的尺寸。
显示毛坯形状 | 选择这个复选框，则画出模型的包围盒。
主轴转速 | 可以设置加工时电机的最大和最小转速。
侧向进给速度 | 设置刀具的侧向进给速度的最大和最小值。
圆弧半径 | 设置加工中圆弧的最大和最小半径。凡半径过大或过小的圆弧都将用折线表示。
进给速度 | 设置刀具进给速度的最大值和最小值。
深度进给速度 | 设置加工时深度进给速度的最大值和最小值。
控制软件版本 | 可以设置输出刀具路径的控制软件的版本。一般都是用5.0的控制软件输出。


工件

10.1.1 工件

功能： “工件” 结点可以用来对工件进行设置、编辑加工材料、添加加工面、编辑刀具库和输入工艺过程等。

对这个结点的操作方式有两种，一种是鼠标左键双击该结点，另一种是在该节点上点击鼠标右键，通过浮动菜单调用。

操作１：左键双击该节点，可以对工件进行设置，其效果和选择菜单“加工项目(T)”>>“项目设置(G)”的效果是一样的，会弹出“工件设置”对话框。在这个对话框中可以设置工件的名称、模型的位置和大小，以及走刀速度等一些控制参数。

操作２：在该节点上点击鼠标右键，弹出如图10-2所示的菜单。这个菜单共有五个命令，分别为工件、材料、加工面、刀具库和输入工艺过程。

图10-2工件的弹出菜单

“工件”命令 | 同操作１的作用是一样的。
“材料”命令 | 可以对材料库进行编辑，其作用同选择菜单“加工项目(T)”>>“加工材料(M)”的命令的效果是一样的，参见第三章材料库。
“加工面”命令 | 可以添加加工面，其作用和选择菜单“加工项目(T)”>>“加工面(R)”的命令的效果是一样的，这个命令将在后面介绍。
“刀具库”命令 | 可以对系统的刀具库进行编辑，其效果和选择菜单“刀具路径(P)”>>“刀具库(N)”的命令的效果是一样的，参见第二章刀具库。
“输入工艺过程”命令 | 可以输入加工工艺，它的效果同选择菜单“加工项目(T)”>>“输入工艺过程”的命令的效果是一样的，参见第七章路径的输入输出。


平面刀具路径编辑

第十一章 平面刀具路径编辑

二维平面中，专门为平面刀具路径提供了一组编辑的功能，主要包括刀具路径排序、组合刀具路径、分离刀具路径、刀具路径变换和镶嵌加工预处理等功能。图11-1为关于刀具路径编辑的菜单。

图11-1 路径编辑功能组


镶嵌加工预处理

11.5 镶嵌加工预处理

在镶嵌切割加工中，对于不光滑的图形如果不作处理，将导致凸凹切块发生干涉，导致镶嵌失败，如图11-18所示。

凸块

凹块

尖角出现干涉

图11-18 镶嵌发生干涉

镶嵌加工预处理可以将不光滑图形整体倒角，保证凸凹切块的顺利镶嵌。镶嵌处理的参数如图11-19所示。

图11-19 镶嵌加工预处理

倒角半径 | 倒角半径必须等于或略大于刀具半径。
镶嵌间隙 | 镶嵌块之间的间隙，一般等于０。


刀具路径的组合与分离

11.2刀具路径组合

组合刀具路径用于对多个路径进行组合，使它们成为一个整体，以便于操作。该命令和对图形进行组合的群组命令相似，即都是对同类的对象进行组合。所不同处在于组合刀具路径功能用于对路径进行组合，而群组命令则是对图形进行组合。

具体操作为：选择欲组合在一起的两个或多个路径，选择“刀具路径\组合刀具路径”菜单项，即完成对选择路径的组合。路径被组合后，它们将作为一个整体出现。用户可以通过点击选择被组合路径中的某个路径来察看是否整个路径组都被选择。

11.3刀具路径分离

分离刀具路径用于将路径进行分离。对路径的分离一共有两种方式，即按照集合分离路径和分离为单条路径。按照集合分离路径。它能够将组合的多条路径分离为组合前的单个路径。它对未组合的单条路径不起任何作用。分离为单条路径，主要用于对中间有抬刀的路径进行分离。它能够从抬刀处将路径分为多个路径。如果被分离的是路径组，则按照该方式分离后，该路径组从抬刀处分开形成多个路径。这与对这组路径中的每个路径按照该方式进行分离的结果相同。对没有抬刀的单条路径进行这种方式的分离没有任何作用。

分离刀具路径的具体操作为：在选择欲分离的路径后，选择“刀具路径\分离刀具路径”菜单项，系统弹出如图11-7所示的对话框。在该对话框中可以选择分离的方式。选择一种分离方式后，点击“确定”按钮，即完成对路径的分离。

图11-7 分离刀具路径


刀具路径排序

11.1刀具路径排序

系统按照路径生成的先后顺序记录了这些路径加工时的先后顺序。由于生成路径是个反复的过程，在路径生成时用户很可能已经不记得这些路径生成的先后顺序，或者这些路径的先后顺序不是加工的先后顺序。此时，就需要用刀具路径排序功能，对路径进行排序。

刀具路径排序功能对所有可见的路径排序。在任何状态下都可以启动刀具路径排序命令。但系统要求当前可见路径对象的个数必须不小于２，否则系统会弹出如图11-2所示的对话框，表示路径不需排序。如果可见路径超过一个，系统将启动如图11-3所示的排序工具条，用户可以按照某种方式排序。

  图11-2 不需排序 　　 　　　　　 图11-3 排序工具条

路径排序方式共分为三种类型，即选择排序、手工排序和自动排序。

1、选择排序

只有在选择了路径对象的情况下才/有效。如果一次选择了多个路径，选择排序过程不改变选择对象内部的先后次序；如果多个选择的路径中间还有其他路径，通过排序后，选择的路径变成紧密排列的路径，中间没有选择的路径会被排到选择路径之前或之后。选择排序方式包括移到最小序号、移到最大序号、减小序号、增大序号、移到…之前、移到…之后等几种。

选择排序方式必须先选择一条或多条路径，然后调整加工次序。所选择的路径变为黑色，且有一个黑色虚线框框住被选择的路径。所有的路径在起点处有一个红色小方格，方格旁边有一个数字。它表示该路径的加工序号，路径中间的连线表示刀具从一个路径移到下一个路径的路线，如图11-4所示。

图11-4 路径序号，“ｂ”被选择

2、手工排序

用户依次指定雕刻加工次序。只有在没有选择任何路径的情况下，手工排序才有效。系统提供的手工排序方式只有指定路径序号一种。

3、自动排序

用户依次指定雕刻加工次序。只有在没有选择任何路径的情况下，自动排序才有效。系统提供的自动排序方式只有路径自动排序一种。

这些参数的含义如下：

移到最小序号 | 选择排序类型，将选择的路径定为最先加工的路径。
移到最大序号 | 选择排序类型，将选择的路径定为最后加工的路径。
减小序号 | 选择排序类型，将选择的路径提前一个加工序号。
增大序号 | 选择排序类型，将选择的路径退后一个加工序号。
移到…之前 | 选择排序类型，将选择的路径提前到某个基准路径之前。作为基准的路径必须不是选择的路径，否则排序无效。
移到…之后 | 选择排序类型，将选择的路径提前到某个基准路径之前。作为基准的路径必须不是选择的路径，否则排序无效。
指定路径序号 | 手工排序类型，用户从第一个路径开始，一直指定到最后一个路径，指定序号的过程是不能倒退的。
路径自动排序 | 自动排序类型，用户从第一个路径开始，一直指定到最后一个路径，指定序号的过程是不能倒退的。 l 如果自动排序后的结果和原始路径的次序相同，系统提示“现有次序与自动排序结果相同”，如图11-5所示。 图11-5 路径序号相同 l 如果自动排序后的连刀路径长度比原始路径的连刀路径长，系统则提示“现有次序比自动排序的效果好”，如图11-6所示。 图11-6 自动排序效果不理想 选择“是”，系统使用自动排序的效果；选择“否”，系统保留现有的次序。
显示路径序号 | 显示路径序号１，２，3等。当路径个数很多时，关闭显示路径序号可以提高显示的清晰度。


锥面中心展开

11.4.4锥面中心展开

锥面中心展开主要用于将扇形刀具路径展开成圆锥面上雕刻的路径。

图11-12 锥面中心展开

在圆锥面的垂直方向上雕刻必须采用转轴雕刻。因为锥角的存在，采用常规的转轴加工方法可能造成实际的加工形状发生变形。为了保证原始图形的真实性，图形设计和加工的方式要作些变化。

图11-13

* 路径的设计过程是：

１）将圆锥面展开成平面扇形。扇形的上下对称，扇形中心和坐标原点重合。

锥面的形状及尺寸如图11-14所示。此图为锥面的侧视图。

图11-14 锥面的轴侧图

在A、B、L、α四个特征参数中，只要知道了其中的任何三个尺寸，便可以将锥面展成平面扇形。展开的图形如图11-15所示。

图11-15 锥面展成平面扇形

其中的计算数据是：内圆直径d = B / sinα （1）

外圆直径D = A /sinα （2）

   圆心角T = B * 360 / d = A * 360 / D （3）

以上三个数学式子可以当作公式通用。

绘制中，要注意以下几点：

① 输入圆心时，为方便下面的操作，将圆心定在坐标原点处，即（0，0），

② 扇形最好上下对称；

③ 绘制扇环形平面图时，一定要保证图形开口朝右；

2）在展开的扇形上绘制图形，并生成刀具路径，如图11-16所示。

图11-16设计图案并生成刀具路径

3）锥面中心展开，用转轴雕刻刀具路径。

选择生成的扇形刀具路径，启动“锥面中心展开”变换功能，获得旋转雕刻路径，如图11-17所示。

图11-17 锥面中心展开

其中各参数意义：

1）“最大半径”就是锥面展开后的大弧的半径即R值， R 等于原始圆锥底圆的半径，即R = B/2；

2）中心坐标指展开的扇形的圆心坐标。如果圆心和坐标原点重合，则设定为（0，0）位置；

3）锥面斜角即展开后的路径平面与水平方向的夹角，此处定为0，即路径平行于水平面。如果受条件限制，不能倾斜圆锥工件，也就是说工件的旋转轴平行于X轴，这时必须设置锥面斜角，斜角的值等于α，也就是圆锥锥角的一半。


切割焊点

11.4.3切割焊点

切割焊点主要用于有机玻璃切边时防止被切掉的有机玻璃翘起而使用。它会在轮廓切割路径的某些位置让路径往上抬高一点切割，以便不把有机玻璃切透，留下切割焊点。

只有平面路径能够增加切割焊点。在如图11-10所示的切割焊点页面中输入焊点长度、焊点高度和焊点位置后，点击“确定”按钮。对话框关闭，在轮廓切割路径上留下切割焊点。

图11-10切割焊点

切割焊点中三个参数的具体意义为：

1. 焊点的长度。见图11-11所示。

2. 焊点的高度。见图11-11所示。

3. 在路径的何处留下怎样的切割焊点？用户可以在焊点位置处选择末点、中点或两点。

图11-11切割焊点的含义


路径平移

11.4.1 路径平移

路径平移主要用于对刀具路径进行移动，平移的距离是相对距离。如果数值大于０，表示朝坐标轴正向平移。如果小于０，则表示向坐标轴负向移动。在对话框中输入平移距离后，点击“确定”按钮，对话框关闭，完成对路径的平移变换。

图11-8 路径平移


刀具路径变换

11.4刀具路径变换

刀具路径变换主要用于变换刀具路径的位置，刀具路径变换不改变原有的加工次序。其功能包括四种变换方式，即：路径平移、路径缩放、切割焊点和锥面中心展开。

* 操作步骤：

1）选择欲作转换处理的路径；

2）选择“刀具路径\刀具路径转换”菜单项，启动变换命令，系统弹出“刀具路径变换”对话框；

3）选择变换方式，设定相关参数，然后点击“确定”按钮，对话框关闭，刀具路径转换也随即完成。


路径缩放

11.4.2 路径缩放

路径缩放主要用于刀具路径的比例变化，缩放的中心是坐标原点。如果缩放比例大于１，表示路径放大；如果小于１，则表示路径缩小，最小的缩放比例是0.01。在页面中输入缩放比例，点击“确定”按钮，对话框关闭，完成对路径的缩放变换。

图11-9路径缩放