欢迎使用精雕软件

JDPaint是精雕科技多年来一直致力研制开发的、具有自主版权的、功能强大的专业雕刻CAD/CAM软件。JDPaint是精雕CNC数控雕刻系统正常运作的保证，也是有效提高CNC雕刻系统使用效率和产品质量的源泉。

JDPaint专业雕刻软件经过多年的发展完善，功能日趋丰富强大，不仅突破了如曲面浮雕、等量切削等多项关键雕刻设计及加工技术，也充分保证了软件产品的易用性和实用性，极大地增强了精雕CNC雕刻机的加工能力和对雕刻领域多样性的适应能力。在应用领域上，JDPaint软件已经彻底突破了适合标牌、广告、建筑模型等较为传统的雕刻应用范畴，在技术门槛更高的工业雕刻领域，如滴塑模、高频模、小五金、眼镜模、紫铜电极等制作业，表现同样出色，成为国内最优秀的雕刻软件。

目前，JDPaint已由较为单一的雕刻设计加工软件，逐步走向面向CNC产品加工的一整套解决方案。

产品服务:

精雕科技网址 www.jingdiao.com

问题反馈E-mail： soft@jingdiao.com

软件开发部电话：010-60803959, 010-60803960

精雕科技总机： 010-60801188

销售热线：010-51922006/7　　E-mail：market@jingdiao.com


前 言

CNC雕刻机在国内开始得到应用，大约只有十年左右的历史。但它的产品和市场发展很快，尤其是近两三年，CNC雕刻机不仅在传统的雕刻应用领域—广告标识制作业占据了举足轻重的地位，同时，也以精细、快速的优势，越来越深地进入了诸多工业领域，特别在CNC雕刻机具有突出优势的小模具、小产品的加工上，已经获得了广泛的应用。CNC雕刻机一方面在快速替代落后的传统手工雕刻作业方式，另一方面，随着制造业界对CNC雕刻技术的认识加深和认可，已在某些产品制造环节选用CNC雕刻机作为首选的制造设备，提升了产品制造品质，较大幅度地降低了生产成本。

CNC雕刻机在进入传统的工业产品制造领域的过程中，既有其精细、快速的优势，也遇到了一些挑战，其中，雕刻CAD/CAM软件的对一些工业产品设计和加工的适应性成为一个主要课题。从CAD功能上来说，雕刻CAD特长在于强大的文字和复杂平面图形的排版设计以及艺术浮雕曲面造型功能，而很多工业产品需要严格精确的曲面模型设计能力，这对于雕刻CAD/CAM软件的相对较弱的精确复杂曲面模型设计能力是勉为其难的；从CAM功能上而言，雕刻CAD/CAM更擅长进行平面加工和曲面细节丰富但整体较为平缓的浅浮雕模型加工，对于经常遇到的带有很多直壁、凹槽的工业模型，其加工能力和加工效果并不理想。

北京精雕科技有限公司是国内CNC雕刻业界的领军厂家，不但推出了一系列高品质的CNC雕刻设备，也研发了国内最早、最优秀的专业雕刻CAD/CAM软件—JDPaint，该软件的最新版本为5.0版本，已经形成一个强大的开放性CAD/CAM软件产品开发平台。北京进取者软件技术有限公司与北京精雕科技有限公司进行密切合作，在JDPaint软件平台上开发了面向工业加工的曲面设计与加工软件—SurfMill 2.0，成为JDPaint CAD/CAM软件产品家族中新的一员。

SurfMill 2.0在CAD功能上，提供强大的三维线框造型功能，具备完备的几何曲面构造与编辑功能，全面支持NURBS曲面造型技术。在CAM功能上，全面支持提供曲面模型的粗加工、半精加工和精加工，提供曲面三维曲面清根功能。SurfMill 2.0的推出，是对JDPaint精确曲面造型和加工能力的一个具有重大意义的提高，可以预期，CNC雕刻机将在工业产品制造领域获得更加广泛深入的应用。

SurfMill 2.0可以独立运行，也可与JDPaint 5.0整合在同一环境下，共同完成产品模型的设计与加工。本说明书为SurfMill 2.0使用手册, 分为上下两册，上册是曲面设计部分，下册是曲面加工部分。

本书是上册，共分十章，各章主要内容如下：

第一章介绍了SurfMill 2.0系统的主要功能。

第二章介绍了SurfMill 2.0的基础操作方法，包括精确定点、对象的选择和显示、对象的操作、绘图面、视图与图形观察等内容。

第三章介绍了曲线绘制命令的使用方法，包括绘制点、线、圆弧、样条、圆、椭圆、矩形、多边形、包围盒、二次曲线等内容。

第四章介绍了曲线编辑命令的使用方法，包括撤消、重做、拷贝、粘贴等基本操作和曲线倒角、曲线修剪、曲线打断、曲线延伸、曲线等距、曲线编修等曲线编辑操作的使用方法。

第五章介绍了图形变换命令的使用方法，包括平移、旋转、镜象、放缩等平面几何变换操作和三维几何变换操作以及转为NURBS、转为网格面等曲线曲面类型转换操作。

第六章介绍了曲面构造命令的使用方法，包括标准曲面、平面、拉伸面、直纹面、旋转面、蒙皮面、边界面、等距面、扫掠面等几何曲面的构造方法。

第七章介绍了曲面编辑命令的使用方法，包括曲面组合、曲面炸开、曲面延伸、曲面裁剪、曲面修补、曲面倒角、曲面编修等几何曲面编辑操作的使用方法。

第八章介绍了与曲面有关的一些曲线的构造方法，包括曲线投影、曲面交线、曲面边界线、曲面流线、曲面上画线、曲线包裹等内容。

第九章介绍了图形的测量与查询方法，包括属性查询、测量点、测量距离、测量角度、测量曲线长度、测量曲面面积等内容。

第十章介绍了SurfMill支持的外部文件格式及相应的文件输入输出方法。


北京精雕科技有限公司 版权所有 翻印必究

第七章 三维变换

-194-

-195-

-193-


对象的显示与隐藏

1.4 对象显示与隐藏

在构造模型的过程中，常常要将一些暂时不操作的对象隐藏起来，使得需要进行操作的对象更加清晰，在需要对隐藏的对象进行操作时，在将其显示即可。

点击导航工具栏中的“ [image] ”按钮，进入对象的显示与隐藏命令，导航工具栏出现如图1-15所示对话框。

图 1-15 对象显示与隐藏

参数定义：

对象过滤 | 根据对象类型来进行筛选指定对象。“对象过滤”的用法与“对象的选择”中的用法相同，这里不再赘述。
颜色过滤 | 根据指定颜色来筛选对象。“颜色过滤”的用法与“对象的选择”中的用法相同，这里不再赘述。
拾取显示 | 通过拾取一个隐藏对象而使它强制显示。
全部显示 | 显示通过“对象过滤”和“颜色过滤”后的所有对象。
隐藏已选对象 | 隐藏当前被选中的对象。
隐藏未选对象 | 隐藏当前没有选中的其他所有对象。
全部隐藏 | 隐藏通过“对象过滤”和“颜色过滤”后的所有对象。
允许显示路径 | 在曲面造型环境中显示刀具路径对象

隐藏与显示只是控制对象的显示状态，隐藏后对象的位置关系和对象本身保持不变，而且隐藏的对象不能再参予任何编辑（包括选择），如果想对此对象进行再编辑，必须把它显示出来方可。

最快捷的隐藏对象方法是：1）首先选中要隐藏的对象，单击鼠标右键，在弹出的右键菜单中选择“隐藏(H)”菜单项即可；2）选中要隐藏的对象，单击常用工具条中的 [image] 按钮隐藏指定对象。

对象显示/隐藏切换：单击常用工具条中的 [image] 按钮，可实现的对象显示/隐藏切换。

在JDPaint使用说明书中我们已经叙述了“颜色工具栏”用于修改图形、文字等操作对象的颜色，设置轮廓线或者区域填充颜色，从而获得彩色效果图。在SurfMill中对象的显示颜色修改与JDPaint系统操作相同，这里不再赘述。


曲面造型工具

第一章 曲面造型工具

SurfMill 2.0软件是在JDPaint系统平台基础上开发出来的插件模块，它由曲面造型工具和刀具路径工具两个状态环境组成。运行SurfMill 2.0，首先必须在JDPaint 5.0下加载SurfMill 2.0插件模块。目前，SurfMill 2.0软件主要包含下列四个部分模块：

三维造型环境 | 提供曲面模型的三维造型环境和三维线框造型功能。
曲面造型模块 | 提供几何曲面创建与编辑功能。
曲面加工模块 | 提供曲面模型的刀具路径自动编程功能。
刀具路径编辑 | 提供刀具路径轨迹编辑功能。

曲面造型工具提供了曲面造型的三维工作环境，三维线框造型、几何曲面构造与编辑等命令操作都必须依赖该环境才能正常运行。在曲面造型工具状态下，可以进行三维图形对象选择、快速变换、绘制曲线、构造曲面等操作。

启动JDPaint 5.0后，点击状态工具栏中的曲面造型工具 [image] 按钮，系统进入曲面造型工具状态，位于界面右侧导航工具栏的状态如图1-1所示。

图1-1 曲面造型工具导航工具栏

参数定义：

微调距离 | 使用键盘快速平移对象时的调整距离。系统默认值为1mm，可通过键盘输入来增大或减小这个数值。
Z向深度 | 定义当前绘图平面的深度值。 当前绘图平面为XY平面时，该选项的值为Z轴绘图深度； 当前绘图平面为XZ平面时，该选项的值为Y轴绘图深度； 当前绘图平面为YZ平面时，该选项的值为X轴绘图深度； 说明：该值仅对鼠标点输入方式有效，对键盘点输入方式无效
选择 | 按指定对象类型选择对象。
显示 | 按指定对象类型显示或者隐藏对象。
加锁 | 按指定对象类型显示或者加锁对象。
坐标系 | 用于系统用户坐标系的设置、创建、修改以及管理。
视角 | 用于定义图形显示的角度，即图形观察视角。
图层 | 用于创建、管理图层对象。

本章主要叙述三维造型环境下的一些通用对象操作功能，主要有以下内容：

l 系统支持的对象类型

l 对象的拾取与选择

l 对象的快速变换

l 对象的显示与隐藏

l 对象的加锁与解锁

l 对象的图层管理

l 系统设置


对象加锁

1.5对象的加锁

点击导航工具栏中的“ [image] ”按钮，进入对象的加锁与解锁命令，导航工具栏出现如图1-16所示对话框。

图 1-16 对象加锁与解锁

参数定义：

对象过滤 | 根据对象类型来进行筛选指定对象。“对象过滤”的用法与“对象的选择”中的用法相同，这里不再赘述。
颜色过滤 | 根据指定颜色来筛选对象。“颜色过滤”的用法与“对象的选择”中的用法相同，这里不再赘述。
全部加锁 | 加锁通过“对象过滤”和“颜色过滤”后的所有对象。
已选对象加锁 | 加锁当前被选中的对象。
未选对象加锁 | 加锁当前没有选中的其他所有对象。
全部解锁 | 解锁通过“对象过滤”和“颜色过滤”后的所有对象。
未选对象解锁 | 解锁当前没有选中的其他所有对象。

加锁与解锁只是控制对象的拾取状态，加锁后对象的位置关系和对象本身保持不变，只是在对象编辑中不能被拾取；加锁对象被解锁后，又可以进行正常拾取操作。


对象的快速编辑

1.3 对象的快速编辑

在曲面造型环境下，利用鼠标或键盘操作被选中对象，用户可以快速完成以下功能：

功能 | 实现方法
快速平移 | 通过键盘的“上下左右”键 实现位置微调。
快速拷贝 | 通过“C trl”键+“上下左右”键 实现快速拷贝。

下面我们分别讲述上述两种快速编辑功能的操作方法。

3.3.1 快速平移操作

使用键盘的“上下左右”键

操作步骤如下：

⑴ 选取要移动的图形。

⑵ 将“导航工具栏”中的“微调距离”的数值改为100，回车。如图1-14所示。

⑶ 敲击一下向上的方向键，图形就会向上移动100毫米。

图1-14 微调距离

3.3.2 快速拷贝操作

“Ctrl”键 + 键盘“上下左右”键

图形拷贝的操作步骤如下：

⑴ 选取要拷贝的图形。

⑵ 将“导航工具栏”中的“微调距离”的数值改为100或其它数值，回车。

⑶ 按住“Ctrl”键，同时敲击键盘“上下左右”键中的一个键，完成复制。


系统支持的对象类型

1.1系统支持的对象类型

在进行三维造型环境介绍之前，有必要了解SurfMill系统能够对哪些类型对象进行操作处理。我们知道JDPaint系统可以支持二维图形、图象、文字、艺术变形等对象。与JDPaint系统不同，SurfMill软件主要面向的工业产品、模具、鞋模、小五金等雕刻加工行业，这些行业有标准的图纸设计，产品设计精度要求高，要求设计出几何模型能够满足行业的精度标准。因此，SurfMill软件在图形对象支持上与JDPaint系统有较大的区别，主要支持以下的对象类型可供操作，如表1-1所示，这些对象共同组成各种复杂的图形文件。

表 1-1 系统支持的对象类型

对象类型 | 类型描述
点 | 空间的三维点。
曲线 | 空间三维曲线，即单段曲线。 SurfMill支持的曲线类有：直线、圆弧、非均匀有理B样条曲线（NURBS曲线）、三维折线、等距曲线和曲面边界线。
组合曲线 | 组合曲线是由首尾相连的曲线连接而成的。它与JDPaint系统中多义线相似。
几何曲面 | SurfMill系统支持精确表达形体的几何曲面模型和非精确表达形体的网格曲面模型。精确几何曲面类型有：直纹曲面、旋转曲面、NURBS曲面和等距曲面。非精确曲面类型有：网格曲面和点云曲面。
组合曲面 | 组合曲面是由多张边界相连的曲面组合而成的曲面对象。
刀具路径 | 刀具走刀的路线对象。
刀具路径组 | 刀具走刀的路线对象集合。
用户坐标系 | 用户坐标系是空间精确定位的主要工具。三维曲线的设计打样工作一般都在某一空间平面上进行，这空间平面就是绘图平面，也称工作平面。绘图平面建立在工作坐标系上，常用的绘图平面主要有XY平面、XZ平面和YZ平面。线框设计要求绘图平面及其相应的工作坐标系有方便灵活的定义和切换。
图层 | 图形集合


系统设置

1.7系统设置

系统设置功能让你设置系统的缺省值，系统储存这些值到一个设置文件（*.CFG），每次启动系统后，JDPaint会自动加载这些参数。在绘图时，可以根据需要，对一些基本系统参数进行修改。

点击“文件”中的“系统设置”菜单，即可弹出如图1-24所示对话框。

图 1-24 “系统设置”对话框

可以通过点击不同的标签按钮切换设置的类型。

1.6.1 系统参数

在系统设置中用鼠标点击“系统参数”标签，可以弹出“系统参数”的对话框，在该页面中可以修改系统显示精度、曲线和曲面的有关操作精度以及Undo设置等参数，如图1-17所示。

参数定义：

显示精度 | 弦高误差 | 曲线和曲面在显示时，对它们进行离散的最大弦高误差，默认值为0.02mm。
 | 角度误差 | 曲线和曲面在显示时，对它们进行离散的最大角度误差，默认值为28.647。
 | U向线数 | 线框显示模式中U方向的曲线数。
 | V向线数 | 线框显示模式中V方向的曲线数。
系统精度 | 拾取精度 | 拾取图形对象时，屏幕上的拾取点与图形边界之间最大像素误差，默认值为6像素。
 | 串链误差 | 用串选方式拾取曲线时，两条曲线在连接端点处的最大允许距离误差。默认为0.01mm。
Undo设置 | 最大撤消次数 | 设置编辑菜单中撤消命令的最大有效次数。
 | 最大重做次数 | 设置编辑菜单中重做命令的最大有效次数。

1.6.2 颜色设置

为了更明显地区分SurfMill中操作的对象，“系统设置”中设置了“颜色设置”对话框，包括“对象颜色”和“绘图面”两组参数，如图1-25所示。

图 1-25 “颜色设置”对话框

参数定义：

对象颜色 | 用于设置各种图形对象的原始颜色，用鼠标双击不同对象的显示区弹出“颜色”对话框，可以选择所需颜色来改变每种对象的颜色。修改了某些对象颜色后，随后生成的该种对象将默认使用该种颜色。点击〖默认颜色〗按钮可以将颜色还原为SurfMill默认颜色。
 | 曲线 | 设定曲线的颜色
 | 曲面 | 设定曲面的颜色
 | 用户坐标系 | 设定用户坐标系的颜色
 | 路径 | 设定刀具路径的颜色
 | 使用系统当前颜色创建新对象 | 选中该选项，生成的新对象时使用系统当前颜色
屏幕背景颜色 | 设置系统的显示背景颜色。

1.6.3自动备份

为了减少某些意外导致数据丢失的情况，系统设置中设置了软件的自动备份功能。单击“自动备份”的标签，弹出如图1-26所示对话框。

图 1-26 “自动备份”对话框

自动备份功能可以将设计数据按预定时间间隔保存到JDPaint应用程序目录下的*_AutoSave.jdp文件中。例如原文件名为“123.jdp”自动备份后的文件名为“123_AutoSave.jdp”。

如果要让JDPaint按照框中设置的时间间隔来自动保存，一定要用鼠标选中自动备份选项。设置完毕以后单击〖确定〗按钮，保存设置。

说明：如果正在编辑的文件太大，自动备份时间间隔要设置的大一些，可设置为10分钟以上，因为自动备份时需要占用一段时间，如果自动备份时间间隔太短，会出现连续保存的现象，影响继续操作，特别是进行浮雕曲面造型和虚拟雕塑时更要注意时间间隔的设置。

1.6.3工作区

工作区和标尺相配合，能够非常直观的标识用户的作图区域。工作区的设置不会影响用户的绘图、排版等操作。一般情况下，不必进行修改。

通过点击“系统设置”对话框中的“工作区”属性页，即可弹出“工作区”对话框，如图1-27所示。

图 1-27 “工作区”对话框

工作区参数含义如下：

左下角 | 设置工作区左下角的X、Y、Z坐标。
尺寸 | 用于设置工作区X、Y、Z方向的大小尺寸。
允许显示 | 表示开启工作区，再用鼠标点击一次，该选项被去掉，工作区关闭。所有选项修改后必须通过点击〖确定〗键，系统参数生效。

1.6.4 功能定制

功能定制充分反映出JDPaint是个开放的雕刻软件平台，它罗列了当前系统提供的可由用户操纵的所有软件模块，用户可根据需要加载或卸载指定的软件模块。此外，精雕科技随时会根据雕刻行业的发展或者特殊行业的要求，开发新的软件模块，用户通常不必全部更新软件，即可实现软件升级。SurfMill 2.0就是利用JDPaint系统平台的这种特性开发出来的软件模块。

通过点击“系统设置”中的“功能定制”标签，可设定模块使用状态。如图1-28所示。

图 1-28 “功能定制”对话框

双击每种模块的“模块名称”，或者单击模块前的图形标识，可以改变模块打开或关闭的状态，改变后通过点击〖确定〗键关闭对话框。没有被禁止的模块图形标识显示为“对号”；当一个模块被禁止后，图形标识显示为“叉号”，下次启动JDPaint时，不会将该模块调入系统中，相应的命令也就不会在菜单中显示。用户可以根据自己的需要定制最适合的功能块，从而获得简洁的工作界面和更好的软件运行效率。

说明：只有重新启动JDPaint，修改的模块状态才会有效


设置当前图层

1.6.5 设置当前图层

设定指定图层为当前图层。

* 操作步骤：

1）选择对象：

选择对象并将该对象所在的图层设置为系统当前图层。


复制图层

1.6.4 复制图层

复制/移动指定图层到另一个图层，如下图1-23所示。

图1-23 图层复制

实现方法：

（1）选择需要复制的图层；（2）选择目标图层和对象操作方式。


复制对象

1.6.3 复制对象

复制或者移动指定对象到指定图层。

实现方法：

（1）选择对象；（2）选择图层。

* 操作步骤：

1）选择对象：

拾取图形对象，拾取选项如下：

图1-21 拾取图形对象

2）选择图层：

选择目标图层和对象操作方式：

图1-22 复制/移动对象到目标图层


隐藏图层

1.6.2 隐藏图层

隐藏指定图层。

图 1-20 隐藏图层

实现方法：

（1）点击 [image] 将可见图层转化为 [image] 不可见图层；

（2）点击 [image] 将不可见图层转化为 [image] 可见图层；

（3）在屏幕中拾取对象将隐藏该对对象所在的图层；


图层管理

1.6对象的图层管理

在图形设计过程中，可将属性相似的对象放在一层，可以方便于选择、显示、加锁和编辑等操作。点击右侧导航工具栏中的“ [image] ”按钮，出现如图1-17所示对话框。

图1-17 图层功能选项

图1-17中其它按钮功能的说明：

图层管理 | 图层管理中包括新建图层、删除图层等一系列图层操作功能。
隐藏图层 | 显示/隐藏指定的图层。
复制对象 | 复制/移动指定对象到指定的图层。
复制图层 | 复制/移动指定图层到另一个图层。
设置当前图层 | 设定指定图层为当前图层。


图层管理器

1.6.1 图层管理

点击“图层管理”按钮进入该功能，如图1-18所示。

图 1-18 图层管理器

对话框面板上已显示出系统缺省的图层：主绘图层，其中的图标含义如下：

* 图标 | 表示当前编辑图层，可以在其他图层的相应区域 [image] 点击鼠标来改变当前图层。当前图层只有一个，所有的新创建的对象，如绘制的图形将被放置到当前图层。但对于已存在对象，被变换或编辑后，其结果则会尽可能保持原来所属的图层。
图标 | 表示该图层不是当前编辑图层。
图标 | 表示图层处于显示状态；点击后为 [image] ，表示隐藏该图层及其所属图形。当前图层不能隐藏。
图标 | 表示图层处于隐藏状态。点击后为 [image] ，表示显示该图层及其所属图形
* 图标 | 表示图层未加锁，点击图标可将其切换为加锁状态。
图标 | 表示图层被加锁，点击图标可将其切换为未加锁状态。图层加锁后，同对象的加锁类似，属于该图层的对象不能被拾取或选择。
图标 | 表示图层的颜色，用鼠标双击它会弹出颜色对话框，可为该图层选择一种新颜色。

* 图1-17中其它按钮功能的说明：

使用图层颜色显示 | 选中“使用图层颜色显示”选项，在显示对象时，所有的图形对象都按各自所属图层的颜色显示，反之，使用对象自身的颜色显示。
新建图层 | 创建一个新的图层，如图1-19所示。
修改层名 | 双击图层名可以修改指定图层的层名。
删除图层 | 删除指定图层。
显示全部 | 将所有图层设置为可见图层
隐藏全部 | 将所有图层设置为不可见图层，除主图层外
加锁全部 | 将所有图层设置为加锁图层，除主图层外
解锁全部 | 将所有图层设置为解锁图层

图1-19 新建图层对话框


串链拾取

1.2.3 串链拾取

若要拾取一个曲线轮廓，使用串连拾取是最快捷的方法之一，它可以快速地把首尾相接的曲线段拾取上。

使用串选方式拾取曲线，导航工具栏中会出现串选工具栏，如图1-6所示，其中提供了有两种串选模式：串链拾取和限制串链拾取。

图1-6 串链拾取

1.2.3.1 串链拾取

指定的一条曲线，系统将自动搜索与当前曲线首尾相连的线段，搜索到新的线段后将其与当前曲线相连并继续执行搜索，直到搜索结束或者遇到曲线分叉点为止，经过这个过程可搜索到一串曲线链。在SurfMill中，将这种通过自动搜索串连曲线的拾取过程称为串链拾取， 如图1-7所示。

图1-7 串链拾取

当曲线链搜索到某一分支点（即有三条或多条曲线共有的端点）处时，系统将在此分支点处停止搜索并显示一个箭头，提示用户拾取哪一分支曲线段作为继续串链搜索的方向，如图1-8所示。用户拾取到分支点处的一条曲线后，则系统将此曲线进行串链并继续向前进行搜索。用户可点击导航工具栏中的 [image] 按钮，可改曲线变串链方向，分支点处的红色箭头将反向。点击“结束拾取”按钮或单击鼠标右键结束串链拾取。

图1-8 分支点处理

1.2.3.2 限制串链

限制串链拾取与自动串链拾取稍有不同，限制串链过程中用户需指定曲线链的开始曲线段与结束曲线段，中间部分由系统自动搜索串链完成。

限制串链拾取的步骤如下，如图1-9所示。

1) 拾取曲线链上的第一条曲线；拾取后在此曲线段的两个端点上出现两个箭头，紫色的表示为串链曲线的起始点，红色的表示追踪下一段曲线的方向点；

2) 拾取曲线链上下一段要串链在一起的曲线；可以拾取曲线链上与上一段相连的曲线或是要连接到的曲线；

3) 继续拾取曲线链上下一段要串链在一起的曲线；点击“结束拾取”按钮或单击鼠标右键结束拾取。

图1-9 限制串链拾取

1.2.3.3 串链分叉处理

在串链拾取与限制串链拾取过程中，遇到曲线链分叉时，导航工具栏中弹出串链拾取按钮选项，如图1-10所示。

图1-10 串选按钮选项

参数定义：

曲线反向 | 用于调整串链曲线当前的方向走向，注意观察曲线上红色箭头与紫色箭头的变化。
对象过滤 | 用于设定拾取过程中对曲线类型的过滤选项。 点击此按钮，弹出过滤对话框，如图1-11所示。
取消拾取 | 用于取消在本次串连拾取中所有被选中的曲线。
结束拾取 | 确定当前被选中曲线链，并结束串链拾取操作。

图1-11 曲线串链过滤设置

参数定义：

类型过滤 | 可以进行串选的曲线包括直线、圆弧、样条曲线、组合曲线、三维折线、曲面边界线和曲面边界环等。 不选择此选项，则上述所有类型的曲线均可以进行被串选；选择此选项，则可以设定那些类型曲线可以被串选，那些不能。选择某一曲线类型，则这类曲线可以被串选，否则不能被串选。点击“全选”和“反选”按钮可以进行全部类型选择和类型的反向选择。
颜色过滤 | 选择该选项，则曲线链上只有颜色相同的曲线才能一起被串选。
曲线共面 | 选择该选项，则只有在同一平面内的曲线才能一起被串选。
角度过滤 | 选择该选项，则当曲线链上两相邻曲线的端点切矢角度大于设定的角度值时，则不能将两曲线进行串选。
曲线连接精度 | 当曲线链上两相邻曲线的端点距离小于设定的连接精度时，两曲线才能被一起串选。否则这两曲线不能被串选。


点选

1.2.1点选

在SurfMill中，对象被选中之前都有相应的提示光标，不同的光标代表将拾取到不同的对象。

提示拾取点。

提示拾取曲线。

提示拾取曲面。

提示拾取绘图平面。

提示拾取刀具路径。

提示拾取指定对象的颜色。

将鼠标移动到指定的对象上，单击鼠标左键，对象被选中。如图1-2所示对图形的点选。点选也被称为点拾取。

图 1-2 对象点选


对象的选择

1.2对象的选择

对象的选择是三维造型环境下常用的操作，也是熟练应用SurfMill系统的基础。在SurfMill系统中，我们把对象的选择与对象的拾取加以区分：

l 对象的选择：指工具命令状态下对图形对象的选择，包括点选、框选和按指定类型选择等功能。SurfMill系统中大部分的命令首先都要进行对象的选择；

l 对象的拾取：指在常规命令过程中要求拾取一个操作对象的过程，往往是一个点选操作。

通常地，二者在SurfMill系统中没有本质的区别，只是在不同对象操作过程中，叫法不同而已。目前，SurfMill系统有四种对象选择的方法：

l 点选

l 窗选

l 曲线串链拾取

l 按对象类型选择


按对象类型选择

1.2.4按对象类型选择

在曲面造型状态下，点击导航工具栏中的“ [image] ”按钮，进入按对象类型选择命令，导航工具栏出现如图1-12所示对话框。

图 1-12 按对象类型选择

参数定义：

对象过滤 | “对象过滤”根据对象类型来进行筛选对象。不同类型的旁边有该类型对象数目的统计，从下拉列表中可以选择“选中个数”、“未选个数”和“总数”分别统计。 对象类型参见上一节。将对象按类型分开，可以有效地实现指定类型对象的选择。
颜色过滤 | “颜色过滤”根据指定颜色来筛选对象。选中此选项，单击“ [image] ”按钮，弹出颜色选择对话框，可以指定颜色。也可点击“ [image] ”按钮，鼠标变成如图1-13所示形状，拾取对象就可获得指定对象的颜色。 图 1-13 拾取对象颜色
全部选中 | 点击“ [image] ”按钮，则选中窗口内所有通过“对象过滤”和“颜色过滤”后的对象。
全部不选 | 点击“ [image] ”按钮，则按窗口内所有通过“对象过滤”和“颜色过滤”后的对象类型，将已经被选中的对象转换为未选状态。

“按类型选择”特别适用于重叠图形、交叉图形的选择，在图形比较错综复杂的时候，选择起来比较方便。


窗选

1.2.2窗选

在窗口空白处按住鼠标左键，拖动鼠标形成一个蓝色的矩形线框，以鼠标点击的位置为相对点，鼠标可以向左移动，也可以向右移动，如图1-3所示。

图 1-3 对象窗选

窗选可分为两类：

包含窗选 | 鼠标从左到右拖动，需要把所要选择的对象全部框住，松开鼠标左键，凡是框内套住的对象就被选中，如图1-4所示。 图 1-4 包含窗选
相交窗选 | 鼠标从右到左拖动，松开鼠标左键，凡是与矩形线框相交的对象和矩形框内套住的对象都被选中，如图1-5所示。 图 1-5 相交窗选

说明：

复选： | 按住“Shift”键，继续点选或窗选图形对象，可以很方便自如地完成复选。
反选： | 按住“Ctrl”键，继续点选或窗选图形对象，可完成反选，即将被选对象转为未选状态。


角度发生器

2.4 角度发生器

在一些功能提示要求输入角度时，按下键盘空格键或者<SPACE BAR>，进入角度发生器命令，在导航工具条中弹出提示对话框，如图2-28所示。

图2-28 角度发生器

角度发生器不仅提供了角度键盘输入，还可以通过以下方式获取精确角度数值。

与X轴夹角 | 以两点直线与X轴方向的夹角作为输入角度。
与Y轴夹角 | 以两点直线与Y轴方向的夹角作为输入角度。
与Z轴夹角 | 以两点直线与Z轴方向的夹角作为输入角度。
三点角度 | 以三点形成的夹角作为输入角度。
两线夹角 | 以两直线的夹角作为输入角度。
圆弧角度 | 以指定圆弧的圆心角作为输入角度。

通过角度发生器精确定角度后，点击<确定>完成角度精确输入。


定义轴线

2.6 定义轴线

在许多命令操作中，需要定义轴线（如旋转轴和镜像轴等），SurfMill中提供了通用的定义轴线工具。如图2-31所示，系统提供了以下几种定义轴线的方法：

图2-31 定义轴线选项组

参数定义：

两点 | 通过两点定义轴线。 实现方法：用鼠标拾取两个点。
直线 | 拾取直线作为轴线。 实现方法： （1）拾取一条直线； （2）选择直线的一个方向做为要定义的矢量方向。


定义方向

2.5 定义方向

在许多命令操作中，需要定义方向（如拉伸方向、投影方向），SurfMill中提供了通用的定义方向工具。如图2-29所示，系统提供了以下几种定义方向的方法：

图2-29 方向定义选项组

参数定义：

指出 | 定义的方向矢量为曲线在其上某一点处的切矢，如图2-30(a)所示。实现方法： （1）拾取一条曲线； （2）选择曲线在拾取点处的切矢方向或其反方向做为要定义的方向矢量。
端点 | 定义的方向矢量为曲线上某一端点的切矢，如图2-30(b)所示。 实现方法： （1）拾取一条曲线； （2）选择曲线在端点处的切矢方向或其反方向做为要定义的方向矢量。
中点 | 定义的方向矢量为曲线上某一端点的切矢，如图2-30(c)所示。 实现方法： （1）拾取一条曲线； （2）选择曲线在中点处的切矢方向或其反方向做为要定义的方向矢量。
两点 | 定义的方向矢量为第一点到第二点的方向矢量，如图2-30 (d) 所示。 实现方法：用鼠标拾取两个点。
法矢 | 定义的方向矢量为曲面上某一点处的法矢，如图2-30(e)所示。 实现方法： （1）拾取一个几何曲面； （2）选择曲面在拾取点处的法矢方向或其反方向做为要定义的矢量方向。
屏幕视向 | 定义的方向矢量为当前屏幕的观察视角方向。
UCS-X轴 | 定义的方向矢量为当前坐标系的X轴向。
UCS-Y轴 | 定义的方向矢量为当前坐标系的Y轴向。
UCS-Z轴 | 定义的方向矢量为当前坐标系的Z轴向。

图2-30 方向定义


定义平面

2.7 定义平面

SurfMill中提供了通用的定义平面工具。如图2-32所示，系统提供了以下几种定义平面的方法：

图2-32 定义平面选项组

参数定义：

UCS-XY平面 | 拾取指定坐标系的XY平面作为定义平面。 实现方法：拾取坐标系
UCS-XZ平面 | 拾取指定坐标系的XZ平面作为定义平面。 实现方法：拾取坐标系
UCS-YZ平面 | 拾取指定坐标系的YZ平面作为定义平面。 实现方法：拾取坐标系
曲线 | 以通过两条共面直线或通过某一条二维曲线(如圆弧)所在的平面作为定义平面。 实现方法：拾取平面曲线，如果拾取的是一条圆弧或平面样条曲线，则定义的平面为该曲线所在的平面；如果拾取的是一条直线，则系统继续提示输入第二条曲线，如果拾取的两条线不共面，则第二次选择无效；
矢量 | 通过确定平面的法矢和平面通过点的方法定义平面 实现方法： （1）输入矢量通过点 （2）输入矢量方向点 （3）输入平面通过点
三点 | 定义通过三点的平面 实现方法： （1）输入平面坐标原点 （2）输入平面X轴向参考点 （3）输入平面Y轴向参考点
平行 | 定义过点与当前绘图平面平行的平面 实现方法： （1）输入平面通过点
视平面 | 定义过点与视平面平行的平面 实现方法： （1）输入平面通过点

图2-33 平面定义


长度-距离发生器

2.3 长度-距离发生器

在一些功能提示要求输入长度或者距离时，按下键盘空格键或者<SPACE BAR>，进入长度-距离发生器命令，在导航工具条中弹出提示对话框，如图2-27 所示。

图2-27 长度-距离发生器

长度-距离发生器实际上是一个数值发生器。它不仅提供了数值键盘输入，还可以通过以下方式获取精确数值。

两点距离 | 拾取两点的长度作为输入数值。
两点X方向距离 | 拾取两点的X轴分量长度作为输入数值。
两点Y方向距离 | 拾取两点的Y轴分量长度作为输入数值。
两点Z方向距离 | 拾取两点的Z轴分量长度作为输入数值。
曲线长度 | 拾取曲线的长度作为输入数值。

通过长度-距离发生器精确数值后，点击<确定>完成数值精确输入。


绘图基础

第二章 绘图基础

SurfMill是三维设计与加工软件，它的工作对象是三维的。目前SurfMill的三维模型主要通过线框和曲面来构建。应用SurfMill进行曲面造型基本步骤如下：

首先，在空间平面上进行三维线框的设计打样，绘制出模型的特征轮廓曲线；

其次，在模型的轮廓特征线基础上，应用曲面构造工具，创建曲面；

第三，应用曲面编辑工具，例如曲面裁剪、曲面圆角过渡等，编辑修改曲面，获得曲面模型；

第四，对曲面模型进行刀具轨迹自动编程，生成加工刀具路径。

这四个步骤的曲面造型思路，即由点生成线，由线生成面，由面生成三维模型以及由曲面模型生成刀具路径，也是当今主流CAD/CAM系统曲面造型的基本思路，读者必须领会把握。

本章主要叙述三维绘图的基础知识，即如何定义三维线框打样平面，如何观察三维模型设计效果，如何输入空间点、长度和角度。三维对象拾取操作也属于是三维绘图的基础操作，在第一章中已经讲述，这里不再赘述。

本章的主要内容包括：

用户坐标系 | 介绍用户坐标系与绘图平面定义。
点输入 | 点输入方法： （1）点坐标鼠标输入； （2）点坐标键盘输入； （3）点坐标发生器。
长度输入 | 长度输入方法： （1）长度鼠标输入； （2）长度发生器。
角度输入 | 角度输入方法： （1）角度鼠标输入； （2）角度发生器。
定义方向 | 定义方向矢量。
定义轴线 | 定义轴线工具
定义平面 | 定义平面工具
视角定义 | 图形三维观察视角定义。


视角定义

2.8 视角定义

在三维空间中观察三维模型，需要设定不同的观察角度，即图形视角。图形视角是当前屏幕上三维图形的观察角度，设定图形的观察视角就相当于用照相机对模型从不同的角度处进行拍照。按一定比例、观察位置和角度显示的图形我们称为视图。在SurfMill中，可以通过不同的视图来观察，也可以动态调整图形视角和保存当前视角。


标准视图

2.8.1 标准视图

在空间中观察三维模型的过程：首先是将对象沿假想的X、Y和Z轴进行放置，如图2-36(a)所示，阶梯块在放置时可使其最远的左角点与世界坐标系原点一致，并将此块与X、Y和Z轴对齐；其次从不同的方向观察对象，图2-36(b)所示为俯视图、主视图和右视图的观察方向；图2-36(c)为该阶梯块的几个标准的视图。

(a) 将对象与X、Y和Z轴对齐 (b) 主、侧和俯视图的观察方向

(c) 六种标准视图

图2-36 视图观察

SurfMill可以设定一些标准的视图来观察三维模型，还可以动态地调整图形视角来进行观察。当前视图设定方法主要有：

1）单击“视图\设置视图(I)”菜单项中的各子菜单项来设定当前视图，如图2-37所示；

2）点击鼠标右键菜单中的视图菜单项来设定当前视图，如图2-38所示；

3）点击常用工具条中的视图按钮来设定当前视图，如图2-39所示；

图2-37 “设置视图”子菜单项 图2-38 鼠标右键菜单中的视图子菜单

图2-39 常用工具条中的视图按钮

SurfMill中提供了俯视图、正视图、右视图、仰视图、后视图、左视图、轴侧视图等七种标准视图。

俯视图 | 沿世界坐标系Z轴的正向向原点观察对象得到的视图。
正视图 | 沿世界坐标系Y轴的负向向原点观察对象得到的视图。
右视图 | 沿世界坐标系X轴的正向向原点观察对象得到的视图。
仰视图 | 沿世界坐标系Z轴的负向向原点观察对象得到的视图。
后视图 | 沿世界坐标系Y轴的正向向原点观察对象得到的视图。
左视图 | 沿世界坐标系X轴的负向向原点观察对象得到的视图。
轴侧视图 | 沿世界坐标系中的(1,-1,1)位置向原点观察对象得到的视图。


自定义视角

2.8.2 自定义视角

用户可通过“视角”命令定义视角，如图2-40所示。

图2-40 视角功能选项

2.8.2.1 保存视角

在设计过程中，某些视角会经常用到（如观察图形某一局部时），为了观察方便可以将它们保存起来，以便随时都可以恢复这些视图。单击“保存视角”按钮，弹出对话框，如图2-41所示。

图2-41 保存当前视图

参数定义：

视角名称 | 保存新视角的名称。
与当前坐标系关联 | 选中该选项时，保存视图还将保存系统此时当前坐标系状态，以便恢复该视角的同时，恢复当前坐标系状态。

2.8.2.2 视角管理

视角管理中罗列了系统中定义的所有视角，包括标准视图和用户自定义的视角，如图2-42所示。

图2-42 视图管理对话框

参数定义：

视角名称 | 双击视角名称，可以将指定视图设置为当前视图。
保存视角 | 保存当前视角。单击该按钮，弹出对话框，如图2-42所示。
更新视角 | 用当前视角更新已保存的视角内容。
删除视角 | 删除已保存指定的用户自定义视角
删除全部 | 删除全部用户自定义的视角


点坐标发生器

2.2.3 点坐标发生器

在一些功能提示要求输入点时，按下键盘空格键或者<SPACE BAR>，进入点坐标发生器命令，在导航工具条容器窗口中弹出一个新的导航工具条，如图2-25 所示。

点坐标发生器功能解决了点坐标不易确定、特征点捕捉不到的时候，但是该点的坐标分量可以从已存在的点或者已存在的对象的相关数据信息获得等情况下的坐标输入问题。点坐标分量的精确值可通过对象捕捉获得，或者其它方式精确获得。

点坐标发生器功能集特征点的自动捕捉与键盘精确输入于一身，是SurfMill系统中功能最强的精确点坐标输入工具。

如同特征点自动捕捉，利用点坐标发生器能够精确捕捉到对象上的特征点，包括：端点、中点、圆心、两线交点、四分点、垂足点、相切点和最近点，其功能较特征点自动捕捉还要强大。在垂足点和相切点时，系统可以重设基点坐标。

在捕捉特征点前，通过设定X、Y、Z的输入坐标分量的检查框的有效标志，可以保证捕捉到预期的点坐标分量，并保留不需改变的点坐标分量。此外，在绝对坐标和相对坐标输入状态下，还可以单击 [image] 按钮，进入长度-距离发生器，分别确定点坐标的分量。类似地，当进行极坐标输入时，与长度-距离发生器和角度发生器协同，能够分别确定输入点的极坐标的长度和角度分量。

通过点坐标发生器精确定点后，点击<确定>完成该点精确输入。

图2-25 点坐标发生器

端点 | 精确捕捉到曲线的端点
中点 | 精确捕捉到曲线的中点
圆心 | 精确捕捉到曲线的圆心
交点 | 精确提取两曲线的交点
最近点 | 精确提取曲线的最近点
穿插点 | 精确提取曲线与平面的交点，如图2-26；首先在屏幕上拾取穿插曲线，然后再根据定义平面选项组来定义穿插平面；
四分点 | 精确捕捉到曲线的四分点
垂点 | 精确计算曲线的垂点
切点 | 精确计算曲线的切点

图2-26 穿插点示意图


点的输入

2.2 点的输入

点的输入可分为点的鼠标输入、点的键盘输入和点坐标发生器输入三种。

点的鼠标输入也称为点对象捕捉，点的键盘输入也称为点坐标输入。


点的键盘输入

2.2.2 点的键盘输入

三维空间中任何一个点的坐标用（X，Y，Z）表达，其中X、Y和Z的值分别表示点在某一坐标系的X轴、Y轴和Z轴进行垂直投影所对应的数值，如图2-35所示。一个点对世界坐标系统的三个轴进行垂直投影得到了点在世界坐标系中的坐标值，同样对用户坐标系的三个轴进行垂直投影便可得到点在用户坐标系中的坐标值。在三维环境中若点的坐标用(X，Y)表示，系统总是把坐标系中当前的标高作为点的Z坐标值，默认情况下，该值为0。

图2-21 三维空间中的点坐标

点坐标的三维输入方式有三种：绝对坐标输入、相对坐标输入和柱坐标输入。在状态栏中的“坐标和数字输入区”内输入点坐标值；另外通过点击状态栏中的“世界坐标/用户坐标”切换按钮，如图2-36所示，可以控制当前输入的点为世界坐标系中的点坐标还是用户坐标系中的点坐标。切换按钮显示 * 表示世界坐标系， [image] 表示用户坐标系。

图2-22 与坐标输入相关的状态栏控制

1、绝对坐标输入

输入方式：（X,Y,Z）或(X,Y)，如(10,10,20)和(50,10)，其中X、Y和Z的值表示点的三个坐标分量值。

说明：

1）当“世界坐标/用户坐标”控制按钮切换为 [image] 时，当前输入的点坐标为用户坐标系坐标；若输入点为二维坐标方式(X,Y)，输入的点的位置在当前绘图平面Z深度处的平行平面内。

2）当“世界坐标/用户坐标”控制按钮切换为 [image] 时，当前输入的点坐标为世界坐标系坐标；若输入点为二维坐标方式(X,Y)，输入的点的位置在世界坐标系中的XY平面内。

3）SurfMill建议用户在三维空间中绘制平面图形时，首先定义好绘图平面和Z深度值，然后输入的点坐标采用用户坐标系中的二维坐标（X,Y）方式，这样就很方便地将三维空间绘图转为二维平面绘图。

2、相对坐标输入

输入方式：（@X,Y,Z）或(@X,Y)，如（@10,10,10）和(@20,15)，其中X、Y和Z的值都是相对于参考点在XYZ三个方向的偏移距离(即坐标增量)，参考点可以是任意一个点。

图2-23 相对坐标输入

说明：

1）当“世界坐标/用户坐标”控制按钮切换为 [image] 时，则输入的X、Y和Z的值是相对于参考点在用户坐标系的XYZ三个方向上的坐标增量；若输入点为二维坐标方式(@X,Y)，输入的点与参考点在用户坐标系中的Z坐标值相同。

2）当“世界坐标/用户坐标”控制按钮切换为 [image] 时，则输入的X、Y和Z的值是相对于参考点在世界坐标系的XYZ三个方向上的坐标增量；若输入点为二维坐标方式(@X,Y)，输入的点与参考点在世界坐标系中的Z值相同。

3）如果要绘制的图形在当前绘图平面Z深度处的平面内，建议在设定好工作深度Z值后采用用户坐标系中的二维相对坐标输入(@X,Y) 方式。

3、柱坐标输入

相对于二维极坐标(~长度，角度)输入，三维环境下采用了柱坐标输入的方式。

输入方式：(~ρ,α,z)或(~ρ,α)，即(~距离,角度,高度)或（~距离,角度）。在柱坐标系中，点的位置由点在XOY面的投影到坐标原点的距离(ρ)、点在坐标系XOY面相对于X轴正向逆时针转过的角度(α)和点在坐标系中的高度值(z)来确定，如图2-38所示。柱坐标系可以建立在世界坐标系或当前用户坐标系中。二维输入方式(~ρ,α)与二维极坐标输入方式相同，点的高度为坐标系中的当前标高。

图2-24 柱坐标系

说明：

1）当“世界坐标/用户坐标”控制按钮切换为 [image] 时，则输入的点为当前用户坐标系中的柱坐标点；若输入点为二维坐标方式(~ρ,α)，则点的z坐标为当前设定的工做深度Z值。

2）当“世界坐标/用户坐标”控制按钮切换为 [image] 时，则输入的点为世界坐标系中的柱坐标点；若输入点为二维坐标方式(~ρ,α)，则点的z坐标值为0。

3）如果要绘制的图形在当前绘图平面Z深度处的平面内，建议在设定好工作深度Z值后采用用户坐标系中的极坐标输入(~ρ,α) 方式。


点的鼠标输入

2.2.1 点的鼠标输入

点的鼠标输入是用鼠标在屏幕上定位一个点的过程，使用鼠标可以在屏幕上随意点击输入点，也可以快速捕捉到已存在的点或者某个已存在的对象的精确位置。SurfMill提供了一种功能，可以非常方便地在屏幕上使用光标，捕捉已存在的点或者是某个已存在的对象的精确位置，并且显示已捕捉过的点的信息。

点的鼠标输入功能主要有：

  1. 屏幕点输入
  2. 特征点捕捉
  3. 正交捕捉

2.2.1.1 屏幕点输入

屏幕点鼠标输入通过鼠标直接在屏幕上点击实现坐标点输入。要实现鼠标在空间上定义任意的三维点，SurfMill系统做了以下约定：

如前文所述，SurfMill系统中具有唯一个系统当前坐标系；系统当前坐标系对应唯一个系统当前绘图平面。鼠标点所对应的点就落在当前绘图平面上。

例如当前绘图平面为XY平面Z向深度为零时，点击鼠标点输入的三维点坐标即为XY平面上的空间点；修改Z向深度值，点击鼠标可以在与XY平面平行的一系列平面输入三维点。同理，当前绘图平面为XZ平面或者YZ平面上时，可以在与XZ平面或YZ平面平行的一系列平面输入三维空间点。

当当前绘图平面与屏幕视平面垂直时，点击鼠标将无法输入三维坐标点，系统弹出错误提示，如图2-15所示。此时可通过快捷健F9切换当前绘图平面，或者通过常用工具条中的设置绘图平面按钮 [image] 重新设置。

图 2-15 自动捕捉功能开启与关闭

除了在当前绘图平面上定点外，SurfMill系统还在提供定义临时绘图平面功能，用户可以通过鼠标在临时绘图平面定点。临时绘图平面的定义请参考《定义平面》章节。

2.2.1.2 特征点自动捕捉

特征点捕捉命令是SurfMill提供的一个绘图辅助工具，用于帮助用户更精确地作图。特征点捕捉也即我们通常所说的自动导航。采用下面方法可切换特征点捕捉命令的开启与关闭：

1）单击菜单栏中的“视图/自动导航”菜单命令，即可切换自动捕捉的开关。

2) 单击工具栏中的特征点捕捉命令的开关按钮“ [image] ”。

自动捕捉功能开启与关闭按钮的表现形式：

图 2-16 自动捕捉功能开启与关闭

SurfMill提供了十五种对象特征点捕捉模式可供选择，如图2-17所示。

图 2-17 特征点自动捕捉工具条

曲线特征点 | 端 点 | 捕捉距光标最近的曲线的端点；也捕捉曲面边界线的端点。
 | 中 点 | 捕捉距光标最近的直线、圆弧、多义线等的中点；也捕捉空间曲线的端点和曲面边界线的中点。
 | 圆 心 | 圆心捕捉模式，捕捉距光标最近的圆、椭圆或圆弧的圆心。
 | 交 点 | 交点捕捉模式，捕捉曲线两两相交的交点。
 | 切 点 | 切点捕捉模式，是在圆、椭圆、圆弧或曲线上捕捉某一点，该点与上一拾取点形成的连线与这些对象相切。
 | 垂 点 | 垂点捕捉模式，捕捉直线、圆弧、椭圆或者曲线上的某一点，该点与上一拾取点形成的连线与这些对象垂直。
 | 四分点 | 四分点捕捉模式，捕捉距光标最近的圆、圆弧、椭圆上0度、90度、180度或270度位置的点。
 | 最近点 | 最近点捕捉模式，捕捉距光标最近的曲线上的最近点。
自由点 | 存在点 | 捕捉距光标最近的存在点；
 | 坐标原点 | 捕捉距光标最近的坐标系的原点；
曲面特征点 | 曲面点 | 捕捉曲面上的点；
 | 曲面边界点 | 捕捉曲面边界线上的点
 | 曲面交叉点 | 捕捉曲面显示参数线相交叉的点
路径特征点 | 路径节点 | 捕捉刀具路径对象上的节点
 | 路径最近点 | 捕捉距光标最近的刀具路径对象上的最近点
 | 设定捕捉 | 设定系统默认的特征点捕捉模式
 | 取消捕捉 | 取消所有特征点捕捉模式
 | 捕捉设置 | 系统特征点设置选项，点该按钮弹出对话框，如图2-24所示，用户可设定系统默认的特征点捕捉模式
 | 强制捕捉 | 选中“强制捕捉”模式按钮，系统强行捕捉距离光标最近的图形对象上的特征点； 不选中“强制捕捉”按钮，系统只捕捉距离光标的最近的，在光标捕捉范围之内的特征点。
 | 投影捕捉 | “投影捕捉”和“空间捕捉”是一对开关按钮。 选中“投影捕捉”按钮，系统自动把光标捕捉到的三维空间点投影成为当前的绘图面上的二维点； 选中“空间捕捉”按钮，系统将光标捕捉到的三维空间点作为的空间点处理； 点击“投影捕捉”按钮，按钮提示为“空间捕捉”，反之亦然。
 | 禁止捕捉 | 选中“禁止捕捉”按钮，特征点自动捕捉功能被关闭。 再点击“禁止捕捉”按钮，特征点自动捕捉功能被启动。 此外， 用鼠标点击“ [image] ”按钮，特征点自动捕捉功能被启动； 用鼠标再次点击“ [image] ”按钮，特征点自动捕捉功能被关闭。

图 2-18 特征点捕捉设置

(a) 端点捕捉 (b) 中点捕捉

(c) 交点捕捉 (d) 圆心捕捉

(e) 切点捕捉 (f ) 垂点捕捉

(g) 四分点捕捉

图 2-19 特征点类型

如果启动了特征点自动捕捉的功能，在执行一些命令时，随着鼠标在图形上移动，会时常出现特征点的代表符号，说明已经捕捉到了附近的特征点。

说明：

1）当前捕捉到的特征点是图形上与光标位置最近地那个的特征点，捕捉点处将显示当前捕捉点的代表符号。

2）切点和垂点捕捉只适用于连续拾取多个点时，所捕捉到的切点或垂点与上一个点所确定的直线与捕捉点所在的曲线相切或垂直。

3）要捕捉曲线上的最近点，必须关闭强制捕捉，另外对于圆弧上的最近点捕捉，还要关闭圆弧圆心捕捉。

4）将空间三维点投影到当前绘图面上的二维点之间的通过“投影捕捉”切换按钮实现。

2.2.1.2 正交捕捉模式

正交捕捉是用于辅助绘图的一种工具，利用SurfMill的正交捕捉，可以绘制出完全相垂直或者相互平行的直线，特别是在许多绘制需要完全垂直和平行的情况下，这种方式更能显示其优势。采用下面方法可切换正交的开启与关闭：

1） 单击菜单栏中的“视图/正交捕捉”命令。

2） 单击工具栏中的正交模式捕捉功能的开关按钮“ [image] ”。

启动了正交模式之后，无论是在执行绘制中的命令，还是在执行变换中的平移、旋转、镜像等命令时，鼠标在确定了第一个点后，移动鼠标，编辑框并不是移动到鼠标的位置，而是只在水平方向或竖直方向进行移动，如图2-31所示。点击鼠标左键即可确定第二点。

图2-20 正交捕捉


曲面显示

2.9 曲面显示

本章将介绍曲面的显示模式和修改曲面显示模式和显示参数等。


显示模式

2.9.1显示模式

SurfMill提供了五种三维曲面模型显示模式：线框显示、渲染显示、边界显示、网格显示和混合显示。点击“工具(T)->显示模式(H)”的各子菜单项（如图2-34），或点击常用工具栏中的显示模式图标按钮，如图2-35所示，可以设定不同的显示模式。

图2-34 显示模式子菜单

图2-35 显示模式工具条

参数定义：

线框显示 | 曲面模型显示为三维线框，如曲面的U向线和V向线，如图2-36(a)所示。
渲染显示 | 曲面模型显示为曲面渲染后的真实感图形，如图2-36(b)所示。
边界显示 | 曲面模型显示为曲面边界轮廓线，如图2-36(c)所示。
网格显示 | 曲面模型显示为三角或者四边网格，如图2-36(d)所示。
混合显示 | 曲面模型显示可以为线框显示、渲染显示、边界显示和网格显示的混合。

(a) 线框显示 (b) 渲染显示

(c) 边界显示 (d) 网格显示

图2-36 显示模式


修改曲面显示

2.9.2 修改曲面显示

用户可以更改屏幕上所有曲面或选定的曲面的显示状态和显示参数等。

2.9.2.1 修改曲面显示

修改屏幕上选定的曲面的显示状态和显示参数等。

点击菜单项“工具（T）”->“显示（D）”->“修改曲面显示（A）”，系统弹出对话框如图2-37所示。用户首先拾取需要修改显示的曲面，然后再定义新的显示参数和选项，点击“确定”按钮。

图2-37 修改曲面显示

参数定义：

【重构曲面边界线】 |  | 选中此选项，则以新的较高的精度值来重构曲面边界线，提高曲面边界线的显示精度；
【重算显示参数线】 |  | 选中此选项，则可以对选定的曲面设定新的显示参数线；
显示参数线 | U向线数 | 线框显示模式中U方向的曲线数；
 | V向线数 | 线框显示模式中V方向的曲线数；
 | 弦高误差 | 曲线和曲面在显示时，对它们进行离散的最大弦高误差；
 | 角度误差 | 曲线和曲面在显示时，对它们进行离散的最大角度误差；
【修改曲面显示模式】 |  | 选中此选项，则可以改变选定的曲面的显示模式；
显示模式 |  | 有线框显示、渲染显示、边界线显示和网格显示四种选项；

2.9.2.2 重建显示模型

修改屏幕上所有曲面的显示参数。

点击菜单项“工具（T）”->“显示（D）”->“重建显示模型（S）”，系统弹出对话框如图2-38所示。

图2-38 重建曲面显示模型

对话框中的各参数定义参照<2.9.2.1 修改曲面显示>。


北京精雕科技有限公司 版权所有 翻印必究

第二章 绘图基础

-46-

-18-

-17-


世界坐标系和用户坐标系

2.1.1 世界坐标系和用户坐标系

使用SurfMill绘制三维图形必须先理解三维坐标系的概念。在三维坐标系中的X、Y、Z的位置关系可以用右手法则来描述，如图2-2所示。

图2-2 右手定则

右手法则：

右手拇指、食指和中指两两互相垂直，其中：

拇指方向代表三维直角坐标系的X轴方向；

食指方向代表三维直角坐标系的Y轴方向；

中指方向代表三维直角坐标系的Z轴方向。

另外，还可以通过右手定则判断旋转的正方向，如果拇指指向代表轴的方向，其余四指并拢弯曲，弯曲方向为旋转角度的正向，如图2-2所示。

SurfMill中把在三维设计中遇到的坐标系分为两类：世界坐标系和用户坐标系。

世界坐标系，英文简称WCS（World Coordinate System），是系统默认的固定不变的坐标系，它不会随着绘图平面或视图的变化而改变；世界坐标系的标记为一正方体并始终位于屏幕的左下角，如图2-3所示。世界坐标系是唯一的，用户不能修改；

用户坐标系，英文简称UCS（User Coordinate System），是由用户定义的空间三维坐标系。用户坐标系可以根据用户绘制图形的需要而创建、修改或者删除。一个坐标系有三个平面与其对应，即XY平面、XZ平面和YZ平面，每个平面都可以根据需要设定为绘图平面。

SurfMill系统中只有一个系统当前坐标系，并将世界坐标系设为缺省的当前坐标系。系统当前坐标系唯一对应一个系统当前绘图平面（下文简称当前绘图平面）。当前绘图平面可为XY平面、XZ平面和YZ平面中之一。当前绘图平面可通过快捷健F9切换，或者通过常用工具条中的设置绘图平面按钮 [image] 进行设置。

图2-3 世界坐标系和用户坐标系

注意：屏幕左下角的坐标标志只为世界坐标系统的三个轴的方向标志，不代表世界坐标系的原点位置。


绘图平面与深度值

2.1.2 绘图平面与深度值

当前绘图平面是定义在当前坐标系上的平面。因此当前绘图平面随着当前坐标系的改变而改变。

当前绘图平面为当前坐标系的XOY平面时，空间上与之平行的一系列平面与绘图平面之间的距离可通过其Z坐标值来标定，如图2-4所示。很明显，在绘图平面内的绘制图形，实际是在该用户坐标系中的XOY面内绘图，这样就可方便地将三维空间绘图转换为二维平面绘图。设定坐标系的不同Z值，可确定出一系列平行与该绘图面的平面。我们把这里的Z值也称为Z向深度值，绘图平面为相当于0工作深度。在一定工作深度平面内绘图，如同在绘图平面内绘图一样方便，其XOY坐标系与绘图平面中的XOY坐标系相同。

图2-4 XOY绘图平面与Z向深度平面

同理，当前绘图平面为XZ平面时，空间上与之平行的一系列平面与绘图平面之间的距离可通过其Y坐标则深度值来标定，如图2-5 (a)所示。

当当前绘图平面为YZ平面时，空间上与之平行的一系列平面与绘图平面之间的距离可通过其X坐标则深度值来标定，如图2-5 (b)所示。

(a) XOZ绘图面及Y向深度平面 (b) YOZ绘图平面及X向深度平面

图2-5 绘图平面及其平行平面

在曲面造型工具状态下，导航工具栏中的深度按钮 [image] 显示了系统当前绘图平面的深度值。要在不同的深度值处绘图时，点击该按钮后，可以直接输入数字来确定深度，也可以在当前屏幕图素上拾取一点，通过该点在当前用户坐标系中的坐标值来确定。


用户坐标系

2.1 用户坐标系

三维线框的设计打样工作一般都在某一空间平面上进行，后者就是绘图平面，也称工作平面。工作平面通常建立在工作坐标系上。线框设计要求工作平面及其对应的工作坐标系有方便灵活的定义和切换方法。例如图2-1中手表含有底面、顶面和侧面的凸台等，它的线框模型十分复杂。三维作图时需要将绘图平面依次设定在表壳的顶面以及前后左右各个侧面和底面上，在局部平面上画二维图。

图 2-1 手表模具


用户坐标系的操作

2.1.3 用户坐标系的操作

点击导航工具栏坐标系按钮 [image] ，弹出下列菜单，如图2-6所示。

图2-6 坐标系操作功能

绘图平面操作主要有以下功能：

1) 设置当前坐标系： | 将指定的坐标系设置为系统当前坐标系。
2) 创建用户坐标系： | 在空间的某一指定位置创建一个新的用户坐标系。
3) 修改用户坐标系 ： | 修改指定的用户坐标系，获得新用户坐标系。
4) 删除用户坐标系 ： | 删除指定的用户坐标系
5) 管理用户坐标系： | 管理用户坐标系

2.1.3.1 设置当前坐标系

SurfMill系统约定系统有且只有一个当前坐标系，采用图形绘制命令生成的图形一般都落在当前坐标系的当前绘图平面上。因此，设定当前坐标系功能命令对于用户确定三维线框的设计打样工作十分重要。

点击“ [image] ”按钮，命令提示“拾取坐标系，并将其设定为系统当前坐标”，用户只需在屏幕上拾取所需的坐标系即可实现当前坐标系的设定。

2.1.3.2 创建用户坐标系

SurfMill提供了以下五种创建用户坐标系的方法。点击“ [image] ”按钮，系统进入创建用户坐标系命令，如图2-7所示。

图2-7 创建用户坐标系

通过三点 | 通过三点构造用户坐标系；
偏移+旋转 | 将指定坐标系偏移一定距离，并绕某一坐标轴旋转一定角度后得到新坐标系；
过点+旋转 | 将指定坐标系偏移到指定点，并按某一坐标轴旋转一定角度后得到新坐标系；
绕轴旋转 | 将指定坐标系绕某一旋转轴线旋转一定角度生成新的坐标系；
屏幕+过点 | 构造一个过指定点与系统屏幕平行的用户坐标系。

1、通过三点

通过三点构造用户坐标系。

图 2-8 创建坐标系：通过三点

实现方法：

（1）选择“通过三点”选项； （2）拾取三个空间点。

* 操作步骤：

1）输入坐标系原点： | 输入点作为坐标系的原点。
2）输入X轴方向参考点： | 输入点作为坐标系的X轴方向点
2）输入Y轴方向参考点： | 输入点作为坐标系的Y轴方向参考点； 点击“确定”按钮即可生成新的坐标系。

2、偏移+旋转

将指定的坐标系偏移一定距离后，绕轴旋转一定角度生成新的用户坐标系。

图 2-9 创建坐标系：偏移+旋转

实现方法：

（1）选择“偏移+旋转”选项；

（2）拾取坐标系；

（3）输入偏移距离参数。

（4）输入旋转角度。

* 操作步骤：

1）选择“偏移+旋转”： | 单击“偏移+旋转”按钮。
2）拾取坐标系： | 拾取用户坐标系，按鼠标右健默认为系统当前坐标系。
3）输入偏移量： | 输入坐标系的偏移量(DX,DY,DZ)，按Enter键
4）输入旋转角度： | 系统弹出如图2-10所示菜单，选择指定的旋转轴，并输入旋转角度，单击“确定”按钮生成新的用户坐标系。 图2-10 绕轴旋转

3、过点+旋转

将指定的坐标系偏移到指定点后，绕某一轴旋转一定角度生成新的用户坐标系。

图2-11 创建坐标系：过点+旋转

实现方法：

（1）选择“过点+旋转”选项；

（2）拾取坐标系；

（3）输入指定点。

（4）输入旋转角度。

* 操作步骤：

1）选择“过点+旋转”： | 单击“过点+旋转”按钮。
2）拾取坐标系： | 拾取用户坐标系，按鼠标右健默认为系统当前坐标系。
3）输入指定点： | 输入坐标系的原点，按Enter键
4）输入旋转角度： | 系统弹出如图2-10所示菜单，选择指定的旋转轴，并输入旋转角度，单击“确定”按钮生成新的用户坐标系。

4、绕轴旋转

将指定的坐标系绕指定轴旋转一定角度生成新的用户坐标系。

图 2-12 绕轴旋转

实现方法：

（1）选择“绕轴旋转”选项；

（2）拾取坐标系；

（3）拾取轴线起点与轴线末起点

（4）输入旋转角度

* 操作步骤：

1）选择“绕轴旋转”选项： | 单击“绕轴旋转”按钮。
2）拾取坐标系： | 拾取用户坐标系，按鼠标右健默认为系统当前坐标系。
3）拾取轴线起点： | 输入旋转轴线的起点。
4）拾取轴线末点： | 输入旋转轴线的末点。
5）输入旋转角度 | 输入旋转角度，单击“确定”按钮生成新的用户坐标系。

5、屏幕+过点

通过指定点创建一个XY平面与屏幕平行的用户坐标系。

实现方法：

（1）选择“屏幕+过点”选项；

（2）输入坐标原点

* 操作步骤：

1）选择“屏幕+过点”选项： | 单击“屏幕+过点”按钮。
2）输入点 | 该输入点作为新用户坐标系的原点

2.1.3.3 修改用户坐标系

SurfMill提供了以下四种创建用户坐标系的方法。点击“ [image] ”按钮，系统进入修改用户坐标系命令，如图2-13所示。修改用户坐标系与创建用户坐标系的过程基本相同，本文不加详述

图2-13 修改用户坐标系

通过三点 | 通过三点构造用户坐标系；
偏移+旋转 | 将指定的坐标系偏移一定距离后再绕某一轴进行旋转；
过点+旋转 | 将指定坐标系偏移到指定点，并按指定轴线旋转坐标系；
绕轴旋转 | 将指定坐标系绕某一旋转轴旋转一定角度。

2.1.3.4 删除用户坐标系

点击“ [image] ”按钮，命令提示“拾取用户坐标系”，用户只需在屏幕上拾取所需删除的用户坐标系即可。

2.1.3.5 管理用户坐标系

坐标系管理功能主要用于管理坐标系的显示与隐藏，如图2-14所示。

图2-14 用户坐标系的显示与隐藏

隐藏坐标系 | 隐藏指定的用户坐标系。
显示坐标系 | 显示指定的被隐藏的用户坐标系
隐藏全部 | 隐藏系统全部坐标系
显示全部 | 显示系统全部坐标系


曲线绘制

第三章 曲线绘制

曲线是构造三维线架模型和曲面模型的基础，SurfMill不仅提供了三维造型中的点、直线、圆弧、样条曲线等基本曲线的绘制功能，还提供了圆、椭圆、矩形、多边形、包围盒和二次曲线等一些特征图形曲线的绘制功能。另外，还可以将曲线链上的多条曲线组合为一条曲线来方便三维模型的构造。曲线的绘制菜单如图3-1所示：

图3-1 曲线绘制菜单

菜单项 | 快捷键 | 功能
点 |  | 绘制三维点。
直线 | Ctrl + Q | 绘制直线。
圆弧 | Ctrl + A | 绘制圆弧。
样条 | Ctrl + P | 绘制样条曲线。
圆 | Ctrl + L | 绘制圆。
椭圆 |  | 绘制椭圆。
矩形 | Ctrl + N | 绘制矩形。
多边形 |  | 绘制多边形。
包围盒 |  | 绘制包围盒。
二次曲线 |  | 绘制二次曲线。
曲线扫掠 |  | 将曲线沿着指定的方向拉伸至一定的距离处。

曲线的绘制是曲面造型的基础，所绘制的主要元素为点和线（直线及各种曲线），包括绘制二维曲线（平面曲线）和三维曲线（空间曲线）；空间曲线可以直接在三维空间中通过输入定义点的坐标来生成，而平面曲线总是生成在某一平面中，因此，建立二维曲线时需要首先确定一个放置平面。通常情况下，通过F9键可以切换当前坐标系的三个正交平面为二维曲线绘制时的参考平面，我们称当前坐标系所激活的参考面为当前绘图平面；除了通过修改当前坐标系和当前绘图平面来定义二维曲线的放置平面外，还可以在曲线绘制命令操作过程中，定义一个临时的绘图平面来作为本次曲线绘制时的放置平面，当本次绘制命令结束后，临时绘图面自动销毁。

图3-2 在当前绘图平面和临时绘图面中绘制的圆弧

在绘制二维曲线过程中，若没有定义临时绘图面，一般是相对于当前绘图平面进行曲线生成的，若定义了临时绘图面，则一般以此临时绘图面作为曲线的放置平面；

临时绘图面的定义方法为：点击某一曲线绘制导航工具栏中的 [image] 按钮，系统将进入定义平面子操作中，此时导航工具栏中将显示定义平面的选项组（如图3-3所示），平面定义各选项可参照<定义平面>；根据情况选择一种方法来定义空间中某一平面为临时绘图面；定义完毕后，系统将返回到曲线绘制主操作中，定义平面按钮将呈下压状态 [image] ，表示临时绘图面已经定义；点击此下压按钮可取消临时绘图面的定义。在某一绘制命令中，各子命令可以定义不同的临时绘图面。

图3-3 临时绘图面的定义选项


曲线拉伸

将一组曲线沿指定方向拉伸（平移）一定的距离，并根据需要在原始曲线和拉伸曲线的对应端点之间生成联接直线（牵引线），如图8-1所示。

图8-1 曲线拉伸

实现方法：

（1）拾取一组曲线；

（2）拾取拉伸方向。

* 操作步骤：

1） 选择菜单项： | 点击菜单“绘制→曲线拉伸”。
2）拾取曲线： | 拾取需要拉伸的一组曲线。 拾取完毕点击鼠标右键。
3）拾取拉伸方向： | 通过方向定义工具定义拉伸方向
4）点击“确定”按钮： | 系统对将生成的拉伸曲线进行预显，注意观察是否合乎要求。 确认无误后，点击鼠标右键，选择弹出菜单中的“确定命令” 菜单项或点击右边导航条上的“确定”按钮。

参数定义：

图8-2 曲线拉伸参数设置

拉伸高度 | 曲线沿拉伸方向的平移距离。 拉伸高度为负值时相当于反向拉伸。 拖动右边的滑杆可以动态改变拉伸高度。
生成牵引线 | 是否需要在原始曲线和拉伸曲线的对应端点之间生成联接直线，如图8-1所示。


绘制圆弧

3.3 绘制圆弧

圆弧绘制导航工具栏中的选项如图3-29所示。

图3-29 圆弧绘制导航工具栏选项

参数定义：

三点圆弧 | 通过任意不共线的三点来生成圆弧。
两点半径圆弧 | 通过两点来生成指定半径的圆弧。
圆心半径角度 | 以圆弧的圆心、半径、初始角和圆心角度来生成圆弧。
圆心首点末点 | 以圆弧圆心和首末点来生成圆弧。
与1曲线相切 | 通过一点来生成指定半径的且与某曲线相切的圆弧。
与2曲线相切 | 以指定的半径来生成与两条曲线均相切的圆弧。
与3曲线相切 | 生成与三条曲线均相切的圆弧。
2曲线+点 | 通过一指定点来生成与两条曲线均相切的圆弧。
1曲线+2点 | 通过两点生成与指定的曲线相切的圆弧。
1曲线+1点 | 通过一点来生成与某曲线在其上某一选择点处相切的圆弧。
【生成整圆】 | 选择此选项，则绘制出的圆弧为一整圆。
定义平面 | 定义圆弧绘制时的临时绘图面。

3.3.1 三点圆弧

通过任意不共线的三点来生成圆弧。

图3-30 三点圆弧

实现方法：

（1）启动三点圆弧命令；

（2）输入圆周上的三个点。

* 操作步骤：

1）启动三点圆弧命令： | 点击“绘制(C)”-> “圆弧(A)”菜单项，或绘制工具条中的 [image] 按钮，选择导航工具栏中的 [image] 绘制选项。
2）输入圆弧起点： | 输入圆弧的起始点，参照<点的输入>。
3）输入圆弧中间点： | 输入圆弧上的中间点，参照<点的输入>。
4）输入圆弧末点： | 输入圆弧的终止点，参照<点的输入>。
5）输入圆弧起点： | 输入下一段圆弧的起始点，或单击鼠标右键结束。可以连续绘制多个圆弧段。

说明：

1. 输入的三个点可以为空间中的任意点；若没有定义临时绘图面，则生成的圆弧将在空间中这三个点所确定的平面内；若定义了临时绘图面，则所输入的这三个点将被投影到临时绘图面上，绘制的圆弧将在这个临时绘图面内；

2. 在同一条直线上的三个点不能生成圆弧。

3.3.2 两点半径圆弧

通过两点来生成指定半径的圆弧。

图3-31 两点半径圆弧

实现方法：

（1）启动两点半径圆弧命令； （2）输入圆弧的起点和末点；

（3）输入圆弧半径； （4）拾取符合要求的圆弧段。

实现方法：

1）启动两点半径 圆弧命令： | 点击“绘制(C)”->“圆弧(A)”菜单项或绘制工具条中的 [image] 按钮，选择导航工具栏中的 [image] 绘制选项。
2）输入圆弧起点： | 输入圆弧起始点，参照<点的输入>。
3）输入圆弧末点： | 输入圆弧终止点，参照<点的输入>。
4）输入圆弧半径： | 输入圆弧半径，可单击鼠标右键接受括号中的默认值，也可直接输入新半径值。
5）选择保留曲线： | 点击要保留的圆弧段即可。 通过定义的起始点、终止点和半径可以确定两条或四条圆弧段，这时屏幕上将显示所有可选的圆弧段。如图3-32所示，其中p1和p2点为起始点和终止点，A1、A2、A3和A4为四段供选择的圆弧。
6）输入圆弧起点： | 可输入绘制下一个圆弧的起始点，或单击鼠标右键结束。可以连续绘制多条两点半径圆弧。

图3-32 选择圆弧段

说明：

1. 若没有定义临时绘图面，则相对于当前绘图平面绘制圆弧；若输入的两个点不在当前绘图平面的同一深度处，则系统首先将第二个点投影到第一个点所在的深度平面内，然后在这个平面上来生成圆弧；

2. 若定义了临时绘图面，系统会将输入的圆弧起末点投影到此临时绘图面上，然后在这个平面内绘制圆弧；

3. 系统默认的最小圆弧半径为这两点之间距离的一半，若输入的圆弧半径小于最小圆弧半径时，将在系统信息提示框中提示用户输入的半径太小无法生成圆弧。

3.3.3 圆心半径角度

以圆弧的圆心、半径、初始角和圆心角度来生成圆弧。

图3-33 圆心半径角度圆弧

实现方法：

（1）启动圆心半径角度圆弧命令；

（2）输入圆心点；

（3）输入圆弧的半径；

（4）输入圆弧起始角和圆心角。

* 操作步骤：

1）启动圆心半径角 度圆弧命令： | 点击“绘制(C)”->“圆弧(A)”菜单项或绘制工具条中的 [image] 按钮，选择导航工具栏中的 [image] 绘制选项。
2）输入圆心： | 输入圆弧的圆心点，参照<点的输入>。
3）输入圆弧半径： | 输入圆弧半径，可直接输入半径值后回车，也可以拖动“橡皮筋”用鼠标定义一点来确定。
4）输入圆弧起始角： | 输入圆弧起始角度，可直接输入角度值后回车，还可以拖动“橡皮筋”用鼠标定义一点来确定。
5）输入圆弧圆心角： | 输入圆弧圆心角，可直接输入角度值，还可以拖动“橡皮筋”用鼠标定义一点来确定。
6）输入圆心： | 输入下一条圆弧的圆心点，或单击鼠标右键结束。可连续绘制多条圆弧。

说明：

1. 若没有定义临时绘图面，生成的圆弧将平行于当前绘图平面并和输入的圆心点在同一深度平面内；此时若输入的圆弧起始角为正，则起始角为从当前绘图面的X轴的正向逆时针转过的角度（当前绘图面的X轴正向的定义参照<3.2.3 角度直线：X轴>）；同样若输入的圆心角为正角度，则圆心角为从起始角开始沿当前绘图面的逆时针方向转过的角度；若圆弧起始角或圆心角为负，则是按顺时针方向计算的；

2. 若定义了临时绘图面，则系统将输入的圆心点投影到临时绘图面内，然后在此临时绘图面内绘制圆弧；圆弧起始角和圆弧圆心角的角度值均是相对于所定义的临时绘图面而言的。

3.3.4 圆心首点末点

以圆弧圆心和首末点来生成圆弧。

图3-34 圆心和起末点圆弧

实现方法：

（1）启动圆心首末点圆弧命令；

（2）输入圆弧圆心点；

（3）输入圆弧起点和末点。

* 操作步骤：

1）启动圆心首末 点圆弧命令： | 点击“绘制(C)”->“圆弧(A)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入圆心： | 输入圆弧圆心点，参照<点的输入>。
3）输入圆弧起点： | 输入圆弧起点，参照<点的输入>。
4）输入圆弧末点： | 输入圆弧末点，参照<点的输入>。

说明：

1. 圆弧圆心点与起始点之间的距离决定了所要绘制的圆弧半径；圆弧的实际末点在圆心与输入的圆弧末点的连线上；

2. 若没有定义临时绘图面，则相对于当前绘图面绘制圆弧；此时系统会将输入的圆弧起点和末点投影到圆心点所在的深度平面内，然后在此平面内来生成圆弧；绘制出的圆弧将平行于当前绘图平面并和输入的圆弧圆心点在同一深度处；

3. 若定义了临时绘图面，系统会将输入的圆弧起点、末点和圆心点投影到这个临时绘图面内，然后在这个面内来生成圆弧。

3.3.5 与1曲线相切

通过一点来生成指定半径的且与某曲线相切的圆弧。

图3-35 与一曲线相切的圆弧

实现方法：

（1）启动与1曲线相切圆弧命令；

（2）拾取要相切的曲线；

（3）输入圆弧起点和半径；

（4）选择要保留的圆弧段。

* 操作步骤：

1）启动与1曲线 相切圆弧命令： | 点击“绘制(C)”->“圆弧(A)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）选择曲线： | 拾取一条要相切的曲线。
3）输入圆弧起点： | 输入圆弧起始点，参照<点的输入>。
4）输入圆弧半径： | 输入圆弧半径，可单击鼠标右键接受括号中的默认值，也可以输入新的半径值回车。
5）选择保留曲线： | 点击要保留的圆弧段即可。 通过定义的起点和半径可以确定多条与原曲线相切的圆弧段，这时屏幕上将显示所有可选的圆弧段。如图3-32所示，其中p1点为起始点，A1、A2、A3和A4为四段供选择的圆弧。
6）输入圆弧起点： | 输入下一条圆弧的起点；可连续绘制多条与一曲线相切圆弧，单击鼠标右键结束圆弧绘制命令。

图3-36 选择要保留的圆弧段

说明：若定义的圆弧直径小于输入的点到曲线的最小距离，则不能生成满足条件的圆弧。

3.3.6 与2曲线相切

以指定的半径来生成与两条曲线均相切的圆弧。

图3-37 两曲线的公切圆弧

实现方法：

（1）启动与2曲线相切圆弧命令；

（2）拾取两条相切曲线；

（3）输入圆弧半径。

* 操作步骤：

1）启动与2曲线 相切圆弧命令： | 点击“绘制(C)”->“圆弧(A)”菜单项，选择导航工具栏中 [image] 绘制选项。
2）拾取曲线1： | 拾取第一条相切曲线。
3）拾取曲线2： | 拾取第二条相切曲线。
4）输入圆弧半径： | 输入圆弧半径，可以单击鼠标右键接受括号中的默认值，也可直接输入新的角度值后回车。
5）拾取曲线1： | 拾取绘制下一段圆弧的第一条相切曲线，或单击鼠标右键结束。可连续绘制多个与两个曲线相切的圆弧。

说明：

1. 拾取的两条曲线须在同一平面内，生成的圆弧也将在这一平面内与这两条曲线相切，与当前绘图面和定义的临时绘图面无关；

2. 半径输入太大和太小都可能无法创建满足该条件的圆弧；

3. 两条相切曲线的拾取位置不同，可能生成不同的圆弧段。图3-38 为拾取曲线1、2的位置与图3-37 不同时，生成不同的圆弧段；生成的圆弧段为切点离两个拾取位置点最近的那段。

图3-38 曲线拾取位置不同生成的不同圆弧段( [image] 表示曲线的拾取位置)

3.3.7 与3曲线相切

生成与三条曲线均相切的圆弧。

图3-39 三曲线的公切圆弧( [image] 表示曲线的拾取位置)

实现方法：

（1）启动与3曲线相切圆弧命令；

（2）拾取圆弧要相切的三条曲线。

* 操作步骤：

1）启动与3曲线 相切圆弧命令： | 点击“绘制(C)”->“圆弧(A)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）拾取曲线1： | 拾取第一条相切曲线。
3）拾取曲线2： | 拾取第二条相切曲线。
4）拾取曲线3： | 拾取第三条相切曲线。
5）选择曲线1： | 拾取绘制下一段圆弧的相切曲线1，或单击鼠标右键结束。可连续绘制多条与三曲线相切的圆弧。

说明：

1. 拾取的这三条相切曲线须在同一平面内，生成的圆弧也将在这个平面内，与当前绘图面和所定义的临时绘图面无关；

2. 三条相切曲线的拾取位置不同可能生成不同的圆弧段，如图3-40 (a)和(b)；

图3-40 三条曲线的拾取位置不同所生成的圆弧段( [image] 表示曲线的拾取位置)

3. 三条相切曲线的拾取顺序不同，也可能生成不同的圆弧段。比较图3-41和图3-39选择的三条曲线的顺序不同所绘制出的圆弧段。

图3-41 三条曲线的公切圆弧( [image] 表示曲线的拾取位置)

4. 不能在三条平行直线之间生成与它们均相切的圆弧。

3.3.8 2曲线+点

通过一指定点来生成与两条曲线均相切的圆弧。

图3-42 2曲线+点圆弧

实现方法：

（1）启动2曲线+点圆弧命令；

（2）拾取两条相切曲线；

（3）输入圆弧通过的点。

* 操作步骤：

1）启动2曲线+点 圆弧命令： | 点击“绘制(C)”->“圆弧(A)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）拾取曲线1： | 拾取第一条相切曲线。
3）拾取曲线2： | 拾取第二条相切曲线。
4）输入圆弧末点： | 输入圆弧所通过的点，参照<点的输入>。若定义了临时绘图面，则实际输入的圆弧末点为输入的点到这个临时绘图面的投影点；
5）拾取曲线1： | 拾取绘制下一条圆弧的相切曲线1，或单击鼠标右键结束。可连续绘制多条两曲线+点圆弧。

说明：

1. 绘制出的圆弧可能与这两条曲线相切于它们的延长线上；

2. 拾取的两条曲线和输入的点需在同一平面内，这样才能生成正确的圆弧。

3.3.9 1曲线+2点

通过两点生成与指定的曲线相切的圆弧；

图3-43 1曲线+2点圆弧

实现方法：

（1）启动1曲线+2点圆弧命令；

（2）拾取圆弧相切曲线；

（3）输入圆弧所通过的两点。

* 操作步骤：

1）启动1曲线+2点 圆弧命令： | 点击“绘制(C)”->“圆弧(A)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）拾取曲线： | 拾取圆弧要相切的曲线。
3）输入圆弧中间点： | 输入圆弧所通过的一点，这个点可能为所要绘制的圆弧的中间点或起始点。
4）输入圆弧末点： | 输入圆弧的末点。
5）拾取曲线： | 拾取绘制下一条圆弧要相切的曲线，或单击鼠标右键结束。可连续绘制多条1曲线+2点圆弧。

说明：

1. 若定义了临时绘图面，则实际定义的圆弧所通过的两个点为输入的两个点到这个临时绘图面上的投影点；

2. 所拾取的相切曲线和两个定义的圆弧通过点需在同一个平面内，这样才能正确生成满足条件的圆弧；

3. 绘制出的圆弧可能与拾取的曲线相切于这个曲线的延长线上。

3.3.10 1曲线+1点

通过一点来生成与某曲线在其上某一选择点处相切的圆弧。

图3-44 1曲线 + 1点圆弧

实现方法：

（1）启动1曲线+1点圆弧命令；

（2）拾取圆弧要相切的曲线；

（3）拾取曲线上一点；

（4）输入圆弧起点。

* 操作步骤：

1）启动1曲线+1点 圆弧命令： | 点击“绘制(C)”->“圆弧(A)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）选择曲线： | 拾取圆弧要相切的曲线。
3）选择曲线上的点： | 拾取曲线上一点，要绘制的圆弧将于该曲线相切与此点。拖动鼠标，将曲线上的红色箭头滑动在指定的位置处单击鼠标左键即可；还可以通过捕捉来拾取点。
4）输入圆弧起点： | 输入圆弧起始点。
5）选择曲线： | 拾取绘制下一条圆弧要相切的曲线，或单击鼠标右键结束。可连续绘制多个1曲线 + 1点圆弧。

说明：

1. 若定义了临时绘图面，则实际定义的圆弧起点为输入的点到这个临时绘图面上的投影点；

2. 所拾取的相切曲线和所定义的圆弧起点需在同一个平面内，这样才能正确生成满足条件的圆弧。


绘制包围盒

3.9 绘制包围盒

相对于二维图形对象的包围矩形来说，三维对象的包围盒是从当前坐标系的XYZ轴三个方向上包含这个三维对象的最小六面体。如图3-65为一半球面的包围盒。

图3-69 半球面的包围盒

实现方法：

（1）启动包围盒命令；

（2）拾取三维对象；

（3）调整包围盒尺寸。

* 操作步骤：

1）启动包围盒命令： | 点击“绘制(C)”->“包围盒(B)”菜单项。
2）拾取三维对象： | 拾取一个或多个曲线和曲面对象。
3）调整包围盒尺寸： | 调整参数选项页中的+X、+Y、+Z、-X、-Y、-Z的值来调整包围盒尺寸。
4）结束命令： | 点击参数选项页中的“确定”按钮结束。

参数定义：

图3-70 导航工具栏中的包围盒参数选项页

+X、+Y、+Z | 将包围盒的左上角点分别向当前坐标系的X、Y和Z轴方向进行扩张和收缩的值。
-X、-Y、-Z | 将包围盒的右下角点分别向当前坐标系的X、Y和Z轴方向进行扩张和收缩的值。
生成中心点 | 选中此选项，则在生成对象包围盒的同时生成了包围盒的中心点。
默认值 | 点击此按钮，则包围盒尺寸恢复到没有进行扩张和收缩时的大小。

说明：包围盒尺寸是被选对象在当前坐标系下的尺寸，尺寸的调整也是相对于当前坐标系中的XY Z轴进行的。


绘制圆

3.5 绘制圆

绘制圆时导航工具栏中的绘制选项如图3-45所示：

图3-49 圆绘制导航工具栏选项

参数定义：

两点圆 | 通过两点来生成指定半径的圆。
三点圆 | 通过任意不共线的三个点来生成圆。
圆心 + 点 | 以圆的圆心和圆上一点来生成圆。
圆心 + 半径 | 以圆的圆心和及半径来生成圆。
圆心 + 直径 | 以圆的圆心和及直径来生成圆。
定义平面 | 定义绘制圆时的临时绘图面。

3.5.1 两点圆

通过两点来生成指定半径的圆。

图3-50 两点圆

实现方法：

（1）启动两点圆绘制命令；

（2）输入圆周上两点。

* 操作步骤：

1) 启动两点圆绘制命令

点击“绘制(C)”->“圆(C)”菜单项，选择导航工具栏中的 [image] 绘制选项。

2) 输入起点：

输入圆上第一点，参照<2.3 点的输入>。

3) 输入末点：

输入圆上第二点, 参照<2.3 点的输入>。

4) 输入起点：

输入下一个圆上的第一点，或单击鼠标右键结束。可连续绘制多个两点圆。

说明：

1. 若没有定义临时绘图平面，则在当前绘图平面及其平行平面内绘制圆；此时若输入的两个点不在当前绘图平面的同一深度处，则系统首先将第二个点投影到第一个点所在的深度平面内，然后再在这个平面内生成圆；

2. 若定义了临时绘图平面，则系统会将输入的两个点投影到这个临时绘图面上，然后再在这个平面内来生成圆。

3.5.2 三点圆

通过任意不共线的三点来生成圆。

图3-51 三点圆

实现方法：

（1）启动三点圆绘制命令； （2）输入圆周上三点。

* 操作步骤：

1）启动三点圆 绘制命令： | 点击“绘制(C)”->“圆(C)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入起点： | 输入圆的起始点，参照<点的输入>。
3）输入中间点： | 输入圆周上第二点，参照<点的输入>。
4）输入末点： | 输入圆周上第三点，参照<点的输入>。
5）输入起点： | 输入下一个圆上的第一点，或单击鼠标右键结束。可连续绘制多个三点圆。

说明：

1. 输入的三个点可以为空间中的任意点；若没有定义圆的临时绘图平面，则绘制出的圆将在空间中由这三个点所确定的平面内；

2. 若定义了圆的临时绘图平面，则系统会将拾取的这三个点投影到这个临时绘图面上，然后再在这个平面内绘制圆；

3. 定义的三个点不能在同一条直线上，否则不能生成圆。

3.5.3 圆心+点

已知圆心和圆周上一点绘制圆。

图3-52 圆心+点圆

实现方法：

（1）启动圆心+点圆绘制命令；

（2）输入圆心点和输入圆周上一点。

* 操作步骤：

1) 启动圆心+点圆绘制命令

点击“绘制(C)”->“圆(C)”菜单项，选择导航工具栏中的 [image] 绘制选项。

2) 输入圆心：

输入圆的圆心点，参照<2.3 点的输入>。

3) 输入起点：

输入圆周上一点，参照<2.3 点的输入>。

4) 输入圆心：

输入下一个圆的圆心点，或单击鼠标右键结束。

可连续绘制多个圆心半径圆。

说明：

1. 若没有定义临时绘图平面，则在当前绘图平面及其平行平面内生成圆；此时若输入的圆心点和圆周上的点不在当前绘图平面的同一深度处，则系统将输入的圆周上点投影到圆心点所在的深度平面内，并在这个深度平面内生成圆；

2. 若定义了临时绘图平面，则系统会将输入的圆心点和圆周上点投影到这个临时绘图平面上，然后再在这个平面内生成圆。

3.5.4 圆心+半径

以圆的圆心和及半径来生成圆。

图3-53 圆心半径圆

实现方法：

（1）启动圆心半径圆绘制命令；

（2）输入圆心；

（3）输入半径。

* 操作步骤：

1）启动圆心半径 圆绘制命令： | 点击“绘制(C)”->“圆(C)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入圆心： | 输入圆的圆心点，参照<点的输入>。
3）输入圆的半径： | 输入圆的半径，可直接输入半径值后回车，或拖动“橡皮筋”用鼠标定义圆周上一点来确定。
4）输入圆心： | 输入下一个圆的圆心点，或单击鼠标右键结束。可连续绘制多个圆心半径圆。

说明：

1. 若没有定义临时绘图面，则在平行于当前绘图平面的圆心点所在得深度平面内生成圆；

2. 若定义了临时绘图面，则系统会将输入的圆心点投影到这个临时绘图面上，然后再在这个平面内来生成圆。

3.5.5 圆心+直径

以圆的圆心和及直径来生成圆。

图3-54 圆心直径圆

实现方法：

（1）启动圆心直径圆绘制命令；

（2）输入圆心；

（3）输入直径。

* 操作步骤：

1）启动圆心直 径圆绘制命令： | 点击“绘制(C)”->“圆(C)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入圆心： | 输入圆的圆心点，参照<点的输入>。
3）输入直径： | 输入圆的直径，可直接输入直径值后回车，或拖动“橡皮筋”用鼠标定义圆周上一点来确定。
4）输入圆心： | 输入下一个圆的圆心点，或单击鼠标右键结束。可连续绘制多个圆心直径圆。

说明：

1. 若没有定义临时绘图平面，则在平行于当前绘图平面的圆心点所在的深度平面内来生成圆；

2. 若定义了临时绘图平面，则系统会将输入的圆心点投影到这个临时绘图面上，然后再在这个平面内生成圆。


绘制二次曲线

3.10 绘制二次曲线

绘制二次曲线时的导航工具栏选项如图3-71：

图3-71 二次曲线导航工具栏选项

参数定义：

抛物线：焦点，方向 | 通过定义抛物线的焦点和方向来绘制抛物线。
抛物线：顶点，焦点 | 通过定义抛物线的顶点和焦点来绘制抛物线。
二次曲线 | 通过定义二次曲线的首末点、顶点和曲率点这四个点绘制通用的二次曲线。
定义平面 | 定义二次曲线绘制时的临时绘图面。

3.10.1 抛物线: 焦点，方向

通过定义抛物线的焦点和方向来绘制抛物线。

图3-72 抛物线: 焦点,方向

实现方法：

（1）启动焦点方向抛物线绘制命令；

（2）输入抛物线的焦点和方向点；

（3）输入抛物线的一个端点。

* 操作步骤：

1）启动焦点方向抛 物线绘制命令： | 点击“绘制(C)”->“二次曲线(I)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入抛物线的焦点： | 输入抛物线焦点，参照<点的输入>。
3）输入抛物线的方向点： | 输入抛物线方向点，参照<点的输入>。
4）输入抛物线的端点： | 输入抛物线的一个端点，参照<点的输入>。
5）输入抛物线的焦点： | 输入下一个抛物线的焦点，或单击鼠标右键结束。可连续绘制多个抛物线。

说明：

1. 若没有定义临时绘图面，则输入的抛物线的焦点、方向点和端点均须在当前绘图平面的同一深度平面内，否则不能生成抛物线；

2. 若定义了临时绘图面，则系统会将输入抛物线的焦点、方向点和端点均投影到这个临时绘图面上，然后再在此平面内生成抛物线；

3. 输入的方向点与焦点决定了抛物线对称轴的方向。

3.10.2 抛物线: 顶点，焦点

通过定义抛物线的顶点和焦点来绘制抛物线。

图3-73 抛物线

实现方法：

（1）启动顶点和焦点抛物线绘制命令；

（2）输入抛物线的顶点和焦点；

（3）输入抛物线的一个端点。

* 操作步骤：

1）启动顶点和焦点抛物线绘制命令： | 点击“绘制(C)”->“二次曲线(I)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入抛物线的顶点： | 输入抛物线的顶点，参照<点的输入>。
3）输入抛物线的焦点： | 输入抛物线的焦点，参照<点的输入>。
4）输入抛物线的端点： | 输入抛物线的一个端点，参照<点的输入>。
5）输入抛物线的顶点： | 输入下一个抛物线的顶点，或单击鼠标右键结束。可连续绘制多条抛物线。

说明：

1. 若没有定义临时绘图面，则输入的抛物线的顶点、焦点和端点均须在当前绘图平面的同一深度平面内，否则不能生成抛物线；

2. 若定义了临时绘图面，则系统会将输入抛物线的顶点、焦点和端点均投影到这个临时绘图面上，然后再在此平面内生成抛物线；

3.10.3 二次曲线

通过定义二次曲线的首末点、顶点和曲率点这四个点来绘制通用的二次曲线。

二次曲线是用一个平面切割圆锥体而得到的曲线，包括椭圆、抛物线和双曲线，曲线的类型取决于切割圆锥体的平面与圆锥体底平面形成的夹角，如图3-74所示。本绘制选项用来绘制通用的二次曲线，如图3-75，可以输入不同的曲率点来绘制椭圆(曲率点1)、抛物线（曲率点2）和双曲线（曲率点3）。

图3-74 用平面切割圆锥体得到的二次曲线

图3-75 二次曲线

实现方法：

（1）启动二次曲线绘制命令；

（2）输入二次曲线的起点、末点；

（3）输入二次曲线的顶点和曲率点。

* 操作步骤：

1）启动二次曲线绘制命令： | 点击“绘制(C)”->“二次曲线(I)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入二次曲线的起点： | 输入二次曲线的起点，参照<点的输入>。
3）输入二次曲线的末点： | 输入二次曲线的末点，参照<点的输入>。
4）输入二次曲线的顶点： | 输入二次曲线的顶点，参照<点的输入>。
5）输入二次曲线的曲率点： | 输入二次曲线的曲率点，参照<点的输入>。

说明：

1. 若没有定义临时绘图面，则输入的二次曲线的起点、末点、顶点和曲率点均须在当前绘图平面的同一深度平面内，否则不能生成抛物线；

2. 若定义了临时绘图面，则系统会将输入二次曲线的起点、末点、顶点和曲率点均投影到这个临时绘图面上，然后再在此平面内生成抛物线；

3. 输入的曲率点须落在顶点与起末点连线夹角范围内部，否则不能生成二次曲线。


绘制椭圆

3.6 绘制椭圆

椭圆绘制时，导航工具栏选项如图3-51所示。

图3-55 椭圆绘制导航工具栏选项

参数定义：

两点椭圆 | 通过定义椭圆的包围矩形的两个角点来绘制椭圆。
圆心半径 | 已知圆心和椭圆两个轴的半径绘制椭圆。
直径 | 已知椭圆一个轴直径的两个端点和另外一点绘制椭圆。
焦点 | 已知椭圆的两个焦点和圆周上一点绘制椭圆。
自定义 | 通过自定义椭圆有关参数来绘制椭圆弧。
定义平面 | 定义椭圆绘制时的临时绘图面；

3.6.1 两点椭圆

通过定义椭圆的包围矩形的两个角点来绘制椭圆。

图3-56 两点椭圆

实现方法：

（1）启动两点椭圆绘制命令；

（2）输入椭圆包围矩形的两个角点。

* 操作步骤：

1）启动两点椭 圆绘制命令： | 点击“绘制(C)”->“椭圆(E)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入第一角点： | 输入包围矩形的第一个角点，参照<点的输入>。
3）输入第二角点： | 输入包围矩形的第二个角点，参照<点的输入>。
4）输入第一角点： | 输入下一个椭圆的包围矩形的第一个角点，或单击右键结束。可连续绘制多个两点椭圆。

说明：

1. 若没有定义椭圆绘制的临时绘图面，则系统会将输入的两角点投影到当前绘图面的所设定的深度平面内，并在这个深度平面内绘制出椭圆；

2. 若定义了椭圆绘制的临时绘图面，则系统将输入的两角点投影到这个临时绘图面上，然后在这个平面内生成椭圆；

3. 椭圆的圆心点为连接这两个角点的直线段的中点，椭圆的两个轴的直径分别为由这两个角点所定义的矩形的长和宽。

3.6.2 圆心半径

已知圆心和椭圆两个轴的半径绘制椭圆。

图3-57 圆心两半径椭圆

实现方法：

（1）启动圆心两半径椭圆绘制命令；

（2）输入椭圆圆心；

（3）输入椭圆第一个半径；

（4）输入椭圆第二个半径。

* 操作步骤：

1）启动圆心两半 径椭圆绘制命令： | 点击“绘制(C)”->“椭圆(E)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入椭圆圆心： | 输入椭圆圆心，参照<点的输入>。
3椭圆半径1： | 输入椭圆第一个轴的半径，可以直接输入直径值，也可以通过拖动“橡皮筋”定义一点来定义椭圆的半径。
4椭圆半径2： | 输入椭圆第二个轴的半径，可以直接输入直径值，也可以通过拖动“橡皮筋”定义一点来定义椭圆的半径。
5）输入椭圆圆心： | 输入下一个椭圆的圆心点，或单击右键结束。可以连续绘制多个圆心两半径椭圆。

说明：

1. 若没有定义椭圆绘制的临时绘图面，则系统将在平行与当前绘图平面并且在输入的圆心点所在的深度平面内生成椭圆；

2. 若定义了椭圆绘制的临时绘图面，则系统会将输入的圆心点投影到这个临时绘图平面上，然后在这个平面内生成椭圆。

3.6.3 直径

已知椭圆一个轴的两个端点和另外一点绘制椭圆。

图3-58 直径椭圆

实现方法：

（1）启动直径椭圆绘制命令；

（2）输入椭圆直径上两点；

（3）输入第三点。

* 操作步骤：

1）启动直径椭圆 绘制命令： | 点击“绘制(C)”->“椭圆(E)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入第一点： | 输入椭圆的一个直径轴的端点1，参照<点的输入>。
3）输入第二点： | 输入椭圆的一个直径轴的端点2，参照<点的输入>。
4）输入第三点： | 输入第三点，参照<点的输入>。
5）输入第一点： | 输入下一个椭圆的一个直径轴的端点1，或单击鼠标右键结束。可连续绘制多个直径椭圆。

说明：

1. 输入的两个直径点确定了椭圆的圆心、半径1和椭圆的倾斜角度，输入的第三个点到第一个直径轴的距离确定了椭圆的另一个轴的半径；

2. 若没有定义椭圆绘制的临时绘图面，则系统将输入的这三个点均投影到当前绘图平面的所设定的深度平面内，然后再在该平面内生成椭圆；

3. 若定义了椭圆绘制的临时绘图面，则系统会将输入的这三个点都投影到这个临时绘图平面上，并在这个平面内生成椭圆。

3.6.4 焦点

已知椭圆的两个焦点和圆周上一点绘制椭圆。

图3-59 焦点椭圆

实现方法：

（1）启动焦点椭圆绘制命令；

（2）输入椭圆的两个焦点；

（3）输入椭圆圆周上一点。

* 操作步骤：

1）启动焦点椭圆 绘制命令： | 点击“绘制(C)”->“椭圆(E)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入第一点： | 输入椭圆的第一个焦点，参照<点的输入>。
3）输入第二点： | 输入椭圆的的第二个焦点，参照<点的输入>。
4）输入第三点： | 输入椭圆圆周上一点，参照<点的输入>。
5）输入第一点： | 输入下一个椭圆的第一个焦点，或单击鼠标右键结束。可连续绘制多个焦点椭圆。

说明：

1. 若没有定义椭圆绘制的临时绘图面，则系统将输入的这三个点均投影到当前绘图平面的所设定的深度平面内，然后再在该平面内生成椭圆；

2. 若定义了椭圆绘制的临时绘图面，则系统会将输入的这三个点都投影到这个临时绘图面上，并在这个平面内生成椭圆；

3.6.5 自定义

通过自定义椭圆有关参数来绘制椭圆弧。

图3-60 自定义的椭圆弧

实现方法：

（1）启动自定义椭圆弧绘制命令；

（2）在对话框中输入椭圆弧的有关参数；

（3）输入椭圆圆心点。

* 操作步骤：

1）启动自定义椭 圆弧绘制命令： | 点击“绘制(C)”->“椭圆(E)”菜单项，点击导航工具栏中的 [image] 按钮。
2）在对话框中输入椭 圆弧的有关参数： | 在弹出的椭圆参数对话框中输入椭圆弧的两个半径、起始和终止角度以及与X轴的夹角等参数，点击“确定”按钮。如图3-61所示。
3）输入椭圆圆心点： | 输入椭圆圆心点。

图3-61 椭圆参数对话框

参数定义：

半径1 | 椭圆长轴半径。
半径2 | 椭圆短轴半径。
起始角度 | 椭圆弧的起始角度。
终止角度 | 椭圆弧的终止角度。
与X轴角度 | 椭圆的长轴与X轴的角度，即椭圆倾斜角度。

说明：

1. 若没有定义椭圆绘制的临时绘图面，则系统将在平行与当前绘图平面并在椭圆圆心点所在的深度平面内来生成椭圆；

2. 若定义了椭圆绘制的临时绘图面，则系统会将输入的圆心点投影到这个临时绘图面上，然后在这个平面内来生成椭圆。


绘制直线

3.2 绘制直线

直线绘制时导航工具栏中的选项如图3-9所示。

图3-9 直线绘制导航工具栏选项

参数定义：

两点直线 | 已知两点绘制一条直线。
正交直线 | 过一点做沿正交方向上的水平或竖直线。
角度直线： X 轴 | 通过一点绘制与X轴成一定角度的直线。
角度直线：参考点 | 过一点做一条与某一参考轴成一定角度的直线。
角平分线 | 绘制两条互成角度的直线的角度等分线。
平行线：距离 | 绘制在一定距离处和已知直线平行的直线。
平行线：过点 | 过一点绘制与一已知直线平行的直线。
平行线：相切 | 绘制与一已知直线平行且与一圆弧或样条曲线相切的直线。
与 2 曲线相切 | 绘制一与两条曲线均相切的直线。
与 2 曲线垂直 | 绘制一与两条曲线均垂直的直线。
与 1 相切1垂直 | 绘制一与一条曲线相切并与另外一条曲线垂直的直线。
与 1 曲线相切 | 过一点绘制与已知曲线相切的一条直线。
与 1 曲线垂直 | 过一点绘制一条与已知曲线垂直的直线。
与 1 曲面垂直 | 过一点绘制一条与已知曲面垂直的直线。
定义平面 | 定义直线绘制时的临时绘图面。

3.2.1 两点直线

已知两点绘制一条直线。

图3-10 两点直线

实现方法：

（1）启动两点直线命令；

（2）输入直线起点；

（3）输入直线末点。

* 操作步骤：

1）启动两点直线命令： | 点击“绘制(C)”-> “直线(L)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入直线起点： | 输入直线起始点，参照<点的输入>。
3）输入直线末点： | 输入直线的末点，参照<点的输入>。可定义多个点来绘制连续的直线段，单击右键结束。

说明：

1. 可以打开绘图的正交模式来绘制水平或垂直的直线；

2. 若没有定义直线绘制临时绘图面，则可以在3D空间中绘制三维直线；

3. 若定义了直线绘制临时绘图面，系统将输入的点均投影到这个临时绘图面上，然后再在这个面内生成二维平面直线。

3.2.2 正交直线

过一点做沿正交方向上的水平或竖直线。

图3-11 正交直线

实现方法：

（1）启动角度直线命令； （2）输入直线起点；（3）输入直线长度；

* 操作步骤：

1）启动角度直线命令： | 点击“绘制(C)”-> “直线(L)”菜单项，在导航工具栏中选择 [image] 绘制选项；
2）输入直线起点： | 输入直线起始点，参照<点的输入>；
4）输入直线长度： | 可以直接输入正交直线长度，也可以拖动在当前绘图面正交方向上的“橡皮筋”来用鼠标拾取另外一点来确定直线的长度；
5）输入直线起点： | 输入下一条正交直线的起点，或单击鼠标右键结束直线绘制命令。可连续绘制多条平行于当前绘图面两正交方向上的直线。

说明：

1. 若没有定义直线绘制临时绘图面，正交方向为当前绘图平面的正交方向，绘制出的直线平行于当前绘图平面；

2. 若定义了直线绘制临时绘图面，系统将把输入的直线起点投影到这个平面内，正交方向为这个临时绘图面内的正交方向，然后再在其内绘制出的正交直线。

3.2.3 角度直线: X轴

通过一点绘制与X轴成一定角度的直线。

图3-12 与X轴成一角度直线

实现方法：

（1）启动角度直线：X轴命令； （2）输入直线起点；

（3）输入直线角度； （4）输入直线长度。

* 操作步骤：

1）启动角度直线命令： | 点击“绘制(C)”-> “直线(L)”菜单项，在导航工具栏中选择 [image] 绘制选项；
2）输入直线起点： | 输入直线起始点，参照<点的输入>。
3）输入角度： | 输入直线与当前绘图面的X轴方向所成的角度值；可以单击鼠标右键接受括号中的默认值，也可以直接输入角度值后回车，还可以通过移动鼠标定义另外一点来确定直线的角度方向值。
4）输入直线长度： | 可以直接输入直线长度，也可以拖动“橡皮筋”在角度方向上定义另外一点来确定直线的长度；直线的长度为相对于起始点“橡皮筋”方向上的长度。
5）输入直线起点： | 输入下一个角度直线的起点，或单击鼠标右键结束。可连续绘制多条角度直线。

说明：

1. 若没有定义直线绘制平面，绘制出的角度直线平行于当前绘图平面，并且和输入的直线起点在同一深度平面内。此时角度是从当前绘图平面的X轴正向开始沿着逆时针方向计算的；绘图平面的X轴正向的定义如下：

Ø 若当前绘图面为XOY面，X轴正向为当前坐标系的X轴正向，如图3-13(a)；

Ø 若当前绘图面为XOZ面，X轴正向为当前坐标系的X轴正向，如图3-13(b)；

Ø 若当前绘图面为YOZ面，X轴正向为当前坐标系的Y轴正向，如图3-13(c).

图3-13 X轴正向的定义

2. 若定义了直线绘制平面，要绘制角度直线，建议采用<3.2.4角度直线：参考轴>的方法来绘制；

3. 当确定了直线的角度后，移动鼠标，此时屏幕中的“橡皮筋”将被限制在该角度或该角度加180°方向上；若输入的直线长度为负值，则实际的角度值输入的角度加180°。

3.2.4 角度直线：参考点

过一点做一条与某一参考轴成一定角度的直线。

图3-14 角度直线：参考轴

实现方法：

（1）启动角度直线命令； （2）输入参考轴的起点和方向点；

（3）输入角度直线的起点； （4）输入与参考轴所成的角度；

（5）输入角度直线长度； （6）选择需保留的直线。

* 操作步骤：

1）启动角度直线命令： | 点击“绘制(C)”-> “直线(L)”菜单项，在导航工具栏中选择 [image] 绘制选项；
2）输入轴线起点： | 输入参考轴的起点，参照<点的输入>；
3）输入轴线方向点： | 输入参考轴的方向点，参照<点的输入>；
4）输入直线起点： | 输入角度直线的起点，参照<点的输入>；
5）输入角度： | 输入直线与所定义的参考轴所成的角度值；可单击鼠标右键接受括号中的默认值，也可以重新输入一角度值后回车；
6）输入直线长度： | 输入角度直线的长度；可单鼠标右键接受括号中的默认值，也可以重新输入一长度值后回车；
7）拾取需保留的直线： | 屏幕上将显示出在参考轴方向两侧均与参考轴成一定角度的两条角度直线，点击要保留的某一侧直线即可；
8）输入轴线起点： | 输入绘制下一条角度直线的参考轴的起点；可连续绘制多条角度直线，或单击鼠标右键结束直线绘制命令。

说明：

1. 若没有定义直线绘制临时绘图面，则相对于当前绘图平面生成角度直线；输入的角度是当前绘图平面内直线与参考轴之间的夹角；

2. 若定义了临时绘图面，则系统将输入的参考轴的起点、方向点和直线起点均投影到这个临时绘图面上，输入的角度为在这个绘图面内与参考轴所成的角度，生成的直线也在这个绘图面内。

3.2.5 角平分线

绘制两条互成角度的直线的角度等分线。

图3-15 角度等分线 (╳表示曲线的拾取位置)

实现方法：

（1）启动角平分线命令；

（2）分别拾取两条直线；

（3）输入角平分数；

* 操作步骤：

1）启动角平分线命令： | 点击“绘制(C)”-> “直线(L)”菜单项，在导航工具栏中选择 [image] 绘制选项。
2）选择直线1： | 拾取第一条直线，注意直线的拾取位置；
3）选择直线2： | 拾取第二条直线，注意直线的拾取位置；
4）输入角平分数： | 输入将选择的两曲线夹角进行等分的数目；可单击鼠标右键接受括号中的默认值，也可以输入新的等分数后回车；
5）选择直线1： | 拾取绘制下一条角度等分线时的第一条直线，或单击鼠标右键结束直线绘制命令。可连续绘制多条曲线间的角平分线。

说明：

1. 两直线的角平分线的位置与当前绘图面和所定义的直线绘制临时绘图面无关；

2. 两相交直线间有四个夹角，因此将会有两组不同夹角处的角平分线，这与两条曲线的拾取位置有关系，如图3-16中的所示的两组角平分线。

图3-16 曲线拾取位置对角平分线的影响

3.2.6 平行线：距离

绘制在一定距离处和已知直线平行的直线。

图3-17 距离平行线

实现方法：

（1）启动距离平行线命令；

（2）拾取直线；

（3）选择偏移方向；

（4）输入偏移距离。

* 操作步骤：

1）启动距离平行线命令： | 点击“绘制(C)”->“直线(L)”菜单项，在导航工具栏中选择 [image] 绘制选项。
2）拾取直线： | 拾取一条已知的直线。
3）拾取偏移方向： | 选择直线偏移方向，在直线的某一侧单击鼠标左键即可。
4）输入等距距离： | 可以单击鼠标右键接受括号中的默认值，或直接输入新的距离值。
5）拾取直线： | 拾取一条直线来绘制下一条距离平行线，或单击右键结束。可以连续绘制多条距离平行线。

说明：

1. 若没有定义临时绘图面，则平行线是相对于当前绘图平面生成的，它是沿着平行于当前绘图平面的方向在直线的某一侧进行偏移等距的；

2. 若定义了临时绘图面，则平行线是相对于这个临时绘图面生成的，它是沿着平行于这个绘图面的方向在直线的某一侧进行偏移等距的；

3. 绘制出的平行线和已知直线等长度。

3.2.7 平行线：过点

过一点绘制与一已知直线平行的直线。

图3-18 过一点和已知直线平行的直线

实现方法：

（1）启动过点平行线命令；

（2）拾取已知直线；

（3）输入平行线通过的点。

* 操作步骤：

1）点击菜单项和选择 导航工具栏选项： | 点击“绘制(C)”-> “直线(L)”菜单项，在导航工具栏中选择 [image] 绘制选项。
2）拾取直线： | 拾取一条已知的直线。
3）输入点： | 输入平行线要通过的点，参照<点的输入>。
4）拾取直线： | 拾取一条直线开始绘制下一条过点平行线，或单击鼠标右键结束。可连续绘制多条过点平行线。

说明：

1. 若定义了临时绘图面，则系统将输入的平行线所通过的点投影到这个临时绘图面上，然后再通过这个投影点来生成原曲线的平行线；

2. 绘制出的平行线与已知直线等长度。

3.2.8 平行线：相切

绘制与一已知直线平行且与一圆弧或样条曲线相切的直线。

图3-19 与一已知直线平行并与一圆弧相切的直线 ( [image] 表示圆弧的拾取位置)

实现方法：

（1）启动相切平行线命令；

（2）拾取直线；

（3）拾取圆弧或样条曲线。

* 操作步骤：

1）启动相切平行线命令： | 点击“绘制(C)”-> “直线(L)”菜单项，在导航工具栏中选择 [image] 绘制选项。
2）拾取直线： | 拾取一已知直线。
3）拾取圆弧或者样 条曲线： | 拾取一条要相切的圆弧或样条曲线。
4）拾取直线： | 选择一条直线开始绘制下一条平行线，或单击鼠标右键结束。可以连续绘制多条相切平行线。

说明：

1. 拾取的已知直线和圆弧或样条曲线必须在同一平面内；

2. 与一直线平行且与一圆弧或样条曲线相切的直线可能有多条，系统将生成切点与圆弧或样条曲线的拾取位置最近的那条平行直线；

3. 绘制出的平行直线与已知直线等长度，并且可能和圆弧或样条曲线相切在它们的延长线上。

3.2.9 与2曲线相切

绘制一条与两条已知曲线均相切的直线。

图3-20 两曲线的公切线 ( [image] 表示曲线的拾取位置)

实现方法：

（1）启动与2曲线相切命令； （2）拾取相切曲线1； （3）拾取相切曲线2。

* 操作步骤：

1）启动与2曲线相切命令： | 点击“绘制(C)”-> “直线(L)”菜单项，选择导航工具栏中的 [image] 选项。
2）拾取圆弧或样条曲线1： | 拾取相切圆弧或样条曲线1。
3）拾取圆弧或样条曲线2： | 拾取相切圆弧或样条曲线2。
4）拾取圆弧或样条曲线1： | 拾取绘制下一条两曲线切线时的曲线1，或单击鼠标右键结束。可以连续绘制多条两曲线切线。

说明：

1. 拾取的两条圆弧或样条曲线须在同一个平面内；绘制出的两曲线切线的位置与当前绘图平面和所定义的临时绘图面无关；

2. 两个圆弧或样条曲线之间的切线可能有多条，系统将生成切点与它们的拾取位置最近的那条切线（如图3-20）。注意：切线可能与圆弧或样条曲线相切于其延长线上。

3.2.10 与2曲线垂直

绘制一与两条曲线均垂直的直线。

图3-21 两曲线的公垂线

实现方法：

（1）启动与2曲线垂直直线命令； （2）分别拾取曲线要垂直的两条曲线。

* 操作步骤：

1）启动与2曲线 垂直直线命令： | 点击“绘制(C)”-> “直线(L)”菜单项，选择导航工具栏中的 [image] 选项。
2）拾取要垂直的曲线1： | 拾取要垂直的第一条曲线；
3）拾取要垂直的曲线2： | 拾取要垂直的第二条曲线；
4）拾取曲线1： | 拾取一条曲线来开始绘制下一条两曲线垂线，或单击鼠标右键结束。可连续绘制多条两曲线垂线。

说明：

1. 拾取的两条曲线必须在同一个平面内，若在平面内二者没有公垂线，则在两曲线的交点处生成的垂线为交点处这个平面的法垂线；绘制出的两曲线公垂线的位置与当前绘图平面和所定义的临时绘图面无关；

2. 与两曲线均垂直的直线可能有多条，系统将绘制出垂足与两条曲线的拾取位置最近的那一条垂线。

3.2.11 与1相切1垂直

绘制一与一条曲线相切并与另外一条曲线垂直的直线。

图3-22 两曲线间的切垂线 ( [image] 表示曲线的拾取位置)

实现方法：

（1）启动与1相切与1垂直直线命令；

（2）拾取要相切的曲线；

（3）拾取要垂直的曲线。

* 操作步骤：

1）启动与1相切与1 垂直直线命令： | 点击“绘制(C)”-> “直线(L)”菜单项，点击导航工具栏中的 [image] 选项。
2）拾取要相切的曲线： | 拾取要相切的圆弧或样条曲线。
3）拾取要垂直的曲线 | 拾取要垂直的曲线，可以是直线、圆弧或样条曲线。
4）拾取要相切的曲线： | 拾取绘制下一条直线时要相切的圆弧或样条曲线，或单击鼠标右键结束。可连续绘制多条与一曲线相切并与另一曲线垂直的直线。

说明：

1. 拾取的两条曲线必须在同一个平面内，否则无法生成直线；生成的两曲线的切垂线的位置与当前绘图平面和所定义的直线绘制临时绘图面无关；

2. 和一曲线相切并与另一曲线垂直的直线可能有多条，系统将生成切点和垂足点与这两条曲线的拾取位置最近的那一条直线。如图3-22与图3-23所示，要相切曲线的拾取位置不同，所绘制出的直线不同。

图3-23 两曲线间的切垂线( [image] 表示曲线的拾取位置)

3.2.12 与1曲线相切

过曲线上一点做该曲线的切线。

图3-24 曲线切线

实现方法：

（1）启动与1曲线相切命令；

（2）拾取圆弧或样条曲线；

（3）输入曲线上一点；

（4）输入曲线切线长度；

（5）拾取要保留的曲线某一方向切线。

* 操作步骤：

1）启动与1曲线相切命令： | 点击“绘制(C)”-> “直线(L)”菜单项，选择导航工具栏项中的 [image] 选项。
2）拾取圆弧或样条曲线： | 拾取要相切的圆弧或样条曲线。
3）输入点： | 输入曲线切线要通过的曲线上一点；可用鼠标拾取该曲线上一点，也可以直接输入一点坐标值后回车；若定义了临时绘图面，则实际输入的点为该点到这个临时绘图面的投影点；若输入的点不在已知曲线上，则曲线上点为该输入点到该曲线上最近的那个切点，如图3-25；
4）输入直线长度： | 输入曲线上一点切线的长度；可单击鼠标右键接受括号中的默认值，也可以输入新值后回车即可；
5）拾取需保留的直线： | 此时屏幕上显示出曲线上该点在曲线两侧的切线；用鼠标拾取需要保留的某一侧切线即可；
6）输入点： | 输入下一条切线所通过的曲线上点；可连续绘制多条已知曲线的切线，或单击鼠标右键结束直线绘制命令。

图3-25 输入的点不在曲线上实际得到的曲线上点

3.2.13 与1曲线垂直

过曲线上一点绘制一条与该曲线垂直的直线。

图3-26 与一曲线垂直的直线

实现方法：

（1）启动与1曲线垂直直线命令；

（2）拾取要垂直的曲线；

（3）输入垂线通过的曲线上点；

（4）输入垂线长度；

（5）拾取要保留的曲线某一侧的垂线。

* 操作步骤：

1）启动与1曲线垂直直线命令： | 点击“绘制(C)”-> “直线(L)”菜单项，选择导航工具栏中的 [image] 选项。
2）拾取曲线： | 拾取要垂直的曲线。
3）输入点： | 输入垂线所通过的曲线上点；可以直接输入点坐标，也可以用鼠标拾取曲线上一点；若拾取或输入的点不在所选择的曲线上，则实际的点为该点到曲线上的投影点，如图3-27所示；
4）输入直线长度： | 输入曲线上一点的垂线长度；可单击鼠标右键接受括号中的默认值，也可以输入新值后回车即可；
5）拾取需保留的直线： | 此时屏幕上显示出曲线上该点在曲线两侧的垂线；用户用鼠标拾取需要保留的某一侧垂线即可；
6）输入点： | 输入下一条垂线所通过的曲线上点；可连续绘制多条已知曲线的垂线，或单击鼠标右键结束直线绘制命令。

图3-27 输入的点不在曲线上实际得到的曲线上点

说明：

由于3D空间中，在不同的方向上过曲线上一点有不同方向的垂线；若没有定义临时绘图面，此时曲线的垂线是相对于当前绘图平面生成的，即在平行于当前绘图平面的方向上过曲线上某一点来生成已知曲线的垂线；若定义了临时绘图面，则相对于此临时绘图面来生成曲线的垂线。

3.2.14 与1曲面垂直

过曲面上一点绘制该曲面的垂线。

图3-28 与1曲面垂直的直线

实现方法：

（1）启动与1曲面垂直命令；

（2）拾取要垂直的曲面；

（3）输入垂线通过的曲面上点；

（4）输入垂线长度；

（5）拾取需保留的曲面某一侧垂线。

* 操作步骤：

1）启动与1曲面 垂直命令： | 点击“绘制(C)”-> “直线(L)”菜单项，选择导航工具栏中的 [image] 选项。
2）拾取曲面： | 拾取曲面对象。
3）输入点： | 输入曲面上垂线所通过的点；可直接输入点坐标，也可以打开曲面点、曲面边界点和曲面交叉点来用鼠标拾取曲面上一点。注意拾取或输入的点最好为曲面上点，若点离曲面较近，则实际取曲面上该点到曲面的最近点；
4）输入曲线长度： | 输入过曲面上一点的曲面垂线的长度；可单击鼠标右键接受括号中的默认值，也可以输入新值后回车即可；
5）拾取需保留的直线： | 此时屏幕上显示出过曲面上该点在曲面两侧的垂线；用户用鼠标拾取需要保留的某一侧曲面垂线即可；
6）输入点： | 输入下一条曲面垂线所通过的曲面上点；可连续绘制多条曲面垂线，或单击鼠标右键结束直线绘制命令。


绘制点

3.1 绘制点

点绘制时导航工具栏中的选项如图3-2所示。

图3-4 导航工具栏中点绘制选项

参数定义：

位置点 | 在某一特定位置上绘制点。
曲线上点 | 在某条曲线上的绘制曲线上点。
曲面上点 | 在某一曲面上绘制曲面上的点。
等分点 | 绘制某一曲线的等分点。

3.1.1 位置点

在某一特定位置上绘制点。

图3-5 位置点

实现方法：

（1）启动位置点绘制命令； （2）输入位置点。

* 操作步骤：

1) 启动位置点绘制命令：

点击“绘制(C)”-> “点(P)”菜单项，选择导航工具栏中的 [image] 选项。

2) 输入点：

输入位置点，参照<2.3点的输入>。可连续输入多个点。

3.1.2 曲线上点

绘制某条曲线上的点。

图3-6 曲线上点

实现方法：

（1）启动曲线上点命令； （2）拾取曲线； （3）拾取曲线上的点。

* 操作步骤：

1）启动曲线上点命令： | 点击“绘制(C)”-> “点(P)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）拾取曲线： | 拾取一条曲线。
3）拾取点： | 输入曲线上的点，参照<点的输入>。移动鼠标，将曲线上的红色箭头在曲线上滑动到某一位置处，单击鼠标左键即可绘制曲线上该位置处的点。可连续绘制多个曲线上点，单击鼠标右键结束。

说明：如果输入的点不在曲线上，则实际得到的曲线上点为输入的点到曲线上的投影点。

3.1.3 曲面上点

绘制曲面上的点。

图3-7 曲面上点

实现方法：

（1）启动曲面上点绘制命令；

（2）拾取曲面；

（3）拾取曲面上点。

* 操作步骤：

1）启动曲面上 点绘制命令： | 点击“绘制(C)”-> “点(P)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）拾取曲面： | 拾取已知曲面。
3）拾取点： | 在该曲面上拾取点。移动鼠标，将曲面上的红色箭头滑动到某一位置处，单击鼠标左键即可绘制曲面上该位置处点。可连续在曲面上绘制多个点，单击鼠标右键结束。

3.1.4 等分点

绘制某一曲线的等分点。

图3-8 等分点

实现方法：

（1）启动等分点命令；

（2）拾取曲线；

（3）输入等分点数。

* 操作步骤：

1）启动等分点命令： | 点击“绘制(C)”-> “点(P)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）拾取曲线： | 拾取一条曲线。
3）拾取点： | 输入曲线上的点，参照<点的输入>。移动鼠标，将曲线上的红色箭头在曲线上滑动到某一位置处，单击鼠标左键即可绘制曲线上该位置处的点。可连续绘制多个曲线上点，单击鼠标右键结束。


绘制多边形

3.8 绘制多边形

多边形绘制时的导航工具栏选项如图3-61所示：

图3-65 多边形绘制导航工具栏选项

参数定义：

内接多边形 | 已知多边形的边数及其外接圆圆心和半径，绘制圆的内接正多边形。
外接多边形 | 已知多边形的边数及其内切圆圆心和半径，绘制圆的外切正多边形。
边长多边形 | 已知多边形的边数和其中一条边的两个端点来绘制正多边形。
【生成组合线】 | 不选此选项，则所绘制出的正多边形的各个边为独立的直线段； 选中此选项，则将各个边直线组合为一条组合曲线。
定义平面 | 定义正多边形绘制时的临时绘图面。

3.8.1 内接多边形

已知多边形的边数及多边形的外接圆的圆心和半径，绘制圆的内接正多边形。

图3-66 内接正六多边形

实现方法：

（1）启动圆内接多边形绘制命令；

（2）输入多边形边数；

（3）输入多边形的中心和半径。

* 操作步骤：

1）启动圆内接多 边形绘制命令： | 点击“绘制(C)”->“多边形(G)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入多边形的边数： | 输入多边形的边数，可单击鼠标右键接受括号中的默认值，也可以直接输入新的边数后回车。
3）输入多边形的中心： | 即输入多边形的外接圆的圆心点，参照<点的输入>。
4）输入多边形的半径： | 即输入多边形的外接圆的半径，半径值可以直接输入，也可以拖动“橡皮筋”定义另外一点来确定。多边形的半径即为多边形中心与每条边的端点之间的距离。
5）输入多边形的中心： | 输入下一个正多变形中心，或单击右键结束。可以连续绘制多个边数相同的圆内接正多边形。

3.8.2 外切多边形

已知多边形的边数及多边形内切圆的圆心和半径，绘制圆的外切正多边形。

图3-67 圆外切正六边形

实现方法：

（1）启动圆外切多边形绘制命令；

（2）输入多边形边数；

（3）输入多边形的中心和半径。

* 操作步骤：

1）启动圆外切多边形绘制命令： | 点击“绘制(C)”->“多边形(G)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入多边形的边数： | 输入多边形的边数，可单击鼠标右键接受括号中的默认值，也可以直接输入新的边数后回车。
3）输入多边形的中心： | 即输入多边形内切圆的圆心点，参照<点的输入>。
4）输入多边形的半径： | 即输入多边形内切圆的半径，半径值可以直接输入，也可以拖动“橡皮筋”定义另外一点来确定。多边形的半径为多边形中心与每条边的中点之间的距离。
5）输入多边形的中心： | 输入下一个正多变形中心，或单击右键结束。可以连续绘制多个边数相同的圆外接正多边形。

说明：

1. 在绘制圆的内接多边形和外切多边形时，若没有定义绘制时的临时绘图面，则在平行于当前绘图平面且深度为输入的中心点所在的深度平面内生成多边形；

2. 在绘制圆的内接多边形和外切多边形时，若定义了临时绘图面，则系统会将输入的多边形中心点投影到这个临时绘图面上，然后再在这个平面内来生成正多边形。

3.8.3 边长多边形

已知多边形的边数和其中一条边的两个端点来绘制正多边形。

(a) (b)

图3-68 边长正五边形

实现方法：

（1）启动边长多边形绘制命令；

（2）输入边数；

（3）输入边的两个端点。

* 操作步骤：

1）启动边长多边形绘制命令： | 点击“绘制(C)”->“正多边形(G)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入多边形的边数： | 输入多边形的边数，可单击鼠标右键接受括号中的默认值，也可以直接输入新的边数。
3）输入第一点： | 输入边的第一个端点，参照<点的输入>。
4）输入第二点： | 输入边的第二个端点，参照<点的输入>。
5）输入第一点： | 输入下一个边长多边形的第一个端点，或单击右键结束。可以连续绘制多个边数相同的边长正多边形。

说明：

1. 若没有定义绘制多边形的临时绘图面，则在当前绘图面及其平行平面内进行绘制；此时若输入的一条边的两个端点不在当前绘图平面的同一深度处，则系统将第二个端点投影到第一个端点所在的深度平面内，并在这个平面内生成多边形；

2. 若定义了绘制多边形的临时绘图面，则系统会将输入的两个端点投影到这个临时绘图面上，然后再在这个平面内来生成多边形；

3. 定义多边形的一条边时，其两个端点的定义顺序不同，多边形的走向不同。比较图3-68中的(a)和(b)，边的两个端点定义顺序和绘制出的多边形。多边形的走向是按照逆时针方向定义的。


绘制矩形

3.7 绘制矩形

矩形绘制导航工具栏选项如图3-62所示。

图3-62 矩形绘制导航工具栏选项

参数定义：

直角矩形 | 通过定义矩形的两个角点或定义中心点和一个角点来绘制直角矩形。
圆角矩形 | 通过定义一直角矩形和圆角半径来绘制圆角矩形。
【中点优先】 | 选中此选项，则定义直角矩形时采用“中心点+角点”输入方法； 不选此选项，则定义直角矩形时采用“角点+角点”输入方法。
定义平面 | 定义矩形绘制时的临时绘图面。

3.7.1 直角矩形

通过定义矩形的两个角点或定义矩形中心点和一个角点来绘制直角矩形。

图3-63 直角矩形

实现方法：

（1）启动直角矩形绘制命令；

（2）输入矩形两个角点或中心点和一个角点。

* 操作步骤：

1）启动直角矩形 绘制命令： | 点击“绘制(C)”->“矩形(R)”菜单项，选择导航工具栏中的 [image] 选项。
2）第一个角点： | 输入矩形第一个角点，参照<点的输入>。若选中【中点优先】选项，则提示输入矩形的中心点。
3）第二个角点： | 输入矩形第二个角点，参照<点的输入>。
4）第一个角点： | 输入下一个矩形第一个角点，或单击鼠标右键结束。若选中【中点优先】选项，则提示输入下一个矩形的中心点。可连续绘制多个直角矩形。

3.4.2 圆角矩形

通过定义一直角矩形和圆角半径来绘制圆角矩形。

图3-64 圆角矩形

实现方法：

（1）启动圆角矩形绘制命令；

（2）输入矩形两个角点或中心点和一个角点；

（3）输入圆角半径。

* 操作步骤：

1）启动圆角矩形 绘制命令： | 点击“绘制(C)”->“矩形(R)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）第一个角点： | 输入矩形第一个角点，参照<点的输入>。若选中【中点优先】选项，则提示输入矩形的中心点。
3）第二个角点： | 输入矩形第二个角点，参照<点的输入>。
4）圆角的半径： | 输入圆角半径值，可直接输入半径值，也可以拖动“橡皮筋”定义一点来确定半径值。若圆角半径值为正，则圆角矩形如图3-60(a)；若圆角半径为负，则圆角矩形如图3-60(b)；若输入的圆角半径值大于矩形的最短边长的一半时，此时的圆角矩形为全圆角矩形，如图3-60(c)。
5）第一个角点： | 输入下一个圆角矩形的第一个角点，或单击右键结束。若选中【中点优先】选项，则提示输入下一个矩形的中心点。可以连续绘制多个圆角矩形。

说明：

1. 若没有定义矩形绘制的临时绘图面，则在当前绘图平面及其平行平面内绘制矩形；若输入的的矩形两角点或中心点和角点不在当前绘图平面的同一深度处，则系统将第二个角点投影到第一个角点或中心点所在的深度平面内，并在这个平面内生成矩形；

2. 若定义了矩形绘制的临时绘图面，则系统会将输入的角点和中心点投影到这个临时绘图面上，然后再在这个平面内来生成矩形。


绘制样条

3.4 绘制样条

样条绘制的导航工具栏选项如图3-45：

图3-45 样条绘制导航工具栏选项

参数定义：

过顶点 | 通过定义样条曲线所通过的一系列点来绘制样条曲线。
过斜率 | 通过定义样条曲线所通过的一系列点和首末两个端点的切矢来绘制样条曲线。
控制点 | 通过定义样条曲线的控制多边形的顶点来绘制样条曲线。
定义平面 | 定义样条绘制时的临时绘图面。

3.4.1 过顶点

通过定义样条曲线所通过的一系列点来绘制样条曲线。

图3-46 过顶点样条曲线

实现方法：

（1）启动过顶点样条绘制命令；

（2）输入样条曲线通过的一系列点。

* 操作步骤：

1）启动过顶点样条 绘制命令： | 点击“绘制(C)”->“样条(N)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入点1： | 输入样条曲线所通过的第一点。
3）输入点2： | 输入样条曲线所通过的第二点。
4）输入点n： | 输入样条曲线所通过的第n点，可连续输入多个点，单击右键结束。

3.4.2 过斜率

通过定义样条曲线所通过的一系列点和首末两个端点的切矢来绘制样条曲线。

图3-47 斜率(切矢)样条曲线

实现方法：

（1）启动斜率样条绘制命令；

（2）输入样条曲线通过的一系列点；

（3）输入起末两个端点切矢点。

* 操作步骤：

1）启动斜率样条绘制命令： | 点击“绘制(C)”->“样条(N)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入点1： | 输入样条曲线所通过的第一点，参照<点的输入>。
3）定义起点斜率： | 此时导航工具栏中显示定义斜率选项组，斜率定义可参照<定义方向>；点击 [image] 按钮或单击鼠标右键取消曲线首点斜率的定义；
4）输入点2： | 输入样条曲线所通过的第二点，参照<点的输入>。
5）输入点n： | 输入样条曲线所通过的第n点，可连续输入多个点，单击右键结束。
6）定义末点斜率： | 此时导航工具栏中显示定义斜率选项组，末点斜率定义可参照<定义方向>；点击 [image] 按钮或单击鼠标右键取消曲线末点斜率的定义；
7）生成样条曲线： | 单击鼠标右键声称样条曲线，或按F键取消上一步操作，重新输入样条曲线通过点；
8）输入点1： | 输入下一条样条曲线所通过的第一点；可连续绘制多条切矢样条曲线，单击鼠标右键结束样条曲线绘制命令。

3.4.3 控制点

通过定义样条曲线的控制多边形的顶点来绘制样条曲线。

图3-48 控制顶点样条曲线

实现方法：

（1）启动控制顶点样条绘制命令；

（2）输入样条曲线通过的一系列控制顶点。

* 操作步骤：

1）启动控制顶点 样条绘制命令： | 点击“绘制(C)”->“样条(N)”菜单项，选择导航工具栏中的 [image] 绘制选项。
2）输入点1： | 输入样条曲线的第一个控制顶点，参照<点的输入>。
3）输入点2： | 输入样条曲线的第二个控制顶点，参照<点的输入>。
4）输入点n： | 输入样条曲线的第n个控制顶点，可连续输入多个点，单击右键结束。

说明：

1. 在绘制样条曲线时，输入的样条曲线通过点或控制点可以为空间中的任意点；若没有定义临时绘图面，则可以在3D空间中绘制三维样条曲线；

2. 若定义了临时绘图面，则系统将输入的样条曲线通过点或控制点投影到该临时绘图面上，然后再在这个平面内来生成二维平面样条曲线。


曲线编辑

第四章 曲线编辑

本章将主要介绍一些常用的系统和曲线编辑操作命令，主要包括以下三类：

1. 系统基本编辑操作：如撤消和重做、复制和粘贴等；

2. 曲线基本编辑操作：如曲线倒角、修剪、打断、延伸和等距等操作；

3. 曲线高级编辑操作：如曲线组合与炸开、毗连、光顺和编修等操作；

图4-1为曲线编辑菜单项。

图4-1 曲线编辑菜单

菜单项 | 快捷键 | 功能
撤消 | Ctrl + Z | 撤消上一步命令的执行。
重做 |  | 取消上一步“撤消”命令的执行结果。
剪切 | Ctrl + X | 删除选定的图素并将它们存储到剪贴板。
复制 | Ctrl + C | 将选定的图素复制一份到剪贴板上。
粘贴 | Ctrl + V | 将剪贴板中存储的图素粘贴到当前文件中。
删除 | Delete | 删除屏幕上的指定图素。
打断 |  | 将一条曲线通过其它曲线或点将其分割为两条曲线。
倒角 | Alt + 0 | 曲线之间进行圆角过渡或斜角过渡。
修剪 | Alt + 8 | 将曲线修剪至某一曲线或一点所定义的边界处。
延伸 | Alt + 9 | 将曲线延伸至某一曲线或一点所定的边界处。
等距 | Alt + 5 | 绘制曲线在其某一侧的一定的距离处的偏移线。
曲线组合 |  | 将曲线链上的多条首尾相接的曲线组合成为一条组合曲线
曲线炸开 |  | 炸开组合曲线，恢复为组合前的多条首尾相接的曲线
曲线毗连 |  | 在曲线的连接端点处进行端点连续性匹配，并将他们连接为一条组合曲线或单条样条曲线。
曲线光顺 |  | 调整曲线，使曲线变得更为“光滑顺眼”。
曲线编修 |  | 拖动曲线的控制点来对曲线的形状进行动态调整。
区域等距 | Ctrl + 1 | 将某一区域轮廓曲线向区域内或区域外偏移一定的距离得到其等距轮廓曲线。
法向等距 |  | 将曲面上的曲线依照曲面的法线方向做等距离偏移。


系统基本编辑操作

4.1 系统基本编辑操作

系统基本编辑操包括：撤销、重做、剪切、复制、粘贴和删除等操作。

4.1.1 撤消

撤消上一步命令的执行。

实现方法：直接启动撤消命令。

* 操作步骤：

启动撤消命令：

点击“编辑(E)”->“撤消(U)”菜单项或常用工具条中的 [image] 按钮。本菜单项后面将显示上一步操作的名称。

说明：并不是所有命令的执行结果都能够被撤消。如系统设置和视图的调整等。

4.1.2 重做

取消上一步“撤消” 命令的执行结果。

实现方法：直接启动重做命令。

* 操作步骤：

启动重做命令：

点击“编辑(E)”->“重做(R)”菜单项或常用工具条中的 [image] 按钮。本子菜单项后面将显示上一步撤消的命令名称。

说明：

1、本命令必须立即跟随在“撤消”命令之后，若在“撤消”命令后又执行了其它的命令后，本命令将可能失效；

2、在系统设置中定义了系统最大撤消和重做的次数，参照<1.6 系统设置>。

4.1.3 剪切

删除选定的图素并将它们存储到剪贴板上，以供粘贴使用。

实现方法：

（1）选择图素；

（2）启动剪切命令。

* 操作步骤：

1) 选择图素：

选择要进行剪切的图素。

2) 启动剪切命令：

点击“编辑(E)”->“剪切(X)”菜单项或常用工具条中 [image] 按钮。

4.1.4复制

将选定的图素复制一份到剪贴板上，以供图形粘贴时使用。

实现方法：

（1） 选择图素；

（2） 启动复制命令。

* 操作步骤：

1) 选择图素：

选择要进行复制的图素。

2) 启动复制命令：

点击“编辑(E)”->“复制(C)”菜单项或常用工具条中 [image] 按钮。

4.1.5 粘贴

将剪贴板中存储的图素粘贴到当前文件中。

实现方法：直接启动粘贴命令。

* 操作步骤：

启动粘贴命令：

点击“编辑(E)”->“粘贴(P)”菜单项或常用工具条中 [image] 按钮。

说明：

可将SurfMill中的各种图素从一个位置复制粘贴至另一个位置，或从一个文件复制粘贴到另一个文件，但是不能在SurfMill和外部程序间进行曲线或曲面的复制粘贴操作。

4.1.6 删除

删除屏幕上的指定图素。

实现方法：

（1）启动删除命令； （2）拾取要删除的图素。

* 操作步骤：

1) 启动删除命令：

点击“编辑(E)”->“删除(D)”菜单项或常用工具条中的 [image] 按钮。

2) 选择被删除的图形：

拾取要删除的图素，可拾取多个曲线或曲面。拾取模式有单个拾取、串链拾取和窗口拾取三种，参照<1.2 对象的选择与拾取>。点击“确定”按钮结束删除命令。

说明：此命令的执行亦可先选择被删除的图素，然后再点击删除菜单项或工具条图标按钮。


曲线高级编辑操作

4.3 曲线高级编辑操作


曲线组合与炸开

4.3.1 曲线组合与炸开

曲线组合是将一条曲线链上的多条首尾相接的曲线组合成为一条曲线；

曲线炸开为组合的逆过程，它将组合曲线炸开为组合前的多条曲线。

4.3.1.1 曲线组合

将一条曲线链上的多条首尾相接的曲线组合成为一条曲线。将多条首尾相接的曲线组合为一条曲线，主要有两大优点和用途：

1) 对这多条曲线进行统一地拾取和变换；

2) 常做为一条光滑的曲线用在构造曲面时的轮廓线，如拉伸截面线、旋转截面线、蒙皮截面线、扫掠截面线或轨迹线等。

组合曲线导航工具栏中的选项如图4-28所示。

图4-28 曲线组合导航工具栏选项

其中提供了两种曲线拾取方式：

1) 串链拾取：

通过拾取在一条曲线链上的任意一条曲线来自动将整个链上的所有曲线拾取并组成为一条组合曲线或将整个曲线链上的曲线转换为一条样条曲线，如图4-29(a)所示。

2) 限制串链：

拾取曲线链上的开始曲线段和下一段要连接的曲线来有选择地拾取曲线链上的一组曲线来将它们组合为一条组合曲线或转换为一条样条曲线，如图4-29(b)所示。

图4-29 组合曲线

系统提供了组合后生成的两种曲线类型：

1) 组合曲线：将在一条曲线链上拾取的多条首尾相接曲线组合为一条组合曲线；选择导航工具栏中的 [image] 选项；

2) 样条曲线：将在一条曲线链上拾取的多条首尾相接曲线组合并转换为一条样条曲线；选择导航工具栏中的 [image] 选项。

另外在组合过程中，还可以选择是否对组合后生成的组合曲线或样条曲线进行光顺操作：选择导航工具栏中的 [image] 选项，并可点击 [image] 按钮，在弹出的对话框中定义光顺选项；关于光顺选项可参照<4.3.3曲线光顺>；图4-30所示为不选择和选择光顺选项得到的曲线组合结果。

图4-30 光顺选项对组合后曲线的影响

实现方法：

（1）启动曲线组合命令；

（2）拾取曲线链上的曲线。

* 操作步骤：

1）启动曲线组合命令： | 点击“编辑(E)”->“曲线组合(M)”菜单项。
2）拾取曲线链上的曲线： | 通过串链拾取或限制串链拾取曲线链上要组合的曲线。拾取方法参照<1.2.3串链拾取>。可拾取多条串链曲线，然后单击鼠标右键结束本次组合操作；若本次组合成功，则在系统提示信息框中输出组合成功信息。可以进行多次组合操作，然后单击鼠标右键结束组合命令。

4.3.1.2 曲线炸开

曲线炸开为曲线组合的逆过程，将一条组合曲线炸开，恢复为组合前的多条首尾相接的曲线。

实现方法：

（1）启动曲线炸开命令；

（2）拾取要炸开的组合曲线。

* 操作步骤：

1） 启动曲线炸开命令：

点击“编辑(E)”->“曲线炸开(S)”菜单项。

2） 择组合曲线：

拾取要炸开的组合曲线。可拾取多条组合曲线，单击鼠标右键进行曲线炸开操作；若对选择的组合曲线炸开成功，则在系统提示信息框中输出分解成功信息。可连续进行多次曲线炸开操作，单击鼠标右键结束。

说明：

1. 曲线组合时选择“转为组合线”后生成的曲线为一条组合曲线，该曲线可以被炸开为组合前的多条曲线；

2. 曲线组合时选择“转为样条线”后生成的曲线为一条样条曲线，该曲线不能被炸开为组合前的多条曲线。


区域等距

4.3.5 区域等距

将某一区域轮廓曲线向区域内或区域外偏移一定的距离得到其等距轮廓曲线。

图4-54 区域轮廓曲线等距

实现方法：

（1）启动区域等距命令；

（2）拾取轮廓曲线；

（3）在对话框中定义轮廓曲线偏移参数和选项。

* 操作步骤：

1) 1) 启动区域等距命令：

点击“编辑(E)”->“区域等距(N)”菜单项。

2) 2) 拾取轮廓曲线：

拾取要偏移的区域轮廓曲线。通过曲线串选方式来进行轮廓曲线的拾取，可拾取多个轮廓曲线，单击鼠标右键结束拾取。曲线串选请参照< 1.2 对象的选择与拾取>。

3) 3) 在对话框中定义偏移参数和选项：

在弹出的对话框(图4-55)中定义偏移距离、偏移次数、偏移方向和尖角处理方式等参数和选项。点击“确定”按钮。

图4-55 轮廓偏移

参数定义：

删除原始图形 | 选择此选项，则在区域等距后将原始区域轮廓曲线删除掉。
偏移距离 | 原始区域轮廓曲线与等距后区域轮廓曲线之间的距离。
偏移次数 | 将区域轮廓曲线进行连续偏移的次数，可一次等距完成多次偏移。
偏移方向 | 将原始区域轮廓图形向其内部还是外部进行偏移来形成新的轮廓曲线。
尖角处理 | 包括尖角、圆角和截断三种处理方法(如图4-56)。图4-57为三种处理方式图例。

图4-56 尖角等距处理方式

图4-57 三种尖角处理方式图例


曲线毗连

4.3.2 曲线毗连

在曲线的连接端点处进行端点连续性匹配，并将它们连接为一条组合曲线或单条样条曲线。

如图4-31(a)所示为三条首尾相接的曲线，图(b)和(c)为根据一定的连续条件将各曲线在连接端点处进行形状调整后并将它们连接转化为一条光滑的样条曲线。

图4-31 曲线毗连

预备知识：

在介绍这个命令之前，首先要知道两个概念：曲线之间的端点连续性及其连续性匹配。在曲面造型过程中，这对构造光滑的曲线连接和曲面连接相当重要。

1. 端点连续性：

通俗的讲，端点连续性是指两曲线在它们的连接端点处的连接状态和光滑程度；一般有位置连续、切矢连续和曲率连续三种：

Ø 位置连续：两曲线在连接端点处的间隙很小或端点重合，可以认为两曲线是互相连接着的，如图4-32(b)；

Ø 切矢连续：两曲线在连接端点处不仅相互连接，而且是互相相切的。这种类型的连续性将产生非常光滑的曲线过渡，如图4-32(c)；

Ø 曲率连续：这是连续性的最高级别，两曲线在连接端点处不仅相互连接、互相相切，而且具有同样的曲率半径，如图4-32(d)；这种类型的连续性将产生比切矢连续更光滑的曲线过渡；在一般情况下，满足切矢连续的曲线光滑过渡就已经足够了。

图4-32 曲线端点连续性

2. 端点连续性匹配

连续性匹配指我们通过调整在连接端点处的曲线形状来使得两条曲线在连接端点处满足一定的连续性；可以调整两条曲线中的任一条曲线或同时调整两条曲线的连接端点处形状来进行匹配操作；在两曲线连接端点处进行连续性匹配的主要作用如下：

Ø 位置连续匹配：消除两曲线间的连接间隙，如图4-33(b)；

Ø 切矢连续匹配：在消除两曲线间间隙的基础上，将两曲线调整到光滑连接状态，如图4-33(c)；

图4-33 端点连续性匹配

曲线毗连操作时的导航工具栏选项如图4-34所示：

图4-34 曲线毗连导航工具栏选项

多线毗连 | 在多条首尾相接的曲线之间进行连续性匹配，并可将它们连接为一条曲线；
两线毗连 | 在两条曲线的连接端点处进行连续性匹配，并可将二者连接为一条曲线；
端点连续性查询 | 查询两曲线在连接端点处的连续性。

4.3.2.1 多线毗连

在多条首尾相接的曲线之间进行连续性匹配，并可将它们连接为一条曲线，如图4-31所示。

实现方法：

（1）启动多线毗连命令；

（2）拾取多条需要进行毗连的曲线；

（3）在对话框中定义毗连参数和选项。

* 操作步骤：

1）启动多线毗连命令： | 点击“编辑(E)”->“曲线毗连(L)”菜单项； 在导航工具栏中选择 [image] 选项。
2）拾取要进行毗连的曲线： | 用鼠标拾取要进行毗连的曲线，毗连曲线可以为单段曲线或组合曲线；曲线拾取完毕后，单击鼠标右键结束；
3）在对话框中定义毗连参数和选项： | 在弹出多线毗连对话框（图4-35）中定义匹配连接的参数和选项，单击“确定”按钮后系统自动进行曲线匹配和连接操作。若选择“曲线处理”选项为“连为样条曲线”或“连为组合曲线”，则根据所设定的间隙精度进行匹配连接后，将会提示在信息提示框中提示用户连接结果。

图4-35 多线毗连对话框

参数定义：

连接端点匹配 | 在曲线连接端点处进行连续性匹配的类型，可以选择“位置连续”和“切矢连续”两种匹配方式；
曲线处理 | 对拾取的多条曲线在连接端点处进行连续性匹配后，是否将这些结果曲线进行连接，有三种选项： l 仍为多条曲线：对匹配结果曲线不进行连接； l 连为样条曲线：将匹配结果曲线连接为一条样条曲线； l 连为组合曲线：将匹配结果曲线连接为一条组合曲线； 另外，选中“删除原始曲线”选项将在匹配连接后删除掉原始曲线，反之则保留原始曲线；
间隙精度 | 当两条曲线间的端点间隙小于所设定间隙精度时，两曲线间可以进行端点匹配和连接操作；当大于所设定间隙精度时，两曲线间将不进行端点匹配和连接操作。

4.3.2.2 两线毗连

在两条曲线的连接端点处进行连续性匹配，并可将二者连接为一条样条曲线或一条组合曲线。比较于多线毗连操作，两线毗连赋予了两条曲线之间进行连接时形状控制的更大柔性。

实现方法：

（1）启动两线毗连命令；

（2）拾取两条连接曲线。

（3）在对话框中定义两线毗连的参数和选项。

* 操作步骤：

1）启动两线毗连命令： | 点击“编辑(E)”->“曲线毗连(L)”菜单项； 在导航工具栏中选择 [image] 选项。
2）拾取第一条曲线的连接端： | 拾取第一条曲线；本条曲线上的与拾取位置最近的那个端点将作为连接端点与下一条曲线进行匹配连接；
3）拾取第二条曲线的连接端： | 拾取第二条曲线；本条曲线上的与拾取位置最近的那个端点将作为连接端点与上一条曲线进行匹配连接；
4）在对话框中定义两线毗连的参数和选项 | 在弹出的“两线毗连”对话框（图4-36）中定义毗连的参数和选项；点击“确定”按钮后系统自动进行两曲线的匹配连接操作。

图4-36 两线毗连对话框

参数定义：

连接端点匹配 | 在曲线连接端点处进行连续性匹配的类型，可以选择“位置连续”和“切矢连续”两种匹配方式；
端点调整 | 有三种选项： l 调整第一条曲线：调整拾取的第一条曲线的连接端点处形状来满足两曲线间的端点连续性，如图4-37(b)所示； l 调整第一条曲线：调整拾取的第二条曲线的连接端点处形状来满足两曲线间的端点连续性，如图4-37(c)所示； l 同时调整两条曲线：同时调整所拾取的两条曲线的连接端点处形状来满足两曲线间的端点连续性4-37(d)所示；
曲线处理 | 对拾取的两条曲线在连接端点处进行连续性匹配后，是否将结果曲线进行连接，有三种选项： l 仍为两条曲线：对匹配结果曲线不进行连接； l 连为样条曲线：将匹配结果曲线连接为一条样条曲线； l 连为组合曲线：将匹配结果曲线连接为一条组合曲线； 另外，选中“删除原始曲线”选项将在匹配连接后删除掉原始曲线，反之则保留原始曲线；

图4-37 端点调整(切矢连续)

说明：

1. 比较与“多线毗连”，两线毗连操作与拾取的两曲线间的端点间隙大小无关，不管相距多远，均能将二者进行端点匹配和连接操作；

2. “两线毗连”中，两条曲线的连接端点的确定只与它们的拾取位置有关，如图*所示即为两条曲线的拾取位置不同，毗连结果也不同（如图4-38 (a)和(b)）；

图4-38 连接端点与曲线拾取位置有关(╳表示曲线的拾取位置)

3. “多线毗连”中的端点调整默认为“同时调整两条曲线”，在两线毗连中端点调整方式可以随用户自定义；

4. 如果两曲线端点间间隙距离较大，曲线毗连操作后可能在端点处较原始曲线形状变化较大（如图4-39(b)），则建议在这两个曲线之间另外绘制一曲线将两二者连接起来，常常采用“两切矢样条”的方法来绘制一样条曲线将二者光滑连接起来(如图4-39(c))，然后在此基础上采用“多线毗连”命令将这三条曲线连接起来；

图4-39 先绘制连接曲线,再进行毗连操作

5. 在“多线毗连”和“两线毗连”操作时，若选择“切矢连续”匹配选项，当匹配结果曲线较原始曲线在连接端处形状变化较大时，可以首先将需要进行端点调整的那条曲线先转换为样条曲线，接着在其端点附近插入一节点或一个控制顶点，然后再进行毗连操作；插入样条曲线节点和控制点可参照<4.3.4 曲线编修>。

4.3.2.3 端点连续性查询

查询两曲线在连接端点处的端点连续性。

实现方法：

（1）启动端点连续性查询命令；

（2）拾取两条曲线。

* 操作步骤：

1）启动端点连续性查询命令： | 点击“编辑(E)”->“曲线毗连(L)”菜单项； 在导航工具栏中选择 [image] 选项。
2）拾取第一条曲线的连接端： | 拾取第一条曲线；本条曲线上的与拾取位置最近的那个端点将作为本曲线的连接端点；
3）拾取第二条曲线的连接端： | 拾取第二条曲线；本条曲线上的与拾取位置最近的那个端点将作为本曲线的连接端点；
4）显示两曲线端点连续性： | 系统将弹出查询结果对话框（如图4-40），对话框中显示了曲线连接端点处各连接参数误差，以及其连续性类型。点击“关闭”即可。

图4-40 曲线连接端点连续性查询结果


曲线光顺

4.3.3 曲线光顺

曲线光顺是指使曲线更为“光滑顺眼”，粗略地讲，就是减少曲线的皱褶，如图所示。由于对曲线的光顺性的判断带有一定的主观因素，可能需要用户根据光顺效果以及光顺曲线与原始曲线的偏差等多种因素进行多次光顺操作。

图4-41 曲线光顺

* 操作步骤：

1）选择菜单项： | 点击菜单“编辑（E）→曲线光顺（G）”。
2）拾取曲线： | 拾取要进行光顺的曲线。
3) 设置参数 | 在右边导航条上设置光顺条件
4）确定退出 | 确认无误后，点击右键，选择右键菜单中的“确定命令”菜单项或直接点击右边导航条上“确定”按钮。

参数定义：

图4-42 曲线光顺参数

最大偏差 | 光顺前后曲线的最大偏差值，用于控制曲线的变形量
首点约束条件 | 1） 自由：对曲线的起始点不施加任何约束条件，光顺后曲线的起点位置可能会移动 2） 固定位置：光顺前后曲线的起始点位置保持不变 3） 固定位置切矢：光顺前后曲线的起始点位置保持不变，起点切矢方向也保持不变
末点约束条件 | 1） 自由：对曲线的末点不施加任何约束条件，光顺后曲线的末点位置可能会移动 2） 固定位置：光顺前后曲线的末点位置保持不变 3） 固定位置切矢：光顺前后曲线的末点位置保持不变，末点切矢方向也保持不变
组合线选项 | 这些选项仅对组合线有效 1） 合并为单曲线 将光顺后的组合线转为单根样条曲线 2） 只光顺连接处 若选中该选项，则只对组合线内部曲线相连接的地方进行局部光顺，消除连接处的尖角，而保持子曲线内部形状不变。若不选该选项，则对组合线进行整体光顺
删除原曲线 | 光顺后是否保留原始曲线


曲线编修

4.3.4 曲线编修

本命令提供了一种通过拖动曲线的控制点来对曲线的形状进行动态调整的方法。如图4-43所示：

图4-43 曲线编修

曲线编修操作时的导航工具栏选项如图4-44：

图4-44 曲线编修导航工具栏选项

本功能提供了以下三种曲线编辑方式：

移动控制点 | 通过移动曲线的控制点的位置来对曲线形状进行调整；
插入控制点 | 通过增加样条曲线某一位置附近处的控制点数目来提高该位置处曲线形状调整的柔性；
插入节点 | 通过在样条曲线上某一位置处插入节点来提高该位置附近曲线形状调整的柔性；

4.3.4.1 移动曲线控制点

通过移动曲线控制点的位置来对曲线形状进行调整。直线和圆弧的控制点分别为直线和圆弧的两个端点，样条曲线的控制点为其控制多边形的各顶点，如图4-45所示。

图4-45 曲线控制点

此处提供了三种控制点移动方式：

l 鼠标动态拖拽曲线控制点；

l 增量移动曲线控制点；

l 对齐曲线控制点；

1. 拖拽曲线控制点

按住鼠标左键并拖动鼠标来对选中的曲线控制点进行位置移动。如果鼠标拖拽点不是曲线控制点，而落在曲线上时，则对整个曲线进行移动。

在拖拽过程中，可以配合Shift、Ctrl键来对曲线上控制点或整个曲线在三维空间中的不同方向上进行移动；基本原则如下：

1) 按住Shift键拖动鼠标：在当前绘图面的正交方向上进行拖拽；

图4-46 在当前绘图面的正交方向上拖拽

2) 按住Ctrl键拖动鼠标：我们定义的第二功能键，对于直线、圆弧和样条曲线有不同的定义：

Ø 直线：按住Ctrl键拖拽直线的一个端点时，沿直线方向拉长或缩短直线；同时拖拽直线两个端点时，沿直线方向移动该直线；

Ø 圆弧：按住Ctrl键拖拽圆弧一个端点时，圆弧将沿在该端点处进行进行延伸或缩短，即圆弧圆心半径不变，圆心角增大或减小（可以动态的将圆弧变为圆或将圆变为圆弧）；同时拖拽圆弧两个端点时，将对圆弧进行角度旋转；另外在按住Ctrl键来拖拽圆弧圆周上任意一点时，此时可对圆弧半径进行动态改变；如图4-47所示：

图4-47 拖拽圆弧端点

Ø NURBS曲线：由于NURBS曲线首末点的切矢方向分别与首末点位置处的两个控制顶点的连线方向相同，因此当按住CTRL键来拖拽曲线的前两个或最后两个控制点时，此时实际移动点将被限制在控制多边形的第一或最后一条边直线方向上；这样就可以保证在曲线的端点切矢方向不变的条件下，来调整曲线端部的形状，在实际应用中比较广泛。

3) 同时按住Shift和Ctrl键拖动鼠标：在垂直于当前绘图平面的方向上进行拖拽，如图4-48所示；

图4-48 在垂直于当前绘图面的方向上拖拽

4) 自由拖动鼠标：在平行于当前绘图面的平面内进行拖拽；

* 操作步骤：

1) 启动曲线编修命令：

点击“编辑(E)”->“曲线编修(V)”菜单项。

2) 拾取曲线：

拾取要编修的曲线。

3) 选择曲线上的控制点：

选择并拖动曲线上的控制点来对曲线形状进行动态调整，拖拽到某一位置后释放鼠标完成本次拖拽，可单击鼠标右键结束编修操作。

说明：

1. 选择要进行调整的控制点时，分为点选和框选两种；其中按住Shift或Ctrl键可分别实现“加选”和“减选”功能；

Ø 按住Shift键选择，将选中的控制点添加到控制点选择集中，实现“加选”功能；

Ø 按住Ctrl键可以将选中的控制点进行不选，实现“减选”功能；

2. “曲线平面内拖拽”选项是只对拖拽平面曲线的控制点时有效，对拖拽整个曲线或拖拽空间曲线控制点来说无效；当拖拽平面曲线(圆弧或平面NURBS曲线)的控制点时，选中该选项后，那么无论鼠标在当前坐标系的XYZ三个方向上的怎么移动，最终目标移动点将会将沿着当前观察角度方向投影到曲线平面内，这样就能很好地保证平面曲线在形状调整后仍然在其原始平面内；

3. 当鼠标落在曲线的控制点上并进行拖拽时，此时通过调整曲线控制点的位置来改变曲线形状；当鼠标落在曲线上并进行拖拽时，在当前用户坐标系的XYZ三个方向上可对曲线进行平行移动；

4. 对于拖拽整个曲线来对进行移动的情形，或在拖拽空间曲线(直线或空间NURBS曲线)的控制点时，要注意当前绘图平面的选择，然后根据需要，配合Ctrl或Shift键来得到满意的曲线位置和形状；

5. 对于圆弧，为了保证圆弧的平面性，在未选择“曲线平面内拖拽”选项时，拖拽圆弧端点时，可能会对圆弧在空间中进行平移；

2. 增量移动曲线控制点

通过对选中的曲线控制点或整个曲线在世界坐标系或当前坐标系的XYZ三个方向上移动一个坐标增量值来对曲线的形状和位置进行调整。

* 操作步骤：

1) 启动曲线编修命令：

点击“编辑(E)”->“曲线编修(V)”菜单项。

2) 拾取曲线：

拾取要编修的曲线。

3) 选择曲线上的控制点：

采用点选或框选的方式选择要进行移动的控制点；

4) 启动增量移动子命令：

点击导航工具栏中 [image] 按钮；

5) 定义增量移动参数和选项：

在系统弹出的对话框（如图4-49）中定义移动增量和参考坐标系，点击“确定”按钮。

图4-49 增量移动对话框

说明：

1. 注意选择增量参考坐标系为世界坐标系还是当前用户坐标系；

2. 若当前曲线没有控制点被选中，则对当前选中的曲线进行增量移动；

3. 为了保证圆弧的平面性，增量移动圆弧的一个端点时，则可能会对整个圆弧在空间中进行平移；

3. 对齐曲线控制点

通过将选择的曲线控制点坐标分量对齐到另外一个点（可以为空间任意点或曲线上其他控制点）的坐标分量来对曲线进行形状和位置的调整。

* 操作步骤：

1) 启动曲线编修命令：

点击“编辑(E)”->“曲线编修(V)”菜单项。

2) 拾取曲线：

拾取要编修的曲线。

3) 选择曲线上的控制点：

采用点选或框选的方式选择要进行移动的控制点；

4) 启动控制点对齐子命令：

点击导航工具栏中 [image] 按钮；

5) 定义控制点对齐参数和选项：

在系统弹出的对话框（如图4-50）中定义对齐方式和参考坐标系，点击“确定”按钮。

图4-50 对齐控制点对话框

说明：

1. 该功能只对当前选中的控制点作用；若当前没有控制点被选中，该功能按钮将被禁止使用；

2. 注意对齐参考坐标系的选择：根据需要选择需对齐的坐标分量值是相对于世界坐标系还是当前用户坐标系；

3. 选中X、Y和Z三个方向上同时进行对齐，可以将曲线某一控制点与选中的点重合；对控制点在某一方向上进行对齐，常用于调整曲线的端点切矢；如图4-51所示，图(a)为对齐操作前，曲线经镜像复制后，得到的两曲线间有尖角；图(b)为将曲线的首末端第二个控制点分别与其首末端第一个控制点在X方向对齐后，经过镜像复制操作后，两曲线间光滑连接。

图4-51 利用控制点对齐来调整曲线端点切矢

4.3.4.2 插入样条曲线控制点

本功能只对编修NURBS样条曲线时有效，对圆弧和直线编修时均无效。

在通过移动样条曲线的控制点来调整曲线某一局部位置的形状时，常常会由于该位置处控制点较少，而很难将曲线调整到满意的形状；此时就需要在该位置处增加控制点来提高曲线形状调整的柔性；这可以通过在该位置处插入样条曲线控制点或节点的方法来实现。

图4-52 插入样条曲线控制点

* 操作步骤：

1) 拾取样条曲线：

在启动“曲线编修”命令后，拾取要插入控制点的样条曲线；

2) 启动插入控制点子命令：

选择导航工具栏中的 [image] 选项；

3) 在曲线的控制多边形上拾取要插入的控制点：

在屏幕显示的样条曲线控制多边形的边线上拾取一点，系统将在边线该位置点处增加一个控制点；可连续插入多个控制多边形顶点；单击鼠标右键结束控制点插入操作；

说明：

在控制多边形某一边线上插入一个控制点后，可能会影响周围的两个控制点的位置，但曲线的形状将不发生变化。若鼠标拾取点不落在样条曲线的控制多边形的边线上，则控制点插入操作会失败。

4.3.4.3 插入样条曲线节点

本功能也只对编修NURBS样条曲线时有效，对圆弧和直线编修时均无效。

通过在曲线上某一位置处插入一个新的节点，来在该位置附近增加一个曲线控制点，作用与插入样条曲线控制点作用基本相同，同样是为了提高该位置处曲线形状调整的柔性。如图4-53所示：

图4-53 插入样条曲线节点

* 操作步骤：

1) 拾取样条曲线：

在启动“曲线编修”命令后，拾取要插入控制点的样条曲线；

2) 启动插入节点子命令：

选择导航工具栏中的 [image] 选项；屏幕上将显示该样条曲线上所有节点分布；

3) 在曲线上拾取要插入的新节点：

在屏幕显示的样条曲线上拾取一点，系统将在该点处增加一个节点；可连续插入多个节点；单击鼠标右键结束节点插入操作；

说明：

1. 当鼠标移动到曲线上已存在的某一节点位置时，注意光标上有红色的曲线点出现，提示用户不能在曲线上该节点处再插入新的节点，这是为了避免曲线上重节点的出现；当鼠标移动到曲线上其他位置点时，光标上有绿色的曲线点出现，提示用户可以在曲线上该点处插入新的节点；

2. 在曲线上的某一点处插入新节点后，当重新切换到显示曲线控制点状态时，可以发现曲线在该位置附近新增加了一个控制点，这样就进一步增强了修改该位置处曲线形状的柔性。


法向等距

4.3.6 法向等距

将曲面上的曲线依照曲面的法线方向做等距离偏移。

图4-58 沿曲面法向进行等距

实现方法：

（1）启动法向等距命令；

（2）拾取曲面上曲线或曲面边界线；

（3）拾取曲线所在的曲面；

（3）输入等距距离；

（4）定义其他参数和选项。

* 操作步骤：

1) 启动法向等距命令：

点击“编辑(E)”->“法向等距(B)”菜单项。

2) 拾取曲面上曲线：

拾取曲面上曲线，有单个拾取、串链拾取、限制串链和窗口拾取四种方式，参照<1.2 对象的选择与拾取>；也可以曲面上点和曲面的边界线。曲线拾取完毕后，单击鼠标右键结束曲线拾取；

3) 拾取曲面：

拾取曲线所在的曲面，有单个拾取、窗口拾取两种方式，可以拾取多个单张曲面或组合曲面；曲面上的箭头方向表示曲线在曲面的那一侧沿曲面法向进行等距，点击已经选中的曲面可以对等距方向进行反向；

4) 输入等距距离：

对话框（图4-59）中的等距距离按钮 [image] 上显示出当前默认的等距距离，可以点击此按钮，然后输入新的距离值；

5) 定义其他参数和选项：

在对话框（图4-59）中定义是否将等距曲线放到与原始曲线相同的图层中和是否删除原始曲线等选项，然后点击“确定”按钮后系统将进行等距操作。完成后在系统信息提示框中将提示用户等距后生成曲线条数。

图4-59 法向等距操作的参数和选项

参数定义：

等距距离 | 曲面上线沿着曲面的法线方向进行等距的距离
放到相同图层 | 选择此选项，则生成的等距曲线将和原始曲线在同一图层中； 不选择此选项，则生成的等距曲线将位于当前绘图层中。
删除原始线 | 选择此选项，则等距操作后将删除掉原始曲线（原始曲线为曲面边界线除外）；反之亦反。


曲线基本编辑操作

4.2 曲线基本编辑操作

曲线基本编辑操作主要包括：打断、倒角、修剪、延伸和等距等命令操作。


曲线延伸

4.2.4 曲线延伸

将曲线延伸到某一条曲线或一点所确定的边界处。

延伸操作的导航工具栏选项如图4-18所示：

图4-18 曲线延伸导航工具栏选项

参数定义：

延伸到线 | 将曲线延伸到指定的曲线边界处。
延伸到点 | 将曲线延伸到指定的点所定义的边界处。
长度延伸 | 将曲线延伸一定的长度。
圆弧转为圆 | 将圆弧变为整个圆。

4.2.4.1 延伸到线

将曲线延伸到指定的曲线边界处。

图4-19 延伸到线

实现方法：

（1）启动延伸到线命令；

（2）拾取一条需延伸的曲线；

（3）拾取延伸到的目标曲线。

* 操作步骤：

1) 启动延伸到线命令：

点击“编辑(E)”->“延伸(E)”菜单项，选择导航工具栏中的 [image] 选项。

2) 拾取需延伸的曲线：

拾取一条需延伸的曲线；可以拾取一条单段曲线或一条组合曲线；注意曲线的拾取位置；

3) 拾取目标曲线：

拾取延伸到的目标曲线；可以拾取一条单段曲线或一条组合曲线；

4) 拾取需延伸的曲线：

拾取下一条要延伸的曲线，或单击鼠标右键结束。可重复上面两步将多个曲线延伸到指定的目标边界曲线处。

说明：

曲线延伸是将延伸曲线从与它的拾取位置最近的那个端点处开始延伸，直至与延伸边界曲线相交或相切为止。因此延伸曲线的拾取位置不同，可能有不同的延伸结果。如图4-20所示。

图4-20 延伸曲线的拾取位置对延伸结果的影响 ( [image] 表示曲线的拾取位置)

4.2.4.2 延伸到点

将曲线延伸到指定的点处。

图4-21 延伸到点

实现方法：

（1）启动延伸到点命令；

（2）拾取一条需延伸的曲线；

（3）拾取延伸到的目标点。

* 操作步骤：

1) 启动延伸到点命令：

点击“编辑(E)”->“延伸(E)”菜单项，选择导航工具栏中的 [image] 选项。

2) 拾取需延伸的曲线：

拾取一条需延伸的曲线；可以拾取一条单段曲线或一条组合曲线；注意曲线的拾取位置；

3) 拾取目标点：

拾取延伸到的目标点，参照<2.3 点的输入>。

4) 拾取需延伸的曲线：

拾取下一条需延伸的曲线，或单击鼠标右键结束。可重复上面两步将多个曲线延伸至指定的目标点。

说明：

1、所定义的延伸边界点不一定要在曲线的延长线上，曲线实际延伸到的边界点为所定义的边界点到延伸曲线投影点。

2、延伸曲线将从与其位置最近的那个端点处开始延伸只目标点。因而延伸曲线的拾取位置不同，延伸结果可能不同，如图4-22所示。

图4-22 延伸曲线的拾取位置对延伸结果的影响

4.2.4.3 长度延伸

将曲线延伸一定的长度。

图4-23 长度延伸( [image] 表示曲线的拾取位置)

实现方法：

（1）启动长度延伸命令；

（2）拾取一条需延伸的曲线；

（3）输入延伸长度。

* 操作步骤：

1) 启动长度延伸命令：

点击“编辑(E)”->“延伸(E)”菜单项，选择导航工具栏中 [image] 选项。

2) 拾取需延伸的曲线：

拾取一条需延伸的曲线；可以拾取一条单段曲线或一条组合曲线；注意曲线的拾取位置，曲线将从与其拾取位置最近的那个端点处开始延伸一定的长度。

3) 输入延伸长度：

输入延伸长度，可单击鼠标右键接受括号中的默认值，也可以直接输入长度值后回车。

4) 拾取需延伸的曲线：

拾取下一条需延伸的曲线，或单击鼠标右键结束。可连续进行多次曲线长度延伸。

4.2.4.4 圆弧转为圆

将圆弧变为整圆。

图4-24 圆弧转为圆

实现方法：

（1）启动圆弧转为圆命令；

（2）拾取圆弧。

* 操作步骤：

1) 启动圆弧转为圆命令：

点击“编辑(E)”->“延伸(E)”菜单项，选择导航工具栏中 [image] 选项。

2) 拾取需延伸的圆弧：

拾取要变为整个圆的圆弧，可连续拾取多条圆弧变为整圆，单击鼠标右键结束。


曲线倒角

4.2.2 曲线倒角

曲线倒角包括曲线倒圆角和倒斜角。曲线倒角导航工具栏选项如图4-2所示：

图4-6 曲线倒角导航工具栏选项

参数定义：

两线倒圆角 | 在两条曲线之间进行光滑的圆角过渡；
轮廓倒圆角 | 在一条曲线链上每两个相邻曲线之间进行两两倒圆角；
倒斜角 | 在两条直线之间进行斜角过渡；
倒尖角 | 在两曲线的交点或其延长线的交点处对两曲线进行自动修剪，在它们之间形成一个尖角；
【裁剪曲线】 | 在倒圆角或倒斜角同时，是否对原曲线进行裁剪或延伸。

4.2.2.1 两线倒圆角

在两条曲线之间进行光滑的圆角过渡。

图4-7 两线倒圆角

实现方法：

（1）启动两线倒圆角命令；

（2）输入圆角半径；

（3）拾取两条要倒圆角的曲线。

* 操作步骤：

1）启动两线倒圆 角命令： | 点击“编辑(E)”->“倒角(F)”菜单项； 选择导航工具栏中 [image] 选项。
2）输入圆弧过渡半径： | 输入倒圆角半径，可单击鼠标右键接受括号中的默认值，或直接输入半径值后回车。
3）选择曲线1： | 拾取倒圆角曲线1；拾取的曲线可以为一条单段曲线或一条组合曲线；曲线拾取位置应该落在要保留的曲线段部分。
4）选择曲线2： | 拾取倒圆角曲线2；拾取的曲线可以为一条单段曲线或一条组合曲线；曲线拾取位置应该落在要保留的曲线段部分。
5）选择曲线1： | 拾取倒下一个圆角时的曲线1，或单击鼠标右键结束。可连续在多条曲线之间倒半径相同的圆角。

4.2.2.2 轮廓倒圆角

在一条曲线链上每两个相邻曲线之间进行两两倒圆角。

图4-8 轮廓倒圆角

实现方法：

（1）启动轮廓倒圆角命令；

（2）输入圆角半径；

（3）拾取两条要倒圆角的曲线。

* 操作步骤：

1）启动轮廓倒圆角命令： | 点击“编辑(E)”->“倒角(F)”菜单项； 选择导航工具栏中 [image] 选项。
2）输入圆弧过渡半径： | 输入倒圆角半径，可单击鼠标右键接受括号中的默认值，或直接输入半径值后回车。
3）选择曲线1： | 拾取曲线链上的任意一条曲线。可连续拾取多条曲线来将多个曲线链上的相邻曲线两两倒圆角。单击鼠标右键结束。

4.2.2.3 倒斜角

在两条直线之间进行斜角过渡。

图4-9 倒斜角

实现方法：

（1）启动倒斜角命令；

（2）输入斜角的两个半径值；

（3）拾取两条要倒斜角的直线。

* 操作步骤：

1）启动倒斜角命令： | 点击“编辑(E)”->“倒角(F)”菜单项； 在导航工具栏中选择 [image] 选项。
2）输入倒角半径1： | 输入斜角半径1，可单击鼠标右键接受括号中的默认值，也可直接输入半径值后回车。
3）输入倒角半径2 | 输入斜角半径2，可单击鼠标右键接受括号中的默认值，也可直接输入半径值后回车。
4）拾取直线1： | 拾取要倒斜角的第一条直线，拾取位置应该落在要保留的曲线段部分。
5）拾取直线2： | 拾取要倒斜角的第二条直线，拾取位置应该落在要保留的曲线段部分。
6）拾取直线1： | 拾取倒下一个斜角时的第一条直线，或单击鼠标右键结束。可连续倒多个半径相同的斜角。

4.2.2.4 倒尖角

在两曲线的交点或其延长线的交点处对两曲线进行自动修剪，在它们之间形成一个尖角。

图4-10 倒尖角

实现方法：

（1）启动倒尖角命令；

（2）依次拾取两条要倒尖角的直线。

* 操作步骤：

1）启动倒斜角命令： | 点击“编辑(E)”->“倒角(F)”菜单项； 在导航工具栏中选择 [image] 选项。
2）选择曲线1： | 拾取倒尖角曲线1；可以拾取一条单段曲线或一条组合曲线；曲线拾取位置应落需延伸或需保留的曲线段部分。
3）选择曲线2： | 拾取倒尖角曲线2；可以拾取一条单段曲线或一条组合曲线；曲线拾取位置应落需延伸或需保留的曲线段部分。
4）选择曲线1： | 拾取要倒斜角的第一条直线，拾取位置应该落在要保留的曲线段部分。

曲线倒角参数定义：

【裁剪曲线】

该选项决定了在倒角的同时，是否对原曲线进行裁剪或延伸。

选择此选项，则将原始曲线裁减或延伸至圆角处；不选择此选项，则不对原始曲线进行裁减或延伸。如图4-11所示。

图4-11 【裁剪曲线】选项

说明：

倒角完毕后，生成的倒角将位于所拾取的第一条曲线所在的图层中；拾取的两条倒角曲线经修剪后将仍然位于它们各自的图层中。


曲线等距

4.2.5 曲线等距

绘制曲线在其某一侧的一定距离处的偏移曲线。

曲线等距操作时，导航工具栏中的选项如图4-25所示：

图4-25 曲线等距导航工具栏选项

其中各选项意义如下：

恒定距离 | 等距时，曲线上各点的等距距离值为一恒定值；
变化距离 | 等距时，曲线的首末点偏移距离值不相同；
【定义平面】 | 定义曲线等距时的参考平面。

4.2.5.1 恒定距离等距

将曲线在其某一侧偏移一个恒定的距离值，得到其等距线。

图4-26 曲线等距

实现方法：

（1）启动曲线恒等距命令； （2）输入等距偏移距离；

（3）拾取要偏移的曲线； （4）选择曲线偏移方向。

* 操作步骤：

1) 启动曲线等距命令：

点击“编辑(E)”->“等距(O)”菜单项。

在导航工具栏中选择 [image] 等距选项；

2) 偏移距离：

输入曲线的偏移距离，可单击鼠标右键接受括号中的默认值，也可直接输入距离值后回车。

3) 拾取曲线：

拾取要进行偏移的曲线。可以拾取一条单段曲线或一条组合曲线；

4) 选择偏移方向：

选择要在曲线的哪一侧绘制偏移线，用鼠标点击某一方向箭头，或在曲线的某一箭头指向方向拾取一点即可。

5) 拾取曲线：

拾取下一条要进行等距的曲线，或单击鼠标右键结束。可连续拾取多条曲线绘制它们在某一侧的等距曲线。

4.2.5.2 变化距离等距

将曲线在其某一侧偏移一个变化的距离值(通过定义不同的首末点偏移值)，得到其等距线。

图4-27 变化距离等距

实现方法：

（1）启动曲线变等距命令； （2）分别输入曲线起点和末点偏移距离；

（3）拾取要偏移的曲线； （4）选择曲线偏移方向。

* 操作步骤：

1） 启动曲线等距命令：

点击“编辑(E)”->“等距(O)”菜单项；

在导航工具栏中选择 [image] 等距选项；

2） 起点偏移距离： | 输入曲线在起始端点处的偏移距离，可单击鼠标右键接受括号中的默认值，也可直接输入距离值后回车。
3） 末点偏移距离： | 输入曲线在另一端点处的偏移距离，可单击鼠标右键接受括号中的默认值，也可直接输入距离值后回车。

4） 拾取曲线（拾取点靠近起始端）：

拾取要进行偏移的曲线；可以拾取一条单段曲线或一条组合曲线；注意曲线的拾取位置：系统在等距操作时，将靠近曲线拾取位置的那个端点定义为起始端，另一端定义为终止端；因此，曲线变等距时的起始端和末端与曲线的实际方向无关，只与曲线的拾取位置有关。

5） 选择偏移方向：

选择要在曲线的哪一侧绘制偏移线，用鼠标点击某一方向箭头，或在曲线的某一箭头指向方向拾取一点即可。

6） 起点偏移距离：

定义下一次进行变等距时的起点偏移距离，可连续进行多次的曲线变等距操作；

说明：

曲线等距时的偏移方向和偏移距离是相对于某一参考平面而言的；偏移方向与此参考平面平行，偏移曲线与原曲线在参考平面内的投影保持等距关系；默认情况下，等距参考平面为系统当前绘图平面，曲线的等距是相对于当前绘图面而言的；用户可以点击导航工具栏中的 [image] 按钮，然后来定义空间中任意一平面为本次等距命令操作的参考平面，平面定义方法参照<定义平面>；

对于二维平面曲线，一般是在其自身的平面中进行等距的，可先调整当前绘图平面使其与该曲线平行，也可直接通过点击“定义平面”按钮，然后定义该二维曲线所在的平面为其等距参考平面来对曲线在其自身平面内进行等距；

对于三维空间曲线，必须相对于一参考平面来进行等距；等距曲线同样为一三维空间曲线，等距距离是二者在参考平面内的投影曲线所保持的等距距离。


曲线打断

4.2.1 曲线打断

将一条曲线通过其它与其相交的曲线或点将其分割为两条曲线。

曲线打断导航工具栏选项如图4-2所示。

图4-2 曲线打断导航工具栏选项

参数定义：

曲线打断 | 将给定曲线在与另一相交曲线的交点处进行打断。
单点打断 | 将给定曲线在其上的某一点处进行打断。
曲线等分 | 将给定曲线按长度等分为多条曲线。

4.2.1.1 曲线打断

将给定曲线在与另一相交曲线的交点处进行打断。

图4-3 曲线打断

实现方法：

（1）启动曲线打断命令；

（2）拾取一条要被打断的曲线；

（3）拾取打断曲线。

* 操作步骤：

1）点击菜单项和导航 工具栏中的选项： | 点击“编辑(E)”->“打断(V)”菜单项，选择导航工具栏中的 [image] 选项。
2）拾取被打断曲线： | 拾取一条要被打断的曲线；可以拾取一条单段曲线或组合曲线；
3）拾取打断曲线： | 拾取一条打断曲线；可以拾取一条单段曲线或组合曲线；
4）拾取被打断曲线： | 拾取下一条被打断的曲线，或单击右键结束命令。可重复上面两步对多个曲线进行打断操作。

4.2.1.2 单点打断

将给定曲线在其上的某一点处进行打断。

图4-4 单点打断

实现方法：

（1）启动单点打断命令；

（2）拾取一条要被打断的曲线；

（3）输入打断点。

* 操作步骤：

1）启动单点打断命令： | 点击“编辑(E)”->“打断(V)”菜单项，选择导航工具栏中的 [image] 选项。
2）拾取被打断曲线： | 拾取一条要被打断的曲线；可以拾取一条单段曲线或一条组合曲线；
3）输入断开点： | 输入打断点，参照<点的输入>。此时曲线上有一个红色的箭头指示曲线上打断点的位置，可移动鼠标使红色箭头沿曲线滑动到某一位置处，点击鼠标左键确定此位置点为打断点。
4）拾取被打断曲线： | 拾取下一条要被打断的曲线，或单击鼠标右键结束。可重复上面两步来对曲线进行打断。

说明：

若输入的曲线断开点不在曲线上，则曲线将在该点到曲线的投影点位置处被打断。

4.2.1.3 曲线等分

将给定曲线按长度等分为多条曲线。

图4-5 三曲线等分

实现方法：

（1）启动曲线等分命令；

（2）拾取被等分曲线；

（3）输入等分段数。

* 操作步骤：

1）启动曲线等分命令： | 点击“编辑(E)”->“打断(V)”菜单项，选择导航工具栏中的 [image] 选项。
2）拾取被等分曲线： | 拾取一条要被等分的曲线；被等分的曲线可以为一条单段曲线或一条组合曲线；
3）输入等分的段数： | 输入等分段数，可单击鼠标右键接受括号中的默认值，也可以输入新值后回车。

说明：

拾取的一条曲线被打断后，生成的两条结果曲线将位于其原始曲线所在的图层中，并与原始曲线的颜色、线型和线宽等属性相同。


曲线修剪

4.2.3 曲线修剪

将曲线修剪到由其它曲线或点所定义的边界处。曲线修剪导航工具栏选项如图4-12所示：

图4-12 曲线修剪导航工具栏选项

参数定义：

多线修剪 | 定义一条或多条边界曲线做为剪刀来对原曲线进行修剪；
两线裁剪 | 在两条曲线的交点处同时对这两条曲线进行修剪；
单点修剪 | 修剪或延伸曲线到某一点所定义的边界点处；

4.2.3.1 多线修剪

定义一条或多条边界线做为剪刀来对原曲线进行修剪。

图4-13 多线裁剪( [image] 表示拾取被修剪曲线的拾取位置)

实现方法：

（1）启动多线裁剪命令；

（2）拾取一条或多条裁剪边界线；

（3）拾取要被修剪的曲线。

操作步骤：

1）启动多线裁剪命令： | 点击“编辑(E)”->“修剪(T)”菜单项，选择导航工具栏中的 [image] 选项。
2）拾取边界线1： | 拾取第一条修剪边界曲线。
3）拾取边界线2 （或者右击）： | 拾取第二条修剪边界曲线，或单击鼠标右键结束边界曲线的拾取。可连续定义多条修剪边界曲线。
4）拾取需裁剪的曲线： | 拾取被修剪的曲线，拾取的位置要在曲线被裁剪掉的部分段上。可以拾取多个被修剪的曲线，单击右键结束。

4.2.3.2 两线裁剪

在两条曲线的交点处同时对这两条曲线进行修剪。

图4-14 两线裁剪( [image] 表示曲线的拾取位置)

实现方法：

（1）启动两线裁剪命令；

（2）拾取两条要修剪的曲线。

* 操作步骤：

1）启动两线裁剪命令： | 点击“编辑(E)”->“修剪(T)”菜单项，选择导航工具栏中的 [image] 选项。
2）拾取曲线1： | 拾取要修剪的第一条曲线，拾取位置应落在曲线上要保留的部分。
3）拾取曲线2： | 拾取要修剪的第二条曲线，拾取位置应落在曲线上要保留的部分。
4）拾取曲线1： | 拾取进行下一次两线修剪时的第一条曲线，或单击鼠标右键结束。可连续进行多次两线修剪。

说明：

拾取的两条曲线必须相交，否则两线裁剪操作会失败；若两条曲线的延长线相交，此时若想修剪二者到交点处，请采用<4.2.2.4倒尖角>方法进行。

4.2.3.3 单点修剪

修剪或延伸曲线到某一点所定义的边界处。

图4-15 单点修剪

实现方法：

（1）启动单点修剪命令；

（2）拾取被裁剪的曲线；

（3）拾取边界点。

* 操作步骤：

1）启动单点修剪命令： | 点击“编辑(E)”->“修剪(T)”菜单项； 选择导航工具栏中的 [image] 选项。
2）拾取需裁剪的曲线： | 拾取要被修剪的曲线；可以为一条单段曲线局或一条组合曲线；拾取的位置要落在曲线上要保留的部分处。
3）拾取点： | 拾取边界点，参照<点的输入>。
4）拾取需裁剪的曲线： | 拾取下一条要被修剪的曲线，或单击鼠标右键结束。可连续对多条曲线进行点修剪。

说明：

1、拾取的边界点可能不在被修剪的曲线上，此时曲线实际修剪到的边界点为输入的边界点到曲线的投影点(如图4-16)；

2、根据定义边界点的位置，可能将曲线延伸修剪到该点(如图4-17)，此时可参照< 4.2.4延伸 >> 延伸到点 >。

图4-16 曲线实际被修剪倒的边界点 图4-17 延伸曲线修剪


曲线展平

5.3 曲线展平

将曲线按指定直径的辊筒进行展平变换或者滚绕变换。

图5-29 曲线展平与滚绕

实现方法：

（1）启动曲线展平命令；（2）拾取曲线或曲面对象；（3）调整曲线展平参数。

* 操作步骤：

1）启动曲线展平命令： | 点击“变换(R)”->“曲线展平(W)”菜单项。
2）拾取曲线对象： | 拾取需要展平或者滚绕的曲线对象，可以为单线或者组合曲线。拾取完毕后，单击鼠标右键，进入下一步。
3）调整滚转与展开参数 | 系统弹出“滚转/展开”对话框，如图5-30所示，调整参数后，点击确定，完成曲线的滚转与展开。

图5-30 曲线展平与滚绕对话框

参数定义：

滚转/展开 | 将指定的曲线按滚筒方式进行滚转或者展开处理。
操作 | 移动：将原始曲线变换移动到新的位置。 复制：保留原始曲线，在新的位置生成曲线展开图形。
旋转 | 旋转直径：指曲线按滚筒方式滚动时滚筒的直径。 角度精度：滚筒滚动时角度的分辨精度，以角度为单位，转动一周为360度。
目标图形 | 目标图形有三种类型：直线、样条和点，即曲线按辊筒旋转展开或者按辊筒旋转滚绕变换后生成新的图形类型。 输入角度：用于确定生成目标图形的起始点在辊筒上的分布位置。辊筒转轴为世界坐标系的X轴，以右手法则确定辊筒旋转方向的正向（逆时针方向），世界坐标系Y轴放方向为角度计算的起始位置。

说明：

该功能的应用背景为任意空间曲线的辊筒加工；

系统默认辊筒转轴为世界坐标系的X轴，因此在作图形的变换之前，需要将图形的中心轴线变换到X轴方向；

系统默认辊筒转动方向为逆时针方向（按右手法则），若需要获得反方向的变换曲线，可用曲线调向命令改变曲线方向。


调整方向

5.5 调整方向

调整曲线的方向或曲面的法矢方向。另外还可以调整一条闭合组合曲线的起始点。

图5-35 调整方向

实现方法：

（1）启动调整方向命令；（2）拾取曲线或曲面对象；（3）调整对象方向。

* 操作步骤：

1）启动调整方向命令： | 点击“变换(R)”->“调整方向(D)”菜单项。
2）拾取三维对象： | 拾取曲线或曲面对象，可以为组合曲线或组合曲面。
3）调整对象方向： | 点击导航工具栏（如图5-36）中的 [image] 按钮来对曲线的方向或曲面的法矢方向进行反向。
4）拾取三维对象： | 拾取下一个要调整方向的曲线或曲面，或单击鼠标右键结束。可调整多个曲线或曲面的方向。

图5-36 方向调整导航工具栏选项

参数定义：

反向 | 点击此按钮，可以对当前选择的曲线方向或曲面的法矢方向进行反向；
循环 | 若当前选择的曲面为组合曲面，可以通过点击此按钮在各个曲面之间进行切换来调整每一个曲面法矢方向；
调整起点 | 此选项只对闭合的组合曲线有效，用来调整该组合曲线的起始点；选中此选项，然后用鼠标点击组合曲线中的某一段曲线，系统将把该曲线段上离拾取点最近的那个端点作为本组合曲线的起点，该曲线段将作为组合曲线的首段曲线，屏幕上组合曲线箭头的位置和方向均发生了变化。


图形变换

第五章 图形变换

本章将主要介绍图形的有关变换和类型转换操作，主要包括以下四类操作：

1、基本图形变换，包括平移、旋转、镜像等变换。基本图形变换均是相对于当前绘图平面进行的变换操作；

2、3D空间中的图形变换操作，包括3D平移、3D旋转、3D镜像等变换。这些3D变换均是相对于当前坐标系进行的变换操作；

3、曲线展平操作；

4．图形聚中和图形翻转变换；

5、曲线曲面方向的调整。

6、曲线曲面类型转换。

图形变换的菜单项如图5-1所示：

图5-1 图形变换菜单

菜单项 | 快捷键 | 功能
平移 | Alt + 1 | 相对于当前绘图平面进行平移变换;
旋转 | Alt + 2 | 相对于当前绘图平面进行旋转变换;
镜像 | Alt + 3 | 相对于当前绘图平面进行镜像变换;
倾斜 |  | 相对于当前绘图平面进行倾斜变换;
放缩 | Alt + 4 | 相对于当前绘图平面进行放缩变换;
3D平移 |  | 在三维空间中进行平移变换;
3D旋转 |  | 绕三维空间中任意轴进行旋转变换;
3D镜像 |  | 相对三维空间中任意平面进行镜像变换;
3D放缩 |  | 以三维空间中任意点为放缩中心进行放缩变换;
UCS到UCS |  | 将图形在两个UCS之间进行平移变换;
曲线展平 |  | 将曲线按指定直径的滚筒展平或者滚绕;
图形聚中 |  | 将所选图形与世界坐标系的原点位置进行对齐操作;
图形翻转 |  | 将选择的图形绕世界坐标系的某一坐标轴进行翻转;
调整方向 |  | 调整曲线曲面的方向;
转为样条 |  | 曲线曲面类型转为NURBS样条曲线曲面类型;
并入2D环境 |  | 曲线转为2D平面设计环境中曲线;


3D镜像变换

5.2.3 3D镜像变换

将图形相对于空间任意平面进行镜像变换。

图5-22 3D镜像变换

实现方法：

（1）启动3D镜像变换命令；

（2）拾取要进行镜像的图形；

（3）定义镜像平面；

（4）定义其它镜像参数。

* 操作步骤：

1）启动3D镜像 变换命令： | 点击“变换(R)”->“3D镜像(I)”菜单项。系统弹出3D镜像变换对话框，如图5-23所示；
2）拾取镜像对象： | 拾取要进行镜像的图形对象，有单个拾取、串链拾取和窗口拾取三种拾取方式，参照< 2.1.1拾取与选择>。单击鼠标右键结束镜像图形的拾取。
3）定义镜像平面： | 镜像对象拾取完毕后，单击鼠标右键或直接点击 [image] 按钮，此时按钮呈下压状态 [image] ，提示用户定义镜像平面，定义方法参照<平面定义>；平面定义完毕后，此按钮前的的图标将会由 [image] 变为 [image] 。
4）定义其它镜像参数： | 定义是否保留原始图形选项。
5）结束命令： | 点击对话框中的“确定”按钮结束。

图5-23 3D镜像变换对话框

参数定义：

保留原始图形

确定是否为镜像拷贝；

选择此选项，镜像后将保留原始图形；否则镜像后将删除掉原始图形。

说明：

3D镜像变换是相对于空间中任意平面对图形进行镜像，与当前绘图平面无关。要在当前绘图平面或其平行平面中对图形相对某一对称轴进行镜像变换，请参照<5.1.3 镜像变换>。


3D旋转变换

5.2.2 3D旋转变换

将图形绕空间任意轴进行旋转移动或旋转拷贝。

图5-19 3D旋转

实现方法：

（1）启动3D旋转变换命令； （2）拾取要进行旋转的图形；

（3）定义旋转轴； （4）定义其它旋转参数。

* 操作步骤：

1）启动3D旋转变 换命令： | 点击“变换(R)”->“3D旋转(T)”菜单项。系统弹出变换对话框，如图5-20所示：
2）拾取旋转对象： | 拾取一个或多个要旋转的图形，有单个拾取、串链拾取和窗口拾取三种拾取方式, 参照<2.1.1拾取与选择>；单击鼠标右键结束旋转图形拾取。
3）拾取旋转轴： | 旋转对象拾取完毕后，单击鼠标右键或用鼠标点击 [image] 按钮，此时按钮呈下压状态 [image] ，提示用户定义旋转轴线；有两点和直线两种定义方法； （1） 两点：用鼠标在屏幕上拾取两点，通过这两点确定出旋转轴的位置和方向； （2） 直线：首先拾取一直线，确定出旋转轴的位置，然后选择该直线上一箭头方向，确定出旋转轴的方向； 定义完毕后，“拾取旋转轴”按钮前的图标将会由 [image] 变为 [image] 。
4）定义其它旋转参数： | 在旋转对话框中定义旋转数目、旋转角度等其他参数选项。
5）结束命令： | 点击对话框中的“确定”按钮结束。

图5-20 3D旋转变换对话框

参数定义：

保留原始图形 | 定义该变换是否为旋转拷贝； 选择此选项，旋转变换后将保留旋转原始图形，否则将其删除掉。
数目 | 对原始图形进行连续旋转变换的次数，即变换后原图形旋转拷贝的数目。
角度 | 旋转角度，即对原始图形进行连续旋转变换时，每一次的角度间隔。旋转角度相对于旋转轴方向满足“右手法则”。

说明：

1、所定义的旋转轴可以为空间中任意方向和位置的轴线，与当前绘图平面无关；要相对于当前绘图平面绕某一点对图形进行旋转变换，请参照<5.1.2 旋转变换>；

2、定义多个图形旋转拷贝数目，可以实现图形的圆形阵列。如图5-21所示。

图5-21 圆形阵列


3D放缩变换

5.2.4 3D放缩变换

将图形在3D空间中相对于当前用户坐标系的X、Y和Z三个方向上进行等比例或不同比例的尺寸放缩。

图5-24 3D放缩变换

实现方法：

（1）启动3D放缩变换命令； （2）拾取要进行放缩变换的图形对象；

（3）拾取放缩中心； （4）定义放缩比例和其它参数选项。

* 操作步骤：

1）启动3D放 缩变换命令： | 点击“变换(R)”->“3D放缩(C)”菜单项。
2）拾取放缩对象： | 拾取要进行放缩的图形对象，有单个拾取、串链拾取和窗口拾取三种拾取方式，参照< 2.1.1拾取与选择>；单击鼠标右键结束放缩对象的拾取。
3）拾取参考中心： | 放缩对象拾取完毕后，单击鼠标右键或直接点击对话框中的 [image] 按钮，此时该按钮呈下压状态 [image] ，开始输入变换中心；可以直接输入中心坐标，也可以用鼠标拾取空间中一点来确定。变换中心定义后，该按钮前的 [image] 图标将变化为 [image] ；变换中心不同，放缩后的图形位置不同, 如图5-25。
4）定义放缩比例 和其它参数选项： | 输入放缩后的XYZ尺寸或放缩比例及其它放缩参数和选项。
5）结束命令： | 点击参数选项页中的“确定”按钮结束。

图5-25 放缩中心(图中C点)对变换的影响

参数定义：

3D放缩变换的参数和选项如图5-26：

图5-26 3D放缩变换参数选项

保留原始对象 | 选择此选项，则在放缩变换后保留原始图形；否则，在变换后删除掉原始图形。
保持比例 | 选择此选项，可使放缩对象在世界坐标系的XYZ三个方向上进行等比例放缩变换。
尺寸 (X向、Y向、Z向) | 放缩后图形对象在当前用户坐标系统中XYZ三个方向上的尺寸范围。
比例 (X向、Y向、Z向) | 在当前用户坐标系XYZ三个方向上对图形进行尺寸放缩的百分比(倍数)； 尺寸和比例是相互关联的，调整放缩后尺寸和放缩比例是变换中确定比例因子的两种方法。

说明：

3D放缩变换是对图形在世界坐标系的三个方向上的尺寸进行放缩变换的，与当前绘图平面无关。要对图形相对于当前绘图平面进行放缩变换，请参照<5.1.5 放缩变换>。


图形三维变换

5.2 图形三维变换

图形三维变换包括3D平移变换 、3D旋转变换 、3D镜像变换 、3D放缩变换 和UCS到UCS这五种操作。5.1中介绍的几种变换均是在3D空间中对图形进行变换的。


3D平移变换

5.2.1 3D平移变换

将图形在3D空间中移动或拷贝至新的位置。根据平移量的确定方式不同，可以分为以下三种平移方式：两点平移，沿方向平移和位移平移。

图5-17所示为3D平移变换对话框；

图5-17 3D平移变换对话框

5.2.1.1 两点平移

通过定义平移参考点和目标点来确定出图形平移后的位置；

实现方法：

（1）启动3D平移变换命令； （2）选择沿两点平移选项；

（2）拾取要进行平移的图形； （3）定义平移参考点和目标点；

（4）定义其它平移参数和选项。

* 操作步骤：

1）启动3D平移 变化命令： | 点击“变换(R)”->“3D平移(O)”菜单项。
2) 选择两点平移法选项 | 在平移对话框(图5-16)选择“沿两点平移”选项；
2）拾取要进行平移的图形： | 拾取一个或多个要平移的图形，单击鼠标右键结束拾取。有单个拾取、串链拾取和窗口拾取三种拾取方式，参照<2.1.1拾取与选择>；
3）拾取平移参考点： | 上一步结束后，单击鼠标右键或直接点击 [image] 按钮，此按钮呈下压状态 [image] ，状态栏提示“拾取参考点1：”，用鼠标在屏幕上拾取一点或直接输入参考点坐标后回车；
4）拾取平移目标点： | 状态栏提示：“拾取目标点2：”，用鼠标在屏幕上拾取一点或直接输入目标点坐标后回车；此时“拾取两点”按钮前的图标由 [image] 变为 [image] ，表示平移参考点和目标点定义完毕；
4）定义其它平移参数和选项： | 定义对话框中平移数目和是否保留平移原始图形等参数选项。
5）结束命令： | 点击对话框中的“确定”按钮结束平移操作。

参数定义：

图5-18 3D平移变换参数选项

保留原始图形 | 是否进行平移拷贝； 选择此选项，平移后将保留平移的原始图形，否则将其删除掉。
数目 | 将原始图形进行连续平移的次数，即变换后原始图形平移拷贝的个数。

说明：定义多个平移拷贝数目可以实现图形在某一方向上进行阵列。

5.2.1.2 沿方向平移

通过定义平移的方向和在此方向上平移的距离来确定出平移后的目标位置。平移的方向矢量是通过拾取两个点来定义的。

实现方法：

（1）启动3D平移变换命令； （2）选择沿方向平移选项；

（2）拾取要进行平移的图形； （3）定义平移方向和平移距离；

（4）定义其它平移参数和选项。

* 操作步骤：

1）启动3D平移 变化命令： | 点击“变换(R)”->“3D平移(O)”菜单项。
2) 选择两点平移法选项 | 在平移对话框(图5-16)选择“沿方向平移”选项；
2）拾取要进行平移的图形： | 拾取一个或多个要平移的图形，单击鼠标右键结束拾取。有单个拾取、串链拾取和窗口拾取三种拾取方式，参照<2.1.1拾取与选择>；
3）拾取方向点1： | 上一步结束后，单击鼠标右键或直接点击 [image] 按钮，此按钮呈下压状态 [image] ，状态栏提示用户输入平移方向点1，用鼠标在屏幕上拾取一点或直接输入参考点坐标后回车；
4）拾取平移方向点2： | 用鼠标在屏幕上拾取一点或直接输入点坐标后回车；这两个点就决定了平移的方向矢量；
5）输入长度： | 输入在该方向上平移的距离后回车；此时“拾取两点+长度”按钮前的图标由 [image] 变为 [image] ，表示平移方向和距离已定义完毕。
4）定义其它平移参数和选项： | 定义对话框中平移数目和是否保留平移原始图形等参数选项。
5）结束命令： | 点击对话框中的“确定”按钮结束。

5.2.1.3 位移平移法

通过定义图形在当前用户坐标系中三个坐标轴方向上的平移量来确定出平移后的图形目标位置。

实现方法：

（1）启动3D平移变换命令； （2）选择位移平移选项；

（2）拾取要进行平移的图形； （3）定义平移位移量；

（4）定义其它平移参数和选项。

* 操作步骤：

1）启动3D平移 变化命令： | 点击“变换(R)”->“3D平移(O)”菜单项。
2) 选择位移平移选项 | 在平移对话框(图5-16)选择“指定位移量”选项；
2）拾取要进行平移的图形： | 拾取一个或多个要平移的图形，单击鼠标右键结束拾取。有单个拾取、串链拾取和窗口拾取三种拾取方式，参照<2.1.1拾取与选择>；
3）输入平移量(DX,DY,DZ)： | 图形拾取结束，单击鼠标右键或直接点击 [image] 按钮，此按钮呈下压状态 [image] ，状态栏提示用户输入当前用户坐标系三个轴方向上的位移量，输入DX,DY,DZ（如输入10,0,0 ）后回车；此时“输入平移量”按钮前的图标由 [image] 变为 [image] ，表示平移位移量已定义完毕。
4）定义其它平移参数和选项： | 定义对话框中平移数目和是否保留平移原始图形等参数选项。
5）结束命令： | 点击对话框中的“确定”按钮结束。


UCS到UCS

5.2.5 UCS到UCS

将选定的图形从一个用户坐标系统变换到另外一个用户坐标系统中去。变换前的图形在参考UCS中的位置对应到变换后的图形在目标UCS中的位置。

图5-27 UCS到UCS

实现方法：

（1）启动“UCS到UCS”命令；

（2）拾取要进行变换的图形对象；

（3）拾取参考坐标系和目标坐标系；

（4）定义其它变换参数。

* 操作步骤：

1）启动“UCS到UCS”命令： | 点击“变换(R)”->“UCS到UCS(U)”菜单项。
2）拾取平移对象： | 拾取要进行变换的图形对象，有单个拾取、串链拾取和窗口拾取三种拾取方式，参照< 2.1.1拾取与选择>。单击鼠标右键结束变换对象的拾取。
3）拾取参考UCS： | 拾取参考坐标系，单击鼠标右键。
4）拾取目标UCS： | 拾取目标坐标系。
5）定义其它变换参数： | 定义变换后是否保留原始图形选项，如图5-28所示。
6）结束命令： | 点击对话框中的“确定”按钮结束。

参数定义：

图5-28 UCS到UCS变换参数选项

参考坐标系 | 平移前的图形所对应的坐标系。
目标坐标系 | 平移后的图形所对应的坐标系。
保留原始图形 | 选择此选项，则在平移后保留原始图形； 不选此选项，则平移后将原始图形删除掉。


基本图形变换

5.1 基本图形变换

包括平移变换、旋转变换、镜像变换、倾斜变换和放缩变换五种，它们均是相对于当前绘图平面进行的变换。


镜像变换

5.1.3 镜像变换

相对于当前绘图平面，以某一轴线为对称轴，对选择的图形进行对称映像或对称拷贝。

镜像变换的导航工具栏选项如图5-8所示。

图5-11 镜像变换的导航工具栏选项

参数定义：

水平镜像 | 对图形在水平方向上进行镜像。
竖直镜像 | 对图形在竖直方向上进行镜像。
【复制图形】 | 选择此选项为镜像拷贝，不选择此选项则为镜像移动。

根据绘图平面内的对称轴的角度不同，镜像变换可分为以下三种方式：

任意角度镜像 | 所定义的对称轴在绘图平面或其平行平面内为任意角度方向的直线。
水平镜像 | 对称轴为过图形的中心且与当前绘图平面的水平轴平行的直线。
竖直镜像 | 对称轴为过图形的中心且与当前绘图平面的竖直轴平行的直线。

5.1.3.1 任意角度镜像

通过定义当前绘图平面或其平行平面内任意一角度的直线为对称轴来对选择的图形进行镜像。

图5-12 任意角度镜像变换

实现方法：

（1）选择图形对象； （2）启动镜像命令；

（3）输入基点； （4）输入镜像角度。

* 操作步骤：

1）选择要进行变换 的图形对象： | 在屏幕上选择和拾取要镜像的图形，可拾取多个图形对象。
2）启动镜像命令： | 点击“变换(R)”->“镜像(M)”菜单项。
3）请输入基点： | 定义镜像轴的基点，参照<点的输入>。
4）请输入镜像角度： | 定义镜像轴的角度，可直接输入角度值，也可移动鼠标确定一点，通过基点与这个点之间的方向矢量来定义角度。角度值为从X轴正向逆时针转过的角度。
5）请输入基点： | 定义下一次镜像的基点，或单击右键结束。可对选中的图形进行多次镜像操作。

5.1.3.2 水平镜像

以过图形中心且与当前绘图平面的水平轴平行的直线作为对称轴来对选择的图形在当前绘图平面或其平行平面内进行镜像。

5.1.3.3 竖直镜像

以过图形中心且与当前绘图平面的竖直轴平行的直线作为对称轴来对选择的图形在当前绘图平面或其平行平面内进行镜像。

(a) 水平镜像 (b) 竖直镜像

图5-13 水平镜像和竖直镜像

实现方法：

（1）选择要变换的图形；

（2）启动水平或竖直镜像命令。

* 操作步骤：

1）选择要进行变换 的图形对象： | 在屏幕上拾取要镜像的图形，可拾取多个图形对象。
2）启动水平或竖直镜像命令： | 点击“变换(R)”->“镜像(M)”菜单项，点击导航工具栏中的 [image] 或 [image] 按钮。

参数定义：

【复制图形】

选中该选项，则对图形在对称轴的另一侧进行进行镜像拷贝。不选该选项，则对选择的图形进行镜像移动。

说明：

本命令只能将图形在当前绘图平面或其平行平面内进行镜像变换，变换前后的图形在当前绘图平面的高度方向上的尺寸坐标值不变；要在三维空间中将图形相对于任一平面进行镜像变换，请参照<3D镜像变换>。


旋转变换

5.1.2 旋转变换

相对于当前绘图平面将图形绕一指定点（旋转基点）旋转一定的角度。

图5-8 旋转变换

实现方法：

（1）选择要旋转的图形对象； （2）启动旋转变换命令；

（3）输入旋转基点和参考点； （4）输入旋转角度。

* 操作步骤：

1）选择要旋转的图形对象： | 在屏幕上拾取要旋转的图形，可拾取多个图形对象。
2）启动旋转变换命令： | 点击“变换(R)”->“旋转(R)”菜单项。
3）请输入基点： | 定义旋转基点。参照<点的输入>。
4）请输入参考点： | 定义旋转参考点。参照<点的输入>。
5）请输入旋转角度： | 定义旋转角度。可直接输入角度值，或通过鼠标拾取一点来定义。
6）请输入基点： | 定义下一次旋转的基点，或单击鼠标右键结束。可连续进行多次旋转变换。

参数定义：

导航工具栏中的选项如图5-9所示：

图5-9 旋转变换导航工具栏选项

【复制图形】

是否进行旋转拷贝。选中该选项，可将选择的图形在新的角度位置处进行复制。不选该选项，则对选择的图形进行旋转移动。

说明：

1、旋转基点和参考点定义了旋转变换的0角度方向；旋转角度是绕基点从此0角度方向上逆时针转过的角度，如图5-10所示；

图5-10 旋转角度

2、本命令只能将图形在当前绘图平面或其平行平面内绕旋转基点进行旋转变换，变换前后的对象在当前绘图平面的高度方向上的尺寸保持不变；要在三维空间中将图形绕任意轴进行旋转变换，请参照<3D旋转变换>。


放缩变换

5.1.5 放缩变换

将选择的图形在当前绘图平面的横向、纵向及高度这三个方向上按照一定的比例进行尺寸放大或缩小。

图5-15 放缩变换

实现方法：

（1）选择要变换的图形；（2）启动放缩变换命令；（3）在对话框中定义放缩参数和选项。

* 操作步骤：

1）选择要进行变换 的图形对象： | 在屏幕上拾取要进行放缩的图形，可拾取多个图形对象。
2）启动放缩变换命令： | 点击“变换(R)”->“放缩(S)”菜单项。
3）在对话框中定义 放缩参数和选项： | 在弹出的放缩变换对话框(图5-16)中定义放缩比例因子、放缩中心点及其它参数和选项，点击“确定”按钮。

图5-16 放缩变换对话框

参数定义：

横向尺寸 | 变换后图形在当前绘图平面的横向方向上的尺寸大小
纵向尺寸 | 变换后图形在当前绘图平面的纵向方向上的尺寸大小
高度尺寸 | 变换后图形在当前绘图平面的高度方向上的尺寸大小
横向比例 | 变换前后图形在当前绘图平面的横向方向上的尺寸缩放百分比
纵向比例 | 变换前后图形在当前绘图平面的纵向方向上的尺寸缩放百分比
高度比例 | 变换前后图形在当前绘图平面的高度方向上的尺寸缩放百分比
保持比例 | 选中此选项，则变换时在当前绘图平面的横向、纵向和高度方向上对原图形进行等比例放缩变换。若要进行等比例放缩，先选中该选项，再调整某一方向上尺寸或比例。
复制图形 | 放缩变换同样也有拷贝和移动两种方式。选中此选项为拷贝方式，变换后保留原图形；不选该选项为移动方式，变换后删除原图形。
放缩中心 | 图形的左下角点或中心点，也可以选择[自定义]选项，然后点击“拾取〉〉”按钮，通过点发生器确定一点来作为放缩中心，参照< 点发生器 >。 图形的放缩是相对于当前绘图平面而进行的，因此定义的放缩中心点若不在当前绘图平面内，则将被投影到当前绘图平面上。放缩中心不同，变换后的图形位置不同。

说明：

1、可以对图形在当前绘图面的横向、纵向和高度方向上进行等比例或不等比例的放缩变换。放缩比例因子在对话框中的确定有两种方式：

（1）输入图形变换后在三个方向上的尺寸大小，系统自动计算出比例因子；

（2）以百分比的形式，输入图形在三个方向上的变换比例因子。

对话框中的这两种方式是相互关联的，当在输入三个反向上变换后的尺寸值时，三个方向上的比例值也随着进行变动。反之当输入比例数值时，尺寸数值也会随着变动。

2、定义的放缩中心点均被投影到当前绘图平面上，要采用三维空间放缩点对选择的对象进行放缩变换，请参照< 5.2.4 3D放缩变换>。


倾斜变换

5.1.4 倾斜变换

相对于当前绘图平面，对选择的图形在当前绘图平面的横向和纵向方向上进行倾斜。

图5-14 倾斜变换

实现方法：

（1）选择要变换的图形对象； （2）启动倾斜变换命令；

（3）输入基点和参考点； （4）输入倾斜角度。

* 操作步骤：

1）选择要进行变 换的图形对象： | 在屏幕上拾取要倾斜的图形，可拾取多个图形对象。
2）启动倾斜变换命令： | 点击“变换(R)”->“倾斜(H)”菜单项。
3）请输入基点： | 输入倾斜变换的基点，参照<点的输入>。
4）请输入参考点： | 输入倾斜变换的参考点，参照<点的输入>。
5）请输入倾斜角度： | 输入倾斜角度，可以直接输入角度值，也可以拾取一点来定义。
6）请输入基点： | 输入下一次倾斜变换的基点，或单击右键结束。可连续进行多次变换。

参数定义：

图5-15 倾斜变换导航工具栏选项

【复制图形】

选中该选项，则对图形进行倾斜拷贝。不选中该选项，则对选择的图形进行倾斜移动。

说明：

1、基点和参考点定义了倾斜变换的0角度方向；倾斜角度是绕基点从此0角度方向上逆时针转过的角度(图5-16)；

图5-16 倾斜角度

2、倾斜的基点位置不发生移动。若基点和参考点确定的矢量方向为当前绘图面的竖直方向（纵向）时，则图形沿当前绘图面的水平方向（横向）进行左右倾斜（图5-14 a）；若基点和参考点确定的矢量方向为当前绘图面的水平方向（横向）时，则图形沿当前绘图面的竖直方向（纵向）进行上下倾斜（图5-14 b）；

3、对图形的错切变换是在当前绘图平面或其平行平面内对图形进行变换的，变换前后的图形在当前绘图平面的高度方向上的尺寸值保持不变。


平移变换

5.1.1 平移变换

相对于当前绘图平面将图形从一个位置移动或复制至另一位置。平移变换导航工具栏中的选项如图5-2所示：

图5-2 平移变换导航工具栏选项

参数定义：

距离平移 | 通过定义图形在当前绘图平面的横向、纵向和高度方向上的移动距离来对图形进行平移变换。
【复制图形】 | 选择该选项，可将图形在目标位置上进行复制；否则进行移动。

图形有两种平移方法：两点平移和距离平移。

两 点平移 | 定义平移的基点和移动点，通过这两个点确定的平移方向和距离来进行平移变换。
距离平移 | 通过定义图形在当前绘图平面的横向、纵向和高度三个方向上的偏移量来对图形进行平移变换。

5.1.1.1 两点平移

定义平移的基点和移动点，通过这两个点确定的平移方向和距离来进行平移变换。

图5-3 两点法平移变换

实现方法：

（1）选择要平移的图形； （2）启动平移变换命令；

（3）输入平移基点； （4）输入平移移动点。

* 操作步骤：

1）选择要平移的图形： | 在屏幕上拾取要平移的图形，可拾取多个图形对象。
2）点击菜单项： | 点击“变换(R)”->“平移(L)”菜单项。
3）请输入基点： | 输入平移基点，参照<点的输入>。
4）请输入移动点： | 输入移动点，参照<点的输入>。
5）请输入基点： | 定义下一次平移的基点，或单击鼠标右键结束。可对图形进行多次平移变换。

说明：输入的基点和移动点可以为空间中的任意两点。

5.1.1.2 距离平移

通过定义图形在当前绘图平面的横向、纵向和高度三个方向上的偏移量来对图形进行平移变换。

实现方法：

（1）选择要平移的图形；

（2）启动距离平移命令；

（3）定义图形在当前用户坐标系中的坐标偏移量。

* 操作步骤：

1）选择要平移的图形： | 在屏幕上拾取要平移的图形，可拾取多个图形对象。
2）点击菜单及导航 工具栏按钮： | 点击“变换(R)”->“平移(L)”菜单项，点击导航工具栏中的 [image] 按钮。
3）定义图形在当前用户坐标系中的坐标偏移量： | 在对话框（图5-4）中定义图形在当前绘图平面的横向、纵向和高度方向上的偏移距离，然后点击“确定”按钮。可直接输入偏移距离，也可点击“拾取〉〉”按钮通过“长度-距离发生器”来定义，参照<长度-距离发生器>。

图5-4 图形偏移量定义对话框

参数定义：

【复制图形】

是否要进行平移拷贝。选中该选项，可将选择的图形在目标位置上进行复制。不选该选项，则将选择的图形移动到目标位置。

说明：

在当前坐标系下，三个坐标平面均可以互相切换来做为当前绘图平面，每一个绘图面都有各自的横向、纵向和高度方向的定义：

Ø 当前绘图面为当前坐标系的XOY面时：横向正向为X轴正向，纵向正向为Y轴正向，高度正向为Z轴正向，如图5-5所示；

图5-5 XOY绘图面的横向、纵向和高度方向

Ø 当前绘图面为当前坐标系的XOZ面时：横向正向为X轴正向，纵向正向为Z轴正向，高度正向为Y轴负向，如图5-6所示；

图5-6 XOZ绘图面的横向、纵向和高度方向

Ø 当前绘图面为当前坐标系的YOZ面时：横向正向为Y轴正向，纵向正向为Z轴正向，高度正向为X轴正向，如图5-7所示；

图5-7 YOZ绘图面的横向、纵向和高度方向


图形聚中

5.4.1 图形聚中

通过将所选图形的某一特征点（即其包围盒的某一特征点）对齐到世界坐标系的原点位置来对图形进行快速移动和聚中对齐操作。

图5-31 图形聚中

实现方法：

（1）选择要进行聚中的图形；（2）启动图形聚中命令；（3）定义图形聚中参数。

* 操作步骤：

1）选择要进行聚中的图形： | 拾取或选择要进行聚中操作的曲线或曲面图形对象；
1）启动曲线展平命令： | 点击“变换(R)”->“图形聚中(V)”菜单项。
2）定义图形聚中参数： | 在系统弹出的对话框(图5-32)中定义所选图形在XYZ三个轴方向上的特征点与世界坐标系的原点的对应聚中方式；点击“确定”按钮后结束；

图5-32 图形聚中对话框

参数定义：

X轴对齐 | 定义所选图形（或其包围盒）在X轴方向的特征点与世界坐标系的原点的对齐方式： 左边聚中：X轴方向上的最小特征点与坐标原点对齐； 中心聚中：X轴方向上的中点与坐标原点对齐； 左边聚中：X轴方向上的最大特征点与坐标原点对齐；
Y轴对齐 | 定义所选图形（或其包围盒）在Y轴方向的特征点与世界坐标系的原点的对齐方式： 上部聚中：Y轴方向上的最大特征点与坐标原点对齐； 中心聚中：Y轴方向上的中点与坐标原点对齐； 下部聚中： Y轴方向上的最小特征点与坐标原点对齐；
Z轴对齐 | 定义所选图形（或其包围盒）在Z轴方向的特征点与世界坐标系的原点的对齐方式： 顶部聚中：Z轴方向上的最大特征点与坐标原点对齐； 中心聚中：Z轴方向上的中点与坐标原点对齐； 底部聚中：Z轴方向上的最小特征点与坐标原点对齐；

说明：

该功能常常用于在生成刀具路经前，将从外部输入的IGES文件中曲面模型首先进行快速地聚中变换操作，这样将会方便后续的操作和刀具路径的输出。


图形聚中和翻转

5.4 图形聚中和翻转

图形聚中和翻转是通过对选择的图形与世界坐标系的原点或某一轴线进行变换操作从而实现对图形的快速移动和旋转。


图形翻转

5.4.2 图形翻转

将选中的图形绕世界坐标系的某一坐标轴旋转180°或90°以进行翻转。

图5-33 图形翻转

实现方法：

（1）选择要进行翻转的图形；（2）启动图形翻转命令；（3）定义图形翻转轴。

* 操作步骤：

1）选择要进行翻转的图形： | 拾取或选择要进行聚中操作的曲线或曲面图形对象；
1）启动曲线翻转命令： | 点击“变换(R)”->“图形聚中(V)”菜单项。
2）定义图形翻转轴： | 在系统弹出的对话框(图5-34)中选择世界坐标系的某一坐标轴作为所选图形的翻转轴及其翻转角度；点击“确定”按钮后结束；

图5-34 图形翻转对话框

参数定义：

绕X轴方向翻转

绕Y轴方向翻转

绕Z轴方向翻转

选择世界坐标系的某一坐标轴(X轴、Y轴或Z轴)为图形翻转轴；

设定翻转角度；


曲线曲面类型转换

5.6 曲线曲面类型转换


转为2D环境曲线

5.7.2 转为2D环境曲线

将3D曲面造型环境中的曲线转换为JDPaint 2D平面设计环境中的曲线。

实现方法：

（1）选择要转换的曲线； （2）启动转换命令； （3）设置转换选项。

* 操作步骤：

1）选择要转换的曲线： | 可以选择多条曲线来进行转换。
2）启动转换命令： | 点击“变换(R)”->“并入2D环境(G)”菜单项。
3）设置转换选项： | 在弹出的对话框(图5-38)中设置转换选项，点击“确定”按钮结束。

图5-38 转为2D曲线对话框

参数定义：

删除当前图形对象 | 选择此选项，则在转换后将当前转换曲线删除。
将空间曲线转为平面 曲线(3D->2D) | 选择此选项，则曲线转换为2D环境中的2D平面曲线类型；不选择此选项，则曲线转换为2D环境中的3D曲线类型。


转为样条

5.7.1 转为样条

将曲线对象转化为NURBS样条曲线对象，如将直线、圆弧、三维折线、等距线和组合曲线等曲线对象转化为NURBS样条曲线对象；将曲面对象转化为NURBS样条曲面对象，如将标准曲面、拉伸面和旋转面等曲面对象转化为NURBS样条曲面对象。

图5-37 圆弧转为样条

实现方法：

（1）启动转为样条命令； （2）拾取曲线或曲面。

* 操作步骤：

1） 启动转为样条命令： | 点击“变换(R)”->“转为样条(N)”菜单项。
2）拾取几何曲面或曲线： | 拾取要转换的曲线或曲面对象，可拾取多个曲线曲面对象，单击鼠标右键结束。

说明：

1、该操作可以将一条光滑的组合曲线转化为一条NURBS曲线。对于不光滑的组合曲线，则将该组合曲线中的各曲线段分别转化为一条NURBS曲线；

2、将本命令不适用于将组合曲面转为NURBS曲面，要将组合曲面转为NURBS曲面，请先对其进行炸开再分别进行转换。

为什么提供该功能：

1、由于三维折线不光滑连续，应用该曲线进行曲面造型之前，有必要让其转化为一条光滑连续的参数曲线；

2、三维折线和等距线在系统中均没有提供充分的编辑功能，要编辑该类曲线，可将其转化为光滑连续的参数曲线后，再进行其他编辑处理；

3、标准曲面、拉伸面和旋转面等类型曲面，本身不能进行曲面控制顶点编修，需转化为NURBS曲面后才能进行曲面控制点编修；

4、曲线曲面转化为NURBS曲线曲面后，具有NURBS曲线曲面的所有特性。


标尺显示

9.1 标尺显示

通过系统上的水平和垂直标尺，可以了解图形对象的大致位置和尺寸。当我们选中一些图形，状态条就会提示被选中图形的类型、数量和名字。

图 9-1 标尺与对象提示

状态条提示内容包括如下：

被选对象的个数 | 提示选择了几个对象，这里提示为“1个对象被选择”。
类型 | 被选对象的类型，类型显示只对单选时有效，选择一个以上的对象后就不再显示类型，这里显示为“样条曲面”。
尺寸 | 被选对象的空间尺寸。


测量图形

第九章 测量图形

为了得到图形的精确尺寸，在图形编辑变换的过程中就需要知道它的尺寸大小。在模型构造过程中还需要随时了解已生成的图形对象的各种属性。SurfMill提供有三种方法来查看图形的尺寸大小等属性信息，分别是：

标尺显示

查看属性

测量功能。


查看图形属性

9.2 查看图形属性

9.2.1 查看单个图形的属性

选中一个图形，点击右键，弹出如图9-2所示导航菜单。

图 9-2 右键弹出菜单

用鼠标点击“对象属性(O)”菜单项，弹出“属性”对话框，如图9-3所示。

图 9-3 对象属性常规页对话框

1）“常规”标签页

“常规” 标签页显示了图形的坐标范围、尺寸及中心等参数：

坐标范围 | 图形在X、Y、Z三个方向的坐标范围，也就是各坐标的最小和最大值。
尺寸及中心 | 显示了图形在坐标系中的位置及尺寸。DX、DY、DZ表示图形在X、Y、Z三个方向的尺寸，CX、CY、CZ表示图形包围盒中心点的坐标值。
坐标系 | 选择“世界坐标系坐标”选项时各坐标参数采用世界坐标系表示。选择“系统当前坐标系”选项时各坐标参数采用系统当前坐标系表示。

2）“属性” 标签页

点击对话框中的“属性” 标签，又弹出如图9-4所示的“属性” 标签页。

图 9-4 对象属性页对话框

显示了这个图形的名称、类型、属性、图层、定义参数等对象信息。对于不同的对象类型，系统显示的定义参数也各不相同。

9.2.2 查看多个图形的属性

选中多个图形，查看它们的属性，如图9-5所示。

图 9-5 查看多个对象属性

弹出如图9-6所示对话框，只显示“常规”标签页，标签页中显示图形组的位置和尺寸大小。

图 9-6 对象属性页对话框


坏面检查

如果曲面的某些部位存在法矢突变的情况，可能会给加工带来不利的影响，因而称之为“坏面”，如下图所示。“坏面检查”功能可以找出存在突变法矢的“坏面”，并用红色将其标识出来。

存在突变法矢的“坏面”

* 操作步骤：

1） 选择菜单项： | 点击菜单“测量→曲面→坏面检查”。
2） 拾取曲面 | 拾取要进行检查的曲面
3） 右键确认 | 拾取完毕，点击右键。系统对已被选中的曲面进行检查，并用红色将“坏面”标识出来
4）继续检查 | 系统提示“拾取曲面”，可以继续拾取曲面进行检查，也可点击右键退出。


测量曲率

测量曲线或曲面的最大和最小曲率半径。该功能可以为加工时选择刀具半径提供参考。

1．测量曲线曲率半径

* 操作步骤：

1） 选择菜单项： | 点击菜单“测量→曲线→曲率半径”。
2） 拾取曲线 | 拾取要进行检查的曲线。
3） 右键确认 | 拾取完毕，点击右键。系统显示曲线的最大和最小曲率半径。
4）继续测量 | 系统提示“拾取曲线”，可以继续拾取曲线进行测量，也可点击右键退出。

2．测量曲面曲率半径

* 操作步骤：

1） 选择菜单项： | 点击菜单 “测量→曲面→曲率半径”。
2） 拾取曲面 | 拾取要进行检查的曲面。
3） 右键确认 | 拾取完毕，点击右键。系统显示曲面的最大和最小曲率半径。
4）继续测量 | 系统提示“拾取曲面”，可以继续拾取曲面进行测量，也可点击右键退出。


测量三点角度

9.3.7 测量三点角度

* 操作步骤：

1） 选择菜单项： | 点击菜单“测量（M）→三点角度（T）”。
2） 依次拾取三点： | 点击“测量三点角度”命令后，鼠标指针变为“ [image] ”形状，如图9-15所示。 提示条提示“测量三点角度：拾取点1：”，用鼠标点击输入第一点（点A）； 提示条提示“测量三点角度：拾取点2：”，用鼠标点击输入第二点（点B）； 提示条提示“测量三点角度：拾取点3：”，用鼠标点击输入第三点（点C）。

图 9-15 测量三点角度

3）继续测量：

此时，“测量结果”对话框显示此三点的角度，并且提示条提示“拾取点1：”继续测量：


测量两线夹角

9.3.5 测量两线夹角

* 操作步骤：

1） 选择菜单项： | 点击菜单“测量（M）→两线角度（W）”。
2） 拾取第一根直线： | 点击“两线角度”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量两线角度：拾取直线1：”，用鼠标点击第一条直线，直线变为绿色，如图9-13所示。

图 9-13 测量两线夹角

3） 拾取第二 根直线： | 接着提示条提示“测量两线角度：拾取直线2：”，用鼠标点击第二条直线。
4）继续测量： | “测量结果”对话框显示这两条直线的夹角，并且提示条提示“拾取第一条直线”继续测量两直线之间的夹角。


测量圆弧角度

9.3.6 测量圆弧角度

* 操作步骤：

1） 选择菜单项： | 点击菜单“测量（M）→圆弧角度（A）”。
2） 拾取圆弧： | 点击“测量圆弧角度”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量圆弧角度：拾取圆弧：”，用鼠标点击所要测量的圆弧，如图9-14所示，这里我们测量两直线之间圆弧。

图 9-14 测量圆弧角度

3）继续测量：

被测量的圆弧变为绿色，此时，“测量结果”对话框显示此圆弧的圆心坐标、半径以及圆心角的大小，并且提示条提示“拾取圆弧”继续测量：。


测量面积

9.3.8 测量面积

* 操作步骤：

1） 选择菜单项：

点击菜单“测量（M）→曲面（S）→面积（A）”。

2） 拾取曲面：

点击“测量面积”命令后，提示条提示“测量面积：拾取曲面：”，用鼠标点击所要测量的曲面，如图9-16所示，这里测量一个球面的面积。

图 9-16测量面积

3）继续测量：

用鼠标点击图形后，即可完成测量，“测量结果”对话框显示该曲面的面积，并且提示条提示“拾取曲面”继续测量曲面的面积：


测量尺寸

9.3.4 测量尺寸

* 操作步骤：

1） 选择菜单项： | 点击菜单“测量（M）→尺寸（Z）”。
2）拾取要测量尺寸的图形： | 点击“测量尺寸”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量尺寸：拾取图形：”，使用单选或框选的方法，选中整个要测量尺寸的图形，如图9-12所示。

图 9-12 测量尺寸

3）继续测量：

“测量结果”对话框显示被选图形或图形组的长、宽、高，并且提示条提示“拾取图形”继续测量图形尺寸：


测量距离

9.3.2 测量距离

* 操作步骤：

1） 选择菜单项： | 点击菜单“测量（M）→距离（D）”。
2） 捕捉第一个点： | 点击“测量距离”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量距离：输入点1：”，使用“捕捉特征点的方法”捕捉要测量距离的第一点，如图9-9所示，这里捕捉圆的圆心点。捕捉到圆心后，点击左键。

图 9-9 输入第一点

3）捕捉第二个点：

提示条提示“测量距离：输入点2：”，使用“捕捉指定特征点的方法”捕捉矩形的右下角点，点击左键，如图9-10所示。

图 9-10 输入第二点与测量结果对话框

4）继续测量：

“测量结果”对话框显示这两点之间的距离，并且提示条提示“拾取第一点”继续测量两点之间的距离。


测量功能

9.3 测量功能

通过“状态条显示”和“查看图形属性”的方法只能得到图形的长、宽、高等尺寸，但是如果想查看图形的某一点的位置，两点之间的距离、图形的长度、角度，圆弧的半径、弧度等，就必须使用“测量”工具，点击“测量（M）”弹出如图9-7所示下拉菜单。

图 9-7 测量功能

参数定义：

点 | 测量某一点的位置坐标。
距离 | 测量两点之间的距离。
曲线-->长度 | 测量曲线的长度。
尺寸 | 测量图形的长、宽、高等尺寸。
两线角度 | 测量两直线的角度。
圆弧角度 | 测量圆弧的角度、半径等信息。
三点角度 | 测量三点的角度，即角（A，B，C）。
曲面-->面积 | 测量曲面的面积。


测量长度

9.3.3 测量长度

* 操作步骤：

1） 选择菜单项： | 点击菜单“测量（M）→曲线（C）→长度（L）”。
2） 拾取曲线： | 点击“测量长度”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量长度：拾取曲线：”，用鼠标点击所要测量的曲线，如图9-11所示，这里测量一条样条曲线的长度。

图 9-11 测量长度

3）继续测量：

用鼠标点击图形后，即可完成测量，“测量结果”对话框显示显示这条曲线的长度，并且提示条提示“拾取曲线”继续测量曲线的长度：。

“测量长度”命令可以应用于测量任何形式的曲线，包括圆和椭圆、闭合图形。


测量点坐标

9.3.1 测量点坐标

* 操作步骤：

1） 选择菜单项： | 点击菜单“测量（M）→点（P）”。
2） 捕捉要测量的点： | 点击“测量点”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量点：输入点：”，使用捕捉特征点的方法捕捉要测量坐标的点，如图9-8所示，这里捕捉圆的圆心点。捕捉到点以后，点击鼠标左键，即可完成测量。
3）继续测量点： | “测量结果”对话框中提示该点的坐标值。状态条提示“输入点：”此时可以继续测量点。

图 9-8 测量点坐标


统计

9.3.9 统计

点击“测量（M）→统计（V）”命令后，系统对当前模型的尺寸﹑坐标范围﹑中心以及图形对象的种类和数量进行统计，并在对话框中显示出统计结果，如图9-17所示。

图 9-17 统计


输入输出

第十章 输入输出

数据的“输入”是将其他软件生成的数据文件，读入SurfMill中，成为SurfMill可以使用的数据。数据的“输出”是将SurfMill图形数据或刀具路径参数转换输出成其它软件可读取的文件。SurfMill的文件输入/输出功能，使得SurfMill能够充分利用其它软件所做的设计，增强了SurfMill与其它软件的数据共享能力，大大地延伸了SurfMill的功能。

SurfMill可支持的输入/输出的文件类型有：

类型 | 文件格式 | 输入 | 输出
三维图形 | VRML Files (*.wrl) 虚拟现实造型语言文件 |  |
 | DXF3D Files (*.dxf) |  |
 | IGES Files (*.igs) |  |
 | STL Files (*.stl) |  |
加工数据 | GCode Files(*.nc) 数控加工G代码文件 |  |
 | En3d Files (*.eng) 精雕雕刻文件 |  |
系统文件 | JDPaint Files(*.jdp) 精雕设计文件 |  |
 | En3d Files (*.eng) 精雕雕刻文件 |  |

文件“输入”与文件“打开”不同：文件“输入”不破坏当前的工作环境，新输入的数据与原设计并行存在，输入的数据独立成块不影响原设计数据；而“打开文件”同开始一个新设计一样，破坏当前的工作环境，然后将工作环境全部交给新打开的图形数据。

文件的输入/输出命令由“文件(F)”菜单下的“输入(I)”/“输出(E)”菜单项完成。

图 10-1 输入/输出菜单命令


文件的输出

10.3文件的输出

用户使用SurfMill软件设计的图形，若要在其他软件系统中使用，应将设计数据输出，生成可供其他软件系统读入的图形数据文件。

进行文件输出时，往往要针对特定的输出软件指定文件的一些格式参数。

SurfMill可以将系统中的曲线曲面等图形对象输出为IGES文件。


加工数据的输入

10.1加工数据的输入

1 、EN3D文件

En3d 文件是精雕机专用的加工指令文件，包括刀具名称、加工路径等加工信息，文件扩展名是ENG。该输入接口可以读取JDPaint和SurfMill生成的En3d文件。

2 、Excellon文件

Excellon文件是印刷电路板行业专用的加工指令文件，包括刀具、钻孔、切边等加工信息，文件的扩展名是DRL。


三维图形的输入

10.2三维图形的输入

1 、DXF3D文件

DXF 文件通常用于表示平面的图形，其实，DXF也可以表示三维的图形，这时，我们称之为DXF3D。SurfMill可以读取DXF3D表示的点、直线、圆弧、圆、椭圆、样条曲线、多义线、块，三角片和网格曲面，不能读取其中的实体数据。图层信息也不能读入。

SurfMill支持从AutoCAD12.0到AutoCAD2000生成的DXF文件。

选择输入的文件名后，系统弹出“DXF3D文件输入”对话框，如图10-2所示。

图10-2 DXF3D文件输入对话框

参数定义：

输入类型 | 对话框中列出了系统可以输入的图形对象类型，用户可以根据需要去掉一些不感兴趣的对象类型。
尺寸单位 | DXF图形文件本身是不包含尺寸单位信息的，因此读入时需要指定图形文件的尺寸单位，要保证输入图形尺寸与输出前一致，所选择的输入尺寸单位必须与输出尺寸单位一致。当输入的图形尺寸很大而导致图形无法正常读入时，可以采用“自定义比例” 选项，并输入一个较小的比例值。

2 、IGES文件

IGES文件是CAD系统之间交换几何数据的常用文件格式，SurfMill可以读取IGES文件，在其基础上进行设计或数控加工。

IGES 文件可以描述几乎所有的几何曲线曲面，但不同的CAD系统根据自身的需要，一般只能支持其中的一部分类型。

SurfMill的IGES输入接口可以接受下面这些几何元素类型：圆弧(100)、组合曲线(102)、直线(110)、样条曲线(112)、变换矩阵(124)、NURBS曲线(126)、样条曲面(114)、直纹曲面(118)、旋转曲面(120)、扫描曲面(122)、NURBS曲面(128)、裁剪曲面(140)、等距曲面(144)等。

选择输入的文件名后，系统弹出“IGES文件输入”对话框，如图10-3所示。

参数定义：

图10-3 Igs 文件输入

[输入曲面] | 选项允许输入文件中的曲面类型，不选时，系统将忽略曲面类型。
[输入曲线] | 选项允许输入文件中的曲线类型，不选时，系统将忽略曲线类型。
[输入空间曲面] | 选项允许保留曲线的高度 ，不选时，系统将空间曲线转换成平面曲线。
[曲面精度] | 参数指用网格曲面逼近各种曲面的精度。
[曲线精度] | 参数指用折线段逼近各种曲线的精度。
〖文件搜索〗 | 按钮用于浏览IGES文件，完成后，在列表框中会提示文件名称、单位、曲线数目和类型、曲面数目和类型等等。
[提示输入进度] | 选项打开提示对话框，提示当前的输入进度。

3 、VRML文件

VRML格式可以用于表示各种复杂的曲面模型，它是网络上描述几何模型的常用文件格式，许多CAD系统都可以输出VRML文件。VRML 经过多年的发展，产生了多个版本，SurfMill可以读取 VRML 2.0版。

VRML图形文件本身是不包含尺寸单位信息的，因此读入时需要指定文件图形的尺寸单位。

4 、STL图象文件

STL 文件用于快速成形系统，它由一批三角片构成，可以逼近各种曲面和实体模型。STL文件有二进制和文本表示两种格式，SurfMill软件可以读取两种文件格式。


北京精雕科技有限公司 版权所有 翻印必究

第十章 输入输出

-252-

-251-

-249-