欢迎使用精雕软件

JDPaint是精雕科技多年来一直致力研制开发的、具有自主版权的、功能强大的专业雕刻CAD/CAM软件。JDPaint是精雕CNC数控雕刻系统正常运作的保证，也是有效提高CNC雕刻系统使用效率和产品质量的源泉。

JDPaint专业雕刻软件经过多年的发展完善，功能日趋丰富强大，不仅突破了如曲面浮雕、等量切削等多项关键雕刻设计及加工技术，也充分保证了软件产品的易用性和实用性，极大地增强了精雕CNC雕刻机的加工能力和对雕刻领域多样性的适应能力。在应用领域上，JDPaint软件已经彻底突破了适合标牌、广告、建筑模型等较为传统的雕刻应用范畴，在技术门槛更高的工业雕刻领域，如滴塑模、高频模、小五金、眼镜模、紫铜电极等制作业，表现同样出色，成为国内最优秀的雕刻软件。

目前，JDPaint已由较为单一的雕刻设计加工软件，逐步走向面向CNC产品加工的一整套解决方案。

产品服务:

精雕科技网址 www.jingdiao.com

问题反馈E-mail： soft@jingdiao.com

软件开发部电话：010-60803959, 010-60803960

精雕科技总机： 010-60801188

销售热线：010-51922006/7　　E-mail：market@jingdiao.com


例子

1.虚拟雕塑造型方法之三----扫描.描图.设计.编修(鹿形公仔)

2.虚拟雕塑造型方法之三----扫描.描图.设计.编修(米老鼠公仔)

3.虚拟雕塑造型方法之三----扫描.描图.设计.编修(狮子头公仔)

4.虚拟雕塑造型方法之三----扫描.描图.设计.编修(相框)


虚拟雕塑作品选集

001 (赵丹)

002 (赵丹)

003 (赵丹)

004 (赵丹)

005 (赵丹)

006 (赵丹)

007 (赵丹)

008 (丛灵丹)

009 (丛灵丹)

010 (丛灵丹)

011 (丛灵丹)

012 (丛灵丹)

013 (丛灵丹)

014 (崔雪)

015(崔雪)

016(崔雪)

017 (崔雪)

018 (崔雪)

019 (崔雪)

020 (崔雪)

021 (丁旭)

022 (丁旭)

023 (刘凤强)

024 (刘凤强)

025 (刘凤强)

026 (秦龙君)

027 (秦龙君)

028 (宋开靖)

029 (宋开靖)

030 (王淑民)

031 (王淑民)

032 (王淑民)

033(王淑民)

034(王双)

035(王双)

036(魏代胜)

037(魏代胜)

038(魏代胜)

039(魏代胜)

040(魏代胜)

041(杨公彧)

042(杨公彧)

043(杨公彧)

044(杨公彧)

045(杨公彧)

046(杨公彧)

047(杨公彧)

048(杨公彧)

049(杨公彧)

050(杨公彧)

051(杨公彧)

052(杨公彧)

053(杨公彧)

054(杨公彧)

055(杨公彧)

056(杨公彧)

057(杨公彧)

原始模型 058(杨忱)

058(刘颖蝉)

059(谢朝清)

060(唐翠)

061(唐翠)

062(唐翠)

063(唐翠)

064(杨春)

065(杨春)

066(杨春)

067(杨春)

068(杨春)

069(杨春)

070(随海然)

071(随海然)

072(随海然)

073(随海然)

074(随海然)

075(张建友)

076(杜慎杰)

077(冯祥)

078(冯祥)

079(马新刚)

080(马新刚)

081(张海玉)

082(张海玉)

083(张海玉)

084(张海玉)

085(张海玉)

086(肖锋华)

087(肖锋华)

088(肖锋华)

089(肖锋华)

090(武艳杰)

091(罗良丰)

092(罗良丰)

093(罗良丰)

094(罗良丰)

095(刘峻峰等----测量编修)

096(刘峻峰等----测量编修)

097(刘峻峰等----测量编修)

098(肖锋华等----测量编修)

099(马新刚等----测量编修)


虚拟雕塑造型方法之一----测量数据编修(铁艺)

1. 扫描（当然精度越高越好，但高精度需要高精度的扫描仪与较长的扫描时间），这里采用Roland的机械扫描仪，使用的扫描网络间距1mm，扫描时间约14小时。

2. 通过格式转换输入Jdpaint中，这里我采用的stl格式。（如图1原始曲面）

3. 对扫描数据进行调整，包括镜象、居中、将曲面最低点置零、网格曲面重构（注意重构精度，可以根据要求的高低、曲面的大小、计算机的性能等选择此参数，我在这里选择0.2mm）等，总之使调整后的曲面适合在虚拟雕塑中操作。（如图2。调整后的曲面）

4. 进入虚拟雕塑中，首先设置模型属性，重做次数10.

5. 用冲压工具将曲面轮廓以外的部分压平（如图3.背景压平后的印第安人）。

6. 使用磨光中的仅去高将模型中的过大的失真点还原（如图4）

7. 羽毛的还原。

a) 使用冲压工具将羽毛中失真过大的位置压平。

b) 用多义线钩出数据丧失部分的曲面轮廓，（对于没有美工基础的人可以通过二维描图的方法实现）。（如图5羽毛轮廓再生）。

c) 使用推移命令恢复羽毛的轮廓。

d) 然后可以通过堆料、去料、磨光等 方法将羽毛作得更加逼真。（如图6）

e) 对于曲面的另一侧则可以用去高磨光的方法，尽量减少整体形状的损失，后使用堆料与去料将整体形状修整好，再使用堆料修出羽翼（注意使用不同形状的刷子将得到不同的结果，即便使用相同形状的刷子，也要注意不同参数对细节形状的影响。例如高斯刷子中的半衰直径对细节的影响就十分大，较小的半衰将产生成十分尖的峰和谷，而较大的半衰直径将产生较平滑的凸起。因此对一与二处虽匀使用了堆料但其半衰直径是有较大变化的。）

8. 发线的还原。

a) 从上图中我们可以看到发线的整体形状保留得比较好因此我们只要对发梢部分做一些处理就可以了。

b) 首先我们将发梢部分压平。将压平部分及其部分边缘涂色。

c)

d) 使用逆时针外螺旋变形长出发梢。

e)

f) 同样方法生成另外两个发梢

g) 使用磨光、堆料、去料修整。

9. 胡须的还原。

a) 胡须还原的方法与发线类似

b) 用涂色工具将某处胡须涂上色，并使用特征工具将其复制到头发下方，取代原有图形。

c)

10. 整体还原。其它细节的还原可以使用磨光，使表面光滑，再使用堆料与去料恢复其棱角。


虚拟雕塑造型方法之一----测量数据编修(木雕01)

1. 将扫描好的文件输入到Jdpaint5.0中。

2.

3. 对网格的位置，格式，精度，步长等做适当的调整使之适合在虚拟中修改。

将网格曲面移到原点位置附近，使用曲面重构命令，使网格曲面适合在虚拟雕塑中进行操作。注：有时我们希望曲面的基面能大一些以便我们可以做一些其它操作，我们可以先生成一曲面，然后将两曲面同时选中进行曲面重构。

重构结果：

4. 进入虚拟雕塑后，设置模型的重做次数和模型的Z向尺寸范围。注意：重做次数一定不要设置太大。重做次数直接影响计算内存的使用量（命令位置：选项->模型属性）。模型的Z向尺寸范围要根据模型的实际尺寸设定。（命令位置：选项->限高保低）。这里我们把重做次数设置为5，根据模型的高度我们把模型的Z向尺寸范围定为0-25。

注：在模型属性中可以找到与模型相关的属性，如：模型尺寸，模型步长，还有一些最长用的基本操作所使用的快捷键，如：刷子尺寸的缩放’a’、’s’，半衰直径的缩放’d’、’f’，显示精度的变换’c’等(显示精度直接影响显示的速度)。

5. 对轮廓边缘的处理。在本例中使用先将步长调小到0.1，再做8-12次整体磨光。

注意：整体磨光受到步长的影响较大。步长越大，造成的失真越大，步长越小，整体磨光所用的时间越长。受以上两点限制，整体磨光的使用并不广泛，但使用得当可大大加快模型复原的速度。下面两图为步长为0.5的磨光三次与步长0.1的磨光10次的效果。

步长为0.5的磨光三次 步长0.1的磨光10次

6. 深沟的处理。（注意：磨光的使用技巧，刷子尺寸的选择、磨光位置的选择、磨光时鼠标走向的控制）

a) 首先使用磨光中的仅补低磨光将沟的大致形状修出，下图为磨光后的深沟的边缘，它缺少轮廓边缘应有的棱角。

b) 减小堆料中半衰直径到0.1，对边缘区域进行堆料同，注意要将边缘区域的棱角堆出。

c) 使用磨光，注意磨光的位置及走向。

注：在棱角处的磨光。 在棱角处磨光时，刷子的尺寸应比深沟略大，刷子的边缘应与棱角处相切。磨光时刷子的走向应与棱角的走向一至。

7. 树节的处理。（糙化的使用）

a) 先将步长调整到0.1，使用糙化使树节表面粗糙。

b)

注意：糙化也与步长有关，因此在做糙化之前要先调整步长。下两图分别为步长为0.5与0.1，其它参数相同情况时糙化的对比。

步长0.5 步长0.1

c) 循环使用堆料与去料使树节表面产生较大起伏（刷子的直径3.5，半衰直径0.2，高度0.05

d)

e) 再使用磨光使粗糙部分与周围部分融合。

f)

g) 另外还可以使用堆料使周围生成一些小的节瘤。

8. 沟壑的中凸起的处理。（去料中半衰的使用）

a)

b) 沟壑中的这种突起主要使用，大半径小半衰的去料和小半径的磨光。

c) 注意磨光时刷子的大小、位置与走向。刷子的半径不应比峰与岭之间的距离大。刷子的边缘应与岭基本相切，走向应当沿岭的走向，不能垂直于岭的走向。

d)

e)

9. 直纹面的使用。

a) 直纹面比较适合下面这类曲面失真的修补，具体操作步骤如下：

b)

c) 沿峰和岭绘制两条样条曲线（注意：一定要在俯视图下绘制）

d)

e) 将曲线投影到曲面上

f)

g) 用两条空间曲线生成直纹面。（e键可以将图形隐藏）

10. 使用磨光修去接痕。

11. 下图为修整好的木雕图


虚拟雕塑造型方法之一----测量数据编修(木雕02)

1. 首先看一下这幅输入好的文件，从下图中我们可以看到原木雕的整体轮廓被完好的保留下来有效数据的失真程度较小，因此这个雕塑模型的还原属于细节还原。

2. 放大后可以看到明显的刀纹，对于很多木工厂家来说这些刀纹并不会影响产品的质量即上图只要将轮廓以外的部分压平就可以加工了，但我还是建意将这些刀纹处理一下，因为粗糙的表面将严重影响加工速度。

3. 下面我们来处理这由木雕，首先使用冲压工具将轮廓以外的部分压平。

4. 局部突起的修补，对于局部突起的修补一般是采用仅去高磨光。注意刷子大小的选择，一般为略大于局部突起为宜。

5. 破损花瓣的处理。实际上这也是一种棱角的修补，主要使用的方法大半衰直径的堆料，修补整体形态，小半衰直径的堆料修补棱角。最后使用小半径的磨光，使表面光滑，但必需保持花瓣内自然的高度变化。

花瓣外侧边缘的修补实际上十分类似边角的锐化，它所使用的主要方法为大半径、小半衰的去料和小半径磨光。

6. 失真侧壁的修补

7. 首先沿曲面轮廓绘制一条样条曲线，现绘制一条倾角约为90度的直线，用这两条曲线做一扫掠面，取代原有侧壁处的曲面。

8. 整个曲面的最大的一处失真主要为花瓣外边缘底部棱角的丢失。别处还有一条浅沟，和一个花瓣的破损。

a) 浅沟的处理方法很简单，使用磨光就可以了。

b) 花瓣外边缘底部棱角的丢失前面已经提到过，它主要使用大半径小半衰的去料，和小半径的磨光。

c) 花瓣的破损的修补方法前面也已经提到过。

d) 这里要注意的问题是花瓣曲面的自然形态，由于曲面的失真面积经前几处要大，修补的过程往往以需要反复进行多次，很容易在多次的修补过程中使曲面的原有形态丧失。因此在这里就更要注意刷子的几个参数的选择。具体步骤如下：

9. 首先使用去料使棱角锐化，并使用堆料将破损花瓣的轮廓堆起。

10. 使用磨光使曲面轮廓清晰，反复几次。

11.

12. 在对这些图形态各异的花瓣处理时我们要仔细观察，体绘它们不同的形态形成的不同视觉效果。我们可以看到有些花瓣的形态是内收的，而有些是外放的。对于内收形态的花瓣我们在磨光的同时可以适当的在基中心部位去一些料，而对于外放形的花瓣则可以适当的填一些料。千万不要认为虚拟浮雕中的磨光是个万能的工具，不管什么图，拿来就用磨光。虚拟雕塑提供了丰富的立体浅浮雕的造型和修补方法，但曲面的形态和神韵还是要由制做者去把握。仔细对比一下这两幅图中的花瓣，应该会有所收获。

13. 下图为处理后浮雕


虚拟雕塑造型方法之一----测量数据编修(木雕03)

下面我们首先看一这荷塘的木雕：

这也是一幅三维扫描图形，从图形的细腻程度可以猜测这是一幅由成品图扫描得到的。仔细观察后会发现有这样几处较大的失真。

这几处失真的修补技法与前面所列完全相同，但要注意修补后的形态风格一定要与原创相形态风格相同，曲面高度和曲率的变化一定要自然，走向要与原创曲面的走向一至。

下面我们讲一这幅图的边框的修补。

1. 首先，我们没其边框描出一条轮廓曲线。

2.

3. 然后，穿过边框绘制一条坚直线，并生成曲面截线（命令位置：雕塑->提取截面）。

4.

5. 编修曲线节点

6.

7. 使用扫掠面中取代选项生成曲面边框。

8.

9.

在这里我们讲一下仿形设计的完整过程及每步骤的注意事项：

第一步：原始数据的获得。这里的原始数据都是通过一台机械扫描仪得到的。

不同的扫描仪失真程度会有所不同，机械式扫描仪可能会产生较多的细节误差，光学扫描仪可能在采光条件差的地方产生较多的误差，可以根据产品的形状特点和具体情况选用扫描仪。

第二步：数据的转换。从扫描仪中出来的数据大多数情况是不能直接使用的，一般要经过数据的转换，可能通过STL、OBJ等格式进行转换

第三步：输入数据的预处理。输入数据一般会有很多缺陷，如有些格式的数据会将图形的原始大小丢失等等。有如下几种预处理可能要做。

a) 图形尺寸的调整。（根据实物尺寸调整）。

b) 图形位置的调整及方向。（一般要将输入曲面移到原点附近，使曲面正视于Z轴，将曲面最低点移到零平面。）

c) 曲面格式的调整。使用曲面重构使之能进入虚拟雕塑中使用。重构步长一般应与数据采集时的采样精度相同或略小一点。如果该值选择的过大，则造成较大程度的失真，较小则重构时间加长。（如果需要较高精度的网格可以在进入虚拟雕塑中调整。）

d) 进入虚拟雕塑后，要根据自己的操作习惯及机器的性能调整重做次数。

e) 接下来根据形状的精度调整模型的步长。

f) 根据模型的高度设置限高保低值。

g) 扫描图形的经常会有如下缺陷：即其局部测量数据低于期望的零平面，此时也可以使用限高保低命令来处理。

具体方法：使用磨光命令观察设计零点（或者叫做期望零点）的数值，使用限高保低命令设置该值，选中模型限高保低选项。如下图为处理前后的图形对比。

第四步：修补模型

第五步：生成加工路径。注意这里一定不要将模型裁剪否则处理速度会变慢。如果边缘以外的路径没有用的话可以用以下方法处理。

1. 使用等高填色。得到零平面。

2. 使用颜色区域失量化得到加工边界。

3. 编修节点。

4. 将曲面与边界同时选中开始加工。


虚拟雕塑造型方法之二----利用外部资源造型

原始数据文件来源于人体动物库，本例用到两个OBJ文件（wolf.obj和manhead.obj），下图中可以看到这两个文件中的图形数据。

1. 输入文件wolf.obj。（命令位置：艺术曲面->标准曲面->读入Obj文件）

2. 调整狼的位置裁下狼头。

3. 并重新调整曲面的方向。

4. 选择适当的精度，曲面重构。（重构精度为0.1）

5. 将曲面最高点调整到50，进入虚拟雕塑，使用限高保低将模型Z向尺寸限制在0-51。并使用冲压，将无用处压平。

6. 读入别一文件manhead.obj。

7. 调整大小位置。

8. 使用模型的限高保低和冲压将人头处理成如下形状。

9. 将两曲面同时选中进行曲面重构，可以进入虚拟雕塑进行修整。

10．添加细节及编修…….


虚拟雕塑造型方法之四----利用几何工具造型

在虚拟雕塑造型中最难于掌握的是整体形状的把握，利用几何工具可以有效的降低使用者艺术造型方面的门坎，加速虚拟雕塑的学习过程与制作过程。

下面是一只小蜥蜴的制作过程：

一．用扫掠面生成头、颈、躯干、尾的轮廓 。

1.1 用曲线勾出蜥蜴的轮廓（头、颈、躯干、尾）。

图1：小蜥蜴的轮廓曲线

由于源图不是俯视图，所以我们不能通过直接描图的办法生成轮廓曲线。不过小蜥蜴的轮廓并不复杂，完全可以通过手绘等到。注意中间的一条曲线是一条辅助线，在以的操作中用处不大

1.2 输入源图描出四肢

图2： 描绘中的四肢

蜥蜴的脚是可动的，因此它的绘制方法是比较灵活的，我们可以描图修改的方法，当然也可以直接绘制的方法。描图对美术功底要求较低，但没有办法直接生成闭合区域。这里我采用了描图的办法。

1.3 将描好的四肢适当缩放并移动到适当的位置。

图3： 蜥蜴四肢位置的调整

1.4 绘制头部、躯干及尾部的截面线。

图4：截面及其与轮廓的位置关系

由于我们将采用扫掠面的方式生成曲面的整体轮廓，因此除每部分（头、躯干和尾）需要两条轨迹线外，我们还需要每部分的截面线，在截面线的绘制过程中要注意截面线的高度。在双轨扫掠面中如采用截面相似一项设置，则在取双轨的最宽处距离为a，则以a作为X轴长度来绘制截面，此时截面与真实截面的比例为1：1，即等大的。当然也可以通过特征高度缩放来解决生成曲面的实际高度问题

1.5 绘制矩形、进入虚拟雕塑环境、建立模型。

图5： 新建的虚拟雕塑模型

开始时为加快运行效率，可将步长设置的适当大些，我将初始精度设置为0.5mm。

1.6 用描掠面构造蜥蜴的整体形态：

a) 点击“几何—扫掠面”

b) 选择两条轨迹线

c) 选择截面线

图6：绘制三条用于生成直纹面的直线

注意扫掠面的起点和终点的，如果扫掠面的起点与终点不对，将会造成曲面的扭曲。上图中比较详细的指出了头部制做时的各条曲线的作用及其起点与终点。在本例中截面的基点均选择为截面的起点（因为本例中的三条截面的起点均在左边）。截面高度效果选择为相似，网格精度打为0.5。网格精度选的比较大，主要是为了提高计算速度，便于修改调整。如果我们对生成的曲面不够满意可以重新调整截面与轨迹的形状。

二．用叠加直纹面形成其撬起的头部与躯干。具体方法如下：

2.1 在蜥蜴的头前、颈部及躯干与尾的连接处分别画三条直线。

图7：绘制三条用于生成直纹面的直线

为加快速度，我们可以将显示模式改为网格显示。三条直线应当尽量长些，确保生成的直纹面可以

2.2 用Z向移动曲线分别将颈部直线和头顶直线升高2mm和5mm。

图8： Z向移动曲线

2.3 用三条直线构造直纹面，选择叠加选项。

图9：叠加后的曲面

a) 选择命令“几何—直纹面”

b) 选择选项叠加。

c) 分别选择三条直线。（一条二维直线，两条空间直线）。

2.4 将轮廓内填入颜色。

图10：填色后的曲面

先使用单线填色，再使用种子填色

2.5 使用颜色外冲压，将无用的边缘去掉。

图11： 冲压后的曲面

2.6 使用曲面融接将蜥蜴的颈部及尾与躯干的连接处变光滑。

图12：几条融接用曲线（白色）。

a) 如下图所示，绘制几条截面线。

b) 选择命令“几何—融接面”

c) 选择相两条曲线。

图13：融接后的效果

三．用颜色浮雕生成爪子。

3.1 将其爪子部分填入颜色。使用颜色浮雕生成爪子的轮廓。

图14：爪子的制作

四．使用纹理刷子制作手工纹理。

4.1 反复使用图像刷子的堆料和去料可以得到较好的手工纹理。

a) 使用堆料

b) 刷子形状选择图像

c) 在打开对话框中选择hatch2.bmp

d) 开始堆料。

e) 再选择hatch4.bmp，再次堆料。

f) 再选择这两个图反复堆、去料即得到手工纹理。

图15：手工纹理效果

hatch2.bmp hatch4.bmp

图16：制作手工纹理用到的两幅位图。

五．细节处理。

在本例中，细节处理应该在纹理处理之前，由于写文档方便所以我将他们的位置调换了（切记不要受我的误导）。细节处理应该是大部分美工的强项，这里只提几个可以加速的命令。

5.1 设定操作范围。

图17：操作范围的设定。

在细节处理的第一步一般会是加大模型的精度，但随着模型精度的提高，处理速度就会变慢。为解决这一矛盾我们可以使用命令“设定操作范围”，以减少计算机的数据处理量。在上图中可以看到许多小的矩形框都是用来设定模型范围的。在设定操作范围后可以用“t”键切换全部显示与部分显示。设定操作范围之后仅能在范围内进行操作（不管是在部分显视模式下还是在全部显视模式下）。命令位置：“模型-设定操作范围”，具体使用方法参见连机帮助系统。

5.2 截取模型。

如果模型数据十分巨大，还可以使用截取模型这个命令。这个命令的设计思想是：以一较大但精度相对较低的模型的为基准，分别建立数个小且精度高的模型，在小模型可以区域内大模型上点被压为零点。分别设计小模型最后将几个模型拼合在一起。以下几图为使用截取模型前后在二维状态下观察到的模型（左为截取模型前，右为截取模型后）。

图18：在线框模式下观察到的曲面模型

图19：截取模型前的模型形态

图20：截取模型后的大模型与小模型的形态。

由于两个模型的精度是不同的，所以相当于我们得到一个局部细化的模型从而即保证了精度以保证了可操作性。


虚拟雕塑使用技巧及范例

艺术家的软件还是工程师的软件

自从研发JDVirs以来，在公司内部普遍存在一种观念：JDVirs是适合艺术家使用的软件，使用者必须有扎实的艺术功底。刚拿到软件时，都觉得新奇，但涂抹几下后就失去了耐心，前面提到的观念成了畏缩情绪的借口。

应该说JDVirs既适合艺术家使用，也适合工程师使用，艺术家有艺术家的用法，工程师有工程师的用法。JDVirs功能丰富，艺术家可能在描出或绘制出大致轮廓之后，有时甚至不描图直接把图片转为高度很小的浮雕(比如说0.1mm)之后，主要利用堆料、去料、擦除、磨光、漂移等几个命令就能把头脑中的构思具体表现出来。工程师在描图或绘制图形之后，至少可以象JDPaint4.0或者JDPaint5.0中艺术曲面部分一样，通过浮雕构造/变形/拼合功能完成模型的造型。在实际应用中，艺术家可能先利用JDVirs的浮雕构造/拼合功能打一粗坯，然后主要依靠JDVirs的手控命令完成模型的造型，而工程师主要依靠JDVirs的浮雕构造/变形/拼合功能完成模型的造型，然后有可能利用JDVirs的手控命令对模型进行局部修改/修饰。随着对JDVirs的熟悉程度提高，工程师也会培养出一些艺术家的感觉，艺术家也会获得一些工程师的逻辑思维，这时用JDVirs造型将更加得心应手。

利用JDVirs造型较之利用JDPaint4.0或者JDPaint5.0中艺术曲面造型有较大的优势，主要体现在:

1) 命令执行速度极快，能极大地节省时间。

2) 三维着色显示，所见即所得。

3) 界面更简单，友好。

4) 可动态地创建, 修改, 修饰模型。

5) 各种浮雕生成方式应有尽有（区域浮雕/单线浮雕/颜色浮雕/单线冲压/位图转浮雕/图象浮雕/融接等）。

6) 模型的数据量不会随着模型的复杂程度的增加而增加等。

在接触JDVirs的初期工程师最好按工程师的方法使用JDVirs，以免影响信心。随着对JDVirs的熟悉，可使用艺术家的命令对构造好的模型进行局部修改/修饰，慢慢过渡到两种方法都掌握。

本文给出了利用JDVirs进行艺术曲面造型的一些技巧、及几个小例子。本文的读者应该已经熟悉艺术曲面造型的基本概念及有一定的艺术曲面造型的实践经验。

操作模式

三种操作模式可用于三种不同的场合：

单模型整体操作模式可用于顶点数较少的模型，是系统缺省的操作模式，也是最常用的操作模式。

单模型局部操作模式可用于顶点数较多的模型或机器速度较慢的场合。

多模型多分辨率操作模式可用于模型一个或多个局部要求比较精细的场合。

系统缺省的操作模式为单模型整体操作模式，利用设定操作范围命令可把单模型整体操作模式转为单模型局部操作模式，利用截取模型命令可把单模型整体操作模式转为多模型多分辨率操作模式。

选择工具中艺术曲面的“矩形网格分割”及“同源矩形网格合并” 命令可把矩形网格曲面无损分割及合并。对于超大型网格曲面（顶点数300万—2000万）可利用无损分割命令把网格曲面分为多个小的矩形网格，然后选择一个小的矩形网格（单模型整体操作模式）进入虚拟雕塑操作；或选择多个小的矩形网格（多模型多分辨率操作模式）进入虚拟雕塑操作。各小矩形网格修改完毕后，可用“同源矩形网格合并” 命令把小矩形网格无损合并，然后重新无损分割后修补原小矩形网格曲面的边界接合处。利用无损分割及合并技术，可处理超大型浮雕壁画。

半衰直径调整

高斯分布是堆/去料时最常用的一种刷子，高斯分布是把神奇的刷子，调整半衰直径相对其直径的比值，可以实现不同的效果。

堆去料大面起鼓时，可把半衰直径设为与直径相等或直径的150%,这样可保证堆去料的区域比较光滑。

构造比较细小的特征时，可把半衰直径设为直径的25%左右。

构造特别细小的特征时，不要把刷子下直径调得很小，可保留刷子直径较大，而把半衰直径设为最小值0.01mm，这样就能构造出精细的特征。

单线冲压能构造模型中最精细的特征，因为单线冲压的宽度只有一个顶点（步长）宽。如果单线冲压还不能满足要求，只能调小模型步长。

会不会依照不同的要求调整半衰直径，是虚拟雕塑是否入门的标志之一。

地图及灰度图象显示方式时颜色模版的使用

在地图及灰度图象方式显示时，与颜色有关的命令不能使用，但颜色模版依然有效，这时看不见充当颜色模版的颜色区域，可把显示方式转为图形显示方式，用“颜色--颜色区域矢量化” 命令把模版颜色区域矢量化，然后再转为地图或灰度图象显示方式。

描图

利用JDVirs制作模型的第一步通常是描图或者利用绘制功能绘制出模型的大致轮廓、区域边界等。描图有两种方法：

1） 在JDPaint环境下加载模型图像后描图

2） 在JDVirs下描图

第一种方法大家比较熟悉，在此不作介绍，主要介绍一下第二种方法描图的过程。假设已有如图1的BMP图像文件，方法2描图的过程如下：

1） 进入JDVirs环境，选择“位图转浮雕”

2） 选择图1的BMP文件。

3） 在对话框“高（Z）”中输入“0”或一较小的高度（比如说“0.1”）后确定，如图2。

4） 选择“模型—加载模型颜色”，再一次选择图1的BMP文件。系统加载图像的颜色或灰度信息，并把图像套色显示于模型上，如图3

5） 在套色的模型描图即可，如图4。

图1 原始图像 图2原始图像转为浮雕(0.1MM)

图 3 图2套色显示 图4 描图后的结果

色块图像

色块图像是指图像中有大块的纯色构成的区域。通常要把色块的边界描出来后再构造浮雕。利用JDVirs，可不用描图，直接利用原图像的色块及颜色浮雕功能生成浮雕，过程如下：

1） 假设色块图像如图1

2） 进入JDVirs，选择“位图转浮雕”

3） 打开色块图像，并在对话框中“高（Z）”中输入“0”后确定。

4） 择“模型—加载模型颜色”，再一次选择图1的BMP文件。系统加载图像的颜色信息，并把图像套色显示于模型上，如图2

5） 利用颜色浮雕功能把各色块转为浮雕，如图3。

图 1 纯色图像 图2 套色显示 图 3 颜色浮雕

等高填色及特征高度缩放

等高填色能够快速把不低于或不高于当前光标处的模型顶点置为当前颜色。填色后的颜色区域边界高度相等。

图1是经过“位图转浮雕”得到的，高度为0.1mm。为了把独角兽或其外围填上颜色，有两个方法：

a) 利用涂抹颜色功能，手工涂抹。

b) 描出其外轮廓边界，区域填色或单线填色后种子填色。

图1 位图转浮雕(0.1MM) 图2 等高填色后

利用等高填色能快速准确的把独角兽的外围填上当前颜色。在后续的堆料过程中，设

置“颜色外”选项。填色过程如下：

1） 选择“等高填色”

2） 设置选项“低于”

3） 在高度为零的外围面中单击鼠标左键。

利用等高填色后，颜色区域边界处顶点高度相等这一特征，可以用特征高度放缩命令，

改变特征的高度，并保证特征边界处不会出现台阶。

利用扫掠构造旋转面

利用扫掠功能，可以构造绕垂直于XOY平面的轴线旋转的曲面。

以转轴与XOY平面的交点P为圆心，绘制一圆或圆弧，如图1，绘制截面线如图1中S。利用截面线和圆做扫掠，可生成旋转面如图2。

图1 截面线及轨迹线

图2 利用扫掠构造旋转面

融接

融接在模型上的两条2D曲线之间建立一过渡面并拼合到模型上。系统自动把2D曲线投影到模型上，然后在投影得到的3D曲线之间建立一过渡面。可以控制过渡面在曲线处的切矢方向为下列四种情形之一：

a) 模型的切矢方向

b) z轴正向

c) z轴负向

d) 水平方向

利用融接功能，能方便地修改模型。如图1要把其左角加宽且变形，可绘制曲线C1

及曲线C2，如图1。

图 1 融接位置曲线

1） 用导动磨光沿曲线C1导动磨光2次。

2） 选择“融接”命令。

3） 选择曲线C1，曲线C2。

4） 把对话框中“切矢2方向”改为“Z＋”后预览并确定即可得到修改后的左角，如图2。

图2 融接后的结果

如果把曲线1及曲线2切矢处的切矢方向都改为“z＋”，融接功能可以快速在两条曲线之间构造一类似扫掠及浮雕的融接面，如图3

图3 z＋融接

纹理单元，辊轮及戒指的设计

纹理单元通常是指把一纹理图像在水平及垂直方向重复平铺后，在纹理图像左右边界处

及上下边界处能够自然连接没有接缝的纹理图像单元。

原理上来说，利用JDVirs的涂抹功能及左右边界部分对称功能、上下边界部分对称功能，用户可自定义无缝连接的纹理单元。利用这些纹理单元，结合JDPaint5.0艺术曲面中的图象纹理及辊轮功能，可以构造出各种各样的有特色的纹理辊轮。

另外一种思路是把整个雕塑模型看作是辊轮或戒指的展开图，直接在展开图上设计辊轮或戒指的花纹，并保证左右边界能自然连接或有一小部分等同。设计完毕利用圆柱面映射拼合功能卷起来看效果。

利用图像刷子做漂移

刷子类型影响漂移的效果。刷子可分为实心刷子及非实心刷子。高斯分布、圆柱、半球

等为实心刷子，即刷子范围内任一点的高度都大于零。由图像定义的刷子大部分为非实心刷子，即刷子范围内有高度为零的区域，如图1。如果构造图像刷子时，有意识地控制刷子中高度不为零的区域的形状及排列，利用这些刷子堆/去料或做漂移，涂抹颜色时，就能实现一些特殊的效果。

如图2就是利用图1的刷子堆料后的效果，模型表面有了手工纹理的感觉。

如图3，利用图1中的刷子做运动方向漂移得到的效果，适合做头发等效果。

在漂移及涂抹颜色命令中，没有刷子类型选项。若要改变刷子的类型，可用“选项――

定义刷子”设定要求的刷子。

(a) (b) (c)

图1 图像刷子

图2 利用图像刷子a及b堆料后的手工纹理效果

图3 利用图像刷子c漂移后的头发效果

提取截面与扫掠

提取截面线功能有两个用途：

1） 观察截面形状

2） 与扫掠配合使用，修改模型

如图1，为了使尾巴延长、翘高，可绘制一单段直线L并提取截面S，并在图1中绘制

两条轨迹线C1及C2，图2是利用提取的截面线及绘制的轨迹线扫掠后的结果，拼合方式为取代。

图1 截面线提取及扫掠轨迹线

图2 扫掠后的结果

导动堆/去料

导动工具控制刷子沿线运动，并相应地改变模型。导动去料可以看作是虚拟投影雕刻，刷子运动的轨迹投影到模型上，可以看作是投影后的雕刻路径。刷子类型就相当不同的刀具类型，半球是球刀，圆柱是柱刀，圆锥是锥刀等。刷子沿线运动后留下的残料，即是改变后的模型，导动去料对话框中的各种选项使得虚拟雕刻比实现雕刻灵活得多，刀具半径在运动过程中可以改变等。

同理导动堆料可以看作是虚拟投影塑形。导动工具的优点在于能够比手工控制刷子运动更精确地改变模型，并且刷子的参数更好控制。

构造区域浮雕，单线浮雕及导动堆去料时的多选问题

构造区域浮雕，单线浮雕及导动堆去料时，若要多选区域或2D图形，方法如下：

1） 选择命令之前，把要选的对象或其一部分选上。

2） 进入命令之后，设定参数。

3） 如果所有对象都已选上，按右键结束命令即可；如果还有对象没有选上，移动鼠标到待选对象上，当其改变颜色时，单击左键即可。

自定义图像刷子

图像刷子在堆/去料及漂移等命令中能实现一些特殊的效果。因此用户可根据其要求，自定义一些特殊的图像刷子。JDVirs中图像刷子是一8位灰度位图，通常其大小定义为255*255，分辨率设定为72DPI，白色为高点，黑色为低点。

保存及加载特征

特征是由一连通的颜色区域界定的模型的一部分或整个模型。可以把特征保存到文件中，在后续的操作中把特征作为刷子、体素或纹理单元使用。

特征的另外一个用途就在于与外界系统如JDPaint、SurfMill或其他系统交换数据。如果模型上的某处利用SurfMill生成比较简单，可以考虑在SurfMill中生成后转为网格曲面，由JDPaint5.0中的艺术曲面转为特征保存，在JDVirs中以体素的形式把保存的特征加载并拼合到模型上。

利用特征文件在系统间传递数据，有数据量小的优点，同时克服了利用位图传递数据时出现的台阶效果及保密性差的缺点。

堆/去料时的限高保低

在堆/去料命令的对话框中，设置了限高保低的输入框，因此在命令中随时可改变限高保低值。

设想一模型高度方向有三个层次，区域1最高不超过6mm，区域2最高不超过4mm，区域3最高不超过2mm。这样一来模型的限高保低值可设为6mm及0mm。在堆料时，在区域1处操作时可把限高值改为6mm；在区域2处堆料时可把限高值改为4mm；在区域3处堆料时可把限高值改为2mm。

同理，去料时可依据模型的层次关系相应地设置保低值。

层

虚拟雕塑环境下只有一个工作模型，但该模型是由两个独立的层构成的——流动层及固化层。流动层及固化层叠加在一起，构成屏幕上见到的模型（复合层）。

固化层及流动层都是一张与的工作模型尺寸等同的网格曲面。固化层是一个基准曲面，除固化及流化命令外其它命令不能修改它。所有的命令都是修改复合层或流动层，缺省为复合层。固化层存在的一个理由之一在于相当一部分命令，如冲压、堆料-自然效果、涂抹纹理等等，必须有一个相对稳定的基准曲面。

由位图转浮雕、图像浮雕，JDP文件读入的对象，或选择工具下构造的对象进入虚拟雕塑环境时，其流动层为一零平面，固化层等于复合层为屏幕上见到的模型。由虚拟雕塑环境下保存及载入“VSM”文件时，固化层、流动层及复合层的信息可保存及重载。

显示控制命令可分别控制只显示流动层、固化层及复合层。但操作时应该处于复合层显示状态，否则速度较慢。功能键“B”可把流动层上顶点高度不为零处以绿色显示出来。

擦除命令就是把流动层上高度不为零的顶点置为零。固化命令把流动层上的对象移到固化层，并把流动层相应的部位置为零。流化命令把固化层上的对象移动到流动层，并把固化层相应的部位清零。

层是虚拟雕塑的一个重要概念，没有理解层的概念就不能解释命令操作过程中的一些怪现象，就不能真正体会虚拟雕塑的好处。

花的构造

花草浮雕是虚拟雕塑常见的应用领域之一，图一是隋海然的作品，花瓣之间相互重迭的效果据说是用堆/去料命令做出来的。这里提供另外一种方法----“工程师法构造花瓣之间相互重迭的效果”，或许对开拓思路，灵活组合运用各命令有所帮助。

图1

图2 图3 图4

1． 描图，执行命令“橡皮----整体固化”，如图2。

2． 如图3，画一扫掠用的截面线（蓝色线）。

3． 如图4，小圆为轨迹线，蓝色线为截面线，扫掠生成花的基体。

图5 图6 图7

4． 如图5，填色后擦掉外部材料。选择命令“特征----高度放缩”把花体高度方向放缩到2.00mm。

5． 如图6，填色并节点编辑一花瓣的轮廓（蓝色线），然后用这轮廓线做区域浮雕，实现一花瓣的重迭效果。

截面形状 椭圆截面

基准高度 0.0mm，

高度效果 实际高度 0.8mm

形状系数 0.3

颜色模板 颜色内

拼合方式 切除

6． 如图7，同理可实现另外几个花瓣的重迭效果。

图8 图9

图10

7． 如图8，利用体素命令生成一XY直径为1.00mm，高度为0.6mm的半球，以取代的方式放置于花瓣中心。固化整个花瓣。

8． 如图9，画花骨线，并用导动堆料生成花骨。去料（只操作流动层）修整花骨。

9． 如图10，堆料，去料，磨光等操作做必要的修整，最后利用特征移动命令把做好的花朵移动到其应处的位置。

相框的构造

相框可用几何曲面构造，重构之后进入虚拟雕塑。灵活组合运用虚拟雕塑的命令，亦能方便地构造出相框。

图 1 图 2

1． 如图1，画截面线及二个矩形框，分别选择二个矩形框做图形聚中操作使其中心位于原点。

2． 如图2，进入虚拟雕塑，选择大矩形框新建模型。调整曲线方向。

图 3 图 4 图 5

3． 如图3，画45度直线1，画辅助线2。填色。

4． 如图4，直线3为轨迹，绿色线为截面线，单轨单截面扫掠，擦除颜色外后整体固化。

5． 如图5，直线4为轨迹，绿色线为截面线，单轨单截面扫掠，擦除颜色内。

图 6 图 7

6． 如图6，相框的边沿有点不光滑。

7． 如图7，把直线3及直线4单线填色（有可能要向里或向外移动一个步长），颜色内冲压--绝对—0，就可得到光滑的侧面。

图8

8． 如图8，特征对称--左右完全对称及特征对称--上下完全对称后，可得到完整的相框。这个例子给我们的启示之一是----在虚拟雕塑环境中，灵活组合运用颜色模板，擦除及固化命令，可修剪曲面。

镶钻孔的构造

义乌分公司的隋海然在其工作总结中提到，在做工艺品和饰品挂件时，常常要在艺术曲面表示的基面上沿曲面法线方向打一锥形孔，以便镶嵌水晶钻石。JDPaint5.16中的JDVirs环境下提供了比较简便的方法实现工艺品，饰品挂件和表壳上曲面法线方向的镶钻孔的构造。

图1 图2 图3

1． 如图1，绘制二个闭合轮廓。

2． 如图2，用内轮廓区域填色。

3． 如图3，仅用外轮廓做区域浮雕（颜色内，其它为缺省参数）。

4． 如图3，选择命令“颜色----颜色区域膨胀/收缩”，使颜色区域膨胀一次。

5． 如图3，选择命令“特征----高度放缩”，把浮雕放缩到10mm高。

图 4 图 5

6． 如图4，选择命令“几何----平面上绘制曲线”，

a. 法线长度设为 –3。

b. 在曲面上单击左键，生成长度为3mm的切平面的法线c及基点。

c. 把曲线类型设为--圆，以切平面的基点为圆心，在切平面上画一半径为3mm的圆。

d. 把曲线类型设为--点，在切平面的法线端点处画一点b。

e. 把曲线类型设为--直线，画锥形孔的母线a。

7． 如图5，选择命令“几何----旋转曲面”，

a. 旋转角度----360

b. 拼合方式----取低

c. 以直线a为母线，法线c的二个端点为基点及方向点，做旋转曲面。

结果如图5。

图 6

图 7

8．如图6及图7，同理可在曲面的其他位置构造镶钻孔。

鹿蹄的构造

如何构造图1中A，B处这种形态呢----在一段连续的材料上隆起一个光滑的台阶。看似非常简单的工作，初学者也觉得无从下手。利用颜色模板限定堆料/去料法也许可以考虑，但是理工背景的人做起来可能比较困难。定义特征后利用特征变形功能亦值得考虑。这里提供特征高度放缩的方法来实现这种自然台阶。为了说明问题，我们在图1中C处构造一个台阶。

图1

图2 图3

1． 如图2，画一直线并填色。

2． 测量A处台阶，可知台阶高度约为0.5mm。选择命令“特征----高度放缩”，在特征原有的高度上增加0.5mm， 结果如图3。

图4

3．磨光后结果如图4。

利用JDVirs构造老鹰

老鹰是浮雕应用的典型例子, 在JDVirs中构造老鹰的过程如下:

1. 图1为老鹰的原始图象.

2. 描图, 图2为描图后的结果, 为了简单起见, 可直接从JDPaint4.0的安装目录下的”Samples\艺术曲面”中打开 “网格鹰.jdp” 文件, 并删除原网格曲面。

图1 老鹰的原始图象 图2 描图后的结果

3. 进入JDVirs环境, 选择图2中所有的二维图形元素后选择 “模型->新建模型” 命令, 把 “XY步长” 改为:0.06, 然后确定, 系统自动生成一略大于选择的二维图形元素的包围盒的基面, 如图3。

4. 构造老鹰的基面

选择区域浮雕命令, 设置参数:

截面形状 椭圆截面

基准高度 0.05

高度效果 限定高度0.10

表面特征 整体光滑

边界角度 45

拼合方式 叠加

移动鼠标到老鹰的外轮廓处, 当其改变颜色时, 单击鼠标左键, 结果如图4。

图3 包围盒的基面 图4 外轮廓面

5.构造身体部分的曲面

选择区域浮雕命令, 设置参数:

截面形状 椭圆截面

基准高度 0.15，

高度效果 自由高度

表面特征 整体光滑

边界角度 45

拼合方式 取高

移动鼠标到老鹰的身体部分轮廓处, 当其改变颜色时, 单击鼠标左键, 结果如图5。

6.构造两条腿的曲面

选择区域浮雕命令, 设置参数:

截面形状 椭圆截面

基准高度 0.15，

高度效果 自由高度

表面特征 整体光滑

边界角度 15(左腿), 30(右腿)

拼合方式 取高

移动鼠标到老鹰的左右腿轮廓处, 当其改变颜色时, 单击鼠标左键, 结果如图6。

图5 构造身体部分 图6 构造两条腿

7.构造两根翅骨部分的曲面

选择区域浮雕命令, 设置参数:

截面形状 椭圆截面

基准高度 0.15，

高度效果 自由高度

表面特征 整体光滑

边界角度 60

拼合方式 取高

移动鼠标到老鹰的翅骨部分轮廓处, 当其改变颜色时, 单击鼠标左键, 结果如图7。

8.构造尾骨部分的曲面

选择区域浮雕命令, 设置参数:

截面形状 椭圆截面

基准高度 0.15，

高度效果 自由高度

表面特征 整体光滑

边界角度 30

拼合方式 取高

移动鼠标到老鹰的尾骨部分轮廓处, 当其改变颜色时, 单击鼠标左键, 结果如图8。

图7 构造两根翅骨 图8 构造尾骨

9.构造翅羽部分的曲面

选择区域浮雕命令, 设置参数:

截面形状 椭圆截面

基准高度 0.15，

高度效果 自由高度

表面特征 整体光滑

边界角度 20

拼合方式 取高

移动鼠标到老鹰两翼上翅羽部分轮廓处, 当其改变颜色时, 单击鼠标左键, 结果如图9。

10.构造尾羽部分的曲面

选择区域浮雕命令, 设置参数:

截面形状 椭圆截面

基准高度 0.15，

高度效果 自由高度

表面特征 整体光滑

边界角度 40

拼合方式 取高

移动鼠标到老鹰尾羽部分轮廓处, 当其改变颜色时, 单击鼠标左键, 结果如图10。

图9 构造翅羽 图10 构造尾羽

11.构造身体及尾骨上羽毛部分的曲面

选择区域浮雕命令, 设置参数:

截面形状 椭圆截面

基准高度 0

高度效果 自由高度

表面特征 整体光滑

边界角度 20

拼合方式 叠加

移动鼠标到老鹰身体及尾骨上羽毛轮廓处, 当其改变颜色时, 单击鼠标左键, 结果如图11。

12.构造头部羽毛部分的曲面

选择单线浮雕命令, 设置参数:

截面形状 圆弧

基准高度 0

高度效果 限定高度 0.05

边界角度 85

边界处理 只做闭合区域

拼合方式 叠加

移动鼠标到老鹰头部羽毛部分（两片）的轮廓图形处, 当其改变颜色时, 单击鼠标左键, 结果如图12。

图11 构造身体及尾骨上羽毛 图12 构造头部羽毛

13 构造两条腿上羽毛部分的曲面

选择区域浮雕命令, 设置参数:

截面形状 椭圆截面

基准高度 0

高度效果 自由高度

表面特征 整体光滑

边界角度 30

拼合方式 切除

移动鼠标到老鹰身体及尾骨上羽毛轮廓处, 当其改变颜色时, 单击鼠标左键, 结果如图13。

14构造鹰爪部分的曲面

选择区域浮雕命令, 设置参数:

截面形状 椭圆截面

基准高度 0

高度效果 自由高度

表面特征 整体光滑

边界角度 60

拼合方式 叠加

移动鼠标到老鹰鹰爪部分轮廓处, 当其改变颜色时, 单击鼠标左键, 结果如图14。

图13构造两条腿上羽毛 图14 构造鹰爪

15构造眼球

选择区域浮雕命令, 设置参数:

截面形状 椭圆截面

基准高度 0

高度效果 自由高度

表面特征 整体光滑

边界角度 40

拼合方式 叠加

移动鼠标到老鹰眼球部分轮廓处, 当其改变颜色时, 单击鼠标左键, 结果如图15。

图15 老鹰