JDPaint 5.0平面设计

欢迎使用JDPaint V5.15平面设计


前 言

JDPaint是精雕科技多年来一直致力研制开发的、具有自主版权的、功能强大的专业雕刻CAD/CAM软件。这是国内最早的专业雕刻软件。JDPaint是CNC数控雕刻系统正常运作的保证，也是有效提高CNC雕刻系统使用效率和产品质量的源泉。JDPaint专业雕刻软件经过多年的发展完善，功能日趋丰富强大，特别是2001年推出的JDPaint 4.0，它在操作流程、用户界面、图形编辑、艺术造型、曲面造型、数控雕刻等方面都有了质的提高，不仅突破了如曲面浮雕、等量切削等多项关键雕刻设计及加工技术，也充分保证了软件产品的易用性和实用性，极大地增强了精雕CNC雕刻机的加工能力和对雕刻领域多样性的适应能力。在应用领域上，JDPaint软件已经彻底突破了适合标牌、广告、建筑模型等较为传统的雕刻应用范畴，在技术门槛更高的工业雕刻领域，如滴塑模、高频模、小五金、眼镜模、紫铜电极等制作业，表现同样出色，成为国内最优秀的雕刻软件。

目前，JDPaint已由较为单一的雕刻设计加工软件，逐步走向面向CNC产品加工的一整套解决方案。随着JDPaint 5.0软件推出，JDPaint已经构建成为一个强大的开放性CAD/CAM软件产品开发平台，在此平台上，形成了一个具有专业特色的、功能更为全面丰富的CAD/CAM软件产品家族。这个家族目前包含JDPaint 5.0精雕雕刻软件、JDVirs 1.0精雕虚拟雕塑软件以及我们的合作伙伴——北京进取者软件技术有限公司基于JDPaint平台研发的SurfMill 1.0曲面造型与加工软件等三个主要产品。

软件名称 | 专业特长 | 适合行业
JDPaint 5.0 精雕雕刻软件 | (1) 平面图形设计；文字排版及编辑。 (2) 图象矢量化与快速抄图。 (3) 艺术浮雕曲面与几何曲面的混合造型设计。 (4) 基于等量切削技术的小刀具高速精细雕刻加工支持。 (5) 支持针对不同行业的专业应用功能，如发饰、印章等。 (6) 支持多种图形、图象、NC加工数据交换接口。 | 适合于标牌、广告、建筑模型等行业，以及适合滴塑模、高频模、小五金、眼镜模等模具行业的小型产品雕刻。
JDVirs 1.0 精雕虚拟雕塑软件 | (1) 以图象或素描手稿为起点构造浮雕模型。 (2) 实时地动态创建、修改、修饰浮雕曲面模型,完全的所见即所得的交互设计过程。 (3) 强大的浮雕曲面编辑工具使得三维浮雕曲面设计与平面图象设计一样容易。 | 适合于三维标识、公仔模、装饰品、首饰等行业的造型设计与雕刻。
SurfMill 1.0 曲面造型与加工软件 | (1) 提供强大的三维线框造型功能。 (2) 提供强大的几何曲面构造与编辑功能，全面支持NURBS曲面造型技术。 (3) 提供强大的曲面加工功能，全面支持曲面模型的粗加工、半精加工和精加工，提供曲面三维清根功能。 (4) 支持多种图形数据交换接口。 | 适合于模具、工业模型等行业的设计与加工。

上述三个产品，既能独立运行，也可被整合在同一环境下，各展所长，共同完成产品模型的设计与加工。本说明书为JDPaint 5.0使用手册，分上中下三册。上册是平面设计部分，中册是曲面设计部分，包括浮雕曲面设计和几何曲面设计，下册是雕刻加工部分。

本书是上册，共分一十五章，各章主要内容如下：

第一章介绍了CNC雕刻的特点和雕刻流程，以及精雕雕刻系统的基本组成。并介绍JDPaint的用户界面、各种工具栏的使用方法和主要的文件操作功能。

第二章介绍了JDPaint的基本操作方法，包括鼠标、键盘等交互设备在JDPaint中的一些约定用法，以及JDPaint系统的命令规范操作过程。

第三章介绍了图形选择工具的使用方法，包括对象的种类、对象的选择和显示、对象的快速编辑变换操作、图层设置及系统设置等内容。

第四章介绍了图形观察功能的使用方法，包括平面和三维显示环境下的视图放缩、平移旋转以及光源的设置等内容。

第五章介绍了绘图的基础知识，包括点与坐标系的基本概念、点的鼠标输入方法、点的键盘输入方法和点、长度、角度发生器的使用方法。

第六章介绍了所有图形绘制命令的使用方法，包括绘制点、线、圆弧、样条、多义线、圆、椭圆、矩形、正多边形、星形、绘制双线、箭头、绘制公式曲线等内容。

第七章介绍了图形编辑命令的使用方法，包括撤消、恢复、剪切、复制、粘贴，曲线的剪裁、延伸、倒角、等距、膨胀，区域的交、并、差等内容。

第八章介绍了图形变换命令的使用方法，包括图形变换、阵列、优化排样、调整方向、群组与集合操作和对象类型转换等内容。

第九章介绍了节点编修工具的使用方法，包括节点的快速编辑，节点的插入、删除、分离、融合，平滑连接、尖点连接、对称连接，定为起点，节点的对齐和移动，特殊节点的显示。另外，还包括图形修边工具和快速描边功能组。

第十章介绍了文字编辑工具，包括文字的一般录入、文字沿曲线录入、文字的基本编辑、文字的一般特性、文字的设置、文字的非精确调整、文字的精确调整、文字的曲线排编辑等内容。

第十一章介绍了艺术变形工具的使用方法，包括封套变形、透视变形、推拉变形、拉链变形、扭转变形、常用变形等内容。

第十二章介绍了图象矢量化工具的使用方法和如何描图。

第十三章介绍了JDPaint 5.0的输入输出接口，包括各种文件数据的输入输出、图库的创建与使用和扫描仪的使用等内容。

第十四章介绍了“测量功能”命令组的使用，包括了标尺测量、查看对象属性和测量功能组的使用说明。

第十五章介绍了“专用功能”命令组的使用，包括了印章设计、发饰加工、尺寸标注等由外部插件嵌入的专用功能组的使用说明。

运行环境

正常运行JDPaint雕刻软件需要一台电脑，配备相应的操作系统以及一些相关的辅助设备。计算机的硬件配置越高，JDPaint的运算速度和工作效率越高。如果经常使用艺术曲面设计、虚拟雕塑造型、曲面雕刻加工等耗费大量硬件资源的功能时，建议用户应至少选择手册推荐的标准配置。

计算机基本硬件配置

主频： | 最低 P3 500 | 标准P4 2G
内存： | 最低 64M | 标准256M
硬盘： | 最低 10G | 标准 40G
显卡（支持OpenGL）： | 最低 8M | 标准 32M
显示器 | 最低 15寸 | 标准 17寸
软驱： | 一只 |
USB | 一只 | 配备128M u盘一只
光驱： | 一只 |
鼠标： | 一只 |
并口： | 一只 |

可选辅助设备

扫描仪一台（TWAIN）

打印机一台

三维扫描仪一台

计算机基本软件配置

操作系统： | 中文Windows98 / Windows NT / Windows 2000 / Windows XP 标准配置为Windows 2000
显示环境： | 最低配置为256 色、640 × 480显示模式 标准配置为真彩色、1024×768显示模式


CNC雕刻与JDPaint 5.0

第一章 JDPaint 5.0简介

1.1 CNC雕刻与JDPaint 5.0

传统的雕刻是手工业的一个分支，加工产品的质量取决于雕刻人员的经验技巧，从学徒到师傅需要很长的时间，很多高超的技能还需要在今后的实践中不断的摸索和领悟。因为雕刻技能的继承性比较差，所以整个行业的发展十分缓慢，经过多个世纪的发展，手工雕刻技术仍然没有明显的变化。在近十几年中，由于计算机技术、信息技术、自动化技术在许多行业中得到了广泛应用，包括机械制造、金融、交通、管理等生产流通领域，极大地推动了这些行业的发展。多年来，人们一直希望这些先进的生产技术能应用到雕刻这个传统而古老的行业中。计算机数控雕刻技术（简称CNC雕刻技术）和计算机数控雕刻机（简称CNC雕刻机）的出现终于把人们这个多年的梦想变成了现实。

CNC雕刻技术是传统雕刻技术和现代数控技术结合的产物，它秉承了传统雕刻精细轻巧、灵活自如的操作特点，同时利用了传统数控加工中的自动化技术，并将二者有机的结合在一起，成为一种先进的雕刻技术。所有这些技术最终都是通过CNC雕刻机转化为真正的生产能力。CNC雕刻机集计算机辅助设计技术（CAD技术）、计算机辅助制造技术（CAM技术）、数控技术（NC技术）、精密制造技术于一体，是目前最先进的雕刻设备，代表了最先进的雕刻技术。使用CNC雕刻技术和CNC雕刻机已经成为雕刻行业的一种潮流。

1.1.1 CNC雕刻的特点

CNC雕刻来源于手工雕刻和传统数控加工，它与二者存在着相同点，同时又存在着一些区别。同任何先进的生产技术一样，CNC雕刻在弥补手工雕刻和传统数控加工的不足之处的同时，总是最大可能地吸取了二者的优点，将它们融会贯通，逐渐形成CNC雕刻的特点。

1、CNC雕刻的加工对象

CNC雕刻的主要加工对象为文字、图案、纹理、小型复杂曲面、薄壁件、小型精密零件、非规则的艺术浮雕曲面等，这些对象的特点是：尺寸小、形态复杂、成品要求精细。

2、CNC雕刻加工的工艺特点

CNC雕刻只能、而且必须使用小刀具加工。

3、CNC雕刻产品的尺寸精度高，产品一致性好

CNC雕刻产品的尺寸精度高，同一产品之间一致性好，这对于模具雕刻和有精密尺寸要求的批量产品加工来说具有重要的意义。另外，控制系统根据加工指令自动控制CNC雕刻机的刀具运动，完成雕刻任务，极大地减轻了劳动强度。这个高度自动化过程使生产大大降低了对传统手工雕刻操作技能的严重依赖程度。

4、CNC雕刻加工是高速铣削加工

与传统的数控加工比较，数控雕刻是高速铣削加工。高速铣削加工是一种高转速、小进给和快走刀的加工方式，形象地称为“少吃快跑”的加工方式。

1.1.2 CNC雕刻流程

CNC雕刻过程中需要CAD技术、CAM技术、NC技术、CNC雕刻机和技术支持等许多环节，缺少任何一个环节，CNC雕刻都会成为跛脚鸭，造成生产过程不畅通，甚至导致整个生产瘫痪。所以，当提起CNC雕刻时，我们应当从整体上理解CNC雕刻，更准确的将它称为CNC雕刻系统。图1-1是一个典型的CNC雕刻系统的流程图。

图1-1 CNC雕刻流程

产品说明 | 包括了加工材料、几何外形、雕刻精度等一系列产品的生产说明，产品的种类、型号不同，相应的说明书的详细程度也不尽相同。雕刻行业的产品主要集中在一些小模具加工、文字图案雕刻等方面，普遍要求产品生产周期短，以便迅速响应市场变化。
CAD建模 | 一般都是在专业雕刻软件上实现的，利用雕刻软件提供的绘图、建模工具，我们可以将产品说明中的文字说明变成产品数据模型。
几何模型 | 是一种可供计算机处理的电子数据，包括了产品的几何外形和尺寸，它是CAD建模的处理结果，也是CAM数控编程的原始数据。
CAM编程 | 一般是在专业的雕刻软件上实现的，利用雕刻软件提供的各种数控编程手段，我们可以根据产品的形状、材料、雕刻要求等规划合理的工艺方案，选择合适的雕刻手段生成实际的刀具轨迹。最终形成控制雕刻机运动和工作状态的NC程序。
NC程序 | 实际上就是有序的控制指令集，可以包括使用的刀具、主轴转速、进给速度、冷却状态、刀具位置、走刀方式等的控制指令。因为NC程序的主要内容是刀具运动位置信息，所以人们通常称为刀具路径。NC程序是凝聚了雕刻人员从分析、设计、工艺规划等一系列工作的劳动成果。
控制信号 | 数控系统是将NC程序解释成控制信号，输送到CNC雕刻机上，控制雕刻机的主轴和刀具运动，最终完成产品的雕刻作业，这个过程都是自动完成的。

特别需要注意的是：CNC雕刻过程聚集了许多高新技术，每项技术对任何初学者来说都有一定的难度，即使一些熟练的CNC雕刻人员也可能碰到一些技术难题。所以一套完整的CNC雕刻系统必须要有一套完整的技术支持体系。这样当任何环节出现不明白的地方时，都可以及时得到技术支持，保证产品按时完工。

1.1.3 CNC雕刻的基本要素

1、CNC雕刻必须具备专业的雕刻CAD软件

CNC雕刻是传统手工雕刻的工业化发展，要使雕刻这一饱含着人类高智能和高技能的工匠型行业上升为工业化专业生产最基本要求是：CNC雕刻设备必须要靠适应雕刻产品设计特点的、专业的雕刻CAD软件来支持。这也是数字化设备的最基本要求。

2、功能完备的雕刻CAM功能是CNC雕刻机效率的源泉

CNC雕刻机仅仅是一个计算机控制的加工工具，要使CNC雕刻能适应雕刻机自身的结构特点、雕刻产品的形态特征和加工工艺要求，发挥出较高的成品加工效率，关键要靠雕刻CAM功能，如果没有功能完备的雕刻CAM功能，CNC雕刻机工作效率和加工质量不会比一个熟练的手工工人高多少。

1.1.4 精雕CNC雕刻系统与雕刻CAD/CAM软件

北京精雕科技有限公司多年来一直致力于CNC雕刻技术和CNC雕刻系统的研制开发，形成了以精雕CNC雕刻机和JDPaint软件为核心的专业雕刻系统，为广告、模型、成品雕刻、模具等几十个行业提供了完整的CNC雕刻方案。

精雕CNC雕刻系统的基本组成如图1-2所示。

图 1-2 精雕CNC雕刻系统

精雕雕刻CAD/CAM软件――JDPaint以其独有的体系结构和功能布局提供了完备的精确制图和艺术绘图的混合设计能力。不仅提供功能强大的平面图形设计，还提供了功能强大的艺术浮雕曲面和NURBS曲面混合造型功能，为实现复杂形态雕刻产品的原创设计提供了有力的支持。JDPaint的雕刻CAM功能提供了丰富的工艺控制和刀具路径优化功能，并以独特的“等量切削”方法为代表的多种CNC雕刻工艺成功地支持了高速铣削（HSM）技术的实现，更好地解决了小刀具的加工效率问题，大大提高了产品加工精度和成品加工速度，推进了工匠型雕刻劳动上升为工业化专业生产的进程。功能强大的JDPaint雕刻软件是保证CNC数控雕刻系统正常运作的保证，也是有效提高CNC雕刻系统使用效率的源泉。目前，JDPaint已成为适合中国雕刻行业需求、功能逐步强大的专业雕刻设计平台。


JDPaint 用户界面

1.2 JDPaint 用户界面

认识精雕雕刻CAD/CAM软件——JDPaint，从认识操作界面布局开始。JDPaint 5.0的用户界面是Windows系统的标准式操作界面，如图1-3所示。这个界面具有Windows系统标准的菜单栏、浮动工具栏、状态栏和绘图区等。

图1-3 JDPaint 5.0操作界面

JDPaint 5.0的操作界面主要由以下部件组成：

标题栏 | 显示当前正在执行的应用程序和正在处理的文件名称。
菜单栏 | 菜单栏列出了应用程序可使用功能的分类。
状态工具栏 | 状态工具栏中的每个按钮分别对应了的不同的命令工具状态，每种状态对应不同的系统工作环境，可以完成相应的对象操作。
观察工具栏 | 最常用的工具栏之一，主要支持平面视图和三维视图操作。
导航工具栏 | 用于引导用户进行与当前状态或操作相关的工作。
颜色工具栏 | 颜色工具栏可设置对象的显示颜色或者填充颜色。
操作提示栏 | 显示正在使用功能的操作过程提示和操作结果。
坐标提示窗口 | 显示鼠标在工作窗口中的坐标位置。
输入窗口 | 一些功能的操作过程允许通过键盘输入坐标或数值数据。这时，位于操作提示栏上的输入窗口会自动打开，准备接受键盘输入。所有的键盘输入，必须在英文输入状态下进行。
2D/3D输入按钮 | 该按钮提示为“投影”时, 此时键盘输入的三维点或者空间捕捉点将直接投影到当前绘图平面上，作为当前绘图平面上的输入点。 该按钮提示为“空间”时, 此时键盘输入的三维点或者空间捕捉点将作为系统三维空间点直接输入。
坐标系转换按钮 | 该按钮提示为“U”时，此时键盘输入的点，将作为当前绘图面坐标系下输入的点处理。 该按钮提示为“W”时，此时键盘输入的点，将作为系统世界坐标系下输入的点处理。
工作窗口 | 用来绘图和对图形进行操作的区域。
工作区 | 用来表示设计工作的参照区域。
滚动条 | 分为水平和垂直滚动条两种，分别用来水平或垂直移动工作窗口中的观察区域。
标尺 | 在2D显示状态，标识工作窗口的位置和尺寸。在3D显示状态，仅用来表示工作窗口的尺寸，不能真实反映工作窗口的位置。
导航菜单 | 通过点击鼠标右键可弹出导航菜单，菜单中包含一些常用的命令。
辅助线 | 为蓝色虚线，分为水平辅助线与竖直辅助线，用于辅助准确排列和放置对象。辅助线仅在二维显示状态下可见。

1.2.1 工具栏的用法

JDPaint中有许多工具栏，通过工具栏可以很方便快捷地操作命令。其中最主要的三个工具栏：状态工具栏、导航工具栏、颜色工具栏，在此需加以详细介绍。

1.2.1.1 状态工具栏

状态工具栏是JDPaint系统最重要的工具栏之一，用于实现不同工具命令状态之间的切换。雕刻应用面广，应用对象特殊，针对不同行业有具体的行业要求，例如工业产品设计要求绘图高效而且设计精度要求高，而广告绘图虽不要求精确，但要求非常直观和便捷。为适应多方面的应用需求，JDPaint针对不同应用对象，设计了不同的编辑工具，相应地提供不同的工具命令状态。JDPaint针对文字、图形、图象、小型复杂曲面、和非规则的艺术浮雕曲面等对象，提供五个基本工具命令状态，如图1-4所示。

图1-4 状态工具栏

图形选择工具 | 系统常规工作状态。在该状态下，可以进行常规的对象选取、绘图、编辑、变换、构造曲面、生成加工路径等操作。
节点编修工具 | 系统特殊工作状态——图形节点编辑与曲线修边编辑状态。在该状态，可以观察到图形节点的基本构成，并能通过对图形节点、控制点及曲线的移动、拉伸、删除等操作，对常规图形以及由文字、艺术变形等对象转变成的图形进行局部编修或变形处理。
文字编辑工具 | 在该状态下，可以进行文字的录入、编辑和排版。
艺术变形工具 | 在该状态下，可以对图形、文字等对象进行封套、透视、推拉、拉链和扭转等艺术变形。
图象矢量化工具 | 在该状态下，可以对图象对象按灰度阈值或者按指定颜色区域，提取轮廓曲线和中心线。

除了以上基本工具状态外，JDPaint可以根据系统模块定制，支持多种工具命令。例如：

虚拟雕塑工具 | 在该状态下，可以对艺术曲面进行设计、编辑和修饰。该工具是由JDVirs1.0所提供的功能。虚拟雕塑工具使得设计与编辑艺术浮雕曲面如同修改平面图象一样方便快捷，特别适合复杂的艺术浮雕、首饰设计、钱币图案、人物外貌、花草等的造型创意。
曲面造型工具 | 该状态为工业模具设计服务，提供了复杂曲面的三维设计环境，具备强大的三维线框设计功能和NURBS曲面造型功能。该工具是由北京进取者软件有限公司在JDPaint平台上研发的SurfMill 1.0所提供的。
数控加工工具 | 该状态为工业模具加工服务，提供了复杂曲面的加工环境，支持复杂曲面模型的各种加工工艺方法。同曲面造型工具一样，该工具也是由SurfMill 1.0所提供的。

1.2.1.2 导航工具栏

导航工具栏能引导用户进行与当前状态或操作相关的工作，是JDPaint系统中十分重要的工具栏之一。状态工具栏中的不同工具，总有一个不同的导航工具栏与之相对应。该导航工具栏会包含一些与当前工具相关的常用基础命令。

刚进入JDPaint5.0界面，系统处于图形选择工具状态时，位于界面右侧导航工具栏的状态如图1-5所示。

在一些命令执行时，会在当前的导航工具栏的下部区域动态添加一组导航选项，指导用户的操作过程；这些导航选项的形态主要包括按钮、检查框等。图1-6所示的是圆绘制命令在选择导航工具栏上添加的导航选项。

图1-5 图形选择工具状态的导航工具栏 图1-6 圆绘制命令的导航选项

另外，也有一部分命令会创建自己的导航工具栏，在此导航工具栏上，用户可输入命令参数、改变命令选项，最终完成命令执行过程。常规命令的导航工具栏被创建后，会悬挂在导航工具栏的分页窗口中的最右侧位置，命令结束后，它会被命令自动删除，分页窗口恢复原来的状态。如图1-7所示，是图层命令创建的导航工具栏。

导航工具栏会因为当前工具和执行命令的不同，而具有不同的参数选项和形态，从而具有不同的功能和操作方法。各种导航工具栏的相关参数意义和操作方法将会在以后的有关章节中结合具体的命令和工具进行详细说明。

1.2.1.3 颜色工具栏

“颜色工具栏”主要用于修改图形、文字等操作对象的颜色，设置轮廓线或者区域填充颜色，从而获得彩色效果图。“颜色工具栏”位于操作界面的右边，布局如图1-8所示。

图1-8 颜色工具栏

颜色填充 | 仅在2D绘制下有效，是2D颜色显示模式的切换开关。 按钮为 [image] 时，表示2D颜色显示模式为单线模式，所有的2D图形按单线显示，并且在改变对象颜色时，仅改变单线颜色，不进行颜色填充； 按钮为 [image] 时，表示2D颜色显示模式为颜色填充模式。被填充的2D封闭图形显示填充颜色，并且在改变对象颜色时，进行颜色填充；
颜色拾取 | 启动颜色拾取命令，拾取某一对象的颜色作为系统当前颜色。
调色板 | 启动调色板命令，从颜色调色板中选择一种颜色作为系统当前颜色。
当前颜色 | 显示系统的当前颜色。
清除填充 | 当某一选中对象(轮廓曲线或者区域)处于颜色填充绘制状态时，点击该按钮，取消该对象颜色填充状态。
颜色按钮 | 颜色按钮列表中列出了几十种颜色，有两种用法： (1) 当系统有选中对象时，点击颜色按钮中的任意一种颜色，将直接修改选中对象的显示颜色； (2) 当系统没有选中对象时，点击颜色按钮中的任意一种颜色，将指定颜色设置为系统当前颜色。
颜色上卷 | 显示上一卷的颜色。
颜色下卷 | 显示下一卷的颜色。

通过颜色调色板设置系统当前颜色。单击〖调色板〗按钮可以弹出“颜色”对话框，如图1-9所示，选中一种颜色，单击〖确定〗后，实现系统当前颜色设置。

图 1-9 颜色调色板

1.2.2 菜单命令

菜单是应用程序的操作命令集，按照其功能不同分为若干菜单组。JDPaint的菜单有下拉式菜单、弹出式菜单两种。

1.2.2.1 下拉式菜单

主菜单栏中所有的菜单项都是下拉式菜单，包括“文件、查看、绘制、编辑、变换、艺术曲面、几何曲面、专业功能、刀具路径、测量、帮助”等菜单项，用鼠标单击一下其中的一个菜单项，或者使用键盘组合键“Alt+菜单项右面的大写字母”，就会拉下来一串菜单，故称下拉式菜单。如图1-10所示，点击“绘制”菜单项，或使用键盘组合键“Alt+D”，即可弹出下拉式菜单，菜单中列出了所有的绘制命令。

每个菜单项都包含若干条菜单命令，它们可以是：

① 子菜单项——子菜单项右边带有“ [image] ”表示本身不能被执行，而是带有下一级菜单项。

② 菜单命令——可执行的操作命令。

可执行的菜单命令大体可分为四类：

命令右边带有“…” | 表示执行时要弹出一个对话框，在对话框中要求用户选择或输入一定的参数才能继续执行命令。
以黑色亮字符显示 | 表示当前状态下此命令可执行。
以灰色暗字符显示 | 表示当前状态下不能使用此命令。
开关式菜单命令 | 此类命令通常没有明显的执行动作，它在程序运行期间始终起作用或始终不起作用，直至用鼠标单击后改变它的作用状态。 此类命令前面“√”，表示正在起作用，无“√”则表示不起作用。

如图1-12标注了”视图”菜单命令的使能状态。

图 1-12 “视图”菜单命令的使能状态

1.2.2.2 弹出式菜单

弹出式菜单平时不可见，在JDPaint中通常是点击按鼠标右键弹出，弹出的菜单击只有菜单命令。点击右键时，鼠标指向的位置不同，弹出的菜单内容就可能不同。弹出式菜单中的命令包含了一些常用命令和一些与上下文相关的的命令。

以图形选择工具状态为例，在JDPaint工作窗口中的绘图区单击鼠标右键，即可弹出一个弹出式菜单，这个菜单也称为导航菜单，如图1-13所示。

图 1-13 弹出式菜单

图1-13菜单命令布局说明：

最近的两次操作命令 | 即：重复命令⑴和重复命令⑵。 点击其中的一个命令，可对此命令进行再次操作。“重复命令⑴和重复命令⑵”只有在进行了两次不同的操作之后才会显示出来。（撤消、重做命令及视窗操作命令以外）。
对象属性 | 选中一个或一组对象，可查看它们的属性。未选择对象时，此命令不显示。
观察命令 | 即窗口观察、全部观察、选择观察、上次观察。这四个命令始终存在于导航菜单中供你选择执行。
辅助线编辑 | 鼠标未指向辅助线时，此命令不显示。用鼠标指向一条辅助线，点击右键，可弹出辅助线编辑的对话框。
重画 | 此命令用于重画当前视图。


JDPaint 50的文件操作

1.3 JDPaint 50的文件操作

在JDPaint 50中，对文件的操作是标准的Windows系统方式。JDPaint所提供的许多基本文件输入输出命令也都采用Windows系统的命令方式。这里主要介绍以下基本文件操作，如图1-14所示，其它文件命令在后面章节分别介绍。

图 1-14 文件菜单

新建 | 新建一个JDPaint文件（*.jdp）。
打开 | 打开一个已保存的JDPaint文件。
保存 | 保存当前编辑的JDPaint文件。
另存为 | 将当前编辑的JDPaint文件另外保存为一个文件。
文件信息 | 查看或编辑当前文件的相关信息。
查找文件 | 通过文件的相关信息查找文件。
退出 | 退出JDPaint编辑系统。

1.3.1 新建文件

启动JDPaint 5.0 后，系统按其默认配置自动创建一个文件。若已经存在一个文件，要新建另一个文件，也可通过“文件”菜单下的“新建”命令来实现。

“新建”命令的使用过程如下：

⑴ 在JDPaint主界面下使用鼠标单击“文件（F）→新建（N）”命令。

⑵ 此时JDPaint将刷新工作区，产生一个名为“无标题”的设计文件，并在主界面的标题栏中显示出来，如图1-15所示。

图 1-15 文件新建

使用“新建”命令时，如果当前窗口中有图形等数据，并在最后一次修改之后没有保存，系统会弹出一个提示框询问用户是否保存当前内容，如果用户要保存当前内容，就点击〖是（Y）〗按钮，如图1-16所示。

图 1-16 文件保存提示框

点击〖是（Y）〗按钮后，系统弹出“保存为”对话框，按要求输入参数，点击〖确定〗即可完成保存，“保存”功能在下面章节中详细讲解。

1.3.2 打开文件

打开“文件”就是打开一个已经保存在计算机中的设计文件。利用“打开”命令只能打开扩展名为 JDP 的文件。

“打开”设计文件的过程如下：

⑴ 在JDPaint主界面下使用鼠标点击“文件（F）→打开（O）”命令，此时系统弹出“打开”文件对话框，如图1-17所示。

图 1-17 打开文件

⑵ “打开文件”对话框的列表框中，列出了当前路径下所有以JDP为扩展名的设计文件，用户可通过点击 [image] 和 [image] 按钮改变驱动器、路径、目录的名称，找寻其它路径下的设计文件。使用鼠标单击 [image] 按钮或拖动滚动条，可浏览当前路径下的所有文件，用鼠标单击所选文件，文件颜色变深，表示文件被选中，JDPaint将选中文件的文件名自动填入文件名编辑框中，还可以直接将文件名用键盘敲入文件名输入框中。在预览窗中还会显示文件的图案。

⑶ 点击“打开”键，JDPaint自动进行文件的打开工作。

若当前操作窗口中的文件尚未存储，打开一个新的文件时，也会出现提示是否“将改动保存”的对话框，其具体方法与新建命令中保存文件一样。

文件的新建和打开命令只能建立唯一的窗口，要建立多个并行的窗口，必须同时打开多个JDPaint操作窗口，在多个窗口中进行操作。

1.3.3 保存文件

为了让计算机把我们的设计文件“记忆”下来，以供随时调用，我们要使用“保存”这个重要的命令，它能将设计工作产生的各类数据存储到计算机中，保存有两种情况：

⑴ 保存到当前的文件中，即：存入在标题栏中标明的文件中。

⑵ 若当前文件为未命名的“无标题”文件，JDPaint将要求用户重新输入文件名，文件类型仍为JDP，在文件保存的过程中将生成新的设计文件。

在设计过程中应及时保存中间设计数据，防止出现意外，免得前功尽弃。

“保存”设计文件的过程如下：

⑴ 点击“文件（F）→保存（S）”命令。

⑵ 若当前文件是打开的文件或已经保存过的文件，系统会自动完成保存，即：用当前操作窗口中的“东西”覆盖掉过去的“东西”。

若当前文件为“无标题”，即：没有进行保存过，需重新输入文件名来建立一个新文件，系统弹出对话框，你可以按照对话框的提示，确定文件要保存的地方（路径）、输入文件名、输入文件信息，并允许保存图象，若前后的文件名一样，将会用新的数据去覆盖原有数据。如图1-18所示。

图 1-18 保存文件

该对话框的使用基本方式同“打开”文件对话框一致。所不同的是，在对话框的［作者］、［客户］、［备注］项，用户可输入对该文件的一些说明文字。

千万别用“空白”的文件去替换一个有数据的文件，这样计算机会抹掉数据文件，生成一个空文件，那就后悔莫及了。

1.3.4 另存为

当我们运用“保存”命令保存文件的时候，将会用当前的数据把过去的数据覆盖掉，只保留当前的结果，有时，我们想保存中间的数据；或者为了方便或安全起见，想在其它路径下保存；或者想另外对文件起个名字，这时就可以使用“另存为”命令，将当前的设计数据保存到一个新的文件中。新文件中文件名发生变化，而文件类型仍为 JDP 类型。

“另存为”的执行过程如下：

⑴ 点击“文件（Ｆ）→另存为（Ａ）”命令，此时系统弹出“另存为”对话框。

⑵ 在“另存为”对话框中输入新的文件名，在对话框的［作者］、［客 户］、［备注］项，可以输入对该文件的一些说明文字。

⑶ 点击〖保存〗按钮，JDPaint将当前的数据存入新文件中。操作界面的标题栏就显示新文件的文件名。

1.3.5 文件信息

为了方便地查看文件信息，JDPaint还设计了“标签”，即“文件信息”功能命令。

点击“文件（F）→文件信息(D)”命令，系统弹出“文件信息”对话框，如图1-19所示。

图 1-19 文件信息

一个新建的文件，“文件信息”对话框为空白，用户可建立“作者”、“客户”名称，在“备注”栏可以填入一些相关信息，如：文件说明等，还可以通过“打开”或“输入”命令调用已存在的文件进行修改信息。

系统自动生成“创建时间”和“修改时间”，可供用户参考。

在“备注”栏输入文字时，如果需要换行，使用“Ctrl+Enter”键盘组合键，若只用“Enter（回车）”键，就会退出对话框。

1.3.6 查找文件

由于时间过长，或文件、目录太多，或忘记了存放文件夹的名称，这样找起来就比较费劲了，用“查找文件”命令，可以让你将文件“信手拈来”。

“查找文件”只能查找JDP格式的文件。

点击“文件（F）→查找文件（H）”命令，系统弹出“查找文件”对话框，如图1-20所示。

图 1-20 查找文件

“查找文件”的具体步骤如下：

⑴ 选择设计文件（扩展名为*.jdp的文件）所在的目录，可用键盘在目录中输入文件名，也可以通过点击 [image] 选择一个目录。

⑵ 根据用户已知条件选择作者、客户、备注、版本、修改时间、创建时间各项中的一项或多项作为你的查找条件，例如知道作者、用户的名称，可在相应的提示栏中输入。条件越多，筛选出来的范围越小。

⑶ 点击〖开始查找〗按钮，系统开始查找符合要求的文件，查找完毕以后，在文件列表中会列出符合条件的文件，点击文件，或者通过文件的效果预览作为参考。

⑷ 确认无误后，点击〖打开〗按钮，将文件输入到操作窗口中。

通过“查找文件”打开文件与直接使用“打开”命令打开文件一样，点击“打开”后，系统会提示“是否将改动保存到某某处”，即：“查找文件”打开的文件要替换掉上一个文件。

1.3.7 退出JDPaint 5.0

退出JDPaint 50是Windows系统的标准操作之一，其退出方式有以下几种：

1） 双击JDPaint标题栏最左端的标志 [image] ，可以关闭程序。

2） 单击标题栏最右端的标准Windows程序的关闭按钮 [image] ，可以关闭程序。

3） 执行菜单项命令“文件（F）→退出（X）”，可以关闭程序。


第二章 JDPaint基本操作

JDPaint是一个集精确绘图与非精确绘图于一体的CAD/CAM软件系统。在绘图时，可以用鼠标来进行点的捕捉，也可直接由键盘输入精确的坐标位置。使用JDPaint提供的命令进行创建和修改图形，显示屏幕、键盘和鼠标是必不可少的图形交互工具。JDPaint系统中的基本操作大多数符合Windows操作习惯，但是在一些键盘和鼠标的操作功能也做了新的约定。

本章着重阐述键盘和鼠标在JDPaint系统中一些约定用法，以及为提高图形设计效率所提供的一些快捷使用技巧，最后再阐述JDPaint命令操作交互规范。


键盘操作

2.1 键盘操作

键盘一般用来输入操作数据，或者执行操作命令。在JDPaint系统中，其功能主要有下述几种：

1. 输入数据

2. 录入文字

3. 常用功能键

4. 导航功能键

5. 组合键操作

6. 快捷键操作

2.1.1 输入数据

在命令执行过程中，在屏幕窗口右下角的输入窗口 [image] 中可以通过键盘输入所需要的数值参数，如点坐标、长度、角度等。输入完毕后按回车键（ENTER）即可将数值输入。

如果使用小键盘输入数据时，要注意(Num Lock)灯是否开启，如果灯关闭，按下“Num Lock”键来切换，只有(Num Lock)灯亮时，输入的数值才有效。数据输入时，不能也不必用鼠标点击输入窗口使其产生光标，当输入窗口变亮时，直接使用键盘输入数字即可。

注意：输入数据时，一定要在英文输入状态下进行操作。

2.1.2 录入文字

在文字工具状态下，可以通过键盘输入文字。

2.1.3 常用功能键

常用功能键在JDPaint中有一些特殊的约定用法。熟悉常用功能键定义，对于熟练应用JDPaint软件有重大帮助。因此，本部分功能说明对于每一位JDPaint软件用户都非常重要。

 | ESC键 | (1) 结束当前命令任务。 (2) 关闭当前对话框。
 | Enter键 | (1)确认当前命令进入下一步。 (2)结束当前命令任务。 (3)关闭当前对话框。
 | Space 空格键 | 在输入点、长度或者角度时，按下空格键，进入精确定点、定长或者定角度命令。
 | Shift键 | (1) 用鼠标进行对象选择时，按下“Shift”键可实现对象的累加选择。 (2) 用鼠标进行对象快速变换时，按下“Shift”键可切换变换方式。移动功能改变为复制功能，拉伸功能改变为倾斜功能。 (3) 在渲染显示时，按住“Shift”键，按住右键，拖动鼠标，可平移视窗进行观察。
 | Ctrl键 | (1) 用鼠标进行对象选择时，按下“Ctrl”键可取消对象的选择状态。 (2) 在渲染显示时，按住“Ctrl”键同时按下鼠标右键并拖动鼠标，可以进行视窗的三维观察。 (3) 在正交模式鼠标输入点时，按住“Ctrl”键可输入短轴坐标，否则，输入长轴坐标。 (4) 在对操作对象进行快速变换时，按住“Ctrl”键，可以保证中心位置不变。
Ctrl + | Ctrl + TAB | 重复上一步命令。
 | PageUp | 视窗放大一倍。
 | PageDown | 视窗缩小一倍。
 | BackSpace | 在“文字编辑工具”状态下，删除光标前面的字符。
 | 上下左右键 | (1) 在“图形选择工具”状态下： 可以按“微调距离”移动被选中的目标。 移动的同时按住“Ctrl”键，可以按“微调距离”复制图形。 移动的同时按住“Shift”键，可以按“微调角度”旋转图形。 (2) 在“结点编修工具”状态下： 可以“微调距离”移动被选中的节点。 (3) 在“文字编辑工具”状态下： 可以移动输入文字的光标。 同时按住“Shift”键，可实现对文字字符的选择。
 | Delete | (1) 在“图形选择工具”和“结点编辑工具”状态下，可以删除被选中的目标。 (2) 在“文字编辑工具”状态下可以删除光标后面的字符。
 | Home | 在“文字编辑工具”状态下： (1) 可以快速地把光标移动到光标所在行的行首。 (2) “Ctrl+ Home”可以快速把光标移到该文档的文首。 (3) “Shift + Home”可以快速地选择从光标位置到光标所在行的行首之间的文字。
 | End | 在“文字编辑工具”状态下： (1) 可以快速地把光标移动到光标所在行的行末。 (2) “Ctrl+ End”可以快速把光标移到该文档的文末。 (3) “Shift+ End”可以快速地选择从光标位置到光标所在行的行末之间的文字。

2.1.4 导航功能键

导航功能键是JDPaint有特色的键盘快捷操作方式。之所以称为导航功能键，是这些键都出现在导航工具栏中，随着不同的工具状态、不同的运行命令而动态地发生变化。使用者可以通过敲击一个按键快速启动一个新的命令，或者完成命令功能选项的选择。一般而言，导航功能键都是可见的，凡在导航工具栏中的按钮、检查框等控制，如果其标题具有一个被中括号包括的下划线字符，那么该字符即是一个导航功能键。 如图2-1所示，是直线绘制命令运行时在导航工具栏上添加的导航选项：

图2-1 直线绘制命令的导航选项

如图2-1所示，直线绘制命令的导航选项可以用从A—K这几个导航功能键进行快速设置，从而完成各种不同方法的直线绘制。 需要注意的是，只有绘图窗口具有输入焦点时，导航功能键的使用才有效。

2.1.5 组合键操作

组合键是常用到的典型Windows操作风格的键盘快捷操作之一。在JDPaint软件中，每个菜单名称和菜单命令都对应着一个字母，所以可以在按住“Alt ”键的同时，按下“菜单名称字母”后，弹出“下拉菜单”，然后敲击“菜单命令字母”，即：

Alt+菜单名称字母 → 菜单命令字母

例如：“文件”菜单名称是“F”，“打开”命令是“O”，那么“打开”的组合键操作就是“Alt+F→O”，其它命令操作类似，通过各个不同字母组合完成需要的命令。

2.1.6 快捷键操作

快捷键是启动JDPaint中常用命令最快捷的方法，它与常用功能键、导航功能键的有机结合，形成一整套具有方便、快捷的JDPaint系统操作命令体系。JDPaint中常用命令快捷操作，详细说明参照“常用快捷键表”。

常用快捷键表

序号 | 菜单类 | 菜单命令 | 快捷键 | 说明
1 | 文件 | 新建 | Ctrl +N | 建立新文挡
2 |  | 打开 | Ctrl+O | 打开一个现有的文档
3 |  | 保存 | Ctrl+S | 保存活动文档
4 | 查看 | 窗口观察 | F5 | 对图形进行窗口放大
5 |  | 全部观察 | F6 | 将所有的图形显示到整个工作窗口
6 |  | 选择观察 | F7 | 将选择的图形显示到整个工作窗口
7 |  | 上次观察 | F8 | 恢复到上次的工作窗口
8 |  | 全屏观察 | F12 | 开启或关闭全屏绘图模式
9 |  | 重画 | Ctrl+R | 重新显示工作窗口
10 |  | 正交捕捉 | Ctrl+D | 开启或关闭正交捕捉模式
11 |  | 特征点自动捕捉 | Ctrl+E` | 开启或关闭特征点自动捕捉模式
12 |  | 显示填充 | Ctrl+F | 显示或隐藏填充颜色
13 | 绘制 | 直线 | Ctrl+Q | 绘制直线
14 |  | 圆弧 | Ctrl+A | 绘制圆弧
15 |  | 多义线 | Ctrl+W | 绘制多义线
16 | 编辑 | 撤消 | Ctrl+Z | 撤消一步操作
17 |  | 剪切 | Ctrl+X | 剪切被选对象，并将其置于剪贴板上
序号 | 菜单类 | 菜单命令 | 快捷键 | 说明
18 |  | 复制 | Ctrl+C Ctrl+Ins | 复制被选对象，并将其置于剪贴板上
19 |  | 粘贴 | Ctrl+V Shift+Ins | 插入剪贴板内容
20 |  | 删除 | Del | 删除被选对象
21 |  | 切断 | Alt+1 | 图形切断
22 |  | 修剪 | Alt+2 | 图形快速裁剪
23 |  | 延伸 | Alt+3 | 非闭合图形延伸
24 |  | 倒圆角 | Alt+4 |
25 |  | 倒斜角 | Alt+5 |
26 |  | 连接 | Alt+6 |
27 |  | 区域等距 | Ctrl+1 | 计算轮廓曲线区域的等距线
28 |  | 区域焊接 | Ctrl+2 | 曲线轮廓区域的求并运算
29 |  | 区域剪裁 | Ctrl+3 | 曲线轮廓区域的相减运算
30 |  | 区域相交 | Ctrl+4 | 曲线轮廓区域的求交集运算
31 | 变换 | 集合 | Alt+F2 | 将被选图形组合为一个集合
32 |  | 取消集合 | Alt+F3 | 将被选图形打散成为单个图形


鼠标操作

2.2 鼠标操作

鼠标作为主要的图形输入设备，可以在屏幕上实现点击、拖动、启动命令和退出系统等操作行为。在JDPaint中，鼠标操作可以完成以下功能：

l 精确定点

l 拾取操作对象

l 启动菜单命令

l 改变命令的进程

l 结束运行命令

下文总结JDPaint系统中一些主要的鼠标操作约定和实现功能。

 | 单击鼠标左键
选择操作命令 | 通过点击“菜单”命令或快捷按钮等，选择并启动该操作命令。
精确定点 | 在绘制、编辑、变换等操作中，凡是要求输入点、圆心、基点、长度、角度等操作要求的，皆可通过鼠标点击、捕捉特征点等操作来完成。
拾取操作对象 | 将鼠标移动到工作窗口中指定的对象上，单击鼠标左键，该图形即被选中，进入到相应的操作状态中。 用鼠标进行对象选择时, (1) <Shift>+鼠标左键：实现对象的累加选择。 (2) <Ctrl>+鼠标左键：取消对象的选择状态。
 | 点击鼠标右键
导出导航菜单 | 系统处于工具命令状态，在工作窗口中点击鼠标右键，在该位置会弹出一个菜单，称为导航菜单。
结束当前命令 | 对于一部分没有自有导航工具栏的命令，在命令运行过程中，单击鼠标右键可以结束当前命令。相当于<ESC>命令。
“下一步”操作 | 默认当前命令参数。当系统处于常规命令状态，在输入长度、角度等操作过程中，如果采用当前命令预设的参数值，通过点击鼠标右键来确认，继续下一步操作。 结束当前操作，进入下一操作流程。例如，在修剪、延伸等命令操作中，需要通过点击右键切换到第二步操作。
“下一段” | 结束当前段，绘制另一段。例如，绘制“多义线”中的样条曲线时，可以通过点击右键来绘制下一段。

其它的一些鼠标行为约定：

拖动鼠标 | 使用鼠标拖动对图形进行快速变换（十点法则）、快速的节点编辑等，完成一些快速编辑操作。
双击鼠标左键 | 在“节点编辑工具”状态下，双击鼠标左键完成插入节点或者删除节点命令。 在“文字编辑工具”状态下，双击鼠标左键可以进行整个字串的选择操作。


命令操作

2.3 命令操作

JDPaint的命令可归为两大类型：工具命令和常规命令。

2.3.1 工具命令

工具命令是JDPaint针对不同的操作对象，提供不同的工作命令状态。例如，前文提到的图形选择工具、文字编辑工具、节点编修工具、图象矢量化工具等等。

工具命令有以下特点：

（1）每个工具命令可以有自身独立的图形编辑环境和显示环境。

（2）每个工具命令均针对特定的对象来实现操作与编辑。

（3）针对特定的操作对象，工具命令可以有适合自身特点的命令交互方式。

（4）工具命令是开放式的，可以随着用户的需求，改进指定工具命令，而不必更新整个系统。

工具命令工作状态的设置或切换，可以通过点击状态工具栏的相关按钮来实现。工具命令机制的支持保证了JDPaint系统成为开放式的雕刻软件系统平台，使精雕科技可以随时根据用户的需求、新兴雕刻行业的开拓提供专业技术支持。随着雕刻行业的发展和软件功能的不断增强，陆续会增加并推出新的工具命令。

2.3.2 常规命令

常规命令是指在特定工具命令状态下，实现特定功能的、具有特定使能状态的、需要启动和结束的、可执行的操作命令。例如在图形选择工具状态下，绘制直线命令就属于常规命令。大量的功能、强大的常规命令是JDPaint实现强大功能的保证。

常规命令的启动主要有四种途径：

（1）通过系统定义的快捷键操作启动命令；

（2）通过菜单栏的菜单命令选项操作；

（3）通过工具栏的工具按钮操作；

（4）通过点击鼠标右键，弹出的导航菜单操作。

常规命令均有统一的命令交互规范过程。

* 其规范的操作过程如下：

选择操作对象 | 如果命令不需预先选择对象，此步骤可忽略。
启动操作命令 | 即开始执行命令，点击相应的菜单命令、功能键、键盘快捷键或者命令按钮。如果该命令不需输入操作参数或选取操作对象，那么完成运算后会立即结束，否则，将进入下一个操作过程。
输入操作参数 | 用户可以根据命令操作提示，在相应的对话框、导航工具栏或者参数输入窗口中输入参数，确认后进入下一个操作过程或者结束命令操作。
选择操作对象 | 用户可以根据命令操作提示，选择指定的操作对象，确认后进入下一个操作过程或者结束命令操作。
结束操作命令 | 部分命令是循环操作命令，不能自动退出，用户必须通过单击鼠标右键或按Esc键来结束操作命令。

  初学者对命令不太熟悉的时候，一定要注意屏幕下方操作提示栏的提示。

  在命令操作过程中，改变命令操作进程的方法主要有：

（1） 点击鼠标右键，表示结束当前命令进程，进入下一步。

（2） 按Esc键，强行结束当前操作命令。


图形选择工具

第三章 图形选择工具

图形选择工具是JDPaint系统的常规工作状态，是系统中功能最强大、命令交互方式最丰富的工具命令之一。在该状态下，可以进行图形对象选择、快速变换、绘制图形、编辑图形、构造曲面和生成加工刀具路径等操作。启动JDPaint 5.0后，系统自动进入图形选择工具状态时，位于界面右侧导航工具栏的状态如图3-1所示。

微调距离 | 使用键盘快速平移对象时的调整距离。系统默认值为1mm，可通过键盘输入来增大或减小这个数值。
微调角度 | 使用键盘快速旋转对象时的调整角度。系统默认值为15度，可通过键盘输入来增大或减小这个角度。
选择 | 按指定对象类型或颜色选择对象。
显示 | 按指定对象类型或颜色显示或者隐藏对象。
图层 | 对象的图层管理。
加锁 | 按指定对象类型或颜色对对象进行加锁或者解锁操作。
顺序 | 调整对象的显示顺序，在图形对象填充显示时特别有用。
对齐 | 对象对齐命令。

本章讲述选择工具环境下提供的通用对象操作功能，主要有以下内容：

l 系统支持的对象类型

l 对象的选择与拾取

l 对象的微调与快速变换

l 对象的显示与隐藏

l 对象的显示颜色

l 对象的显示顺序

l 对象的加锁

l 对象的图层管理

l 构造辅助线

l 对象的对齐

l 系统设置


系统支持的对象类型

3.1 系统支持的对象类型

在进行对象操作编辑之前，有必要了解JDPaint系统能够对哪些类型对象进行操作处理。不同类型的对象具有不同的属性，操作方法也不相同。因此，通过了解对象类型，用户可以对所编辑的对象做到心中有数。JDPaint主要支持以下对象类型的操作，如表3-1所示，这些对象共同组成各种复杂的图形文件。

表 3-1 系统支持的对象类型

对象类型 | 类型描述
图形 | 图形是精确表达一个物体的结构、形状尺寸及其它信息的二维对象，是系统中最基本、最常用的操作对象。图形对象由基本图形元素组成，基本图形元素主要有：点、直线、圆弧、圆、椭圆和样条曲线。 JDPaint提供的图形类有：多义线，圆、椭圆和图形结合。
文字 | JDPaint支持各种字体的文字排版，如轮廓字体、单线字体、笔画字体等，每种字体均可设置不同的字形。 JDPaint提供的文字类有：多行排文字、圆排文字、椭圆排文字和沿任意曲线排文字。
图象 | 即数字图象，由象素点组成并具有色彩特征的点阵图象，图象类似于照片。
艺术变形 | 艺术变形类是指按照特殊艺术效果变形图形或者文字对象所获得的新对象类型。 JDPaint支持的艺术变形主要有：封套变形、透视变形、推拉变形、拉链变形、扭转变形。
三维曲线 | 三维曲线类是指位于三维空间上的几何曲线，主要有：直线、圆弧、样条曲线和等距线。
曲面 | JDPaint支持精确表达形体的几何曲面和非精确表达形体的艺术浮雕曲面。 精确的几何曲面是基于NURBS曲面造型技术的、能够保证高精度的几何形体表达，主要类型有：二次圆锥曲面（如球面、圆柱面等），直纹曲面、旋转曲面和NURBS曲面。 非精确的艺术浮雕曲面是基于网格曲面变形技术的非精确几何形体表达。非精确的艺术浮雕曲面特别适合于不能用精确几何表达的形体，例如艺术浮雕、首饰等。
群组 | 各种对象组成的共同体，可统一操作。
刀具路径 | 刀具走刀的路线对象。
辅助线 | 用来帮助图形快速定位的辅助直线。
节点 | 即图形的结构点，是组成图形的具有特殊结构特征的点。图形的节点只有在图形节点编修状态才会显示可见。


对象的选择与拾取

3.2 对象的选择与拾取

对象的选择是图形选择工具下常用的操作，也是熟练应用JDPaint系统的基础。在JDPaint系统，我们把对象的选择与对象的拾取加以区分：

对象的选择是指工具命令状态下对图形对象的选择，包括点选、框选和按指定类型选择等功能。JDPaint系统中大部分的命令首先都要进行对象的选择。

对象的拾取是指在常规命令过程中要求拾取一个操作对象的过程，实际上往往是一个点选操作。

通常地，二者在JDPaint系统中没有本质的区别，只是在不同对象操作过程中，叫法不同而已。目前，JDPaint系统提供三种对象选择的方法：

l 点选

l 窗选

l 按对象类型选择

3.2.1 点选

将鼠标移动到指定的对象上，单击鼠标左键，对象被选中。如图3-2所示对图形的点选。通常地，点选也被称为点拾取。

图 3-2 对象点选

3.2.2 窗选

在窗口空白处按住鼠标左键，拖动鼠标形成一个蓝色的矩形线框，以鼠标点击的位置为相对点，鼠标可以向左移动，也可以向右移动，如图3-3所示。

图 3-3 对象窗选

窗选可分为两类：

l 包含窗选：鼠标从左到右拖动，需要把所要选择的对象全部框住，松开鼠标左键，凡是框内套住的对象就被选中，如图3-4所示。

图 3-4 包含窗选

l 相交窗选：鼠标从右到左拖动，松开鼠标左键，凡是与矩形线框相交的对象和矩形框内套住的对象都被选中，如图3-5所示。

图 3-5 相交窗选

说明

复选： | 按住“Shift”键，继续点选或窗选对象，可以很方便自如地完成复选。
反选： | 按住“Ctrl”键，继续点选或窗选对象，可完成反选，即将被选对象转为未选状态。

3.2.3 按对象类型选择

在选择工具状态下，点击导航工具栏中的“ [image] ”按钮，进入按对象类型选择命令，导航工具栏出现如图3-6所示对话框。

图 3-6 按对象类型选择

对象过滤 | “对象过滤”根据对象类型来进行筛选对象。不同类型的旁边有该类型对象数目的统计，从下拉列表中可以选择“选中个数”、“未选个数”和“总数”分别统计。 将对象按类型分开，可以有效地实现指定类型对象的选择。
颜色过滤 | “颜色过滤”根据指定颜色来筛选对象。选中此选项，单击“ [image] ”按钮，弹出颜色选择对话框，可以指定颜色。也可点击“ [image] ”按钮，鼠标变成如图3-7所示形状，拾取对象就可获得指定对象的颜色。 图 3-7 拾取对象颜色
全部选中 | 点击“ [image] ”按钮，则选中窗口内所有通过“对象过滤”和“颜色过滤”后的对象；
全部不选 | 点击“ [image] ”按钮，则按窗口内所有通过“对象过滤”和“颜色过滤”后的对象类型，将已经被选中的对象转换为未选状态。

“按类型选择”特别适用于重叠图形、交叉图形的选择，在图形比较错综复杂的时候，选择起来比较方便。

颜色过滤总是针对对象的颜色进行过滤的。当开启使用图层颜色显示、关闭群组颜色显示和关闭路径组颜色显示时，窗口中显示的图形颜色可能并不是对象的真正颜色，容易引起误操作。建议在上述情况下，不使用或特别小心使用颜色过滤功能。随后要讲到的显示和加锁也有同样问题，将不再赘述。


对象的显示顺序

3.3 对象的微调与快速编辑

当对象被选中后屏幕上就会出现图形选择框，由十个小方框构成，如图3-8所示，我们把这十个小方框就叫做图形快速编辑的手柄，利用鼠标对这十个手柄进行随手的拖拉操作，可以实现对选择对象的位置微调和快速变换操作。

我们把这十个手柄按顺序编号，如图3-9所示。对这十个编辑手柄的操作我们称之为“十点操作法则”。

图3-8 图形被选中后的选择框 图 3-9 十个编辑手柄

通过操作被选对象和十个编辑手柄，用户可以快速完成以下功能：

功能 | 实现方法
快速平移 | 通过鼠标拖动9号手柄 实现快速平移； 使用键盘的“上下左右”键 实现位置微调。
快速拷贝 | 通过“Shift”键+9号手柄实 现； 通过“Ctrl”键+“上下左右”键 实 现。
快速旋转 | 通过拖动10号手柄实现； 通过“Shift”键+“上下左右”键 实现。
快速镜像 | 使用 2号和6号手柄 完成X方向的镜像， 使用 4号和8号手柄 完成Y方向的镜像。 “Ctrl”键+2、4、6、8号手柄 完成中心位置不变的镜像。
快速放缩 | 通过 2、4、6、8号手柄完成不等比例 放缩; 通过 1、3、5、7号手柄完成等比例 放缩。 “Ctrl”键+上述手柄，可保证操作对象中心位置不变。
快速倾斜 | 通过“Shift”键+2、4、6、8号手柄 实现。 “C trl”键+“Shift”键+2、4、6、8号手柄 可实现中心位置不变的倾斜操作。

下面我们分别讲述上述几种快速变换功能的操作方法。

3.3.1 快速平移操作

1、拖动9号手柄

图形移动的操作步骤如下：

⑴ 选取要移动的图形。

⑵ 将鼠标移动到中心手柄处，此时鼠标指针变为“ [image] ”形状，按住鼠标左键不放，移动鼠标，此时一个兰色虚线框显示出来，我们把这个虚线框称为图形编辑框，它随着鼠标的移动而移动。如图3-10所示。

图3-10

⑶ 释放鼠标左键，图形被移动到图形选择框所在的位置，移动过程结束。

2、使用键盘的“上下左右”键

操作步骤如下：

⑴ 选取要移动的图形。

⑵ 将“导航工具栏”中的“微调距离”的数值改为100，回车。如图3-11所示。

图3-11

⑶ 敲击一下向上的方向键，图形就会向上移动100毫米。

3.3.2 快速拷贝操作

1、“Shift”键 + 鼠标拖动9号手柄

图形拷贝的操作步骤如下：

⑴ 选取要拷贝的图形。如图3-12所示。

⑵ 按住“Shift”键，将鼠标移动到9号手柄处，鼠标变为“ [image] ”形状。按住鼠标左键不放，移动鼠标，图形编辑框随着鼠标的移动而移动。如图3-13所示。

图3-12 图3-13

⑶ 释放鼠标左键和“Shift”键，拷贝过程结束。

2、“Ctrl”键 + 键盘“上下左右”键

图形拷贝的操作步骤如下：

⑴ 选取要拷贝的图形。

⑵ 将“导航工具栏”中的“微调距离”的数值改为100或其它数值，回车。

⑵ 按住“Ctrl”键，同时敲击键盘“上下左右”键中的一个键，完成复制。

3.3.3 快速旋转操作

1、拖动10号手柄

图形旋转的操作步骤如下：

⑴ 选取要做旋转操作的图形。

⑵ 将鼠标移动到10号手柄，鼠标变为一个圆弧状的单方向箭头，按住鼠标左键不放，移动鼠标，图形编辑框随着鼠标的移动而旋转，如图3-14所示。

⑶ 释放鼠标左键，图形旋转了一定的角度，旋转过程结束，如图3-15所示。

图3-14 图3-15

2、“Shift”键+“上下左右”键

例如将图形旋转30º。

图形旋转的操作步骤如下：

⑴ 选取要做旋转操作的图形。

⑵ 将“导航工具栏”中的“微调角度”改为30º，回车，如图3-16所示。

图3-16

⑶ 按住“Shift”键，敲击“上下左右”键中的上键，图形逆时针旋转30º，敲击“上下左右”键中的下键，图形顺时针旋转30º，如图3-17所示。

（a）图形逆时针旋转30º （b）图形顺时针旋转30º

图3-17

3.3.4 快速镜像操作

1、X方向镜像：拖动2、6号手柄

操作步骤如下：

⑴ 选取要镜像的图形。

⑵ 将鼠标移动到2号或6号手柄，鼠标变为一个左右箭头形状，按住鼠标左键不放，使鼠标向相反方向移动并超出图形，如图3-18所示。

⑶ 释放鼠标左键，图形的X方向镜像结束。如图3-19所示。

图3-18 图3-19

2、Y方向镜像：拖动4、8号手柄

操作步骤 同X方向镜像，镜像结果如图3-20所示。

图3-20

3.3.5 快速放缩操作

1、不等比例放缩：拖动2、4、6、8号手柄。

1）X方向放缩：拖动4、8号手柄。

操作步骤如下：

⑴ 选取要放缩的图形。

⑵ 将鼠标移动到4、8号手柄其中的一个，鼠标变为一个左右箭头形状，按住鼠标左键不放，图形编辑框随着鼠标的变化，拉长或变窄，如图3-21所示。

⑶ 释放鼠标左键，图形在X方向或Y方向完成放缩，这种放缩是不等比例的。如图3-22所示。

图3-21 图3-22

2）Y方向放缩：拖动2、6号手柄。

操作步骤同X方向的放缩，放缩结果如图3-23所示。

图3-23

2、等比例放缩：拖动1、3、5、7号手柄。

操作步骤如下：

⑴ 选取要放缩的图形。

⑵ 将鼠标移动到1、3、5、7号手柄其中的一个，鼠标变为倾斜箭头形状，按住鼠标左键不放，移动鼠标，图形编辑框随着鼠标的变化而等比放大或缩小，如图3-24所示。

⑶释放鼠标左键，图形放缩过程结束，如图3-24所示。

图3-24

在操作中，若同时按下“Ctrl”键，可实现对象中心位置不变的缩放变换。如图3-25所示。同样，在“快速旋转”、“快速倾斜”操作中，按下“Ctrl”键，作用相同，不再赘述。

图3-25

3.3.6 快速倾斜操作

1、X方向倾斜：“Shift”键+2号或6号手柄

图形X方向倾斜的操作步骤如下：

⑴ 选取要做倾斜操作的图形。

⑵ 按住“Shift”键，将鼠标移动到2号或6号手柄，鼠标变为一个标有指向左右的单方向箭头形状，按住鼠标左键不放，左右移动鼠标，图形编辑框随着鼠标的移动而倾斜，如图3-26所示。

⑶ 释放鼠标左键和“Shift”键，图形在X向被倾斜了一定的角度，倾斜过程结束，如图3-27所示。

图3-26 图3-27

2、Y方向倾斜：“Shift”键+4号或8号手柄

图形Y方向倾斜同X方向倾斜的操作步骤，倾斜结果如图3-28所示。

图3-28


对象的显示与隐藏

3.4 对象的显示与隐藏

当设计的图形对象很复杂，操作对象很多时，为了使需要操作的对象更加清晰，可以将一部分对象隐藏，仅显示当前有用的操作对象。

点击导航工具栏中的“ [image] ”按钮，进入对象的显示与隐藏命令，导航工具栏出现如图3-29所示对话框。

对象过滤 | 根据对象类型来进行筛选指定对象。“对象过滤”的用法与“对象的选择”中的用法相同，这里不再赘述。
颜色过滤 | 根据指定颜色来筛选对象。“颜色过滤”的用法与“对象的选择”中的用法相同，这里不再赘述。
拾取显示 | 通过拾取一个隐藏对象而使它强制显示。
全部显示 | 显示通过“对象过滤”和“颜色过滤”后的所有对象。
隐藏已选对象 | 隐藏当前被选中的对象。
隐藏未选对象 | 隐藏当前没有选中的其他所有对象。
全部隐藏 | 隐藏通过“对象过滤”和“颜色过滤”后的所有对象。

隐藏与显示只是控制对象的显示状态，隐藏后对象的位置关系和对象本身保持不变，而且隐藏的对象不能再参与任何编辑（包括选择），如果想对此对象进行再编辑，必须把它显示出来方可。


对象的显示颜色

3.5 对象的显示颜色

在第一章中我们已经叙述了“颜色工具栏”用于修改图形、文字等操作对象的颜色，设置轮廓线或者区域填充颜色，从而获得彩色效果图。这一节我们叙述如何修改对象的显示颜色和填充颜色。如图 3-30所示，颜色工具栏按钮功能的说明参见相关部分。

图3-30 颜色工具栏


修改对象颜色

3.5.1 修改对象颜色

通过颜色工具栏修改图形对象颜色。

图3-31 修改图形对象颜色

实现方法：

（1）选中指定图形对象；

（2）将颜色工具栏中的颜色填充按钮设置为单线显示模式 [image] ；

（3）点击颜色按钮或当前颜色按钮，实现对象显示颜色修改；


填充显示图形区域

3.5.2 填充显示图形区域

首先，必须清楚不是任意对象都可以实现填充显示，必须是封闭的图形区域才可以实现颜色填充，例如圆、椭圆等封闭的图形对象；对于开曲线或包含开曲线的图形集合，例如不封闭的多义线、单线体文字等对象，均不能实现或不能正确实现颜色填充。

其次，颜色填充只在二维显示状态下才有效，在图形的三维观察环境下，系统不支持填充显示。

第三，图象、三维曲线和曲面等对象，均不提供颜色填充显示；曲面对象在三维观察环境下提供曲面渲染功能。

在二维显示环境下，通过颜色工具栏修改图形区域填充颜色，如图3-32所示。

图3-32 修改图形填充颜色

实现方法：

（1）选中指定图形区域对象；

（2）将颜色工具栏中的颜色填充按钮设置为颜色填充模式 [image] ；

（3）点击颜色按钮或当前颜色按钮，实现对象显示颜色修改。

如果图形区域或轮廓有重叠部分，可以通过调整“顺序”来改变它们的层次关系。“顺序”调整功能可通过点击导航工具栏中的〖顺序〗按钮得到。


取消图形填充显示

3.5.3 取消图形填充显示

图3-33 取消图形填充

实现方法

（1）选中被填充的图形区域对象；

（2）点击颜色工具栏中的取消填充按钮 [image] ，即可实现取消对象填充状态。


对象的显示顺序

3.6 对象的显示顺序

几个对象重叠在一起，特别是填充颜色后的图形叠放在一起，就需要通过调整图形的层次，达到填充的预期效果，并且点击填充后的图形的内部颜色部分，填充图形也按照它们的层次顺序被选中，点击导航工具栏中的“ [image] ”按钮，弹出如图3-34所示按钮选项。

移到最前边 | 将选中的对象移动到最前边，也就是最前一层。
移到最后边 | 将选中的对象移动到最后边，也就是最后一层。
前移一次 | 将选中的对象向前移动一层。
后移一次 | 将选中的对象向后移动一层。
移到…前边 | 将选中的对象移到被指定对象之前的一层。
移到…后边 | 将选中的对象移到被指定对象之后的一层。

“顺序“的主要用途是：当对象颜色填充时会遇到互相重叠的颜色，为了保证预期的显示效果，可以调节颜色优先显示的顺序。如图3-35所示，将深色矩形填充区域移动到填充图形圆的上面。

图 3-35 显示的顺序

实现方法：

（1）选择要调整顺序的对象；

（2）点击“顺序”按钮；

（3）调整对象显示顺序。

* 操作步骤：

1）选择对象：

用鼠标选择需调整显示顺序的图形对象，如图3-35中的矩形。

2）点击”顺序”按钮：

点击“顺序”按钮，弹出一排菜单，如图3-34所示。

3）调整对象显示顺序：

点击“[C]前移一次”或“[Z]移到最前边”按钮，矩形区域就移动到圆的上面了。如图3-35所示。


对象加锁

3.7 对象加锁

当多个操作对象重叠在一起，不便于选择，又不想把它隐藏起来，就可用“加锁”工具将它们锁定，“锁住”的操作对象只显示在窗口中，但不能进行任何编辑操作（包括选择和拾取），如果想对它进行编辑，必须进行解锁。

点击右侧导航工具栏中的“加锁”按钮，出现如图3-36所示对话框。

“对象过滤”与“颜色过滤”的用法与3.2.2节“对象的选择”中的用法相同，这里不再赘述。图 3-36中的其它参数说明如下：

已选对象加锁 | 锁定当前被选中的对象。
未选对象加锁 | 锁定当前未选中的对象。
全部加锁 | 锁定通过“对象过滤”和“颜色过滤”后的所有对象。
未选对象解锁 | 对当前没有选中的对象解锁。
全部解锁 | 对通过“对象过滤”和“颜色过滤”后的所有对象解锁。


对象的图层管理

3.8 对象的图层管理

在图形设计过程中，可将属性相似的对象放在一层，可以方便于选择、显示、加锁和编辑等操作。点击右侧导航工具栏中的“ [image] ”按钮，出现如图3-37所示对话框。

面板上已显示出系统缺省的两个图层：主绘图层和主路径层，其中的图标含义如下：

图标 | 表示当前编辑图层，可以在其他图层的相应区域点击鼠标来改变当前图层。当前图层只有一个，所有的新创建的对象，如绘制的图形将被放置到当前图层。但对于已存在对象，被变换或编辑后，其结果则会尽可能保持原来所属的图层。
图标 | 表示图层处于显示状态；点击后消失，表示隐藏该图层及其所属图形。当前图层不能隐藏。
* 图标 | 表示图层未加锁，点击图标可将其切换为加锁状态。
图标 | 表示图层被加锁，点击图标可将其切换为未加锁状态。图层加锁后，同对象的加锁类似，属于该图层的对象不能被拾取或选择。
图标 | 表示图层的颜色，用鼠标双击它会弹出颜色对话框，可为该图层选择一种新颜色。

图3-37 图层对话框

图3-37中其它按钮功能的说明：

使用图层颜色显示 | 选中“使用图层颜色显示”选项，在显示对象时，所有的图形对象都按各自所属图层的颜色显示，反之，使用对象自身的颜色显示。
新建图层 | 创建一个新的图层。
修改层名 | 修改指定图层的层名。
删除图层 | 删除指定图层。

3.8.1 新建图层

建立一个新的图层。

图 3-38 新建图层

* 操作步骤：

选择“新建图层”命令：

用鼠标点击“新建图层”按钮，面板上出现一个新的图层，点击按钮“应用”或“确定”即可。

3.8.2 修改层名

修改图层的名称。

图 3-39 修改层名

实现方法：

（1）选择修改层名命令.（2）输入新的图层名称

* 操作步骤：

1）选择“修改层名”命令：

用鼠标点击“修改层名”按钮，弹出如图3-40所示“图层名称”对话框。

图3-40 图层名称对话框

2）输入图层名称：

在编辑框内输入图层的名称，点击“确定”按钮即可。

3.8.3 删除图层

删除所选图层。

实现方法：

（1）选择图层；（2）选择命令。

* 操作步骤：

1）选择图层：

用鼠标在面板上点击要删除的图层，使它处于选中状态。

2）选择命令：

用鼠标点击“删除图层”按钮，或直接按下“Delete”键，即可删除图层。


设置辅助线

3.9 设置辅助线

辅助线作为JDPaint系统中一个辅助定位对象，有助于准确排列和放置物体，在标牌类图形排版时经常会用到。另外，标尺也是 JDPaint的一个参考尺寸度量工具，在工作窗口的左侧和上侧各有一个垂直和水平标尺，分别表示工作窗口在整个绘图范围中的位置和尺寸。辅助线与标尺在绘图过程中都是非常重要的辅助定位参考，辅助线的创建与删除也与标尺紧密相关，与标尺分布相对应，辅助线有垂直和水平两种类型，如图3-41所示。

图 3-41 辅助线设置

辅助线创建与删除可分为随意设置和精确设置两种方法。

3.9.1 随意设置辅助线

在对辅助线的位置没有精确要求时，使用鼠标对辅助线进行操作是非常方便易行的方法，可以实现辅助线的添加、移动、删除三种操作。

添加辅助线 | 用鼠标左键在水平标尺或竖直标尺上任意位置，按住左键将鼠标指针拖入工作窗口中，鼠标指针变为“ [image] ”或“ [image] ”状，这时，会有一条蓝色的线随着鼠标的移动而移动。当到达合适的位置后，松开鼠标左键，即可在该位置加入一条辅助线。
移动辅助线 | 将鼠标光标移动至一条辅助线上，用鼠标左键点取并按住左键移动鼠标，鼠标指针变为“ [image] ”或“ [image] ”状，这时，会有一条蓝色的线随着鼠标的移动而移动。当达到合适的位置后，松开鼠标左键，即可把辅助线移动到该位置。
删除辅助线 | 同移动辅助线过程相类似，将鼠标光标移动至一条辅助线上，用鼠标左键点取并按住左键移动鼠标，把鼠标及蓝色的线移动到标尺上，松开鼠标左键，即可把该辅助线删除。

3.9.2 精确设置辅助线

用鼠标设置辅助线只能粗略地确定辅助线的位置，要实现对辅助线精确的设置与修改。JDPaint提供了编辑辅助线命令。有两种方法可以启动运行该命令：

1、用鼠标双击标尺

在没有执行命令的情况下，把鼠标移动到辅助线上点击鼠标右键，从导航菜单中选取“辅助线编辑”菜单项。

启动辅助线编辑命令后，弹出“辅助线编辑”对话框，如图3-42所示，通过编辑修改相应的参数，用户可以实现精确设置辅助线。

对话框中主要选项含义如下：

类型 | 列出了水平和垂直两种辅助线类型
“水平线”被选中 | 位置列表框中会列出已有水平辅助线的坐标值，随后对辅助线的修改操作都是对水平辅助线进行的。
“垂直线”被选中 | 位置列表框中会列出已有垂直辅助线的坐标值，随后对辅助线的修改操作都是对垂直辅助线进行的。
位置 | 列表框列出了当前系统中所有的水平或垂直辅助线的坐标值，在文本输入框中可以输入新的辅助线坐标值。
增加 | 将文本输入框中的输入的数值作为坐标值生成一条水平或垂直辅助线。
移动 | 将文本输入框中输入的数值作为坐标值赋予列表框中当前被选中的辅助线，改变它的位置。
删除 | 将列表框中当前被选中的辅助线删除。
删除所有 | 将列表框中所有辅助线全部删除。
阵列 | 阵列能一次生成多条等距离的辅助线。点击“阵列”按钮，系统弹出“辅助线阵列”对话框，如图3-43所示。在其中输入辅助线的起点、间距和个数。

图 3-43 “辅助线阵列”对话框

说明：辅助线只在2D显示方式下才能被显示和使用。


对象的对齐

3.10 对象的对齐

对象对齐是JDPaint中一个重要的辅助定位工具，有助于准确排列和放置物体，在标牌类图形排版时经常会用到。对象对齐命令与辅助线定位相结合，组成了JDPaint一整套快速定位功能。

在讲述对象对齐命令之前，首先需了解一个图形对象的尺寸方位定义。如图3-44所示，图形对象的尺寸是由它所在的包围盒的长、宽、高决定的（在本例中高度为0）。从水平方向看，可分为左、中、右三个基准位置；从竖直方向可分为顶部、中部、底部三个基准位置。对象对齐功能正是应用这些基准位置来快速实现对象的对齐。

点击导航工具栏中的“ [image] ”按钮，弹出如图3-45所示按钮选项。

图 3-44 图形尺寸方位 图 3-45 对象对齐命令

靠左对齐 | 将选中的对象与指定的基准对象在水平方向靠左对齐
水平中心 | 将选中的对象与指定的基准对象在水平方向中心对齐
靠左对齐 | 将选中的对象与指定的基准对象在水平方向靠右对齐
顶部对齐 | 将选中的对象与指定的基准对象在竖直方向顶部对齐
竖直中心 | 将选中的对象与指定的基准对象在竖直方向中心对齐
底部对齐 | 将选中的对象与指定的基准对象在竖直方向底部对齐
组合对齐 | 同时实现水平方向和竖直方向的对齐

3.10.1 靠左对齐/水平中心/靠右对齐

顶部对齐/竖直中心/底部对齐

图 3-46 对象对齐命令

实现方法：

（1）选择需对齐的对象；（2）点击对齐命令按钮； （3）选择对齐基准对象。

* 操作步骤：

1）选择需对齐的对象：

用鼠标在绘图工作区选择需对齐的的对象。

2）选择对齐命令：

选择对齐命令之一：靠左对齐、水平中心、靠右对齐、顶部对齐、竖直中心、底部对齐。

右边导航菜单弹出“ [image] ”选项。

选中该选项，系统将把被选需对齐的对象作为一个整体计算，来参与对齐处理。

未选中该选项，系统将把被选需对齐的对象逐个参与对齐处理，相当于组合对齐中的分散对齐选项。

3）选择参考图形：

选中对齐参考图形后，命令立即执行实现对象对齐效果。

3.10.2 组合对齐

同时实现对象的水平对齐与竖直对齐

图3-47 图形组合对齐

实现方法：

（1）选择需对齐的对象； （2）点击组合对齐命令按钮； （3）选择对齐基准对象。

* 操作步骤：

1）选择需对齐的对象：

用鼠标在绘图工作区选择需对齐的的对象。

2）选择组合对齐命令：

点击组合对齐命令按钮。

3）选择参考对象：

选择对齐参考对象，系统弹出“图形对齐”对话框，如图3-48所示，设置水平对齐选项与竖直对齐选项，点击确定按钮，系统自动完成对象对齐。

图 3-48 图形对齐对话框


系统设置

3.11 系统设置

系统设置功能可以设置系统的缺省值，系统储存这些值到一个设置文件（JDPAINT.CFG），每次启动系统后，JDPaint会自动加载这些参数。在绘图时，可以根据需要，对一些基本系统参数进行修改。

点击“文件”中的“系统设置”菜单，即可弹出如图3-49所示对话框。

图 3-49“系统设置”对话框

可以通过点击不同的标签按钮切换设置的类型。

3.11.1 系统参数

在系统设置中用鼠标点击“系统参数”标签，可以弹出“系统参数”的对话框，它包括“编辑参数”和“Undo设置”两组参数，如图3-49所示，以下是对“系统参数”对话框的内容和意义进行的说明：

微调距离 | 使用键盘的上下左右键将被选图形目标在四个方向上移动的距离。系统默认值为1mm。
微调角度 | 按住“Shift”键，使用键盘的上下左右键将被选图形目标在平面内旋转的角度。系统默认值为15度。
网点间距 | 使用网格捕捉时，设定坐标变化的位移量，也就是相邻两网点间的距离。
最大撤消次数 | 设置编辑菜单中撤消命令的最大有效次数。
最大重做次数 | 设置编辑菜单中重做命令的最大有效次数。

说明：“编辑参数”中的微调距离与微调角度跟导航工具栏中的微调距离与微调角度是一样的，但在导航工具栏中设置更为方便。

3.11.2 颜色设置

为了更明显的区分JDPaint中操作的对象，“系统设置”中设置了“颜色设置”对话框，包括“对象颜色”和“颜色覆盖”两组参数，如图3-50所示。

图 3-50 “颜色设置”对话框

“对象颜色”用于设置各种图形对象的原始颜色，用鼠标双击不同对象的显示区弹出“颜色”对话框，可以选择所需颜色来改变每种对象的颜色。修改了某些对象颜色后，随后生成的该种对象将默认使用该种颜色。需要注意的是，这种颜色修改操作，并不影响以前已存在对象的显示颜色。点击〖默认颜色〗按钮可以将所有的对象颜色设定还原为JDPaint默认颜色。

“颜色覆盖”通过控制显示中的对象颜色显示，观察系统中的对象分布情况和相关的对象信息。“颜色覆盖”包括三个功能。当“使用路径组颜色显示路径组中对象” 被设置时，所有的路径颜色按所属的路径组颜色显示，否则，按路径本身的颜色显示。当“使用群组颜色显示群组中对象”被设置时，所有被群组包含的对象均被显示成为所属群组的颜色，否则，按各自对象本身的颜色显示。当“使用图层颜色显示图层中对象”被设置时，所有的对象均被显示成为所属图层的颜色，否则，按各自对象本身的颜色显示；由于路径组和群组对象均属于某个图层，所以该图层设置有效时，前述两个级别较低的设置即自动无效。

3.11.3 自动备份

为了减少某些意外导致数据丢失的后果，系统设置中设置了软件的自动备份功能。单击“自动备份”的标签，弹出如图3-51所示对话框。

图 3-51 “自动备份”对话框

自动备份功能可以将设计数据按预定时间间隔保存到JDPaint应用程序目录下的AutoSave.jdp文件中。

如果要让JDPaint按照框中设置的时间间隔来自动保存，一定要用鼠标选中自动备份选项。设置完毕以后单击〖确定〗按钮，保存设置。

说明：如果正在编辑的文件太大，自动备份时间间隔要设置的大一些，可设置为10分钟以上，因为自动备份时需要占用一段时间，如果自动备份时间间隔太短，会出现连续保存的现象，影响继续操作，特别是进行浮雕曲面造型和虚拟雕塑时更要注意时间间隔的设置。

3.11.4 工作区

JDPaint工作区和标尺相配合，能够非常直观的标识用户的作图区域。在三维观察状态下，工作区又可以作为三维观察的参照物。工作区的设置不会影响用户的绘图、排版等操作。一般情况下，不必进行修改。

通过点击“系统设置”对话框中的“工作区”属性页，即可弹出“工作区”对话框，如图3-52所示。

图 3-52 “工作区”对话框

工作区参数含义如下：

左下角 | 设置工作区左下角的X、Y、Z坐标。
尺寸 | 用于设置工作区X、Y、Z方向的大小尺寸。
允许显示 | 表示开启工作区，再用鼠标点击一次，该选项被去掉，工作区关闭。所有选项修改后必须通过点击〖确定〗键，系统参数生效。

3.11.5 功能定制

功能定制充分反映出JDPaint是个开放的雕刻软件平台，它罗列了当前系统提供的可由用户操作的所有软件模块，用户可根据需要加载或卸载指定的软件模块。此外，精雕科技随时会根据雕刻行业的发展或者特殊行业的要求，开发新的软件模块，用户通常不必全部更新软件，即可实现软件升级。

通过点击“系统设置”中的“功能定制”标签，可设定模块使用状态。如图3-53所示。

图 3-53“功能定制”对话框

双击每种模块的“模块名称”，或者单击模块前的图形标识，可以改变模块打开或关闭的状态，改变后通过点击〖确定〗键关闭对话框。没有被禁止的模块图形标识显示为“对号”；当一个模块被禁止后，图形标识显示为“叉号”，下次启动JDPaint时，不会将该模块调入系统中，相应的命令也就不会在菜单中显示。用户可以根据自己的需要定制调入最适合的功能模块，从而获得简洁的工作界面和更好的软件运行效率。

说明：只有重新启动JDPaint，修改的模块状态才会有效。


图形观察

第四章 图形观察

由于显示屏幕大小的限制，绘图过程中往往无法看清整个图。为了清楚地观察一个图形的细微部分或者一个图形的全貌，须放大图形的局部或者缩小图形的显示，这时，图形的大小比例并没有发生变化，变化的只是图形的显示范围。同样图形显示的移动也并不是图形本身坐标位置的移动。JDPaint提供了的大量图形观察命令主要集中在“视图”菜单中，如图4-1所示。

图4-1 “视图”菜单与视图工具条

功能 | 快捷键
窗口观察 | F5
全部观察 | F6
选择观察 | F7
上次观察 | F8
放大观察 | Page Up
缩小观察 | Page Down
全屏观察 | F12
重画 | Ctrl + R
*缩放观察 | Ctrl +Shift+鼠标右键
*平移观察 | Ctrl +鼠标右键
*旋转观察 | Shift +鼠标右键


窗口观察

4.1 窗口观察

可以通过选取视窗中的一个矩形区域，使该区域被显示到整个工作窗口中，从而对操作对象进行局部放大观察。如图4-2所示。

图4-2 窗口观察

* 操作步骤：

1）启动窗口观察命令：

有三种方法可启动窗口观察命令：

用鼠标点击“窗口观察”菜单项；

单击观察工具栏种的窗口观察按钮“ [image] ”

使用快捷键“F5”。

2）输入第一角点：

系统在屏幕左下方的提示栏中提示：输入第一角点，鼠标指针变成“ [image] ”状，将鼠标移动到要显示窗口的左上角点，点击一下。

3）输入第二角点：

接着提示栏中提示：输入第二角点， 此时，移动鼠标，在确定的第一点和鼠标指针间显示一蓝色矩形虚线框，该矩形框会随着鼠标位置的变化而变化，这个蓝色矩形框表示窗口放大后的观察区域。鼠标移动到合适的位置，点击鼠标左键完成。

此时系统提示：输入第一角点，又回到第二步的状态。“窗口观察”是一个循环操作命令，命令开始后，操作者可以按二、三步骤选取两点，反复进行窗口放大观察，直到满足要求为止。

4）结束“窗口观察”命令：

单击鼠标右键，结束当前命令。


平移观察

4.2 平移观察

JDPaint5.0的平移功能用于调整工作窗口的观察位置，实现工作窗口的动态移动。点击视图工具条上的 [image] 功能键，此时工作窗口中的鼠标变成 [image] 形状，按住鼠标左键即可进行视窗的平移。

视窗的平移还可通过滚动条来实现。滚动条分为水平滚动条和垂直滚动条两种类型。水平滚动条用于调整工作窗口水平方向的观察位置，垂直滚动条用于调整工作窗口垂直方向的观察位置。水平滚动条的形式如图4-3所示。下面以此为例说明滚动条的各个部件的使用方法和功能：

图4-3 工作窗口滚动条

左按钮 | 点击“左按钮”—— 向左滚动窗口。
右按钮 | 点击“右按钮”—— 向右滚动窗口。
滑动块 | 拖动“滑动块”—— 左拖动则向左滚动窗口，向右拖动则向右滚动窗口

垂直滚动条的使用方法和水平滚动条类似。


放缩观察

4.3 放缩观察

放大与缩小是最常用的视窗管理命令，点击“放大观察”或“缩小观察”命令，或者点击视图工具条上的相应图标，可放大或缩小视窗。

放大观察的四种实现方法：

（1）点击观察工具条中的 [image] 功能键，可将视窗放大一倍进行观察；在放大前后，观察范围的中心保持一致。

（2）点击“视图”菜单中的〖放大观察〗按钮，窗口放大一次。

（3）键盘快捷键是 Page Up键。

（4）滚动3D鼠标上的滚珠，使之向里旋。

缩小观察的四种实现方法：

（1）点击观察工具条中的 [image] 功能键，可将视窗缩小一倍进行观察；在缩小前后，观察范围的中心保持一致。

（2）点击“视图”菜单中的〖缩小观察〗按钮，窗口缩小一次。

（3）键盘快捷键是 Page Down键。

（4）滚动3D鼠标上的滚珠，使之向外旋。


旋转观察

4.4 旋转观察

在三维编辑状态下，应用旋转观察命令，可以旋转改变视点和视线方向，从任意角度察看到模型的几何形状。

* 旋转观察的操作步骤如下：

⑴ 进入旋转观察状态：用鼠标点击“旋转观察”菜单项或相应的功能键“ [image] ”，或者按住“Ctrl”+鼠标右键。

⑵ 此时系统在屏幕左下方的提示栏中提示：拾取选转中心，鼠标指针变成“ [image] ”状，按住鼠标左键，拖动鼠标，即可进行旋转观察。立体平台和坐标轴将随着鼠标的移动而进行旋转，可进行多次操作，直到获得满意的观察角度为止。

(3) 结束“旋转观察”命令：单击鼠标右键，结束命令。

图4-4 旋转观察


全部观察

4.5 全部观察

“全部观察”功能，可以将当前屏幕上的全部对象，完全显示到整个工作窗口中。

用鼠标点击“全部观察”菜单项或相应的功能键，即可在工作窗口中观察到所有已存在的对象。

“全部观察”的快捷键为“F６”。


选择观察

4.6 选择观察

“选择观察”功能，可以将当前被选择对象完全显示到整个工作窗口中。

首先要用鼠标选中观察的对象，然后用鼠标点击“选择观察”菜单项或相应的功能键即可在工作窗口中观察到所有被选择对象。

“选择观察”的快捷键为“F７”。

说明：没有对象被选中时，“选择观察”图标为灰色，表示观察对象没有选中时，不能使用“选择观察”命令。


上次观察

4.7 上次观察

“上次观察”功能，可以将工作窗口恢复到上次工作窗口的显示状态，此功能可以连续使用，直到最初的工作窗口显示状态（此时“上次观察”图标变灰）。

用鼠标点击“上次观察”菜单项或相应的功能键，即可恢复到上次工作窗口的显示状态。

“上次观察”的快捷键为“F８”。


极限观察

4.8 极限观察

“极限观察”功能，可以将整个绘图范围完全显示到整个工作窗口中。极限观察可观察的范围就是绘图区的最大范围，即：8000mm 。极限观察仅在二维显示状态有效。

用鼠标点击“极限观察”菜单项或相应的功能键，即可在工作窗口中观察到整个绘图范围。


1：1观察

4.9 1：1观察

为了方便用户在设计时能观察出设计图形的实际尺寸，可采用“1：1观察”，即：设计图形与实际图形尺寸成1：1观察状态，这样能从视觉上判断一个图形的大小。“1：1观察”仅在二维显示状态有效。

点击“1：1观察”菜单命令，即可在工作窗口中观察到1：1的视图。


全屏观察

4.10 全屏观察

“全屏观察”是开启或关闭全屏绘图模式的命令，点击“全屏观察”菜单命令或敲击键盘快捷键“F12”即可切换为“全屏观察”状态。


重画

4.11 重画

经过一些图形绘制或编辑操作后，可能在工作窗口中残留一些无用的图形显示，影响观察效果。例如移动或删除图形后，可能图形线有间断或工作窗口中有残留点，通过“重画”命令可以刷新窗口显示。

点击“重画”菜单命令即可刷新工作窗口。用键盘快捷键“Ctrl+R”也可以执行重画功能。


显示模式

4.12 显示模式

JDPaint系统提供了两种显示环境：二维显示环境和三维显示环境。在不同的显示环境中对象的显示方式不同，相应地，系统提供不同的显示模式。如图4-5所示，显示模式菜单与显示模式工具栏。

图4-5 “显示模式”子菜单 图4-6 显示模式工具栏

当JDPaint系统中的所有对象均采用符合Windows标准的GDI绘图机制进行绘制时，由于GDI绘图机制只适合绘制二维图形，而不擅长于绘制三维图形。故此，我们把这种用GDI显示图形的环境称为二维显示环境。该显示环境提供了以下两种显示模式：

平面显示 | 二维观察效果显示，这是系统缺省的显示模式。
填充显示 | 二维观察填充效果显示，用于观察二维图形的填充效果。

当JDPaint系统中的所有对象均采用OpenGL绘图机制进行绘制时，由于OpenGL特别擅长于绘制三维图形，我们把这种用OpenGL显示图形的环境称为三维显示环境。该显示环境提供了以下三种显示模式：

线框显示 | 用线框模型显示曲面模型。
渲染显示 | 用渲染模型显示曲面模型，即曲面渲染。
边界显示 | 用边界模型显示曲面模型，即显示曲面边界线。

用户既可以在二维显示环境绘图，也可以在三维显示环境下绘图。二维环境特别适合于绘制平面图形，三维环境特别适合于绘制三维立体模型。JDPaint对三维模型的显示效果有三种处理：线框显示、渲染显示和边界显示，例如半球面的三维显示效果如图4-7所示。用户可在这些显示模式下对观察视图进行放缩操作和三维动态旋转，还可创建和编辑三维模型。

线框显示 渲染显示 边界显示

图4-7 三维显示模式


视图观察

4.13 视图观察

在建立三维模型前，首先要学会三维空间观察模型。通常地，我们在观察对象时都是从某一视点和视线方向出发，获得对象的视觉反馈。这视觉反馈就是视图。在三维模型的绘制过程中，用户最常用的是一些标准视图如主视图、左视图和轴测图等。用户可改变视点和视向获得其它效果的视图。

JDPaint系统在常用工具栏上设置了“设置视图”功能按钮，点击该按钮弹出一些常用的视图菜单命令，如图4-8所示。

图4-8 “视图”工具栏

例如在“线框显示”模式下，半球面的不同视图显示，如图4-9所示。

（a）顶视图 (b)前视图

(c)右视图 (d) 轴侧图

图4-9 视图观察


光源设置

4.14 光源设置

在三维模型设计过程中，用户希望看到模型的逼真效果，在“渲染显示”三维显示模式下，生成模型的图象与实物的照片相差无几。

* 计算机渲染过程主要是三维的图象处理，一般分为四个步骤：

1、准备要渲染的三维模型；

2、设置照明，包括指定光源和生成阴影；

3、添加色彩，包括选定材质并将其赋予可见的表面；

4、进行渲染。

以上是概念上的渲染步骤，在JDPaint中进行渲染，用户可以实现以下设置：

1、指定多个光源；

2、指定光源的不同类型；

3、指定视图与光线不同组合；

4、分配模型材质。

4.14.1 设置光源

光源可分为三种类型：线光源、点光源和聚光灯。

1、线光源

线光源是一种具有平行管线的直射光源，它相当于太阳光，各个光线来自同一方向且光强相等，在一个相同的方向对场景中的所有对象进行照射。当用户需要对场景中的背景进行均匀照射时，线光源很有帮助。

线光源有三个重要属性：

(1) 光线颜色：任何光线都是有颜色的，并且光线颜色均可以改变。

(2) 光线强度：从某一个光源照射到物体表面上一点，再反射出来的光，可以分为三个部分：环境光、漫反射光和镜面反射光。通过调整环境光、漫反射光和镜面反射光系数，用户可以获得适当的光线强度。

(3) 光线方向：光线的方向是指光线照射到物体上的方向，它是相对于物体的空间位置的相对方向。

2、点光源

点光源的光线，类似电灯所发出的光，它向各个方向照射，其强度随距离的增大而减弱。与光源距离越远的表面，看起来越暗，而较接近于光源的表面，则显得比较亮。

3、聚光灯

聚光灯是呈圆锥状的一道光束。在用户指定聚光灯光线时，需要设置目标点、距离及圆锥的尺寸。

对于点光源和聚光灯光线，物体表面的亮度取决于以下三个因素：

(1) 角度：在JDPaint对模型进行渲染时，表面的亮度由光线的反射角角度决定。反射角就是光线方向与被照射面的法线方向的夹角。与光线方向相垂直的表面，接收到的光线最多，显得最亮。当反射角度增加时，表面所接收到的光线减少，表面看起来发暗。

(2) 反射率：表面的亮度还取决于该表面反射回来的光线的数量。

(3) 距离：物体离光源越远，反射回来的光线就越少，亮度就越暗。

单击“视图”菜单下的“光源设置”命令，导航工具栏中出现“光源设置”对话框，如图4-10所示。

图4-10 光源设置对话框

4.14.1.1 添加和删除光源

要添加光源，点击“添加光源”按钮，弹出如图4-11所示对话框。

图4-11 “添加光源”对话框

选择一种光源类型，并可为新光源修改名称，单击“确定”即可完成新光源的添加。

要删除光源，选择要删除的光源作为当前光源，单击“删除光源”即可删除指定光源。

在三维显示环境下，系统最多可设置八个光源，至少应保留一个光源。

4.14.1.2 编辑光源参数

用户可以修改已有光源的参数，从而获得不同光源效果。光源参数定义如下：

颜色 | 光源的颜色
强度 | 不同类型光的强度系数，取值为0到1。 环境光：周围环境的光。 漫反射：对象表面向空间各方向均匀反射出的光。 镜面光：对象表面向一定方向反射出的光。
方向 | 光线的方向，采用经度和纬度的角度来设置，取值范围分别为-180到180。对于点光源，多一个“距离”参数，表示点光源到对象中心的距离。

4.14.1.3 使用默认光源

点击“使用默认光源”按钮，JDPaint会自动采用系统缺省的线光源，删除其余自定义的光源。


设置材质

4.14.2 设置材质

为物体指定材质，可以使物体显得更真实。用户可以为物体指定多种参数，如颜色、透射率、环境反射和粗糙度等，用户可自己创建材质，也可以利用材质库中的材质，然后将材质赋予某一个指定对象。

单击“视图”菜单下的“光源设置”命令，导航工具栏中出现“光源设置”对话框，如图4-12所示。

背景颜色 | 背景按钮 [image] ，单击按钮弹出 颜色设置对话框，用户可以设置渲染的背景颜色。
使用对象颜色 | 是指用模型表面的颜色渲染显示该模型。
使用材料颜色 | 是指为模型表面指定特定的材质，使模型渲染显示得更真实

* 为模型表面设定材质的具体步骤如下：

(1) 单击对话框上的 [image] 按钮，弹出如图4-13所示“材料”对话框。

图4-13 “材料”对话框

(2) 单击“定义材料”按钮，弹出如图4-14所示“定义材料”对话框。

图4-14 “定义材料” 对话框

(3) 单击“编辑材料”按钮可以编辑列表框中的当前材料，弹出“定义材料”对话框编辑材料参数。

(4) 单击“删除材料”按钮会删除当前的材料。


绘图基础

第五章 绘图基础

在JDPaint工作的期间，系统会提示用户输入点、长度或者角度，或者提示拾取指定类型对象。JDPaint系统提供了三种点的输入方法，可以在屏幕中随意定点或者精确地确定点的位置。本章将主要叙述点的几种输入方法，长度（或距离）和角度的输入方法，对象的拾取在前面章节中已经讲过，本章不再赘述。

本章的主要内容有：

点输入方法 | （1）点坐标鼠标输入 （2）点坐标键盘输入 （3）点坐标发生器
长度输入方法 | （4）长度发生器
角度输入方法 | （5）角度发生器


点坐标鼠标输入

5.1 点坐标鼠标输入

点坐标的鼠标输入是用鼠标在屏幕上定位一个点的过程，可以使用鼠标在屏幕上随意点击来输入点，也可以快速捕捉到已存在的点或者已存在的对象上的特征点。JDPaint提供了一种功能，可以非常方便地在屏幕上使用光标，捕捉已存在的点或者是已存在的对象上的特征点的精确位置，并且显示已捕捉的点的信息。

点的鼠标输入功能主要有：

· 特征点捕捉

· 网格点捕捉

· 正交捕捉


网格点捕捉

5.1.1 网格点捕捉

为了帮助绘图者选择合适的位置，网格点（或栅格）是一种非常有用的工具。网格点只作为绘图的辅助工具出现，不是图形的一部分。选择 “视图（ALT+V）→网格捕捉（V）” 菜单，网格捕捉功能启动，绘图区出现如图 5-1 所示的栅格网点。

图 5-1 网格点捕捉显示

在网格捕捉状态下，如果显示的网点之间的距离等于系统设置中的网点间距时，这时绘制图形，用鼠标直接在绘图区点击输入点的位置，这个点就会落到距离鼠标最近的网点上。

网点间距可以调整，网格点间距设置可以在菜单栏中的“文件/系统设置”命令来进行，在系统参数中改变“网点间距”，如图5-2所示，详细过程请参照“系统设置”说明功能。

图 5-2 网格点间距设置

网格捕捉的启动或关闭必须通过“视图/网格捕捉”来进行切换。网格点的显示和捕捉只在二维显示环境中有效，在三维显示环境中系统未加支持。

说明：在使用网格捕捉的方法时，最好将〖正交模式〗和〖特征点捕捉〗按钮复位，否则网格捕捉将受到影响。


正交捕捉模式

5.1.2 正交捕捉模式

正交捕捉是用于辅助绘图的一种工具，利用JDPaint的正交捕捉，可以绘制出完全相垂直或者相互平行的直线，特别是在许多绘制需要完全垂直和平行的情况下，这种方式更能显示其优势。采用下面方法可切换正交的开启与关闭：

1）单击菜单栏中的“视图/正交捕捉”命令。

2）单击工具栏中的正交模式捕捉功能的开关按钮“ [image] ”。

启动了正交模式之后，无论是在执行绘制中的命令，还是在执行变换中的平移、旋转、镜像等命令，鼠标在确定了第一个点后，移动鼠标，当前点并不是移动到鼠标的位置，而是只在水平方向或竖直方向进行移动，如图5-2所示。点击鼠标左键即可确定第二点。

图5-3 正交捕捉

说明：在正交模式输入过程中，按住Ctrl键，可以进行短轴输入，否则为长轴输入。


特征点自动捕捉

5.1.3 特征点自动捕捉

特征点捕捉命令是JDPaint提供的另一个绘图辅助工具，用于帮助用户更精确地作图。特征点捕捉也即我们通常所说的自动导航。采用下面方法可切换特征点捕捉命令的开启与关闭：

1）单击菜单栏中的“视图/自动导航”菜单命令，即可切换自动捕捉的开关。

2) 单击工具栏中的特征点捕捉命令的开关按钮“ [image] ”。

自动捕捉功能开启与关闭按钮的表现形式：

图 5-4 自动捕捉功能开启与关闭

JDPaint提供了八种对象特征点捕捉模式可供选择，如图5-5所示。

端 点： | 端点捕捉模式，捕捉的是距光标最近的直线、圆弧、多义线等的端点。也捕捉空间曲线的端点和曲面边界线的端点。
中 点： | 中点捕捉模式，捕捉的是距光标最近的直线、圆弧、多义线等的中点。也捕捉空间曲线的中点和曲面边界线的中点。
圆 心： | 圆心捕捉模式，捕捉的是距光标最近的圆、椭圆或圆弧的圆心。
交 点： | 交点捕捉模式，可以捕捉曲线两两相交的交点。
切 点： | 切点捕捉模式，是在圆、椭圆、圆弧或曲线上捕捉某一点，该点与上一拾取点形成的连线与这些对象相切。
垂 点： | 垂点捕捉模式，捕捉的是直线、圆弧、椭圆或者曲线上的某一点，该点与上一拾取点形成的连线与这些对象垂直。
四分点： | 四分点捕捉模式，捕捉的是距光标最近的圆、圆弧、椭圆上0度、90度、180度或270度位置的点。
最近点： | 最近点捕捉模式，捕捉的是距光标最近的对象上的某一特征点。
强制捕捉： | 选中”强制捕捉”模式按钮，系统强行捕捉距离光标最近的图形对象上的特征点； 不选中”强制捕捉”按钮，系统只捕捉距离光标最近的，在光标捕捉范围之内的特征点；
投影捕捉/ 空间捕捉 | “投影捕捉”和“空间捕捉”是一对开关按钮。 选中”投影捕捉”按钮，系统自动把光标捕捉到的三维空间点投影成为当前的绘图面上的点； 选中“空间捕捉”按钮，系统将光标捕捉到的三维空间点作为空间点处理； 点击“投影捕捉”按钮，按钮提示为“空间捕捉”，反之亦然；
禁止捕捉 | 选中“禁止捕捉”按钮，特征点自动捕捉功能被关闭。 再点击“禁止捕捉”按钮，特征点自动捕捉功能被启动。此外， 用鼠标点击“ [image] ”按钮，特征点自动捕捉功能被启动； 用鼠标点击“ [image] ”按钮，特征点自动捕捉功能被关闭。

图 5-6 特征点类型

如果启动了特征点自动捕捉的功能，在执行一些命令时，随着鼠标在图形上移动，会时常出现特征点的代表符号，说明已经捕捉到了附近的特征点，例如，在出现“ [image] ”时，说明已经捕捉到了图形的端点，如图5-7，这时只要单击一下鼠标，所需要的点就捕捉在这个特征点上了。

图 5-7 捕捉图形端点


绘图基础

5.2 点坐标键盘输入

5.2.1 坐标系与点坐标

二维坐标系是由原点和两根坐标轴组成的，水平轴称作 X轴，竖直轴称作 Y轴，两轴的交点 O 称作原点，二维坐标系如图5-8所示。二维坐标系把一个平面分成了四个部分， X轴上的刻度以原点为界，左半轴是负值（负值的书写形式是数字前面加一个“-”号），右半轴是正值；同样，Y轴上的刻度以原点为界，下半轴是负值，上半轴是正值。

三维坐标系是由原点和X、Y与Z坐标轴组成的，两轴的交点 O 称作原点，三维坐标系如图5-9所示。三维坐标系中任意两轴线组成一个平面，相应地定义三个基本绘图平面：XOY平面、YOZ平面和XOZ平面。

图 5-8 二维坐标系 图 5-9 三维坐标系

点坐标是用数字形式表示一个点在坐标系中的位置。

在二维坐标系中，点坐标的表达方法为：（X，Y）。

在三维坐标系中，点坐标的表达方法为：（X，Y，Z）。

其中X表示X轴坐标值，Y表示Y轴坐标值，Z表示Z轴坐标值。

注意：在JDPaint5.0中， X、Y、Z可以代表一个具体的数值，同时也支持由数学表达式表示的值，如（5+3，10*2）表示的点即是（8，20）。

5.2.2 绝对坐标输入

在一个平面内可以有许许多多的坐标系，如图5-10所示。

图 5-10 多个坐标系

只要坐标原点不同，就可以画出任意一个坐标系。为了方便确定它的坐标，指定其中的一个坐标系为绝对坐标系，绝对坐标系的原点的坐标是（0，0），如上图我们指定中间的原点是0，坐标轴分别是X、Y的坐标系是绝对坐标系。

绝对坐标：在绝对坐标系中，表示一个点的位置的坐标叫绝对坐标。

在JDPaint5.0中绝对坐标的表示和输入方法如下：

1、绝对坐标的表示方法：（X，Y）

X 对应JDPaint 5.0的工作区水平标尺的数值（2D显示模式下）。

Y 对应JDPaint 5.0的工作区竖直标尺的数值（2D显示模式下）。

2、绝对坐标的输入方法：

当点击绘制菜单里的命令后，在JDPaint界面的右下角出现一条白色方框，如图5-11所示，这就是数字输入提示区。输入绝对坐标，用键盘直接输入“数字，数字”即可。例如，绘制一点坐标（20，40），直接在数字输入提示区中输入：20，40 即可。

图 5-11 数字输入提示区

输入后点（20，40）就显示在系统绘图区中，如图5-12所示。

图 5-12 输入绝对坐标点

5.2.3 相对坐标输入

在工作区内，除了上面提到的这个绝对坐标系之外其它任何一个坐标系都是相对坐标系。一个平面中只能有一个绝对坐标系，其它的坐标系叫相对坐标系。

相对坐标：在相对坐标系中，表示一个点的位置的坐标叫相对坐标。

可以看出，绝对坐标系和相对坐标系只是原点和坐标轴的相对位置不同。例如把一个矩形分别放在绝对坐标系和相对坐标系中，其左下角分别与两个坐标系的原点重合，底边和左边分别与坐标轴重合，可以看出，它的大小不会变化，只是相对位置发生了变化，如图 5-13 所示。

图 5-13 相对坐标系

在JDPaint5.0中相对坐标的表示和输入方法如下：

1、相对坐标的表示方法：（@X，Y）

X对应JDPaint 5.0的工作区内相对于某一点的水平距离。

Y对应JDPaint 5.0的工作区内相对于某一点的竖直距离。

2、相对坐标的输入方法

例如，N点的绝对坐标是（-120，-80），M点的绝对坐标是（40，40），M点相对于N点的相对坐标是（@160，80），如图5-14所示。

图 5-14 输入相对坐标点

5.2.4 极坐标输入

极坐标也是一种常用的点坐标输入方式。

极坐标系：由原点和X正半轴组成的坐标系，如图5-15所示。

图 5-15 极坐标系

极坐标：在极坐标系中，由角度、长度来确定另一点位置的坐标。

1、极坐标的表示方法

（~长度，角度）或（~ρ，α）。如图5-16所示。

图 5-16 极坐标表示

2、极坐标的输入方法：

例如绘制一条直线，直线的长度是100mm，斜度是45度，如图5-17所示。

图 5-17 极坐标绘制直线

* 操作步骤：

1）选择命令：

选择“绘制（ALT+D）→直线（L）”菜单, 提示条提示“两点直线：输入直线的起点：”，用鼠标在绘图区任意点击一下，确定直线的起点，这时在工作区内出现可以绕起点随意拉动旋转的橡皮筋。

2）输入极坐标：

当状态条提示“两点直线：输入直线的末点：”，输入“~100，45”， [image] 。输入完后回车，直线绘制完成。

说明：在输入极坐标时，输入的长度值如果为正值，直线为正向，为负值，直线是反向；角度按照顺时针旋转的方向定为负值，按逆时针旋转的方向定为正值。


点坐标发生器

5.3 点坐标发生器

在一些功能提示要求输入点时，按下键盘空格键或者<SPACE BAR>，进入点坐标发生器命令，在导航工具条容器窗口中弹出一个新的导航工具条，如图5-18 所示。

点坐标发生器功能是新的系统功能，它与长度发生器、角度发生器统一成为JDPaint系统一大精确定位特色功能。

点坐标发生器功能解决了：当点坐标不易确定、特征点不能直接捕捉到时，但该点的坐标分量可以从已存在的点或者已存在的对象的相关数据信息中获得，从而解决该点的坐标输入问题。点坐标分量的精确值可通过对象特征点捕捉获得，或者其它方式精确获得。

点坐标发生器功能集特征点的自动捕捉与键盘精确输入于一身，是JDPaint系统中功能最强的精确点坐标输入工具。

如同特征点自动捕捉，利用点坐标发生器能够精确捕捉到对象上的特征点，包括：端点、中点、圆心、两线交点、四分点、垂足点、相切点、最近点、中心点和图形的重心点，其功能较特征点自动捕捉还要强大。在垂足点和相切点时，系统可以重设基点坐标。

在捕捉特征点前，通过设定X、Y、Z的输入坐标分量的检查框的有效标志，可以保证捕捉到预期的点坐标分量，并保留不需改变的点坐标分量。此外，在绝对坐标和相对坐标输入状态下，还可以单击 [image] 按钮，进入长度-距离发生器，分别确定点坐标的分量。类似地，当进行极坐标输入时，与长度-距离发生器和角度发生器协同，能够分别确定输入点的极坐标的长度和角度分量。

通过点坐标发生器精确定点后，点击<确定>完成该点精确输入。


长度-距离发生器

5.4 长度-距离发生器

在一些功能提示要求输入长度或者距离时，按下键盘空格键或者<SPACE BAR>，进入长度-距离发生器命令，在导航工具条中弹出提示对话框，如图5-19 所示。

图5-19 长度-距离发生器

长度-距离发生器实际上是一个数值发生器。它不仅提供了数值键盘输入，还可以通过以下方式获取精确数值。

两点距离 | 拾取两点的长度作为输入数值
两点X方向距离 | 拾取两点的X轴分量长度作为输入数值
两点Y方向距离 | 拾取两点的Y轴分量长度作为输入数值
曲线长度 | 拾取曲线的长度作为输入数值

通过长度-距离发生器精确数值后，点击<确定>完成数值精确输入。


角度发生器

5.5 角度发生器

在一些功能提示要求输入角度时，按下键盘空格键或者<SPACE BAR>，进入角度发生器命令，在导航工具条中弹出提示对话框，如图5-20所示。

图5-20 角度发生器

角度发生器不仅提供了角度键盘输入，还可以通过以下方式获取精确角度数值。

与X轴夹角 | 以两点直线与X轴方向的夹角作为输入角度
与Y轴夹角 | 以两点直线与Y轴方向的夹角作为输入角度
三点角度 | 以三点形成的夹角作为输入角度
两线夹角 | 以两直线的夹角作为输入角度
圆弧角度 | 以指定圆弧的圆心角作为输入角度
圆弧切角 | 选择圆弧上一点的切线与X轴方向的夹角输入角度

通过角度发生器精确定角度后，点击<确定>完成角度精确输入。


绘制图形

第六章 绘制图形

JDPaint提供了点、直线、圆弧、圆、椭圆、样条、多义线等二维基本图形元素的绘制功能，还提供了矩形、星形、正多边形、双线和箭头、公式曲线等一些常用的特征图形元素的绘制功能。用户可以利用这些功能，方便快捷地绘制出各种各样复杂的二维平面设计图形。“绘制”菜单结构如图6-1所示。

图6-1 图形绘制菜单与绘制工具条

点 |  | 绘制点对象
直线 | Ctrl+Q | 绘制直线对象
圆弧 | Ctrl+A | 绘制圆弧对象
样条 | Ctrl+P | 绘制样条曲线对象
多义线 | Ctrl+W | 绘制多义线对象
圆 | Ctrl+L | 绘制圆
椭圆 |  | 绘制椭圆
矩形 | Ctrl+T | 绘制矩形
星形 |  | 绘制星形
正多边形 |  | 绘制正多边形
双线 |  | 绘制双线
箭头 |  | 绘制箭头
公式曲线 |  | 绘制公式曲线
曲面上线 |  | 绘制曲线上线，参见中册说明书
三维曲线 |  | 绘制空间三维曲线，参见中册说明书


点

6.1 绘制点

绘制一个或多个二维点对象。

如图6-2所示。

实现方法：

输入点的位置。

* 操作步骤

1）启动绘制点命令：

点击“绘制(D)”-> “点(P)”菜单项或绘制工具条中 [image] 按钮。

2）输入点：

输入要绘制点的位置，参照<点输入方法>。可完成多个点的绘制，单击右键结束命令。


多义线

6.5 绘制多义线

多义线是作为单个对象创建的相互连接的序列线段。它是包含连续的多段线的一条曲线，其中包含的曲线段可以为直线段、圆弧段和样条曲线段等，图6-32所示。前面绘制的直线、圆弧和样条曲线均为只包含直线段、圆弧段和样条曲线段的的多义线。多义线功能是在描图过程中最常用的命令之一。

本功能将提供包含直线段、圆弧段和样条曲线段的多义线的绘制方法；

多义线绘制导航工具栏中的选项如图6-33。

图6-33 多义线绘制导航工具栏选项

直线 | 绘制通过两点的直线段。
三点弧 | 绘制通过三点的圆弧段。
起点圆心角度弧 | 绘制已知圆弧起点、圆心及圆弧圆心角的圆弧段。
首末点角度弧 | 绘制已知圆弧的首末点和圆弧圆心角的圆弧段。
首末点半径弧 | 绘制已知圆弧的首末点和半径的圆弧段。
样条曲线 | 绘制已知通过指定的点的样条曲线。
【平滑连接】 | 选中该选项，所绘制的多义线的各曲线段之间将光滑相切连接（图6-34）。
【自动连接】 | 选中该选项，在绘制本条多义线过程中，定义的任意一曲线段的端点与已存在的一条多义线的起始点或终止点重合时，则系统自动将这两条多义线连接成为一条多义线。注意：这时绘制当前点可能会发生变化，在新的当前点处进行下一曲线段的绘制。
取消一步 | 点击此按钮，可撤销上一曲线段的绘制，绘制当前点随着进行变化。
闭合结束 | 点击此按钮，可以结束多义线的绘制，并且自动将该多义线闭合。

实现方法：

（1）启动多义线绘制命令；

（2）绘制各曲线段。

* 操作步骤：

1) 启动多义线

绘制命令：

点击“绘制(D)”->“多义线(Y)”菜单项或绘制工具条中的 [image] 按钮。

2) 绘制各曲线段：

在导航工具栏中选择要绘制的曲线段选项。单击鼠标右键结束绘制，或点击 [image] 按钮结束。

图6-34 由16段圆弧平滑连接的一条多义线

6.5.1 多义线 >> 直线

已知起末点绘制直线段。参照<<6.2.1直线>>两点直线。

6.5.2 多义线 >> 三点弧

已知圆弧圆周上三点，绘制圆弧段。参照<<6.3.1 圆弧>>三点圆弧。

6.5.3 多义线 >> 起点圆心角度弧

已知圆弧起点、圆心及圆弧圆心角，绘制圆弧段。

如图6-35所示。

实现方法：

（1）启动起点圆心角度弧命令；

（2）输入圆弧起点和圆心点；

（3）输入圆弧圆心角。

* 操作步骤：

1) 启动起点圆心角度弧命令：

选择导航工具栏中的 [image] 选项。

2) 输入起点圆心角度圆弧--起点； | 输入圆弧起点。 若本圆弧段不是多义线的首段，则起点为绘制当前点，本步略；若为多义线首段，则需要输入点坐标，参照<点的输入>。
3) 输入起点圆心角度圆弧--圆心： | 输入圆弧圆心点，参照<点的输入>。

4) 输入起点圆心角度圆弧--角度，Shift切换圆弧方向

输入圆弧圆心角，可直接输入角度值后回车，也可以拖动“橡皮筋”定义一点来确定。默认的圆弧的圆心角度是从圆弧的起始点开始逆时针转过的角度。按住Shift来切换圆弧方向。

6.5.4 多义线 >> 首末点角度弧

已知圆弧的首末点和圆弧圆心角，绘制圆弧段。

如图6-36所示。

实现方法：

（1）启动首末点角度弧命令；

（2）输入圆弧起点和末点；

（3）输入圆弧圆心角。

* 操作步骤：

1) 启动首末点角度弧命令：

选择导航工具栏中的 [image] 选项。

2) 输入起点终点角度圆弧--起点：

输入圆弧起点。若本圆弧段不是多义线的首段，则起点为绘制当前点，本步略；若为多义线首段，则需要输入点坐标，参照<点的输入>。

3) 输入起点终点角度圆弧--终点：

输入圆弧终点，参照<点的输入>。

4) 输入起点终点角度圆弧--角度：

输入圆弧圆心角，可直接输入角度值，也可以拖动“橡皮筋”定义一点来确定。

6.5.5 多义线 >> 首末点半径弧

已知圆弧的首末两点和半径，绘制圆弧段。

如图6-37所示。

实现方法：

（1）启动首末点半径弧命令；

（2）输入圆弧起点和末点；

（3）输入圆弧半径。

* 操作步骤：

1) 启动首末点半径弧命令：

选择导航工具栏中 [image] 选项。

2) 输入起点终点角度圆弧--起点：

输入圆弧起点。若本圆弧段不是多义线的首段，则起点为绘制当前点，本步略；若为多义线首段，则需要输入点坐标，参照<点的输入>。

3) 输入起点终点角度圆弧--终点：

输入圆弧终点，参照<点的输入>。

4) 输入起点终点角度圆弧--半径：

输入圆弧半径，可直接输入半径值后回车，也可以拖动“橡皮筋”定义一点来确定。

6.5.6 多义线 >>样条曲线

已知样条曲线所通过的点，绘制样条曲线段。参照<< 6.4 绘制样条曲线 >>。


直线

6.2 绘制直线

直线绘制提供了以下几种绘制的方法，如图6-3为导航工具栏中的直线绘制选项。

图6-3 直线导航工具栏选项

两点直线 | 绘制通过两点的直线
角度直线 | 绘制通过一点并与X轴成一定角度的直线
角平分线 | 绘制两条互成角度的直线的角平分线
圆弧圆弧切线 | 绘制两个圆或圆弧的内外公切线
圆弧直线垂线 | 绘制和一圆/圆弧相切并与一已知直线垂直的直线
平行线：距离 | 绘制在一定距离处和已知直线平行的直线
平行线：过点 | 绘制过一点并与一已知直线平行的直线
平行线：圆弧 | 绘制与一已知直线平行且与一圆/圆弧相切的直线

6.2.1 直线 >> 两点直线

定义直线起点和末点来创建一条直线。

如图6-4所示。

实现方法：

（1）启动两点直线命令；

（2）输入直线起点和末点。

* 操作步骤：

1) 启动两点直线命令：

点击“绘制(D)”-> “直线(L)”菜单项或绘制工具条中的 [image] 按钮；在导航工具栏中选择 [image] 选项。

2) 输入直线的起点：

输入直线起始点，参照<点的输入>。

3) 输入直线的末点：

输入直线的末点，参照<点的输入>。可输入多个点来绘制连续的直线段，单击右键结束。

说明：可以打开绘图的正交模式来绘制水平或垂直的直线。

6.2.2 直线 >> 角度直线

绘制通过一点并与X轴成一定角度的直线。

如图6-5所示。

实现方法：

（1）启动角度直线命令；

（2）输入直线起点；

（3）输入直线角度；

（4）输入直线长度。

* 操作步骤：

1）启动角度直线命令：

点击“绘制(D)”-> “直线(L)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中 [image] 绘制选项。

2）输入直线的起点：

输入直线起始点，参照<点的输入>。

3）输入直线角度：

可以单击鼠标右键接受括号中的默认值，或直接输入角度值，也可以通过鼠标定义另外一点来确定直线的角度方向值。角度是依照逆时针方向从X轴正向开始计算的。

4）输入直线长度：

可以单击鼠标右键接受括号中的默认值，或直接输入直线长度，也可以拖动“橡皮筋”在角度方向上定义另外一点来确定直线的长度；直线的长度为相对于起始点“橡皮筋”方向上的长度。

5）输入直线的起点：

输入下一个角度直线的起点，或单击鼠标右键结束。可连续绘制多条角度直线。

说明：当确定了直线的角度后，移动鼠标，此时屏幕中的“橡皮筋”将被限制在该角度或该角度加180°方向上。

6.2.3 直线 >> 角平分线

绘制两条互成角度的直线的角平分线。

如图6-6所示。

实现方法：

（1）启动角平分线命令；

（2）拾取两条直线；

（3）输入角平分线长度。

* 操作步骤：

1）启动角平分线命令：

点击“绘制(D)”-> “直线(L)”菜单项或绘制工具条中的 [image] 按钮；在导航工具栏中选择 [image] 绘制选项。

2）选择直线1：

拾取第一条直线。

3）选择直线2： | 拾取第二条直线。
4）输入直线长度： | 可以单击鼠标右键接受括号中的默认值，或直接输入直线长度后回车，也可以拖动“橡皮筋”在角度方向上定义另外一点来确定直线的长度。

5）选择保留直线：

从四条角平分线中，拾取一条需要保留的直线段。

说明：

1、要绘制的角平分线的起点为这两条互成角度的直线或直线延长线的交点；

2、两条互成角度的直线有四个夹角，因此选择了两条直线后，就有四个方向上的角平分线可供选择（图6-7）；系统将根据用户拾取两条曲线的位置确定一默认的方向，用鼠标拖动“橡皮筋”的方向将限制在这四个方向上。定义的直线的长度为相对于起始点在“橡皮筋”方向上的长度。

图6-7 两条直线的四个角平分线方向

6.2.4 直线 >>圆弧圆弧切线

绘制两个圆或圆弧的内外公切线。如图6-8所示。

图6-8 两圆弧切线（ [image] 表示圆弧的拾取位置）

实现方法：

（1）启动圆弧圆弧切线命令；

（2）拾取两个圆或圆弧。

* 操作步骤：

1) 启动圆弧圆弧

切线命令：

点击“绘制(D)”-> “直线(L)”菜单项或绘制工具条中 [image] 按钮；选择导航工具栏中 [image] 选项。

2) 选择圆或圆弧1：

拾取第一个圆或圆弧。

3) 选择圆或圆弧2：

拾取第二个圆或圆弧。

4) 选择圆或圆弧1：

拾取绘制下一条公切线的第一个圆或圆弧，或单击鼠标右键结束。可连续绘制多条两圆弧切线。

说明：

两个圆/圆弧之间的切线可能有四条，包括两条内公切线和两条外公切线。系统将根据拾取圆/圆弧的位置来确定要绘制的切线。注意：切线可能与圆弧相切于其延长线上。图6-8 所示“ [image] ”表示圆弧的拾取位置不同，分别绘制出两圆的内公切线和外公切线。

6.2.5 直线 >> 圆弧直线垂线

绘制与一圆/圆弧相切并与一已知直线垂直的直线。如图6-9所示。

图6-9 与一圆弧相切并与一已知直线垂直的直线 ( [image] 表示圆弧的拾取位置)

实现方法：

（1）启动圆弧直线垂线命令；

（2）拾取要相切的圆弧/圆；

（3）拾取要垂直的直线。

* 操作步骤：

1）启动圆弧直线垂线命令：

点击“绘制(D)”-> “直线(L)”菜单项或绘制工具条中 [image] 按钮；选择导航工具栏中 [image] 选项。

2）选择圆弧（或圆）：

拾取要相切的圆或圆弧。

3）选择直线：

拾取要垂直的直线。

4）选择圆弧（或圆）：

拾取绘制下一条切垂线时要相切的圆或圆弧，或单击鼠标右键结束。可连续绘制多条与一圆弧相切并与一已知直线垂直的直线。

说明：

1、和一圆/圆弧相切并与一已知直线垂直的直线可能有两条，系统将生成与圆/圆弧拾取位置最近的那一条直线，如图6-9所示；

2、所绘制的切垂线可能与所选的圆弧相切于圆弧的延长线上，与所选的直线的垂足也可能在所选直线的延长线上。

6.2.6 直线 >>平行线：距离

绘制在一定距离处和已知直线平行的直线。

如图6-10所示。

实现方法：

（1）启动距离平行线命令；

（2）拾取直线；

（3）输入距离；

（4）选择偏移方向。

* 操作步骤：

1）启动距离平行线命令：

点击“绘制(D)”-> “直线(L)”菜单项或绘制工具条中 [image] 按钮；选择导航工具栏中 [image] 绘制选项。

2）选择直线：

拾取一条已知的直线。

3）输入等距距离：

可以单击鼠标右键接受括号中的默认值，或直接输入距离值后回车。

4）选择方向：

选择直线偏移方向，在直线的某一侧单击鼠标左键拾取一方向点即可。

5）选择直线：

拾取一条直线开始绘制下一条距离平行线，或单击鼠标右键结束。可以连续绘制多条距离平行线。

说明：绘制出的平行线和已知直线等长度。

6.2.7 直线 >>平行线：过点

绘制过一点并与一已知直线平行的直线。

如图6-11所示。

实现方法：

（1）启动过点平行线命令；

（2）拾取已知直线；

（3）输入平行线通过点。

* 操作步骤：

1) 启动过点平

行线命令：

点击“绘制(D)”-> “直线(L)”菜单项或绘制工具条中 [image] 按钮；选择导航工具栏中 [image] 绘制选项。

2) 选择直线：

拾取一条已知的直线。

3) 选择点：

输入平行线要通过的点，参照<点的输入>。

4) 选择直线：

拾取一条直线开始绘制下一条过点平行线，或单击鼠标右键结束。可连续绘制多条过点平行线。

说明：绘制出的平行线与已知直线等长度。

6.2.8 直线 >>平行线：圆弧

绘制与一已知直线平行且与一圆/圆弧相切的直线。如图6-12所示。

实现方法：

（1）启动圆弧平行线命令；

（2）拾取要平行的直线；

（3）拾取要相切的圆或圆弧。

* 操作步骤：

1）启动圆弧平行线命令： | 点击“绘制(D)”-> “直线(L)”菜单项或绘制工具条中 [image] 按钮；选择导航工具栏中的 [image] 选项。
2）选择直线： | 拾取一条直线。
3）选择圆弧（或圆）： | 拾取一条圆或圆弧。

4）选择直线：

选择一直线开始绘制下一条圆弧平行线，或单击鼠标右键结束。可以连续绘制多条圆弧平行线。

说明：

1、与一直线平行且与一圆/圆弧相切的直线可能有两条，系统将生成与圆/圆弧拾取的位置最近的那条直线。如图6-12所示：其中“ [image] ”表示圆弧的拾取位置；

2、生成的平行线与已知直线等长度；

3、生成的平行线与所选圆弧可能在二者的某一或同时在二者的延长线上相切。


圆弧

6.3 绘制圆弧

导航工具栏中的圆弧绘制选项如图6-13所示。

图6-13 圆弧绘制导航工具栏选项

三点圆弧： | 已知圆弧圆周上的三个点，绘制圆弧。
两点圆弧： | 已知两点和圆弧半径绘制圆弧。
圆心半径角度： | 已知圆心、半径和起始角、终止角绘制圆弧。
与1图形相切： | 已知一曲线及该曲线上一点和圆弧的半径绘制圆弧，使该圆弧和已知曲线相切于该点。
与2图形相切： | 已知两条曲线和圆弧半径绘制圆弧，使该圆弧和这两条已知曲线均相切。
与3图形相切： | 已知三条曲线绘制圆弧，使该圆弧和这三条已知曲线均相切。
两直线圆弧： | 已知两条直线和圆弧半径绘制一圆弧，使圆弧与第一条直线相切并且圆心在第二条直线上。
【圆】 | 选中该选项，可绘制与1图形、2图形或3图形相切的圆。

如图6-14所示 6.3.1 圆弧 >> 三点圆弧

已知圆弧圆周上的三个点，绘制圆弧。。

实现方法：

（1）启动三点圆弧命令；

（2）输入圆周上的三个点。

* 操作步骤：

1) 启动三点

圆弧命令：

点击“绘制(D)”-> “圆弧(A)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中 [image] 绘制选项。

2) 输入第一点：

输入圆弧的起始点。

3) 输入第二点：

输入圆弧上的第二个点。

4) 输入第三点：

输入圆弧的终止点。

5) 输入第一点：

输入下一段圆弧的起始点，或单击鼠标右键结束。可以连续绘制多个圆弧段。

说明：输入的三个点不能在一条直线上，否则不能生成圆弧。

6.3.2 圆弧 >> 两点半径圆弧

已知两点和圆弧

半径绘制圆弧。如图6-15所示。

实现方法：

（1）启动两点半径圆弧命令；

（2）输入圆弧的起始点和终止点；

（3）输入圆弧的半径；

（4）拾取符合要求的圆弧段。

* 操作步骤：

1) 启动两点半径

圆弧命令：

点击“绘制(D)”->“圆弧(A)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

2) 输入圆弧的起始点：

输入圆弧起始点。

3) 输入圆弧的终止点：

输入圆弧终止点。

4) 输入圆弧半径：

输入圆弧半径，可单击鼠标右键接受括号中的默认值，也可直接输入新半径值后回车。

5) 选择保留圆弧部分：

点击要保留的圆弧段即可。

通过定义的起始点、终止点和半径可以确定两条或四条圆弧段，这时屏幕上将显示所有可选的圆弧段。如图6-16所示，其中p1和p2点为起始点和终止点，A1、A2、A3和A4为四段供选择的圆弧。

6) 输入圆弧的起始点：

可输入绘制下一个圆弧的起始点，或单击鼠标右键结束。可以连续绘制多条两点半径圆弧。

图6-16 选择圆弧段

说明：起始点和终止点定义后，如果输入的圆弧半径太小，系统弹出对话框提示用户应该输入的最小圆弧半径，据此值重新输入合适的半径值即可。

6.3.3 圆弧 >> 圆心半径角度

已知圆心、半径和起始角、终止角绘制圆弧.如图6-17所示。

实现方法：

（1）启动圆心半径角度圆弧命令；

（2）输入圆心点；

（3）输入圆弧的半径；

（4）输入圆弧起始角和终止角。

* 操作步骤：

1) 启动圆心半径角度圆弧命令：

点击“绘制(D)”->“圆弧(A)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中 [image] 绘制选项；

2) 输入圆心：

输入圆弧的圆心点。

3) 输入圆弧半径：

输入圆弧半径，可单击鼠标右键接受括号中的默认值，也可直接输入新半径值后回车，还可以拖动“橡皮筋”用鼠标定义一点来确定。

4) 输入圆弧的起始角度（-360~360）：

输入圆弧起始角度，可单击鼠标右键接受括号中的默认值，也可直接输入新的角度值后回车，还可以拖动“橡皮筋”用鼠标定义一点来确定。

5) 输入圆弧的终止角度（-360~360）：

输入圆弧终止角度，可单击鼠标右键接受括号中的默认值，也可直接输入新的角度值后回车，还可以拖动“橡皮筋”用鼠标定义一点来确定。

6) 输入圆心：

输入下一条圆弧的圆心点，或单击鼠标右键结束。可连续绘制多条圆心半径角度圆弧。

说明：

1、起始角和终止角限定在-360º~360º之间，正角度是从X轴的正向逆时针计算的，负角度是从X轴的正向顺时针计算的；

2、当输入的终止角大于起始角度时，此时的圆弧为按照逆时针方向从起始角度到终止角度的一段弧；当终止角度小于起始角度时，此时的圆弧为按照顺时针方向从起始角度到终止角的一段弧。

6.3.4 圆弧 >> 与1图形相切

已知一曲线及该曲线上一点和圆弧的半径绘制圆弧，使该圆弧和已知曲线相切与该点。

如图6-18所示。

实现方法：

（1）启动与1图形相切圆弧命令；

（2）拾取一已知曲线和该曲线上的一点；

（3）输入圆弧半径；

（4）选择要保留的圆弧段。

* 操作步骤：

1）启动与1图形相切圆弧命令：

点击“绘制(D)”->“圆弧(A)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中 [image] 绘制选项

2）选择曲线1：

拾取一已知曲线。

3）选择曲线上的点：

拾取该曲线上一点，用鼠标在该曲线上直接单击或捕捉一点，绘制的圆弧将和该曲线相切于本点。

4）输入圆弧半径：

输入圆弧半径，可以单击鼠标右键接受括号中的默认值，也可直接输入新的角度值后回车。

5）选择保留圆弧部分：

点击要保留的圆弧段。当曲线和曲线上的点及圆弧半径确定后，满足该条件的圆弧将有四段并全部显示在屏幕上供用户选择。如图6-19中的A1、A2、A3和A4圆弧段。

6）选择曲线1：

可继续拾取另一已知曲线来绘制下一个相切圆弧，或单击鼠标右键结束。可连续绘制多个与一曲线相切的圆弧。

参数选项：

【圆】

选中该选项，将生成一满足该条件的圆；否则将生成一段圆弧。

6.3.5 圆弧 >> 与2图形相切

已知两条曲线和圆弧半径绘制圆弧，使该圆弧和这两条已知曲线均相切。

如图6-20所示。

实现方法：

（1）启动与2图形相切圆弧命令；

（2）拾取两条相切曲线；

（3）输入圆弧半径。

* 操作步骤：

1) 启动与2图形相切圆弧命令：

点击“绘制(D)”->“圆弧(A)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中 [image] 绘制选项。

2) 选择曲线1：

拾取第一条相切曲线。

3) 选择曲线2：

拾取第二条相切曲线。

4) 输入圆弧半径：

输入圆弧半径，可以单击鼠标右键接受括号中的默认值，也可直接输入新的角度值后回车。

5) 选择曲线1：

拾取绘制下一段圆弧的第一条相切曲线，或单击鼠标右键结束。可连续绘制多个与两个曲线相切的圆弧。

参数选项：

【圆】

选中该选项，将生成一满足该条件的圆；否则将生成一段圆弧。

说明：

1、半径输入太大和太小都可能无法创建满足该条件的圆弧；

2、圆弧可能和选择的两曲线相切于这两曲线的延长线上；

3、两条相切曲线的拾取位置不同，可能生成不同的圆弧段。图6-21 为拾取曲线1、2的位置与图6-20不同时，生成不同的圆弧段；生成的圆弧段为切点离两个拾取位置点最近的那段。

6.3.6 圆弧 >> 与3图形相切

已知三条曲线绘制圆弧，该圆弧和这三条曲线均相切；

如图6-22所示。

实现方法：

（1）启动与3图形相切圆弧命令；

（2）拾取圆弧要相切的三条曲线；

* 操作步骤：

1) 启动与3图形相切圆弧命令：

点击“绘制(D)”->“圆弧(A)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

2) 选择曲线1：

拾取相切曲线1。

3) 选择曲线2：

拾取相切曲线2。

4) 选择曲线3：

拾取相切曲线3。

5) 选择曲线1：

拾取绘制下一段圆弧的相切曲线1，或单击鼠标右键结束。可连续绘制多条与三曲线相切圆弧。

参数选项：

【圆】

选中该选项，将生成一满足该条件的圆；否则将生成一段圆弧。

说明：

1、三条相切曲线的拾取位置不同可能生成不同的圆弧段，如图6-23(a)和(b)。

图6-23 三条曲线的拾取位置不同所生成的圆弧段( [image] 表示曲线的拾取位置)

2、三条相切曲线的拾取顺序不同，也可能生成不同的圆弧段。比较图6-22和图6-24选择的三条曲线的顺序不同所绘制出的圆弧段。

3、不能在三条平行直线之间生成与它们均相切的圆弧。

6.3.7 圆弧 >> 两直线圆弧

已知两条直线和圆弧半径绘制一圆弧，使圆弧与第一条直线相切并且圆心在第二条直线上。

如图6-25所示。

实现方法：

（1）启动两直线圆弧命令；

（2）拾取两条直线；

（3）输入圆弧半径；

（4）选择要保留的圆弧。

* 操作步骤：

1) 启动两直线圆弧命令：

点击“绘制(D)”->“圆弧(A)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

2) 选择圆弧相切直线1：

拾取第一条直线，圆弧将与该直线或延长线相切。

3) 选择圆心所在的直线2：

拾取第二条直线，圆弧的圆心将位于该直线上或其延长线上。

4) 输入圆弧半径：

输入圆弧半径，可以单击鼠标右键接受括号中的默认值，也可直接输入新的角度值后回车。

5) 选择保留圆弧部分：

点击要保留的圆弧段即可。定义好两条直线和圆弧半径后，满足该条件的圆弧可能有两个并显示在屏幕上，图6-26所示弧A1和A2。

6) 选择圆弧相切直线1：

可继续根据状态栏提示重复上面四步骤来绘制多条两直线圆弧，或单击右键结束。

图6-26 选择满足条件的圆弧

说明：所拾取两条直线不能相互平行，否则不能生成该圆弧；


样条曲线

6.4 绘制样条曲线

在工程设计中，除了要绘制一些规则曲线外，还要根据测量或实验得到的一系列点绘制一条通过这些点并且光滑的曲线，称这类曲线为样条曲线。样条曲线的数学基础为Bezier曲线和B-Spline曲线。

本命令将根据输入的样条曲线所通过的点来绘制开放或闭合的样条曲线。

如图6-27所示。

实现方法：

（1）启动绘制样条曲线命令；

（2）输入样条曲线所通过的多个点。

* 操作步骤：

1) 启动绘制样条曲线命令：

点击“绘制(D)”->“样条(N)”菜单项或绘制工具条中的 [image] 按钮。

2) 输入第(1)个点：

输入样条曲线所通过的第一个点。

3) 输入第(2)个点：

输入样条曲线所通过的第二个点。

4) 输入第(n)个点：

逐次输入样条曲线所通过的数据点。可连续输入多个样条曲线通过点，单击鼠标右键结束。

参数选项：

导航工具栏中样条绘制选项如图6-28。

【闭合曲线】：选中此选项，则可绘制光滑闭合的样条曲线。

【给定端点切矢】：选中此选项，则在结束样条所通过的点输入后，还需定义样条起始点和终止点处的端点切矢。端点切矢量的定义方法为：拖动“橡皮筋”，在端点附近定义一点，通过这个点与端点之间的方向矢量来定义端点切矢。如图6-29。

【转为Bezier】：绘制出的样条曲线的类型为多义线，若未选该选项，则该多义线只包含一段样条曲线段；若选中该选项，则系统将该样条曲线段转为一段或多段光滑连接的Bezier曲线段。试比较这两种方式绘制的样条曲线在“节点编辑”时节点的不同（图6-30、31）。

【取消上一点】：点击此按钮，则删除上一个输入的样条曲线通过点，同时样条曲线形状随着进行变化。

图6-29 给定端点切失

图6-30 未转Bezier，调整样条曲线的控制多边形顶点 图6-31 转为Bezier，调整样条曲线定义时的输入点


圆

6.6 绘制圆

绘制圆时的导航工具栏中的选项如图6-38所示。

图6-38　绘制圆导航工具栏选项

两点圆： | 已知圆周上两点，绘制圆。
三点圆： | 已知圆周上的三个点，绘制圆。
圆心半径圆： | 已知圆心和半径画圆。
圆心直径圆： | 已知圆心和直径画圆。

另外在6.3圆弧绘制功能中，还提供了与一条、两条或三条曲线分别相切的圆的绘制方法。

6.6.1 圆 >> 两点圆

已知圆周上两点，绘制圆。如图6-39所示。

实现方法：

（1）启动两点圆命令；

（2）输入圆周上两点。

* 操作步骤：

1） 启动两点圆命令：

点击“绘制(D)”->“圆(C)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

2） 输入第一点：

输入圆上第一点，参照<点的输入>。

3） 输入第二点：

输入圆上第二点, 参照<点的输入>。

4） 输入第一点：

输入下一个圆上的第一点，或单击鼠标右键结束。可连续绘制多个两点圆。

6.6.2 圆 >> 三点圆

已知圆周上的三个点，绘制圆。如图6-40所示。

实现方法：

（1）启动三点圆命令；

（2）输入圆周上三点。

* 操作步骤：

1）启动三点圆命令：

点击“绘制(D)”->“圆(C)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

2）输入第一点：

输入圆上第一点，参照<点的输入>。

3）输入第二点：

输入圆上第二点，参照<点的输入>。

4）输入第三点：

输入圆上第三点，参照<点的输入>。

5）输入第一点：

输入下一个圆上的第一点，或单击鼠标右键结束。可连续绘制多个三点圆。

说明：定义的三个点不能在同一条直线上，否则不能生成圆。

6.6.3 圆 >> 圆心半径圆

已知圆心和半径画圆。如图6-41所示。

实现方法：

（1）启动圆心半径圆命令；

（2）输入圆心点；

（3）输入半径。

* 操作步骤：

1) 启动圆心半径圆命令：

点击“绘制(D)”->“圆(C)”菜单项或绘制工具条中 [image] 按钮；选择导航工具栏中 [image] 绘制选项。

2) 输入圆心：

输入圆心点，参照<点的输入>。

3) 输入圆的半径：

输入圆半径，可以单击鼠标右键接受括号中的默认值，或直接输入半径值后回车，也可以通过拖动“橡皮筋”定义圆周上的一点来定义圆的半径。

4) 输入圆心：

输入下一个圆的圆心点，或单击右键结束。可连续绘制多个圆心半径圆。

6.6.4 圆 >> 圆心直径圆

已知圆心和直径画圆。如图6-42所示。

实现方法：

（1）启动圆心直径圆绘制命令；

（2）输入圆心点；

（3）输入直径。

* 操作步骤：

1）启动圆心直径圆绘制命令：

点击“绘制(D)”->“圆(C)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

2）输入圆心：

输入圆心点，参照<点的输入>。

3）输入圆的直径：

输入圆的直径，可以单击鼠标右键接受括号中的默认值，或直接输入直径值后回车，也可以通过拖动“橡皮筋”定义圆周上的一点来定义圆的直径。

4）输入圆心：

输入下一个圆的圆心点，或单击鼠标右键结束。可连续绘制多个圆心直径圆。


椭圆

6.7 绘制椭圆

椭圆绘制导航工具栏中的绘制选项如图6-43。

图6-43 绘制椭圆导航工具栏选项

两点椭圆： | 通过定义椭圆的包围矩形的两个角点来绘制椭圆。
圆心半径半径： | 已知圆心和两个轴的半径绘制椭圆。

6.7.1 椭圆 >> 两点椭圆

通过定义椭圆包围矩形的两个角点来绘制椭圆。

如图6-45所示。

实现方法：

（1）启动两点椭圆命令；

（2）输入椭圆的两个角点。

* 操作步骤：

1) 启动两点

椭圆命令：

点击“绘制(D)”->“椭圆(E)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

2) 输入第一角点：

输入包围矩形的第一个角点，参照<点的输入>。

3) 输入第二角点：

输入包围矩形的第二个角点，参照<点的输入>。

4) 输入第一角点：

输入下一个椭圆包围矩形的第一个角点，或单击鼠标右键结束。可连续绘制多个两点椭圆。

说明：

1、椭圆的圆心点为连接这两个角点的直线段的中点，椭圆的两个轴的直径分别为由这两个角点所定义的矩形的长和宽；

2、用这种方法不能绘制倾斜的椭圆。

6.7.2 椭圆 >> 圆心半径半径

已知圆心和两个轴的半径绘制椭圆。

如图6-46所示。

实现方法：

（1）启动圆心半径半径椭圆命令；

（2）输入椭圆圆心；

（3）输入椭圆两个半径。

* 操作步骤：

1) 启动圆心半径半径椭圆命令：

点击“绘制(D)”->“椭圆(E)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

2) 输入圆心：

输入椭圆圆心，参照<点的输入>。

3) 输入第一半径：

输入椭圆第一个轴的半径，可以直接输入半径值后回车，也可以通过拖动“橡皮筋”定义一点来定义椭圆的半径。

4) 输入第二半径：

输入椭圆第二个轴的半径，可以直接输入半径值后回车，也可以通过拖动“橡皮筋”定义一点来定义椭圆的半径。

5) 输入圆心：

输入下一个椭圆的圆心点，或单击右键结束。可以连续绘制多个圆心两半径椭圆。

说明：可以采用这种方法绘制倾斜椭圆，拖动“橡皮筋”定义的第一个半径点就确定了椭圆的倾斜角度。


矩形

6.8 绘制矩形

矩形绘制导航工具栏中的绘制选项如图6-47：

图6-47 绘制矩形导航工具栏选项

直角矩形 | 已知矩形的两个角点来绘制矩形。
圆角矩形 | 已知矩形的两个角点和圆角半径绘制圆角矩形。

6.8.1 矩形 >> 直角矩形

已知矩形的两个角点来绘制矩形。

如图6-48所示。

实现方法：

（1）启动直角矩形命令；

（2）输入矩形的两个角点。

* 操作步骤：

1) 启动直角矩

形命令：

点击“绘制(D)”->“矩形(R)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

2) 输入第一角点：

输入矩形第一个角点，参照<点的输入>。

3) 输入第二角点：

输入矩形第二个角点，参照<点的输入>。

4) 输入第一角点：

输入下一个矩形的第一个角点，或单击鼠标右键结束。可以连续绘制多个直角矩形。

说明：用鼠标拖动“橡皮筋”定义角点时，按住shift键绘制出的矩形为正方形。

6.8.2 矩形 >> 圆角矩形

已知矩形的两个角点和圆角半径绘制圆角矩形。

如图6-49所示。

实现方法：

（1）启动圆角矩形命令；

（2）输入矩形的两个角点；

（3）输入圆角半径值。

* 操作步骤：

1) 启动圆角矩形命令：

点击“绘制(D)”->“矩形(R)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

2) 输入第一角点：

输入矩形第一个角点，参照<点的输入>。

3) 输入第二角点：

输入矩形第二个角点，参照<点的输入>。

4) 输入半径：

输入圆角半径值，可直接输入半径值后回车，也可以拖动“橡皮筋”定义一点来确定半径值。

5) 输入第一角点：

输入下一个圆角矩形的第一个角点，或单击右键结束。可以连续绘制多个圆角矩形。

说明：

1、利用“橡皮筋”定义角点时，按住shift键，则拖动形成的矩形为正方形；在用“橡皮筋”定义圆角半径时，若同时按住shift键，则圆角圆心在图形之外。如图6-50A所示。

2、若圆角半径值大于或等于矩形最短边长的一半时，则绘制的出的矩形为全圆角矩形，如图6-50B。

图6-50A 按住shift键时的圆角特征 图6-50B 全圆角矩形


正多边形

6.9 绘制正多边形

正多边形绘制导航工具栏中的选项如图6-51。

图6-51 绘制正多边形导航工具栏选项

内接多边形 | 已知圆的圆心、半径和多边形的边数，绘制圆的内接正多边形。
外切多边形 | 已知圆的圆心、半径和多边形的边数，绘制圆的外切正多边形。
边长多边形 | 已知多边形的边数和其中一条边的两个端点来绘制正多边形。

6.9.1 正多边形 >> 内接多边形

已知圆的圆心、半径和多边形的边数，绘制圆的内接正多边形。

实现方法：

（1）启动内接多边形绘制命令；

（2）输入边数；

（3）输入圆心点；

（4）输入半径。

* 操作步骤：

1) 启动内接多边形绘制命令：

点击“绘制(D)”->“正多边形(G)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项；

2) 输入边数：

输入多边形的边数，可单击鼠标右键接受括号中的默认值，也可以直接输入新的边数后回车。

3) 输入圆心：

输入正多变形的外接圆圆心点，参照<点的输入>。

4) 输入半径：

输入正多变形的外接圆半径，半径值可以直接输入，也可以拖动“橡皮筋”定义另外一点来确定。

5) 输入圆心：

输入下一个正多变形的外接圆的圆心，或单击鼠标右键结束。可以连续绘制多个边数相同的圆内接正多边形。

说明：圆的圆心点即为正多边形的中心点，圆的半径即为多边形中心与每条边的端点之间的距离。

6.9.2 正多边形 >> 外切多边形

已知圆的圆心、半径和多边形边数，绘制圆的外切正多边形。

实现方法：

（1）启动外切多边形绘制命令；

（2）输入边数；

（3）输入圆心点；

（4）输入半径。

* 操作步骤：

1) 启动外切多边形绘制命令：

点击“绘制(D)”->“正多边形(G)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

1) 输入边数：

输入多边形的边数，可单击鼠标右键接受括号中的默认值，也可以直接输入新的边数后回车。

2) 输入圆心：

定义多边形内切圆圆心点，参照<点的输入>。

3) 输入半径：

输入多边形内切圆半径，半径值可以直接输入，也可以拖动“橡皮筋”定义另外一点来确定。

4) 输入圆心：

输入下一个正多变形的内切圆的圆心，或单击右键结束。可以连续绘制多个边数相同的圆外切正多边形。

说明：圆的圆心点即为正多边形的中心点；圆的半径为多边形中心与每条边的中点之间的距离。

6.9.3 正多边形 >>边长多边形

已知多边形的边数和其中一条边的两个端点来绘制正多边形。

(a) (b)

图6-54 边长正五边形

实现方法：

（1）启动边长多边形绘制命令；

（2）输入边数；

（3）输入边的两个端点。

* 操作步骤：

1) 启动边长多边形绘制命令：

点击“绘制(D)”->“正多边形(G)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中的 [image] 绘制选项。

2) 输入边数：

输入多边形的边数，可单击鼠标右键接受括号中的默认值，也可以直接输入新的边数后回车。

3) 输入第一点：

输入边的第一个端点，参照<点的输入>。

4) 输入第二点：

输入边的第二个端点，参照<点的输入>。

5) 输入第一点：

输入下一个边长多边形的第一个端点，或单击右键结束。可以连续绘制多个边数相同的边长正多边形。

说明：定义多边形的一条边时，其两个端点的定义顺序不同，多边形的走向不同。多边形的走向是按照输入的两个点的逆时针方向定义的。比较图6-59的(a)和(b)，边的两个端点定义顺序和绘制出的多边形。


星形

6.10 绘制星形

与正多边形类似，星形也是由边数和其外接或内接圆来确定的；通常要同时定义星形的内接圆和外接圆（二者同心）。星形的边数为其内接或外接多边形的边数。图6-51 所示：

图6-55 星形的外接圆、内接圆和外接多边形

星形绘制时的导航工具栏中的选项如图6-52。

图6-56 绘制星形时导航工具栏选项

单半径星形 | 已知星形的外接圆和边数绘制星形。
双半径星形 | 定义星形的外接圆、内接圆及其边数来绘制星形。
【圆弧星形】 | 选中此选项，将可绘制双半径圆弧星形。

6.10.1 星形 >> 单半径星形

已知星形的外接圆和边数绘制星形。

图6-57 单半径星形

实现方法：

（1）启动单半径星形命令；

（2）输入星形的边数；

（3）输入星形的外接圆圆心；

（4）输入星形的外接圆半径。

* 操作步骤：

1) 启动单半径星形命令：

点击“绘制(D)”->“星形(S)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中 [image] 绘制选项。

2) 输入边数：

输入星形的边数，可单击鼠标右键接受括号中的默认值，也可以直接输入新的边数后回车。

3) 输入圆心：

输入星形的外接圆圆心，参照<点的输入>。

4) 输入半径：

输入星形的外接圆半径，可以直接输入半径值后回车，也可以用鼠标拖动“橡皮筋”定义另外一点来确定。

5) 输入圆心：

输入下一个星形的外接圆圆心，或单击鼠标右键结束。可连续绘制多个边数相同的单半径星形。

说明：星形的内接圆半径由系统根据外接圆的半径和其边数自动计算出来，一般用于绘制比较规则的星形。

6.10.2 星形 >> 双半径星形

定义星形的外接圆、内接圆及其边数来绘制星形。

图6-58 双半径星形

实现方法：

（1）启动双半径星形命令；

（2）输入星形的边数；

（3）输入星形的外接圆或内接圆的圆心；

（4）输入星形的两个半径。

操作步骤：

1) 启动双半径星形命令：

点击“绘制(D)”->“星形(S)”菜单项或绘制工具条中的 [image] 按钮；选择导航工具栏中 [image] 绘制选项。

2) 输入边数：

输入星形的边数，可单击鼠标右键接受括号中的默认值，也可以直接输入新的边数后回车。

3) 输入圆心：

输入星形的内接圆或外接圆圆心，参照<点的输入>。

4) 输入第一半径：

输入星形的第一个半径，可以直接输入半径值后回车，也可以用鼠标拖动“橡皮筋”定义另外一点来确定。

5) 输入第二半径：

输入星形的第二个半径，可以直接输入半径值后回车，也可以用鼠标拖动“橡皮筋”定义另外一点来确定。

6) 输入圆心：

输入下一个星形的内接圆或外接圆圆心，或单击鼠标右键结束。可连续绘制多个边数相同的双半径星形。

参数选项：

【圆弧星形】

选中该选项，绘制出的星形的各边不是直线段，而为圆弧段（图6-55）。

图6-59 圆弧星形

说明：星形的两个半径即内接圆和外接圆半径。星形的第一半径可以为其内接圆半径，也可为其外接圆的半径；系统根据定义两个半径的大小，确定其内接和外接圆的半径。


双线

6.11 绘制双线

已知线宽来绘制双线，即绘制距离等于线宽的两条平行直线。

实现方法：

（1）启动双线绘制命令；

（2）输入双线线宽；

（3）输入双线起点和末点。

* 操作步骤：

1) 启动双线绘制命令：

点击“绘制(D)”->“双线(D)”菜单项。

2) 输入双线的线宽：

输入双线线宽，即两平行线的距离。可单击鼠标右键接受括号中的默认值，也可以直接输入新的线宽值后回车。

3) 输入双线的起点：

输入双线的起点，参照<点的输入>。

4) 输入双线的末点：

定义双线的末点，参照<点的输入>。可连续输入多个末点来绘制连续的双线，单击鼠标右键结束。

说明：

1、定义好线宽后，双线的绘制同直线的绘制方式相同；

2、绘制出的双线的图形类型为图形集合，该集合包含两条只含有直线段的多义线。


箭头

6.12 绘制箭头

箭头绘制的导航工具栏中的绘制选项如图6-61。

图6-61 绘制箭头时导航工具栏选项

斜角箭头 | 已知箭头上的四个特征点，绘制斜角箭头。
直角箭头 | 已知箭头上的四个特征点，绘制直角箭头。
单线箭头 | 已知箭头上的三个特征点，绘制单线箭头。

三种类型的箭头如图6-62 所示：

图6-62 三种类型的箭头

6.12.1 箭头 >> 斜角箭头 箭头 >> 直角箭头

已知箭头上的四个特征点，绘制斜角和直角箭头；

图6-63 绘制斜角箭头和直角箭头

实现方法：

（1）启动斜角箭头或直角箭头绘制命令；

（2）输入箭头上的四个特征点。

操作步骤：

1) 启动斜角或直角箭头绘制命令：

点击“绘制(D)”->“箭头(W)”菜单项；分别选择导航工具栏中的 [image] 或 [image] 绘制选项。

2) 输入第一点：

输入箭头上的第一个特征点，参照<点的输入>。

3) 输入第二点：

输入箭头上的第二个特征点，参照<点的输入>。

4) 输入第三点：

输入箭头上的第三个特征点，参照<点的输入>。

5) 输入第四点：

输入箭头上的第四个特征点。参照<点的输入>。

6) 输入第一点：

输入下一个箭头上的第一个特征点，或单击鼠标右键结束。可以连续绘制多个斜角箭头或直角箭头。

说明：输入的第一点为箭头的起始点，第二点确定了箭头的整体长度，第三点确定了箭头的整体宽度和尖部的长度，第四点确定了斜角箭头的端部斜角及宽度和直角箭头端部的宽度。

6.12.2 箭头 >> 单线箭头

已知单线箭头上的三个特征点来绘制单线箭头。

图6-64 绘制单线箭头

实现方法：

（1）启动单线箭头绘制命令；

（2）输入箭头上的三个特征点。

* 操作步骤：

1) 启动单线箭头绘制命令：

点击“绘制(D)”->“箭头(W)”菜单项；

选择导航工具栏中的 [image] 绘制选项；

2) 输入第一点：

输入箭头上的第一个特征点，参照<点的输入>。

3) 输入第二点：

输入箭头上的第二个特征点，参照<点的输入>。

4) 输入第三点：

输入箭头上的第三个特征点，参照<点的输入>。

5) 输入第一点：

输入下一个箭头上的第一个特征点，或单击鼠标右键结束。可以连续绘制多个单线箭头。

说明：

1、第一点为箭头的起始点，第二点确定了箭头的整体长度，第三点确定了箭头尖部的长度和宽度；

2、绘制出的箭头的图形类型为图形集合，该集合包含两条只含有直线段的多义线。


公式曲线

6.13 绘制公式曲线

根据数学公式（或参数表达式）绘制出相应的数学曲线。公式曲线为用户提供一种更方便、更精确的作图方法，以适应某些精确轮廓外形的作图设计的需要。

图6-65 公式曲线

实现方法：

（1）启动公式曲线绘制命令；

（2）在对话框中定义绘制公式曲线的参数和选项；

（3）拾取曲线的放置基点。

* 操作步骤：

1) 启动公式曲线绘制命令：

点击“绘制(D)”->“公式曲线(F)”菜单项。

2) 在对话框中定义绘制公式曲线的参数和选项：

在公式曲线对话框（图6-66）中定义公式曲线相关参数，点击“确定”按钮。

3) 拾取曲线基点：

定义曲线在屏幕上放置的基点，参照<点的输入>。

图6-66 公式曲线对话框

参数选项：

起始值 | 公式中的变量t的起始值。
终止值 | 公式中的变量t的终止值。
单位 | 公式中的变量t的单位，可以为度、弧度或其它。
曲线输入 | 确定了曲线的哪一个点将来对应到曲线在屏幕上的放置基点。有曲线的中心点、起点、末点和原点四种对应方式。
直角坐标 极坐标 | 输入的公式为直角坐标公式X(t)和Y(t)。 输入的公式为极坐标公式ρ(t)。
X(t)= Y(t)= | 当为直角坐标时，输入X(t)和Y(t)的表达式。 当为极坐标时，输入ρ(t)的表达式。
曲线拟合精度 | 将精确的公式曲线用NURBS曲线进行拟合的精度。
多段拟合 | 当曲线过长或参数域取值跨度较大时，用一段NURBS曲线进行拟合可能达不到所要求的精度，因此建议用多段曲线进行拟合。选中此选项，然后点击该按钮，在弹出的对话框（图6-67）中输入用NURBS曲线拟合的段数。
提取公式 | 从公式库中提取公式。点击此按钮，在公式库对话框(图6-68)中选择一已存储的公式，点击确定。
存储公式 | 将当前输入的公式存储到公式库中以便下一次直接从中将其提取出来。点击此按钮，在弹出的对话框（图6-69）中输入公式名称来将当前公式存入公式库。
曲线预览 | 点击此按钮，将在预览框中显示出当前公式的曲线图形。

图6-67 多段拟合对话框

图6-68 从公式库中提取公式

图6-69 存储公式


图形编辑

第七章 图形编辑

本章介绍图形的有关编辑操作命令，包括以下三类：

1、基本编辑操作命令，如撤消与重做、复制和粘贴、删除等；

2、曲线编辑操作命令，如曲线裁剪与延伸、等距、倒角等；

3、区域操作命令，如区域构造、等距、焊接、剪裁、求交等。

可以点击“编辑”菜单中的各子菜单项（图7-1）或“编辑”工具条中的各按钮（图7-2）来执行相应的命令操作。

图7-1 编辑菜单

图7-2 编辑工具条

撤消 | Ctrl + Z | 撤消操作
重做 |  | 重做操作
剪切 | Ctrl + X | 剪切图素至剪贴板
复制 | Ctrl + C | 复制图素至剪贴板
粘贴 | Ctrl + V | 从剪贴板粘贴图素
删除 | Del | 删除图素
等分 |  | 曲线等分
切断 |  | 曲线切断
修剪 | Alt + 8 | 曲线修剪
延伸 | Alt + 9 | 曲线延伸
倒倒角 | Alt + 0 | 曲线倒圆角
倒斜角 |  | 曲线倒斜角
连接 |  | 曲线连接
闭合 |  | 曲线闭合
单线等距 | Alt + 5 | 单线等距
单线膨胀 |  | 单线膨胀
计算中心线 |  | 计算中心线
多边构造区域 |  | 多个曲线边界构造区域轮廓图形
区域修剪曲线 |  | 区域轮廓图形修剪曲线
区域等距 | Ctrl + 1 | 区域轮廓图形等距
区域焊接 | Ctrl + 2 | 区域轮廓图形合并
区域剪裁 | Ctrl + 3 | 区域轮廓图形剪裁
区域求交 | Ctrl + 4 | 区域轮廓图形求交


图形基本操作

7.1 图形的基本编辑操作

图形的基本编辑操作包括撤消与重做、剪贴、复制、粘贴和删除等。

1、撤消和重做可以帮助用户更改绘图中的误操作，返回到前面某一命令的操作状态。

2、剪切、复制、粘贴和删除是最基本的复制和删除图素的四个命令。其中前三个均与

Windows的剪贴板有关。

3、在不同的工具状态下，剪切、复制、粘贴的对象可能不同，例如，在文字编辑状态下，上述操作是对当前正在编辑的字符串的被选字符进行的，而在对象选择工具下，则是对被选对象整体进行操作。

7.1.1 撤消

撤消上一步命令的执行。

实现方法： 直接启动撤消命令。

* 操作步骤：

启动撤消命令：

点击“编辑(E)”->“撤消(U)”菜单项或常用工具条中的 [image] 按钮。本菜单项后面将显示上一步操作的名称。

说明：

1、一些命令包含自身的撤消选项，用户无需退出此命令的执行便可取消上一步操作。如在创建多义线命令执行过程中，可以撤消上一曲线段的绘制；

2、并不是所有命令的执行结果都能够被撤消，如系统设置和各种观察命令等。

7.1.2 重做

取消上一步“撤消”命令的执行结果。

实现方法：

直接启动重做命令。

* 操作步骤：

启动重做命令：

点击“编辑(E)”->“重做(R)”菜单项或常用工具条中的 [image] 按钮。本菜单项后面将显示上一步所撤消的命令名称。

说明：

1、本命令必须立即跟随在“撤消”命令之后，若在“撤消”命令后又执行了其它的命令后，本命令将可能失效；

2、在系统设置中定义了系统最大撤消和重做的次数，参照系统设置。

7.1.3 剪切

删除选定的图素并将它们存储到剪贴板上，以供粘贴使用。

实现方法：

（1）选择图素；

（2）启动剪切命令。

* 操作步骤：

1) 选择图素：

选择要进行剪切的图素

2) 启动剪切命令：

点击“编辑(E)”->“剪切(X)”菜单项或常用工具条中的 [image] 按钮。

7.1.4 复制

将选定的图素复制一份到剪贴板上，以供图形粘贴时使用。

实现方法：

（1）选择图素；

（2）启动复制命令。

* 操作步骤：

1) 选择图素：

选择要进行复制的图素。

2) 启动复制命令：

点击“编辑(E)”->“复制(C)”菜单项或常用工具条中的 [image] 按钮。

7.1.5 粘贴

将剪贴板中存储的图素粘贴到当前文件中。

实现方法：

直接启动粘贴命令。

* 操作步骤：

启动粘贴命令：

点击“编辑(E)”->“粘贴(P)”菜单项或常用工具条中的 [image] 按钮。

说明：

1、可将JDPaint中的各种图素从一个文件复制粘贴到另一个文件；

2、可将光栅图象从外部程序中复制粘贴至JDPaint中，但不能将图象从JDPaint复制粘贴至外部程序中；

3、矢量图形不能在JDPaint和其它程序间进行复制粘贴；

4、在“文字编辑工具”下，文字可在JDPaint与Photoshop、AutoCAD、CorelDraw等外部程序中进行相互复制粘帖，但不保留文字的排列、字体、大小等信息。

7.1.6 删除

删除屏幕上的指定图素。

实现方法：

（1）启动删除命令；

（2）拾取要删除的图素。

* 操作步骤：

1) 启动删除命令：

点击“编辑(E)”->“删除(D)”菜单项或常用工具条中的 [image] 按钮。

2) 选择被删除的图形：

拾取要删除的图素。可删除多个图素，单击鼠标右键结束命令。

说明：此命令的执行亦可先选择被删除的图形，然后再点击删除菜单项或工具条选项。


曲线等分

7.2 曲线编辑操作

曲线的编辑操作包括：曲线等分、切断、修剪、延伸、倒角、连接、闭合、等距、膨胀、计算中心线等操作。

7.2.1 曲线等分

将一曲线等分为若干段。

图7-3 三等分曲线

实现方法：

（1）启动等分命令；

（2）输入等分段数；

（3）拾取要等分的曲线段。

* 操作步骤：

1) 启动等分命令：

点击“编辑(E)”->“等分(V)”菜单项。

2) 输入等分段数：

输入曲线等分段数，单击右键接受当前括号中的默认值或输入新值后回车。

3) 拾取被等分曲线：

拾取要等分的曲线段，可以连续拾取多个曲线段来进行等分，单击右键结束。

参数选项：

导航工具栏中的等分选项如图7-4：

图7-4 曲线等分导航工具栏选项

【整体等分】 | 主要是针对包含多段线的多义线而言的。图7-5为包含有三个曲线段的一条曲线，拾取曲线的位置在中间段。若不选中“整体等分”选项，则只对中间的线段进行等分；若选中“整体等分”选项，则对整条曲线进行等分。
【保留单线】 | 是否在每个等分点处将原曲线分裂为两条不同的曲线。若选中该选项，则等分后的曲线仍为一条包含这些等分段的曲线；若不选中该选项，则等分后的曲线的条数为所输入的等分段数。

(a)要等分曲线 (b) 不选“整体等分” (c)整体等分

图7-5 【整体等分】选项


曲线切断

7.2.2 曲线切断

将给定的曲线在某位置处进行打断。导航工具栏选项如图7-6。

图7-6 曲线切断导航工具栏选项

点切断 | 将给定曲线在其上的某一点处进行切断。
线切断 | 将给定曲线在与另一相交曲线的交点处进行切断。
【自动闭合】 | 线切断时的选项，参照<线切断>。
【删除裁剪】 | 线切断时的选项，参照<线切断>。

7.2.2.1 曲线切断 >> 点切断

将指定曲线在其上的某一点处进行切断。

图7-7 点切断

实现方法：

（1）拾取要被切断的曲线；

（2）启动点切断命令；

（3）拾取切断点。

* 操作步骤：

1) 拾取要被切断的曲线：

拾取一条要被切断的曲线。

2) 启动点切断命令：

点击“编辑(E)”->“切断(K)”菜单项；

选择导航工具栏中的 [image] 选项。

3) 拾取断开点：

拾取曲线上的断开点，可拾取多个断开点将曲线分为多段，单击鼠标右键结束。

7.2.2.2 曲线切断 >> 线切断

将指定曲线在与另一相交曲线的交点处进行切断。

图7-8 线切段

实现方法：

（1）拾取要被切断的曲线；

（2）启动线切断命令；

（3）拾取切断曲线。

* 操作步骤：

1) 拾取要被切断的曲线：

拾取一条要被切断的曲线；

2) 启动线切断命令：

点击“编辑(E)”->“切断(K)”菜单项；选择导航工具栏中的 [image] 选项；

3) 拾取切断曲线：

拾取切断曲线。可以拾取多条切断曲线，点击鼠标右键结束；

参数选项：

【自动闭合】 | 若被切断曲线和切断曲线有两个或两个以上的交点，则将切断后得到的每条曲线在交点处闭合。如图7-9；
【删除裁剪线】 | 选中此选项，则将曲线切断后将裁剪线(拾取的切断曲线)删除掉。

图7-9 自动闭合


曲线修剪

7.2.3 曲线修剪

利用一条或多条曲线对象对给定曲线（被裁剪线）进行修剪, 删除不需要的部分。曲线修剪命令的导航工具栏选项如图7-10。

图7-10 曲线修剪导航工具栏选项

线裁剪 | 利用一个或多个曲线作为边界线来对给定的曲线进行裁剪。
点裁剪 | 利用曲线上的点作为边界来对曲线进行裁剪。

7.2.3.1 修剪 >> 线裁剪

利用一个或多个曲线作为边界线来对给定的曲线进行修剪；

(a)边界曲线和被修剪曲线定义 (b) 修剪结果

图7-11 线修剪

实现方法：

（1）启动线裁剪命令；

（2）拾取边界曲线；

（3）拾取被裁剪的曲线。

* 操作步骤：

1) 启动线裁剪命令：

点击“编辑(E)”->“修剪(T)”菜单项或编辑工具条中的 [image] 按钮；选择导航工具栏中的 [image] 选项。

2) 选择第(1)个修剪边界图形：

拾取第一条边界曲线。

3) 选择第(2)个修剪边界图形，单击鼠标右键开始选择被修剪图形：

拾取第二条边界曲线，或者单击右键结束边界曲线的拾取。可连续定义多条边界曲线。

4) 选择被修剪图形：

拾取被修剪的曲线，拾取的位置要在曲线被裁剪掉的部分段上。可以拾取多个被修剪的曲线，单击右键结束。

7.2.3.2 修剪 >> 点裁剪

利用曲线上的点作为边界来对曲线进行裁剪。

(a) 被修剪曲线及边界点定义 (b) 修剪结果

图7-12 点修剪曲线

实现方法：

（1）启动点裁剪命令；

（2）拾取被裁剪曲线；

（3）拾取边界点。

* 操作步骤：

1) 启动点修剪命令：

点击“编辑(E)”->“修剪(T)”菜单项或编辑工具条中的 [image] 按钮；选择导航工具栏中 [image] 选项。

2) 选择被修剪图形：

拾取被裁减的曲线，曲线的拾取位置要在裁剪后要保留的部分段上。

3) 输入点：

鼠标拾取作为裁剪边界的点，拾取的点可以在曲线上也可以不在曲线上。

4) 选择被修剪图形：

拾取另外一条要被修剪的曲线，或单击右键结束。

说明：若拾取的边界点不在曲线上，则对曲线进行裁剪的实际边界点为该点到被裁剪曲线上的最近点。


曲线延伸

7.2.4 曲线延伸

将给定的曲线延伸到某一曲线边界或某一点处。

曲线延伸导航工具栏中的选项如图7-13。

线延伸 | 将给定的曲线延伸到另一曲线所确定的边界。
点延伸 | 将给定的曲线延伸到指定的点处。

7.2.4.1 延伸 >> 线延伸

将指定曲线延伸到另一曲线所确定的边界。

(a) 边界曲线和延伸曲线的定义 (b) 延伸结果

图7-14 曲线延伸到线 ( [image] 表示曲线的拾取位置)

实现方法：

（1）启动线延伸命令；

（2）拾取边界曲线；

（3）拾取延伸曲线。

* 操作步骤：

1) 启动线延伸命令：

点击“编辑(E)”->“延伸(E)”菜单项或编辑工具条中的 [image] 按钮；选择导航工具栏中的 [image] 选项。

2) 选择第(1)个延伸边界图形：

拾取第一个边界曲线。

3) 选择第(2)个延伸边界图形，单击鼠标右键选择被延伸图形：

拾取第二个边界曲线，或单击鼠标右键结束边界曲线的定义。可以连续拾取多个延伸边界曲线。

4) 选择被延伸曲线：

拾取延伸曲线。可拾取多个曲线延伸到边界曲线，单击鼠标右键结束延伸操作。

说明：曲线延伸是将延伸曲线从与它的拾取位置最近的那个端点处开始延伸，直至与延伸边界曲线相交或相切为止。因此延伸曲线的拾取位置不同，可能有不同的延伸结果。如图7-15。

图7-15 延伸曲线的拾取位置对延伸结果的影响 ( [image] 表示曲线的拾取位置)

7.2.4.2 延伸 >> 点延伸

将指定曲线延伸到指定的点处。

(a) 延伸曲线和边界点的定义 (b) 延伸结果

图7-16 曲线延伸到点

实现方法：

（1）启动点延伸命令；

（2）拾取要延伸的曲线；

（3）定义延伸到的边界点。

* 操作步骤：

1) 启动点延伸命令： | 点击“编辑(E)”->“延伸(E)”菜单项或编辑工具条中的 [image] 按钮；选择导航工具栏中的 [image] 选项。
2) 选择被延伸曲线： | 拾取要延伸的曲线。

3) 输入点：

定义延伸边界点。通过鼠标在屏幕上直接点击或捕捉一点来确定边界点。

4) 选择被延伸曲线：

拾取下一个要延伸的曲线，或单击右键结束。

说明：

1、所定义的延伸边界点不一定要在曲线的延长线上，曲线实际延伸到的边界点为所定义的边界点到延伸曲线的最近点；

2、延伸曲线是从与其拾取位置最近的那个端点处开始延伸的。如图7-17。

图7-17 延伸曲线的拾取位置对延伸结果的影响


曲线倒圆角

7.2.5 曲线倒圆角

在曲线或曲线段之间进行给定半径的圆弧光滑过渡。

倒圆角导航工具栏中选项如图7-18。

图7-18 倒圆角导航工具栏中选项

单线过渡 | 在一条曲线的每两个相邻曲线段之间，进行给定半径的圆角过渡。
两线过渡 | 在两曲段线之间进行给定半径的圆角过渡。
【裁剪曲线】 | 在两线过渡时，是否对原曲线进行裁剪。

倒角后的图形与原始图形之间的关系，如图7-19所示。

图7-19 倒角后的图形与原始图形之间的关系

7.2.5.1 倒圆角 >> 单线过渡

在曲线的每两个相邻曲线段之间进行给定半径的圆角过渡。

图7-20 单线倒圆角

实现方法：

（1）启动单线过渡命令；

（2）输入圆角半径；

（3）拾取要倒圆角的曲线。

* 操作步骤：

1) 启动单线过渡命令：

点击“编辑(E)”->“倒角(F)”->“倒圆角(F)”菜单项或编辑工具条中的 [image] 按钮；在导航工具栏中选择 [image] 选项。

2) 输入圆角过渡半径：

输入圆角半径,单击右键接受当前括号中的默认值或输入新值后回车。

3) 选择曲线1：

拾取要进行圆角过渡的曲线。该曲线应该为包含两个或两个以上的曲线段的多义线。可以连续拾取多条曲线进行圆角过渡，单击鼠标右键结束。

7.2.5.2 倒圆角 >> 两线过渡

在两曲段线之间进行给定半径的圆角过渡。

图7-21 两线倒圆角

实现方法：

（1）启动两线过渡命令；

（2）输入圆角半径；

（3）拾取两条要倒圆角的曲线段。

* 操作步骤：

1) 启动两线过渡命令：

点击“编辑(E)”->“倒角(F)”->“倒圆角(F)”菜单项或编辑工具条中的 [image] 按钮；在导航工具栏中选择 [image] 选项。

2) 输入圆角过渡半径：

输入倒圆角半径，可单击右键接受当前括号中的默认值或输入新值后回车。

3) 选择曲线1：

拾取第一个曲线段，拾取位置应该在要保留的曲线段部分。

4) 选择曲线2：

拾取第二个曲线段，拾取位置应该在要保留的曲线段部分。

5) 选择曲线1：

拾取下一次要倒圆角的曲线段1，或单击右键结束。可以连续倒多个倒角。

参数选项：

【裁剪曲线】

在倒圆角的同时，是否用圆角对两条曲段进行裁剪。若未选该选项，则不对原曲线进行裁剪，如图7-22。

图7-22 倒角不裁剪曲线


曲线倒斜角

7.2.6 曲线倒斜角

在指定的两直线段之间进行斜角过渡。

倒斜角导航工具栏中的选项如图7-23。

单线倒斜角 | 在一条曲线的每两个相邻的直线段之间倒斜角
两线倒斜角 | 在两个给定的直线段之间倒斜角

图形倒斜角后，倒角后的图形与原始图形之间的关系如图7-24。

图7-24 倒角后的图形与原始图形之间的关系

7.2.6.1 倒斜角 >> 单线倒角

在一条曲线的每两个相邻的直线段之间倒斜角。

图7-25 单线倒斜角

实现方法：

（1）启动单线倒斜角命令；

（2）输入倒角半径1和输入倒角半径2；

（3）拾取要倒斜角的曲线。

* 操作步骤：

1) 启动单线倒斜角命令：

点击“编辑(E)”->“倒角(F)”->“倒斜角(M)”菜单项或编辑工具条中的 [image] 按钮；在导航工具栏中选择 [image] 选项。

2) 输入倒角半径1：

定义倒角半径1，可单击右键接受当前括号中的默认值或输入新值后回车。

3) 输入倒角半径2：

定义倒角半径2，可单击右键接受当前括号中的默认值或输入新值后回车。

4) 拾取需倒角的直线段1：

拾取要倒斜角曲线，该曲线应该为一条至少含有两个相邻的直线段的多义线。可连续拾取多条曲线倒斜角，单击鼠标右键结束。

7.2.6.2 倒斜角 >> 两线倒角

在两个给定的直线段之间倒斜角。

图7-26 两线倒斜角

实现方法：

（1）启动两线倒斜角命令；

（2）输入倒角半径1和倒角半径2；

（3）拾取要倒斜角的两条直线段。

* 操作步骤：

1) 启动两线倒斜角命令：

点击“编辑(E)”->“倒角(F)”->“倒斜角(M)”菜单项或编辑工具条中的 [image] 按钮；选择导航工具栏中 [image] 选项。

2) 输入倒角半径1：

定义倒角半径1，可单击右键接受当前括号中的默认值或输入新值后回车。

3) 输入倒角半径2：

定义倒角半径2，可单击右键接受当前括号中的默认值或输入新值后回车。

4) 拾取需倒角的直线段1：

拾取第一个要倒斜角的直线段，拾取位置应该在要保留的曲线段部分。

5) 拾取需倒角的直线段2：

拾取第二个要倒斜角的直线段，拾取位置应该在要保留的曲线段部分。

6) 拾取需倒角的直线段1：

拾取下一次要倒斜角的直线段1，或单击右键结束命令。可连续倒多个斜角。

说明：

1、两个直线段不能平行，可以相交也可以不相交；

2、两个直线段可以是同一条曲线上相邻的或不相邻的直线段，也可以不在同一条曲线上；图7-27(a)为同一条曲线上的两不相邻的直线段倒斜角的结果，图7-27(b)为一直线段与另一条曲线上的一直线段倒斜角。

（a） (b)

图7-27 两线倒斜


曲线连接

7.2.7 曲线连接

将两条或者多条开曲线连接为一条曲线。

曲线连接命令的导航工具栏选项如图7-28。

自动连接 | 分别从一条开曲线的首末端点出发，在一定的精度范围内搜索附近的与其首末点相连的曲线来将它们连接成为一条曲线。
缺省连接 | 同时改变两条开曲线的连接端点位置来将二者连接为一条曲线。
改变首点连接 | 将第一条曲线的连接端点移至第二条曲线的连接端点处来进行连接。
改变末点连接 | 将第二条曲线的连接端点移至第一条曲线的连接端点处来进行连接。
加入直线连接 | 在两条曲线的连接处加入一直线段来将这两条曲线连接起来。
加入圆弧连接 | 两条曲线的连接处加入一圆弧段来将这两条曲线连接起来圆弧。
加入曲线连接 | 两条曲线的连接处加入一样条曲线来将这两条曲线连接起来。
自动连接精度 | 点击此按钮，可以设定自动连接时的连接精度。

7.2.7.1 连接 >> 自动连接

分别从一条开曲线的首末端点出发，在一定的精度范围内搜索附近的与其首末点相连的曲线来将它们连接成为一条曲线。

图7-29 自动连接

实现方法：

（1）启动自动连接命令；

（2）拾取一条开曲线。

* 操作步骤：

1) 启动自动连接命令：

点击“编辑(E)”->“连接(J)”菜单项；

选择导航工具栏中的 [image] 选项。

2) 拾取第一条开曲线：

选择一条开曲线自动将其与其周围的在一定精度范围内的曲线连接起来。可以连续选择多条曲线进行自动连接，点击鼠标右键结束。

参数选项：

自动连接精度：

要连接的两个曲线在连接端点处的最大允许距离，范围在0.001-10mm之间。若两条曲线的连接端点不重合，此时要将二者连接起来与连接精度有关。

调整方法：点击导航工具栏中的 [image] 按钮，在弹出的连接精度对话框（图7-30）中输入精度值。

图7-30 连接精度调整对话框

说明：若某一曲线的连接点处可以两个或两个以上的曲线连接，即到了“岔路口”，这时在屏幕上显示出方向箭头（图7-31（a）），提示用户选择另一连接曲线。只须在其中要连接的那一条曲线上单击即可。图7-31(b)为连接结果。

图7-31 连接“岔路口”

7.2.7.2 连接 >> 缺省连接、连接 >> 改变首点连接、连接 >> 改变末点连接

通过改变两条开曲线的端点位置来将二者连接为一条曲线。与自动连接不同，这三种方式都是针对两条曲线而言的。

图7-32 曲线连接

缺省连接 | 两条曲线的连接端点均相互靠拢相交在一起。
改变首点连接 | 第二条曲线的连接端点不动，第一条曲线的连接端点靠拢至第二条曲线的连接端点处。
改变末点连接 | 第一条曲线的连接端点不动，第二条曲线的连接端点靠拢至第一条曲线的连接端点处。

实现方法：

（1）启动缺省连接或改变首点连接或改变末点连接命令；

（2）拾取两条要连接的开曲线。

操作步骤：

1) 启动缺省连接或改变首点连接或改变末点连接命令： | 点击“编辑(E)”->“连接(J)”菜单项； 选择导航工具栏中的 [image] 或 [image] 或 [image] 选项。
2) 拾取第一条开曲线： | 拾取第一条开曲线，该曲线的连接端点为距离拾取位置最近的那个端点。

3) 拾取第二条开曲线：

拾取第二条开曲线，该曲线的连接端点为距离拾取位置最近的那个端点。

4) 拾取第一条开曲线：

拾取下一次连接的第一条开曲线，或单击右键结束命令。可连续进行多次连接。

7.2.7.3 连接 >> 加入直线连接、连接 >> 加入圆弧连接、连接 >> 加入曲线连接

在两条曲线的连接端点之间加入一直线、圆弧或样条曲线来将这两条曲线连接起来。

(a)加入直线连接 (b)加入圆弧连接 (c) 加入曲线连接

图7-33 连接方式

加入直线连接 | 在两条曲线的连接端点处加入一直线段将二者连接起来。
加入圆弧连接 | 在两条曲线的连接端点处加入一圆弧段将二者连接起来。
加入曲线连接 | 在两条曲线的连接端点处加入一曲线段将二者连接起来。

实现方法：

（1）启动加入直线连接或加入圆弧连接或加入曲线连接命令；

（2）拾取两条要连接的开曲线。

* 操作步骤：

1) 启动加入直线连接或加入圆弧连接或加入曲线连接命令：

点击“编辑(E)”->“连接(J)”菜单项；选择导航工具栏中的 [image] 或 [image] 或 [image] 选项；

2) 拾取第一条开曲线：

拾取第一条开曲线，该曲线的连接端点为离拾取位置最近的那个端点。

3) 拾取第二条开曲线：

拾取第二条开曲线，该曲线的连接端点为离拾取位置最近的那个端点。

4) 拾取第一条开曲线：

拾取下一次连接的第一条开曲线，或单击右键结束。可连续进行多次连接。


曲线闭合

7.2.8 曲线闭合

通过一定的方式将开曲线闭合。可以在首末点加入直线或圆弧，也可以改变开曲线的首末点来进行闭合。

图7-34 曲线闭合

实现方法：

（1）选择开曲线；

（2）启动曲线闭合命令；

（3）在对话框中定义闭合模式。

* 操作步骤：

1) 选择开曲线：

拾取一个或多个需要闭合的曲线。

2) 启动曲线闭合命令：

点击“编辑(E)”->“闭合(L)”菜单项或编辑工具条中的 [image] 按钮。

3) 在对话框中定义闭合模式：

在弹出的曲线闭合模式对话框（图7-35）中选择一种闭合模式，点击“确定”按钮。

图7-35 闭合模式对话框

参数选项：

闭合模式：

1. 加入直线闭合：在曲线的首末点之间加入一直线段进行闭合；

2. 加入圆弧闭合：在曲线的首末点之间加入一圆弧段进行闭合；

3. 改变首点闭合：曲线的末点不动，将首点移至末点来进行闭合；

4. 改变末点闭合：曲线的首点不动，将末点移至首点来进行闭合。


单线等距

7.2.9 单线等距

将给定曲线在其某一侧方向上偏移一定距离，即绘制某一条曲线的等距线。

图7-36 单线等距（偏移次数=2）

实现方法：

（1）启动单线等距命令； （2）定义对话框中等距参数和选项；

（3）拾取曲线； （4）选择曲线偏移方向。

* 操作步骤：

1) 启动单线等距命令：

点击“编辑(E)”->“单线等距(S)”菜单项或编辑工具条中的 [image] 按钮。

2) 定义对话框中等距参数和选项：

在弹出的曲线偏移对话框中(图7-37)定义偏移距离、次数和尖角处理等参数和选项，点击“确定”按钮。

3) 拾取曲线： | 拾取要等距的曲线。
4) 选择方向： | 定义曲线偏移方向，在曲线的一侧拾取一点即可。

5) 拾取曲线：

拾取下一条要等距的曲线，或单击鼠标右键结束。可以选择多条曲线进行偏移操作。

图7-37 单线等距参数对话框

参数选项：

删除原始曲线 | 曲线偏移后是否将原始曲线删除掉。
偏移距离 | 等距曲线与原始曲线之间的距离。
偏移次数 | 将原始曲线在其某一侧方向上进行连续偏移的次数。
尖角处理 | 主要有尖角、圆角和截断三种处理方式(图7-38)。图7-39为三种不同的处理方式图例。

图7-38 尖角等距处理方式

尖角过渡 圆角过渡 截断过渡

图7-39 三种尖角处理方式图例


单线膨胀

7.2.10 单线膨胀

将曲线同时向两侧偏移一个给定的距离，然后由这两条等距线来形成一个封闭的区域。它可以快速地将一条单线变成一个区域。

实现方法：

（1）选择曲线；

（2）启动单线膨胀命令；

（3）在对话框种定义膨胀参数和选项。

* 操作步骤：

1) 选择曲线：

拾取一条或多条要进行膨胀的曲线。

2) 启动单线膨胀命令：

点击“编辑(E)”->“单线膨胀(G)”菜单项或编辑工具条中的 [image] 按钮。

3) 在对话框种定义膨胀参数和选项：

在弹出的膨胀参数对话框（图7-41）中定义有关膨胀参数，点击“确定”按钮。

图7-41 膨胀参数对话框

参数选项：

删除原始图形 | 在曲线膨胀后，是否将原始曲线删除掉。
膨胀距离 | 将原始曲线分别向两侧做偏移的距离。
膨胀次数 | 将原始曲线分别向两侧连续做偏移的次数。
端头处理 | 指用什幺样的方法将曲线的两侧等距线在端点处连接起来形成一个封闭的轮廓曲线。有直线、圆弧和延伸三种。图7-42所示。
尖角处理 | 有尖角、圆角和截断三种处理方式，参照<7.2.9单线等距>。

图7-42 三种端头处理方法


计算中心线

7.2.11 计算中心线

计算生成封闭的图形或者轮廓文字的中心线。

图7-43 计算中心线

实现方法：

（1）选择图形； （2）启动计算中心线命令。

* 操作步骤：

1) 选择图形：

选择要计算中心线的图形。

2) 启动计算中心线命令：

点击“编辑(E)”->“计算中心线(N)”菜单项。

说明：本命令只适用于封闭的图形或者轮廓字对象。


区域操作

7.3 区域操作

7.3.1 区域的概念

区域是雕刻加工的最基本的图形形态，雕刻设计就是在绘制和编辑各式形状的区域图形。区域是指由闭合的平面图形围成一个有效范围，这里的闭合图形可以是单线闭合图形，如图7-44（a）所示，也可以是多个闭合图形组成的有效范围，如图7-44（b，e）所示。很明显，单个封闭图形可以形成区域，多个封闭图形也可组成区域。在JDPaint中，多个封闭图形通过图形集合命令形成一个图形集合对象，代表一个图形区域，其区域的有效范围通过图形的相互包含关系来确定。有关图形集合命令参见下一章图形变换。

在JDPaint系统中，我们强调闭合图形的有效范围是相对于闭合图形组成的无效范围而言的。区域图形中可能出现无效范围的情况有：(1) 图形中的曲线有相交或者自交现象，如图7-44 (d, e )所示；（2）图形中含有开曲线，如图7-44（f）所示，此时图形区域定义具有二义性，这种具有二义性的图形区域我们称之为非法区域或者无效区域。雕刻设计过程中，除非特别应用需要，应该尽量避免出现非法区域。

图7-44 区域定义

除了应用曲线绘制与编辑命令绘制出封闭的图形，形成有效区域外，JDPaint系统还提供了以下区域编辑功能：

1、 对单个区域或者多个区域的形状进行修改和编辑，形成新的区域。这些功能包括：区域等距、区域焊接、区域裁剪和区域求交；

2、 通过“多边构造区域”的方法，快速生成一批相对有规则的区域，提高绘图速度。这种方法在设计花纹时或描图抄图时经常应用；

3、 使用区域边界对图形进行批量修剪，提高图形编修的效率和准确率。

通过修改系统显示模式，用户可以用填充显示观察到图形区域的填充效果，如图7-44（c）所示。


多边构造区域

7.3.2 多边构造区域

给定一条或多条曲线及区域内任意一点，生成由这些曲线作为边界所围成的一个包含该点的封闭区域轮廓。这种方法提供了多条曲线生成区域轮廓图形的方法。

图7-45 多边构造区域

实现方法：

（1）启动多边构造区域命令；（2）拾取边界曲线；（3）拾取轮廓区域内任意参考点。

* 操作步骤：

1) 启动多边构造区域命令：

点击“编辑(E)”->“多边构造区域(M)”菜单项。

2) 拾取第(1)个边界曲线：

拾取第一条边界曲线。

3) 拾取第(2)个边界曲线，单击鼠标右键开始输入参考点：

拾取第二条边界曲线，或单击右键结束边界曲线的定义。可连续拾取多条边界曲线，单击右键后边界曲线定义结束。

4) 拾取第(1)个被边界曲线包围的参考点：

定义要生成的轮廓区域内的任意一点。

5) 拾取第(2)个被边界曲线包围的参考点，单击鼠标右键开始计算轮廓：

可继续定义多个轮廓区域内的参考点,或单击右键结束。

参数选项：

导航工具栏中的操作选项如图7-46为：

图7-46 多边构造区域操作选项

【保留边界曲线】 | 选中此选项，则由这些边界曲线通过互相裁剪生成封闭的区域轮廓后，仍然保留这些原始边界曲线。
【偏移结果图形】 | 选中此选项，可以将生成的区域轮廓平移至另一位置处，可以避免结果图形与原始图形相混淆，影响操作； 平移距离设置方法：点击 [image] 按钮，在弹出的对话框(图7-47)中定义平移距离。

图7-47 设置平移距离


区域修剪曲线

7.3.3 区域修剪曲线

用区域轮廓边界来修剪掉曲线在区域边界内或在区域边界外的部分。

图7-48 区域修剪曲线

实现方法：

（1）选择被修剪曲线； （2）启动区域修剪曲线命令； （3）拾取修剪区域轮廓。

* 操作步骤：

1) 选择被修剪曲线：

拾取要被修剪的一条或多条曲线。

2) 启动区域修剪曲线命令：

点击“编辑(E)”->“区域修剪曲线(A)”菜单项。

3) 拾取裁剪区域边界：

拾取修剪区域轮廓边界。

参数选项：

导航工具栏中的选项为：

【保留环内曲线】

选中此选项，则在曲线被区域轮廓修剪后，保留曲线在区域边界内的部分；否则保留区域边界以外的部分。如图7-48所示。


区域运算

7.3.5 区域焊接

将两个或多个区域轮廓进行合并，形成新的轮廓区域，即区域并集运算。

图7-51 区域焊接

实现方法：

（1）选择两个或两个以上区域轮廓图形；

（2）启动区域焊接命令；

（3）在对话框中定义区域运算参数选项。

* 操作步骤：

1）选择区域轮廓图形：拾取两个或两个以上的区域轮廓图形。

2）启动区域焊接命令：点击“编辑(E)”->

“区域焊接(W)”菜单项或编辑工具条中的 [image] 按钮。

3）定义区域运算选项：在弹出的区域焊接对话框(图7-52)中定义有关的区域运算参数和选项，点击“确定”按钮。

参数选项：

删除原始图形 | 选中此选项，焊接前的原始区域轮廓图形将在区域焊接后被删除掉。
曲线处理方法 | 包括转为直线和保留曲线两个选项： 1) 转为直线：将焊接前的区域轮廓图形中的样条曲线段和Bezier曲线段在焊接后用直线段进行拟合； 2) 保留曲线：焊接前的区域轮廓图形中的样条曲线段 和Bezier曲线段在焊接后类型不变。

7.3.6 区域剪裁

从一个区域中移去另一个区域以形成新的轮廓区域，即区域相减运算。

图7-53 区域剪裁

实现方法：

（1）选择被裁剪区域轮廓图形；

（2）启动区域剪裁命令；

（3）拾取裁剪区域轮廓。

* 操作步骤：

1）选择被裁剪区域轮廓图形：拾取一个或多个要被剪掉部分区域的轮廓图形。

2）启动区域剪裁命令：点击“编辑(E)”->“区域剪

裁(H)”菜单项或选择编辑工具条中的 [image] 按钮。

3）拾取裁剪图形：拾取裁剪区域轮廓图形。

参数选项：

导航工具栏中的操作选项如图7-54：

【保留原始图形】 | 选中此选项，区域裁剪后将保留被裁减的区域轮廓图形。
【保留裁剪图形】 | 选中此选项，区域裁剪后将保留裁剪区域轮廓图形。
【曲线转为直线】 | 选中此选项，区域裁剪后将被裁减区域图形中的样条曲线段和Bezier曲线段用直线段来进行拟合。

7.3.7 区域求交

由两个或多个轮廓区域中重叠部分的公共区域来形成一个新的轮廓区域，即区域交集运算。

图7-55 区域求交

实现方法：

（1）选择多个区域轮廓图形；

（2）启动区域求交命令；

（3）定义区域运算参数和选项。

* 操作步骤：

1) 选择多个区域轮廓图形： | 拾取两个或多个区域轮廓图形
2) 启动区域求交命令： | 点击“编辑(E)”->“区域求交(I)”菜单项或编辑工具条中的 [image] 按钮。

3) 定义区域运算参数和选项：

在弹出的区域求交运算对话框中，定义有关的选项和参数(图7-56)，点击“确定”按钮。


区域求交

7.3.7 区域求交

由两个或多个轮廓区域中重叠部分的公共区域来形成一个新的轮廓区域，即区域交集运算。

图7-55 区域求交

实现方法：

（1）选择多个区域轮廓图形；

（2）启动区域求交命令；

（3）定义区域运算参数和选项。

* 操作步骤：

1) 选择多个区域轮廓图形： | 拾取两个或多个区域轮廓图形
2) 启动区域求交命令： | 点击“编辑(E)”->“区域求交(I)”菜单项或编辑工具条中的 [image] 按钮。

3) 定义区域运算参数和选项：

在弹出的区域求交运算对话框中，定义有关的选项和参数(图7-56)，点击“确定”按钮。


区域剪裁

7.3.6 区域剪裁

从一个区域中移去另一个区域以形成新的轮廓区域，即区域相减运算。

图7-53 区域剪裁

实现方法：

（1）选择被裁剪区域轮廓图形；

（2）启动区域剪裁命令；

（3）拾取裁剪区域轮廓。

* 操作步骤：

1）选择被裁剪区域轮廓图形：拾取一个或多个要被剪掉部分区域的轮廓图形。

2）启动区域剪裁命令：点击“编辑(E)”->“区域剪

裁(H)”菜单项或选择编辑工具条中的 [image] 按钮。

3）拾取裁剪图形：拾取裁剪区域轮廓图形。

参数选项：

导航工具栏中的操作选项如图7-54：

【保留原始图形】 | 选中此选项，区域裁剪后将保留被裁减的区域轮廓图形。
【保留裁剪图形】 | 选中此选项，区域裁剪后将保留裁剪区域轮廓图形。
【曲线转为直线】 | 选中此选项，区域裁剪后将被裁减区域图形中的样条曲线段和Bezier曲线段用直线段来进行拟合。


区域等距

7.3.4 区域等距

对组成区域的轮廓图形向内或向外以给定的距离进行偏移以形成新的轮廓区域图形。

图7-49 区域等距

实现方法：

（1）选择区域轮廓图形；

（2）启动区域等距命令；

（3）在对话框中输入等距参数。

* 操作步骤：

1）选择区域轮廓图形：拾取要进行等距的区域轮廓图形。

2）启动区域等距命令：点击“编辑(E)”->“曲域等距(O)”菜单项或编辑工具条中的 [image] 按钮。

3）在对话框中定义等距参数和选项：在弹出的区域等距对话框（图7-50）中输入有关等距参数和选项，点击“确定”按钮。

参数选项：

删除原始图形 | 选中此选项，在区域等距后将原始图形区域轮廓删除掉。
偏移距离 | 原始图形区域轮廓与等距后图形区域轮廓之间的距离。
偏移次数 | 区域轮廓进行偏移的次数，可一次完成多次偏移。
偏移方向 | 选择将原始区域轮廓图形向其内部还是外部进行偏移形成新的区域轮廓。
尖角处理 | 包括尖角、圆角和截断三种处理方法。参照< 7.2.10单线膨胀 >中的尖角处理。


图形变换

第八章 图形变换

本章主要介绍图形的变换和转换操作，包括以下几类：

1、图形基本变换操作：包括平移、旋转、放缩和阵列等操作。

2、图形之间的尺寸和位置变换操作：包括尺寸等同、均分间隔等操作。

3、优化排样操作。

4、群组与集合：包括群组与取消群组、集合与取消集合等操作。

5、对象转换：包括对象类型的转换，对象图层的转换等操作。

6、曲线方向调整。

在对图形进行变换操作时，必须先选中操作对象，然后再点击图形变换菜单（图8-1）或变换工具条按钮（图8-2）来执行相应的命令操作。

图8-1 变换菜单命令

图8-2 变换工具条


平移变换

8.1 图形基本变换

图形的基本变换在本节是指图形精确变换，即图形的平移、旋转、镜像、倾斜、放缩等操作。图形的快速变换在前面章节已有叙述。

8.1.1 平移变换

将图形从一个位置移动或复制至另一位置。平移变换导航工具栏中的选项如图8-3所示。

图8-3 平移变换导航工具栏选项

距离平移 | 通过直接定义图形在X和Y方向上的平移距离来进行平移变换。
【复制图形】 | 选择该选项，可将图形在目标位置上进行复制；否则进行移动。

图形有两种平移方法：两点平移法和距离平移法。其中两点平移法是系统默认的方法。

8.1.1.1 平移变换 >> 两点平移

定义平移的基点和移动点，通过这两个点定义平移的距离和方向来进行平移变换。

如图8-4所示。

实现方法：

（1）选择要平移的图形；

（2）启动平移变换命令；

（3）输入平移基点和移动点。

* 操作步骤：

1）选择要平移的图形：

在屏幕上拾取要平移的图形，可拾取多个图形对象。

2）启动平移变换命令：

点击“变换(R)”->“平移(L)”菜单项或变换工具条中的 [image] 按钮。

3）请输入基点：

输入平移基点，参照<点的输入>。

4）请输入移动点：

输入移动点，参照<点的输入>。

5）请输入基点：

定义下一次平移的基点，或单击鼠标右键结束。可对图形进行多次平移变换。

8.1.1.2 平移变换 >> 距离平移

通过定义图形在X和Y方向上的偏移距离确定出图形的新位置。

如图8-5所示。

实现方法：

（1）选择要平移的图形；

（2）启动距离平移命令；

（3）定义图形在横向和纵向的偏移量。

* 操作步骤：

1）选择要平移的图形：

在屏幕上拾取要平移的图形，可拾取多个图形对象。

2）启动距离平移命令：

点击“变换(R)”->“平移(L)”菜单项或变换工具条中的 [image] 按钮；然后点击导航工具栏中的 [image] 按钮。

3）定义图形在横向

和纵向的偏移量：

在弹出的对话框（图8-6）中定义图形在横向和纵向的偏移距离，点击“拾取>>”按钮可以启动“长度-距离发生器”来定义偏移距离，参照<5.4长度-距离发生器>。点击“确定”结束。

图8-6 图形偏移量定义对话框


旋转变换

8.1.2 旋转变换

将图形绕一指定点（旋转基点）旋转一定的角度。如图8-7所示。

图8-7 旋转变换

实现方法：

（1）选择旋转对象； （2）启动旋转变换命令；

（3）输入旋转基点和参考点； （4）输入旋转角度。

* 操作步骤：

1）选择旋转对象：

在屏幕上拾取要旋转的图形，可拾取多个图形对象。

2）启动旋转变换命令：

点击“变换(R)”->“旋转(R)”菜单项或变换工具条中的 [image] 按钮。

3）请输入基点：

输入旋转基点。参照<点的输入>。

4）请输入参考点：

输入旋转参考点。参照<点的输入>。

5）请输入旋转角度：

输入旋转角度。可直接输入旋转角度，或移动鼠标确定一点来确定。

6）请输入基点：

输入下一次旋转的基点，或单击鼠标右键结束。可进行多次旋转变换。

参数选项：

旋转变换时导航工具栏中的选项如图8-8所示。

图8-8 旋转变换导航工具栏选项

【复制图形】

是否进行旋转拷贝。选中该选项，可将选择的图形在新的角度位置处进行复制；不选择该选项，则对选择的图形进行旋转移动。

说明：旋转基点和参考点定义了旋转变换的0角度方向；旋转角度是绕基点从此0角度方向上逆时针转过的角度（如图8-9）；

图8-9 旋转角度


镜像变换

8.1.3 镜像变换

对选择的图形以某一条直线为对称轴，进行对称映像或对称拷贝。

镜像变换的导航工具栏选项如图8-10所示。

图8-10 镜像变换导航工具栏选项

水平镜像 | 对图形在水平方向上进行镜像。
竖直镜像 | 对图形在竖直方向上进行镜像。
【复制图形】 | 选择此选项为镜像拷贝，不选择此选项则为镜像移动。

根据对称轴的不同，镜像变换可分为以下三种方式：

1、任意角度镜像：所定义的对称轴为任意角度方向的直线；

2、水平镜像：对称轴为过图形的中心且与X轴平行的直线；

3、竖直镜像：对称轴为过图形的中心且与Y轴平行的直线。

8.1.3.1 镜像变换 >> 任意角度镜像

定义任意一角度的直线为对称轴来对选择的图形进行镜像。如图8-11所示。

实现方法：

（1）选择图形对象；

（2）启动镜像命令；

（3）输入基点；

4、输入镜像角度。

* 操作步骤：

1) 选择图形对象：

在屏幕上拾取要进行镜像变换的图形，可拾取多个图形对象。

2) 启动镜像命令：

点击“变换(R)”->“镜像(M)”菜单项或变换工具条中的 [image] 按钮。

3) 请输入基点：

定义镜像轴的基点，参照<点的输入>。

4) 请输入镜像角度：

定义镜像轴的角度，可直接输入角度值，也可移动鼠标确定一点，通过基点与这个点之间的方向矢量来定义角度。角度值为绕基点从X轴正向逆时针转过的角度。

5) 请输入基点：

定义下一次镜像的基点，或单击右键结束。可对选中的图形进行多次镜像操作。

8.1.3.2 镜像变换 >> 水平镜像、镜像变换 >> 竖直镜像

以过图形中心且与X/Y轴平行的直线作为对称轴来对选择的图形进行镜像。

(a) 水平镜像 (b) 竖直镜像

图8-12 水平镜像和竖直镜像

实现方法：

（1）选择镜像对象；

（2）启动水平镜像或竖直镜像命令。

* 操作步骤：

1）选择镜像对象：

在屏幕上拾取要镜像的图形，可拾取多个图形对象。

2）启动水平镜像或

竖直镜像命令：

点击“变换(R)”->“镜像(M)”菜单项或变换工具条中 [image] 按钮；

点击导航工具栏中的 [image] 或 [image] 按钮。


倾斜变换

8.1.4 倾斜变换

对选择的图形进行倾斜移动或拷贝。

图8-13 倾斜变换

实现方法：

（1）选择倾斜对象；

（2）启动倾斜变换命令；

（3）输入倾斜基点和参考点；

（4）输入倾斜角度。

* 操作步骤：

1）选择倾斜对象：

在屏幕上拾取要进行倾斜变换的图形，可拾取多个图形对象。

2）启动倾斜变换命令：

点击“变换(R)”->“倾斜(H)”菜单项或变换工具条中 [image] 按钮。

3）请输入基点：

输入倾斜变换的基点，参照<点的输入>。

4）请输入参考点：

输入倾斜变换的参考点，参照<点的输入>。

5）请输入倾斜角度：

输入倾斜角度，可以直接输入角度值，也可以拾取一点来确定。

6）请输入基点：

输入下一次倾斜变换的基点，或单击鼠标右键结束。可连续进行多次变换。

参数选项：

倾斜变换导航工具栏中的选项如图8-14：

图8-14 倾斜变换导航工具栏选项

【复制图形】

选中该选项，则对图形进行倾斜拷贝；

不选中该选项，则对选择的图形进行倾斜移动。

说明：

1、基点和参考点的定义参照<点的输入>，二者定义了倾斜变换的0角度方向；倾斜角度是绕基点从此0角度方向上逆时针转过的角度(图8-15)；

图8-15 倾斜角度

2、倾斜的基点位置不发生移动。若基点和参考点确定的矢量方向为竖直方向时，则图形沿水平方向进行左右倾斜（图8-13 a）；若基点和参考点确定的矢量方向为水平方向时，则图形沿竖直方向进行上下倾斜（图8-13 b）。


放缩变换

8.1.5 放缩变换

将选择的图形按照一定的比例进行放大或缩小变换。

如图8-16所示。

实现方法：

（1）选择要变换的图形对象；

（2）启动放缩变换命令；

（3）在对话框中定义放缩参数和选项。

* 操作步骤：

1）选择图形对象：

在屏幕上拾取要放缩的图形，可拾取多个图形对象。

2）启动放缩变换命令：

点击“变换(R)”->“放缩(S)”菜单项或变换工具条中 [image] 按钮。

3）在对话框中定义

放缩参数和选项：

在弹出的放缩变换对话框(图8-17)中定义放缩比例因子、放缩中心点和其它变换选项，点击“确定”按钮结束。

图8-17 放缩变换对话框

参数选项：

放缩变换对话框中的参数和选项定义如下：

横向尺寸 | 输入图形变换后的横向尺寸(X轴方向尺寸)。
纵向尺寸 | 输入图形变换后的纵向尺寸(Y轴方向尺寸)。
横向比例 | 输入放缩变换后的横向百分比（X轴方向尺寸变换倍数）。
纵向比例 | 输入放缩变换后的纵向百分比（Y轴方向尺寸变换倍数）。
保持比例 | 选中此选项，则在变换时保持原图形的横纵比例，即横向和纵向按等比例进行放缩。若要进行等比例放缩，要先选中该选项，再调整横向或纵向的尺寸或比例。
复制图形 | 放缩变换同样也有拷贝和移动两种方式。选中此选项为拷贝方式，变换后保留原图形；不选该选项为移动方式，变换后删除原图形。
放缩中心 | 放缩变换前后，图形在放缩中心位置不变。 放缩中心常常为图形的左下角点或中心点，也可以选择[自定义]选项，然后点击“拾取〉〉”按钮，通过“点发生器”确定一点来作为放缩中心，参照<5.3 点坐标发生器>。 放缩中心不同，变换后的图形位置不同。如图8-18。

图8-18 不同的放缩中心点

说明：可以对图形在横向和纵向进行等比例或不等比例的缩放变换。在对话框中确定放缩比例因子有两种方式：

（1）输入变换后图形在横向和纵向的尺寸大小，系统自动计算出比例因子；

（2）以百分比的形式，输入图形在横向和纵向的尺寸变化比例。

对话框中的这两种方式是相互关联的，当输入“横向尺寸”或“纵向尺寸”时，“横向比例”或“纵向比例”也随着变动。反之当输入比例数值时，尺寸数值也随着变动。


图形阵列

8.2 图形阵列

将给定的图形按照一定的方式进行阵列拷贝。在阵列菜单项下有四个子菜单项（图8-19），分别定义了四种不同的阵列方式。

图8-19 阵列子菜单

矩形阵列 | 将选择的图形按照矩形的方式分别在水平方向和竖直方向上进行拷贝(图8-20a)。
圆形阵列 | 将选择的图形在圆周方向上进行拷贝(图8-20b)。
曲线阵列 | 将选择的图形沿着某一条曲线方向进行拷贝(图8-20c)。
图形放到曲线上 | 将图形按照某一对齐方式排列到一给定的曲线上（图8-20d）。

(a) 矩形阵列 (b) 圆形阵列 (c) 曲线阵列

(d) 图形放到曲线上

图8-20 四种不同的阵列方式

8.2.1 矩形阵列

将选择的图形按照矩形的方式分别在水平方向和竖直方向上进行拷贝。

图8-21 矩形阵列

实现方法：

（1）选择阵列对象；

（2）启动矩形阵列命令；

（3）在对话框中定义阵列的参数和选项。

* 操作步骤：

1）选择阵列对象：

在屏幕上拾取要进行阵列的图形，可拾取多个图形对象。

2）启动矩形阵列命令：

点击“变换(R)”->“阵列(A)”->“矩形阵列(R)”菜单项或变换工具条中的 [image] 按钮。

3）在对话框中定义

阵列参数和选项：

在弹出的对话框(图8-22)中输入水平方向和竖直方向上的图形复制个数和间距以及其它阵列选项，点击“确定”按钮结束。

图8-22 矩形阵列对话框

参数选项：

横向间距 | 水平方向上图形阵列的间距，即为阵列图形的列间距。
纵向间距 | 竖直方向上图形阵列的间距，即为阵列图形的行间距。
复制数目 | 横向或纵向图形阵列个数，即为阵列图形的列数和行数。
反方向 | 默认的横向和纵向阵列方向分别平行于X和Y轴的正方向， 选中对话框中的该选项，可进行负方向上的阵列。
间距计算方法 | 有按偏移距离和按图形间距计算两种方法。图8-21中的间距为按图形间距计算，图8-23 为按偏移距离计算。

图8-23 按偏移距离计算的间距

8.2.2 圆形阵列

将图形沿圆周按照逆时针或顺时针方向以一定的角度间距来进行阵列。

图8-24 圆形阵列

实现方法：

（1）选择阵列对象； （2）启动圆形阵列命令；

（3）在对话框中定义阵列参数和选项； （4）输入阵列中心点。

* 操作步骤：

1）选择阵列对象：

在屏幕上拾取要进行阵列的图形，可拾取多个图形对象。

2）启动圆形阵列命令：

点击“变换(R)”->“阵列(A)”->“圆形阵列(A)”菜单项或变换工具条中的 [image] 按钮。

3）在对话框中定义阵列

参数和选项：

在弹出的对话框（图8-25）中定义圆形阵列的有关参数和选项，包括阵列起始角度、角度间距、图形复制数目等，点击“确定”按钮。

4）请输入圆形阵列中心点：

输入圆形阵列中心点，参照<点的输入>。

图8-25 圆形阵列对话框

参数选项：

删除原始图形 | 阵列后是否将原始图形删除掉。选中此选项，则将原始图形删除掉。
顺时针阵列 | 选中该选项，起始角度和角度间距是按照顺时针方向计算的。不选该选项，则是按照逆时针方向来进行计算的。
旋转图形 | 选中该选项，图形沿着圆周阵列的同时绕阵列中心进行旋转； 不选该选项，则图形仍沿圆周按照水平方向排列，此时须指定原始图形的基准点(图8-26)。图8-27 为不旋转图形图例。
起始角度 | 指原始图形的基准点和阵列中心点的连线与阵列的第一个图形基准点和阵列中心点的连线的夹角。它确定了圆形阵列第一个图形的位置。
角度间距 | 阵列图形之间的角度偏移量。
复制数目 | 圆形阵列图形个数。

图8-26 不旋转图形时的对话框 图8-27 圆形阵列（不旋转图形）

8.2.3 曲线阵列

将图形沿着该某一路径曲线方向进行阵列拷贝。

图8-28 曲线阵列

实现方法：

（1）选择阵列对象； （2）启动曲线阵列命令；

（3）在对话框中定义阵列参数和选项； （4）拾取路径曲线；

（5）拾取基准点； （6）选择方向。

* 操作步骤：

1）选择阵列对象：

在屏幕上拾取要进行阵列的图形，可拾取多个图形对象。

2）启动曲线阵列命令：

点击“变换(R)”->“阵列(A)”->“曲线阵列(C)”菜单项或变换工具条中的 [image] 按钮。

3）在对话框中定义阵列 参数和选项： | 在弹出的对话框（图8-29）中定义图形沿曲线阵列的间距和要复制的个数以及其它一些参数和选项，点击“确定”按钮。
4）拾取阵列图形路径： | 拾取做为阵列路径的曲线。

5）在图形路径上拾取

阵列基准点：

在路径曲线上拾取阵列基准点，即阵列路径的起始点。

6）选择方向：

屏幕上在基准点处显示两个方向箭头供选择，这将决定要从起始点开始沿着哪一段路径曲线方向进行阵列。选择某一方向箭头即可选择阵列方向。

图8-29 曲线阵列对话框

参数选项：

图形间距 | 阵列拷贝图形中相邻两个图形中心之间的距离。
复制数目 | 阵列拷贝后的图形个数。
旋转图形 | 选择此项，阵列时图形进行旋转，沿着曲线的径向排列，否则按照水平方向排列。
间距计算方法 | 包括按曲线长度计算和按点间距离计算两种： 1) 按曲线长度：按照阵列后相邻两个图形副本的基点在路径曲线上所对应的那一段曲线长度来进行计算的。图8-30中曲线段AB=BC=CD=DE=EF=图形间距； 2) 按点间距离：按照图形元素的基准点之间的直线距离的长度进行计算的。图8-31 中直线段AB=BC=CD=DE=EF=图形间距；

图8-30 按曲线长度计算间距

图8-31 按点间距离计算间距

8.2.4 图形放到曲线上

将图形按照某一对齐方式排列到一给定的曲线上。

图8-32 图形放置到曲线上

实现方法：

（1）选择要排列到曲线上的对象；

（2）启动图形放到曲线上命令；

（3）拾取基准曲线；

（4）在对话框中定义放置参数和选项。

* 操作步骤：

1）选择要排列到曲线上的图形：

拾取要排列到曲线上的图形，可拾取多个对象。

2）启动图形放到曲线上命令：：

点击“变换(R)”->“阵列(A)”->“图形放到曲线上(T)”菜单项或变换工具条中的 [image] 按钮。

3）拾取基准曲线：

拾取图形要放置到的基准曲线。

4）在对话框中定义

放置参数和选项：

在弹出的对话框（图8-33）中定义水平和竖直方向上的对齐方式、图块编辑方式，图块排列的比例及其它一些排列选项等，可以边调整边在屏幕上预览结果。点击“确定”按钮结束。

图8-33 图形放到曲线对话框

参数选项：

竖直对齐 | 图形与基准曲线在竖直方向上的对齐方式：顶端对齐、中线对齐、底端对齐。如图8-34。 1) 顶端对齐：图形的顶部与曲线对齐并相切； 2) 中线对齐：图形的中心与曲线对齐； 3) 底端对齐：图形的底部与曲线对齐并相切。
水平对齐 | 图形与基准曲线在水平方向上的对其方式：左对齐、居中、右对齐和两端对齐。如图8-35。 1) 左对齐：图形在曲线上排列时与曲线左端对齐； 2) 居中：图形在曲线上排列时与曲线中部对齐； 3) 右对齐：图形在曲线上排列时与曲线右端对齐； 4) 两端对齐：图形在曲线上均匀分布。
图块编辑、 比例 | 调整图形在基准曲线上的位置和图形宽度、高度及多个图形排列的间距。有以下几种： 1) 沿曲线滑动：图形位置可沿着曲线方向进行动态滑动； 2) 沿法线滑动：图形位置可沿着曲线的法线方向进行动态滑动； 3) 修改间隙：多个图形在曲线上排列时，修改它们之间的排列间距； 4) 修改宽度：图形排列到曲线上时，修改图形的宽度； 5) 修改高度：图形排列到曲线上时，修改图形的高度。 图8-36为以底端对齐和左对齐为例来进行图块编辑各方式的调整。 拖动比例滑杆来进行动态调整。
曲线反向 | 选取此项可以改变曲线的正反方向。图8-37 以底端对齐和左对齐为例将曲线反向结果。
图形反向 | 选取此项可以改变图形排列的方向。图8-38 以底端对齐和左对齐为例将图形反向结果。
删除原图 | 选取此项可删除原始图形

图8-34 竖直对齐方式

图8-35 水平对齐方式

图8-36 图块编辑方式

图8-37 曲线反向

图8-38 图形反向


并入3D环境

8.6.5 并入3D环境

将图形对象转换为SurfMill软件提供的3D几何曲面造型环境中的三维图形对象。

实现方法：

（1）选择图形对象；

（2）点击菜单项；

（3）在对话框中定义是否删除当前图形选项。

* 操作步骤：

1）选择图形对象：

拾取要转换的图形对象。

2）点击菜单项：

点击“变换(R)”->“并入3D环境(M)”菜单项。

3）在对话框中定义

是否删除原始图形：

在对话框（图8-75）中确定是否删除当前图形。

说明：该命令亦可以将文字对象转换为几何曲面造型环境中的曲线。转换后的结果需要切换到SurfMill的几何曲面造型环境中才能观察到。


尺寸等同

8.3 图形之间的尺寸和位置变换

图形之间的尺寸和位置变换主要包括尺寸等同、均分间隔等命令操作。

8.3.1 尺寸等同

将被选图形根据参考图形的尺寸做尺寸变换，使二者在水平方向或在竖直方向或同时在这两个方向上的尺寸相同。如图8-39所示。

图8-39 尺寸等同

实现方法：

（1）选择尺寸等同对象； （2）启动尺寸等同命令；

（3）拾取参考图形； （4）在对话框中定义等同参数和选项。

* 操作步骤：

1）选择尺寸等同对象：

在屏幕上拾取要进行尺寸等同的图形，可拾取多个图形对象。

2）启动尺寸等同命令： | 点击“变换(R)”->尺寸等同(Z)”菜单项或变换工具条中的 [image] 按钮。
3）拾取参考图形： | 拾取等同参考图形。

4）在对话框中定义

等同参数和选项：

在弹出的尺寸等同对话框（图8-40）中，定义等同的方向和等同方式，点击“确定”按钮。

图8-40 尺寸等同对话框

参数选项：

等同方向 | 包含三个选项： 1) 水平尺寸等同：被选图形与参考图形在X方向尺寸等同； 2) 竖直尺寸等同：被选图形与参考图形在Y方向尺寸等同； 3) 双向尺寸等同：被选图形与参考图形在X、Y方向尺寸都等同。
等同方式 | 包含两个选项： 1) 整体等同：当进行尺寸等同的图形由多个元素组成时，这多个元素将作为一个整体，与参考图形进行尺寸等同的变换。如果要求尺寸等同后仍保持图形之间的相对关系，此时就必须选取该项； 2) 分散等同：当进行尺寸等同的图形由多个元素组成时，各个元素将按照自己的特征尺寸分别和参考图形进行尺寸等同，不保留原来图形之间的相对位置关系。 图8-41 为两种不同的等同方式的结果。

图8-41 整体等同和分散等同


均分间隔

8.3.2 均分间隔

将三个或三个以上的被选图形在它们的包围矩形框内按照某种距离间隔方式，调整它们之间位置关系，使它们在水平和竖直方向上均匀分布。如图8-42所示。

图8-42 均分间隔

实现方法：

（1）选择三个或三个以上的图形对象；

（2）启动均分间隔命令；

（3）在对话框中定义均分参数和选项。

* 操作步骤：

1）选择三个或三个

以上的图形对象：

拾取要进行间隔均分的三个或三个以上的图形对象。

2）启动均分间隔命令：

点击“变换(R)”->均分间隔(E)”菜单项或变换工具条中的 [image] 按钮。

3）在对话框中定义

均分参数和选项：

在弹出的对话框(图8-43)内定义在水平方向和竖直方向上距离间隔方式，点击“确定”按钮。

图8-43 均分间隔对话框

参数选项：

水平方向 | 水平方向上的距离间隔方式，有左边、中心、间距、右边四种间隔方式。如图8-44。 a) 左边：以图形1的左边位置到图形2的左边位置为间隔距离； b) 中心：以图形1的中心位置到图形2的中心位置为间隔距离； c) 间距：以图形1的右边位置到图形2的左边位置为间隔距离； d) 右边：以图形1的右边位置到图形2的右边位置为间隔距离。
竖直方向 | 竖直方向上的距离间隔方式，有顶部、中心、间距、底部四种间隔方式。如图8-45。 a) 顶部：以图形1的顶部位置到图形2的顶部位置为间隔距离； b) 中心：以图形1的中心位置到图形2 的中心位置为间隔距离； c) 间距：以图形1的底部位置到图形2的顶部位置为间隔距离； d) 底部：以图形1的底部位置到图形2的底部位置为间隔距离。

图8-44 水平距离间隔方式

图8-45 竖直距离间隔方式


优化排样

8.4 优化排样

在一块材料上尽可能紧凑地排放要进行下料的样件，减少空白间隙，也就是尽量提高材料的利用率，称为优化排样。

执行“优化排样”命令后将进入一个优化排样的操作环境，该环境提供了一些辅助排样的工具，支持手工排样和自动排样以及两者的结合。自动排样是其中的重要功能，该功能可以对任意形状的样件进行自动优化排样，材料也可以为任意形状。自动排样支持嵌套排样（在带内孔样件的孔内排放其它较小样件）以提高材料利用率，还可以在材料内部指定任意形状的不可用区域，以便在排样时避开这些区域。

图8-46 优化排样示意

8.4.1 操作方法

8.4.1.1 名词解释

在详细介绍优化排样功能之前需要对几个概念进行说明：

1）样件： 指需要进行下料的图形，由一个闭合外轮廓和若干岛屿组成，岛屿表示样件上的空洞。外轮廓和岛屿共同定义样件的占用区域。普通图形只有定义为样件后才能参与自动排样。

2）材料： 指可供下料的形材。样件在其上排放好后进行下料。形材可以为任意形状（矩形最常见），由一个外轮廓和若干岛屿定义。外轮廓表示材料的整体形状，岛屿表示材料内部不可进行排样的区域，比如破损区域。外轮廓和岛屿共同定义材料的可用区域。

3）搭边线： 排样时样件之间一般要间隔一些距离，以方便下料或保护样件，因此需要对样件的轮廓进行向外等距（岛屿向内等距），该等距轮廓就称为样件的搭边线。等距的距离（搭边线与原图形的间距）称为搭边间距。同样道理，材料边框也需要进行等距，其等距轮廓就称为材料的搭边线。但与样件不同是，材料边框的外轮廓是向内等距（岛屿向外等距）。

为保证搭边线计算的正确，要求样件有闭合的外轮廓而且轮廓上没有断点和重点，因为这样才能对样件轮廓进行等距。

搭边线的主要作用为在排样时用作干涉（重叠）检查，也可用于调整样件间的间距以满足一些加工工艺上的要求。例如在进行切割样件的排样时，通常要求搭边间距大于切割刀具的半径，这样在切割下料时才不会切坏样件。

样件的搭边线的外轮廓以蓝色显示，内部岛屿以绿色显示。材料边框的搭边线的内外轮廓均以绿色显示。如图8-47所示。

样件 材料

图8-47 样件和材料的定义

4）干涉： 在材料边框内排列的样件的搭边线与材料边框的搭边线相交，也就是样件越出了材料边界或样件间互相有重叠称为发生了干涉。在手工排样过程中，当用户用鼠标或方向键移动样件时系统将根据样件及材料边框的搭边线进行干涉（重叠）检查，导致样件与材料边框发生干涉的移动操作将被取消。如图8-48所示。

图4-48 干涉

8.4.1.2 操作步骤

实现方法：

（1）绘制出样件和材料的边界图形； （2）选择样件，进入排样环境；

（3）选择材料边界，设置搭边间距； （4）进行自动排样；

（5）调整排样结果； （6）退出排样环境。

* 操作步骤：

1） 处理样件图形

和材料边框图形：

必须首先绘制出样件和材料的边界图形。

将包含多个轮廓的单个样件图形进行集合，使参与排样的每个样件都成为一个单独的图形集合。如果材料边框图形包含多个轮廓，也应进行集合。对各样件图形及材料边框图形的轮廓进行检查，保证其闭合。

如果是进行文字的优化排样，必须先把文字对象转为图形。具体转换方法请参考后面的补充说明。

为避免混乱，样件图形在排样前最好放在材料边框的外面。

样件 材料

图8-49 优化排样的准备工作

2）选中待排样件：

选中所有待排样件的图形

图8-50 选中待排样件

3）选择菜单项： | 点击“变换（R）—〉优化排样（O）”菜单项，进入排样环境。 系统右边将出现一个导航条。导航条上提供了一些功能按钮。各按钮的作用请参考后面的功能按钮说明。
4） 选择排样边界： | 系统提示“拾取排样边界”，用鼠标左键点击材料边界图形。

5）设置搭边距离：

系统弹出“设置搭边距离对话框”。设置好样件和材料的搭边间距后，点击“确认”按钮。如果需要在带内孔样件的孔内排放其它较小的样件，必须选择“保留岛屿”选项。

此时系统将样件图形按样件搭边间距向外等距生成一个蓝色的外框（内部岛屿为绿色），称为样件搭边线。材料边框则按材料搭边间距向内等距产生一个绿色的边框，称为材料搭边线。

图8-51 设置搭边间距

6）进行“自动排样”：

选中样件，点击“自动排样”功能按钮。

有关“自动排样”的详细操作方法请参考对“自动排样”功能按钮的说明。

7）调整排样结果：

自动排样结束后，样件将被自动摆放到材料边框内，如图8-52所示。

对自动排样结果不满意的地方进行手工局部调整。手工调整的方法请参考补充说明第3条。

根据需要也可以修改自动排样参数重新进行自动排样。先点击右边导航条上的“排样重置”按钮，再点击“自动排样”按钮即可。

要退出排样环境，按ESC键即可。

图8-52 排样结果

8.4.1.3 补充说明

1、将文字对象转为图形的操作步骤

1）选中文字对象：

选中要转换为图形的文字对象。

2）选择菜单项：

点击菜单项“变换（R）—〉文字转为图形（X）”。

3）设置转换方式：

系统弹出“文字转换图形”对话框。如果需要保留整字进行排样，选择“单个字符转为一个集合”，如果需要拆散文字笔画进行排样，选择“单个笔画转为一个集合”。

图8-53 “文字转图形”对话框

4）点击“确认”按钮：

点击“确认”按钮，转换完成。

有关“文字转为图形”操作的详细说明请参考其自身的使用说明。

2、分批排样

可以对样件进行分批排样。进入排样环境后，先选中一部分样件，点击“自动排样”按钮，被选中这一部分样件就被排到材料边框内。系统会记录下当前已排好的样件情况，下次被选中的样件将在前面的排样基础上继续排列。若点击“自动排样”按钮时无样件被选中，则对所有剩余样件进行自动排样。如果需要全部重新开始自动排样，可以先点击“排样重置”按钮，这样先前所有的排样记录都会被清除掉。

3、手工排样

自动排样结束后根据排样结果，可以用鼠标或方向键对样件进行人为调整，从而获得更好的排样结果。人机结合的排样效果比单纯依赖计算机排样要好一些。排样环境提供了平移、旋转、连续平移和干涉检查等手工排样工具。

为方便手工排样，在排样工具环境中可以用鼠标或方向箭头键平移或旋转样件。选中样件或图形后，系统将显示两个操作手柄，一个用于移动样件，一个用于旋转样件，操作方式与普通图形的平移和旋转手柄相同。

图8-54 样件移动手柄

样件的移动操作方式与普通图形的移动操作相同（方向键平移，SHIFT+方向键旋转，还可以用时标拖动手柄），但导致样件与材料边框发生干涉的移动操作将被取消。TAB+方向键可以在一个方向上连续移动样件直到发生干涉为止，可用于加速移动过程。排样时可以先将样件逐个用鼠标移入排样边框内部，再用鼠标或箭头键调整其位置与角度，以获得较为理想的排样结果。在排样工具环境中不允许进行样件的缩放和变形操作。

移动和旋转步距分为粗调步距和微调步距，分别用于快速移动和细微调整样件的位置。操作中可以通过回车键进行这两种步距的切换（当前的步距方式显示在状态栏中）。具体说明请参考“手排步距”功能按钮的说明。

4、增加或删除样件

在排样环境中可以增加和删除排样样件，重选材料边框。具体方法请参考对“增加样件”，“删除样件”和“选择边界”等功能按钮的的说明。

功能异常说明

样件或材料搭边线生成失败

当样件或材料的轮廓不闭合，有重点或其他一些异常情况时，无法进行等距，导致搭边线生成失败。此时应对样件或材料的轮廓进行检查和修整。

8.4.2 功能按钮说明

图8-55 优化排样功能按钮

现将排样环境右边导航条上的各个功能按钮的作用逐一介绍如下：

8.4.2.1 优化排样>>选择边界

选择或重新选择材料边框。材料边框的轮廓必须闭合，可以包含岛屿（内轮廓）。被选中的材料边框将按材料搭边间距向内等距产生一个绿色的边框，称为材料搭边线。

图8-56 选择边界

* 操作步骤：

1）点击“选择边界”按钮：

点击导航条上“选择边界”按钮。

2）拾取材料边界图形：

拾取由闭合轮廓组合成的材料边界图形。

异常说明

材料搭边线生成失败

当材料的轮廓不闭合，有重点或其他一些异常情况时，无法进行等距，导致搭边线生成失败。此时应对材料轮廓进行检查和修整。

8.4.2.2 优化排样>>增加样件

在排样过程中将普通图形转为排样样件。样件图形的轮廓必须闭合，可以包含岛屿（内轮廓）。普通图形只有转为排样样件后才能参与自动排样。

系统将被选中的样件图形按样件搭边间距向外等距生成一个蓝色的外框（内部岛屿为绿色），称为样件搭边线。

图8-57 增加样件

* 操作步骤：

1）选中要转为样件的图形：

选中所有要转为样件的图形。

2）点击“增加样件”按钮：

点击导航条上“增加样件”按钮，被选中的图形即转为排样样件。

异常说明

样件搭边线生成失败

当样件的轮廓不闭合，有重点或其他一些异常情况时，无法进行等距，导致搭边线生成失败。此时应对样件轮廓进行检查和修整。

8.4.2.3 优化排样>>撤消样件

在排样过程中将排样样件转为普通图形，其蓝色搭边线将被清除。被撤消的样件将不能再参加自动排样。注意并非删除样件图形本身。

图8-58 撤消样件

* 操作步骤：

1）选中样件：

选中所有要撤消的排样样件。

2）点击“撤消样件”按钮：

点击导航条上“撤消样件”按钮，被选中的排样样件即转为普通图形。

8.4.2.3 优化排样>>手排步距

设置用方向箭头键平移或旋转样件时的步距方式和步距值。

* 操作步骤

1）点击“手排步距”按钮：

点击导航条上“手排步距”按钮，系统弹出“设置移动步距”对话框。

2）设置参数：

在对话框中设置步距方式和输入步距值。

3）点击“确认”按钮：

设置完毕，点击“确认”按钮。

图8-59 “设置移动步距”对话框

参数定义：

移动方式 | 移动方式分为粗调和微调，分别用于快速移动和细微调整样件的方位。在手工排样过程中可以通过回车键进行这两种方式的切换（当前的移动方式显示在状态栏中）。 1）粗调 用较大的步距对样件件形移动和旋转，对样件放为进行粗略和快速调整。 2）微调 用较小的步距对样件件形移动和旋转，对样件放为进行精细调整。
粗调步距 | 粗调时使用的平移和旋转增量。
微调步距 | 微调时使用的平移和旋转增量。

8.4.2.4 优化排样>>搭边间距

设置样件及材料边框的搭边距离。

* 操作步骤：

1）点击“搭边间距”按钮：

点击导航条上“搭边间距”按钮，系统弹出“设置搭边距离”对话框。

2）设置参数：

在对话框中输入搭边间距值。

3）点击“确定”按钮：

设置完毕，点击“确定”按钮。

图8-60 “设置搭边距离”对话框

参数定义：

板料边距 | 材料的搭边间距。
样件边距 | 样件的搭边间距。
保留岛屿 | 当需要在具有内孔的样件的内孔部分排下其他的的小样件（嵌套排样）时，必须将对话框中的“保留岛屿”选项选上。

不保留岛屿 保留岛屿

图8-61 保留岛屿示意

8.4.2.5 优化排样>>自动排样

自动进行排样优化计算，将样件紧凑地摆放到材料边框内。

排样前系统自动判断样件是否位于材料边框内部，位于材料边框内部的样件在排样时将保持不动。因此排样前应当先把需要自动排列的样件移到材料边框外。

如果需要取消原先所有的排样状态，全部重新开始自动排样，先点击“排样重置”按钮，再进行自动排样。

* 操作步骤：

1）选中样件：

选中需要参与排样的样件。被选中的样件将出现两个操作手柄。

系统将只对被选中的样件进行排样，如果没有样件被选中，则对所有样件进行排样。

图8-62 选中样件

2）点击“自动排

样”按钮：

点击导航条上“自动排样”按钮，系统弹出“自动排样设置”对话框。

图8-63 “自动排样设置”对话框

3）设置排样参数：

在“自动排样设置”对话框中设置与自动排样有关的参数。各参数的具体含义请参考“自动排样”功能按钮中的“参数定义”。

4）开始排样：

设置完毕，点击对话框中“开始排样（O）”按钮。

5）等待排样结果：

系统开始自动排样，并弹出排样进度工具条提示自动排样的进度。

在自动排样的过程中可以点击“取消”按钮终止排样过程。

图8-64 排样进度工具条

参数定义：

排样精度 | 排样样件的定位精度。也可以想象为将材料内部区域均匀网格化，网格间距即为排样精度。 当样件和排样边界尺寸较大时，可适当加大排样精度值（降低排样精度），以加快计算速度。当样件和排样边界尺寸较小时，可适当减小排样精度值（提高排样精度），但排样精度过高，会大幅增加计算时间。 修改自动排样精度后将导致全部重新排样。
复制样件 | 选中该选项，则将原始样件的拷贝排放到材料边框内，原始样件保持不动。否则直接将原始样件排入材料边框内。
孔内排样 | 在具有内孔的样件的孔内排入较小样件（嵌套排样），进一步提高材料利用率。要进行孔内排样，在设置搭边间距时必须选择“保留岛屿”选项。
旋转步距： | 自动排样需要对每个样件进行旋转以探测出一个较好的排放位置，旋转步距为旋转探测的每步旋转角度增量。步距越小，排样结果一般来说会更好，但排样时间也将增加。 系统提供了三个旋转步距选项： a) 不旋转 排样时样件不进行旋转，只进行平移 。 b) 整数角旋转 排样时样件除进行平移外还按指定的整数角度进行旋转。 c) 精细旋转 排样时样件除进行平移外还按指定的小数角度（0.1 — 0.6）进行旋转。

(a) 排样前

(b) 排样后

图8-65 孔内排样示意

为产生较好的排样结果，有几条原则需要注意：

1、大小样件搭配在一起排样时，产生的排样结果一般较好。因为小样件可以充分利用大样件之间的空隙。

2、对于一些高度耦合的样件，可以人为的先把它们拼装在一起，转为图形组或集合，作为一个整体再参与自动排样。人机结合的排样效果比单纯依赖计算机排样要好一些。

图8-66 高度耦合样件

3、当对材料利用率要求不是太高时，可以适当加大旋转步距，以加快计算速度。对于矩形件或外形较为方正时，将旋转步距设为90度可以大大加快计算速度而不过多影响材料利用率。对圆形件可设为不旋转，排样结果不受任何影响。当样件和排样边界尺寸较大时，可适当加大排样精度值（降低排样精度），以加快计算速度。当样件和排样边界尺寸较小时，可适当减小排样精度值（提高排样精度），但排样精度过高，会大幅增加计算时间。

4、由于自动排样的优化目标之一是尽量降低排样结果的总高度。当样件数目相对于材料面积来说较小时，将材料边框横放和竖放的排样效果可能很不一样。因此应根据实际情况和需要调整材料边框的方向。如下图所示，虽然两种排样结果的总高度是一样的，但边框竖放的排样结果的材料利用率显然要高一些。

图8-67 横排与竖排

8.4.2.6 优化排样>>排样重置

每次排样结束系统会记录下当前已排好的样件情况，下次被选中的样件将在前面的排样基础上继续排放。如果需要从头重新开始自动排样，可以先点击“排样重置”按钮，进行排样状态的重新初始化后，这样先前所有的排样记录都会被清除掉。下次点击“自动排样”按钮时将全部重新开始自动排样，即使位于材料边框内部的样件也将被重新排列。修改自动排样精度等排样参数后也将导致全部重新排样。

* 操作步骤：

点击“排样重置”按钮：

点击导航条上“排样重置”按钮。

8.4.2.7 优化排样>>“干涉检查”

该选项主要用于辅助手工排样，避免排样时发生“干涉”（样件与样件或样件与材料边界有重叠部分）。该选项被选上时，用鼠标或箭头移动样件时如果导致干涉发生，该步的移动操作将被取消。不选“干涉检查”选项，则不会对移动操作作任何检查，需要用户自己去避免“干涉”。排样过程中为了方便有时可以暂时取消对样件的干涉检查，位置调整好后再将“干涉检查”选项选上。

8.4.2.8 优化排样>>“显示编号”

选中该选项后系统将显示样件的原始编号，方便用户将排样前后的样件对应起来。


群组与集合

8.5 群组与集合

8.5.1 群组

JDPaint中操作对象有图形、文字、图象、空间曲线、曲面等，群组提供了以组为单位来操作多个图形元素的简单方法。

1、群组的概念和属性

群组是多个对象组成的一个组单元，主要用于将多个对象作为一个整体统一进行选择和变换操作，如进行复制、粘贴、删除、平移、旋转、镜像等操作，这样就避免了对它们一一进行选择和变换操作的繁琐过程。

群组中的各个对象仍保持其原来的基本属性，即“文字”还是“文字”，“图形”还是“图形”等。使用群组可以保护对象之间的相对空间位置关系以及相互之间的特殊连接关系，但不能对群组中的对象进行改变基本属性的“编辑”命令，如不能对群组中的图形对象进行节点编辑、切断、修剪和延伸等编辑操作。要对群组中的对象进行这些编辑操作，必须将这个群组对象打散成单个对象，即取消群组。

2、创建群组

* 创建一个群组对象的步骤为：

1）选择图形： | 拾取要进行组合成一个组的多个图形对象。
2）启动群组命令： | 点击“变换(R)”->“群组(G)”菜单项或变换工具条中的 [image] 按钮。

3、取消群组

* 取消群组命令的操作步骤为：

1) 选择群组对象：

拾取要进行打散的群组对象

2) 启动取消群组命令：

点击“变换(R)”->“取消群组(U)”菜单项或变换工具条中的 [image] 按钮。

8.5.2 集合

与群组类似，集合也是将多个对象组合为一个整体单元，对这多个对象不仅可以象群组一样进行统一地选择和变换。与群组不同的是它还可以整体进行编辑操作，包括“编辑”菜单里的命令、节点编修、图形修边等操作，而且集合后的图形组具有一致的颜色填充和轮廓属性，可以通过“集合”命令重新界定一组图形的轮廓边界，生成新的填充、编辑或雕刻区域。另外集合中的文字对象也改变为图形对象。

在“变换”菜单中有创建集合和取消集合两种操作。

1、创建集合

* 创建一集合对象的步骤为：

1) 选择图形：

拾取要进行集合的多个图形对象

2) 启动集合命令：

点击“变换(R)”->“集合(C)”菜单项或变换工具条中的 [image] 按钮。

2、取消集合

* 取消集合命令的操作步骤为：

1) 选择集合对象：

选择要进行打散的集合对象

2) 启动取消集合命令：

点击“变换(R)”->“取消集合(B)”菜单项或变换工具条中的 [image] 按钮。

3、集合的特点：

集合后的图形有以下主要特点：

1） 多个区域轮廓的集合可以生成新的区域轮廓

一个区域的轮廓是由一条闭合的曲线或一条首末点共享的曲线构成的；将两个区域轮廓进行集合后，可组合生成一个新的区域。图8-68 (a)为集合前的三个区域轮廓，(b)和(c)分别为将这三个区域轮廓进行集合前后的轮廓区域的填充效果。

图8-68 区域轮廓集合后的新的区域

若有多个相互嵌套的区域轮廓进行集合，则新的区域轮廓的界定原则为：从里向外数第二个轮廓区域减去第一个轮廓区域生成一个新的区域，然后用第三个轮廓区域减去这个新的区域又生成一个新的区域，就这样依次类推，得出最终的轮廓区域。图8-69所示：

图8-69 相互嵌套的区域轮廓的集合

由于集合后重新界定了新的轮廓区域，比较下图中将两个圆集合前和集合后的区域与矩形区域进行区域焊接运算的结果。

图8-70 集合后的图形进行的区域焊接

2）可以对集合中的多个图形进行整体的编辑变换

集合后的图形组不仅可以进行整体选择和变换，还可以进行“编辑”菜单中的所有编辑命令，另外还可以整体进行节点编辑、艺术变形等。图8-71(a)为集合前，每次只能选中一个图形进行节点编辑，图(b)为选择由这两个图形组合成的集合对象进行节点编辑，将会使这两个图形同时被选中来进行节点编辑。

图8-71 集合前后的节点编修

3）文字集合后，改变属性：变成图形，不再具有文本属性。

4）集合的操作对象：只能是图形和文字。


对象转换

8.6 对象转换

8.6.1 文字转为图形

将文字对象转换为图形集合对象。主要用于对文字的轮廓进行节点编辑、图形编辑或优化优化排样等操作。

实现方法：

（1）选择文字对象；

（2）点击菜单项；

（3）在对话框中定义文字转换方式。

* 操作步骤：

1）选择文字对象：

拾取要进行转换的文字对象。

2）点击菜单项：

点击“变换(R)”->“文字转为图形(X)”菜单项。

3）在对话框中定义文字转换方式：

在弹出的对话框(图8-72)中定义文字转换为图形集合的方式，点击“确定”按钮。

参数选项：

转换方式

主要包括三种转换方式：

1. 整个字串转为一个集合：将选定的整个文字串转换为一个图形集合对象。

2. 单个字符转为一个集合：每个字符将转换为一个独立的图形集合对象。

3. 单个笔划转为一个集合：每个单独的与其它笔划不连接的笔划将转换为一个独立的图形集合对象。如图8-73。

图8-73 单个笔划转为一个集合

说明：文字转换为图形的另一种方法是通过图形集合命令；文字转换为图形后就丧失了文字的特性；

8.6.2 路径转为图形

将刀具路径对象转换为图形对象。

实现方法：

（1）选择刀具路径； （2）点击菜单项。

* 操作步骤：

1）选择刀具路径： | 拾取要进行转换的刀具路径对象。
2）点击菜单项： | 点击“变换(R)”->“路径转为图形(P)”菜单项。

说明：当刀具路径转变为图形后，若还要生成刀具路径，而且原来的刀具路径的深度没有变化，可将图形进行单线雕刻，就可以获得原来的路径。刀具路径在转为图形后三维深度会在变换后丢失，并且无法恢复。

8.6.3 清除艺术变形

将艺术变形后的对象变换为图形对象。

实现方法：

（1）选择艺术变形对象； （2） 点击菜单项；

* 操作步骤：

1）选择艺术变形对象： | 拾取要进行转换的艺术变形对象。
2）点击菜单项： | 点击“变换(R)”->“清除艺术变形(N)”菜单项。

说明：本命令与“艺术变形工具”中的“清除艺术变形”的作用相同。

8.6.4 曲线转换为圆弧

将选择的曲线用一个或多个圆弧段来进行拟合，使得原曲线由多条圆弧段组成。

实现方法：

（1）选择曲线；

（2）点击菜单项；

（3）在对话框中定义转换参数和选项。

* 操作步骤：

1）选择曲线： | 拾取要进行转换的曲线。
2）点击菜单项： | 点击“变换(R)”->“曲线转为圆弧(T)”菜单项。
3）在对话框中定义转换参数和选项： | 在弹出的对话框（图8-74）中定义圆弧拟合精度和是否删除原始曲线选项，点击“确定”按钮。

参数选项：

删除原始曲线 | 选中该选项，则转换后将原始曲线删除掉。
圆弧拟和精度 | 曲线用一个或多个圆弧段来进行拟合的精度。

说明：若原始曲线中含有直线段，则仍然保留这些直线段，系统将其它的曲线段如样条曲线段、Bezier曲线段等用圆弧段来进行拟合。注意：本命令只对2D曲线适用，不能将3D Nurbs曲线转换为圆弧曲线段。


对象图层转换

8.6.6 对象图层转换

将选择的对象转换为另一个图层上的对象。

实现方法：

（1）选择要转换图层的对象；（2）点击菜单项；（3）选择目标图层。

* 操作步骤：

1）选择要转换 图层的对象： | 选择一个或多个要转换图形的对象
2）点击菜单项： | 点击“变换(R)”->“图层转换(Y)”菜单项。
3）选择目标 图层： | 在弹出的转换图层对话框(图8-76)中，将显示出系统当前所有的绘图图层列表，选择一个要转换到的目标图层，点击“确定”按钮结束。

说明：

1、选择的多个对象可以不在同一图层内；

2、路径对象不能转换到另外一个图层上。


调整方向

8.7 调整方向

调整某一曲线的方向走向。

实现方法：

（1）点击菜单项；

（2）拾取曲线；

（3）调整曲线方向。

* 操作步骤：

1）点击菜单项： | 点击“变换(R)”->“调整方向(D)”菜单项。
2）用鼠标左键选 择图形： | 拾取要调整方向的曲线
3）调整曲线方向： | 点击导航工具栏中的 [image] 按钮，对原曲线的方向进行反向；还可以用左键双击曲线直接来进行曲线反向。可对多个曲线的方向进行调整，单击右键结束命令

说明：命令的执行可以采用“先选择后执行”或“先执行后选择”方式进行。


三维变换

第七章 三维变换

上册中所介绍的二维图形变换(如平移、旋转等)，均是对选中的图形在XOY平面内进行位置和形状的变换操作；在JDPaint5.0几何曲面造型中，构造曲面的轮廓曲线首先在XOY平面上绘制出来，然后通过三维平移、旋转等变换操作将它们直接变换到三维空间中去。本章将介绍这些三维变换操作命令来将平面曲线变换为空间曲线，将曲线和曲面在空间中进行位置和尺寸的变换等。

三维变换操作的菜单项如图7-1。点击“几何曲面(G)”-〉“三维变换(T)”菜单项，然后点击某一三维变换子菜单项即可对选中的图形在三维空间中进行变换。

平移 | 将选中的图形在三维空间中沿着某一方向平移一定的距离。
旋转 | 将选中的图形在三维空间中绕某一轴线旋转一定的角度。
镜像 | 将选中的图形在三维空间中相对某一平面进行对称映像。
缩放 | 将选中的图形以空间某一点为中心，对其XYZ三个方向的尺寸进行缩放。


三维镜像变换

7.3 三维镜像变换

将选中的图形在三维空间中相对某一平面进行对称映像。

图7-6 3D镜像变换

实现方法：

（1）启动三维镜像变换命令；

（2）拾取要进行镜像变换的图形；

（3）定义镜像平面的基点和法矢；

（4）定义其它镜像参数。

* 操作步骤：

1）启动三维镜像命令： | 点击“几何曲面(G)”-〉“三维变换(T)”-〉“镜像(M)”菜单项。
2）选择曲线或曲面： | 拾取要进行镜像的图形对象，单击鼠标右键结束镜像图形的拾取。
3）定义镜像平面的 基点和法矢量： | 定义镜像平面，包括平面基点和平面法矢。可以在参数定义页(图7-7)中直接输入平面基点(Sx、Sy和Sz)和平面法矢(Vx、Vy和Vz)，或通过矢量选项组来定义。
4）定义其它镜像参数： | 定义是否删除原始图形选项。
5）结束命令： | 点击参数定义页中的“确定”按钮结束。

参数定义：

三维镜像变换的参数和选项如图7-7：

图7-7 3D镜像参数定义

镜像平面 | 包括定义平面的基点(Sx、Sy和Sz)和平面法矢(Vx、Vy和Vz)。如图7-8为基点和法矢所确定的平面。
删除原始图形 | 选择此选项，则镜像后原始图形将被删除掉； 不选此选项，则为镜像拷贝，镜像后保留原始图形。

图7-8 镜像平面的定义


三维平移变换

7.1 三维平移变换

将选中的图形在三维空间中沿着某一方向平移一定的距离。

图7-2 三维平移变换

实现方法：

（1）启动三维平移变换命令； （2）选择要进行平移的曲线或曲面对象；

（3）定义平移方向矢量； （4）输入平移距离等平移参数和选项。

* 操作步骤：

1）启动三维平移变换命令： | 点击“几何曲面(G)”-〉“三维变换(T)”-〉“平移(L)”菜单项。
2）选择曲线或曲面： | 拾取要进行平移的曲线或曲面对象。
3）定义平移方向矢量： | 定义三维空间中平移方向矢量。可直接输入方向矢量分量值(Vx,Vy和Vz)，也可以通过矢量选项组进行定义。
4）输入平移距离等参数定义： | 输入平移距离、定义是否删除原始图形选项。
5）结束命令： | 点击参数定义页中的“确定”按钮结束。

参数定义：

三维平移的参数和选项如图7-3所示。

图7-3 三维平移参数和选项

平移距离（Dx,Dy,Dz） | 若为正值，则为图形沿着所定义的平移方向进行移动的距离； 若为负值，则为图形沿着平移方向的反方向进行移动的距离。
保持方向 | 不选该功能，图形变换按移动方向（Vx、Vy、Vz）的增量进行计算； 选择该功能，图形变换按移动方向（Vx、Vy、Vz）移动输入的长度。
删除原始图形 | 选中此选项，则在平移后将原始图形删除掉； 不选此选项，则将原始图形在新的位置进行拷贝。


三维旋转变换

7.2 三维旋转变换

将选中的图形在三维空间中绕某一轴线旋转一定的角度。

图7-4 三维旋转变换

实现方法：

（1）启动三维旋转变换命令； （2）拾取要进行旋转的图形；

（3）定义旋转轴的基点和方向； （4）输入旋转角度；

（5）定义其它旋转参数。

* 操作步骤：

1）启动3D旋转变 换命令： | 点击“几何曲面(G)”-〉“三维变换(T)”-〉“旋转(R)”菜单项。
2）选择曲线或曲面： | 拾取一个或多个要旋转的图形，单击鼠标右键结束旋转图形拾取。
3）定义旋转轴的基 点和方向： | 定义旋转轴基点和方向。
4）输入旋转角度： | 可直接输入角度值，也可以拖动下面的滑杆来调节旋转角度值。旋转角度值的范围为(-360~360)，并且相对于旋转轴满足“右手定则”。
5）定义其它旋转参数： | 定义是否删除原始图形选项。
6）结束命令： | 点击参数定义页中的“确定”按钮结束。

参数定义：

三维旋转变换的参数和选项如图7-5：

图7-5 3D旋转参数定义

轴起点(Sx,Sy,Sz) | 旋转轴的基点坐标。
轴矢量(Vx,Vy,Vz) | 旋转轴的方向矢量值。
旋转角度 | 图形相对于旋转轴的旋转角度。
删除原始图形 | 选择此选项，旋转变换后原始图形将被删除掉； 不选此选项，则在新的角度处对原始图形进行拷贝。


三维缩放变换

7.4 三维缩放变换

将选中的图形以空间某一点为中心，对其XYZ三个方向的尺寸进行缩放。

图7-9 三维放缩变换

实现方法：

（1）启动三维放缩变换命令；

（2）拾取放缩变换的对象；

（3）拾取放缩中心；

（4）定义放缩比例和其它参数定义。

* 操作步骤：

1）启动三维放缩 变换命令： | 点击“几何曲面(G)”-〉“三维变换(T)”-〉“放缩(S)”菜单项。
2）拾取放缩变换对象： | 拾取要进行放缩的图形对象，单击鼠标右键结束放缩对象的拾取。
3）拾取放缩中心点： | 输入变换中心，可以在参数定义页(图7-10)中直接输入放缩中心坐标(X、Y和Z)，也可以用鼠标拾取空间中一点来确定。
4）定义放缩比例和 其它参数定义： | 输入放缩后的XYZ尺寸或放缩比例及其它放缩参数和选项。
5）结束命令： | 点击参数定义页中的“确定”按钮结束。

参数定义：

三维放缩变换的参数和选项如图7-10：

图7-10 3D放缩变换参数定义

变换中心(X、Y、Z) | 放缩变换前后，图形在输入的变换中心处位置不变。变换中心不同，放缩后的图形不同，如图7-11。
保留原始对象 | 选择此选项，则在放缩变换后保留原始图形；否则，在变换后删除掉原始图形。
保持比例 | 选择此选项，可使放缩对象在世界坐标系的XYZ三个方向上进行等比例放缩变换。
尺寸(X向、Y向、Z向) | 放缩后图形对象在三维坐标系XYZ三个方向上的尺寸范围。
比例(X向、Y向、Z向) | 在三维坐标系统中XYZ三个方向上对图形进行放缩的尺寸百分比(倍数)； 尺寸和比例是相互关联的，调整放缩后尺寸和放缩比例是变换中确定比例因子的两种方法。

图7-11 放缩中心(图中C点)对变换的影响


ToolNode_index

第九章 节点编修工具

JDPaint5.0中有三种命令工具可对图形进行编辑，即图形选择工具、节点编修工具和艺术变形工具。图形在这其中的任何一种工具下进行编辑时所表现的形式和所进行的编辑都不一样。例如在图形选择工具下，图形几乎可以使用“主菜单”中的所有的“编辑变换”命令对其进行编辑。本章叙述图形在“节点编修工具”下的编修功能。

节点编修工具命令包含两类功能：图形节点编辑与图形快速修边。图形节点编辑是指通过修改图形的形状控制点（即图形节点）的位置，达到快速修改图形形状的目的，如图9-1所示；图形快速修边是指用一段或者多段曲线替换图形中指定的边界曲线，达到快速修改图形形状的目的，如图9-2所示。

图 9-1 图形节点编辑

图 9-2 图形快速修边

点击状态工具栏中的节点编修工具按钮 [image] ，按下按钮后，按钮显示为 [image] ，表示启动了“节点编修工具”命令，进入节点编修状态，鼠标指针变为一个黑色箭头 [image] 。窗口右边的导航工具栏中出现节点编辑的命令选项，如图9-3所示节点编辑导航工具栏与图9-4所示修边编辑导航工具栏。

图 9-3 节点编辑导航工具栏 图 9-4 修边编辑导航工具栏

图9-3中节点编辑功能描述如下：

微调距离 | 改变“微调”距离，通过“上下左右”键移动被选节点的位置。与选择工具中微调距离的功能相同。
插入节点 | 在线段的指定位置插入一个节点，以利于图形编辑。
删除节点 | 删除指定的一个或多个节点。
融合节点 | 把两个断开的节点融合为一个节点，达到连接或闭合的目的。
分离节点 | 把一个或多个节点分离，生成一段或多段不连接的线段。
转为直线 | 将图形中的圆弧或曲线段转化为直线段。
转为曲线 | 将图形中的圆弧或直线段转化为曲线段。
转为圆弧 | 将图形中的曲线段或直线段转化为圆弧。
尖点连接 | 将图形中曲线的连接状态改变为尖点连接状态，使得修改指定曲线段的形状时，相连的曲线段的形状不会发生改变。 即节点两边的曲线或圆弧在连接处任意变形移动，互相不受影响和干扰。
平滑连接 | 将图形中曲线的连接状态改变为平滑连接状态，使得修改指定曲线段的形状时，相连的曲线段的形状始终与其保持平滑连接。
对称连接 | 将图形中曲线的连接状态改变为对称连接状态，使得修改指定曲线段的形状时，相连的曲线段的形状始终与其保持平滑对称连接。 对称连接是平滑连接中的一种特殊状态，仅适用于两相连的曲线，任意改变其中的一条曲线形状，另外一条曲线也会跟着对称变动。
定为起点 | 把所选节点指定成曲线的起点。
节点对齐 | 把一个或多个节点“上下左右”对齐，或与某个直线、辅助线对齐。
自动减点 | 在保证图形变形不大，通过数据点的优化逼近，使图形上的节点数量减少到较优化的状态。 该功能特别适合于节点很多且分布较为密集的图形进行数据优化。
显示重点 | 如果图形轮廓中含有重点(即有两个节点重叠在一起的点)，此功能可以把重叠点位置指示出来。
合并重点 | 自动合并图形轮廓中含有所有重叠点。
显示断点 | 如果图形轮廓中含有断点，此功能可以把断点指示出来。
合并断点 | 自动合并图形轮廓中含有所有断点，使其连接成为一个连续的整体。
显示自交点 | 如果图形轮廓中含有自交的地方，此功能可以把自交点的位置指示出来。
节点设置 | 此功能设置自动减点精度、节点及控制线颜色等节编辑功能中用到的参数。

图9-4中修边编辑功能描述如下：

直线修边 | 应用一段直线替代图形轮廓中的指定边界曲线。
圆弧修边 | 应用一段圆弧替代图形轮廓中的指定边界曲线。
曲线修边 | 应用一段曲线替代图形轮廓中的指定边界曲线。
折线修边 | 应用两段直线替代图形轮廓中的指定边界曲线。
延伸修边 | 应用图形轮廓中的两段直线的延伸部分代替该两段直线之间的曲线段。
直线描边 | 应用绘制直线（或者折线）的方法生成折线直接替代图形中的指定边界曲线。
圆弧描边 | 应用绘制三点圆弧的方法生成圆弧直接替代图形中的指定边界曲线。
样条描边 | 应用绘制样条曲线的方法生成曲线直接替代图形中的指定边界曲线。
显示节点 | 在修边过程中是否显示图形的节点分布。

本章将分以下几部分讲述图形的节点边修工具：

1、 节点的基本概念

2、 节点的基本操作

3、 节点编辑工具命令

4、 图形修边工具命令


9.1.0

9.1 节点的基本概念

图形节点是指图形的形状控制点。确定了图形的形状控制点，整个图形的形状也就基本确定。因此通过修改图形的形状控制点，可以方便地修改图形的形状。在JDPaint系统中，图形是由直线、圆弧或曲线等基本图元组成的，掌握了基本图元的形状控制方法，用户也就掌握图形的节点编辑方法。


基本图元的节点分布

9.1.1 基本图元的节点分布

JDPaint 5.0中，组成图形的基本图元形状控制点（或节点）定义如下：

基本图元 | 形状控制点（或节点） | 图例
直线段 | 直线的起点和末点 |
圆弧 | 圆弧的起点和末点 |
圆 | 圆的圆心和起点 |
椭圆 | 椭圆的圆心与两个正交点 |
Bezier曲线段 | 曲线的四个控制点顶点， 曲线端点与相连内部的控制顶点的连线称为曲线的控制手柄 |
样条曲线 | 样条曲线的所有控制顶点 |


图形的节点分布

9.1.2 图形的节点分布

图形是由基本图元相连接组成的，因此图形的节点分布也就是基本图元的节点分布，如图9-5所示。

图 9-5 图形的节点

可以看出图形中的节点分布具有以下特点：

1、图形有起点和末点

图形是由基本图形单元相连接形成的，因此图形都有起点和末点。

在非闭合图形上，我们把图形的起点用较大的节点显示表示，使之与图形的末点相区别。可以通过“定为起点”命令将非闭合图形的末点改为起点。

在闭合图形上，起点和末点重合，大节点既是图形的起点又是图形的末点。闭合图形上的任意点，都可以通过“定为起点”命令设定为图形的起点。

2、图形中相邻曲线的首尾连接

除了非闭合图形的起点和末点外，其它节点分布于两条线段的连接处，改变此处节点的位置或属性，与它相邻的两段曲线都会发生变化。相连曲线段之间的节点主要属性有：尖点连接、平滑连接和对称连接。其中平滑连接和对称连接仅对Bezier曲线和圆弧连接有效，其他类型曲线连接只具有尖点连接属性。

3、可通过曲线的控制手柄编辑曲线

如果图形中含有曲线，点击这条曲线两端的任意一个节点，在节点上会出现从节点发出的一条蓝线，线的另一端有个实心的黑方框，这就是曲线的控制手柄，我们称之为控制线，如果此处是平滑连接或对称连接的节点，此节点两边的曲线都会出现控制线，通过拖动曲线控制点的位置，可调整曲线的形状，如图9-6所示。

图 9-6 控制手柄与控制点

4、图形中的图元类形可相互转换

不同的图形元素具有不同的节点编辑特征，通过将一种类型图元转换为另一种类型的图元，可以为图形获得更加灵活的编辑特性。例如将直线段转化为曲线，可以使图形中的直线段处理起来具有更多的灵活特征。

5、圆和椭圆的节点

圆和椭圆是特殊的图形对象，具有以下独特的特点：

l 圆和椭圆的圆心处的节点，这个节点只能进行移动和删除原始图形的操作。

l 圆和椭圆轮廓线上的节点，可以通过移动这些节点实现图形的放缩功能，删除其中的任何节点都会导致删除原始图形，圆上的节点还能进行起点位置的变化。

除上述特点之外，圆和椭圆上的节点不能进行其它任何编辑。


节点连接状态属性

9.1.3 节点连接状态属性

从上文我们知道，图形中相连曲线段之间的节点主要属性有：尖点连接、平滑连接和对称连接。这里我们对这种节点连接关系进行详细总结说明，如图9-7所示。

1） 相连直线段之间的节点连接方式——尖点连接；

直线与直线之间不存在平滑连接和对称连接关系，如果要对直线段之间进行节点的“连接方式”的编辑，就必须先把两条直线段或其中的一条直线段转化为曲线或圆弧，再使用这三种“连接方式”进行编辑。

2） 直线段与圆弧或曲线段之间的节点连接方式——尖点连接与平滑连接；

3） 圆弧与曲线段之间的节点连接方式——尖点连接与平滑连接；

4） 曲线段与曲线段之间的节点连接方式——尖点连接、平滑连接和对称连接。

直线与圆弧 圆弧与圆弧 圆弧与曲线

直线与曲线 曲线与曲线

图9-7 相连线段之间的连接方式

除了指定图形中的某一段曲线，将其转化为另一种曲线类型外，还可通过选择节点，将所选节点的相应线段转为其它类型，那么，被选节点与类型转换线段的对应关系如何确定呢？

1）非闭合图形——从起点到末点的顺序来判断

从起点开始，到末点的前一个节点，按照从起点到末点的方向，依次控制着下一段曲线，即改变其中的一个节点的直线、曲线或圆弧类型，那么与这个节点相连的两条线段中按照从起点到末点方向上的线段转为相应的直线、曲线或圆弧。改变线段末点的类型，不起任何作用，如图9-8所示。

图9-8 开曲线中的节点及其所控制的线段

2）对于闭合图形——按图形的顺时针或逆时针来判断

闭合图形的判断原则与非闭合图形相同。由于闭合图形上的方向不能从图形中直接观察出来，需要借助“调向”工具。因此对于闭合图形上的节点，我们可按照顺时针或逆时针的方向，依次控制着下一段曲线，即改变其中的一个节点的直线、曲线或圆弧类型，那么与这个节点相连的两条线段中按照顺时针或逆时针方向上的线段转为相应的直线、曲线或圆弧，如图9-9所示。

图9-9 闭曲线中的节点及其所控制的线段


9.2.0

9.2 节点的基本操作

图形节点的基本操作包括：

l 节点的选择

l 节点的快速编辑

l 节点的快速变换


节点的选择

9.2.1 节点的选择

图形节点选择是节点编辑最基本操作之一。

在节点编修工具状态下，随着鼠标的移动鼠标标识在不断的发生变化。在绘图区的其它地方鼠标标识呈“ [image] ”状，移动到已进入节点编辑状态的图形，遇到直线段时，鼠标标识呈“ [image] ”状，遇到圆弧时，鼠标标识呈“ [image] ”状，遇到节点时，鼠标标识呈“ [image] ”状，如图9-10所示。

图 9-10 鼠标标识变化

JDPaint系统提供了两种节点选择方法：

单选：用鼠标点击一个节点。节点颜色变黑，表示节点被选中。

窗选：按住鼠标左键不放，拖动鼠标，把要选择的节点用虚线框框住，松开鼠标左键，所有在框内的节点即被选中。

说明：

1）复选：按住“Shift”键，继续点选或框选节点，可以很方便地实现节点的自由添加选择。

2）反选：在已选择的节点基础上，按住“Ctrl”键，继续点选或框选节点，可以很方便地自由筛减节点。

例如，连接直线或圆弧的节点被选中后，节点的形态如图9-11所示。

图 9-11 节点被选显示状态

曲线被选中后，节点的形态如图9-12所示，单选状态会出现控制线。

图 9-12 曲线被选显示状态


9.2.2.0

9.2.2 节点的快速编辑

节点编辑状态下，使用鼠标对圆弧、曲线、控制点进行拖动，快速完成图形的编修。无论是闭合图形还是非闭合图形，都可以使用如下几种方法进行节点的快速编辑：

l 用鼠标移动节点

l 用键盘移动节点

l 拖动曲线或圆弧改变曲线、圆弧的形状

l 拖动控制点改变曲线的形状

l 快速插入和删除节点

l 圆和椭圆的快速编辑


用鼠标移动节点

9.2.2.1 用鼠标移动节点

用鼠标拖动被选节点来移动节点的位置。

图 9-13 用鼠标平移节点

实现方法：

（1）用鼠标选择节点；

（2）拖动节点。

* 操作步骤：

1）选择节点：

用鼠标选择点选或者窗选一个或多个节点。

2）拖动节点：

用鼠标点中其中的一个节点，按住鼠标不放，拖动鼠标，出现图形编辑框，图形编辑框显示了随着节点的移动，图形的变化过程，如图9-13所示（虚线代表图形编辑框）。移动到合适位置后，释放鼠标，图形移动完成。


用键盘移动节点

9.2.2.2 用键盘移动节点

通过键盘的“上下左右”键来移动节点的位置。

实现方法：

（1）用鼠标选择节点；

（2）移动节点。

* 操作步骤：

1）选择节点：

用鼠标选择一个或多个节点。

2）移动节点：

使用键盘“上下左右”键对节点进行移动，图形也会随着节点的移动而变化。

图形移动的距离由微调距离参数控制，用户可以通过输入 [image] ，修改“微调”参数。


拖动曲线或圆弧改变曲线、圆弧的形状

9.2.2.3 拖动曲线或圆弧改变曲线、圆弧的形状

用鼠标拖动曲线或圆弧来改变曲线或圆弧的形状。

图 9-14 拖动曲线或圆弧来改变曲线或圆弧的形状

实现方法：

（1）将鼠标移到指定的曲线或圆弧上；

（2）拖动曲线或圆弧。

* 操作步骤：

1）选择曲线或圆弧：

用鼠标选择曲线或圆弧轮廓线。

2）拖动曲线或圆弧：

用鼠标点中线段的某一个位置，按住鼠标不放，拖动鼠标，出现图形编辑框，图形编辑框显示了随着鼠标的移动图形的变化过程，如图9-14所示（虚线代表图形编辑框）。移动到合适位置后，释放鼠标，图形移动完成。

说明：拖动圆弧的操作方法与曲线的一样，直线是不能进行拖动的，如果想拖动直线段，必须把直线段转化成曲线或圆弧，再进行拖动。


拖动控制点改变曲线的形状

9.2.2.4 拖动控制点改变曲线的形状

对于曲线段，选中曲线段两端的其中一个节点会出现控制线，拖动控制点同样可以改变曲线的形状，如图9-15所示。这是曲线段所特有的性质。

图 9-15 拖动控制点改变曲线的形状


快速插入和删除节点

9.2.2.5 快速插入和删除节点

在进入节点编辑状态下的图形的轮廓线上，双击一下，即可插入一个节点，插入的节点不改变图形的形状和属性，如图9-16所示。

图 9-16 双击插入节点

在进入节点编辑状态下的图形的轮廓线上，对准一个节点双击一下，即可把这个节点删除，如图9-17所示。

图 9-17 双击删除节点


圆和椭圆的快速编辑

9.2.2.6 圆和椭圆的快速编辑

拖动圆和椭圆的圆心处的节点，可以实现圆和椭圆的移动，可以用鼠标双击此节点或者选中此节点使用键盘“Delete”键删除圆或椭圆。

可以通过移动这些节点实现图形的放缩功能，圆上的节点还能进行起点位置的变化。如图9-18所示。

删除圆和椭圆上的任何节点即可删除原始图形。


9.2.3.0

9.2.3 节点的快速变换

节点编辑状态下，在工作窗口上单击鼠标右健，弹出导航菜单，如图9-19所示。

图 9-19 鼠标右键导航菜单

其中平移节点、旋转节点和镜像节点命令属于节点的快速变换功能。


平移节点

9.2.3.1 平移节点

平移图形中被选中的节点。

实现方法：

（1）选中图形中的节点；

（2）选择平移节点命令；

（3）输入平移基点与平移放置点。

* 操作步骤：

1）选中图形中的节点：

用鼠标选中图形中需要平移的节点。

2）选择平移节点命令：

单击用鼠标右键，弹出导航菜单，如图9-19所示，选中平移节点命令。

3）输入平移基点：

在状态提示栏中出现提示：请输入平移基点，用鼠标在屏幕上点击输入一点。

4）输入平移放置点：

在状态提示栏中出现提示：请输入平移放置点，用鼠标在屏幕上点击输入另一点，完成平移节点命令，如图9-20所示。


旋转节点

9.2.3.2 旋转节点

旋转图形中被选中的节点。

实现方法：

（1）选中图形中的节点；

（2）选择旋转节点命令；

（3）输入旋转基点与旋转角度。

* 操作步骤：

1）选中图形中的节点：

用鼠标选中图形中需要平移的节点。

2）选择旋转节点命令：

单击鼠标右键，弹出导航菜单，如图9-19所示，选中旋转节点命令。

3）输入旋转基点：

在状态提示栏中出现提示：请输入旋转基点，用鼠标在屏幕上点击输入一点。

4）输入旋转角度：

在状态提示栏中出现提示：请输入旋转角度，用鼠标在屏幕上点击输入另一点或者从键盘输入角度，完成旋转节点命令，如图9-21所示。


镜像节点

9.2.3.3 镜像节点

镜像图形中被选中的节点。

实现方法：

（1）选中图形中的节点；

（2）选择镜像节点命令；

（3）输入镜像基点与镜像角度。

* 操作步骤：

1）选中图形中的节点：

用鼠标选中图形中需要平移的节点。

2）选择镜像节点命令：

单击用鼠标右键，弹出导航菜单，如图9-19所示，选中镜像节点命令。

3）输入镜像基点：

在状态提示栏中出现提示：请输入镜像基点，用鼠标在屏幕上点击输入一点。

4）输入镜像角度：

在状态提示栏中出现提示：请输入镜像角度，用鼠标在屏幕

上点击输入另一点或者从键盘输入角度，完成镜像节点命令，如图9-22所示。


9.3.0

9.3 节点编辑工具命令

本节叙述在节点编辑状态下的命令使用说明，在导航工具栏中选择节点编辑属性页如图9-3所示，主要包括如下命令：

插入节点 | 转为直线 | 尖点连接 | 定为起点 | 显示重点
删除节点 | 转为曲线 | 平滑连接 | 节点对齐 | 合并重点
融合节点 | 转为圆弧 | 对称连接 | 自动减点 | 显示断点
分离节点 |  |  |  | 合并断点
 |  |  |  | 显示自交点
 |  |  |  | 节点设置


插入节点

9.3.1 插入节点

在选定的直线、圆弧或曲线的指定位置上增加一个节点，使该图形多一个可编辑的节点。

图 9-23 插入节点

实现方法：

（1）选择图形上拾取一点；

（2）选择插入节点命令或者双击鼠标左键。

* 操作步骤：

1）选择图形：

用鼠标左键点击要编辑的图形对象，此时该图形上所有节点全部显示出来。

2）选择插入点：

用鼠标点击图形的某一个位置，出现黑色的实心圆点作为插入位置的标记。

3）选择插入节点命令：

点击“ [image] ”命令，标记处插入一个节点,并处于选中状态。

说明：双击图形的某一位置，也可实现插入节点功能。


对称连接

9.3.10 对称连接

两条线段之间的节点使用“对称连接”方式。“对称连接”是一种特殊的平滑连接，是曲线所特有的连接方式。

图 9-33 对称连接

实现方法：

（1）选中图形中一个或多个节点；

（2）点击对称连接按钮。

* 操作步骤：

1）选择要使用“对称

连接”的节点：

用鼠标选取一个或多个要使用“对称连接”的节点。

2）选择“对称连接”命令：

点击〖对称连接〗按钮，系统自动执行“对称连接”命令，如图9-33所示。

“平滑连接”与“对称连接”的区别：

“对称连接”是一种特殊的平滑连接，节点两边的控制线总是对称的，不仅其方向是相对的，而且控制线的长度也是相等的。当移动其中的一个控制点时，另一个控制点将同时移动，并且控制线的长度也同时发生变化。也就是说，当改变节点一侧的曲线段的倾斜角度和弯曲程度时，节点另一侧的曲线段的倾斜角度和弯曲程度也将同时发生变化。在对称节点处，曲线不仅形成平滑过渡，而且在节点两侧的曲率半径也相等。所以我们把这种节点之间的连接方式叫做“对称连接”， 如图9-34所示。

图9-34 对称连接

“平滑连接”的节点两边的控制线的方向是相对的，但控制线的长度可以独立变化，当移动其中一个控制点时，另一个控制点也将随之移动，但另一个控制线的长度不发生变化。也就是说，在改变节点一侧的曲线段的倾斜角度和弯曲程度时，节点另一侧的曲线段的倾斜角度也发生变化，但该曲线段通过节点时的曲率半径将不发生变化。在平滑节点处，曲线可以形成平滑过渡，所以我们把这种节点之间的连接方式叫做“平滑连接”，如图9-35所示。

图 9-35 平滑连接


定为起点

9.3.11 定为起点

起点指图形的起始点，图形进入节点编辑状态后，节点较大的为起点，图9-36所示是一些常用图形的节点显示，其中起点比其它节点略大。

图 9-36 图形起点

可以进行“定为起点”操作的图形约定如下：

非闭合图形 | 多义线的一端是起点，另一端就是末点。只能把末点选中执行“定义起点”命令，其它节点或线段上任意位置都不可以定为起点。
闭合图形 | 闭合图形的起点和末点的位置重合，图形上任意节点或线段上任意位置都可以定为起点。
圆 | 圆的轮廓线的任意位置都可以定为起点。
椭圆 | 椭圆不能改变起点位置（除镜像外）。

定为起点过程，如图9-37所示。

图 9-37 定为起点

实现方法：

（1）选择开曲线的末节点或者闭合曲线上的任意需要定为起点的点；

（2）选择定为起点命令按钮。

* 操作步骤：

1）选择要“定为起

点”的节点：

用鼠标选取要定为起点的节点，或者在线段上点击一下，出现黑点。

2）选择“定为起点”命令：

点击“ [image] ”按钮，“定为起点”命令结束后，所选位置变为起点，如图9-37所示。


自动减点

9.3.13 自动减点

在保证图形形状尽可能不失真（变形）的情况下，自动删除图形多余的节点。自动减点后，减少了节点数量，原来的直线段逼近的曲线转化为曲线段，图形更加光顺，同时有利于图形局部调整。

图 9-40 自动减点前图形 图 9-41 自动减点后图形

实现方法：

（1）选择图形中的需优化的多个节点；

（2）选择自动减点命令。

* 操作步骤：

1）选择图形中的节点：

用鼠标选取需要减点的节点范围，可以是图形的全部节点，也可以是图形的一部分节点。

2）选择“自动减点”命令：

点击“ [image] ”按钮，执行自动减点命令。自动减点以后，图形轮廓上的节点大大减少，而且图形轮廓中的曲线和圆弧部分全部用曲线段代替，可以用鼠标拖动曲线段进行调整，使图形轮廓变得更逼真、光滑。如图9-41所示。

自动减点命令特别适用于优化逼近存在大量多余节点的图形，自动减点精度可以在“节点设置”中设置。


显示重点、断点与自交点

9.3.14 显示重点、断点与自交点

有时候图形中经常有冗余点，例如重点、自交点和断点等，这样不但不利于图形的编修，还影响区域的形成、刀具路径的计算，我们用显示重点、显示自交、显示断点命令来“探测”这些冗余节点的位置，再根据这些位置去修改编辑它们。

首先，介绍重点、断点和自交点在JDPaint中的定义。

重点： 在一个节点位置同时存在两个或两个以上完全重合的节点。重点有两种，如果一个大节点和一个小节点重合，就显示为“重点1”的形式，如果两个都是小节点或两个都是大节点重合，就没有节点显示，为“重点2”的形式，对于不显示节点的位置，只要用鼠标点中应该存在节点的位置，按住左键拖动鼠标，即可拉出节点，如果是重点删除其中的一个节点即可，图例：

图9-42 图形的重点

断点：图形断开位置点（包括有两个断开的节点重合），如图9-43所示。

图9-43 图形的断开点（断点）

自交点 ： 一个图形区域发生交叉，交叉位置点叫做自交点，在图形轮廓中自交点处往往非常的小，肉眼不易觉察，需要放大后才能看到，图例：

图9-44 图形的自交点

其次，在JDPaint中可通过显示重点、断点和自交点命令，系统自动用不同符号分别标出重点、自交点、断点的位置，如图9-45，9-46，9-47所示。

图 9-45 显示重点

图 9-46 显示断点 图 9-47 显示自交点

第三，删除图形上的冗余点。JDPaint中提供了合并重点和合并断点功能。合并重点命令将自动合并图形中存在的重合点；合并断点命令将自动连接图形中断开的线段，将它们连接为一个整体，如图9-48所示。删除图形的自交点只能通过节点编辑或者其他图形编辑方法来实现。

图 9-48 合并断点


节点设置

9.3.15 节点设置

通过节点设置可以设置节点编修中的一些常用的参数，如图9-49所示。

图 9-49 节点设置

自动减点精度 | 此数值越小，自动减点后图形失真（变形）越小，减掉的节点个数越少，反之，图形失真（变形）越大。减掉的节点个数越多。系统默认值是“0.05”。
判断重点精度 | 只要两个重点之间的距离在精度值以内，这两个重点就可以通过“显示重点”功能显示出来。系统默认为“0.02”。
判断断点精度 | 只要两个断点之间的距离在精度值以内，这两个断点就可以通过“显示断点”功能显示出来。系统默认为“0.05”。
节点颜色 | 设置节点显示颜色，系统默认节点显示为黑色。用鼠标点击相应的颜色块，即可弹出颜色对话框选择颜色，如图9-50所示。点取颜色按钮可改变节点显示颜色。
控制线颜色 | 设置控制线显示颜色，系统默认控制线为蓝色。

图 9-50 颜色节点设置


删除节点

9.3.2 删除节点

删除当前所选的节点，如果删除后的节点少于两个的话，将删除整个图形。

实现方法：

（1）选中图形中要删除的节点；

（2）点击删除节点命令按钮，或者双击鼠标左键。

* 操作步骤：

1）选择图形：

用鼠标左键点击要编辑的图形对象，此时该图形上所有节点全部显示出来。

2）选择要删除的节点：

使用鼠标选取要删除的节点。

3）选择“删除节点”命令：

点击删除节点命令按钮“ [image] ”，所选的节点被删除。

说明：双击图形的指定节点，也可实现删除节点功能。


融合节点

9.3.3 融合节点

把两个断开的节点融合为一个节点，这两个节点必须是各自所在的非封闭连续线的首点或末点。通过“融合节点”将分离的图形元素连接起来形成一条连续线，达到连接或闭合的目的。把两个分离的图形进行节点之间的融合之前，必须先将它们进行集合，才能将要融合的节点同时显示出来，进行融合等命令的编辑。或者对一条开曲线，也可对它的首点与末点进行融合。

图9-24 选择要融合的节点

图 9-25 融合节点

实现方法：

（1）只能选中图形中的两个断点；

（2）点击融合命令按钮。

* 操作步骤：

1）选择图形：

选取要操作的图形，如果是分离的多个图形，通过集合命令将它们集合为一个整体。

2）选择要融合的节点：

用鼠标选择要融合的节点。如图9-24所示。

注意：选中的节点只能也必须同时有两个断点。

3）选择融合命令：

点击融合节点命令按钮“ [image] ”，所选节点融合为一点。


分离节点

9.3.4 分离节点

将一个或多个除起末点之外的节点分离成两个重合的节点，两线段在此节点处断开，从而达到分别编辑的目的。

图 9-26 分离节点

实现方法：

（1）选中图形中一个或多个节点。

（2）点击分离节点按钮。

* 操作步骤：

1）选择图形：

用鼠标左键点击图形对象，使图形处于选中状态。

2）选择要分离的节点：

用鼠标选取一个或多个要分离的节点。

3）选择“分离节点”命令：

选择分离节点命令按钮“ [image] ”，每个所选的节点分离成两个节点。


转为直线

9.3.5 转为直线

将所选节点所控制的线段转为直线。

图 9-27 选择多个节点转为直线

图 9-28 选择曲线上的点将曲线转为直线

实现方法：

（1）选中图形中指定线段的节点，或者在指定线段上选择一点（出现黑点）；

（2）点击转为直线按钮。

* 操作步骤：

1）选择要转为直线的节点：

用鼠标选取一个或多个要转为直线的节点。

2）选择“转为直线”命令：

点击转为直线命令按钮“ [image] ”，选取的节点所控制的那些线段将转化为直线。如图9-27所示


转为曲线

9.3.6 转为曲线

将当前节点所控制的那些线段转化为曲线，使图形轮廓可以按曲线方法进行编辑，图形变得光滑。

图 9-29 转为曲线

实现方法：

（1）选中图形中指定线段的节点，或者在指定线段上选择一点（出现黑点）；

（2）点击转为曲线按钮。

* 操作步骤：

1）选择要转为曲线的节点：

用鼠标选取一个或多个要转为曲线的节点。

2）选择“转为曲线”命令：

点击转为曲线命令按钮 [image] ，被选择节点所控制的线段变为曲线，圆弧转变曲线后，为保持原图的形状，在线段上可能会增加一个节点。转变为曲线的线段就可进行曲线的节点编辑。


转为圆弧

9.3.7 转为圆弧

将当前节点所控制的那段线段转化为圆弧，使图形轮廓可以按圆弧的方法进行编辑。

图 9-30 转为圆弧

实现方法：

（1）选中图形中指定线段的节点，或者在指定线段上选择一点（出现黑点）；

（2）点击转为圆弧按钮。

* 操作步骤：

1）选择要转为圆弧的节点：

用鼠标选取一个或多个要转为圆弧的节点。

2）选择“转为圆弧”命令：

选择转为圆弧命令 [image] ，被选择节点所控制的线段变为圆弧。


尖点连接

9.3.8 尖点连接

两条线段之间的节点使用“尖点连接”方式。拖动一段曲线，曲线发生变形，相邻的两端段曲线就不会发生变形，这样对曲线进行编修容易形成尖点。

图 9-31 尖点连接

实现方法：

（1）选中图形中一个或多个节点。

（2）点击尖点连接按钮。

* 操作步骤：

1）选择要使用“尖点

连接”的节点：

用鼠标选取一个或多个要使用“尖点连接”的节点。

2）选择“尖点连接”命令：

点击“ [image] ”按钮，系统自动执行“尖点连接”命令，使用尖点连接后的节点两边的曲线段再进行调整时就“互不干涉”了，如图9-31所示。

说明：

1）“尖点连接”命令只适用于曲线与曲线之间采用了“平滑连接”或“对称连接”后的情况（使用绘制“样条”命令绘制的多段样条曲线上的节点是平滑连接的）。

2）曲线与曲线之间采用了“平滑连接”或“对称连接”后，当我们对曲线进行节点编辑的时候，改变其中一条曲线的形状，相邻的两条曲线也跟着变化，如果对曲线的节点使用“尖点连接”命令以后，拖动一段曲线，使曲线发生变形，相邻的两端段曲线就不会发生变形，这样对曲线进行编修容易形成尖点。

3）对于两边含有直线或圆弧的节点就不必要使用“尖点连接”命令，这种节点在任何时候都视为“尖点连接”的情况，也就是说如果节点两边有一条线段是直线或圆弧，无论采用了“平滑连接”，还是“对称连接”后，任意调整另一边的曲线，都不会影响直线或圆弧的形状。


平滑连接

9.3.9 平滑连接

两条线段之间的节点使用“平滑连接”方式。如果节点两边含有曲线或圆弧，而此节点又是“尖点连接”，可使此处的线段连接光滑。

图 9-32 平滑连接

实现方法：

（1）选中图形中一个或多个节点；

（2）点击平滑连接按钮。

* 操作步骤：

1）选择要使用“平滑

连接”的节点：

用鼠标选取一个或多个要使用“平滑连接”的节点。

2）选择“平滑连接”命令：

点击“ [image] ”按钮，系统自动执行“平滑连接”命令。使用平滑连接后的节点两边的线段会自动保持平滑连接，如图9-32所示。

功能说明：由图9-32可以看出，只要节点两边含有曲线或圆弧，这个节点经过“平滑连接”后，节点两边的线段会自动平滑连接。如果此节点两边都是曲线，经过“平滑连接”后，拖动其中的一条曲线，另一条曲线也跟着变化，使节点处始终保持平滑连接；而含有圆弧的节点，拖动圆弧，不会影响其它线段。


9.3.12.0

9.3.12 节点对齐

“节点对齐”命令能将所选择的各个节点统一按照所选取节点范围的上、下、左、右进行排版，或者与所选的直线或辅助线进行对齐。

JDPaint 5.0提供了两种节点对齐方式，如图9-38所示。

1）按照选取节点范围的边界对齐。

所选取的节点都会按照所选节点范围边界的某个方向对齐，用鼠标选取对齐的方向。然后按〖确定〗按钮确定。边界对齐方位可以选择“顶部”、“底部”、“左边” 和“右边”中的一个。

2）按照指定的对象（直线或辅助线）对齐。

所选取的节点都会按照所指的对象（直线）进行对齐，用鼠标选取“指定对象（直线）对齐”选项，点击〖确定〗，提示栏中提示“选择直线图形”，点击指定的直线或辅助线，系统自动完成“节点对齐”命令。

图 9-38 “节点对齐”对话框


按选定节点的边界对齐

9.3.12.1 按选定节点的边界对齐

图 9-38 节点对齐>>控制顶点对齐

实现方法：

（1）选中图形中需对对齐的节点；

（2）选择节点对齐命令；

（3）在对话框中选取“控制顶点对齐”选项及对齐位置。

* 操作步骤：

1）选中要对齐的节点：

用鼠标选取图形中需对齐的节点。

2）选择节点对齐命令：

点击“ [image] ”按钮，系统弹出“节点对齐”对话框，选取“控制顶点对齐”和“顶部”对齐方式。

3）确定对齐命令：

点击〖确定〗，系统自动执行节点对齐命令，如图9-38所示。


按指定对象（直线）对齐

9.3.12.2 按指定对象（直线）对齐

图 9-39 节点对齐>>指定对象（直线）对齐

实现方法：

（1）选中图形中需对齐的节点；

（2）选择节点对齐命令，在对话框中选取“指定对象对齐”选项；

（3）选择对齐参考直线或者辅助线。

* 操作步骤：

1）选中要对齐的节点：

用鼠标选取图形中需对齐的节点。

2）选择节点对齐命令：

点击“ [image] ”按钮，系统弹出“节点对齐”对话框，选取“指定对象对齐”命令选项。并点击〖确定〗。

3）选择参考直线或者辅助线：

用鼠标拾取一直线或者辅助线，系统自动按照直线位置进行对齐，对齐结果如图9-39所示。


图形修边工具命令

9.4 图形修边工具命令

本节叙述在图形修边状态下的命令使用说明，在导航工具栏中选择图形修边属性页如图9-4所示，主要包括如下命令：

修边工具 |  | 用指定的一段直线、圆弧或曲线去快速地代替图形中的某一部分线段，完成快速修边。
 | 直线修边 | 以直线来代替图形轮廓的某一部分。
 | 圆弧修边 | 以圆弧来代替图形轮廓的某一部分。
 | 曲线修边 | 以曲线来代替图形轮廓的某一部分。
 | 折线修边 | 以折线来代替图形轮廓的某一部分。
 | 延伸修边 | 以两条直线段的延伸直线段代替图形轮廓的某一部分。
快速描边 |  | 用指定的连续线段快速地代替图形中的某一部分线段，完成快速描边。
 | 直线描边 | 以连续直线来代替图形轮廓的某一部分。
 | 圆弧描边 | 以连续圆弧来代替图形轮廓的某一部分。
 | 样条描边 | 以连续样条来代替图形轮廓的某一部分。
节点显示 |  | 当选取此项时，图形的节点被显示出来。

“图形修边工具”具有快速替换、可编辑性强等特点，侧重于图形中曲线段的整体替换，而“节点编辑工具”则侧重于图形的局部节点编辑，特别是具体到某一段线的编辑时是非常方便的，图形修边命令与节点编辑命令相互配合，形成了JDPaint一套较为完整的非精确图形编辑工具。

在图形修边状态下，鼠标在图形轮廓上移动时，会出现黑圆点或黑方点，方点在线段的端点或中点出现，黑圆点在除端点和中点外的地方出现，即曲线上的最近点，如图9-51所示。

图9-51 图形上特征点提示

如果开启图形的节点显示选项，图形轮廓上会出现显示，如图9-52所示。用户可以根据需要开启或者关闭节点显示。

图 9-52 开启与关闭节点显示


直线修边

9.4.1 直线修边

以直线来代替图形轮廓的某一部分。

图 9-53 直线修边

实现方法：

（1）选择直线修边功能；

（2）生成直线；

（3）删除原轮廓线。

* 操作步骤：

1）选择直线修边功能：

在导航工具栏上选中“直线修边”选项。

2）生成直线：

用鼠标拾取第一个点后，在鼠标指针与第一点之间出现蓝色的线段，用蓝色的线段去逼近轮廓线部分，然后确定第二点的位置。如图9-53所示。

3）编辑新的线段：

当鼠标移动到兰色的线段上时，鼠标标识变为“ [image] ”状，这是指：这条兰色的线段已经“曲线化”，可以对它进行拖动，去逼近曲线。如图9-54所示。当然，用户也可以不编辑该曲线，直接进入下一步操作。

图9-54 编辑替换曲线

4）删除原轮廓线：

确定完第二点的位置后，提示条提示“鼠标右键点击对象要删除的部分”，把鼠标移动到轮廓线被替换部分的段线上，鼠标标识变为“ [image] ”状，点击鼠标右键，即可把轮廓线被替换部分的原始图形删除，并用直线替换掉。如图9-55所示。

图9-55 删除原始轮廓曲线


圆弧修边

9.4.2 圆弧修边

使用圆弧来代替轮廓线的某些部分。

实现方法：

（1）选择圆弧修边功能；

（2）生成圆弧；

（3）删除原轮廓线。

* 操作步骤：

1）选择圆弧修边功能：

在导航工具栏上选中“圆弧修边”选项。

2）生成圆弧：

用鼠标点击需要圆弧逼近的轮廓线，使之进入修边状态，然后选择第1点和第2点，在两点之间出现一条蓝色的圆弧线段，用鼠标拖动圆弧线去逼近轮廓线。

3）删除原轮廓线：

逼近好后，同样对准被替换部分的轮廓线点击右键即可完成替换。


曲线修边

9.4.3 曲线修边

使用一段曲线来代替轮廓线的某些部分。

图 9-57 曲线修边

实现方法：

（1）选择曲线修边功能；

（2）生成曲线；

（3）删除原轮廓线。

* 操作步骤：

1）选择曲线修边功能：

在导航工具栏上选中“曲线修边”选项。

2）生成曲线：

用鼠标点击需要曲线逼近的轮廓线，使之进入修边状态，然后选择第1点和第2点，在两点之间出现一条蓝色的曲线线段，用鼠标拖动曲线去逼近轮廓线。

3）删除原轮廓线：

逼近好后，同样对准被替换部分的轮廓线点击右键即可完成替换。


折线修边

9.4.4 折线修边

使用折线来代替轮廓线的某些部分。

图 9-58 折线修边

实现方法：

（1）选择折线修边功能；

（2）生成折线；

（3）删除原轮廓线。

* 操作步骤：

1）选择折线修边功能：

在导航工具栏上选中“折线修边”选项。

2）生成折线：

用鼠标点击需要折线逼近的轮廓线，使之进入修边状态，然后选择第1点和第2点，在两点之间出现一条蓝色的线段，折线修边与直线修边的区别是中间多了一个黑点，拖动这个黑点，直线就变为折线，用这个折线去逼近轮廓线，用鼠标拖动曲线去逼近轮廓线。

3）删除原轮廓线：

逼近好后，同样对准被替换部分的轮廓线点击右键即可完成替换。


延伸修边

9.4.5 延伸修边

以两条直线段的延伸直线段代替图形轮廓的某一部分。

图 9-59 延伸修边

实现方法：

（1）选择延伸修边功能；

（2）拾取曲线段1；

（3）拾取取线段2。

* 操作步骤：

1）选择延伸修边功能：

在导航工具栏上选中“延伸修边”选项。

2）拾取曲线段1上的点：

用鼠标在需要延伸的曲线上点击一点，此时线段上出现一个黑点。

3）拾取曲线段2上的点：

用鼠标在需要延伸的另一曲线上点击一点，系统自动计算完成延伸修边，如图9-59所示。


直线描边

9.4.6 直线描边

使用多段连续直线来代替轮廓线的某些部分。

图 9-60 直线描边

实现方法：

（1）选择直线描边功能； （2）生成连续直线。

* 操作步骤：

1）选择直线描边功能：

在导航工具栏上选中“直线描边”选项。

2）生成连续直线：

用鼠标点击需要直线描边的轮廓线，使之进入修边状态，然后连续选择点连接成多段直线去逼近轮廓线，用鼠标拖动曲线去逼近轮廓线，点击鼠标右键结束，系统自动删除原轮廓线。


圆弧描边

9.4.7 圆弧描边

使用多段圆弧来代替轮廓线的某些部分。

图 9-61 圆弧描边

实现方法：

（1）选择圆弧描边功能； （2）生成连续圆弧。

* 操作步骤：

1）选择圆弧描边功能：

在导航工具栏上选中“圆弧描边”选项。

2）生成连续圆弧：

用鼠标点击需要圆弧描边的轮廓线，使之进入修边状态，然后连续选择三点生成圆弧去逼近轮廓线，系统自动删除原轮廓线。


样条描边

9.4.8 样条描边

使用样条曲线来代替轮廓线的某些部分。

图 9-62 样条描边

实现方法：

（1）选择样条描边功能； （2）生成样条曲线。

* 操作步骤：

1）选择样条描边功能：

在导航工具栏上选中“样条描边”选项。

2）生成样条曲线：

用鼠标点击需要样条描边的轮廓线，使之进入修边状态，然后连续选择点生成样条去逼近轮廓线，单击鼠标右键结束，系统自动删除原轮廓线。


CmdText_index

第十章 文字编辑工具

JDPaint 5.0中的文字录入与编辑是非常丰富的，从直线排列到任意曲线排列，再到艺术变形等，基本能满足雕刻业的排版需要，JDPaint 5.0还有对曲线上排列文字的精确编辑、对文字串中个别文字的处理、文字串的多行输入以及文字串的自动调整等功能，可以很方便地完成对文字的录入与编辑。如图10-1所示。

单击系统状态工具条中的“ [image] ”按钮，就可以启动文字编辑工具。“ [image] ”按钮被按下为“ [image] ”，鼠标指针变为“ [image] ”形状，操作界面右侧弹出导航工具栏，工具栏中提供了所有的文字编辑工具选项，如图10-2所示。

图10-2 字体编辑工具对话框

在JDPaint系统中，只有在文字编辑工具下，才可以完成对文字的各种排列与编辑。

下文分以下几部分分别介绍文字的录入与编辑功能。

1、文字的字体，叙述JDPaint系统目前支持的文字字体类型。

2、文字的录入功能，叙述多行排文字、曲线排文字等各种文字的录入方法。

3、文字的基本编辑，叙述文字的基本属性编辑方法。

4、曲线排文字编辑，叙述复杂文字的高级编辑方法。


CmdText_Font

10.1 文字的字体

JDPaint 5.0 系统能够全面支持符合Windows系统标准的TureType字体，因此安装在Windows操作系统“控制面板”中“字体”文件夹中的TureType字体，JDPaint系统都可以直接使用。除此之外，JDPaint还自带的“精雕细圆单线”、“精雕仿宋单线”、“精雕数字单线”三款单线字体供用户使用。

JDPaint 5.0所采用的字体有三种类型，如图10-3所示。

1）一般轮廓字体（TureType字体）。

2）特殊轮廓字体，叫笔画字体，除一些特殊情况（如三维清角）一般不使用笔画字体。

3）精雕单线体。

图10-3 JDPaint支持的字体

在操作中怎样来判断哪些是笔画字体呢？笔画字体在字体文件夹中不是很多，一般这种字体的表示方法如图10-4所示。

图10-4 笔画字体的表示方法


文字的录入

10.2 文字的录入

在JDPaint系统中，文本排版主要有以下几种类型：多行排文本，圆弧排文本，椭圆排文本和任意曲线排文本。

多行排文本 | 相当于文本段落，可分为单行排文本和多行排文本。
圆弧排文本 | 文字沿圆弧曲线排版分布。
椭圆排文本 | 文字沿椭圆曲线排版分布。
任意曲线排文本 | 文字沿任意曲线排版分布。

其中圆弧排文本、椭圆排文本和任意曲线排文本统称曲线排文本。

在录入文字之前首先选择“输入法”，点击屏幕右下角输入法按钮，就可以弹出输入法导航菜单，菜单中提供了当前计算机所有的输入法，输入法可以添加（添加输入法可以在有关人员的指导下进行），如图10-5所示。

图10-5 文字输入法

如果需要录入英文，就使用“ [image] ”输入法，把鼠标移到这个位置点击一下就可以进入这个输入法了，使用键盘录入英文，还可以录入数字。如图10-6所示。

图10-6 英文输入

如果需要录入中文，可供选择的输入法比较多，常用的输入法就有“五笔字型输入法”、“全拼输入法”、“智能abc输入法”“微软拼音输入法”“郑码输入法”等，选择一种你比较熟练的输入法，把鼠标移到这个位置点击一下进入这个输入法，使用键盘录入中文汉字，如图10-7所示。

图10-7 中文输入


多行排文本录入

10.2.1 多行排文本录入

进入文字编辑工具以后，用鼠标在绘图区点击一下，便出现如图10-8所示的光标，光标周围有四个控制点：

图10-8 选择文字录入基准点

提示条提示“文字编辑工具：一个多行排文本正被编辑”。出现光标后就可以录入文字了。

图10-9 多行排文本的录入


沿曲线排文本录入

10.2.2 沿曲线排文本录入

沿指定的一条曲线排版录入文字。以圆弧排文本录入为例，如图10-10所示。

图10-10 文字沿曲线录入

实现方法：

（1）进入文字编辑工具状态； （2）选择曲线，使光标落在曲线上； （3）录入文字。

* 操作步骤：

1）选择曲线：用鼠标拾取指定曲线，如图10-10, 光标落在圆上，提示条提示“文字编辑工具：一个圆排文本正被编辑”,出现文字录入光标,进入文字录入状态。

说明：由于所选择的曲线可以为圆、椭圆或者任意曲线，相应地就有圆排文字、椭圆排文字和任意曲线排文字。他们的文本录入方法是一样的。

2）录入文字： 直接录入文字。在录入过程中，空格键表示一个空字符。


文本的对齐方式

10.2.3 文本的对齐方式

在文字录入及编辑过程中，文本对齐是文字排版的重要指标，不同类型的文字排版有着不同的对齐表现形式，分别主要有：

多行排文本的对齐方式

圆排文本的对齐方式

椭圆排文本的对齐方式

曲线排文本的对齐方式

对齐工具是右侧导航工具栏中的中间部位的三个按钮，从左到右分别为“左对齐”、“居中”、“右对齐”，如图10-11所示。


多行排文本的对齐方式

10.2.3.1 多行排文本的对齐方式

1）对齐的基准：以光标的落点，就是要录入文字时光标的起始位置为基准。

2）对齐的种类：分为“左对齐”、“居中”、“右对齐”三种，如图10-12所示。

“左对齐”： 从基准位置开始向右排列。

“居 中”： 从基准位置开始向两边排列。

“右对齐”： 从基准位置开始向左排列。

图 10-12 对齐种类

3）使用方法：

在文字编辑状态下，在多行排文本的录入过程中或者选中一个多行排文本，分别点击“左对齐”、“居中”、“右对齐”按钮，文字排版效果如图10-13所示。

左对齐 居中 右对齐

图 10-13 多行排文本的对齐方式


圆或椭圆排文本的对齐方式

10.2.3.2 圆或椭圆排文本的对齐方式

1）对齐的基准：以光标的落点为基准，一般为圆的正上方。

2）对齐的种类：分为“左对齐”、“居中”、“右对齐”三种，如图10-14所示。

“左对齐” | 从基准位置开始沿圆或椭圆顺时针排列。
“居 中” | 从基准位置开始沿圆或椭圆两方向排列。
“右对齐” | 从基准位置开始沿圆或椭圆逆时针排列。

图10-14 圆弧排文字对齐种类

3）对齐工具的使用方法同上。

另外椭圆的排列方法同圆的排列方法一样，这里不在详细讲解。


任意曲线排文本的对齐方式

10.2.3.3 任意曲线排文本的对齐方式

1）对齐的基准：曲线排文本的基准点与曲线的起点和末点有关，在缺省的情况下通常以曲线的起点为基准点，曲线排文字的基准点编辑在后面有关章节将详细讲解。

2）对齐的种类：分为“左对齐”、“居中”、“右对齐”三种，如图10-15所示。

“左对齐” | 文字从基准位置向曲线末点排列。
“居 中” | 文字从基准位置向曲线两边排列。
“右对齐” | 文字从基准位置向曲线起点排列。


文字的基本编辑

10.3 文字的基本编辑

文字的基本编辑主要包括以下内容：文字的选择，文字的添加与删除，文字的剪切、复制与粘贴，文字的字体编辑, 文字的尺寸调整, 文字基线对齐。涉及到导航命令，如图10-16所示。

在下文中会用到一些专有名词：文字对象与文字字符。为了方便说明，避免出现概念混淆，在此对其加以说明。

文字对象 | 是指JDPaint中的文字对象，比如一个多行排文字对象，我们也称之为一个文字串；再比如一个圆排文字对象，我们也可称之为一个文字串。
文字字符 | 是指文字对象中的字符。由于文字对象均是由字符组成，因此这里我们称这些字符为文字字符。

对文字对象的编辑可以从两方面进行：

1）从整体上编辑修改文字对象中所有字符的属性和参数。

2）从局部上编辑修改文字对象中某一些字符的属性和参数。

本节主要叙述以下几部分内容：

文字的选择 | (1) 文字对象的选择。 (2) 文字字符的选择。
文字的添加与删除 | (1) 文字字符的添加与删除。 (2) 文字对象的添加实际上是文字的录入过程；文字串的删除实际上是删除一个文字对象，这里不加阐述。
文字的剪切、复制与粘贴 | 指文字字符的剪切、复制与粘贴。
文字的字体编辑 | (1) 从整体上调整文字对象的字体， (2) 从局部上调整指定文字字符的字体。
文字的尺寸调整 | (1) 从整体上调整文字对象中所有字符的尺寸， (2) 从局部上调整指定文字字符的尺寸。
文字基线对齐 | 多行排文本进行基线的对齐。


文字的选择

10.3.1 文字的选择

文字选择包括选择文字对象和选择文字对象中的指定文字字符。


文字对象的选择

10.3.1.1 文字对象的选择

录入文字时是纯录入状态，一些操作不能进行，如基线对齐、放到图形上、提取基准图形等命令，如果要对它们进行操作，必须重新对文字对象进行选择，方法很简单：在绘图区其它地方任意点击一下，然后再点击该文字对象，文字对象就变为选择状态下的录入形式，基线对齐、放到图形上、提取基准图形等命令就可以进行操作了。


光标在文字对象中移动

10.3.1.2 光标在文字对象中移动

选中文字对象后，可以用键盘的“上下左右”键，当然也可以用鼠标点击，把光标移动到文字对象中的任何地方。

使用键盘的 Home键，可以快速的把光标移动到光标所在行的行首。

使用键盘的 End键，可以快速的把光标移动到光标所在行的行末。


文字字符的选择

10.3.1.3 文字字符的选择

对文字对象中字符进行编辑，必须首先选中被编辑的字符。选择方法有两种：

1、用鼠标选择

a. 光标与鼠标指针重合 b 被选中的字符块

图10-17 文字对象选择

图10-18 选中所有字符

实现方法：

（1）选择文字对象；

（2）用鼠标拖动实现选择指定字符；

（3）用鼠标双击文字串把所有字符全部选中。

* 操作步骤：

1）选择文字对象： | 在文字编辑工具状态下，在屏幕拾取一个文字对象，进入该文字串编辑状态。
2）选择字符： | 用鼠标点击，使光标移动到“精”的左边，这时使鼠标指针与光标重合，如图10-17 (a) 所示，按下左键，此时鼠标指针又变为“ [image] ”形状，按住左键不放，向右拖动鼠标，出现黑色块，黑色块罩住的地方就是被选中的字符，如图10-17 (b)所示。
3）选中全部字符： | 如果要把所有字符全部选中，用鼠标双击文字串即可，如图10-18所示。

2、用键盘快捷键选择

实现方法：

（1）选择文字对象；

（2）按Shift+“上下左右”键选择指定字符。

（3）按Shift + Home/End键把所有字符全部选中。

* 操作步骤：

1）选择文字对象： | 在文字编辑工具状态下，在屏幕拾取一个文字对象，进入该文字串编辑状态。
2）移动光标： | 按Shift+“上下左右”键选择指定字符。图10-16中，以选择的“精雕”两个字为例，用鼠标点击或者使用“上下左右”键，使光标移动到“精”的左边，这时按住“Shift”键，敲击右“ [image] ”键两次，即可完成对“精雕”两个字的选择。
3）选中全部字符： | Shift+ Home键：可以快速的选择从光标位置到光标所在行的行首之间的文字。 Shift+ End键： 可以快速的选择从光标位置到光标所在行的行末之间的文字。

说明：使用键盘进行选择，可以完成对任意字符的选择。使用鼠标选择不容易把文字串最后的字符选中。


文字的添加与删除

10.3.2 文字的添加与删除

在文字对象中添加或删除文字字符，是文字排版中最常用的操作之一。


添加文字字符

10.3.2.1 添加文字字符

在指定的文字串中加入文字字符。

图10-19 添加文字字符

实现方法：

（1）选择文字对象；

（2）将光标移到指定的字符之前；

（3）录入文字。

* 操作步骤：

1）选中文字对象： | 在文字编辑工具状态下，选择需要加入文字字符的文字对象，进入该文字串编辑状态。
2）移动光标： | 用键盘的“上下左右”键，当然也可以用鼠标点击，使光标移动到需要添加文字的地方，把光标移动到北洼路的“北”字的前面，如图10-19所示。
3）录入文字： | 如图10-19所示，用键盘输入“海淀区”，那么北洼路的“北”字的前面就加入了“海淀区”三个字。


删除文字字符

10.3.2.2 删除文字字符

在文字对象中删除指定的文字字符。

图10-20 删除文字字符

实现方法：

（1）选择文字串；

（2）将光标移到指定的字符之前；

（3）用退格键或者删除键删除字符。

* 操作步骤：

1）选择文字串： | 在文字编辑工具状态下，选择需要加入文字字符的文字串，进入该文字串编辑状态。
2）移动光标： | 将光标移动到要删除字符的位置，调整好光标的位置后，使用退格键“ [image] ”删除光标前面的字符，使用删除键“ [image] （Delete）”删除光标后面的字符。如图10-20所示。


删除被选字符

10.3.2.3 删除被选字符

在文字对象中，删除被选中的文字字符。

图10-21 删除被选文字字符

实现方法：

（1）选择文字对象；

（2）选择文字对象中的指定文字字符；

（3）用删除键删除字符。

* 操作步骤：

1）选择文字对象： | 在文字编辑工具状态下，选择需要加入文字字符的文字对象，进入该文字编辑状态。
2）选择字符： | 选择需要“删除”的字符。参考上节的“文字的选择”。
3）删除字符： | 点击“ [image] ”按钮或者使用键盘删除键“Delete”，把“有限公司”四个字删除，如图10-21所示。


10.3.3.0

10.3.3 文字的剪切、复制与粘贴

JDPaint系统支持Windows系统下标准的“剪贴板”功能，也就是说，无论是在“Microsoft Word”、“Photoshop”等软件中，还是在打开的另一个JDPaint5.0中使用剪贴板抓取的文字或者图片，都可以在JDPaint的绘图区通过“粘贴”功能把它粘贴过来。同样，通过JDPaint获得的“剪贴板”上的文字也可以在其它软件中通过“粘贴”功能调入。

在录入文字的过程中，或者录入完文字以后，也可以对被选字符进行复制、剪切、粘贴等操作，从而实现对重复文字的快速编辑。它们的快捷功能按钮如图10-22所示。

图10-22 复制、剪切、粘贴、删除工具栏

它们的键盘快捷键：

剪切 | Ctrl+X | 把被选择的字符剪切下来，放到“剪贴板”中。
复制 | Ctrl+C Ctrl+Insert | 把被选择的字符复制一个，放到“剪贴板”中。
粘贴 | Ctrl+V Shift+Insert | 把通过“剪切”或者“复制”到“剪贴板”中的字符放到光标所在的位置。
删除 | Del | 把被选择的字符删除掉。


复制被选字符

10.3.3.1 复制被选字符

复制文字对象中被选中的文字字符到Windows系统的剪贴板中。

图10-23 复制被选文字字符

实现方法：

（1）选择文字对象； （2）选择指定文字字符； （3）按复制按钮。

* 操作步骤：

1）选择文字对象： | 在文字编辑工具状态下，选择需要加入文字字符的文字对象，进入该文字编辑状态。
2）选择字符： | 选择需要“复制”的字符。参考上节的“文字的选择”。
3）按复制按钮： | 点击“ [image] ”按钮或者使用键盘快捷键“Ctrl+C”，把“有限公司”四个字复制到“剪贴板”中，这时，文字串中的“有限公司”仍然保留着，如图10-23所示。


剪切被选字符

10.3.3.2 剪切被选字符

剪切文字对象中被选中的文字字符到Windows系统的剪贴板中。

图10-24 剪切被选文字字符

实现方法：

（1）选择文字对象；（2）选择指定文字字符；（3）按剪切按钮。

* 操作步骤：

1）选择字符： | 选择需要“剪切”的字符。参考上节的“文字的选择”。
2）按剪切按钮： | 点击“ [image] ”按钮或者使用键盘快捷键“Ctrl+X”，把“精雕”两个字剪切到“剪贴板”中，这时，文字串中“精雕”两个字就被剪掉了，如图10-24所示。


粘贴文字字符

10.3.3.3 粘贴文字字符

将Windows系统“剪贴板”中的文字粘贴到当前文字对象中光标所在的位置。

图10-25 粘贴文字字符

实现方法：

（1）选择文字对象；（2）指定字符粘贴位置；（3）按粘贴按钮。

* 操作步骤：

1）指定字符粘贴位置： | 通过键盘或者鼠标移动光标到文字对象中的指定位置，确定文字字符在文字串中的粘贴位置。
2）按粘贴按钮： | 把光标移动到任何位置，点击“ [image] ”按钮或者使用键盘快捷键“Ctrl+V”，把“精雕”两个从“剪贴板”中粘贴到光标所在的位置，并且可以连续粘贴多个，如图10-25所示。

可以把“剪贴板”中的文字粘贴到另一个JDPaint或者“Microsoft Word”等其它软件在录入文字时的光标下。另外，还可以使用“Microsoft Word”等软件中的“复制”或者“剪切”命令，把文字粘贴到JDPaint录入文字时的光标下。

需要注意的是：通过“复制”或者“剪切”到“剪贴板”的文字，不带有其它任何文字信息，粘贴时它默认所要粘贴到的文字串中光标所在的位置的文字信息，这时候最好先设置好文字的字体、尺寸，再进行粘贴！


10.3.4.0

10.3.4 文字的字体编辑

字体是文字最基本的属性之一。前文已经叙述了JDPaint可以支持的字体类型。

下文分四个部分介绍文字字体编辑：

1) 文字对象中所有字符的字体编辑。

2) 文字对象中被选文字字符的字体编辑。

3) 横排文字与竖排文字。

4) 字体管理器。


文字对象的字体编辑

10.3.4.1 文字对象的字体编辑

从整体上，调整文字对象中的所有字符的字体。

图10-26文字串的字体编辑

实现方法：

（1）选择文字对象；（2）设置新字体；（3）确认新字体应用于整个文字串。

* 操作步骤：

1）选择文字对象：

用鼠标左键点击文字对象，使文字对象处于选中状态。右侧导航工具栏中的“字体设置”下面标有字体名称的方框就显示出被选中的文字串的字体类型，如图10-27所示。

图10-27文字串及其字体

2）设置新字体：

用鼠标点击 [image] 的黑三角块，弹出“字体选项”对话框，在右侧显示选中字体的预览效果，如图10-28所示。

拖动鼠标至“方正隶书简体”处，出现兰色块，点击一下，字体设置为“方正隶书简体”，如图10-29所示。

图10-28 字体效果预览

图10-29新字体设置

3）确认新字体应用

于整个文字串：

点击“ [image] ”功能命令，那么整个字串就由“黑体”变为“方正隶书简体”，如图10-30所示。

图10-30 修改文字对象字体


文字字符的字体编辑

10.3.4.2 文字字符的字体编辑

从局部上，调整文字对象中的指定文字字符的字体。

图10-31 文字串中字符的字体编辑

实现方法：

（1）选择文字对象；

（2）选择文字对象中的字符；

（3）设置新字体；

（4）确认新字体应用于被选字符。

* 操作步骤：

1）选择文字对象中的字符：

选中需要改变字体的文字字符，如图10-32所示。

图10-32 选中文字字符

2）设置新字体：

设置新字体，例如新字体设为隶书。

3）确认新字体应用于

文字字符：

用鼠标点击“ [image] ” 功能命令，确认新字体应用于文字字符。那么被选中的字符就变为“隶书”，如图10-33所示。

图10-33 修改文字字符字体


横排或竖排文字

10.3.4.3 横排或竖排文字

在Windows系统中，字体有许多表示方法，其中最主要的是TrueType类型字体。在简体中文TrueType字体中，横排字体与竖排字体通常只相差一个符号“@”，如图10-34所示。因此，在JDPaint文字排版中，横排字体与竖排字体之间的转换将十分容易。横排字体转为竖排字体只需在字体名称前面加”@”字符即可；竖排字体转为横排字体只需在字体名称前面除掉”@”字符即可。其他操作步骤参考字体编辑，如图10-35所示。

图10-34 字体类型

文字串的竖排方式 被选字符的竖排方式

图10-35 竖排方式


常用字体管理器

10.3.4.4 常用字体管理器

字体类型很多，可达成百上千种，除了Windows提供的常用字体外，许多公司都有自己的字库，为有效管理各种类型字体，JDPaint提供了常用字体管理器，将用户从茫茫字库解放出来。字体管理器的作用是向“字体设置”对话框中添加或者删除常用字体。如图10-36所示。

图10-36 “字体设置”对话框

实现方法：

（1）选择“字体设置”命令；（2）搜索和添加常用字体；（3）删除常用字体。

* 操作步骤：

1）选择命令： | 在导航工具栏中，点击“ [image] ”的箭头按钮，弹出“字体设置”对话框。如图10-36所示。
2）搜索和添加常用字体： | 查找指定的字体。选中字体后，点击“ [image] ”按钮，或者点击鼠标右键，弹出导航菜单，点击“添加常用字体”，如果添加多个字体，就继续选中字体一个一个的添加，最后点击〖确定〗按钮。

3）删除常用字体：

在常用字体文件夹“ [image] ”中，选中指定字体后，点击“ [image] ” 按钮， 如果删除多个字体，就继续选中字体一个一个的删除，最后点击〖确定〗按钮，字体就被删除了。

说明：如果把整个字库添加为“常用字体”，就单击字体文件夹“ [image] ”，然后点击〖添加常用字体〗按钮，即可完成添加。


文字的尺寸编辑

10.3.5 文字的尺寸编辑

文字尺寸是文字重要的基本属性之一，它包括：字符高度、字符宽度、字符间距，倾斜角度和行间距等等参数指标。JDPaint中文字尺寸的定义符合Windows系统对文字定义的规范。

1）文字的字宽、字高、间距、行距是“文字字符”的字宽、字高、间距、行距。一个英文字母占有一个字符，一个汉字占有两个字符。即：汉字的宽度=字宽×2 。

2）文字的字宽、字高、间距、行距与实际文字的大小尺寸不一致，这也符合Windows系统对字符属性定义的习惯，图10-37所示。

图10-37 字符尺寸参数定义

进入文字编辑工具以后，右边导航工具栏就出现了将要输入文字的字宽、字高、间距、行距、倾斜角度的显示，如图10-38所示。

图10-38 文字尺寸参数

字宽 | 字符的宽度，单位：毫米。
字高 | 字符的高度，单位：毫米。
倾斜 | 字符的倾斜角度，单位：度。
间距 | 两字符的间距，按照字符块宽度的百分比计算。
行距 | 两行字符串之间的行距，直接输入距离值，单位：毫米。

文字尺寸编辑过程实质是这些尺寸参数的修改过程。为了方便调整文字尺寸大小，JDPaint提供了以下文字尺寸编辑功能：文字尺寸快速编辑、调整字符尺寸参数和精确调整文字实际尺寸。

文字尺寸快速编辑 | 用鼠标或键盘快速编辑修改文字的尺寸参数。
调整字符尺寸参数 | 通过调整字符尺寸参数，直接调整文字对象或被选文字字符的尺寸。
调整文字实际尺寸 | 通过确定文字的实际精确尺寸，自动调整文字对象所有字符的尺寸参数。


文字尺寸快速编辑

10.3.5.1 文字尺寸快速编辑

录入文字时，文字对象的周围有四个控制点，如图10-39所示，通过调整这四个控制点就可以完成对文字对象尺寸和位置的快速编辑。

图 10-39 文字对象的控制点

高度控制点 | 用于控制调整文字对象中字符的高度。
宽度控制点 | 用于控制调整文字对象中字符的宽度。
间距控制点 | 用于控制调整文字对象中字符之间的间距。
移动控制点 | 用于控制调整文字对象的位置基准点。

* 操作步骤：

1）调整文字的高度：

用鼠标点中高度控制点，拖动到合适位置，文字的高度就变化为调整后的高度，如图10-40所示

图10-40 文字高度调整前与调整后

2）调整文字的宽度：

用鼠标点中宽度控制点，拖动到合适位置，文字的宽度就变化为调整后的宽度，如图10-41所示

图10-41 文字宽度调整前与调整后

3）调整文字的间距：

用鼠标点中间距控制点，拖动到合适位置，文字的间距就变化为调整后的间距，如图10-42所示

图10-42 文字间距调整前与调整后

4）调整文字的基准位置：

用鼠标点中平移控制点，拖动到合适位置，整个文字都将平移到新的位置，如图10-43所示

图10-43 文字间距调整前与调整后

曲线排文字串与多行排文字串的使用方法基本相同，四个控制点的功能也是一致的，唯一不同的是，在调整的过程中，文字串始终沿着它的曲线基线进行变化。如图10-44所示。

图10-44 曲线排文字调整前与调整后


文字字符尺寸编辑

10.3.5.2 文字字符尺寸编辑

通过调整字符尺寸参数，直接调整文字对象所有字符的大小尺寸或者调整文字对象中被选文字字符的大小尺寸。

图 10-45 编辑文字的尺寸

实现方法：

（1）选择文字对象或者选择文字对象中指定的文字字符；

（2）设置新的字符尺寸；

（3）确认修改变量应用于指定的文字对象或者文字对象中指定的文字字符。

* 操作步骤：

1）选择文字对象或文字字符：

选中需要改变尺寸的文字对象或文字字符。选中后，在右侧的导航工具栏中出现当前被选文字串或字符的尺寸，如图10-46所示。

图10-46 选中文字对象

2）设置新的字符尺寸：

在右边导航工具栏中的文字尺寸编辑框中设置文字尺寸参数，如图10-47所示。

图10-47 新的尺寸参数 图10-48 尺寸修改完成

3）确认新的变量被应用：

点击“ [image] ”，确认新的字符尺寸参数就应用于被选文字串，如图10-48所示。

说明：同样地，如果是选择文字对象中指定的文字字符，设置新的文字尺寸参数，点击“ [image] ”，新的字符尺寸参数就应用于被选字符上。


精确调整文字对象尺寸

10.3.5.3 精确调整文字对象尺寸

由于Windows系统定义的文字尺寸参数不能真实地反应文字的实际尺寸，而用户在某些场合，又需要精确的文字尺寸。JDPaint精确调整文字对象尺寸功能，正是为此提供的。精确调整文字尺寸的命令是导航控制选项中的两个命令：

“ [image] ”和“ [image] ”。

1、精确调整字串高度

图 10-49 调整字串高度

实现方法：

（1）选择文字对象；

（2）点击“调整字串高度”按钮；

（3）设置新的参数并确定。

* 操作步骤：

1）选择文字对象：

选择需要调整文字高度的文字对象。

2）点击“调整字串高度”按钮：

在导航工具栏中点击 [image] “调整字串高度”按钮，弹出如图10-50所示。

图10-50 “调整字串高度”对话框

3）设置新的参数：

选择宽度和间距都跟随调整，调整到“20”毫米，如图10-51所示。点击“确定”，文字串中文字的实际高度就被调整到20毫米。

图10-51 精确调整字串高度

调整后文字的实际高度是指“最大实际高度”，也就是说是文字串中最高的文字字符的实际高度，其它的字符以它为基准成比例放大和缩小，所以并不是每个字符调整后的实际高度都是一样的。

2、精确调整字串长度

图 10-52 调整字串长度

实现方法：

（1）选择文字对象；

（2）点击”调整字串长度”按钮；

（3）设置新的参数并确定。

* 操作步骤：

1）选择文字对象：

选择需要调整文字高度的文字对象。

2）点击“调整字串长度”

按钮：

在导航工具栏中点击 [image] 按钮，弹出如图10-53示。

图10-53 “调整字串长度”对话框

3）设置新的参数：

设置新的参数，点击“确定”，文字串中文字的实际长度就被调整到设定的值。

参数定义

长度调整 | 1． 字串实际长度：显示当前字串的实际长度。 2． 调整到：调整后的字串长度。 3． 调整字符宽度改变字串长度：调整后的字符的宽度按比例跟随长度的改变而改变。 4． 调整字符间距改变字串长度：调整后的字符的间距按比例跟随长度的改变而改变。
跟随调整 | 字符高度按宽高比例跟随调整： 选择此功能的前提是在选择“调整字符宽度改变字串长度”功能的基础上，此功能调整后的字符的间距按比例跟随长度的改变而改变。


多行排文本基线对齐

10.3.6 多行排文本基线对齐

对多个多行排文本进行基线对齐处理，如图10-54所示。

图 10-54 多行排文本的基线对齐

实现方法：

（1）选择需要被对齐的文字对象；

（2）点击“基线对齐”按钮；

（3）拾取另一参考对象（多行排文字对象或者辅助线）。

* 操作步骤：

1）选择要被对齐

的文字对象：

用鼠标左键点击文字对象，选中需要被对齐的多行排文字对象。

2）点击”基线对齐”按钮：

在导航工具栏中，点击“ [image] ”按钮，提示条提示“文字基线对齐：拾取一个多行排文字对象或辅助线作为对齐基准”，这时点击作为对齐基准的字串或辅助线，二者就基线对齐了。如图10-54所示。


10.4.0

10.4 曲线排文本编辑

曲线排文本要比多行排文本复杂得多，效果千变万化，控制参数较多。由于文字沿曲线变化可以获得各种艺术效果，满足文字排版的多样性需求，因此在雕刻行业应用相当广泛。曲线排文本编辑涉及到的导航命令，如图10-55所示。

曲线排文本的编辑方法主要有：

① 圆弧排文本编辑

② 椭圆排文本编辑

③ 任意曲线排文本编辑

④ 文本放到图形上

⑤ 提取基准图形

⑥曲线排文本的节点编辑


圆或椭圆排文本编辑

10.4.1 圆或椭圆排文本编辑

圆弧排文本与椭圆排文本的编辑参数基本相同，编辑方法也相同，学会了圆排文本编辑也就学会了椭圆排文本编辑。下文仅以圆弧排文本为例进行说明。

图 10-56 圆或椭圆排文本的精确编辑

实现方法：

（1）选择圆排文字对象或者椭圆排文字对象;

（2）点击“曲线排参数编辑”按钮;

（3）选择曲线；

（4）修改曲线排参数并确认新的参数应用被选的文字串。

* 操作步骤：

1）选择文字对象：

用鼠标左键点击圆弧排文字对象或者椭圆排文本对象，选中需要编辑的文字对象。

2）点击“曲线排参

数编辑”按钮：

3）选择曲线：

点击导航工具栏中“ [image] ”按钮。

选择基准曲线，即圆。弹出如图10-57所示的对话框，对话框中显示了当前被选曲线排字串的参数。

4）编辑参数并确认：

修改被选曲线排字串的参数，并确认新的参数应用被选的文字串。如果对其中的参数进行了修改，要点击“ [image] ”按钮进行认可；如果想退出此对话框进行其它的编辑，就点击“ [image] ”退出。

图10-57 “曲线排参数”对话框

曲线排参数定义

对齐：

对齐工具按钮，从左到右分别为“左对齐”、“居中”、“右对齐”。对齐方式与前面讲解的用法是一样的，这里不再赘述。

变换：

文字对象中字符在圆弧或椭圆上的变换方式。

1． 正常排列方式

文字对象中的字符的方向始终与圆或椭圆垂直（和圆或椭圆的法线方向保持一致）进行排列。

2． 投影排列方式

文字串中的字符沿着圆或椭圆排列时，不改变方向，始终为竖直或者水平方向。

投影

图10-58 文字变换方式

放置：

文字对象在圆或椭圆上的放置位置，也就是文字对象的基线与圆或椭圆的相对文字定义，主要选项有：基线、顶部、中线、底部和自由。

1． 基线放置

文字对象的基线与圆或椭圆对齐，如下图10-59所示。

图10-59 基线放置

2． 顶部放置

文字对象的顶部与圆或椭圆对齐，如下图10-60所示。

图10-60 顶部放置

3． 中线放置

文字对象的中线与圆或椭圆对齐，如下图10-61所示。

图10-61中线放置

4． 底部放置

文字串的底部与圆或椭圆对齐，如下图10-62所示。

图10-62 底部放置

5． 自由放置

使用自定义的方法，把文字串放在圆或椭圆上的任意位置，通过调整对话框中的“ [image] ”，来调整文字串的基线与圆或椭圆之间的距离，偏值距离可以输入负值，正值与负值的偏移方向正好相反。

图10-63自由放置

方向：

圆或椭圆的方向：绘制的圆或椭圆是有方向的，有逆时针和顺时针两种，系统缺省为逆时针。它的方向可以通过菜单“变换（ALT+ R）→调整方向（D）”查看和修改。

图10-64 曲线的方向

1、正向排列

文字串的排列方向与圆弧或椭圆的曲线方向一致。如图10-65所示（圆的方向是逆时针）。

图10-65正向排列

2、逆向排列

文字串的排列方向与圆弧或椭圆的曲线方向相反，如图10-66所示（圆的方向是逆时针）。

图10-66 逆向排列

如果圆弧或者椭圆的方向是顺时针，文字串的排列正好相反。

基准：

文字排版的基准位置对于文字的排版十分重要，在文字录入章节中，我们已经对文字对象的基准进行了一些说明，这里将详细说明圆和椭圆上的基准定义。任意曲线上的基准定义请参照下一节任意曲线排文本编辑。

文字对象以圆或椭圆上某个点的位置为基准进行排列，这个基准决定了文字对象的位置。对于圆和椭圆分别提供两种基准：角度基准与长度基准。

1． 角度基准：文字对象以图形上某一角度上的点为基准进行排列。

圆一周的角度是360度，逆时针为正值，顺时针为负值，椭圆也如此。在JDPaint 5.0中，在缺省的情况下，把圆和椭圆的0度点定义在水平直径的右端点。一般地，把圆和椭圆的角度从它们的起点开始算。

图10-67 圆与椭圆的角度分布

2． 长度基准：文字对象以图形上某一圆弧长度上的点为基准进行排列。基准距离值正负的判断和输入：

基准距离计算方法：圆或椭圆的基准距离值是以圆或椭圆的起点为0位开始计算的，与圆和椭圆的方向一致的基准距离值是正值，方向相反的基准距离值是负值。圆的起点是可以随意设置的，椭圆的起点不能随便设置。

通过“绘制”命令绘制的圆和椭圆，只要不经过节点编辑把它的起点改变，那么它的起点位置是确定的：圆的起点的位置是水平直径的右端点。椭圆的起点根据绘制的方法不同又分为两种：使用“两点椭圆”绘制的椭圆的起点始终是水平轴的右端点；使用“圆心半径半径”绘制的椭圆的起点始终是第一个确定的椭圆的半径的端点为起点，如图10-68所示，大节点就是起点。

图10-68 圆与椭圆的起点分布

在进行文字串的编辑时，为了便于把握参数的输入和文字串的排列，我们一般使用标准的圆和椭圆，也就是如图10-67所示的圆和椭圆，圆和椭圆是绘制完成后不经过任何编辑的，它们的方向是逆时针，起点是水平直径和水平轴的右端点，另外椭圆最好不要旋转，文字排列完成后，把文字转化为图形，再进行任意的旋转变形。

图10-69 圆和椭圆的起点和方向

基准应用举例

基准位置对于文字排版十分重要，下面讲解这两个基准的使用方法，为了讲解的需要，我们只讲“标准圆”圆排的情况，而且其它参数如“变换、放置、方向”分别是“正常、基线、逆向排列”，如图10-70所示。

图10-70 标准圆弧排文本

1、角度基准的应用

通过改变基准角度的角度参数来实现文字对象沿曲线排位置的移动。

例 把图10-70中文字对象的左端（“北”字的左端）移动到圆的45度处。

使用步骤如下：

⑴ 首先，选择文字串的对齐方式为“左对齐”，确定文字串的左端位置。 然后，基准角度输入“45”度，确定圆的45度处点的位置。如图10-71所示。

图10-71 调整角度基准的角度值

⑵ 参数设置好后，点击〖应用〗，文字串的排列位置就发生了变化，如图10-72所示，“北京精雕科技有限公司”的左边与圆的“45”度位对齐。

图10-72 应用角度调整结果

⑶ 同样，如果使文字串的中间与圆的45度位对齐，就使用“居中”对齐方式，如果使文字串的右端与圆的45度位对齐，就使用“右对齐”方式，如图10-73所示。

图10-73 角度基准对齐

当然，通过改变其它参数如“变换、放置、方向”，会生成各种形式的排列效果，如图10-73所示，请大家试着生成下面文字串的排列效果。

图10-74 调整曲线排参数

2、长度基准的应用

通过改变基准距离的距离参数来实现文字对象沿曲线排位置的移动。它的应用方法基本和角度基准的应用方法一样。

例 把图10-70中文字串的左端（“北”字的左端）移动到距离圆（圆的半径是25毫米）的起点为逆向25毫米处。

使用步骤如下：

⑴ 首先，选择文字串的对齐方式为“左对齐”，确定文字串的左端位置。

然后，使用“长度基准”，因为我们采用的是“逆向排列”，所以基准距离输入“-25”毫米，才能到达圆的逆向的“25”毫米处，确定圆的25毫米处点的位置。如图10-75所示。

图10-75 调整长度基准的基准距离

⑵ 参数设置好后，点击〖应用〗，文字串的排列位置就发生了变化，如图10-76所示，“北京精雕科技有限公司”的左边与距离圆的起点“25”毫米处对齐。

图10-76 应用长度基准调整结果

⑶ 同样，如果使用“居中”或“右对齐”的对齐方式，就会使文字串的中间或右端分别与距离圆的25毫米处点的位置对齐，如图10-77所示。

图10-77 长度基准对比比较

当然，通过改变其它参数如“变换、放置、方向”，会生成各种形式的排列效果。

椭圆排文字的编辑与圆的相同，这里不再对其进行讲解。

一般对于圆或椭圆排文字的曲线编辑采用“角度基准”比较容易排列和接受，操作也比较简单。


任意曲线排文本的编辑

10.4.2 任意曲线排文本的编辑

在JDPaint 中除了圆和椭圆之外的图形上排列的文本都叫任意曲线排文本：

1、非闭合图形如样条曲线、圆弧、直线等开曲线排文本是任意排文本。

2、除了圆和椭圆外的闭合图形如矩形、多边形、星形等闭合曲线排文本，也是任意排文本。

无论是开曲线，还是闭合曲线排文本都有共同的性质，它们的排列和编辑都是一样的。

图 10-78 任意曲线排文本的编辑

实现方法：

（1）选择任意曲线排文字对象;

（2）点击“曲线排参数编辑”按钮;

（3）修改曲线排参数，并确认新的参数应用被选的文字对象。

* 操作步骤：

1）选择文字对象：

用鼠标左键点击。任意曲线排文本对象，选中需要编辑的文字对象。

2）点击“曲线排参数编辑”按钮：

点击导航工具栏中“ [image] ”按钮，弹出如图10-57所示的对话框，对话框中显示了当前被选曲线排字串的参数。

3）编辑参数并确认：

修改被选曲线排字串的参数，并确认新的参数应用被选的文字串。如果对其中的参数进行了修改，要点击“ [image] ”按钮进行认可；如果想退出此对话框进行其它的编辑，就点击“ [image] ”退出。

曲线排参数定义：

对齐： | 与圆和椭圆排的用法相同。
变换： | 文字对象中字符在曲线上的排列方式，与圆和椭圆排的用法相同。如图10-79所示。 图 10-79 文字在曲线上的排列方式
放置： | 文字对象在曲线上的位置，也就是文字对象与曲线的相对位置关系。与圆和椭圆排的用法相同。如图10-80所示。 图10-80 文字对象在曲线上的位置
方向： | 文字对象排列时，与曲线的方向相同，还是与曲线的方向相反。 绘制的曲线是有方向的，非闭合曲线的方向是从起点到末点，闭合曲线的方向分顺时针和逆时针两种，它的方向可以通过方向调整工具查看和修改，如图10-81所示。 图10-81 曲线的方向 正向排列：文字串的排列方向与图形的方向一致。 逆向排列：文字串的排列方向与图形的方向相反。 如图10-82所示。 图10-82 文字在曲线上的排列方向
基准： | 文字对象以曲线的某个点的位置为基准进行排列，这个基准决定了文字串的位置。 1． 角度基准：文字串以图形上某一角度上的点为基准进行排列。 以曲线的中心点O为起点，每隔45度绘制一条射线，如图10-83所示，有的射线与曲线有交点，有的射线与曲线没有交点。 图10-83 角度基准 这些有角度的射线与曲线相交的点就是曲线的角度基准，如A、B、C、D、E、F点，基准角度为这条射线的角度。 如果这条射线与曲线没有交点，那么，在这个角度上曲线就没有基准点，文字串就不能进行排列，如上图中45度、90度、135度的射线与曲线就没有交点。 如果这条射线与曲线有两个以上的交点，那么，就选取距离中心点最近的交点作为在这个角度上曲线的基准点，如上图中180度射线与曲线的交点B就是输入基准角度为180度时的基准点。 2． 长度基准：文字串以图形上距离起点或末点的长度位置点为基准进行排列。 基准距离值的判断与输入，前提是“正向排列”： l 非闭合图形也是有方向的，方向是从起点到末点，起点和末点都可以作为0位，从起点开始到末点方向的基准距离值输入正值，从末点开始到起点方向的基准距离值输入负值。 l 闭合图形的方向有顺时针和逆时针，基准距离的正负的输入也是根据是否与图形的方向一致来确定，与图形方向一致的基准距离值输入正值，与方向相反的基准距离值输入负值。 如果是“逆向排列”，情况正好相反。

基准应用举例

1、角度基准应用

任意曲线排文本的角度基准本身没有实际的几何意义，但是应用角度基准也能获得不同曲线排的效果。

l 对齐方式是“居中”，基准角度是“ [image] ”的排列的图例：

图10-84

l 对齐方式是“左对齐”，基准角度是“ [image] ”的排列的图例：

图10-85

l 对齐方式是“右对齐”，基准角度是“ [image] ”的排列的图例：

图10-86

在进行任意曲线排文本的编辑时，使用“角度基准”，一般用来确定文字串正好排列在曲线的中心位置的情况，如图10-87所示。

图10-87

2、长度基准的应用

例 对如图10-88所示样条曲线排文本进行编辑。

图10-88 样条曲线排文本

以下是选择“正向排列”的几种情况，而且其它参数如“变换、放置”分别是“正常、基线”：

l 参数：“左对齐”、“正向排列”、“长度基准”、“基准距离为0”。文字的排列方式如图10-89所示。

图10-89

l 参数：“左对齐”、“正向排列”、“长度基准”、“基准距离10”。文字的排列方式如图10-90所示。

图10-90

l 参数：“右对齐”、“正向排列”、“长度基准”、“基准距离0”。文字的排列方式如图10-91所示。

图10-91

l 参数：“右对齐”、“正向排列”、“长度基准”、“基准距离-10”。文字的排列方式如图10-92所示。

图10-92

下面是选择“逆向排列”的情况，而且其它参数如“变换、放置”分别是“正常、基线”，这时，文字串在曲线的另一边，而且基准距离输入正负值的情况与“正向排列”时正好相反：

参数：“左对齐”、“逆向排列”、“长度基准”、“基准距离10”。文字的排列方式如图10-93所示。

图10-93

其它情况请读者在下面练习，这里不再赘述。

一般对于任意曲线排文本的编辑采用“长度基准”时比较容易确定文字串与曲线的左端或者右端对齐，如图10-94所示。

图10-94


文本放到图形上

10.4.3 文本放到图形上

JDPaint提供两种生成沿曲线排列的文字的方法：

（1）文字沿曲线录入，在10.2节讲解了直接录入的方法；

（2）把文字放到曲线上。通过把文字放到指定图形上，可以将多行排文字转换为曲线排文字，也可以将一个曲线排文字放到另一曲线获得新的曲线排文字。

图10-95 选择文字对象

图10-96 文字对象放到图形上

实现方法：

（1）选择指定文字对象；

（2）点击“放在图形上”按钮；

（3）选择基准曲线。

* 操作步骤：

1）选择文字对象：

用鼠标左键点击文字串对象，选中文字对象。如图10-95所示，选择文字串“北京精雕科技有限公司”。

2）点击“放在图形上”按钮：

在导航工具栏中用鼠标点击“ [image] ”，这时提示条提示“拾取一个基准图形”，并且工具栏弹出“ [image] ”，如果保留原始文本就在前面的小方框中点击一下，出现“ [image] ”。

3）拾取基准图形：

用鼠标拾取一个基准图形，弹出“曲线排参数”对话框。按照以上讲解的方法，对其排列方式按要求进行编辑，编辑完后，点击〖确定〗即可生成曲线排文字，如图10-96所示。


提取基准图形

10.4.4 提取基准图形

曲线排文本进行各种编辑之后，如果原始图形已经被删除了，或者对曲线排文本进行了节点编辑，已经改变了文本的基线，通过该命令，可得到文本的基线图形。

图10-97 提取基准图形

实现方法：

（1）选择曲线排文字对象；

（2）点击“提取基准图形”按钮。

* 操作步骤：

1）选择曲线排文字对象：

在文字编辑状态下，用鼠标左键点击圆排文字、椭圆排文字或者任意曲线排文字对象，文字对象的基线变为兰色虚线。

2）点击“提取基准图形”按钮：

在导航工具栏中点击“ [image] ”按钮，即可提取出文字串的基准图形，如图10-97所示。


10.4.5

10.4.5 曲线排文本的节点编辑

曲线排文本除了能进行以上讲解的编辑外，还可以进行节点编辑，启动“节点编修工具”，进入节点编辑状态，用鼠标点击曲线排文字串，就可以进入曲线排文字节点编辑状态。下面分别说明：

圆或椭圆排文本的节点编辑

任意曲线排文本的节点编辑


圆或椭圆排文本的节点编辑

10.4.5.1 圆或椭圆排文本的节点编辑

对圆或椭圆排文本进行节点编辑。

实现方法：

（1）选择“节点编修工具”状态；

（2）选择圆或椭圆排文字串；

（3）应用节点编辑调整基准图形。

* 操作步骤：

1）选择“节点

编修工具”：

启动“节点编修工具”，进入节点编辑状态。

2）选择文字对象： | 用鼠标左键点击圆或椭圆上的文字串对象，选中文字对象，文字串的对象变为兰色线，而且线上出现节点，鼠标指针变为“ [image] ”状态，就可以进行文本的节点编辑。如图10-98所示。 图10-98 选择文字对象
3）节点编修基准图形： | 对于圆和椭圆排文本的节点编辑主要有如下几种操作： (1) 整体移动： 用鼠标点击中心的位置控制点，可以实现文本的移动，如图10-99所示。释放鼠标，文字串就排列在新的基线上了。 图10-99 整体移动 (2) 半径缩放 圆和椭圆排文本进行节点编辑时，还可以改变它们的半径，对于椭圆还可以分别改变它的两个半径。有两种方法改变它们的半径： 第一种方法：通过拖动圆或椭圆排文本在节点状态下的基线来改变它们的半径。 用鼠标点中圆或椭圆排文本在节点状态下的基线，拖动鼠标，有一个虚线编辑框跟着移动，如图10-100所示。释放鼠标，文字串就排列在新的基线上了。 图10-100 拖动基线缩放半径 第二种方法：通过拖动圆或椭圆排文本在节点状态下的节点来改变它们的半径。 用鼠标点中圆或椭圆排文本在节点状态下的基线的节点，拖动鼠标，有一个虚线编辑框跟着移动，对于圆排的节点可以任意移动，而椭圆的节点就不能随便移动，水平轴只能在水平方向移动，竖直轴只能在竖直方向移动，如图10-101所示。释放鼠标，文字串就排列在新的基线上了。 图10-101 拖动节点缩放半径 (3) 调整基线起点 用鼠标点中圆排文本，进入节点编辑状态，用鼠标点中圆的起点，拖动鼠标，有一个虚线编辑框跟着移动，如图10-102所示。 图10-102 调整基线起点 拖动到合适的位置松开鼠标，那么文字串的基线的半径就发生了变化，并且，随着基线圆起点的变化，文本中文字串的中间始终与起点对齐，如图10-103所示。 图10-103 调整后文字串


任意曲线排文本的节点编辑

10.4.5.2 任意曲线排文本的节点编辑

对任意曲线排文本进行节点编辑。

实现方法：

（1）选择“节点编修工具”状态；

（2）选择任意曲线排文字对象；

（3）应用节点编辑调整基准图形。

* 操作步骤：

1）选择“节点编修”工具：

启动“节点编修工具”，进入节点编辑状态。

2）选择文字串：

用鼠标左键点击圆或椭圆上的文字串对象，选中文字串，文字串的基线变为兰色线，而且线上出现节点，鼠标指针变为“ [image] ”状态，就可以进行文本的节点编辑。

3）节点编修基准图形： | 对于任意曲线排文本的节点编辑主要有如下几种操作： （1）重新定义起点： 用鼠标选中曲线的终点，点击“定为起点”按钮，曲线的方向改变，文本的排列也发生改变，如图10-104所示。 图 10-104 重新定义起点 （2）改变曲线形状： 利用节点的移动、使用“转为直线、转为圆弧、转为曲线”、“尖点连接、平滑连接、对称连接”等命令。 图 10-105 改变曲线形状 （3）改变曲线的中心点： 改变了曲线的形状就改变了曲线的中心，这时如果是采用了“角度基准”进行排列的文本，文字串与曲线的相对位置就会跟着曲线的变化而变化，如图10-106所示。 图10-106 改变曲线的中心点 如果是采用了“长度基准”进行排列的文本，文字串与曲线的相对位置就不会发生变化。


艺术变形工具

第十一章 艺术变形工具

JDPaint提供了对图形和文字的形状作各种变形的工具。使用这些工具，您可以从一个简单的图形开始，只需要通过直观的操作，就可以衍生变化出极其复杂的、充满艺术效果的图形，甚至是令人意想不到的艺术图形。在JDPaint中将这些变形工具统称为艺术变形工具。它包括五种变形工具，可以产生五种不同的变形效果，它们分别是：封套变形、透视变形、推拉变形、拉链变形、扭转变形。

通过点击“状态工具栏”中艺术变形工具按钮 [image] ，在屏幕右侧的导航工具栏中即可弹出艺术变形工具选项，如图11-1所示。

图11-1 艺术变形导航工具栏

当对图形和文字实施了某一种变形效果之后，可以对它再实施其它的变形效果，从而使形状变化多端，丰富多彩。如图11-2中的两个图形都是在一个椭圆上先采用拉链变形以产生锯齿，然后再采用扭转变形生成的艺术图形。

在图形和文字上施加了艺术变形操作后，就不能再对它们作其它的操作如节点编辑、生成加工路径等等。如果要做这些操作，应当使用图11-1中的操作或主菜单“变换(R)—>清除艺术变形(N)”命令，清除变形操作。

图 11-2 艺术变形效果


封套变形

11.1 封套变形

封套变形给图形和文字添加封套，对象周围将出现带有八个节点的矩形绿色封套线框，用户可以通过节点编辑该矩形封套线框，获得图形的艺术变形效果，如图11-3所示。

实现方法：

（1）选择图形或文字对象；

（2）选择封套变形命令；

（3）用节点编修工具编辑封套线框。

* 操作步骤：

1）选择图形或文字：

在艺术变形工具状态下，用鼠标选中需要变形的图形或文字对象。

2）点击“封套变形”按钮：

在导航工具栏中点击“ [image] ”，系统自动切换到“节点工具状态”，在导航工具栏的底部弹出“封套变形”类型选项，如图11-4所示，它分为“水平模式”、“垂直模式”、“双向模式”，缺省为“双向模式”。可用鼠标选择其它的封套模式。

图 11-4 封套模式

水平模式 | 原始图形或文字中，是水平的线，变化后仍然保持水平。
垂直模式 | 原始图形或文字中，是垂直的线，变化后仍然保持垂直。
双向模式 | 对象沿着水平和垂直两个方向同时按照封套线框作变化。

3）节点编辑封套对象：

拖动节点或线框的每段曲线，封套线框将按照鼠标的拖动方向产生变形。对封套线框的编辑，与节点编辑的操作完全相同，用户可使用节点编辑操作，来改变线框的形状。同时，图形将随着线框的形状变化而发生相应改变。如图11-3封套变形效果。

4）清除艺术变形：

变形完毕以后，在系统中记录的封套变形对象。用户必须清除封套才能恢复为图形性质，清除艺术变形可通过点击菜单“变换”中的“清除艺术变形”命令，或者切换回“艺术变形工具”状态，点击〖清除艺术变形〗按钮，清除封套后的图形如图11-5所示。

图 11-5 清除艺术变形


透视变形

11.2 透视变形

透视变形为图形或文字对象添加透视效果，可以使对象产生距离和深度的效果，使二维图形在观察上具有三维透视的效果，如图11-6所示。

JDPaint可以为对象添加两种透视效果：单点透视和两点透视，单点透视又分为：水平透视和垂直透视。在添加透视效果后，还可以根据需要编辑透视效果。

图 11-6 透视变形

实现方法：

（1）选择图形或文字对象；

（2）选择透视变形命令；

（3）编辑控制点修改艺术图形。

* 操作步骤：

1）选择图形或文字：

在艺术变形工具状态，用鼠标点击需要变形的图形或文字对象。

2）选择透视变形命令：

在导航工具栏中点击透视变形命令按钮，此时对象被具有四个控制点的蓝色矩形框包围，同时系统在导航工具栏中弹出“透视变形”类型选项，如图11-7，它分为“水平透视”、“垂直透视”、“双灭点透视”，用鼠标选择一种透视方式。

图 11-7 透视变形模式

水平透视 | 对象沿着水平方向上逐渐后退。
垂直透视 | 对象沿着垂直方向上逐渐后退。
双灭点透视 | 对象沿着水平和垂直两个方向上逐渐后退。

3）编辑透视变形对象：

用鼠标分别拖动各个方向上的控制点达到变形效果。

4）清除艺术变形：

变形完毕以后，点击〖清除艺术变形〗按钮，清除对图形施加的“透视变形”操作，恢复图形性质。


推拉变形

11.3 推拉变形

推拉变形是将图形的各个节点推离或拉近变形中心，从而改变图形的形状，获得变形效果，如图11-8所示。

图 11-8 推拉变形

实现方法：

（1）选择图形或文字对象；

（2）选择推拉变形命令；

（3）编辑推拉变形对象的控制手柄。

* 操作步骤：

1）选择图形或文字对象：

在艺术变形状态下，用鼠标点击需要变形的图形或文字对象。

2）选择推拉变形命令：

在导航工具栏中点取〖推拉变形〗，图形自动转化为推拉变形对象，此时图形中心出现一个蓝色小方框。这个小方框表示“推拉”的中心，它的位置可以移动，还有一蓝色带箭头的拉杆，通过鼠标左右拉动拉杆来确定变形后图形的形状。用鼠标拖动拉杆向作右移动，即为“推”，把图形的节点推离变形中心；用鼠标拖动拉杆向作左移动，即为“拉”，把图形的节点拉近变形中心。

同时系统在导航工具栏中弹出“推拉变形”类型选项，如图11-9，它分为“推拉方式1”、“推拉方式2”、 〖中心变形〗三个命令选项，用鼠标选择一种推拉方式。

图 11-9 推拉变形模式

推拉方式1 | 推拉过程中，由图形节点位置的改变而产生推拉变形。
推拉方式2 | 推拉过程中，图形各段曲线随着图形节点位置改变而跟着变化，共同产生推拉变形效果。
中心变形 | 将推拉的中心移动到图形的几何中心。

3）编辑推拉变形

的控制手柄：

用鼠标修改推拉中心位置，或者用鼠标左右推拉拉杆，使图形发生变形，达到理想的变形效果。如图11-8所示。


拉链变形

11.4 拉链变形

拉链变形在对象的轮廓线内侧和外侧将增加一系列节点，使对象的轮廓线变成锯齿状。如图11-10所示。

图 11-10 拉链变形

实现方法：

（1）选择图形或文字对象；

（2）选择拉链变形命令；

（3）编辑拉链变形对象的控制手柄。

* 操作步骤：

1）选择图形或文字对象： | 在艺术变形状态下，用鼠标点击需要变形的图形或文字对象。
2）选择拉链变形命令： | 在导航工具栏中点取〖拉链变形〗，图形对象自动转化为拉链变形对象。此时图形中心出现一个蓝色小方框，用它来确定变形的中心。它的位置可以移动，还有一蓝色带箭头的拉杆，通过鼠标左右拉动拉杆来确定变形后图形的形状。拉杆上还有一小矩形框，用它可以调节“锯齿”的频率（“锯齿”的密度）。 同时系统在导航工具栏中弹出 [image] 按钮选项。

中心变形：将拉链的中心移动到图形的几何中心。

3）编辑拉链变形的控制手柄：

用鼠标左右推拉拉杆来调节“锯齿”的幅度（锯齿的高度），用小矩形框来调节“锯齿”的密度，如图11-11所示，应用拉链变形做出的效果。

图 11-11 拉链变形效果


扭转变形

11.5 扭转变形

扭转变形可以将对象绕一个点旋转，形成螺旋形效果，如图11-12所示。

图 11-12 旋转变形

实现方法：

（1）选择图形或文字对象；

（2）选择扭转变形命令；

（3）编辑扭转变形对象的控制手柄。

* 操作步骤：

1）选择图形或文字对象：

在艺术变形工具状态下，用鼠标点击需要变形的图形或文字对象。

2）选择扭转变形命令：

在导航工具栏中点取〖扭转变形〗，图形对象自动转化为扭转变形对象。此时对象中心出现一个蓝色小方框，表示对图形实施扭转的中心，它的位置可以移动。还有一蓝色带箭头的拉杆，按住拉杆三角端，使其绕中心作顺时针或逆时针旋转，以确定变形后图形的形状。

同时系统在导航工具栏中弹出扭转方向选项，它分为“顺时针”、“逆时针”，如图11-13所示，用户可选择扭转模式。扭转变换过程中，如果对扭转的方向不满意，可选择另外的时针方向，直接将图形作反向调整，效果如图11-14所示。

图 11-13 扭转方向模式

逆时针 | 绕扭转中心逆时针扭转。
顺时针 | 绕扭转中心顺时针扭转。
中心变形 | 将扭转的中心移动到图形的几何中心。

3）编辑扭转变形的控制手柄：

用鼠标拖动扭转变形拉杆来调节对象变形效果，直到满意为止。如图11-14所示，应用扭转变形做出的效果。

图 11-14 扭转变形效果


常用变形效果

11.6 常用变形效果

除了以上常规的五种变形功能以外，JDPaint 提供了一些常见的封套变形效果，如波浪、腰鼓、圆弧、桥形、梯形、倾斜盒、八角盒、三角形、牛角等等封套变形。用户可以直接将这些变形效果施加于图形或文字对象之上，获得设定的变形效果，并在此基础上作进一步的编辑，使变形效果作进一步的变化，如图11-15所示。

图 11-15 常用变形效果

实现方法：

（1）选择图形或文字对象；

（2）选择常用变形效果命令；

（3）选择一种指定的变形效果。

* 操作步骤：

1）选择图形或文字对象：

在艺术变形工具状态下，用鼠标点击需要变形的图形或文字对象。

2）选择常用变形效果命令：

在导航工具栏中点击“常用变形效果”，弹出如图11-16所示“艺术变形库”对话框，其中列出了多达30种艺术变形效果。

图 11-16 艺术变形库

3）选择一种指定的变形效果：

从“艺术变形库”对话框中，选取一种变形效果，系统自动将图形转化为指定的封套效果，并进入“节点编辑状态工具”环境，用户可以对图形上的封套进行节点编修，改变封套的形状，从而进一步改变图形形状。


12.0

第十二章 图象矢量化

通常地，人们通过图形扫描仪，直接把图形（如工程图纸）和图象（如照片、广告画）扫描到计算机中，以象素信息进行存储表示。要将这些图象中以象素表达的图形信息，转化为真正的矢量图形信息，就需要进行图形化的过程——图象矢量化，从图象中识别重建矢量图形。

当然，人们也可以用手工描图的方法，在计算机中直接绘制图象轮廓，获得矢量图形。手工描图过程也称为“手动抄图录入”。用户只要熟练应用CAD中的绘图命令就可以实现手工描图。图象矢量化相对要复杂得多。传统上，图纸扫描输入和识别重建的基本处理步骤是：

1） 利用光电元件逐行扫描线画图，获得图纸的计算机象素信息表达——数字图象。

2） 去除噪声，即图纸上的污点、线段上的毛刺和断裂等。

3） 矢量化，即从图象中找出所有的线段，并根据各线段之间的连接关系生成相关的图形；

4） 校正图形，修补线条，生成有用的CAD系统格式文件。

描图与图象矢量化的优缺点比较，如表1所时：

表 1 描图与图象矢量化的比较

 | 图象矢量化 | 描图
生成图形速度 | 快，由系统自动计算生成 | 慢，需要用手工逐个线段地输入
生成图形质量 | 1) 与图象的质量有关； 2）与矢量化计算的算法有关；一般地，从整体上，生成的轮廓曲线能较好地反应图象中图形的形状；但是可能会损失图形的局部形状质量； | 根据描图者对图形的把握，可以绘制出高水平的图形；
图形编修工作量 | 需要对矢量化后的图形进行必要的编修，方可获得高质量的图形。 | 根据描图者绘图过程对图形形状的控制，可对图形进行编修，也可以不编修，绘图者可自行决定。

在JDPaint系统中，图像输入可以通过图象文件的输入或者图象扫描功能实现，该部分参见“数据输入输出”说明内容；第2、3步骤主要在图象矢量化工具命令中实现，第4步骤校正图形，通过图形节点边修工具实现，该部分参见“节点边修工具”说明内容。

本章主要叙述图象矢量化工具的用法和如何使用绘图命令手工描图。


图象矢量化

12.1 图象矢量化

在JDPaint系统的图象矢量化工具中，提供了两种图象矢量化功能：阈值矢量化和颜色矢量化。阈值矢量化是指按图象的颜色灰度阈值对图象进行二值化处理，进而提取该二值化图象中的轮廓边界曲线或者中心线。颜色矢量化是指按指定颜色，提取图象中该颜色区域的轮廓曲线或者中心线。

点击状态工具栏中的图象矢量化工具按钮“ [image] ”，进入矢量化工具状态，操作界面右侧弹出导航工具栏，如图12-1所示。

颜色精度 | 指在彩色矢量化过程中，对相似颜色分辨的精度。颜色精度主要用于控制颜色拾取时相近的颜色都能被拾取上。颜色精度小，系统拾取相近颜色的范围越小；颜色精度大，系统拾取相近颜色范围越大。
按阈值提取轮廓 | 按颜色灰度阈值方式提取图象中指定的灰度区域。
效果预览 | 图象中矢量化区域确定后，点击“效果预览”按钮，可观察到当前图象矢量化的预览效果。
生成图形 | 图象中矢量化区域确定后，点击“生成图形”按钮，生成当前图象的矢量化图形。
选项设置 | 用于设置矢量化计算参数。


颜色矢量化

12.1.2 颜色矢量化

对一个颜色区域边界比较清晰的图象，有必要提取图象中指定颜色区域的边界曲线或中心线。颜色矢量化功能正是在这种背景上提供的，颜色矢量化功能特别适合于浮雕墨稿、高频模墨稿等图象的边界轮廓提取。

图12-4 矢量化提取轮廓边界线

图12-5 矢量化提取中心线

实现方法：

（1）选中图象对象； （2）用鼠标点选图象需提取轮廓的颜色区域；

（3）点击“生成图形”按钮，生成矢量化图形。

* 操作步骤：

1)选择图象对象：

在图象矢量化工具状态，用鼠标左键点击图象对象，使图象处于选中状态。

2）用点选图象的颜色区域：

用鼠标左键点击图象中需矢量化的颜色区域，屏幕中出现被选区域轮廓曲线的闪烁现象，该轮廓曲线既为要提取的轮廓曲线。

 | 拾取使用技巧： | (1) 用鼠标再点击当前颜色区域，取消当前颜色区域选择。 (2) 按Esc键也取消当前颜色区域选择。 (3)按Ctrl+鼠标左键点击，完成多种颜色选择，此时所选的颜色区域为多种颜色区域的并集。
3）点击“效果预览”按钮： |  | （用户可以省略这一步，直接进入下一步操作。） 点击 [image] 按钮，可以观察到当前生成指定轮廓曲线图形的预览效果。如果生成的图形效果不好，用户可以重新点击，拾取新的颜色轮廓曲线或者中心线；或者点击 [image] ，设置新的矢量化计算参数。

4)点击“生成图形”按钮：

点击 [image] 按钮，生成指定轮廓曲线图形。


阈值矢量化

12.1.1 阈值矢量化

通过对图象进行二值化处理，获得图象中指定区域的边界轮廓或中心线。阈值矢量化适合于各种类型的图象，特别是图象颜色灰度变化比较明显的图象对象。

图12-2 阈值矢量化

实现方法：

（1）选中图象对象； （2）选择按阈值提取轮廓命令；

（3）设定图象灰度阈值，并确定； （4）点击“生成图形”按钮，生成矢量化图形。

* 操作步骤：

1)选择图象对象：

在图象矢量化工具状态下，用鼠标左键点击图象对象，使其处于选中状态。此时 [image] 按钮由灰变亮。

2)选择按阈值

提取轮廓命令：

用鼠标左键点击 [image] 按钮，弹出阈值矢量化对话框，如图12-3所示。设置阈值矢量化中的阈值参数，并确定，屏幕中出现被选区域轮廓曲线的闪烁绘制，该轮廓曲线既为所用户指定要提取的轮廓曲线。

图12-3 “阈值矢量化”对话框

黑色区域： | 选中黑色区域，系统将自动提取图象中黑色区域的轮廓。
白色区域： | 选中白色区域，系统将自动提取图象中白色区域的轮廓。
阈 值： | 图象灰度阈值，是图象黑白颜色的区分值。图象灰度在0至阈值之间的象素为黑色，其余为白色。阈值的取值范围为0-255之间。一个象素的灰度阈值计算公式如下： 设象素的颜色为(RGB)，则 象素的灰度阈值 = (R*30 + G*59 + B*11) / 100
3)点击“效果 预览”按钮： | （用户可以省略这一步，直接进入下一步操作。） 点击 [image] 按钮，可以观察到当前生成指定轮廓曲线图形的预览效果。如果生成的图形效果不好，用户可以重新点击 [image] 按钮，提取新的轮廓曲线或者中心线；或者点击 [image] ，设置新的矢量化计算参数。
4)点击“生成图形”按钮： |  | 点击 [image] 按钮，生成指定轮廓曲线图形。


矢量化计算设置

12.1.3 矢量化计算设置

在上述矢量化过程中，在点击“生成图形”按钮之前，可点击“效果预览”按钮，察看矢量化的结果，如对效果不满意，可调整矢量化计算选项设置，或者重新提取图象轮廓曲线。

点击选项设置 “ [image] ” 按钮，弹出“矢量化计算设置”对话框，如图12-6所示，调整矢量化计算设置参数，获得较好的矢量化效果。

图12-6“矢量化计算设置”对话框

参数说明：

参数 | 子选项 | 功能说明
区域提取 |  | 设定当前矢量化提取图象区域曲线类型。
 | 轮廓线 | 提取图象区域的边界轮廓曲线，如图12-4所示。
 | 中心线 | 提取图象区域的的中心线，如图12-5所示。
图形路径 |  | 设定图形数据点的曲线化方法。
 | 直线拟合 | 使用直线（或者折线）优化逼近轮廓曲线。
 | 曲线拟合 | 使用样条曲线和直线段优化逼近轮廓曲线。
 | 拟合精度 | 曲线拟合精度控制，取值范围在0.7—5.0象素之间
图象去噪 |  | 在提取图象轮廓之间，对图象进行去噪处理
 | 边界光滑 | 通过图象侵蚀算法（膨胀与腐蚀算法）处理，使图象轮廓边缘变得光滑。 适用场合：当图象的轮廓边缘很不光滑，有许多噪声时，通过图象边界光滑，消除一部分噪声，获得较光滑的边界效果。
 | 消除噪声 | 消除图象中的噪声，取值范围在1—80象素之间。消除噪声计算方法： 当消除噪声选项取值为10时，将删除色块区域面积小于10个象素面积以下的所有小色块。 适用场合：当图象中有许多斑点，或着有许多不必要的小色块时，可通过消除噪声功能删除图象中的小色块。


描图

12.2 描图

手工描图也是一种将图象轮廓直接转化为矢量图形的重要方法。描图过程也称为“手动抄图录入”。对于图形比较简单，且使用图象矢量化后得到的轮廓图却非常粗糙，可通过描图得到图象的轮廓图形。

在JDPaint系统中，描图使用的工具是“绘制”中的“多义线(Y)”命令，“多义线”中的命令提供了绘制直线、圆弧、样条曲线等功能，绘制的线段可以是连续、闭合或者是光滑的。利用了多义线的这种功能，利用直线、圆弧或样条曲线对图象的轮廓进行拟合，可以快速地生成图形轮廓。在“绘制”一章中我们已经对绘制“多义线”的命令进行了详细的讲解。

下面，我们举例说明使用“多义线”对图象进行描图的方法。

例 使用“多义线”对如图12-7所示的图象进行描图，得到图象的轮廓图。

图12-7 描图

操作步骤如下：

⑴ 启动多义线命令。绘制(D)→多义线(Y)→[H]样条曲线。

⑵ 首先描图象的外轮廓，把图象放大，从图象米老鼠的下巴开始描，如图12-8所示。

图12-8

⑶ 然后沿着图象的外轮廓定义样条曲线的控制点，控制点的位置要选择的合适，使样条曲线的变动正好与图象的轮廓吻合为最佳位置，如果感觉上一步确定的控制点的位置不是很理想，就使用“取消一步”，把上一个控制点取消掉，再继续绘制，如图12-9所示。

图12-9

用这种方法可以一直绘制到米老鼠的耳根部位，如图12-10所示。

这时点击右键，结束上一段样条曲线的绘制，如图12-10所示，上一段样条曲线变为图形状态，鼠标的移动对它已经没有影响，这时就可以继续下一段样条曲线的绘制，如图12-11所示。

图12-10 图12-11

这样一直绘制到起点位置，“闭合结束”绘制命令，外轮廓描完。如图12-12所示。

图12-12

同样，描完外轮廓，再描内轮廓，最后得到图象的轮廓图形，如图12-13所示。

图12-13

说明：

1）当然在描图的过程中，可以根据情况选择使用“多义线”中的“绘图”命令，比如，在描米老鼠的耳朵时，就可以使用“三点弧”、“首末点角度弧”、 “首末点半径弧”等，还可以使用“光滑连接”、“自动连接”等功能。

2）其实，描图只是把图象的外轮廓勾勒出来，得到的外轮廓还要经过“节点编辑”、“图形修边”等工具进行修边，得到更准确的轮廓图形。

3）同样，图象矢量化出来的图形也往往需要经过“节点编辑”、“图形修边”等工具进行修边，才能得到更准确的轮廓图形。


数据的输入与输出

第十三章 数据的输入与输出

一个JDPaint文件（*.jdp）包含了图形和刀具路径等数据，JDPaint系统图形和刀具路径可通过通讯以EN3D文件（*.eng）传送到CNC雕刻系统中。在前面部分我们已经讲述一些JDPaint 5.0的文件操作命令。本章我们着重阐述文件数据的输入与输出，涉及到的命令如图13-1所示。

图 13-1 数据输入/输出

输入 | 将其它系统的格式文件输入到当前JDPaint系统中。
输出 | 将JDPaint系统的图形数据中转换输出为其它格式文件。
扫描图象 | 应用图形扫描仪将图象扫描输入到JDPaint系统。
常用图库 | 通过JDPaint提供的常用图库输入图形到JDPaint系统。
打印 | 将JDPaint文件输出到打印机。


图形输入

13.1.1 图形输入

在“常用图库”对话框中，操作者可使用鼠标选取图案类型和浏览图库中的元素，若有需要的图案，直接使用鼠标就可拖出来。

具体操作步骤如下：

⑴ 通过鼠标点击图库类型图标 [image] ，选择图库元素类型。

⑵ 使用鼠标点击垂直工具条浏览库中的元素。

⑶ 使用鼠标选取所需图库元素，然后按住鼠标，拖动鼠标将图形元素移出图库进入绘图区域。

⑷ 释放鼠标左键，该图就被选出放在了绘图区内。

如果“原始尺寸”选项被选中，那么图形拖出后保持图形原有的宽度、高度尺寸，如果去掉该选项，可根据实际要求进行尺寸的设定。如图13-3所示。

图 13-3 修改图形尺寸

点击对话框中的〖关闭〗按钮退出“常用图库”对话框。

常用图库操作只能在“图形选择工具”状态中进行，其它状态不能使用。

下图13-4中几个商标都是从图库中获得的：


用户建库

13.1.2用户建库

我们不仅能从图库中获得图形，还能往里面添加设计好的图形，以便以后随时取用。有时候这种取图方法比从文件中打开还要方便快捷。

建库的操作步骤如下：

⑴ 用鼠标点击“常用图库”对话框的“ [image] ”按钮，系统弹出“用户建库”对话框，框中缺省库名为“USER”，用户可输入自己喜欢的图库名称。

⑵ 点击〖确定〗，系统回到“常用图库”对话框，等待用户加入图库元素，如图13-5所示。

图 13-5 用户建库

⑶ 用鼠标选取工作窗口中的图形，再点击对话框中的 [image] 按钮，系统弹出如图13-6所示的“加入图形”对话框。用户可在该对话框中的“图形名字”输入框中为加入的图形取一个名字。图形加入到图库后，成为一个图库元素。

图 13-6 加入图形

如果对加入的图库元素不满意，可用鼠标选取该图库元素，点击 [image] 按钮，即可将图库元素从图形库中删除。

如果对新建的图库不满意，可用鼠标选取该图库，点击 [image] 按钮，即可将图库删除。

“加入图形”、“删除图形”、“删除图库”操作只针对用户自建的图库才能使用。 对于系统提供的图库或图库元素，则不能进行加入或删除操作。


常用图库

13.1 常用图库

绘图和设计过程中，我们可能要用到花边、商标、动物等等图形，为了方便大家设计和绘图，JDPaint在文件菜单下的“常用图库”中提供了2000余种平面图案库，这些图案包括的内容有：

l 动物

l 工具

l 公共标牌及路标

l 广告

l 花边

l 箭头

l 交通工具

l 卡通画

l 人物肖像

l 商标–1

l 商标–2

l 衣物

l 杂项

l 植物

用户首先进入图形选择工具状态，用鼠标点击“文件”菜单下的“常用图库”命令，系统弹出“常用图库”对话框，如图13-2所示。


打印

13.2 打印

文件打印是Windows系统标准的文件操作功能之一。JDPaint对打印功能的支持是通过Windwos系统支持进行的，也就是说，安装在Windows上的系统打印机可作为JDPaint的打印机。打印实际上是将JDPaint文件输出到打印机的过程。

通过点击“文件”菜单下的“打印”命令即可弹出“打印”对话框，如图13-7所示，点击确定即可完成文件打印。


打印机及其属性

13.2.1 打印机及其属性

选择打印机设备：

名称（N） | 显示与计算机相连的打印机。
状态、型号、位置、备注 | 显示当前打印机的状态、型号、与计算机的接口等信息。
设置打印的份数 | 参数设置完毕以后，通过点击〖确认〗按钮，开始打印图形。

打印机“属性”设置：可设置打印机的“纸张、图形、字体、设备选项”等，点击〖属性〗按钮，即可弹出“打印机属性”对话框。如图13-8所示。

图 13-8 打印机的属性

“纸张”对话框 | 可设置打印机的“纸张、打印方向、纸张来源、介质选择”等。
“图形”对话框 | 可设置打印机的“分辨率、抖动情况、浓度、图形方式”等。
“字体”对话框 | 可设置TureType字体按照位图或图形的方式打印。
“设备选项”对话框 | 可设置打印机的“打印质量、记录打印机内存”等。


打印范围及其页面设置

13.2.2 打印范围及其页面设置

“打印”对话框中可以设置打印范围：全部打印还是选择打印。通过点击页面设置还可弹出“页面设置”对话框，如图13-9所示。

图 13-9 页面设置

打印的“页面设置”对话框可以设置打印的页面属性，如位置、大小、比例、边距等等，这些设置是本系统提供的功能。点选“预览”，则可在显示区观察到打印输出的效果图，框中参数解释如下：

边距 | JDPaint中设置的页面边界与设置纸张边界的距离。
比例 | 表示打印出的图形较原图的倍数，此值为1，表示与原图1：1，此值大于1，表示放大，小于1表示缩小。
布局 | 打印图形在纸张的位置，一般取中心。上边和左边的数值表示打印图形距离JDPaint设定边界的距离。


扫描图象

13.3 扫描图象

扫描图象是应用图形扫描仪直接把图形（如工程图纸）和图像（如照片、广告画）扫描输入到JDPaint系统中，以象素信息存储在图象对象中的过程。不同的扫描仪厂商提供的程序界面是不同的，JDPaint系统提供了统一的扫描仪输入接口，由菜单命令“文件（F）→扫描图象（C）”来执行扫描功能。

图象扫描的操作过程：

⑴ 点击“文件（F）→扫描图象（C）”。

⑵ 系统打开图如图13-10所示对话框。

图13-10 扫描仪设备输入接口

⑶ 在此对话框中选择可用的扫描仪驱动软件。然后点击〖Select〗按钮，就弹出对应的扫描仪的操作界面，按照扫描仪的操作步骤进行扫描即可，一般要经过“预览”、“选择扫描范围”、“设置扫描点数（分辨率）”、“扫描”、“关闭操作界面”等几步，扫描后的图象落在JDPaint的绘图区。

说明：

1）我们在扫描时由于图片放置的不够端正，扫描下来的图象会出现歪斜、颠倒的现象，此时我们要对图象进行“图象处理”。

2）图象的颜色模式和尺寸，应根据将要在JDPaint中所做的应用进行相应的设置。


输入与输出

13.4 输入与输出

输入/输出功能使JDPaint软件系统与其它专业软件之间的数据交换成为可能，使得JDPaint可以充分利用其它专业软件所做的设计和加工数据，增强了JDPaint与其它软件的数据共享能力，大大地延伸了JDPaint的功能。

目前，JDPaint可支持的输入/输出的文件格式类型有：

类型 | 文件格式 | 输入 | 输出
二维图形 | DXF Files (*.dxf) |  |
 | EPS Files (*.eps) |  |
 | AI Files (*.ai) |  |
 | HP-GL Plotter Files (*.plt) |  |
 | GERBER Files (*.gbr) 印刷线路板文件 |  |
点阵图象 | Bitmap Files (*.bmp) |  |
 | JPEG Files(*.jpg) |  |
 | PNG Files (*.png) |  |
 | TIFF Files (*.tif) |  |
 | PCX Files (*.pcx) |  |
文本格式 | Text Files (*.txt) |  |
三维图形 | VRML Files (*.wrl) 虚拟现实造型语言文件 |  |
 | DXF3D Files (*.dxf) |  |
 | IGES Files (*.igs) |  |
 | STL Files (*.stl) |  |
加工数据 | Excellon Files(*.drl) 印刷线路板文件 |  |
 | En3d Files (*.eng) 精雕雕刻文件 |  |
 | WEDM Files(*.dat) 线切割数据文件 |  |
 | 3B Files(*.3B) 线切割加工文件 |  |
系统文件 | JDPaint Files(*.jdp) 精雕设计文件 |  |
 | En3d Files (*.eng) 精雕雕刻文件 |  |

文件“输入”与文件“打开”不同：

文件“输入”不破坏当前的工作环境，新输入的数据与原设计并行存在，输入的数据独立成块不影响原设计数据；而“打开文件”同开始一个新设计一样，破坏当前的工作环境，然后将工作环境全部交给新打开的图形数据。

文件的输入/输出命令由“文件(F)”菜单下的“输入(I)”/“输出(E)”菜单项完成。

图 13-11 输入/输出菜单命令

本文通过以下几部分说明JDPaint系统的输入输出功能：

1、输入输出命令交互过程

2、图象文件格式说明

3、二维图形文件格式说明

4、文本文件格式说明

5、加工数据文件格式说明

5、三维图形文件格式说明


输入/输出交互过程

13.4.1 输入/输出交互过程

在JDPaint系统中，所有文件输入的过程都是类似的，同样地，所有文件输出的过程也是一样的。本节通过举例说明文件输入/输出操作过程，使读者可以做到举一反三。

例一 输入一个BMP图象。

操作过程如下：

⑴ 点击菜单命令“文件(F) → 输入(I) → 点阵图象(G)”。

⑵ 系统弹出“输入”对话框，如图13-12所示。

图13-12

对话框的右侧有一个“预览”选项，如上图所示，如果有“√”标记，则表示在“打开”图象前，在预览窗口中显示图象。如果无“√”标记，则表示在预览窗口中不显示图象。

⑶ 在“输入”对话框的“文件类型”列表框中，点击 [image] 按钮，弹出JDPaint所能输入的所有点阵图象的文件类型格式，选取要输入的文件格式，例如BMP位图格式的文件，文件类型为*.bmp。如图13-13所示。

图13-13

⑷ 用户选择了文件格式后，系统在对话框中列出了当前目录下的相应文件。这时，用鼠标选择要输入的文件。

⑸ 点击〖打开〗按钮。待文件打开后，用鼠标在绘图区拾取一下，以确定图象放置的位置。

经过以上操作，图象文件就可以输入到JDPaint中。JDPaint中所有文件的输入步骤都与此例雷同。

例二 输出一个BMP图象

文件输出的过程如下：

⑴ 在JDPaint主界面下使用鼠标选取“文件（F）→输出（E）…”菜单项。此时系统弹出文件“输出”对话框，如图13-14所示。

图13-14

⑵ 在文件“输出”对话框的“保存类型”列表框中，选择将要生成的文件类型，并在“文件名”编辑框中，键入文件名。

在“输出”对话框中的输出方式中有两个选项：

[全部输出] 和 [选择输出]：

如果选择了[全部输出]，则输出所有图形。

如果选择了[选择输出]，则只输出被选择的图形。(如果要输出被选择的图形，则在输出操作前，应首先选择图形，再选取菜单命令“文件（F）→ 输出（E）…”。

⑶ 选取〖保存〗按钮。图形即被输出到文件。

经过以上操作，JDPaint中的图形数据就可以保存为相应格式的数据文件，提供给其它软件系统使用。


图象文件格式

13.4.2 图象文件格式

1、 BMP位图文件

文件后缀名，*.bmp。

BMP图象文件格式是微软公司为其Windows环境设置的标准图象格式。BMP是英文BitMap(位图)的缩写。随着Windows在世界范围的不断普及，BMP文件格式无疑也已经成为PC机上的流行图象文件格式。BMP文件适合于所有的图象存储，但BMP文件对图象的压缩比不高，因此文件尺寸较大，不利于传输和存储。

JDPaint可以输入Windows版本的BMP位图文件，对于Macintosh计算机和其他操作系统下生成的图象，则应当存贮为Windows版本的位图文件。

2、JPEG图象文件

文件后缀名，*.jpg。

JPEG是英文Joint Photographics Experts Group(联合摄影专家小组)的首字母缩写。JPEG格式文件是经过压缩后保存的图象，因此文件的尺寸较小，有利于保存和传输。

JPEG压缩是有损压缩，也就是说JPEG经过压缩后得到的图象和压缩前的图象略有差异。JPEG格式文件可以适用于大部分的图象，但也有一些图象类型是不适用的。例如，由于JPEG文件不能很好地处理具有突出边界的图象类型，所以由计算机所画的具有突出边界的这一类图象，处理效果则不是很好。而对于处理一张由摄影师得到的照片来讲，到目前为止，JPEG格式文件是最好的图象存储格式。

3、TIFF图象文件

文件后缀名，*.tif。

TIFF是英文Tagged Image File Format（标记图象文件格式）的首字母缩写。它是一种通用的位映射图象格式之一。

TIFF文件在设计的最初并不是针对某一个具体的操作平台的，也不是针对某一个具体的应用软件。所以在不同硬件之间的修改和转换都是十分容易的，例如一般的PC机和Macintosh机之间，TIFF文件可以进行相互转换和移植。

正因为TIFF文件具有以上所述的优点，同时也带来了一些不可避免的缺点。由于它支持不同的平台和不同的软件，所以，它的结构是多样的、可变的。于是，它就有多种的压缩存储方式，这就给解压TIFF文件带来了很大的麻烦和困难。不可能存在一种软件，能够打开任意的TIFF文件。

TIFF文件具有不同的版本，最新推出的是6.0版本。对于早期的5.0版本和4.0版本的TIFF文件，使用JDPaint输入时可能会出错。

因此，在这些情况下，可以试用别的图象处理软件如PhotoShop等，来打开文件并将其存为BMP文件后，再输入到JDPaint中。

4、PNG图象文件

文件后缀名，*.png。

PNG图象文件的全称是Portable NetWork Graphics（便携式网络图形）。它是为了适应网络数据传输而设计的一种图象文件格式。用于取代格式较为简单、专利限制严格的GIF图象文件格式。而且，这种图象文件格式在某种程度上甚至还可以取代格式比较复杂的TIFF。现在，PNG图象文件格式主要用于网络传输以及图象编辑，主要有以下优点：首先，PNG图象文件格式的压缩效率在绝大多数情况下高于GIF图象文件格式，一般可高出5%到20%。其次，PNG图象文件格式采用无损压缩算法处理图象数据。在图象编辑过程中保存的数据，在重新恢复后，不会象JPEG图象文件格式一样损失原始图象质量。而且，PNG图象文件格式提供多达48位真彩色图象或者16位灰度图象描述。

PNG图象文件格式主要支持3种图象类型：真彩色图象、灰度级图象以及颜色索引数据图象。

5、PCX图象文件

文件后缀名，*.pcx。

PCX图象文件格式最初为Zsoft公司的PaintBrush应用程序所使用，目前已成为一种通用的图象文件格式。PCX文件格式可处理单色、16色和256色图象数据，文件由文件头、图象数据与可选扩展调色板数据组成。


二维图形文件输入

13.4.3 二维图形文件输入

1、DXF二维图形文件的输入

文件后缀名，*.dxf。

DXF是英文Data eXchange Format（数据交换格式）的大写字母缩写，是由AutoCAD软件的制造商制定的图形文件存储格式。随着AutoCAD软件十多年来的不断发展，全世界范围内使用AutoCAD的用户也越来越多。因此，作为AutoCAD图形存储格式的DXF文件，也成为了一种事实上的图形文件标准。

不仅AutoCAD软件可以将图形保存为DXF文件，其它几乎所有的绘图软件如CorelDraw、FreeHand、Illustrator等等都可以将图形保存为DXF文件。

DXF文件的格式，经历了AutoCAD软件从1.0版本到现在的AutoCAD2000历次升级变化，不同的版本的AutoCAD软件，输出的DXF文件会有所不同。

JDPaint支持从AutoCAD12.0到AutoCAD2000生成的DXF文件。

DXF二维文件可以存储多种图形元素，目前可以输入到JDPaint软件中的图形元素有：点、直线、圆弧、圆、椭圆、样条曲线、多义线、文字、块。网格面和3DFace等一些三维对象不能读入。三维点、直线、圆弧、椭圆、样条线和多义线将被转为二维图形。文字对象可以读入，但其字体将发生改变。

图层信息也可读入。需要留意的是一些图层的颜色为白色，由于JDPaint环境的背景也为白色，这将导致这些图层内的图形读入后不可见，让人误以为读入图形发生了丢失。这时只要改变一下图层的颜色就能看到相应的图形。

由于建筑图形的坐标和尺寸值一般都很大，很容易超出JDPaint环境的允许尺寸范围，导致输入图形混乱。输入图形之前，需要检查图形的坐标和尺寸是否在允许范围内，尤其需要留意的是图形的坐标，因为很多时候图形的尺寸本身并不大，但其绝对坐标值却很大。当图形的尺寸过大时对图形进行一定比例的缩小，当图形的坐标过大时将图形的中心平移到离坐标原点较近的地方。

选择输入的文件名后，系统弹出“DXF文件输入”对话框，如图13-15所示。

这些参数的含义是：

自动连接断点 | 当读入的图形包含很多散乱的线条时，选择该选项可以把一系列首尾相连的线条连接成一条多义线，这样就可以减少加工时的抬刀次数。
连接精度 | 进行自动连接断点操作时，如果两条线段端点间的距离（间隙）小于设定的“连接精度”，则认为它们是相连的，并把它们组成一条多义线。 应当设置一个适当的连接精度值。连接精度值太大可能会发生误连接（把不该连接的线段连接上了），连接精度值太小则可能会发生漏连接（该连接的线段没有连接上）。
处理多义线 线宽 | DXF文件中有的多义线是带有宽度的。若不选该选项，读入文件时将忽略多义线的线宽。选中该选项，读入文件时将按多义线的线宽对多义线进行膨胀，这可能会花费一些时间。
焊接带宽 多义线 | 只有选中“处理多义线线宽”选项时该选项才有意义。选中“处理多义线线宽”选项后再选中该选项表示要对膨胀后的多义线进行焊接。注意当带宽多义线数目较多时焊接过程可能会耗费较多时间，而且结果可能会出错。建议先不焊接带宽多义线，等图形读入后根据需要再选择部分带宽多义线进行焊接。
尺寸单位 | DXF图形文件本身是不包含尺寸单位信息的，因此读入时需要指定图形文件的尺寸单位，要保证输入图形尺寸与输出前一致，所选择的输入尺寸单位必须与输出尺寸单位一致。当输入的图形尺寸很大而导致图形无法正常读入时，可以采用“自定义比例” 选项，并输入一个较小的比例值。

2、HP_GL/2 PLT文件的输入

文件后缀名，*.plt。

HP_GL/2 PLT文件是一种支持绘图机的矢量图形文件。由于支持绘图机，所以文件格式简单，图形元素单一，主要由直线段组成。

而其它图形元素，如曲线、文字等，由软件在保存图形为PLT文件时，将其离散为小直线段，用小直线段来表示。

由于以上原因，当把PLT文件输入到JDPaint时，所有图形均由直线段组成。也是同样的原因，PLT文件在由JDPaint输入时，可将原图形中的所有元素，一个不漏的输入进来。

使用PLT文件作为JDPaint与其他软件的数据交流接口，非常稳定，不容易丢失图形，但在输入输出过程中无法保持曲线信息，造成图形精度和数据量增大的问题，同时，输入图形存在大量节点，也会在软件中导致编辑处理的困难，甚至影响数控加工的精度和效率。

常用的平面设计软件如CorelDraw、FreeHand等都能生成PLT文件。但由于以上提到的PLT作为数据接口的优缺点，除非确有必要，我们建议应使用更为先进的、能在输入输出过程中最大限度保持曲线信息的“AI”或“EPS”作为数据接口。

3、EPS文件的输入

文件后缀名，*.eps。

EPS是英文Encapsulated PostScript（封装的PostScript）的缩写，是用PostScript语言描述的一种ASCII图形文件格式。PostScript是专门为打印图形和文字而设计的一个页面描述语言，它与打印的介质无关，不管您是在纸上和胶片上进行打印，还是在屏幕显示都适合。PostScript是由Adobe公司在1985年提出来的，主要目标是提供一种独立于设备的能够方便地描述图像的语言，文件本身只是用PostScript语言描述了所要显示或者打印的图像有哪些特征、参数，在显示或者打印PostScript文件的时候，再由PostScript解释器解释执行，进行具体的打印或者显示，得到所要的图象。现在有很多打印机上带有PostScript语言解释器，可打印出高品质的图形图像，最高能表示32位图形图像。PostScript语言经历了1和2两个版本，现已经发展到3版本。EPS文件描述了单个页面的显示，它用来被插入到别的PostScript语言描述页面文件中。EPS文件格式经历了1.2和2.0两个版本，目前已发展到3.0版格式。

几乎所有的平面设计软件都支持EPS文件的输入输出，如Illustrator、CoreDraw和FreeHande等；另外一些CAD软件也支持EPS文件，如AutoCAD、TurboCAD等。

EPS文件中包含矢量图形、图象、文字和区域填充等元素。目前JDPaint 5.0只支持EPS文件中的矢量图形部分的输入，支持1.2、2.0和3.0 三种EPS文件格式，同时支持PostScript3中的绝大部分指令。输入到JDPaint中的图形元素将保持原来的尺寸和颜色属性。

对于图形中的文字，建议用户在输出EPS文件前将文字转换为图形路径，或在输出EPS文件时选择将文字转换为图形路径选项。对于有颜色填充和图案填充的区域轮廓的输入，在输出EPS文件前应确保轮廓曲线的存在。对于颜色填充、图案填充和图象填充等JDPaint一般不予输入。

选择输入的文件名后，系统弹出“EPS文件输入”对话框，点击对话框中的“文件信息”按钮，将显示出此EPS文件的类型、EPS版本号、PostScript语言版本号、文件标题、文件输出系统、创建时间、文件总字节数、文件中包含的PostScript语言段字节数和文件中图形边界盒大小等信息。如图13-16所示。点击确定按钮后，如果文件较大，则出现等待光标 [image] ，提示用户系统正在读取文件，请稍候。

图13-16 EPS文件输入对话框

注意：由许多图像处理软件（如PhotoShop、Photo-Paint等）输出的EPS文件文件中只包含图象信息，将没有图形数据输入到JDPaint中。在通过EPS文件输入图形元素到JDPaint系统中时，建议用户将图中的图像、区域填充等元素删除掉，这样可提高EPS文件的读取速度。

4、AI文件的输入

文件后缀名：*.ai。

AI文件是著名Adobe公司推出的一款广泛应用于平面设计领域的矢量图形软件Illustrator生成的图形文件，目前的最新版本为R10版。AI字母便是英文Adobe Illustrator首字母缩写。几乎所有的平面设计软件都能支持AI文件的输入输出，如CorelDraw，FreeHand等。

AI文件中包括矢量图形、图像、文字和区域填充等元素。目前JDPaint 5.0只支持ai7.0或7.0以下的文件版本中的矢量图形元素的输入，输入到JDPaint中的图形元素将保持原来的尺寸和颜色属性。因此在别的系统中要输出AI图形文件到JDPaint时，一定要注意输出的文件版本为7.0或7.0以下。

在对于图形中的文字，建议用户在输出AI文件前将文字转换为图形路径，或在输出AI文件时选择将文字转换为图形路径选项。对于有颜色填充和图案填充的区域轮廓的输入，在输出AI文件前应确保轮廓曲线的存在。对于颜色填充、图案填充和图象填充等JDPaint一般不予输入。

选择输入的文件名后，系统弹出“AI文件输入”对话框，点击对话框中的“文件信息”按钮，将显示出此AI文件的版本号、文件标题、文件输出系统、创建时间及文件中图形边界盒大小等信息。如图13-17所示。

图13-17 AI文件输入对话框

5、Gerber文件的输入

文件后缀名，*.gbr。

Gerber文件是印刷电路板（PCB）行业常用的数据交换格式，通常也被称为“光绘格式”。大多数PCB设计和加工软件都可以输出Gerber文件。

Gerber文件的内容主要包括线路板上的元器件﹑连线和孔洞等图形的信息。

目前JDPaint软件支持RS274D、RS274X和FIRE GXXX三种格式的Gerber文件。

选择输入的文件名后，系统弹出“参数设置”对话框，如图13-18所示。

图13-18 GERBER文件输入对话框

这些参数的含义是：

格式种类 | 可以选择RS274D、RS274X和FIRE GXXX三种格式的Gerber文件。
整数位数 | 文件内的坐标值的整数位数。与小数位数、补零方式一起用于设置文件内的数值的表示格式。
小数位数 | 文件内的坐标值的小数位数。
补零方式 | 当坐标值的有效数字位数不足（小于整数位数和小数位数的和）时的补零方式 1）前补零 位数不足时在数字前用0补足位数 2）后补零 位数不足时在数字后用0补足位数 3）不补零 位数不足时也不补零 4）小数点 采用带小数的数值表示方式
坐标类型 | 文件内的坐标值是采用绝对方式还是增量方式。
尺寸单位 | GERBER图形文件本身是不包含尺寸单位信息的，因此读入时需要指定文件图形的尺寸单位。
图层名 | 当前文件的图形读入后将放入的图层的名字。如果输入的是一个新图层名，则系统将新建一个以该名字命名的图层来放置该文件的图形，否则图形被存入指定的图层中。缺省图层名与文件名相同。
焊接多义线 | Gerber文件中的多义线一般为带宽多义线。系统读入文件时将按多义线的线宽对多义线进行膨胀。选中该选项表示要对膨胀后的多义线进行焊接。注意当带宽多义线数目较多时焊接过程可能会耗费较多时间，而且结果可能会出错。建议先不焊接带宽多义线，等图形读入后根据需要再选择部分带宽多义线进行焊接。

RS274X和FIRE GXXX这两种格式的文件内一般都包含了整数位数、小数位数、补零方式、尺寸单位以及坐标类型等参数信息，此时对话框内的参数设置将被忽略。RS274D格式的文件内则一般不包含参数信息，需要在对话框内正确设置各个参数，否则将导致读入的图形不正确。

RS274D文件格式一般不包含文件头，与文件格式有关的参数信息和预定义孔（DCode）信息，都需要用户事先输入。系统提供了一个对预定义孔的维护工具。如图13-14所示，当输入的Gerber文件缺少文件头时，系统会弹出“DCode设置”对话框，对话框内列出了Gerber文件中所有的未定义孔，用户可以对它们进行定义，定义完毕后可以将这些定义保存下来（点击“保存”按钮），下次输入Gerber文件时直接读取这些定义信息即可（点击“读取”按钮）。Gerber文件的详细格式说明请参考有关的规格定义文件。

图13-19 GERBER文件格式


文本文件输入

13.4.4 文本文件输入

TXT（*.txt）文本文件是一种ASCII码的可读文本格式文件，是通用的文本存储格式，在Dos和Windows操作系统上的所有文本编辑软件，都支持TXT文件的输入和输出。

TXT文件分为“带换行符的TXT文件”和“纯文本文件”。

目前JDPaint 软件支持纯文本文件。因此，如果输入的是“带换行符的TXT文件”，则JDPaint 在换行处不做处理，而当做一整行输入。


加工数据输入

13.4.5 加工数据输入

1、EN3D文件

En3d 文件是精雕机专用的加工指令文件，包括刀具名称、加工路径等加工信息，文件扩展名是ENG。该输入接口可以读取JDPaint3.0 、JDPaint 4.0和JDPaint5.0生成的En3d文件。

2、Excellon文件

Excellon文件是印刷电路板行业专用的加工指令文件，主要用来支持印刷电路板的数控钻铣加工。该输入接口可以读取Excellon Format II格式的文件，解释其中的刀具、钻孔、铣边等加工信息，文件扩展名一般是DRL。

选择输入的文件名后，系统弹出“Excellon格式II解释器”对话框，如下图13-20所示。

图13-20 Excellon格式II解释器

该解释器可以将Format II版本的Excellon PCB钻铣数据文件调入到JDPaint中，并自动生成刀具路径。这些刀具路径被JDPaint输出成为Eng加工文件后，可以使用精雕机在EN3D加工控制软件的控制下进行PCB的钻铣加工。

这些参数的含义是：

度量单位 | 表示Excellon数据所用的度量单位，有公制和英制两种选择。如果文件的格式非常标准，已有单位设定指令，可以不必自设，程序在作解释时会自动按文件的正确设置进行处理。
补零方式 | 表示Excellon数据所用的补零方式，有LZ和TZ两种选择。LZ即前补零（Leading Zero）方式，TZ即后补零（Trailing Zero）方式。如果文件的格式非常标准，已有补零方式指令，可以不必自设，程序在作解释时会自动按文件的正确设置进行处理。
整数位数与小数位数 | 表示Excellon数据所用的坐标（或尺寸）的解析方法。我们最常用的有32格式和33格式，前者即整数位数为3位，小数位数为2位，而后者即整数位数为3位，小数位数为3位。如果文件的格式非常标准，已有整数位数与小数位数定义指令，可以不必自设，程序在作解释时会自动按文件的正确设置进行处理。
坐标 | 本项不可以自己修改。表示坐标是绝对坐标还是相对坐标。
使用刀具 | 本项不可以自己修改。仅用于显示该Excellon数据使用（或定义）了哪些刀具。在开始时，这个列表项不显示任何刀具，只有在按一次“下一步”按钮后，解释器将Excellon数据的文件头进行了解释，列表项才能够显示此数据所使用（或定义）的刀具。
解释选项 | 表示需要调入Excellon数据中的那种类型数据。有两个选项：解释钻孔指令和解释铣切指令。如果前者被选中，解释器可以将钻孔数据解释调入，如果后者被选中，解释器可以将铣切数据解释调入，如果两者都被选中，解释器可以将钻孔数据和铣切数据都解释调入。

* 使用步骤：

（1）点击“下一步”按钮，解释器将Excellon数据的文件头进行了解释，并用Excellon数据中的相关参数定义修改解释器所使用的初始解释参数。再次点击“下一步”按钮，解释器将Excellon数据文件调入，

（2）选择解释器解释输入的刀具路径，输出为ENG加工数据文件，即可在EN3D中进行钻铣加工。注意：JDPaint 的（0，0）位置对应Excellon数据的零位，一般在刀具路径输出时应将输出原点定为（0，0，0），这样可以与Excellon数据的坐标可以保持一致。

说明：

本解释器目前可以解释大部分Format II版本的常用指令。以下是不支持的部分指令，遇到下述指令将中断解释：

M19 | 二进制码钻孔指令
M60和M61 | 参考放缩指令
M97和M98 | 钻字符指令
G82 | 双行线钻孔
G83 | 圆形8孔连钻
G84 | 连钻出较大的圆孔
G85 | 连钻出长形孔
G87 | 连钻出长形孔
P | P指令
所有的 Vision Assist 指令 |

以下是不解释的部分指令，遇到下述指令将忽略：

M06 | 条件暂停指令
M09 | 刀具检查指令
M18 | 刀尖检查指令
M47和M47 | 暂停并显示消息指令
G40、G41和G42 | 铣切补位指令

3、WEDM文件

WEDM文件是线切割行业较为常用的一种线切割数据交换文件。文件扩展名是DAT。文件包含了平面直线、圆弧、圆的图形信息。

4、3B和4B(R3B)文件

3B和4B(R3B)文件是线切割行业常用的加工代码文件，由于缺乏统一的标准，需要进行一些必要的格式配置（请参考“3B文件输出”中的说明）。文件包含了工件的线切割加工代码。

5、NC文件

NC文件是G代码格式的数控指令文件。该输入接口可以读取标准格式的NC文件，解释其中的换刀、直线插补、圆弧插补、钻孔等加工信息，文件扩展名一般是NC。

选择输入的文件名后，系统弹出“读取NC程序”对话框，如下图13-21所示。

图13-21 输入NC文件对话框

这个对话框含有一些控制输入文件和显示输入文件性质的参数。

这些参数的含义是：

文件列表框 | 列表框中显示了要输入到系统中的“*.nc”文件。一次可以选择多个文件。
[添加] | 点击这个按钮，可以从计算机中选择*.nc文件，选择的文件加在列表框中。
[删除] | 在列表框中选择一个文件，点击该按钮，则该文件就从列表框中删除。
[文件扫描] | 要察看输入路径的具体信息，点击这个按钮，系统会将该路径的尺寸、使用的刀具等信息显示在对话框的相应位置。
路径原点 | 该参数表示输入的路径在界面上的位置。该参数表示输入的路径在界面上的位置。XY坐标可以自定义，也可以从下拉框中选择位置，如原点、左上角、左下角、右上角、右下角或者中心等； Z坐标可以自定义，也可以从下拉框中选择位置，如原点、最高点和最低点等；。
[NC设置] | 点击“NC设置”按钮，弹出如图13-22所示的对话框，在这个对话框里，可以根据不同的机床，选择相应的数控加工指令，也可以修改这些指令。
[使用刀具] | 下拉框中列出了*.nc文件使用的刀具的编号，要想知道具体的刀具信息，可以点击匹配刀具按钮，弹出如图13-23所示的对话框，这个对话框中列出了刀具的具体信息。包括刀具的名称、类型和刀具参数等。刀具编号的列表框中列出了所有刀具的编号。在这个对话框中可以修改使用的刀具名称、刀具类型和刀具的参数。
路径尺寸 | 列出了要输入的NC文件的尺寸和坐标范围。
忽略慢速下刀 | 选择该复选框，就忽略了输入的NC路径中的慢速下刀信息。

点击[NC设置]按钮，系统弹出对话框，列举所有可以识别的NC指令，如下图所示。

图13-22 支持的数控指令

用户可以重新确定刀具的名称、类型和几何尺寸，如下图所示。

图13-23 修改刀具参数


三维图形输入

13.4.6三维图形输入

1、DXF3D文件

DXF 文件通常用于表示平面的图形，其实，DXF也可以表示三维的图形，这时，我们称之为DXF3D。JDPaint5.0可以读取DXF3D表示的点、直线、圆弧、圆、椭圆、样条曲线、多义线、块，三角片和网格曲面，不能读取其中的实体数据。图层信息也不能读入。

JDPaint支持从AutoCAD12.0到AutoCAD2000生成的DXF文件。

选择输入的文件名后，系统弹出“DXF3D文件输入”对话框，如图13-24所示。

图13-24 DXF3D文件输入对话框

这些参数的含义是：

输入类型 | 对话框中列出了系统可以输入的图形对象类型，用户可以根据需要去掉一些不感兴趣的对象类型。
尺寸单位 | DXF图形文件本身是不包含尺寸单位信息的，因此读入时需要指定图形文件的尺寸单位，要保证输入图形尺寸与输出前一致，所选择的输入尺寸单位必须与输出尺寸单位一致。当输入的图形尺寸很大而导致图形无法正常读入时，可以采用“自定义比例” 选项，并输入一个较小的比例值。

2、IGES文件

IGES文件是CAD系统之间交换几何数据的常用文件格式，JDPaint5.0可以读取IGES文件。

IGES 文件可以描述几乎所有的几何曲线曲面，但不同的CAD系统根据自身的需要，一般只能支持其中的一部分类型。JDPaint5.0的IGES输入接口可以接受下面这些几何元素类型：

圆弧(100)、组合曲线(102)、直线(110)、样条曲线(112)、变换矩阵(124)、NURBS曲线(126)、样条曲面(114)、直纹曲面(118)、旋转曲面(120)、扫描曲面(122)、NURBS曲面(128)、裁剪曲面(140)、等距曲面(144)等。

选择输入的文件名后，系统弹出“IGES文件输入”对话框，如图图13-25所示。

图13-25 IGES文件输入

这些参数的含义是：

文件名 | 选项修改输入文件名称。
忽略尺寸单位 | 忽略IGES文件本身的尺寸单位。
缩放比例 | 缩放几何模型的比例。
[图形单元] | 用于过滤输入的IGES单元。

点击[图形单元]按钮，系统弹出IGES单元对话框，用户可以剔除一些不需要输入的图形单元，如图13-26所示。

图13-26 IGES文件输入

3、VRML文件

VRML格式可以用于表示各种复杂的曲面模型，它是网络上描述几何模型的常用文件格式，许多CAD系统都可以输出VRML文件。VRML 经过多年的发展，产生了多个版本，JDPaint5.0可以读取 VRML 1.0和2.0版。

VRML图形文件本身是不包含尺寸单位信息的，因此读入时需要指定文件图形的尺寸单位。

4.、STL图象文件

STL 文件用于快速成形系统，它由一批三角片构成，可以逼近各种曲面和实体模型。STL文件有二进制和文本表示两种格式，JDPaint5.0软件可以读取这两种文件格式。


文件的输出

13.4.7 文件的输出

用户使用JDPaint软件设计的图形，若要在其他软件系统中使用，应将设计数据输出，生成可供其他软件系统读入的图形数据文件。

进行文件输出时，往往要针对特定的输出软件指定文件的一些格式参数。

1、3B文件的输出

JDPaint软件可以将系统中的二维图形输出为线切割加工3B或4B格式。

选择输出的文件名后，系统弹出“3B文件输出”对话框，如图13-27所示。

图13-27 3B文件输出

这些参数的含义是：

文件格式 | 线切割加工文件的格式以3B最为常见，格式也相对统一，但不同厂家的控制器能读入的文件格式常有一些细微差别。而4B和R3B格式则相对杂乱一些。因此在输出时需要根据实际情况设置好输出文件的格式。 系统提供了几种较为常见的3B格式作为预定义格式。对于其他的格式则可以通过用户自己配置的方式来定义为“自定义格式”，最大限度地适应用户的特殊要求。用户可以同时定义多种自定义格式。
曲线逼近精度 | 线切割加工文件中只能包含直线和圆弧信息，系统中的样条线必须离散为折线段。曲线逼近精度定义了离散的精度。
加入跳步代码 | 两段不相连的图形的加工代码之间是否需要加入跳步代码（连线的加工代码）。
显示输出的代码 | 输出结束后显示输出的代码。
格式种类 | 自定义文件格式的代码种类，分为3B和4B（R3B）两种。
格式名 | 给自定义格式起的名字。
允许最大圆弧半径 | 有的控制器对能加工的圆弧的最大半径有限制，当圆弧半径大于上限值时需要将其离散为折线段。
无空格分隔 | 输出的代码文件中不能包含空格。
暂停符 与 终止符 | 不同系统使用的加工暂停符和终止符可能不一样，可以在这里进行配置。
R+号表示符 与 R-号表示符 | 4B和R3B格式通常是在3B格式的基础上增加了圆弧的半径信息，半径值前的正负号通常用于表示圆弧的凹凸。但不同系统使用的正负号代码可能不一样，可以在这里进行配置。
半径R位置 | 4B和R3B格式中的半径值通常放在第一位，但也有的厂家把它放在第四位，可以在这里进行配置。


14.0

第十四章 测量图形

为了得到图形的精确尺寸，在图形编辑变换的过程中就需要知道它的尺寸大小，JDPaint提供有三种方法查看和测量图形的尺寸大小，分别是：

标尺显示

查看属性

测量功能


标尺显示

14.1 标尺显示

每当我们绘制完一个图形，结束绘制命令后，图形呈被选择状态，这时状态条显示了图形的类型、尺寸和高度。这就是使用“状态条显示”查看和测量图形尺寸的方法。

它的操作非常的简单、方便、快捷，只要选中将要被查看图形，提示条就显示出此图形的尺寸，如图14-1所示。

状态条包括如下内容：

（1）被选对象的个数：提示选择了几个对象，这里提示为“一个对象被选”。

（2）类型：被选对象的类型，类型显示只对单选时有效，选择一个以上的对象后就不再显示类型，这里显示为“多义线”。

除了圆和椭圆以外，其它任何图形，包括非闭合图形如直线、圆弧、样条和闭合图形如直角矩形、圆角矩形、正多边形、星形等图形一经绘制完成，就以“多义线”的形式存在，也就是说它的类型都属于“多义线”。

（3）尺寸：X、Y、Z是指被选对象在这三个方向的尺寸，这里“X100.00”是指矩形在水平方向上的长度是100毫米，同样“Y30.00”和“Z0.00”分别指矩形在竖直方向上的宽度是30毫米、矩形的高度是0。

（4）高度：被选对象的高度。我们在前面讲过JDPaint4.0是平面绘图机制，对于绘制的图形来说，只要没有经过空间变换，高度都是0，高度的概念在以后讲曲面时再具体讲解。


查看单个图形的尺寸

14.2.1 查看单个图形的尺寸

选中一个图形，点击右键，弹出如图14-2所示导航菜单。

图 14-2 右键导航菜单

用鼠标点击“对象属性”，弹出“属性”对话框，如图14-3所示。

图 14-3对象属性

1）“常规”对话框

“常规”对话框显示了图形的位置、尺寸、颜色等参数：

位置：显示了图形在坐标系中的位置，例如上图对话框中显示的图形在水平方向最左边对应的坐标值是：X= -26.938，最右边对应的坐标值是：X= 11.397；竖直方向最下边对应的坐标值是：Y= -2.59，最上边对应的坐标值是：Y= 28.492；因为是二维图形，所以高度方向对应的坐标值都是0。

尺寸：图形的长、宽、高。

颜色：显示线框颜色和闭合图形的填充颜色。

2）“对象”对话框

点击上图中的多义线处，又弹出如图14-4所示的对话框。

图 14-4 对象属性

显示了这个图形的名称、类型、属性、起点、末点等对象信息。


查看多个图形的属性

14.2.2 查看多个图形的属性

选中多个图形，查看它们的属性，如图14-5所示。

图 14-5 右键导航菜单

弹出如图14-6所示对话框，只显示“常规”对话框，而且常规对话框中也只显示图形组的位置和尺寸大小。

图 14-6 常规属性


14.3.0

14.3 测量功能

通过“状态条显示”和“查看图形属性”的方法只能得到图形的长、宽、高等尺寸，但是如果想查看图形的某一点的位置，两点之间的距离、图形的长度、角度，圆弧的半径、弧度等，就必须使用“测量”工具，点击“测量”弹出如图14-7所示下拉菜单。

图 14-7 测量功能

点： | 测量某一点的位置坐标。
距离： | 测量两点之间的距离。
长度： | 测量曲线的长度。
尺寸： | 测量图形的长、宽、高等尺寸。
两线角度： | 测量两直线的角度。
圆弧角度： | 测量圆弧的角度、半径等信息。
三点角度： | 测量三点的角度，即角（A，B，C）。

点击“查看”菜单中的“命令工具栏”，再点击“测量工具栏”，弹出测量工具条，各功能键所代表的命令如图14-8所示。

图 14-8 测量工具条


测量点坐标

14.3.1 测量点坐标

点击“测量点”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量点坐标：拾取测量点：”，使用捕捉特征点的方法捕捉要测量坐标的点，如图14-9所示，这里捕捉圆的圆心点。

图 14-9 测量点坐标

捕捉到点以后，点击左键，即可完成测量，提示条显示此点的坐标值，并且提示“拾取测量点”继续测量点： 。


测量距离

14.3.2 测量距离

点击“测量距离”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量距离：拾取第一点：”，使用“捕捉特征点的方法”捕捉要测量距离的第一点，如图14-10所示，这里捕捉圆的圆心点。

图 14-10 测量距离：拾取第一点

捕捉到圆心后，点击左键，提示条提示“测量距离：拾取第二点：”，使用“捕捉指定特征点的方法”捕捉矩形的中心点，如图14-11所示。

图 14-11测量距离：拾取第二点

点击左键，提示条显示这两点之间的距离，并且提示“拾取第一点”继续测量两点之间的距离： 。


测量长度

14.3.3 测量长度

点击“测量长度”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量长度：拾取曲线：”，用鼠标点击所要测量的曲线，如图14-12所示，这里测量一条样条曲线的长度。

图 14-12 测量样条曲线长度

“测量长度”命令可以应用于测量任何形式的曲线，包括圆和椭圆、闭合图形在内。

用鼠标点击图形后，即可完成测量，提示条显示这条曲线的长度，并且提示“拾取曲线”继续测量曲线的长度： 。


测量尺寸

14.3.4 测量尺寸

点击“测量尺寸”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量尺寸：输入第一角点：”，使用框选的方法，把整个所要测量尺寸的图形框住，如图14-13所示。

图 14-13 测量尺寸

点击左键完成测量，提示条显示被选图形或图形组的长、宽、高，并且提示“输入第一角点”继续测量图形尺寸： 。


测量直线夹角

14.3.5 测量直线夹角

点击“直线夹角”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量直线夹角：拾取第一条直线：”，用鼠标点击第一条直线，直线变为绿色，如图14-14所示。

图 14-14 测量直线夹角

接着提示条提示“测量直线夹角：拾取第二条直线：”，用鼠标点击第二条直线后，提示条显示这两条直线的夹角，并且提示“拾取第一条直线”继续测量两直线之间的夹角： 。


测量圆弧角度、半径、圆心位置

14.3.6 测量圆弧角度、半径、圆心位置

点击“测量圆弧角度”命令后，鼠标指针变为“ [image] ”形状，提示条提示“测量圆弧角度：拾取圆弧：”，用鼠标点击所要测量的圆弧，如图14-15所示，这里我们测量两直线之间圆弧。

图 14-15 测量圆弧角度

点击左键，被测量的圆弧变为绿色，此时，提示条显示此圆弧的圆心坐标、半径以及圆心角的大小，并且提示“拾取圆弧”继续测量：


测量三点角度

14.3.7 测量三点角度

点击“测量三点角度”命令后，鼠标指针变为“ [image] ”形状，如图14-16所示，提示条提示“测量圆弧角度：拾取第一点：”，用鼠标点击输入第一点（点A）；提示条提示“测量圆弧角度：拾取第二点：”，用鼠标点击输入第二点（点B）；提示条提示“测量圆弧角度：拾取第三点：”，用鼠标点击输入第三点（点C）。

图 14-16 测量三点角度

此时，提示条显示此三点的角度，并且提示“拾取第一点”继续测量：


15.1 概述

随着CNC雕刻机的发展，涉及的行业越来越多，从广告标牌业、建筑模型业、印刷业、印章业等，到小型模具加工业等。分工越来越细，专业性也越来越强。不同行业的设计类型、雕刻加工工艺往往千差万别、各有千秋。

JDPaint 为了适应不同行业的不同需要，不断推出了各种更加专业的设计功能，如图象处理、广告标牌、印章设计等功能。这些功能作为JDPaint的插件存放在“专业功能”菜单下，可方便用户调用。用户可以通过“文件”菜单下的“系统设置” 命令中的“功能定制”来打开或关闭专业功能模块。

本章介绍的专业功能有：

标牌广告

图象处理

建筑模型

发饰加工

尺寸标注

印章设计


生成流水号

15.2.1 生成流水号

很多胸牌都需要有编号，这么多的号码如果使用“文字编辑工具”一个一个的录入，会相当的麻烦，因为既要保证数字排列一致，还要保证数字不能漏掉。“生成流水号”功能可以轻松解决这个难题。

在胸牌设计排版的过程中，可以把“生成流水号”放到最后一步去编辑，而且只在一个胸牌上“示范”一下，其它胸牌就会根据这个“示范”的样式去自动生成流水号。

“生成流水号”前期的工作包括：

l 胸牌版面的设计。

l 相同部分的刀具路径生成。

l 路径优化。

l 切边路径生成。

l 相同部分的阵列（阵列时需把切边路径也包含在里面）。

经过以上操作之后，生成如图15-1所示的一批标牌，接下来就可以进行流水号的生成了。

图 15-1

“生成流水号”前需准备的参数：

l 阵列后的“胸牌”中尽量不带有文字部分，只保留刀具路径即可。

l 在左下角的一个胸牌中，确定“数字”号码所在的位置、字体、文字大小等。并按要求输入一个数字号码，如上图中的001 。该数字字符串即可作为基准字串。

l 确定“数字”号码的偏移量——测量切边路径的尺寸，并记下。

这就是“数字”号码在水平方向和在竖直方向移动到第二个胸牌相应位置的位移量。其实这个数值就等于切边路径在阵列时的偏移量。例：如果阵列后的胸牌之间的间距是0，“数字”号码的位移量就等于这个路径轮廓的长度和宽度，长度就是“数字”号码在水平方向的位移量（列距），宽度就是“数字”号码在竖直方向的位移量（行距）。

注意在阵列时如果胸牌之间有间距，偏移量要分别加上这个间距的大小。

* 操作步骤：

1） 选择菜单项：

点击菜单“专业功能（Z）→标牌广告（A）→生成流水号（S）”。

2） 设置参数：

系统弹出“生成流水号”对话框，如图15-2所示。

在对话框中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。

参数设置好后可以点击“计算序列号”，系统在序列号列表中显示将要生成的流水号的号码供用户进行预览，还可以在序列号列表中编辑序列号。

还可以点击“文件读取”按钮，将存储在文本文件中的号码读入序列号列表中。

图 15-2 “生成流水号”对话框

3）选取基准字串：

点击〖选取基准字串〗按钮，对话框消失，提示条提示“拾取一个基准文字”，这个基准文字是指在阵列后的左下角的胸牌中已经确定好位置、字体、大小的数字。选择基准字串后又弹出“生成流水号”对话框，此时，对话框提示是否“保留基准字串”，可根据需要进行设置。如果没有作为范例的基准字串，则需要明确指定起始位置，也就是位于左下角的第一个流水号的坐标位置。

4）点击〖确定〗按钮：

参数确认无误后，点击对话框〖确定〗按钮，流水号生成。如图15-3所示。

参数设置好后点击“计算序列号”按钮，系统在序列号列表中显示将要生成的流水号的号码供用户进行预览。用鼠标左键双击任何一个号码，弹出“编辑流水号”对话框，如图 15-4所示。可以对流水号进行编辑。在对话框中选中“添加新号”选项则可以添加一个新的号码到列表框中。

图 15-4

参数定义：

行数 | 阵列拷贝时的行数。
列数 | 阵列拷贝时的列数。
行距 | 图形阵列拷贝时每一行图形之间的图形偏移距离，等于胸牌图形的高度加上胸牌图形垂直方向的间距。注意是基点与基点之间的距离，而不是图形间距。
列距 | 图形阵列拷贝时每一列图形之间的图形偏移距离。
横排优先 | 选中该选项表示流水号先从左向右排，排满一行后再排下一行。此时只能输入“列数”，行数不需要输入，它是通过流水号的总数除以“列数”自动计算出来的。 若不选该选项表示流水号先从下往上排，排满一列后再排下一列。此时只能输入“行数”，列数不需要输入，它是通过流水号的总数除以“行数”自动计算出来的。
起始号 | 流水号的第一个数字（一般为最小号码）。
号码个数 | 要生成的流水号的总数。
号间隔 | 相邻两个号码之间的差值。 假设号间隔为3，第一个号码为“001”，则第二个号码将为“004”。
位数 | 流水号的数字位数，即流水号是几位数。位数不足时前面补零。 假设位数为4，则号码8将表示为“0008”，号码88将表示为“0088”。
前缀 | 流水号前面要增加的字符。生成的每个流水号数字的前面都将加上设定的前缀字符。 例如前缀为“No.”时，生成的流水号（假定从001开始）将依次为“No.001” 、“No.002” 、“No.003” 等。
起始X，起始Y | 流水号第一个号码（位于左下角）的左下角坐标。其它号码将以该号码为基准，依次等距排列。
序列号列表 | 将准备生成的流水号号码列于列表框中，并允许对表格中的号码进行增加，删除和修改。选中号码按Delete键可以删除该号码，双击一个号码可以修改该号码或在该号码前添加新号码。 在点击“确定”按钮时，如果列表框中的内容为空，将按对话框中设置的参数计算出所有流水号。如果列表框中的内容不为空，将按列表框中的内容生成流水号。
删除号码组合 | 可以把一些不希望出现的号码或号码组合输入到列表框中。*号为通配符。 例如“110”表示不能出现“110”这一个号码，但“1105”和“6110”是允许的；“*14*”表示号码中不能出现字符组合“14”，因此“14” 、“141” 、“214” 、“5146”均是不允许出现的。
指定起始位置 | 通过拾取一个指定点的方式指定流水号左下角的起始位置。
选取基准字串 | 基准文字是指在阵列后的左下角的胸牌中已经确定好位置、字体、大小的数字。通过选取基准字串来获得要生成流水号的位置、字体、大小信息，也就是将基准字串作为一个模板（范例）来生成其它流水号。
计算序列号 | 点击该按钮系统将按对话框中设置的参数计算出所有流水号，显示在右边的序列号列表中。可以通过检查列表框中的号码来确定参数设置是否正确。
文件读取 | 将存储在文本文件（*.txt）中的号码读入序列号列表中。注意在文件中一个号码占一行。


文字替换

15.2.2 文字替换

将文字对象中的特定文字或文字组合替换为其他的文字或文字组合。该功能与一般的文字排版软件中的文字替换功能类似。

* 操作步骤：

1） 选中文字对象：

选中要进行文字替换的文字对象。若要对所有文字对象进行文字替换，此步可以跳过。

图 15-5 原始文字对象

2） 选择菜单项：

点击菜单“专业功能（Z）→标牌广告（A）→文字替换（R）”。

3） 设置参数：

弹出“文字替换”对话框，如图15-6所示。在对话框中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。

图 15-6 “文字替换”对话框

4）点击〖确定〗按钮：

参数确认无误后，点击对话框〖确定〗按钮。文字替换完成，系统提示被替换的字符串个数。

图 15-7 “文字替换”结果

参数定义

搜索文字 | 文字对象中希望被替换掉的文字。注意：对于英文字母，大小写是敏感的。
替换文字 | 用来替换老文字的新文字。
从被选文字中替换 | 只在被选中的文字对象中进行“文字替换”操作。
从所有文字中替换 | 对系统中所有的文字对象进行“文字替换”操作。


15.2.3概述

15.3 图象处理

无论是通过扫描获得的图象，还是通过输入获得图象，使用“编辑”、“变换”中的命令只能对图象进行移动、复制、放大、缩小、删除、粘贴等操作，如果想对图象进行旋转、镜像，就必须使用“专业功能”中的“图象处理”功能。


反色

15.3.1 反色

把图象的颜色变换为相反的色彩，常应用于灰度图象的变换。反色后的图象灰度与反色前的灰度在某一点上正好互补。如图15-8所示。

图 15-8 图象反色

实现方法：

（1）选中图象；

（2）选择菜单。

* 操作步骤：

1）选中图象：

用鼠标左键点击图象对象，使图象处于选中状态。

2）选择“反色”菜单：

点击菜单“专业功能（Z）→图象处理（I）→反色（C）”。


转为二值图象

15.3.2 转为二值图象

将图象转为只有黑白两种色彩的图象。如图15-9所示。

图 15-9 转为二值图象

实现方法：

（1）选中图象；

（2）选择菜单。

* 操作步骤：

1）选中图象：

用鼠标左键点击图象对象，使图象处于选中状态。

2）选择“转为二值

图象”菜单：

点击菜单“专业功能（Z）→图象处理（I）→转为二值图象（T）”。

3）输入“二值化阈值”：

系统弹出“图象二值化”对话框，如图15-10所示，要求输入“二值化阈值”（0-255），系统默认为12。设置好后，点击〖确定〗按钮

图 15-10 “图象二值化”对话框

参数定义：

二值化阈值： | 二值化转换时灰度的分界线，灰度大于该值的像素被转为黑色，灰度小于该值的像素被转为白色。


转为灰度图象

15.3.3 转为灰度图象

将彩色图象转为没有色彩而只有明暗层次关系的灰度图象。如图15-11所示。

图 15-11 转为灰度图象

实现方法：

（1）选中图象；

（2）选择菜单。

* 操作步骤：

1）选中图象：

用鼠标左键点击图象对象，使图象处于选中状态。

2）选择“转为灰

度图象”菜单：

点击菜单“专业功能（Z）→图象处理（I）→转为灰度图象（G）”。


水平翻转

15.3.4 水平翻转

图象以X轴为基准在水平方向进行翻转。就是图象做水平方向的镜像。如图15-12所示。

图 15-12 水平翻转

实现方法：

（1）选中图象；

（2）选择菜单。

* 操作步骤：

1）选中图象：

用鼠标左键点击图象对象，使图象处于选中状态。

2）选择“水平翻转”菜单：

点击菜单“专业功能（Z）→图象处理（I）→水平翻转（H）”。


竖直翻转

15.3.5 竖直翻转

图象以Y轴为基准在竖直方向进行翻转。就是图象做竖直方向的镜像。如图15-13所示。

图 15-13 竖直翻转

实现方法：

（1）选中图象；

（2）选择菜单。

* 操作步骤：

1）选中图象：

用鼠标左键点击图象对象，使图象处于选中状态。

2）选择“竖直翻转”菜单：

点击菜单“专业功能（Z）→图象处理（I）→竖直翻转（V）”。


图象旋转

15.3.6 图象旋转

图象绕左下角点旋转指定角度。如图15-14所示。

图 15-14 图象旋转

实现方法：

（1）选中图象；

（2）选择菜单。

* 操作步骤：

1）选中图象：

用鼠标左键点击图象对象，使图象处于选中状态。

2）选择“旋转”菜单：

点击菜单“专业功能（Z）→图象处理（I）→旋转（R）”。

3）输入参数：

系统弹出“图象旋转”对话框，选定参数后，点击〖确定〗按钮，完成旋转命令。如图15-15所示。

图 15-15 “图象旋转”对话框

参数定义：

预设角度： | 选定“90度 逆时针”后图象逆时针旋转90度。同样，选定“90度 顺时针”后图象顺时针旋转90度，选定“180度”后图象旋转180度。
自定义角度： | 当选择“自定义角度”时，对话框中会增加“角度” 定义栏，可以在此输入所需的角度，以及旋转方向，输入完成后，点击〖确定〗按钮，完成旋转命令，如图15-15所示。


生成砖墙

15.4.1 生成砖墙

在指定的矩形区域内填充生成砖墙图案，所采用得绘制方式可以减少加工时的抬刀次数。如图15-16A和图15-16B所示。

矩形域 交错砖墙 平行砖墙

图 15-16A 砖墙图案

+

=

图 15-16B 砖墙构成

实现方法：

（1）指定填充矩形域的两个角点；

（2）设置砖墙参数。

* 操作步骤：

1） 选择菜单项：点击菜单“专业功能（Z）→建筑模型（M）→生成砖墙（W）”。

2） 拾取第一个角点： 拾取待填充矩形区域第一个角点。

3）拾取第二个角点：拾取待填充矩形区域第二个角点（与第一角点形成对角），如图15-17所示。

绘制墙砖
4）输 入 参 数： 在弹出对话框内设置砖墙图案类型及砖块尺寸，如图15-18所示。各参数具体含义可以参考“参数定义”中的说明。

5）点击“确认”按钮：参数确认无误后，点击对话框〖确定〗按钮，砖墙生成。

图 15-18 “砖墙设置”对话框

参数定义：

砖墙类型 | 指定要生成的砖墙的图案类型，分为交错和平行两种。如图15-18所示。
设置砖高 | 设置组成砖墙图案的砖块的高度。有两种指定方式： 1） 指定尺寸 直接指定砖块的高度尺寸，单位为毫米。 2） 指定行数 指定砖墙图案中砖块的行数（层数），由此换算出砖块的高度
设置砖长 | 设置组成砖墙图案的砖块的长度。有两种指定方式： 1）指定尺寸 直接指定砖块的长度尺寸，单位为毫米。 2）指定比例 指定砖块长度与砖高的比例（砖长/砖高），由此换算出砖块的长度。


球状水晶面插件使用说明

球状水晶面插件用于构造由平面多边形镶嵌而成的球状物体，如水晶状足球、水晶艺术灯罩及其他的球状水晶工艺品。球状水晶面构造完成之后，可以执行变换或变形等操作生成水晶椭球体或其他的形体。

球状水晶面由网格曲面表示，所而针对网格曲面的操作同样适用于球状水晶面。球状水晶面插件以专业功能的形式出现，由如下几个命令组成：

1）求弧长及弦长

2）生成球面正多边形

3）复制球面多边形

4）共面曲线

5）等弦长曲线

6）生成球状水晶面

球状水晶面假定其基体是一半球或整球状物体，因此球的半径R是设计球状水晶面时必须知道的。实际应用中可通过实物测量得到球的半径R，或根据设计要求确定球的半径R。

已知球的半径为R，则球的周长为2πR。在选择工具环境下，以任意点为圆心，画一半径为r=2πR/4=πR/2的二维圆。圆内的面积可看作是半径为R的半球的经度线拉直压平后的结果。这样二维圆内的任何一点唯一对应半球上的一三维点。圆内任何一点到圆心的距离等于球面上对应点到沿经度线到球冠上点的弧线长度。

进行了前面的准备工作之后，只要在二维圆内画出球面的一组多边形分割图，再经过“生成球状水晶面”命令即可得到所要的三维水晶面。因此，现在要解决的问题是如何画这组多边形分割图，可以利用二维绘制命令直接在圆内绘制多边形，但因展平过程中圆周方向的尺寸与球面的尺寸是有误差的，多边形映射到球面上时会变形，边长尺寸会改变，有可能不共面。

球状水晶面插件提供的这组命令可以保证生成边长尺寸精确，不变形，共面的多边形，下面介绍这组命令：


1. 求弧长及弦长

求球面上任意两点之间的弧长及弦长。

选择半球的展平图，然后选择命令，系统提示：

“第一点：”用鼠标指定第一点

“第二点：”用鼠标指定第二点

两点之间的弧长及弦长结果显示于导航区的对话框中，如图1

图 1

如果已知弦长，在导航区对话框“弦长”框中输入弦长，“弧长”框中将显示对应的弧长，反之亦然。


2. 生成球面正多边形

在球面上创建正多边形，并在展平图中生成其映象，展平图中的映象多边形一般不是正多边形。

选择半球的展平图，然后选择命令，系统导航区出现对话框，选择正多边形类型，设定边长及超始点角度，然后在圆内或其周围指定正多边形中心的位置，系统生成球面正多边形在二维展平图中的映象。

图2 图3


3. 复制球面多边形

以球面上多边形的一条边界为轴，翻转复制该多边形，并保证复制的多边形所有的顶点位于球面上，最后生成该多边形在二维展平图上的映象。如果原多边形共面, 翻转复制的多边形亦共面；如果原多边形不共面, 翻转复制的多边形亦不共面。

选择半球的展平图，然后选择命令，系统提示：

“选择多边形”

移动鼠标到待复制的多边形处，当其改变颜色时，单击鼠标左键，系统将以离鼠标单击处最近的一条边界为轴，翻转复制该多边形，并生成该多边形在二维展平图上的映象。

图4 图5 图6


4. 共面曲线

在二维展平图中指定三个各不相同的点，系统通过球面上对应的三点生成一平面，并与球面相交，求得交线并把交线映射到二维展平图中。在二维展平图中，如果一个多边形的所有顶点都位于该共面曲线上，则该多边形映射到三维球面上时，一定是共面的。

选择半球的展平图，然后选择命令，系统提示：

第一点：指定第一点

第二点：指定第二点

第三点：指定第三点

三点输入完毕，系统将显示共面曲线。

图7


5. 等弦长曲线

在二维展平图上指定一中心位置后，系统显示球面上所有到该点弦长为给定数值的点的映象。

选择半球的展平图，然后选择命令，在导航区对话框设置弦长，系统提示：

指定中心位置：

指定中心位置后系统显示等弦长曲线。


6. 生成球状水晶面

把二维展平图中的多边形转换为三维水晶网格曲面。

选择所有的多边形及半球的展平图，然后选择命令，系统把多边形转换为三维水晶网格曲面。


综合应用

综合应用——构造一水晶足球

现实中的足球是圆的，在此我们构造一平面片构成的水晶足球。观察足球可以发现，足球是由十二个正五边形及20个正六边形构成。任何一个正五边形周围是五个正六边形。多边形边长及球的半径之间存在一定的关系，通过推算或实测或作图就可得知足球的半径R与正多边形边长edgelen之间的关系为：

R/edgelen=2.4780

即足球半径为正多边形边长的2.4780倍。设要构造的足球半径为100mm，则正多边形边长edgelen为：

edgelen=100/2.4780=40.3551（mm）

半球展平图的半径r为：

r=π·R/2.0=3.14159×100/2.0=157.0795（mm）

画展平图（二维圆），半径r=157.0795。

1. 生成球冠处边长edgelen=40.3551（mm）的正五边形

a. 选择展平图

b. 选择命令“生成球面正多边形”，在对话框中选择“五边形”，边长框中数值设为40.3551

c. 单击鼠标左键捕捉展平图的圆心，即可生成边长为40.3551的球面正五边形，如图9：

图9

2. 生成正五边形周围一外接球面正六边形

由前面的分析得知，五边形周围是五个正六边形，在此我们生成其中的一个。如图10，正六边形边长为40.3551mm , 那么其相邻的两个顶点之间的距离为69.8971（mm）。

图10

五边形及六边形顶点编号如图9及图10。六边形的1号顶点位于五边形的1号顶点处，六边形的2号顶位于五边形的2号顶点处。现在需要确定3号顶点的位置。在图11中以2号顶点为中心，生成其等弦长（40.3551mm）曲线，再以1号顶点为中心，生成其等弦长（69.8971mm）曲线，两曲线有二个交点，不难确定其中一个交点是顶点3的位置。同理可以确定顶点4、5、6的位置。连接1、2、3、4、5、6顶点得一球面正六边形在展平图中的映象。如图12。

图11 图12

3. 复制球面正多边形

生成了一个正六边形后，利用“复制球面多边形”功能就能翻转复制出所有其它正六边形。如图13及图14：

图13 图14

4. 绘制另外五个五边形

六边形之间的空洞，即是一个五边形的位置，利用直线绘制功能在各空洞处补上一五边形，可利用求弧长及弦长命令验证五边形边长相等，利用共面曲线命令验证其五个顶点共面。

图15

5.生成球状水晶面

选择展平图及16个五边形、六边形，然后选择“生成球状水晶面”，即可生成半个水晶面足球，如图16：

图16

6. 构成完整的足球

把图16中的半个足球绕Z轴转动36º并保留原图，然后相对XOY平面镜像即可构成一完整的水晶足球，如图17。细分之后可磨去尖点及硬边得到一真正的足球。

图17 图18

图18中球的半径为99mm，可见水晶足球的顶点在同一球面上(R=100mm)。


15.7.0

15.7 印章设计

印章排版软件是北京精雕科技有限公司推出的一套面向印章行业的、旨在提高印章排版设计与加工效率的专业软件模块，非常适合于从事印章设计与加工领域的业内人士使用。

印章排版软件的主要功能与特色：

1. 提供几十种常用的印章模板, 用户应用印章模板可以十分方便、快捷地完成各种常用印章的排版设计。

2. 提供了印章设计参数保存与提取功能，使用户在设计类似的印章时，不必重新定义设计参数，直接使用上次设计的参数。

3. 提供历史文档记录。将印章文字保存到历史文档中，用户可以不必多次录入相同的文字。

4. 提供多种指纹防伪印章的设计方案及设计方法。


印章模板

15.7.1 印章模板

点击“印章设计-->常用印章…”菜单命令，系统弹出印章排版对话框，如图15-43所示。

图15-43 印章排版

参数说明：

[选择印章] | 点击[选择印章]按钮，弹出常用印章对话框，用户可从其中任选一种印章类型，如图15-44所示。 图 15-44 常用印章类型
[提取印章] | 将保存在印章库中印章提取出来，同时提取出该印章的设计参数和印章文字。单击[提取印章]按钮，弹出对话框，如图15-45所示。 图 15-45 提取印章
[保存印章] | 保存印章与提取印章相对应，它把当前印章的设计参数和印章文字同时保存到印章库中。单击[保存印章]按钮，弹出对话框，如图15-46所示。 图 15-46 保存印章
[重设参数] | 将当前印章的设计参数设定为系统默认值。
[效果预览] | 单击该按钮，观察当前印章的设计效果。
[填充显示] | 单击该按钮，观察当前印章的填充显示效果。
[印章镜像] | 单击该按钮，观察当前印章的镜像效果。
印章参数 | 定义了当前印章的设计参数。通过调整参数，可以获得指定印章排版效果。
输入文字 | 定义了当前印章的文字；印章中不同区域的文字，用符号“|”进行分隔；同一区域、处于不同行的文字，用符号“\”进行分隔。 用户所输入的印章文字，可以保留到历史文档中。点击“历史文档”将弹出历史文档编辑对话框，用户可以对历史文档中的文字进行编辑，如图15-47所示。 图15-47 历史文档


印章图形参数

15.7.2 印章图形参数

在JDPaint中，应用印章模板排版制作印章的过程如下：

1) 点击[选择印章]按钮，从印章模板中选择一种常用印章；

2) 录入印章文字，或者从历史文档中提取印章文字；

3) 编辑当前印章图形区域控制参数，获得满意的印章排版效果；

4) 点击确定，将生成的印章放置到JDPaint系统的工作区的指定位置。

很明显，对于某种模板印章来说，印章图形区域控制参数直接决定了该印章的图形文字排版。印章图形文字形状控制参数分为两部分：图形形状控制参数和文字控制参数，如图15-48所示。

图 15-48 印章图形控制参数与文字控制参数

图形形状控制参数 | 上下高度 | 用于确定该图形区域的纵向尺寸。
 | 左右宽度 | 用于确定该图形区域的横向尺寸。
 | 字边间距 | 用于确定该图形区域中文字到图形边界的距离。
 | 印章边宽 | 用于确定该印章边框的宽度。
 | 圆角半径 | 用于确定该印章角点的圆角过渡半径，此参数仅对矩形边框印章有效。
 | 中线宽度 |
文字控制参数 | 字体 | 该区域文字的字体。
 | 文字排列：直排、横排 | 文字排列选项，仅对线排文字有效。
 | 字间距离 | 文字字符间距离
 | 行间距离 | 文字行间距离
 | 文字高度 | 文字字符高度
 | 文字宽度 | 文字字符宽度


指纹设计

15.7.3 指纹设计

在JDPaint中，指纹设计并不是真正的人体指纹设计，而是指仿人体指纹的图形设计；真正的人体指纹通常通过图形扫描仪扫描到JDPaint系统中，再通过图象矢量化功能或者手工描图方法获得。

该功能通过确定指纹的线宽、线间距快速生成仿指纹的同心圆，用户可通过图形编辑方法，修改图形从而获得各种仿指纹图形。

点击“印章设计-->指纹设计”菜单命令，系统弹出印章排版对话框，如图15-49所示。

图 15-49 指纹同心圆设计

图 15-50 指纹同心圆


尺寸标注

15.6.1 尺寸标注

对图形进行尺寸标注。尺寸标注包括半径、直径、距离（长度）以及角度标注四类。按照标注对象的数目又可分为单元素标注和双元素标注。半径、直径和长度标注为单元素标注，距离和角度标注则为双元素标注。

该命令可根据拾取的标注元素的类型，个数以及位置关系自动判断尺寸标注的类型，因此用这一个命令即可完成半径、直径、距离以及角度尺寸标注。

单元素标注

双元素标注

图15-37 尺寸标注示例

实现方法：

（1）拾取标注元素；

（2）拾取尺寸定位点；

（3）输入标注文字。

* 操作步骤：

1） 选择菜单项： | 击“专业功能（Z）→尺寸标注（D）→生成标注（D）”菜单。
2）拾取第一个标注元素： | 用鼠标左键点击待标注元素。系统将根据拾取的元素类型判断尺寸标注类型。

3）拾取第二个标注元素：

用鼠标左键点击第二个待标注元素。

若为单元素标注，可跳过此步直接进行第4步。

若不拾取而直接点击鼠标右键右键则回到第 2步，重新拾取第一个标注元素。

4）拾取尺寸定位点：

移动鼠标，系统随着鼠标的移动进行尺寸标注的预显，标注文字用一个方框表示。在满意的位置点击鼠标左键，设定尺寸定位点。

若不拾取定位点而直接点击鼠标右键则回到第 3步，重新拾取第二个标注元素。

5）输入标注文字：

系统提示输入标注文字， [image] 括号内为标注图形的实际尺寸，也是缺省的标注文字。通过键盘输入标注文字，输入文字后回车即完成一个尺寸标注。若不输入文字直接点击鼠标右键则直接采用缺省文字标注。

输入文字时，直径标注符号"φ"用"%c"输入，角度标注符号"°"用"%d"输入。如果不需要标注文字，可以输入一个空格。

完成一个尺寸标注后系统回到第2步的拾取状态，可继续进行其它尺寸标注。要退出尺寸标注命令，按ESC键即可。

下面以一个角度尺寸标注为例，说明尺寸标注的过程：

图15-38 尺寸标注过程

参数定义：

在尺寸标注过程中可以点击右边导航条中的“参数设置”按钮，弹出“尺寸标注设置”对话框进行尺寸标注样式的设置，随后的尺寸标注将采用新设置的样式。对话框参数的具体含义可以参考“参数设置”功能中的说明。


更新标注

15.6.2 更新标注

根据当前的尺寸样式设置对尺寸标注进行样式更新，使其与当前的尺寸样式设置保持一致。更新标注前应当先用“参数设置”功能设置好所需要的尺寸标注样式的参数。

图15-39 更新标注示例

实现方法：

（1）拾取标注元素； （2）选择菜单项。

* 操作步骤：

1）选中尺寸标注：

拾取需要更新标注样式的尺寸标注，使其处于选中状态。

2）选择菜单项：

点击菜单“专业功能（Z）→尺寸标注（D）→尺寸更新（U）”菜单。被选中的尺寸标注即更新为当前样式。


编辑标注

15.6.3 编辑标注

对已有的尺寸标注进行编辑，改变尺寸线的位置，样式及标注文字。被编辑尺寸标注将采用当前设定的标注样式，而不再保留原来的样式。

图15-40 编辑标注

实现方法：

（1）拾取尺寸标注； （2）拾取尺寸定位点； （3）输入标注文字。

. * 操作步骤：

1） 选择菜单项：

点击“专业功能（Z）→尺寸标注（D）→编辑标注（E）”菜单。

2）拾取尺寸标注：

鼠标左键点击需要编辑的尺寸标注。

3）拾取尺寸定位点：

移动鼠标，系统随着鼠标的移动进行尺寸标注的预显。在满意的位置点击鼠标左键，设定尺寸定位点。

若点右键则回到第 2步，重新拾取尺寸标注。

4）输入标注文字：

通过键盘输入标注文字，输入文字后回车即完成一个尺寸标注的编辑。点右键则直接采用缺省文字标注。

输入文字时，直径标注符号"φ"用"%c"输入，角度标注符号"°"用"%d"输入。如果不需要标注文字，可以输入一个空格。

完成一个尺寸标注的编辑后系统回到第2步的拾取状态，可继续进行其它尺寸标注的编辑。要退出尺寸标注命令，按ESC键即可。

参数定义：

在编辑尺寸标注过程中可以点击右边导航条中的“参数设置”按钮，弹出“尺寸标注设置”对话框进行尺寸标注样式的设置，随后的更新尺寸将采用新设置的样式。对话框参数的具体含义可以参考“参数设置”功能中的说明。


参数设置

15.6.4 参数设置

设置尺寸标注的样式。

* 操作步骤：

1） 选择菜单项： | 点击菜单“专业功能（Z）→尺寸标注（D）→参数设置（S）”菜单。
2） 设置参数： | 弹出“尺寸标注设置”对话框，如图15-41所示。在对话框中设置尺寸标注的样式参数，各参数具体含义可以参考“参数定义”中的说明。

图15-41 “尺寸标注设置”对话框

3）点击〖确定〗按钮：

参数确认无误后，点击对话框〖确定〗按钮。尺寸标注的样式参数将被保存下来。以后的尺寸标注将采用刚被设定的尺寸样式。

参数定义：

文字高度 | 标注文字的高度。
字宽系数 | 标注文字宽度与高度的比例。
小数位数 | 标注数值圆整到小数点后的位数。
文字与尺寸线间隙 | 标注文字底部距离尺寸线的间隙。
文字基点 | 文字相对于尺寸线的位置（垂直于尺寸线方向）。 1）尺寸线上 标注文字落在尺寸线的上方。 2）居中 标注文字中心落在尺寸线上。 3）尺寸线下 标注文字将在尺寸线的下方。
文字方向 | 标注文字的排列方向，有两种选择： 1）与尺寸线平行 始终平行于尺寸线方向 2）文字水平 始终保持水平
文字位于尺寸线中点 | 该选项选中则文字始终位于尺寸线的中点，不选中则可位于尺寸线上任一点处。
延伸长度 | 尺寸边界线高出尺寸线的长度。
与图形间隙 | 尺寸线底部与标注图形的间隙。
左箭头 | 选“无”表示尺寸线左端无箭头，否则为有箭头。
右箭头 | 选“无”表示尺寸线右端无箭头，否则为有箭头。
箭头长度 | 尺寸线两端箭头的长度。

图15-42 尺寸标注参数示意


发饰加工0

15.5 发饰加工

发饰加工模块为发饰加工行业提供了一组专用工具，为发饰加工中常用到的各种与圆排列﹑圆钻孔相关的操作提供方便。


圆选择

15.5.1 圆选择

按半径选择或不选系统中的圆对象。指定一个半径值，系统中所有半径等于该半径值的圆对象都被选中或不选。群组中的圆不被处理，但将进行提示。

* 操作步骤：

1）选中参照圆：

选中一个指定半径的圆作为参照对象。此步可以跳过。

2）选择“圆选择” 菜单项： | 点击菜单“专业功能（Z）→发饰专业（H）→圆选择（R）”。
3）设置对话框参数： | 系统弹出对话框，如图15-19所示。若第1步选择了参照圆，则对话框中的圆半径初始值即为该参照圆的半径。此时也可以重新设置圆半径。选择“选中”或“不选”按钮即可选中或不选系统中指定半径的圆。

图 15-19 “圆选择”对话框

参数定义：

圆半径 | 需要“选中”或“不选”的圆的半径值。
匹配精度 | 当系统中一个圆的半径值与指定的圆半径值的差值小于匹配精度时，则认为该圆为符合条件的圆。


颜色选择

15.5.2 颜色选择

按颜色选择或不选系统中的图形对象。指定一个参照图形，系统中所有与该参照图形颜色相同的图形对象都被选中或不选。群组中颜色相同的对象不被处理，但将进行提示。

* 操作步骤：

1）选择“颜色选

择”菜单项：

点击菜单“专业功能（Z）→发饰专业（H）→颜色选择（C）”。

2）设置操作类型：

若要选中图形，选择导航条右边的“选中”选项，若要不选图形，选择导航条右边的“不选”选项。

3）拾取参照图形：

用鼠标左键点击参照图形对象。

选择参照图形后系统中与该参照图形颜色相同的所有图形将被选中或不选。

参数定义：

选中 | 系统中与该参照图形颜色相同的所有图形将被选中。
不选 | 系统中与该参照图形颜色相同的所有图形将被不选。


统计圆

15.5.3 统计圆

统计选择集或系统中不同半径的圆对象的数量，将统计结果列表显示。统计信息包括不同半径圆的半径值﹑数量﹑选中状态﹑刀具匹配情况。同时还可以通过该命令选中或不选系统中某一半径的圆。

* 操作步骤：

1）选择需要统计的圆：

使需要统计的圆处于选中状态。如果需要对系统中所有的圆进行统计，此步可以跳过。

2）选择“圆统计”菜单：

点击菜单“专业功能（Z）→发饰专业（H）→统计圆（S）”。

系统弹出“圆统计”对话框。对话框中将列出选择集和系统中不同半径的圆对象的数量，如图15-20所示。

此时还可以通过“选中”或“不选”按钮对指定半径的圆进行选择或不选，圆的选中状态也将相应显示在列表框中。

如果在选择“统计圆”菜单项之前选择集不为空，对话框中将列出选择集中不同半径的圆对象的数量，否则对话框中将列出系统中所有不同半径的圆对象的数量。

图 15-20 “圆统计”对话框


半径编辑

15.5.4 半径编辑

修改选择集中的圆对象的半径，其圆心保持不变。

图 15-21 半径编辑

* 操作步骤：

1）选中一组圆：

使需要改变半径的圆处于选中状态。

2）选择“半径编辑”菜单：

点击菜单“专业功能（Z）→发饰专业（H）→半径编辑（E）”。

3）输入新半径：

系统在状态工具栏提示输入新的半径，如图图 15-22所示。

用键盘输入新的半径后回车，被选中的这组圆的半径将被修改为新输入的半径。

图 15-22 输入新半径

功能异常说明：集合或群组中的圆不能修改半径，必须先取消集合或群组，才能修改其中的圆的半径。


圆心钻孔

15.5.5 圆心钻孔

以选择集中的各个圆的圆心作为钻孔位，根据圆的半径匹配预先设定的钻孔刀具，生成钻孔刀具路径组。同一半径的圆孔的钻孔路径使用同一把刀具，并处于同一个路径组中。用户可以保留各孔的原始顺序或让系统自动优化钻孔顺序。

图 15-23 圆心钻孔

* 操作步骤：

1）选中圆： 先选中一组要进行钻孔的圆。

2）选择“圆心钻孔”菜单：点击菜单“专业功能（Z）→发饰专业（H）→圆心钻孔（D）”。

3）设置参数：

系统弹出“圆心钻孔”对话框。对话框中将列出选择集中不同半径的圆对象的数量及相应的钻孔刀具名称。若尚未选择刀具则刀具名称为空。

选择“修改刀具”按钮（或双击列表栏第一列）可以选择或改变圆对象对应的钻孔刀具。只有当所有圆孔都有对应刀具时才能生成钻孔轨迹。

图 15-24 “圆心钻孔”对话框

4）点击“确定”按钮：

参数设置完毕后，点击“确定”按钮。系统生成钻孔刀具路径组，同时保存圆对象与钻孔刀具的匹配关系（下次进行圆心钻孔时将自动选择匹配的钻孔刀具）。

参数定义：

钻孔深度 | 需要加工的孔的深度。
优化钻孔排序 | 让系统自动优化钻孔顺序，使轨迹长度尽可能缩短。


路径排序

15.5.6 路径排序

对选择集中的路径组内包含的钻孔或切割路径按其使用刀具的不同将其拆解成为多个子路径组，每个子路径组都使用同一刀具。并在使用同一刀具的子路径组内部进行自动优化排序。使用单一刀具的路径组不会被拆解，仅在其内部进行自动优化排序。

一般只用于对钻孔路径和切割路径进行排序。

图 15-25 路径排序

* 操作步骤：

1）选中刀具路径：

使待排序刀具路径处于选中状态。

2）选择“路径排序”菜单：

点击菜单“专业功能（Z）→发饰专业（H）→路径排序（O）”。

3）输入参数：

系统弹出“路经排序”对话框，如图15-26所示。各参数的具体含义请参考“参数定义”中的说明。

图 15-26 “路径排序”对话框

4）点击“确定”按钮：

参数设置完毕后，点击“确定”按钮。系统提示完成排序。

参数定义：

路径种类 | 需要进行排序的路径的种类。 1） 闭合路径 待排序的路径为闭合路径，也就是路径的始末点重合，而且形成一个闭合轮廓。通常大字切割路径可视为闭合路径。 2） 非闭合路径 待排序的路径为非闭合路径，也就是路径的始末点不重合。对非闭合路径只能按“最短路径”方式进行排序，且不能调整内外顺序。钻孔路径可以视为不闭合路径。
走刀路线 | 设置路径优化的方式 1）最短路径 对钻孔或切割路径进行排序，尽量缩短空走行程。 2）往复走刀 按从左至右，从下至上“之”字形往复走刀。这种方式主要用于切割路径的排序。除了能缩短空走行程外，还可以与“调整起点”相结合，避免切割时出现松动。
调整起点 | 该选项只对切割路径有效，而且只在“往复走刀”时有效。 通过调整切割路径的起点来避免切割时出现松动（先切割靠近已切割区域的部分边界，后切割远离已切割区域的部分边界）。
内外顺序 | 用于设置闭合路径的内外顺序。该选项只对切割路径有效。 1）由外至内 先加工外轮廓，再加工内轮廓。 2）由内至外 先加工内轮廓，再加工外轮廓。
左下角为起点 | 排序后先从左下角开始加工，也就是位于左下角的路径排在第一位。
外圈最后统一切割 | 将最外层切割轨迹留到最后进行切割。该选项只对切割路径有效。

由外向内 由内向外

(a) 内外顺序

（b）外圈最后切割

图 15-27 切割顺序

图 15-28 往复走刀并调整切割路径起点


线上排列

15.5.8 线上排列

将图形沿曲线排列。在发饰加工中可用于在闭合边界上均布小圆孔。

* 操作步骤：

1) 选中基准图形：

使需要沿曲线排列的基准图形处于选中状态。

2) 选择“线上排列”菜单：

点击菜单“专业功能（Z）→发饰专业（H）→线上排列（A）”。

3）输入参数：

系统弹出“线上排列”对话框，如图15-33所示。各参数的具体含义请参考“参数定义”中的说明。

选定参数后，点击〖确定〗按钮。

图 15-33 “线上排列”对话框

4）拾取排列路经：

拾取一根曲线作为排列路径。

5）拾取阵列基准点：

在排列路径上拾取一点作为阵列基准点（排列起始点）。应当选择靠近图形的一端作为基准点。

6）选择排列方向：

系统显示两个箭头，提示选择排列方向。左键点击所需要的方向箭头。

参数定义:

图形间距 | 阵列拷贝图形中相邻两个图形中心之间的距离。
复制数目 | 阵列拷贝后的图形个数。
旋转图形 | 选择此项，阵列时图形进行旋转，沿着曲线的径向排列，否则按照水平方向排列，系统默认为选中状态。 在发饰加工中用于在闭合边界上均布小圆孔时，不用选择该选项。
指定最大排列数量 | 用指定数目的基准图形排满路径曲线。
最小排列间距 | 用基准图形排满路径曲线，同时保证阵列图形基点的间距不小于最小排列间距。
放到线上 | 把阵列图形的中心点与路径曲线上的点对齐。基准图形保持不动。 在发饰加工中用于在闭合边界上均布小圆孔时，将该选项选上，可以保证圆孔圆心落在线上（即使基准圆不落在线上也是如此）。
排满 | 图形沿曲线排满，首尾均排有图形，中间等距分布。 1） 指定数目 用指定数目的图形将曲线排满。 2） 指定最小排列间距 按间距计算排满曲线所需的图形个数，实际排列时图形间距可能会略大于该值，因为要保证首尾均排有图形。 在发饰加工中用于在闭合边界上均布小圆孔时，将该选项选上，可以自动调整圆孔间距，使小圆孔在闭合边界上均匀分布。

间距计算方法：

[按曲线长度计算]——图形间距的计算方法是按照曲线的长度进行计算的，就是说阵列的第一个与第二个图形的基准点之间对应的曲线长度等于第二个与第三个图形基准点之间对应的曲线长度，曲线段AB=BC=CD=DE=EF=图形间距，如图15-34所示。

图15-34 按曲线长度计算

[按点间距离计算]——图形间距的计算方法是按照图形元素的基准点之间的直线距离的长度进行计算的，就是说阵列的第一个与第二个图形的基准点之间的直线距离等于第二个与第三个图形基准点之间的直线距离，直线段AB=BC=CD=DE=EF=图形间距，此项与“按曲线长度计算”互锁，如图15-35所示。

图15-35 按点间距离计算

原始图形

不放到线上

放到线上

图15-36 “放到线上”选项示意


圆充满

15.5.7 圆充满

用指定半径的圆均匀充满一个空白封闭区域。这里所说得“均匀”是指视觉上的均衡匀称。

主要选项：

填充圆 | 用指定半径的圆均匀充满一个空白封闭区域。
调整圆 | 对封闭区域内放置的圆进行均匀化处理。


圆充满>>填充圆

15.5.7.1 圆充满 >>填充圆

对一个空白闭合区域用指定半径的圆进行均匀填充。

图 15-29 圆充满

* 操作步骤：

1）先选中一个填充圆：

选中一个圆作为填充圆。此步可以跳过而在第5步直接输入填充圆的半径。

2）选择“圆充满” 菜单：

点击菜单“专业功能（Z）→发饰专业（H）→圆充满（F）”。

3）选择“填充圆”子功能：

在右边导航条上选择“填充圆”选项。

4）拾取待填充区域边界：

拾取一个闭合轮廓作为填充区域边界。

拾取结束右键回车。

5) 输入参数：

系统弹出“圆充满”对话框，如图15-30所示。

设定参数后，点击〖确定〗按钮。

图 15-30 “圆充满”对话框

参数定义:

最大充满数目 | 用指定数目的圆对待填充区域进行填充。数目过大有可能导致填充圆发生重叠，而且会大大增加均匀处理时间。当充满数目大于200时系统不再做自动均匀处理，因为耗时太多。
最小边界距离 | 用指定圆尽可能地填满待填充区域，并保证圆与圆之间，圆与边界之间的距离不小于最小边界距离。圆与边界之间的距离也不能小于圆半径。
填充圆半径 | 用于填充闭合区域的圆的半径值。半径过大有可能导致填充圆发生重叠，过小则可能增加均匀处理时间。
排列方式 | 可以选择纵横对齐的行排方式也可选择沿边界等距环排的方式。
均匀处理 | 对填充的圆进行均匀处理。当填充圆数目较大时可能会花费较多时间。当填充圆数目大于200时系统不再做自动均匀处理。

由于均匀填充并非一个确定性的几何计算过程，而是需要反复多次的调整，因此只有当参数值较为合理时才能获得较好的填充结果。如果对填充结果不满意可以用“调整圆”功能多进行几次均匀处理。


圆充满>>调整圆

15.5.7.2 圆充满>>调整圆

对封闭区域内放置的圆进行均匀化处理，使各圆在封闭区域内均匀分布。而“填充圆”是对一个空白闭合区

均匀处理后
矩形标注: 封闭区域边界 ................. .......................... 矩形标注: 填充圆

图 15-31 调整圆

* 操作步骤：

1）选择“圆充满” 菜单： | 点击菜单“专业功能（Z）→发饰专业（H）→圆充满（F）”。
2）选择“调整圆”子功能： | 在右边导航条上选择“调整圆”选项。

3）选择填充区域边界：

拾取一个闭合轮廓作为填充区域边界。

4）选择填充圆：

拾取填充圆。（为方便拾取，最好将填充圆进行集合）拾取结束点击鼠标右键。

5）输入参数：

系统弹出“均匀处理”对话框，如图15-32所示。各参数的具体含义请参考“参数定义”中的说明。设定参数后，点击〖确定〗按钮。

图 15-32 “调整圆”对话框

参数定义:

最小间距 | 也就是最小边界距离，均匀化处理时保证圆与圆之间，圆与边界之间的距离不小于最小间距。
处理次数 | 进行均匀化处理的次数，处理次数越多，效果越好，但也将花费更多的时间。

功能异常说明

填充失败 | 填充圆半径或指定的小边界距离过大，都可能导致填充失败。填充区域的轮廓也必须保证闭合，无断点和重点。
未作均匀处理 | 当填充圆数目大于200时系统不再做自动均匀处理。


鞋模放码插件使用说明


1. 鞋底镜像

图1 鞋底镜像对话框

作用：

将鞋模镜像，以便从一只已设计好的鞋模(左脚或右脚)直接得到相对的另一只鞋模(右脚或左脚)。

步骤：

a． 择鞋底模型。

b． 选择“专业功能→鞋模放码→鞋底镜像”，右方会出现相应的镜像对话框（如图1所示）。

c． 选择相对X轴或相对Y轴

d． 确定（图2为相对Y轴镜像前后的鞋底模型）。

注：选项相对X轴事实上是把路径XOZ平面作镜像，而选项相对Y轴事实上是把路径YOZ平面作镜像。


2. 鞋底放码

鞋底放码对话框

作用：

当中间鞋号的鞋底模型设计好后，利用鞋底放码功能，可自动得到全系列的鞋底模型。避免重复的将每一个模型都从头到尾的设计，大大提高鞋底模型的设计速度。

步骤：

a． 选择已设计好的鞋底模型型

b． 选择“专业功能→鞋模放码→鞋底放码”，系统将弹出“鞋底扩缩”对话框，如图3所示：

c． 设置参数：

d． 选择是否在高度方向上扩缩。（如果是则选中此项）

e． 点击确定后系统自动生成扩缩后的鞋底模型，并删除原鞋底模型。

下面对对话框中的参数作一下简要的介绍：

1. 鞋号系列：

JDPaint5.0中提供五种鞋号系列供选择，它们分别是中国鞋号、法国鞋号、美国鞋号、英国鞋号、日本鞋号。可以根据设计的鞋底模型所采用的标准选择其中一种。

2. 中间号鞋模参数（即已设计好的鞋模的参数）：

a． 鞋号：

根据上一参数鞋号类型的选择不同，下拉列表中可选的鞋号参数也不相同。其中

中国鞋号分为：9号，9号半，…，30号。

法国鞋号分为：16号，17号，18号，…，48号。

美国鞋号分为：

a． 儿童：0.5号，1号1.5号，…，13.5号。

b． 成人：1号，1.5号，2号，…，13.5号。

英国鞋号分为：

a． 儿童：0.5号，1号1.5号，…，13.5号。

b． 成人：1号，1.5号，2号，…，13.5号。

日本鞋号分为：9号，9.5号，10号，…，30号。

b． 鞋型：

根据上一参数鞋号类型的选择不同，下拉列表中可选的鞋型参数不同。其中

鞋号为中国鞋号时，鞋型为：1型，1.5型，2型，…，5型等九种。

鞋号为法国鞋号时，鞋型为：A型，B型，C型，…，G型等七种。

鞋号为美国鞋号时，鞋型为：AAAA型，AAA型，AA型，A型，B型，C型，D型，E型，EE型等九种。

鞋号为英国鞋号时，鞋型为：A型，B型，C型，…，G型等七种。

鞋号为日本鞋号时，鞋型为：C型，D型，E型，EE型，EEE型，等五种。

c． 楦底样长：

“鞋号”选择不同的参数时，系统按各国家标准已设定相应的楦底样长参数，用户也可依据实际情况修改。

d． 楦底宽：

“鞋号”或“鞋型”选择不同的参数，系统依据各国家标准已设定相应的数值，用户也可依据实际情况修改。

e． 扩缩到：

鞋号：同“中间号鞋模参数”中的“鞋号”参数一样，“鞋号系列”选择不同的系列，下拉列表中会出现相应的参数可以选择。

鞋型：同“中间号鞋模参数”中的“鞋型”参数一样，“鞋号系列”选择不同的系列，下拉列表中会出现相应的参数可以选择。

f. 扩缩标准：

根据“鞋号系列”选择的不同系列，系统已按照各国家标准设定不同的值，用户可以根据实际情况改变参数。

点击确定后，系统自动扩缩中间号鞋底模型，生成要求的鞋号、鞋型的鞋底模型，并删除中间号鞋底模型。


3. 鞋底路径镜像

作用：

鞋底路径镜像功能可以简单、快捷、精确的实现左右脚鞋底路径的转换。

步骤：

a． 直接选择“专业功能→鞋模放码→鞋底路径镜像”菜单项，系统弹出“读鞋模加工工艺文件”对话框，如图4所示。

图4：读鞋模加工工艺文件对话框

b． 选择鞋模加工工艺文件，点击[打开]按钮后，系统将弹出“镜像文件另存为”对话框（如图5所示）。

镜像方位存为对话框

c． 输入文件名（即：镜像后生成的鞋模加工工艺文件名）。

d． 点击确定按钮后系统将生成镜像后的鞋模加工工艺文件（.sol）与镜像后的路径文件，并将它们存储在当前目录下。

注：镜像后路径文件的命规则，即在输入的鞋模加工工艺文件名称后加一字母作为镜像后的路径文件，该字母为镜像后路径文件表示工位的汉语拼音的第一个字母。例：如果我们把镜像后的工艺文件命名为Mirror（即在图5所示的对话框中的文件名中填入Mirror），则MirrorD、MirrorQ、MirrorH、MirrorZ和MirrorY分别表示镜像后的底面、前面、后面、左面和右面的加工路径。在使用镜像路径时屏幕内不能有刀具路径。


4. 鞋底路径放码

作用：

中间号鞋底设计好之后，利用鞋底扩缩功能，可自动得到全系列的鞋底模型型。当我们要扩缩的鞋号与现有的中间号鞋底鞋号相近时，也可以只对当前鞋号鞋底的刀具路径进行鞋底路径放码，达到快速生成新鞋号路径的目的。

步骤：

a． 不需要选择任何操作对象，直接选择“专业功能→鞋模放码→鞋底路径放码”，系统弹出“读鞋模加工工艺文件”对话框，如图4所示：

b． 选择要放码的鞋模加工工艺文件后系统弹出“鞋底扩缩”对话框（如图3所示），该对话框的设置方法与鞋底放码中的“鞋底扩缩”对话框的设置方法是一致的。但要注意鞋号不能变化太大否则会造成一定程度的失真。

a． 点击确定按钮后，系统将弹出“放码文件另存为”对话框（如图5所示）。

c． 输入文件名（即：放码后生成的鞋模加工工艺文件名）。

d． 系统将生成的放码后的工艺文件及刀具路径文件，并保存在同一目录下。文件的命名规则与鞋底镜像相同。


5.毛坯装夹

1. 毛坯装夹

图：5 毛坏装夹对话框

作用：

这里我们需要介绍一下鞋模加工的一般过程，在鞋模加工过程中第一个要加工的表面大部分为五个工位以外的第六个表面，铣平，切去部分轮廓，钻定位孔与装夹孔，加装夹具，分别加工另外五个工位。毛坯装夹这一功能以原点为中心生成夹具的轮廓和孔位，便于确定所采用的夹具的尺寸及其相对于模型的位置关系，同时也便于生成钻孔路径。使得鞋模的设计加工更加专业化，进一步减少了加工中的手工操作，提高了鞋模加工的工作效率。

步骤：

a． 不用选择任何对象，直接选择“专业功能→鞋底放码→毛坯装夹”，系统会在窗口右侧弹出挂装夹对话框（如图5所示）。

b． 选择装夹板的类型

c． 选择装夹板的形状

d． 填写装夹板的尺寸

e． 填写孔距及孔位

f． 点击确定后系统会自动生成夹具图形

g． 可以根据需要生成钻孔路径。


6.对刀点计算

1. 对刀点计算

作用：

鞋底五个加工面的刀具路径生成之后就要考虑一个问题：加工时是使用专用夹具装卡的，每加工一个工位都需要精确计算出每个加工工位的起刀点，在鞋模放码插件中和JDXM鞋模机的专用控制程序EN3DS中都提供了自动计算各加工工位起刀点的功能。下面将详细讲解鞋模放码插件中该功能的使用。

JDXM机的专用控制程序可自动设置鞋模加工时五个工位的起刀点。借助对刀仪，在加工过程中更换刀具及上下移动电机时都可进行自动补偿。鞋模放码插件中提供的对刀点计算功能原理上与JDXM机控制程序中对刀点计算相同。鞋模放码插件中计算对刀点可用来验证控制程序中的对刀点或用于没有JDXM机专用控制程序的场合。

步骤：

a． 选择“专业功能→鞋底放码→对刀点计算”菜单项，系统弹出“计算对刀点”对话框，如图6所示。

b． 选择夹具朝向。根据所使用的鞋模机夹具的安装方式选择。

图6：对刀点计算对话框

c． 填写路径参数，根据生成的鞋模底面路径填写。

d． 填写夹具参数，一台鞋模机的夹具参数一般是不变的，可以根据控制程序中的相应参数填写。

e． 填写对刀参数，根据实际对刀的情况填写。

f． 选择是否换刀，并填写换刀后的对刀值。（此步骤为可选步骤）

g． 点击“确定”，系统会弹出“通知”对话框（如图7所示），其中记录了不同工位时的起刀点的值。

图7：起刀点显示对话框

下面对对话框中的部分参数加以解释

a． 夹具朝向是针对现有鞋模机床夹具的不同摆放方位而设计的，选择时根据所使用的机床而定。

b． 路径参数中填写数值为鞋模底面路径的最高点的Z坐标值。

c． 对刀参数中的毛坯表面Z坐标可按如下方法测定：

① 将待加工毛坯以底面加工工位装卡到卡具上。

② 装上一把合适的刀具（该刀具为加工时的第一把刀具）。

③ 上下移动主轴机头，调节刀具到毛坯表面（一般还要在到达毛坯表面后再加深0.5毫米）。记录此时Z向的当前值，该值即为毛坯表面Z坐标。

d． 对刀参数中的第一次对刀值可按如下方法确定：

① 接上一步，在测定好Z坐标后，将当前值定义为毛坯表面Z坐标（在JDXM机的专用控制软件EN3DS中按Ctrl+X键将当前值定义为鞋底表面）

② 此时去对刀，得到的对刀基准即为第一次对刀值。

e． 夹具参数

这组参数每台机床都不完全相同，在出厂前都已经测定好，不可以随意修改，我们只需将测定好的值输入即可。

f． 换刀计算及换刀后的对刀值

在更换刀具或移动主轴等造成刀具在Z轴方向上发生变化后需要重新对刀并计算起刀点。这时要设定此参数，此时还需要设定前面测定的毛坯表面Z坐标和第一次对刀值。

注：该功能已经集成到鞋模专用的控制程序中了，在控制程序中使用要比这里简单的多，因为大部分的参数都已集成（夹具参数集成在控制程序中，夹具朝向和路径参数集成在鞋模工艺文件中。）因此只需设定毛坯表面Z坐标(鞋底表面)和第一次对刀值就可以了。


7. 定义鞋模加工工艺文件

作用：

鞋模加工时需要生成多个工位的刀具路径文件，鞋模加工工艺文件就是把加工鞋模各工位的刀具路径文件信息封装到一个文件中。路径放码, 镜像, 仿真及鞋模机专用加工控制程序可以由该加工工艺文件找到各工位的路径文件，进行整体的放码, 镜像,仿真和加工，可以直观的观察路径文件的位置情况，并大大简化鞋模专用机加工工艺。

步骤：

a． 击“专用功能→鞋模放码→定义鞋模加工工艺文件”，系统弹出定义鞋模加工工艺文件对话框，如图8所示：

图8： 定义鞋模加工工艺文件对话框

b． 输入底面路径最高点Z坐标值

c． 选择夹具朝向

d． 选择底面的粗加工路径（可选的）。

e． 分别选择添加已经生成的鞋模各工位的加工路径

f． 点击确定后系统将弹出“保存”对话框，选择工艺文件的存储路径（与路径文件的存储目录相同）及文件名。

g． 点击“保存”后系统将生成鞋模加工工艺文件

注1：各工位名称及模型摆放位置的约定

注2：工艺文件的处理方式

工艺文件是一文本文件，可以用记事本打开，可以自动生成，也可以直接用记事本创建或修改。工艺文件仅记录各个工位文件所在的位置及它们之间的相对位置关系，因此工艺文件不能替代各工位的刀具路径文件。鞋模工艺文件与其所对应的工位刀具路径文件必须在同一目录下。图10为一工艺文件

图10：鞋模工艺文件的格式

从上图中我们可以看到工艺文件中的记录。下面分别对其加以解释：

[Identification] JDP-SOL //ID JDP-SOL

[Version] 4.0 //版本 4.0

[Describation] Xyz company //备注 Xyz company

[MinPoint] 0. 0. 0. //最小点, 不用修改

[MaxPoint] 0. 0. 0. //最大点, 不用修改

[ModelSize] 0. 0. 0. //模型尺寸, 不用修改

[MaxSolePathZ] 0.000000 //模型底面路径的最大Z坐标

[FixtureOrientation] 1 //夹具朝向 0--朝前; 1--朝左

[Rough] 0 //开粗路径文件数, 不用

[Sole] 1 //底面路径文件数

d.ENG //底面路径文件名称

[Front] 1 //前面路径文件数

q.ENG //前面路径文件名

[Back] 1 //后面路径文件数

h.ENG //后面路径文件名

[Left] 1 //左面路径文件数

z.ENG //左面路径文件名

[Right] 1 //右面路径文件数

y.ENG //右面路径文件名


8. 鞋底路径多工位合成观察

作用：

鞋模加工文件由不同工位的多个刀具路径文件组成，那我们能不能将各加工工位的刀具路径合成在一起观察呢？这样也有利于及早发现问题，“鞋底多工位路径合成观察”命令就提供了这个功能.

步骤：

a． 择“专业功能→鞋模放码→鞋底多工位路径合成观察”菜单项，系统弹出“读鞋模加工工艺文件”对话框，如图11所示：

图11：读鞋模加工对话框

b． 选择要观察的鞋模加工工艺文件，点击“确定”按钮，该加工工艺文件所包含的各个刀具路径文件同时被调出来，并以其原有的相对位置关系显示在屏幕上。（如图12所示）

图12：使用鞋底多工位合成观察命令看到的路径


欢迎使用精雕软件

JDPaint是精雕科技多年来一直致力研制开发的、具有自主版权的、功能强大的专业雕刻CAD/CAM软件。JDPaint是精雕CNC数控雕刻系统正常运作的保证，也是有效提高CNC雕刻系统使用效率和产品质量的源泉。

JDPaint专业雕刻软件经过多年的发展完善，功能日趋丰富强大，不仅突破了如曲面浮雕、等量切削等多项关键雕刻设计及加工技术，也充分保证了软件产品的易用性和实用性，极大地增强了精雕CNC雕刻机的加工能力和对雕刻领域多样性的适应能力。在应用领域上，JDPaint软件已经彻底突破了适合标牌、广告、建筑模型等较为传统的雕刻应用范畴，在技术门槛更高的工业雕刻领域，如滴塑模、高频模、小五金、眼镜模、紫铜电极等制作业，表现同样出色，成为国内最优秀的雕刻软件。

目前，JDPaint已由较为单一的雕刻设计加工软件，逐步走向面向CNC产品加工的一整套解决方案。

产品服务:

精雕科技网址 www.jingdiao.com

问题反馈E-mail： soft@jingdiao.com

软件开发部电话：010-60803959, 010-60803960

精雕科技总机： 010-60801188

销售热线：010-51922006/7　　E-mail：market@jingdiao.com