曲面构建

第六章 曲面构建

几何曲面主要包含两种曲面类型：标准曲面和自由曲面。JDPaint中的自由曲面造型采用了NURBS作为几何描述的主要方法。

标准曲面是可以用简单的函数来表达的规则曲面，包括球面、柱面、锥面、环面等。标准曲面可以精确转化为NURBS曲面。构造标准曲面的操作过程比较简单，只要输入相应的参数，即可生成标准曲面。

构造自由曲面的操作过程相对复杂一些，一般来说需要通过拾取一些特征曲线并执行相应的曲面构造命令来构造出曲面。例如蒙皮面就需要一组空间曲线作为曲面的骨架。可以说曲线构造是曲面构造的基础。因此，必须学会灵活运用各种曲线绘制和几何变换工具。

系统提供了一组工具用于构造各种具有不同几何特征的几何曲面。与几何曲面构造功能有关的菜单位于 “几何曲面（G）” 主菜单内。

在构造曲面过程中，会经常遇到一些相同或相似的操作。这里就将这些常用操作提出来，进行简单介绍。更详细的说明请参考相关章节。在以后的各个曲面构造命令说明中对这些操作就不再重复叙述。这里主要涉及到的操作有：

曲线曲面的拾取 |
曲线曲面的反向 |
点输入方式 | 参见第二章
方向输入方式 | 参见第二章
轴线输入方式 | 参见第二章
平面输入方式 | 参见第二章


命令导航条

命令导航条简介

大多数曲面构造操作会在系统右边弹出一个导航条，用于进行参数设置和操作步骤导航，如图6-2所示。导航条通常包括以下几部分：

图6-2 曲面操作导航条

1） 子命令选项区

有的命令包括几个几个子命令。不同的子命令的参数选项和操作流程会有所不同。因此进入一个命令后的第一步就是选择需要的子命令。但多数命令都只有一个子命令，此时导航条上就不会出现子命令选项区。

2） 拾取对象列表区

拾取对象列表用于显示和管理拾取到的图形对象。一个拾取对象列表对应一个图形对象的拾取步骤，拾取结果（选中对象）的名字将显示在列表框内。

如果拾取对象列表所对应的拾取步骤为当前拾取步骤，该拾取对象列表就会被用绿色加亮显示 [image] ，表示其处于活动状态。此时新选中的图形对象就会被加入到该对象列表中。当拾取对象列表处于灰色状态 [image] 时，表示其对应拾取步骤不是当前步骤。

用鼠标点击一个拾取对象列表，当前拾取步骤就会切换到其对应的拾取步骤，该拾取对象列表也相应加亮显示。

当一个导航条上具有两个以上列表框时，列表框的标题可能具有不同的颜色，这表示该列表中选中对象的显示颜色。这样可以通过不同的颜色区分开不同拾取步骤的选中对象。

3） 拾取步骤按钮

有时命令需要拾取一些抽象的几何对象，例如平面、方向、轴线等，这些对象不是系统中实际存在的几何图形，因此用一个按钮来代表其拾取步骤。

如果拾取步骤按钮所对应的拾取步骤为当前拾取步骤，该按钮就会处于下压状态 [image] ，表示其处于活动状态。当按钮处于凸起状态 [image] 时，表示其对应拾取步骤不是当前步骤。

用鼠标点击一个拾取步骤按钮，其对应的拾取步骤就会变为当前拾取步骤，该按钮也相应变为下压状态。

按钮前面有一个小图标 [image] ，用来表示该拾取步骤是否已成功进行。拾取步骤尚未进行时图标显示为 [image] ，当该拾取步骤进行后，且拾取对象有效时，该图标会变为 [image] ,表示该拾取步骤已成功进行。

4） 参数设置区

命令执行中需要输入的一些辅助参数和选项设置会放置在该区域。

5） 拾取方式设置区

当命令处于某一个拾取步骤时，该步骤可供选择的拾取方式将显示在该区域。

以上五个部分不是每个命令都会全部具备，一个命令可能只具有其中的几个部分。


拾取图形对象

曲线曲面的拾取

1、拾取步骤

一个操作通常会包括若干个拾取步骤。每个拾取步骤会要求用户拾取满足一定条件（例如指定对象类型）的对象，只有满足条件的对象才能被选中。例如“吸附裁剪”操作就需要拾取一组被裁剪曲面和一组曲线作为剪刀线，也就是包含两个拾取步骤，第一个步骤要求拾取曲面，第二个步骤要求拾取曲线。

每个拾取步骤会产生一组拾取对象（拾取结果），因此，在操作导航条中都会有一个拾取对象列表框与相应的拾取步骤对应，用于显示被选中对象的名字（系统中每个图形对象都有一个唯一的名字），如图6-3所示。在每个拾取步骤中，依次用鼠标左键拾取满足该步骤所要求条件的对象，被选中的对象的名字将出现在对应的列表框中。在拾取对象列表框中选中对象的名字，其对应的图形就会闪亮。

(a)被拾取对象 (b)导航条上的拾取对象列表框

图6-3 拾取对象列表

当某个拾取步骤正在进行中时，其对应的列表框将变亮。由于每次只能进行一个拾取步骤，所以导航条上最多只有一个列表框变亮，提示当前正在进行的拾取步骤。同时系统底部的工具栏上会出现该拾取步骤的提示，例如： 。操作时应时刻注意当前所处的拾取状态，以免发生误选。

一个拾取步骤进行完毕，可以切换到另一个拾取步骤。系统提供三种切换拾取步骤的方式：

一个拾取步骤进行完毕，点击鼠标右键进入导航条上位于其下方的下一个拾取步骤。通过点击鼠标右键，可以从上至下遍历命令必需的所有拾取步骤。这是按命令预先设置的顺序来切换拾取步骤。

在操作过程中要直接切换（跳跃）到某一个拾取步骤，用鼠标左键点击其对应的列表框即可。当发现任何一个拾取步骤的拾取结果有问题时，都可以直接切换到该拾取步骤，重新拾取或调整图形对象。

通过各拾取步骤对应的快捷键（标题左边方括号里的字母）来切换拾取步骤。

(a) “选择曲面”为当前拾取步骤 (b) “选择边界线”为当前拾取步骤

图6-4 当前拾取步骤

2、删除误选对象

在实际操作中误选是难以避免的，系统提供两种方法来删除误选对象：

1）在拾取对象列表框中选中该对象的名字，按“Delete”键；

2）在拾取对象列表框中选中该对象的名字，在右键弹出菜单中选择“删除选中项目”菜单项，如图6-5所示；

3）在某些操作中再次拾取该对象的图形（用鼠标左键再次点击该对象图形）也可去除该误选对象。

对某一拾取步骤的纠正并不会影响任何其它的拾取步骤。用户可以在各拾取步骤间随意切换，进行调整，直到所有拾取对象和参数设置都正确以后，再点击“确定”按钮执行整个命令。

(a) 删除误选曲线前 (b) 删除误选曲线后

图6-5 删除误选对象

3、拾取方法

如果当前拾取步骤允许采用多种拾取方式，系统会在导航条的下部显示“拾取模式”选项，如下图6-6所示。用户可以选择需要的拾取方式后再进行拾取。

图 6-6 曲线拾取模式

曲线和曲面最常用的拾取方式为“单个拾取”，用鼠标左键点击曲线或曲面即可拾取曲线。此外还可以用“窗口拾取”方式来拾取落在窗口内的所有曲线或曲面。在某些操作中，还可以用“串链拾取”方式来拾取一系列首尾相连的曲线。灵活运用不同的拾取方式，会大大加快拾取过程。

有些操作允许先选中图形对象，再选择菜单进入操作命令。进入操作命令后预先选中的图形对象便会自动分类出现在相应的拾取对象列表框中，如图6-7所示。

(a) 选中曲面和要投影的曲线 (b) 曲面和曲线分别出现在各自列表框中

图6-7 先选中图形对象，再进入操作命令


曲线曲面反向

曲线曲面的反向

有很多操作需要输入拾取曲线或曲面的方向。当曲线或曲面被选中后，其方向将用一个红色的箭头显示出来。

有两种方法来改变被选中曲线或曲面的方向：

1）在拾取对象列表框中选中要反向的对象，点击鼠标右键弹出右键菜单，在菜单中选择“反向选中对象”即可，如图6-8(a)所示。

2）在拾取对象列表框中点击鼠标右键弹出右键菜单，选择“反向所有对象”可将列表框中所有被选中对象进行反向，如图6-8(b)所示。

反向前 反向后

(a) 曲面反向

反向前 反向后

(b) 曲线反向

图6-8 曲面曲线反向


标准曲面

标准曲面是可以用简单的函数来表达的规则曲面，包括球面、柱面、锥面、环面、椭球面等。标准曲面的构造过程相对比较简单。只要输入相应的参数，即可生成标准曲面。


球面

根据给定的球心及半径构造一个半球面。

图6-15 球面

* 操作步骤：

1） 选择菜单项： | 点击菜单“曲面→标准曲面（S）→球面（S）”。
2） 设置参数： | 系统右边出现“球面”导航条。在导航条中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。球心坐标可直接从键盘输入，也可以通过拾取指定点来输入。
3）点击“确定”按钮： | 参数确认无误后，点击导航条上“确定”按钮，球面生成。

图6-16 球面参数

参数定义：

类型 | “凸面”表示生成球面的上半部分，“凹面”表示生成球面的下半部分。
球心坐标 | 球心坐标的X，Y，Z值。可直接从键盘输入，也可以通过拾取指定点来输入。
球半径 | 球的半径。


柱面

根据给定参数构造一个半圆柱面。

图6-17 柱面

* 操作步骤：

1） 选择菜单项： | 点击菜单“曲面→标准曲面（S）→柱面（C）”。
2） 设置参数： | 系统右边出现“柱面”导航条。在导航条中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。原点坐标可直接从键盘输入，也可以通过拾取指定点来输入。
3）点击“确定”按钮： | 参数确认无误后，点击导航条上“确定”按钮，柱面生成。

参数定义：

图6-18 柱面参数

类型 | “凸面”表示生成柱面的上半部分，“凹面”表示生成柱面的下半部分。
原点坐标 | 圆柱左侧面的圆心坐标值。 可直接从键盘输入，也可以通过拾取指定点来输入。
柱面长度 | 柱面沿轴线方向的长度。
柱面半径 | 圆柱的截面半径。
与X轴角度 | 圆柱的中心轴线与X轴的夹角。


锥面

根据给定参数构造一个半圆锥面。

图6-19 锥面

* 操作步骤：

1） 选择菜单项： | 点击菜单“曲面→标准曲面（S）→锥面（N）”。
2） 设置参数： | 系统右边出现“锥面”导航条。在导航条中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。原点坐标可直接从键盘输入，也可以通过拾取指定点来输入。
3）点击“确定”按钮： | 参数确认无误后，点击导航条上“确定”按钮，锥面生成。

参数定义：

图6-20 锥面参数

类型 | “凸面”表示生成锥面的上半部分，“凹面”表示生成锥面的下半部分。
原点坐标 | 圆锥左侧面的圆心坐标值。 可直接从键盘输入，也可以通过拾取指定点来输入。
锥面长度 | 锥面沿轴线方向的长度。
锥面半径1 | 圆锥左侧截面的半径。
锥面半径2 | 圆锥右侧截面的半径。
与X轴角度 | 圆锥的中心轴线与X轴的夹角。


环面

根据给定参数构造一个半圆环面。

图6-21 环面

* 操作步骤：

1） 选择菜单项： | 点击菜单“曲面→标准曲面（S）→环面（T）”。
2） 设置参数： | 系统右边出现“环面”导航条。在导航条中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。原点坐标可直接从键盘输入，也可以通过拾取指定点来输入。
3）点击“确定”按钮： | 参数确认无误后，点击导航条上“确定”按钮，环面生成。

参数定义：

类型 | “凸面”表示生成环面的上半部分，“凹面”表示生成环面的下半部分。
原点坐标 | 圆环的中心坐标值。 可直接从键盘输入，也可以通过拾取指定点来输入。
外环半径 | 环的最大半径。
内环半径 | 环的最小半径。

图6-22 环面参数


椭球面

根据给定参数构造一个半椭球面。

图6-23 椭球面

* 操作步骤：

1） 选择菜单项： | 点击菜单“曲面→标准曲面（S）→椭球面（T）”。
2） 设置参数： | 系统右边出现“椭球面”导航条。在导航条中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。原点坐标可直接从键盘输入，也可以通过拾取指定点来输入。
3）点击“确定”按钮： | 参数确认无误后，点击导航条上“确定”按钮，椭球面生成。

参数定义：

类型 | “凸面”表示生成椭球面的上半部分，”凹面”表示生成椭球面的下半部分。
原点坐标 | 椭球的中心坐标值。 可直接从键盘输入，也可以通过拾取指定点来输入。
椭球半径 | 椭球在X、Y、Z三个方向的半径。

图6-24 椭球面参数


平面

与绘图平面不同，几何曲面中的“平面”是实际存在的几何面，是具有边界的，可以对它进行裁剪﹑倒角等曲面编辑操作。根据平面的边界形状，可以将其分为矩形平面和边界平面。


矩形平面

边界为矩形的几何平面。有“两点平面”和“三点平面”两种构造方式。

1、两点平面

通过指定矩形的两个角点来构造一个位于当前作图平面内的矩形平面，如图5-12所示

图5-12 两点平面

* 操作步骤：

1） 进入命令： | 点击菜单“几何曲面→平面→矩形平面”，在右边导航条上选择“两点平面”选项。
2） 拾取角点1： | 拾取矩形平面的第一个角点。 角点坐标可直接从键盘输入，也可以通过拾取指定点来输入。
3） 拾取角点2： | 拾取矩形平面的第二个角点。

2、 三点平面

通过拾取三个空间点构造一个矩形平面，该矩形平面可以不落在当前作图平面内，如图5-13所示。

图5-13 三点平面

* 操作步骤：

1） 进入命令： | 点击菜单“几何曲面→平面→矩形平面”，在右边导航条上选择“三点平面”选项。
2） 拾取点1： | 拾取矩形平面的第一个角点。
3） 拾取点2： | 拾取矩形平面的第二个角点。
4） 拾取点3： | 拾取矩形平面的第三个角点。


边界平面

通过拾取位于同一平面内的一个或多个闭合轮廓来构造一个或多个具有边界的平面。闭合轮廓包括外轮廓和内轮廓。系统用一个外轮廓和若干个内轮廓对一张无边界的平面进行裁剪，生成一个带边界的平面，如图6-32所示。

图6-32 边界平面

* 操作步骤：

1） 选择菜单项： | 点击菜单“曲面→边界平面”。
2） 拾取闭合轮廓： | 拾取构成闭合轮廓的曲线。 曲线可以为组合线，也可以为单根曲线。系统会对所拾取的所有曲线进行连接，把它们组成闭合轮廓。 轮廓之间最好不要相交或重叠。
3）点击“确定”按钮： | 闭合轮廓确认无误后，点击导航条上“确定”按钮。

功能异常说明：

无法生成边界平面

若拾取的曲线无法构成闭合轮廓或不在同一平面内（偏离平面的误差超过允许值），将无法生成边界平面。


自由曲面

6.4 自由曲面

构造自由曲面的操作过程相对复杂一些，一般来说需要通过拾取一些特征曲线并执行相应的曲面构造命令才能构造出自由曲面。在执行曲面构造命令前需要把这些特征曲线绘制好，并调整好其空间位置。例如蒙皮面就需要一组方向相同，形状相似，按顺序排列的空间曲线作为曲面的骨架。可以说曲线构造是曲面构造的基础。因此，必须学会灵活运用各种曲线绘制和几何变换工具。由于大多数曲面构造命令都要求事先准备好合乎要求的特征曲线，在后面各命令的具体说明中就不再一一强调这一点了。

很多操作要求拾取曲线作为所生成曲面的特征线，这些曲线既可以是绘制的曲线，也可以是曲面的边界线。大多数曲面操作中要求输入的曲线必须为光滑曲线（直线、圆弧、样条曲线等）或光滑组合曲线（或多义线）。对于光滑组合线，系统自动将其转为单根光滑样条线。若不加说明，后面提到的“光滑曲线”均指这两类曲线。这里所说的“光滑”是指曲线上没有尖角，或相邻两线段的转角小于一定值。应当尽量避免用不光滑的曲线来构造曲面，因为这样构造出来的曲面会产生尖棱，给许多后续操作带来麻烦。


拉伸面

将拉伸曲线沿指定方向拉伸指定的距离而构造出的曲面称为拉伸面。也可以理解为将拉伸曲线（底部轮廓）沿指定拉伸方向平移指定的距离（拉伸高度），得到另一根曲线（顶部轮廓），在两根曲线间用直线进行连接（作直纹面）而形成的曲面。

拉伸时还可指定倾斜角度，使拉伸曲线在拉伸的同时进行缩放，最终形成一个带拔模斜度的拉伸曲面，如图5-15所示。

图5-15 拉伸面

实现方法：

（1）拾取一根或多根拉伸曲线；

（2）输入拉伸方向；

（3）设置拉伸参数。

* 操作步骤：

1） 选择菜单项： | 点击菜单“几何曲面→拉伸面”。
2） 拾取拉伸曲线： | 拾取一根或多根平面曲线作为拉伸曲线。 拉伸曲线可以为单根曲线，也可以为多义线，但必须共面。 拾取完毕点击鼠标右键。
3） 输入拉伸方向： | 用矢量输入工具获取或直接输入拉伸的方向矢量。具体操作方法请参考“几何曲面操作概述”中的说明。 拉伸方向不能平行于拉伸曲线所在平面。
4） 设置参数： | 系统右边出现“拉伸面”导航条。在导航条中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。
5）点击“确定”按钮： | 系统根据所设置的参数对将生成的曲面进行预显，注意观察是否合乎要求。 确认无误后，点击导航条上“确定”按钮。

参数定义：

拉伸面参数

拉伸方向 | 拉伸曲线的拉伸方向，由一个方向矢量定义，如上图所示。
拉伸距离 | 拉伸曲线沿拉伸方向的平移距离，如图5-15所示。 拉伸高度为负值时相当于反向拉伸。 拖动右边的滑杆可以动态改变拉伸高度。
倾斜角度 | 拔模斜度，拉伸曲面与平行轴线方向的锥度角，如图5-15所示。 倾斜角度为正值时拉伸曲面沿拉伸方向呈收缩趋势（向内拔模），角度为负值时拉伸曲面沿拉伸方向呈放大趋势（向外拔模）。倾斜角度范围是-90°~90°。 当拉伸曲线不封闭时，倾斜角度方向无法确定。
双向拉伸 | 将拉伸曲线沿拉伸方向的正向和反向同时拉伸，如图5-16(b)所示。
加上盖 | 当拉伸曲线组成闭合轮廓时在拉伸曲面的顶部加上一个以顶部轮廓为边界的平面，如图5-16(c)所示。
加下盖 | 当拉伸曲线组成闭合轮廓时在拉伸曲面的底部加上一个以底部轮廓为边界的平面，如图5-16(d)所示。
过渡类型 | 当倾斜角度不为0时，一组首尾相连的拉伸曲线拉伸成的曲面之间可能会产生缝隙。为了将各拉伸曲面连接起来，需要用增加过渡曲面等方式来补上这些缝隙。有以下三种连接方式： 1） 圆角过渡 在各拉伸面之间采用圆弧过渡方式进行光滑连接，如图5-16(e)所示。 2） 尖角过渡 将各拉伸面沿缝隙处的边界进行延伸，使其相交并互相裁剪，从而消除相互间的缝隙，如图5-16(f)所示。 3） 截断过渡 用一张三角平面将拉伸面间的缝隙补上，如图5-16(g)所示。

(a) 单向拉伸 (b) 双向拉伸

(c) 加上盖 (d) 加下盖

(e) 圆角过渡 (f) 尖角过渡

(g) 截断过渡

图5-16 拉伸面参数设置示意

功能异常说明：

拉伸面自交： | 当倾斜角度过大时，可能会导致拉伸面产生自交。应当避免生成这种不理想的几何形状。


直纹面

由一根直线的两端点分别在两条曲线（截面线）上匀速运动而形成的轨迹曲面称为直纹面，如图5-17所示。直纹面以两条截面线为骨架，用直线连接两个截面线。

图5-17 直纹面

直纹面的截面线可以是普通光滑曲线，也可以是一个空间点，如图5-18所示。

曲线 + 曲线

曲线 + 点

图5-18 直纹面种类

实现方法：

（1）选择构造直纹面命令；

（2）拾取两根或多根截面线。

* 操作步骤：

1） 选择菜单项： | 点击菜单“几何曲面→直纹面”。
2） 拾取截面线： | 按截面线的排列顺序依次拾取两根或多根截面线。 截面线可以为光滑曲线或空间点，也可以为组合线。当截面线为不光滑组合线时，各截面线的段数应相等。 如果需要在连续多个拾取截面线之间生成直纹面，在系统右边导航条上正确设置连续生成方式（参考“参数定义”中的说明），然后按截面线的排列顺序依次拾取截面线。
3）点击“确定”按钮： |  | 系统对将生成的曲面进行预显，注意观察是否合乎要求。 确认无误后，点击导航条上“确定”按钮。

参数定义：

生成方式：

指定在连续拾取多根截面线时截面线的配对关系，如图5-20所示。

1) 连续生成 在一组连续拾取的截面线间连续生成直纹面。

2) 间隔生成 在一组连续拾取的截面线间间隔生成直纹面，这时应拾取偶数根截面线。

连续生成 间隔生成

图5-20 直纹面生成方式

功能异常说明：

曲面扭曲：

当截面线为闭合曲线时，应注意两根截面线的起点的对应情况。一般来说，两根闭合截面线的起点最好互为最近点，否则可能产生扭曲，如图5-21所示。

图5-21 截面线起点对应不好导致曲面扭曲


旋转面

轮廓曲线按给定的起始角度和终止角度绕一旋转轴线旋转而形成的轨迹曲面就是旋转面，如图5-22所示。

图5-22 旋转面

实现方法：

（1）拾取一段或多段轮廓曲线； （2）输入旋转轴的起点和方向矢量； （3）设置参数。

* 操作步骤：

1） 选择菜单项： | 点击菜单“几何曲面→旋转面”。
2） 拾取轮廓曲线： | 拾取一段或多段轮廓曲线。 轮廓曲线可以为单根曲线，也可以为多义线（可以光滑也可以不光滑）。 轮廓曲线最好和旋转轴在同一平面内，且不要横跨旋转轴。 拾取完毕点击鼠标右键。
3） 拾取旋转轴： | 用矢量输入工具获取或直接通过键盘输入旋转轴的起点和方向矢量。
4） 设置参数： | 在系统右边的导航条中设置各项参数，各参数具体含义可以参考“参数定义”中的说明。
5）点击“确定”按钮： | 系统对将生成的曲面进行预显，注意观察是否合乎要求。 确认无误后，点击导航条上“确定”按钮。

参数定义：

图5-23 旋转面参数

轴起点 | 旋转轴的起点。该点可以是旋转轴通过的任意一个空间点。
轴矢量 | 旋转轴的方向矢量。
起始角 | 旋转面的起始角度，角度正向按右手螺旋规则确定。轮廓曲线所在的原始位置的角度为0度。起始角范围为-360度到+360度。
终止角 | 旋转面的终止角度。终止角范围为-360度到+360度，且终止角应大于起始角。

旋转面轴线的方向与轮廓线旋转的正方向有直接关系，遵守“右手螺旋”规则，如图5-24所示，右手大拇指的指向与轴线的方向一致，其余四个手指的指向就是轮廓线旋转的正方向。

图5-24 “右手螺旋”规则


单向蒙皮面

单向蒙面

以一组方向相同，形状相似的截面线为骨架，在其上蒙上一张光滑曲面，称为单向蒙皮面。蒙皮面通过各个截面线，并光滑连接各个截面线，如图6-51所示。

蒙皮面与直纹面在构造方法上非常相似。只是直纹面在截面线之间以直线连接，而蒙皮面在各个截面线之间以光滑曲线连接。

图6-51 单向蒙皮面

实现方法：

（1）进入“单向蒙皮面”命令；（2）依次拾取截面线。

* 操作步骤：

1） 选择菜单项： | 点击菜单“几何曲面→单向蒙面”。
2） 拾取截面线： | 按截面线的排列顺序依次拾取截面线。 截面线必须为光滑曲线。
3） 设置参数： | 在系统右边的导航条中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。
4）点击“确定”按钮： | 参数确认无误后，点击导航条上“确定”按钮。

参数定义：

图6-52 闭合曲面示意

闭合曲面：

生成一张闭合的蒙皮面，且曲面在第一根截面线处光滑连接。

功能异常说明：

曲面扭曲：

当截面线为闭合曲线时，应注意截面线的起点的对应。一般来说，各截面线的起点最好互为最近点，否则可能生成扭曲的曲面，如图6-53所示。

a） 正常蒙皮面

(b) 截面线起点对应不好导致曲面扭曲

图6-53 蒙皮面扭曲原因


双向蒙皮面

在两组纵横交错的截面线构成的骨架上蒙上一张光滑曲面，称为双向蒙皮面。双向蒙皮面分别通过两组截面线，并光滑连接各个截面线。

单向蒙皮面是采用一组单向截面线构造曲面，构造出来的曲面只能反映出一个方向的变化趋势。而双向蒙皮面还可以指定另一个方向的截面线，用来进一步控制曲面的形状，从而反映出两个方向的变化趋势。如图5-28所示。

图5-28 双向蒙皮面与单向蒙皮面的区别

从图5-28可以看出：采用U向截面线1、2、3、4、5构造单向蒙皮面时，其边界轮廓完全由U向截面线确定，不能对V向形状进行控制。而采用双向蒙皮面时，除了U向截面线外，还可以选择V向截面线1、2，这样得到的曲面的边界通过V向截面线，也就是可以控制曲面的V向形状。

双向蒙皮面的U向截面线数和V向截面线数都可以大于或等于2，但不能小于2，如图5-29所示。

图5-29 双向蒙皮面

实现方法：

（1）拾取U向截面线。

（2）拾取V向截面线。

* 操作步骤：

1） 选择菜单项： | 点击菜单“几何曲面→双向蒙皮”。
2） 拾取U向截面线： | 按U向截面线的排列顺序依次拾取U向的截面线。 截面线必须为光滑曲线。 拾取完毕点击鼠标右键。
3） 拾取V向截面线： | 按V向截面线的排列顺序依次拾取V向的截面线。 截面线必须为光滑曲线。

4） 设置参数： | 在系统右边的导航条中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。
5）点击“确定”按钮： | 参数确认无误后，点击导航条上“确定”按钮。

参数定义：

拟合精度：

曲面对截面线的贴近程度。精度越高，曲面越精确，但数据量也越大。

对于截面线有如下要求：

（1）每个截面线都必须为单根光滑曲线。

（2）纵横两个方向的截面线应该在网格点处相交。这样生成的曲面才能很好的蒙在截面线上，否则将会产生不确定的偏差。

（3）截面线两端可以伸出网孔外，生成曲面时网孔外的线段将被裁剪掉。裁剪后必须形成规则网格，如图5-31所示。

（4）两组截面线形成的网孔必须为四边形网孔，不允许出现三边形及五边形网孔。且每行和每列的网孔数必须相等，不能出现不完整网孔，如图5-32所示。当各个四边形网孔形状较为规则和均匀时生成的曲面形态才较好。

(a) 截面线 (b) 双向蒙皮面

图5-31 修剪网孔外的线段形成规则网格

图5-32 非法截面线


边界面

在已知曲线围成的边界区域内生成的光滑曲面称为边界面，如图5-33所示。边界面按边界的数目可分为四边面和三边面。在四条首尾相接的边界线内生成的曲面，称为四边面。类似地，在三条首位相接的边界线内生成的曲面称为三边面。

图5-33 边界面

* 操作步骤：

1） 选择菜单项： | 点击菜单“几何曲面→边界面”。
2）拾取边界线： | 按边界线排列顺序依次拾取边界曲线。边界曲线必须为光滑曲线。 注意边界线必须首尾相接且连成一个闭合区域。
3）点击“确定”按钮： | 确认无误后，点击导航条上“确定”按钮。

功能异常说明：

边界线不闭合： | 当边界线不闭合时无法生成边界面。这时应注意检查边界线之间的间隙是否过大。


等距面

按给定的等距（偏移）方向和距离，生成与已知曲面等距的曲面。等距面的性质与等距线相似，等距面的各个点到原始曲面的距离等于给定的距离，如图5-35所示。

等距面的形状不仅受原始曲面的影响，而且与偏移距离及偏移方向有关。

图5-35 等距面

实现方法：

（1）拾取需要进行等距的一个或多个曲面；

（2）输入偏移距离。

* 操作步骤：

1） 选择菜单项：

点击菜单“几何曲面→等距面”。

2） 拾取曲面：

拾取需要进行等距的一个或多个原始曲面。改变曲面的法矢方向可以改变等距方向。

3） 设置参数：

在系统右边的导航条中输入偏移距离。

4）点击“确定”按钮：

参数确认无误后，点击导航条上“确定”按钮。

参数定义：

图5-36

偏移距离： | 等距面的各个点到原始曲面的距离,输入负数可以反向等距。 拖动编辑框下面的滑杆可以动态地修改偏移距离。

功能异常说明：

无法生成等距面： | 当原始曲面上的某些点处不光滑或法线不唯一，则不能生成等距面或出现错误。
等距面自相交： | 如果等距距离大于原始曲面的最小曲率半径，等距面可能出现异常，如原始曲面的一部分在等距面上消失、等距面自相交或出现尖棱等，如图5-37所示。

图5-37 等距面自相交


管道面

根据指定的中心线及半径值构造截面为圆形的管道面。管道面实际上是以一个给定半径的整圆为截面线，以中心线为轨迹线的单截面单轨扫掠面。在扫掠过程中，圆形截面线总是与轨迹线垂直，且圆心始终位于轨迹线上，如图5-38所示。

图5-38 管道面

实现方法：

（1）拾取管道的中心线；

（2）设置管道圆截面的半径值。

* 操作步骤：

1） 选择菜单项：

点击菜单“几何曲面→管道面”。

2） 拾取中心线：

拾取一根光滑曲线作为管道的中心线。

3） 设置参数：

设置管道圆截面的半径值。

管道半径应小于中心线最小曲率半径。

4）点击“确定”按钮：

参数确认无误后，点击导航条上“确定”按钮。

参数定义：

图5-39 管道面参数

双半径管道 | 选中该选项则管道起始圆截面的半径和终止圆截面的半径可以不相等。
管道半径1 | 管道起始圆截面的半径值。拖动编辑框下面的滑杆可以动态地修改半径值。 管道半径应小于中心线最小曲率半径，否则生成的管道曲面将产生自交现象。
管道半径2 | 管道终止圆截面的半径值。拖动编辑框下面的滑杆可以动态地修改半径值。

功能异常说明：

曲面自交：

当中心线不光滑或管道半径大于中心线最小曲率半径时，曲面在拐角处会产生自交，如图5-40所示。此时应调整半径值或将轨迹线在拐角处打断，分段生成管道面。

图5-40 管道面产生自交


旋转扫掠面

将截面线绕指定旋转轴旋转，同时对截面线进行调整（平移和缩放），以保证其端点搭在轨迹线上，这样形成的轨迹曲面称为旋转扫掠面。旋转扫掠可以视为旋转与扫掠的结合，如图5-49所示。

旋转扫掠的轨迹线可以为一根也可以为两根。

图5-49 旋转扫掠

实现方法：

（1）拾取一根光滑曲线作为截面线；

（2）拾取一根或两根光滑曲线作为轨迹线；

（3）拾取旋转轴。

* 操作步骤：

1） 选择菜单项： | 点击菜单“几何曲面→旋转扫掠”。
2） 拾取截面线： | 拾取一根光滑曲线作为截面线。 拾取完毕点击鼠标右键。
3） 拾取轨迹线： | 拾取一根或两根光滑曲线作为轨迹线。 拾取完毕点击鼠标右键。
4） 拾取旋转轴： | 用矢量输入工具获取或直接通过键盘输入旋转轴的起点和方向矢量。 若轨迹线为闭合曲线，旋转轴必须被包围在轨迹线内。 截面线与旋转轴应位于同一平面内，且截面线不要横跨旋转轴，否则生成的曲面形状将难以预料。
5）点击“确定”按钮： | 参数确认无误后，点击导航条上“确定”按钮。

参数定义：

图5-50 旋转扫掠参数

轴起点 | 旋转轴的起点，该点可以是旋转轴通过的任意一个空间点。
轴矢量 | 旋转轴的方向矢量。
截面线高度 | 该设置仅在单轨扫掠且轨迹线为非平面曲线或轨迹线所在平面与旋转轴不垂直时有意义，这两种情况用得要少一些。在轨迹线为非平面曲线且轨迹线平面与旋转轴垂直时这两个选项产生的结果是一样的。 1）高度可变 扫掠过程中截面线高度（沿旋转轴方向的投影长度）可变，这样在生成的旋转扫掠面的一端随着轨迹线的起伏趋势变化，另一端将保持平齐，如图5-51(a)所示。 2）高度不变 扫掠过程中截面线高度不变，生成的旋转扫掠面的两端都随着轨迹线的起伏趋势变化，如图5-51(b)所示。

(a) 高度可变 (b) 高度不变

图5-51 轨迹线为空间曲线的单轨旋转扫掠

功能异常说明：

曲面扭曲 | 在生成双轨扫掠曲面时，轨迹线的方向必须一致，否则生成的曲面将是扭曲的。
曲面不通过轨迹线 | 从旋转扫掠的性质可以看出它只适用于轨迹线较为规则圆整的情况，严格地说，就是任意一个过旋转轴的旋转半平面与轨迹线只能有一个交点。如图5-52所示的轨迹线是不合理的。

图5-52 不合法的旋转扫掠轨迹线


扫掠面

6.4.8 扫掠面

将截面线沿着一条或两条轨迹曲线运动而扫出的曲面，称为扫掠面。截面线通过扫掠运动及形状变化而构成扫掠面的骨架，用来控制扫掠面一个方向上的形状。而轨迹线则用来引导和约束截面线的运动，确定截面线在空间的位置。

扫掠面的构造规则是非常灵活多样的。截面线的数量可以为一个或多个。轨迹线也可以为一根或两根。在扫掠过程中，可以对截面线和轨迹线施加不同的几何约束，让截面线和轨迹线之间保持不同的位置关系，还可以对截面线施加各种变形规则，从而生成形状多样的扫掠面。


单截面单轨

单截面单轨扫掠面是将一个截面线沿着单根轨迹线的方向运动扫掠而形成的曲面，如图5-41所示。

图5-41 单截面单轨扫掠

实现方法：

（1）拾取一根曲线作为截面线；

（2）拾取一根光滑曲线作为轨迹线；

（3）设置扫掠的各种控制参数。

* 操作步骤：

1） 选择菜单项： | 点击菜单“几何曲面→扫掠面→单截面-单轨”。
2） 拾取截面线： | 拾取一根曲线作为截面线。截面线最好为平面曲线。 拾取完毕点击鼠标右键。
2） 拾取轨迹线： | 拾取一根光滑曲线作为轨迹线。
4） 设置参数： | 在系统右边的导航条中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。
5）点击“确定”按钮： | 参数确认无误后，点击导航条上“确定”按钮。

在生成扫掠面之前，应当将轨迹线和截面线都摆放在希望曲面生成的位置上，并调整好截面线与轨迹线的空间位置。只有当轨迹线的起点落在截面线上时曲面才会既通过截面线又通过轨迹线，否则优先通过截面线。截面线所在平面最好垂直于轨迹线，这样生成的扫掠面才比较光顺。

参数定义：

图5-42 单截面单轨扫掠参数

扫掠方式 | 设置截面线所在平面的法矢方向在扫掠过程中的变化方式。 1）旋转扫掠 截面线沿轨迹线运动时，按照轨迹线各点处的切矢方向做相应的旋转，从而保持截面线所在平面的法矢与轨迹线的切矢方向的相对角度不变，如图5-43(a)所示。 2）平移扫掠 截面线在轨迹线各点处的方位保持不变。即截面线所在平面的法矢在运动过程中始终平行于其初始法矢方向，如图5-43(b)所示。
截面变形 | 截面变形是指在扫掠过程中对截面线施加的形状和方位变化，用于丰富扫掠曲面的形状变化。 1） 截面缩放 截面线在扫掠过程中进行缩放，缩放比例由起始比例平滑过渡到终止比例，如图5-43(e)所示。 2） 截面扭转 截面线在扫掠过程中进行扭转，也就是截面线将在自身平面内绕着轨迹线的切矢进行旋转，旋转角度从0逐步过渡到扭转角度。如图5-43(d)所示。 3） 截面倾斜 截面线所在平面在扫掠过程中绕着截面线平面与轨迹线平面的交线进行旋转（前倾或后倾），旋转角度从0逐步过渡到倾斜角度。如图5-43(c)所示。如果截面线为直线则不进行倾斜。
起始比例 | 截面线在轨迹线起点处的缩放比例。
终止比例 | 截面线在轨迹线终点处的缩放比例。
扭转角度 | 截面线在轨迹线终点处相对于起点处的扭转角度，截面线在扫掠过程中将从起点开始逐步进行扭转，角度从0逐步过渡到设定的扭转角度。
倾斜角度 | 截面线在轨迹线终点处相对于起点处的倾斜角度，截面线在扫掠过程中将从起点开始逐步进行倾斜，角度从0逐步过渡到设定的倾斜角度。

(a) 旋转扫掠 (b) 平行扫掠

(c) 截面倾斜 (d) 截面扭转

(e) 截面缩放

图5-43 单截面单轨扫掠各种不同截面约束的效果


单截面双轨

单截面双轨扫掠面是将截面线搭在两条轨迹线上，并沿着轨迹线的方向运动扫掠而形成的曲面，如图5-44所示.

(a) 截面高度不变 (b)截面高度可变

图5-44 单截面双轨扫掠

实现方法：

（1）拾取一根曲线作为截面线；

（2）拾取两根光滑曲线作为轨迹线；

（3）设置参数。

* 操作步骤：

1） 选择菜单项： | 点击菜单“几何曲面→扫掠面→单截面-双轨”。
2） 拾取截面线： | 拾取一根曲线作为截面线。 拾取完毕点击鼠标右键。
3） 拾取轨迹线： | 拾取两根光滑曲线作为轨迹线。 第二根轨迹线允许为空间点。
4） 设置参数： | 系统右边出现导航条。在导航条中输入各项参数，各参数具体含义可以参考“参数定义”中的说明。
5）点击“确定”按钮： | 参数确认无误后，点击导航条上“确定”按钮。

在生成扫掠面之前，应当将轨迹线和截面线都摆放在希望曲面生成的位置上，并调整好截面线与轨迹线的空间位置。只有当轨迹线的起点落在截面线上时曲面才会既通过截面线又通过轨迹线，否则优先通过截面线。

参数定义：

图5-45

截面线高度：

在扫掠过程中，截面线的两端分别搭在两条轨迹线上运动，如果两条轨迹线的间距发生变化，截面线的宽度将随之发生变化，截面线的高度（指截面线自身的尺寸高度，而不是坐标高度）则有两种变化方式可以选择：

1）高度可变：截面线的高度在扫掠过程中随着两根轨迹的相距宽度发生变化，而且变化比例相等，从而保持不同位置处各截面形状的相似性。在两条轨迹线相距较宽的地方，相应的截面线高度也较大，反之，在两条轨迹线相距较窄的地方，相应的截面线高度也较小，如图5-44(b)所示。

2）高度不变：截面线的高度在扫掠过程中保持不变。这样生成的扫掠面的高度沿着轨迹线方向将保持相等，如图5-44(a)所示。

功能异常说明：

曲面边界与轨迹线不吻合

只有当轨迹线的起点落在截面线上时曲面才会既通过截面线又通过轨迹线。


多截面扫掠

多截面单/双轨

指截面线数大于1时，轨迹线数为1或2时形成的扫掠面。初始截面线沿着一根或两根轨迹线扫掠，并逐步平滑过渡到下一个截面的形状。生成的扫掠面将插值通过所有截面线，并在各截面线间平滑过渡。最常用的有单轨双截面扫掠，单轨多截面扫掠，双轨双截面扫掠等。

单轨双截面扫掠是将第一根截面线搭在一条轨迹线上，沿着轨迹线的方向运动扫掠，并逐步平滑过渡到第二根截面线的形状而形成一张扫掠曲面，如图5-46所示。

图5-46 双截面单轨扫掠

单轨多截面扫掠将第一根截面线搭在一条轨迹线上，沿着轨迹线的方向运动扫掠，并依次平滑过渡到后面的几根截面线形状而形成一张扫掠曲面，如图5-47所示。

图5-47 多截面单轨扫掠

双轨双截面扫掠是将第一根截面线搭在两条轨迹线上，沿着轨迹线的方向运动扫掠，并逐步平滑过渡到第二根截面线形状而形成的曲面，如图5-48所示。

图5-48 双截面双轨扫掠

实现方法：

（1）拾取多条截面线； （2）拾取一条或两条轨迹线。

* 操作步骤：

1） 选择菜单项： | 点击菜单“几何曲面→扫掠面→多截面-单/双轨”。
2） 拾取截面线： | 依次拾取多条截面线，截面线必须为光滑曲线。 拾取完毕点击鼠标右键。
3） 拾取轨迹线： | 拾取一条或两条轨迹线，轨迹线必须为光滑曲线。
4）点击“确定”按钮： | 参数确认无误后，点击导航条上“确定”按钮。

在生成扫掠面之前，应当将轨迹线和截面线都摆放在希望曲面生成的位置上，并调整好截面线与轨迹线的空间位置。只有当轨迹线的起点落在截面线上时曲面才会既通过截面线又通过轨迹线。截面线所在平面最好尽量垂直于轨迹线，这样生成的扫掠面才比较光顺。


曲面编辑

第七章 曲面编辑

虽然几何曲面构造工具提供了多种构造曲面的方法，但在表达一些复杂形体时仍显得不够用。这时就需要使用几何曲面编辑工具对已构造好的几何曲面进行进一步的编辑，从而产生合乎需要的复杂曲面形状。

曲面编辑包括曲面延伸、两面拼接和曲面编修等功能。与曲面编辑功能有关的菜单位于 “曲面（S）” 主菜单内。


两面拼接

两面拼接是在两曲面间，或者曲面与曲线之间，或者曲线与曲线之间做一张拼接曲面对它们进行光滑连接。

在曲面与曲面之间做拼接面可以将不相连的两个曲面光滑地连接在一起，形成整体光滑的曲面组，如图6-3所示。

图6-3 曲面与曲面拼接

还可以在曲面与曲线、曲线与曲线之间作拼接面。在曲线与曲线之间做拼接面，其效果等同于在两条曲线之间生成直纹面。

图6-4 曲面与曲线拼接

实现方法：

（1）拾取第一根需要进行拼接的曲面边界线或曲线；

（2）拾取第二根需要进行拼接的曲面边界线或曲线。

* 操作步骤：

1）选择菜单项： | 点击菜单“几何曲面→两面拼接”。
2）拾取第一根曲面 边界线或曲线： | 拾取第一根需要进行拼接的曲面边界线或曲线。 如果是对曲面进行拼接，应拾取其需要进行拼接的那根边界线（注意是拾取曲面边界线而不是拾取曲面），如果是对曲线进行拼接则直接拾取该曲线。
3）拾取第二根曲面 边界线或曲线： | 拾取第二根需要进行拼接的曲面边界线或曲线。
4）设置参数： | 调整拼接曲面的凹凸程度。 系统将对曲面拼接效果进行预显，注意观察生成的过渡面是否合乎要求。

5）点击“确定”按钮：

确认无误后，点击导航条上“确定”按钮。

参数定义：

图6-6 曲面拼接参数

形状凹凸控制

拖动滑杆可以控制拼接曲面的凹凸程度，如图6-7所示。

这实际上是调整曲面边界线上跨界切矢的长度，因此只有在对曲面进行拼接的时候才有效。

图6-7 形状凹凸控制


曲面延伸

将曲面沿边界进行平滑延伸。在实际绘图时，由于某种原因，可能使绘制的曲面不到位（短了或窄了），这时可用曲面延伸功能对曲面进行延伸，如图7-3所示。

对于旋转面﹑球面﹑锥面等具有旋转特征的特殊曲面，当所选延伸边界为其母线时，将按照其自然定义方式进行延伸（改变旋转角度），如图7-3 (b)所示。一般的样条曲面则沿曲面边界的切向延伸出去，如图7-5(a)所示。

(a) 切向延伸

(b) 自然延伸

图7-3 曲面延伸

实现方法：

（1）选择要延伸的曲面边界

（2）设置要延伸的曲面边界的延伸比例。

* 操作步骤：

1） 选择菜单项： | 点击菜单“曲面（S）→曲面延伸（T）”。
2） 拾取曲面边界： | 拾取需要进行延伸的曲面边界。 只能拾取非裁剪边界。
3） 设置参数： | 在右边导航条上设置要延伸的曲面边界的延伸长度或延伸比例。 系统会根据所设置的参数进行延伸预显，注意观察延伸结果是否合乎要求。
4）确定退出 | 确认无误后，点击右键，选择右键菜单中的“确定命令”菜单项或直接点击右边导航条上“确定”按钮。

参数定义：

图7-4 曲面延伸参数

按比例延伸 | 通过设置延伸部分长度与原曲面长度之比来确定延伸长度
按长度延伸 | 直接设置延伸部分的长度
删除原始面 | 曲面延伸后是否还保持原始曲面

功能异常说明：

裁剪面不能进行延伸

不能对裁剪面的裁剪边界进行延伸。


曲面编修

几何（NURBS）曲面的形状由其控制顶点确定，曲面的控制顶点大致反映了曲面的形状变化趋势，因而可以通过调整或增删曲面的控制顶点来改变曲面的形状，以达到所期望的外形，如图7-58所示。

(a) 编修前

(b) 编修后

图7-58 曲面编修

实现方法：

（1）拾取要进行编修的曲面；

（2）调整曲面的控制顶点。

* 操作步骤：

1） 选择菜单项： | 点击菜单“曲面（S）→曲面编修（I）”。
2） 拾取曲面： | 拾取要进行编修的曲面。
3） 编辑控制顶点： | 利用各种编辑方式调整曲面的控制顶点，从而实现对曲面形状的编辑调整。
4）点击“确定”按钮： | 修改确认无误后，点击导航条上“确定”按钮。

* 由于移动控制顶点最为常用，下面介绍一下移动控制顶点的操作步骤。

1） 设置“变换方式”： | 将“变换方式”设置为“随手移动。
2） 选择控制顶点： | 选择要移动的控制顶点。 可以选中一个或多个控制顶点，具体方法请参考“参数定义”中关于“选点方式”的说明。 被选中的控制顶点将以红色显示，同时一个彩色的坐标架将显示在被选中控制点上（有多个控制点被选中时坐标原点落在多个控制顶点的重心上），指示该点的XYZ方向（红色为X轴，绿色为Y轴，蓝色为Z轴），如图7-58(b)所示。该坐标架将作为控制顶点移动的参考坐标架。
3） 设置“变换约束”： | 根据需要对控制点的移动施加一定的约束。 假如希望控制点只沿Z轴移动，就选择“Z”选项。假如希望限制控制点只在XY平面内移动，就选择“XY”选项。具体请参考“参数定义”中关于“变换约束”的说明。
4） 移动控制顶点： | 用鼠标左键点击彩色坐标架原点（注意不要点击箭头），并按住左键不放，向新的位置方向移动，移动到新的位置后松开鼠标左键，控制顶点即被移动到新位置。
5）重复2-4步的操作： | 重复2-4步的操作，直到获得满意的曲面形状。

参数定义：

图7-59 曲面编修参数

变换方式

对控制顶点的编辑方式。“随手移动”较为常用，“比例变换”和“旋转变换”不易控制，编修后的曲面形状难以预料，建议尽量少用。

1） 1） 随手移动：被选中的控制顶点随鼠标移动，直接修改控制顶点的坐标分量。操作时用鼠标左键点击彩色坐标架原点，并按住左键不放，移动鼠标，控制顶点将随着鼠标的移动而移动。

2） 2） 比例变换：将选中的多个控制顶点相对于彩色坐标架原点沿指定的方向进行比例（缩放）变换。操作时用点击鼠标左键，并按住左键不放，向外（离开彩色坐标架原点）移动鼠标，控制顶点将随着鼠标的移动而进行缩放。注意必须选中多个控制顶点才能进行“比例变换”，此时坐标原点落在多个控制顶点的重心上。

3） 3） 旋转变换：将选中的多个控制顶点绕指定的轴线进行旋转变换。操作时用鼠标左键点击一个被选中的控制顶点，并按住左键不放，移动鼠标，控制顶点将随着鼠标的移动而进行旋转。注意必须选中多个控制顶点才能进行“旋转变换”，此时坐标原点落在多个控制顶点的重心上。

变换约束

用鼠标拖动控制顶点时，对控制顶点的移动方式施加一定的限制，这样可以更好地控制编修操作。

1） 1） 当变换方式为“随手移动”时：

l l X、Y、Z选项分别表示控制顶点只能沿着彩色坐标架的X、Y、Z三个坐标轴移动；注意在操作时用鼠标左键点击彩色坐标系的任何一个箭头，变换约束都将切换到该箭头对应的坐标轴上。例如点击红色箭头变换约束都将被设置为X轴。

l l XY、YZ、ZX选项分别表示控制顶点只能在XY、YZ、ZX三个坐标平面内移动；

l l 曲面法向选项表示控制顶点只能沿着曲面法矢方向移动。

2） 2） 当变换方式为“比例变换”时：

l l X、Y、Z选项分别表示控制顶点将沿X、Y、Z三个方向进行缩放；

l l XY、YZ、ZX选项分别表示控制顶点将在XY、YZ、ZX三个坐标平面内进行缩放。

l l 曲面法向选项表示控制顶点将沿曲面法矢方向进行缩放。

3） 3） 当变换方式为“旋转变换”时：

l l X、Y、Z选项分别表示控制顶点将绕着X、Y、Z三个坐标轴旋转；

l l 曲面法向选项表示控制顶点将绕着曲面法矢方向旋转。

选点方式

1） 1） 单选或框选：只选中被直接拾取的控制顶点。

2） 2） U线上的点列：拾取一个控制顶点后，U向上与该顶点在同一列的所有控制顶点均被选中。

3） 3） V线上的点列：拾取一个控制顶点后，V向上与该顶点在同一列的所有控制顶点均被选中。

被选中的控制顶点将以红色显示，同时一个彩色的坐标架将显示在被选中控制点上（有多个控制点被选中时坐标原点落在多个控制顶点的重心上），指示该点的XYZ方向（红色为X轴，绿色为Y轴，蓝色为Z轴）。该坐标架将作为控制顶点移动的参考坐标架。

倍增控制线

倍增控制线用于将曲面的控制顶点加倍，以增加编修的灵活度。因为可供调整的控制顶点越多，对曲面的调整就可以更细微。

1） 1） 行线：U向上的控制顶点加倍。

2） 2） 列线：V向上的控制顶点加倍。

3） 3） 双向：UV两个方向上的控制顶点均加倍。

插入控制线

在曲面的指定位置处插入一排控制顶点，以增加编修的灵活度。

1） 1） 行：在指定位置插入一行控制顶点。

2） 2） 列：在指定位置插入一列控制顶点。

3） 3） 双向：在指定位置插入一行和一列控制顶点。

删除控制线

当曲面的控制顶点过多时，可以删除一些控制顶点以简化曲面的编修。

1） 1） 行：在指定位置删除一行控制顶点。

2） 2） 列：在指定位置删除一列控制顶点。

3）双向：在指定位置删除一行和一列控制顶点。

修改点坐标

拾取一个目标点，将当前选中的控制顶点的坐标修改为与目标点相同。可以选择只修改部分或全部三个坐标分量。

共线

使被选中的控制顶点落在一条直线上。

先选中要修改的控制顶点，再选择要落在其上的直线即可。

施加磁场

选中该选项并设置磁场半径后，系统显示一个以彩色坐标架原点为中心的球状磁场区域。在移动彩色坐标架时，位于该区域内部的被选中控制顶点将按其距离磁场中心的距离远近而移动不同的距离。可以想象为在磁场中心（彩色坐标原点）放置了一块磁铁，磁场半径是它的影响范围，而在被选中的控制顶点处放置了相同的铁块。当移动磁铁（彩色坐标原点）时，位于磁场区域内的控制顶点将随之移动。离它越近的顶点受到的作用力越强，越远的顶点受到的作用力越弱。

注意只有选中多个控制顶点施加磁场才有意义。

磁场半径

磁场的影响区域为一个球状区域，其半径即为磁场半径。位于影响区域外的控制顶点将不受磁场力的影响。

曲面显示精度

曲面显示的精细程度。


转为网格面

将几何曲面转为网格面。几何曲面转换为网格面后，就可以用来与艺术浮雕进行各种拼合运算，实现各种复杂的造型。

实现方法：

（1）拾取需要转为网格面的几何曲面；

（2）设置参数。

* 操作步骤：

1） 选择菜单项： | 点击“几何曲面（G）→转为网格面（C）”。
2） 拾取曲面： | 依次拾取需要转为网格面的几何曲面。
3）设置参数： | 在系统右边的导航条上设置与转换有关的参数。参数的具体说明请参考“参数定义”。
4）点击“确定”按钮： | 确认无误后，点击导航条上“确定”按钮。

参数定义：

图6-15 转为网格面参数

非均匀（自适应）网格 | 非均匀（自适应）网格是根据给定的误差值，在弯曲较大的地方用较密的网格逼近曲面，在弯曲较小的地方用较疏的网格逼近曲面，即自动按照曲面的平坦度（曲率）的不同，生成疏密有致的网格。使生成的网格面与NURBS曲面之间最大距离小于给定的逼近精度，同时总的三角面数最小。
转换精度 | 进行非均匀网格转换的逼近精度。
均匀网格 | NURBS曲面是用UV两个方向的等参数线来表示的，均匀网格转换就是将U方向的等参数线分成若干等份，将V方向的等参数线分成若干等份，然后将这些等分点规则地连接成为网格。
U向网格数 | 均匀网格转换的U向网格数。
V向网格数 | 均匀网格转换的V向网格数。

均匀网格的优点在于：计算时间少，生成速度快，网格疏密度可直观地由U向数目和V向数目的大小来控制。均匀网格的缺点在于：在曲面拐角的地方，虽然网格密度已经很大，当仍然会将其遗漏。使得到的网格与原始曲面有较大差异。

非均匀网格的优点在于：当曲面较平直时，用很少的几个三角片就可以逼近曲面，这种情况对于平面、直纹面尤其明显。而且会自动搜索曲面有拐角的地方，保证生成的网格不失真。同时产生的网格面片较少，这对于减少曲面生成加工路径的时间，以及提高曲面渲染的速度都将十分明显。非均匀网格的缺点在于：计算时间较长，当逼近误差较小时，生成速度较慢。因此，在实际使用中应当根据曲面的具体情况采用不同的网格化方法。

图6-16是一个四棱台的NURBS曲面，分别按照均匀和非均匀转换的结果。

图6-16 几何曲面转为网格面


曲面上线

第八章 曲面上线

我们说曲线是构造曲面的基础，但是有一些曲线的构造却要依赖于已有的几何曲面。这些曲线一类为几何曲面上的特征线，例如曲面边界线、曲面组边界线、曲面流线、曲面交线等。这类曲线隐含在曲面内，在某些情况下需要把它们显式地抽取出来，为其它操作提供便利。另一类与曲面相关的曲线则是将几何曲面外的曲线通过某种方式映射到曲面上，得到贴合在曲面上的对应曲线。这类曲线的构造方法包括曲线投影、曲面上画线等。

与曲面上线功能有关的菜单位于 “绘制（D）” 主菜单的“曲面上线（U）”的菜单组中。


空间直线

通过两个空间（三维）点绘制一条直线。可连续输入多个点来绘制连续的空间直线段，如图8-1所示。

图8-1 空间直线

实现方法：

1、进入“空间直线”命令；

2、输入直线起点；

3、输入直线末点。

* 操作步骤：

1） 进入“空间直线” 命令： | 点击“三维曲线(C)”-> “空间直线(L)”菜单项。
2） 输入直线起点： | 输入直线起始点，可以通过键盘输入点的X，Y，Z三个坐标或捕捉一个空间点。
3） 输入直线终点： | 输入直线的终点，可以通过键盘输入点的X，Y，Z三个坐标或捕捉一个空间点。 可连续输入多个点来绘制连续的直线段，单击右键结束。

说明：

1、可以打开绘图的正交模式来绘制水平或垂直的直线。

2、绘制时必须处于“空间”绘图状态，才能绘制出真正的空间曲线。


三维样条曲线

该命令提供了三种绘制样条曲线的方式，如图8-2所示：

图8-2 样条绘制导航工具栏选项

过顶点： | 通过定义样条曲线所通过的一系列点来绘制样条曲线。
过点+两端切矢： | 通过定义样条曲线所通过的一系列点和首末两个端点的切矢来绘制样条曲线。
控制顶点： | 通过定义样条曲线的控制多边形的顶点来绘制样条曲线。

说明：当前绘图状态必须为“空间”绘图状态，才能绘制出真正的空间曲线

8.1.2.1 样条 >> 过顶点

通过定义样条曲线所通过的一系列点来绘制样条曲线，如图8-3所示。

图8-3 过顶点样条曲线

实现方法：

（1）进入“三维样条曲线”命令；

（2）选择“过顶点”绘制方式；

（3）依次输入样条曲线所通过的一系列空间点。

* 操作步骤：

1）进入“三维样条曲线”命令： | 点击“绘制(C)”->“三维样条曲线(N)”菜单项。
2）选择“过顶点”绘制方式： | 选择导航工具栏中的 [image] 绘制选项。
3）输入样条通过点： | 依次输入样条曲线所通过的一系列空间点，可连续输入多个点，单击右键结束。

8.1.2.2 样条 >> 过点 + 两端切矢

通过定义样条曲线所通过的一系列点和首末两个端点的切矢来绘制样条曲线，如图8-4所示。

图8-4 过点+两端切矢样条曲线

实现方法：

（1）进入“三维样条曲线”命令； （2）选择“过点+两端切矢”绘制方式；

（3）依次输入样条曲线通过的一系列空间点； （4）输入起末两个端点切矢的末点。

* 操作步骤：

1） 进入“三维样条”命令： | 点击“绘制(C)”->“三维样条曲线(N)”菜单项。
2） 选择“过点+两端 切矢” 绘制方式： | 选择导航工具栏中的 [image] 绘制选项。
3） 输入样条通过点： | 依次输入样条曲线所通过的一系列空间点，可连续输入多个点，单击右键结束。
4） 输入起点切矢： | 输入样条起点切矢的末点。系统以样条曲线起点作为起点切矢的起点，所输入的点作为起点切矢的末点。
5） 输入末点切矢： | 输入样条末点切矢的末点。系统以样条曲线末点作为末点切矢的起点，所输入的点作为末点切矢的末点。

8.1.2.3 样条 >> 控制顶点

通过定义样条曲线的控制多边形的顶点来绘制样条曲线，如图8-5所示。

图8-5 控制顶点样条曲线

实现方法：

（1）进入“三维样条曲线”命令；

（2）选择“控制顶点”绘制方式；

（3）依次输入样条曲线的控制顶点。

* 操作步骤：

1） 进入“三维样条”命令： | 点击“绘制(C)”->“三维样条曲线(N)”菜单项。
2） 选择“控制顶点” 绘制方式： | 选择导航工具栏中的 [image] 绘制选项。
3） 输入控制顶点： | 依次输入样条曲线的控制顶点，可连续输入多个点，单击右键结束。


曲面交线

生成两组曲面的交线，如图8-6所示。

图8-6 曲面交线

实现方法：

（1）拾取第一组曲面；

（2）拾取第二组曲面。

* 操作步骤：

1） 选择菜单项： | 点击菜单“绘制→曲面上线→曲面交线”。
2）拾取第一组曲面： | 依次拾取第一组曲面。 拾取完毕点击鼠标右键。
3）拾取第二组曲面： | 依次拾取第二组曲面。
4）确定退出 | 确认无误后，点击鼠标右键，选择弹出菜单中的“确定命令” 菜单项或点击右边导航条上的“确定”按钮。

参数定义：

交线精度

由于曲面的原始交线是由一系列非常密集的交点组成的折线段，数据量太大，需要用光滑的样条曲线来逼近（拟合）这些折线段。拟合精度用于控制拟合样条曲线与折线段的最大偏差。拟合精度越高，样条曲线与原始交线越接近，但数据量也越大。


曲面边界线

提取出一张曲面的一段或多段边界线，包括裁剪边界线，如图8-12所示。

曲面 曲面边界线

图8-12 提取曲面边界线

* 操作步骤：

1） 选择菜单项： | 点击菜单“绘制→曲面上线→曲面边界线”。
2）拾取曲面边界线： | 依次拾取要提取出来的曲面边界线。可以拾取一段或多段边界线。
3）设置参数： | 设置边界线的拟合精度等参数。
4）点击“确定”按钮： | 确认无误，点击“确定”按钮。

参数定义：

拟合精度 | 拟合精度用于控制拟合样条曲线与折线段的最大偏差。拟合精度越高，样条曲线与原始边界线越接近，但数据量也越大。
最大转角 | 拟合时将一根边界线在不光滑连接的地方断开，分成多段光滑样条曲线。当边界线前后两段形成的夹角大于设定的“最大转角”时，认为边界线在此处不光滑，应予以断开。


曲面组边界线

提取出一组首尾相连的曲面构成的曲面整体区域的外边界线，不包括曲面间的重合边界，如图8-9所示。

曲面组 曲面组边界线

图8-9 提取曲面组边界线

实现方法：

（1）拾取一组首尾相连的曲面；

（2）设置边界线的连接精度和拟合精度。

* 操作步骤：

1）选择菜单项： | 点击菜单“绘制（C）→曲面上线（U）→曲面组边界线（P）”。
2）拾取曲面： | 依次拾取一组首尾相连的曲面。
3）设置参数： | 设置边界线的连接精度和拟合精度等参数。
4）确定退出 | 确认无误后，点击鼠标右键，选择弹出菜单中的“确定命令”菜单项或点击右边导航条上的“确定”按钮。

参数定义：

连接精度 | 相邻的两张曲面之间可能会有微小的缝隙，这样它们的外边界线的端点之间也会存在缝隙。当这些缝隙小于一定的临界值时，可以忽略该缝隙，认为边界线是相连的，将它们组合到一根边界线曲线中。该临界值就称为连接精度。 当边界线间的缝隙大于连接精度时，边界线将分段生成。
拟合精度 | 系统将用光滑的样条曲线来逼近（拟合）裁剪边界，拟合精度用于控制拟合样条曲线与原始边界线的最大偏差。拟合精度越高，样条曲线与原始边界线越接近，但数据量也越大。
最大转角 | 拟合时将一根边界线在不光滑连接的地方断开，分成多段光滑样条曲线。当边界线前后两段形成的夹角大于设定的“最大转角”时，认为边界线在此处不光滑，应予以断开。


曲面流线

根据给定的参数方向和参数值从曲面上提取出一条曲面流线（等参数线），如图8-11所示。

图8-11 提取曲面流线

实现方法：

（1）拾取一张曲面； （2）设置参数方向及参数值。

* 操作步骤：

1） 选择菜单项： | 点击菜单“绘制→曲面上线→曲面流线”。
2）拾取曲面： | 拾取一张曲面。
3）设置流线方 向及参数值： | 在系统右边的导航条上设置流线方向及参数值。 当需要提取通过曲面上某一指定点的流线时，用鼠标拾取该指定点即可。该指定点的参数值将会反映到导航条上的曲面参数编辑框里。
4）点击“确定”按钮： | 系统将根据所设置的参数值对要生成的曲面流线进行预显，注意观察结果是否合乎要求。 确认无误后，点击“确定”按钮。

参数定义：

参数线方向 | 要生成的流线（等参数线）的方向，分为U，V两个方向。一次只能提取一个方向的流线。
U参数值 | 要生成的U向流线（等参数线）的参数值，该流线上的每一点在曲面上具有相等的U参数值。U参数值的范围在0到1之间。 拖动下面的滑杆可以动态地改变U参数值。
V参数值 | 要生成的V向流线（等参数线）的参数值，该流线上的每一点在曲面上具有相等的V参数值。V参数值的范围在0到1之间。 拖动下面的滑杆可以动态地改变V参数值。


曲线投影

将一组曲线投影到曲面上，得到其投影曲线，如图8-7所示。

图8-7 曲线投影

实现方法：

（1）拾取需要投影到曲面上的一组曲线；

（2）拾取一张或一组相连的曲面作为投影基面；

（3）选择投影方式。

* 操作步骤：

1） 选择菜单项： | 点击菜单“绘制→曲面上线→曲线投影”。
2） 拾取曲线： | 拾取需要投影到曲面上的一组曲线。 拾取完毕点击鼠标右键。
3） 拾取曲面： | 拾取一张或一组相连的曲面作为投影基面。 拾取完毕点击鼠标右键。
4） 选择投影方式： | 在系统右边的导航条上选择投影方式。
5) 输入投影方向 | 该步骤仅在“沿方向投影”时需要进行。 用方向输入工具输入投影方向。
6）点击“确定”按钮： | 确认无误后，点击导航条上“确定”按钮。

参数定义：

图8-8 曲线投影参数设置

投影方式：将曲线投影到曲面上的方式。

1）1）吸附到面上

原始曲线上的每一点都可以在曲面上找到一个与它距离最近的点，将这些最近点依次相连即可得到原始曲线在曲面上的投影线，如图8-9(a)所示。该方式相当于将曲线吸附到曲面上，适用于曲线上各点距离曲面较近的情况或某些不能用简单方向矢量投影的场合。

2）2）沿方向投影

将原始曲线上的各点沿一个矢量方向平行投影到曲面上，将这些投影点依次相连即可得到原始曲线在曲面上的投影线。可以想象为用一束平行光沿指定矢量方向照射原始曲线，原始曲线落在曲面上的影子即为投影曲线，如图8-9(b)所示。

(a) 曲面最近点投影

(b) 沿矢量方向投影

图8-9 投影方式示意

功能异常说明：

无法投影：

当投影线落在曲面外时，无法生成完整的投影曲线。


曲面上画线

在一张曲面上绘制一条或多条光滑样条曲线，曲线将贴合在曲面上，如图8-11所示。

图8-11 曲面上画线

实现方法：

（1）拾取一张曲面；

（2）在曲面上依次拾取样条曲线要通过的点。

* 操作步骤：

1）选择菜单项： | 点击菜单“绘制（C）→曲面上线（U）→曲面上画线（D）”。
2）拾取曲面： | 拾取一张曲面。
3）拾取曲线要通过的点： | 在曲面上依次拾取样条曲线要通过的点。拾取点时尽量让当前画线部位正对着自己。
4）右键回车： | 要结束绘制并生成绘制曲线，点击鼠标右键即可。此时可继续绘制下一条曲线。 要退出绘制过程，按ESC键。

功能异常说明：

拾取不到曲面上的点

拾取点时尽量让当前画线部位正对着自己。


欢迎使用精雕软件

JDPaint是精雕科技多年来一直致力研制开发的、具有自主版权的、功能强大的专业雕刻CAD/CAM软件。JDPaint是精雕CNC数控雕刻系统正常运作的保证，也是有效提高CNC雕刻系统使用效率和产品质量的源泉。

JDPaint专业雕刻软件经过多年的发展完善，功能日趋丰富强大，不仅突破了如曲面浮雕、等量切削等多项关键雕刻设计及加工技术，也充分保证了软件产品的易用性和实用性，极大地增强了精雕CNC雕刻机的加工能力和对雕刻领域多样性的适应能力。在应用领域上，JDPaint软件已经彻底突破了适合标牌、广告、建筑模型等较为传统的雕刻应用范畴，在技术门槛更高的工业雕刻领域，如滴塑模、高频模、小五金、眼镜模、紫铜电极等制作业，表现同样出色，成为国内最优秀的雕刻软件。

目前，JDPaint已由较为单一的雕刻设计加工软件，逐步走向面向CNC产品加工的一整套解决方案。

产品服务:

精雕科技网址 www.jingdiao.com

问题反馈E-mail： soft@jingdiao.com

软件开发部电话：010-60803959, 010-60803960

精雕科技总机： 010-60801188

销售热线：010-51922006/7　　E-mail：market@jingdiao.com


北京精雕科技有限公司 版权所有 翻印必究

第六章 构建曲面

-194-

-153-

-151-


北京精雕科技有限公司 版权所有 翻印必究

第六章 几何曲面编辑

-204-

-203-

-191-