第一章 艺术曲面生成

艺术曲面是指由四边形及三角形组成的多边形网格，所以也称为网格曲面。网格曲面有以下几大特点：

1、网格致密。网格曲面用很多的小多边形表达曲面形态，因此网格必须致密才能保证形状误差较小。

2、数据量大。因为网格致密，如果曲面尺寸较大，必然导致数据量大。

3、非精确造型。用离散的网格表达连续的曲面，必然引入误差，但是曲面的主要尺寸如长、宽、高等还是可以精确控制的，误差只出现在曲面中间过渡部位，因此网格表示法的适应面还是很广的。

4、简单、直观。网格曲面生成、造型简单直观，形状描述能力无可比拟，随着计算机处理速度的不断提高及三维扫描输入技术的发展，网格曲面造型技术已成为CAD领域的一个越来越重要的分支。

按照组成网格曲面的多边形分类，网格曲面可分为如下几类：

1）普通网格——由四边形及三角形组成。

2）矩形网格——由MxN个按顺序水平放置的矩形组成。

3）拓扑矩形网格——由MxN个按顺序放置的四边形组成，如放样等生成的网格。

4）单向周期网格——拓扑矩形网格的一个特例，常用于表示辊筒。

下图是JDPaint5.0中提供的艺术曲面选项。

艺术曲面菜单栏


1.1 区域浮雕

根据曲面的边界曲线和曲面的截面特征构造艺术浮雕曲面（如图1-1所示）。区域浮雕能够根据边界曲线生成各种高度和截面形状的网格曲面（包括矩形网格和非矩形网格曲面），在实际中应用较多。

图1-1 区域浮雕

实现方法：

（1）选择曲线边界；

（2）边界曲线转换为浮雕曲面。

* 操作步骤：

1）点击菜单命令“区域浮雕”：鼠标点选。

2）选择曲面边界，即用鼠标点选或框选对象：边界曲线必须是封闭的文字或图形轮廓，边界曲线不能自交、不能重叠，以形成严格的区域。

3）设定浮雕曲面参数：浮雕参数包括截面形状、基准高度、侧面角度等。

4）生成浮雕曲面：设定完参数，点击“确定”按钮。

说明：按ESC键，结束区域浮雕命令。

区域浮雕参数定义：

本部分解释在区域浮雕中用到的参数变量（如图1-2所示）。

图1-2 区域浮雕参数设置


1.1.1 截面形状及其特点

截面形状：面形状包括矩形、三角、椭圆和样条四种，是网格曲面断面形状，分别如下图所示。

图1-3 矩形截面 图1-4 三角截面

图1-5 椭圆截面 图1-6 样条截面

1、矩形截面的主要特点：

（1） 曲面是一个在高度方向拉起的方块。

（2） 曲面的侧面垂直，表面水平。

（3） 主要用于构造规则的平台、平面等。

2、三角截面的主要特点：

（1） 侧面与底面构成一定的夹角（小于90度）。

（2） 曲面在中心位置出现尖棱。

（3） 主要用于构造类似于清角模型的曲面。

3、椭圆截面的主要特点：

（1） 曲面整体光滑。

（2） 截面的形状符合椭圆的变化。

（3） 曲面的边界与水平面必须构成一定的夹角。

（4） 通常用于构造各种光滑的网格曲面，是最常用的截面形式。

4、样条截面的主要特点：

（1） 可以构造出与底面光滑连接的网格曲面。

（2） 通常用于构造有特殊外形的网格曲面。

截面的形状不同，用于控制截面的形状参数也不相同。为了便于说明，我们用字母来表示对话框中的形状参数，其中 H0 – 基准高度，H1–实际高度，H – 限定高度，　A – 边界角度，形状系数S – 短轴半径／长轴半径。


1.1.2 矩形截面

它的形状参数只有基高一项，用于表示拉伸体的高度，当拉伸高度等于0时，构造的实际上是一张平面。如图1-7所示。

图 1-7 矩形截面


1.1.3 三角截面

构造出类似于清角模型的网格体，其参数含义如下图所示，其中形状系数仅仅用于变化基准高度H0以上的部分，如图1-8所示。

图 1-8 三角截面

三角截面的形状主要是通过倾斜角度A和三角高度控制的，倾斜角度是侧面与底平面之间的夹角，用角度表示。系统提供了五种控制三角高度的方法，即：自由高度(自由膨胀)、限定高度、实际高度、完全等高、部分等高。

用这五种控制三角高度造型效果分别如下图所示。

图 1-9 自由高度 图 1-10 实际高度 图 1-11 限定高度

图 1-12完全等高 图 1-13 局部等高

1、自由高度(自由膨胀)的效果特征：

（1）侧面与底面保持设定的角度；

（2）曲面在不同宽度的高度不同；

（3）曲面的最大高度取决于区域的最大宽度和侧面角度；

（4）相同参数条件下，区域或角度越大，曲面越高，区域或角度越小，曲面越低。

2、实际高度的效果特征：

（1）区域不分大小，最大高度总是用户设定的实际高度；

（2）区域的侧面角度是根据区域的宽度和实际高度计算获得的；

（3）在实际高度一定的情况下，区域越大，侧面角度越小；区域越小，侧面角度越大。

3、限定高度的效果特征：

（1）侧面与底面保持设定的角度；

（2）当所设定的限定高度小于区域计算出的曲面最大高度时，网格的高度将强制被抹平，即按照设定的限定高度生成网格曲面；当所设定的限定高度大于区域计算出的曲面最大高度时，其效果与自由膨胀的效果完全一致。

4、完全等高的效果特征：

（1）除了尖角外，曲面区域中心的高度与设定的高度完全一致；

（2）侧面与底面的角度是随着区域的宽窄变化的，区域越宽，角度越小，区域越窄，角度越大；

（3）设计的曲面具有更强的立体感。

5、局部等高的效果特征：

（1）是完全等高与限定高度的混合效果，当区域的宽度太大时，采用限定高度的方式，避免侧面角度太小，当区域的宽度较窄时，采用完全等高的方式，避免曲面的高度太低；

（2）侧面的角度是局部变化的，但总是大于用户设定的数值；

（3）当设定的角度太小时，效果与完全等高的效果完全一致。


1.1.4 椭圆截面

椭圆截面可以构造出整体光滑的网格曲面。截面形状总是使用部分椭圆曲线控制曲面的变化趋势，截断的这部分椭圆端点的切线与水平线的夹角就是侧面角度A。其中形状系数S仅仅用于变化基准高度H0以上的部分，如图1-14所示。

图 1-14

椭圆截面形状主要是通过倾斜角度A、短轴与长轴的比例S以及曲面高度控制的。

倾斜角度是侧面与底平面之间的夹角，用角度A表示。系统提供了五种控制椭圆高度的方法，即：自由高度(自由膨胀)、限定高度、实际高度、完全等高、部分等高，它们的效果特征与三角截面是一致的，其五种造型效果分别如图1-15—1-19所示。

图 1-15 自由高度 图 1-16 限定高度 图 1-17 实际高度

图 1-18 完全等高 图 1-19 局部等高


1.1.5 样条截面

样条截面可以构造更加随意的上表面形状，其中形状系数仅仅用于变化H0以上的部分。如图1-20所示。

图 1-20

样条截面的控制参数包括拉高比例、表面特点，也有五种造型效果，这与椭圆截面的效果大致相同。

1、基准高度：

一般用网格高度的数值来表示距离零平面的高度，有时所设计的曲面不是从零平面起始的，需要叠加在一个矩形块上，即曲面生成以后有一个“台阶”，我们可以在浮雕曲面参数设置中用基准高度的数值来表示这个“台阶”的高度。

前面讲解矩形截面时提到：针对于矩形截面网格来说，它只有一种高度定义方式，所以生成的网格高度就等于基准高度，但对于其他截面形状的网格来说，高度定义方式比较多，此时用基准高度的数值来表示网格曲面“台阶”的高度，台阶以上部分按照设置参数计算。

基准高度等于零，生成的曲面网格“台阶”等于零（图 1-21），基准高度大于零，生成的曲面网格“台阶”大于零（图1-22），如果基准高度小于零，则生成底面在零平面以下的网格曲面（图1-23）。

图 1-21 图 1-22 图 1-23

2、侧面角度：

在三角、椭圆、样条截面网格中，只要选择自由高度、限定高度、局部等高中的任何一种，就要对生成曲面网格的侧面角度进行设置。自由高度方式的网格曲面高度由区域边界大小和侧面角度决定，区域不变的情况下，侧面角度越大，曲面越陡峭，曲面高度越大。如下图所示

图 1-24 侧面角度较小 图 1-25 侧面角度较大

3、拉高比例：

是一个比例数值，即生成网格曲面高度与设置曲面高度的比例。此值一般为1，如果为零，生成曲面高度将为零；如果大于1，生成曲面比设置的曲面高度要大，反之则比设置的曲面高度小；如果小于零，则生成下凹的曲面。如下图所示

图 1-26 拉高比例=2 图 1-27 拉高比例=1 图 1-28 拉高比例= –1

4、形状系数S：

椭圆截面的短轴半径与长轴半径之比。

在设置椭圆截面形状参数的时候，可设置形状系数S。比值越大，曲面越陡峭；反之，比值越小，曲面变化越平缓，我们建议这个比值一般应该落在[0.2-1.0]这个范围之内。

为了进一步了解形状系数对椭圆截面的影响，我们来看一看下面的实例。

例 我们绘制一个圆，以它作为网格曲面的边界区域，它的半径是10mm(R=10mm)，如图1-29所示，截面形状采用“椭圆截面”，为了讲解的需要，边界角度输入90度，采用“自由高度”，拉高比例为1，形状系数输入0.6，表面特点选择“整体光滑”，基准高度为0，构造浮雕曲面，如图1-30（A）所示。

（A） [image] (B)

图 1-29 网格边界区域 图 1-30 浮雕曲面

图1-30（B）就是曲面在直径d处的截面形状，此时形状系数S等于h比d/2。在计算浮雕曲面时，比例系数越小浮雕曲面形状越扁平，比例系数越大浮雕曲面形状越饱满，但边界角度不变，如图1-31所示，这也是与拉高比例不同的地方。

边界角度是90度，形状系数是0.6的示意图

边界角度是90度，形状系数是0.3的示意图

图1-31

1） 当形状系数为1时，浮雕曲面形状最饱满，对于上面提到的参数设置情况，截面就是一个半圆，如图1-32所示。

图 1-32

2） 形状系数小于1时，浮雕曲面形状开始扁平，如图1-31所示。

3） 形状系数大于1时，浮雕曲面呈倒椭圆状，如图1-32所示。

图 1-32

4）形状系数等于零，网格高度为零，系统生成一平面，如图1-33所示。

图 1-33

以上是边界角度为90度的情况，对于0<边界角度<90的情况，变化规律是相同的，这里就不再赘述。

5、整体光滑：

曲面的变形比较柔软，缺少刚性，构造出曲面整体较光滑。

6、棱角清晰：

曲面尖角处采用延伸过渡，构造曲面整体的棱角清晰。效果对比如图1-34、图1-35所示。

图 1-34整体光滑 图 1-35棱角清晰

7、网格精度：

每个小网格的尺寸。

参数中还需设置网格的精度，网格设置中包括网格的尺寸精度和浮雕预览精度，网格的尺寸精度是每个小网格的尺寸，它的单位是毫米。系统默认网格尺寸精度x、y方向都为0.2mm，即每0.2mm×0.2mm区域内生成一个网格；此值越小，单位区域内生成网格数目越多，系统计算时间越长，反之网格数目越少，系统计算时间越短。用户可根据设计浮雕的表面精度要求来设定。

一般我们建议一张网格曲面的网格数目不要超过1000 X 1000 个，即x、y方向上精度为0.1~0.5，预览精度0.2~0.8，否则计算、预览的速度会受到影响。

考虑到时间上的利用，往往设计浮雕可以先选择较大的精度设置来确定思路，用相对较小的精度来最后设计。

由于网格曲面的最终形状取决于多个参数，通过组合这些参数便可以构造出各种各样的网格曲面。对初学者来说，熟练控制组合这些参数需要一段时间，但是只要经过一些实例的练习，用户不难掌握网格造型的一些技巧。

8、生成矩形网格：

生成的网格曲面是以所选边界曲线的矩形边界为边界，也就是说边界曲线内区域按照曲面设置参数生成网格，其他区域生成高度为零的平面，如果要按照边界曲线内区域生成网格，则要去掉生成矩形网格选项。

以下两图是这两种网格的对比效果：

以边界曲线为边界构造网格 矩形网格

图 1-36 非矩形网格和矩形网格对比

说明：矩形网格计算速度一般较快，我们会在后面章节中讲述矩形网格的具体用法。


1.2 单线浮雕

单线浮雕是将特征线（对特征线没有要求，可以是封闭的或者不封闭，相交或者不相交的曲线）构成的区域按照一定的高度、截面和边界角度进行浮雕处理，如图1-37和图1-38所示。单线浮雕有些类似区域浮雕，但是，区域浮雕对图形区域要求很苛刻，即区域的边界曲线必须要是封闭曲线；而单线浮雕不仅无此要求、对描图的要求不高，而且对描图中出现的交叉曲线也能处理；此外，线条越多越密，单线浮雕计算速度越快。

图1-37 特征线为不相交的曲线

图1-38 特征线为相交的曲线

* 操作步骤：

1）构造特征线：任意构造，特征线可以是闭合的，也可以是不闭合的或自交的。

2）选择单线浮雕命令，设定各项参数，完成设置，确定生成单线浮雕：从艺术曲面菜单上选择单线浮雕命令，设定其中的各项参数（其参数与区域浮雕中的参数类似），点击确定按钮生成单线浮雕。

单线浮雕参数定义：

如图1-39所示是单线浮雕参数的设置界面。

高度 | 包括自由高度、实际高度和限定高度，其含义和区域浮雕中的参数相同。请参见“区域浮雕”的相关参数说明。
截面 | 包括直线和圆弧。前者的截面为三角形，后者的截面类似椭圆。请参见“区域浮雕”的相关参数说明。
边界角度 | 特征线形成的侧面与水平面的夹角。请参见“区域浮雕”的相关参数说明。
步长 | 网格的尺寸精度是每个小网格的尺寸，系统默认网格尺寸精度x、y方向都为0.2mm，即每0.2mm×0.2mm区域内生成一个网格；此值越小，单位区域内生成网格数目越多，系统计算时间越长，反之网格数目越少，系统计算时间越短。用户可根据设计浮雕的表面精度要求来设定。
边界处理 | 包括只做闭合区域、包围盒约束和自由边界三个选项。 1）只做闭合区域：只对特征线中的曲线相交形成的闭合区域进行浮雕处理。如图1-40所示。 2）包围盒约束：浮雕曲面的边界要受到特征线包围盒的约束，其边界要与包围盒边界重合，形成的单线浮雕曲面在边界处的曲面高度为0，如图1-41所示。 3）自由边界：边界不受约束，形成的浮雕曲面的边界可以上翘，在边界处曲面高度一般不为0。如下图1-42所示。

图1-40 只做闭合区域

图1-41 包围盒约束

图1-42 自由边界

加密、磨光、细分：意义同“网格曲面加密/磨光/细分“，请参见“网格曲面加密/磨光/细分”的参数说明。


1.3 放样曲面

在曲面造型系统中，除了二次曲面（球面、柱面、锥面、圆环面等）和平面等少数可以直接定义的曲面外，绝大多数曲面都是自由曲面，这些曲面的构造过程必须依赖各种形式的曲线，由曲线生成曲面是曲面造型的基本方法，旋转面和扫描面就是通过曲线构造曲面的典型实例。放样曲面是一种更加高级的扫描曲面，它将扫描面的截面线个数拓展到多个，将扫描曲线的个数也拓展到两个，形成了一套完整的造型方法。

图1-43 放样曲面

实现方法：

（1）绘制截面线和轨迹线；

（2）确认轨迹线和截面线参数生成放样面。

例 构造一个长为90mm、半径是15 mm的柱面。

* 操作步骤如下：

1）绘制截面线和轨迹线：如图1-44所示

图1-44 截面线和轨迹线

2）点击“构造放样曲面”命令，弹出“构造放样曲面”对话框：如图1-45所示。

图1-45 构造放样曲面对话框

3）确认轨迹线参数：构造柱面的轨迹线条数是一条，选择“一条”，并点击右侧的拾取轨迹线 [image] 按钮，退出对话框，系统提示“拾取第1条轨迹线”，点击直线，又弹出对话框，如图1-46所示。

图1-46 构造放样曲面对话框2

4）确认截面线参数：构造柱面的截面线个数是“一条”，输入“1”，并点击右侧的拾取截面线 [image] 按钮，退出对话框，系统提示“拾取第1条截面线”，点击圆弧，又弹出对话框，如图 1-47所示。

图 1-47

5）生成柱面：他参数不变，点击〖确定〗，生成柱面，如图1-48所示。

图1-48

放样曲面参数定义：

本部分解释在放样曲面功能中用到的参数变量。

1）轨迹条数：

表示构成放样曲面的轨迹线个数，有“一条”和“两条”两个选项，当选中“两条”时，可激活“对应方式”和“高度效果”两个功能。对应方式又分为“最短距离对应和等参数对应”，高度效果又分为“截面相似和截面等高”，如图1-49所示。

图1-49

2）截面个数：

表示构成放样曲面截面线的个数，系统默认“1”个，截面形状默认为圆弧状。截面个数可以根据实际情况任意输入。

3）〖拾取截面

线〗按钮：

点击此功能按钮后，对话框消失，要求你拾取截面线，这时用鼠标依次点击截面线，点击的次数等于截面个数，拾取完截面线后，对话框又弹出来，然后进行以下的操作。这里注意，拾取截面线的次序要与扫描的顺序一致，即从轨迹线起点位置的截面线拾取到末点位置的截面线。

4）当前截面：

表示正在编辑的截面线。点击此功能右侧的 [image] 按钮，可选择需要被编辑的截面线。并通过“修改”栏改变这条截面线的参数。

5）截面基点：

修改所有截面线的基点位置。即如果想修改截面线基点的位置，必须在“当前截面”选择是“全部”时进行。除直接使用系统提供的“起点、末点、左下、右下”等特征点外，还可以“自定义”基点，点击〖拾取基点〗按钮，按照顺序依次拾取基点位置即可。

6）截面位置：

截面线在轨迹线上的位置。有“均匀分布”和“自定义”两个选项。截面位置以直线段与主轨迹线的交点为准。

7）〖拾取截面

位置〗按钮：

使用自定义的方法确定每条截面线的位置。如图1-50所示

图1-50

8）过渡效果：

截面线沿着轨迹线扫描在建立截面之间的过渡曲面时，使用光滑过渡和自然过渡。光滑过渡方式用平滑的样条曲线连接相邻截面线中对应的点。自然过渡方式则用直线连接相邻截面线中对应的点。如图1-51所示。

光滑过渡 自然过渡

图1-51

9）修改：

修改当前截面线的参数。如果想修改截面线的参数，必须在“当前截面”选择“全部”以外的截面线时，才能进行操作，即只能对其中一条截面线进行参数修改。可进行修改的参数有“基点位置（X、Y坐标）、截面位置、截面宽度和高度”等。可通过拖动“滑块”或在数字输入框直接输入数值，改变当前截面的参数。如图1-52所示。

图1-52

10）〖清零〗

按钮：

点击 [image] 按钮后，被修改的“当前截面”参数恢复到最初状态。如果把所有的截面全部“清零”，当前截面选择“全部”，然后点击〖清零〗即可。

11）〖效果预览〗按钮：

点击此按钮可在显示区显示当前参数下曲面的渲染效果图。

12）网格精度：

表示生成放样曲面的每个正方形网格的边长，可分别输入轨迹线方向和截面线方向的网格精度，此数值越小，构造的曲面越光滑细致，但生成网格面所用的时间越长，相反，此数值越大，构造的网格面越粗糙，生成网格面所用的时间越短，网格尺寸的大小直接从键盘上输入数字即可。轨迹线方向和截面线方向的网格精度的表示方法如图1-53所示。

图1-53

13）显示类型：

包括全部显示、显示线框、显示曲面、显示过程选项。

a、全部显示：在“构造放样曲面”对话框的显示区内，显示构成放样曲面的所有部分，包括曲面、线框（轨迹线、截面线、基点）等，如图1-54所示。

图1-54

b、显示线框：在“构造放样曲面”对话框的显示区内，只显示构成放样曲面的线框（轨迹线、截面线、基点）部分。如图1-55所示。

图1-55

c、显示曲面：在“构造放样曲面”对话框的显示区内，只显示构成放样曲面的曲面部分。

d、显示过程：在“构造放样曲面”对话框的显示区内，显示构造放样曲面的过程，即截面线在沿着轨迹线扫描时，动态地显示截面线的空间变化过程及其运动轨迹，有助于我们理解构造放样曲面的过程，如图1-56所示。

图1-56


1.4 纹理曲面

纹理曲面主要包括几何纹理、分形曲线曲面以及表面填充和扰动纹理。

几何纹理可以构造出常见的编织带纹理、缠绕结纹理、填充纹理和腐蚀纹理曲面；除此之外，大千世界中，许多物体的形状是极不规则的，例如，形态各异的树木树枝，千奇百怪的树叶，沟壑纵横的地表地势，起伏不平的山脉高山，变化无常的浮云等。这些物体的形状按照传统的绘图设计方式是很难设计实现的，但是，纹理曲面提供的图形迭代曲线、D0L系统曲线、D2L系统植物等功能使这个问题得到了较好的解决。

以下分别介绍这些有关纹理曲面命令的使用、操作及说明。


1.4.1 几何纹理

在日常生活中，随时随地我们都能看到带有纹理效果的物体，比如：编织带、装饰墙砖、汽车的反光灯罩等等，这些纹理虽然变化多端、形状各异，但都有一个特点，就是无论纹理多么复杂，都是由一个基本的单元组成，由这个单元通过阵列复制等功能完成大面积纹理的构造。

几何纹理功能主要试图用计算机辅助设计的方法模仿出一些纹理效果。目前，系统已经提供了四种基本的纹理曲面构造方法，即编织带纹理、缠绕结纹理、填充纹理、腐蚀纹理。编织带纹理用于模仿横竖交错的编织效果，如铁丝网、篱笆墙等；缠绕结纹理用于模仿一条或多条不同的带子经过相互缠绕的形成的效果，如中国结等；填充纹理用于模仿单个图形的阵列效果，如三角填充、球面填充等；腐蚀纹理用于模仿地表外形，如沙地、波浪效果。利用这些构造方法，用户可以方便地构造一些纹理曲面。

下面就依次讲解这些纹理曲面的构造使用以及相关的参数。


1.4.1.1 几何纹理>>编织带纹理

构造背景为编织带的纹理网格曲面。

图1-57 构造纹理曲面对话框。

* 操作步骤：

1）点击“构造纹理曲面（T）”菜单命令，弹出“构造纹理曲面”对话框，然后选择纹理类型为“编织带纹理”，如图1-57所示。

2）选择效果库中基本的编织方法：从中选择纹理曲面的基本构造方法，即编织带纹理、缠绕结纹理、填充纹理或腐蚀纹理。这里选择“构造编织带纹理”。

3）选择编辑方向：可通过选择“横向（黄色）、纵向（紫色）、全部”，对编织带水平和竖直方向上的截面线进行单独某个方向或全部方向的编辑。

4）设置编辑方向上截面线的参数： 包括：单向条数、中心间距、截面形状、截面线尺寸、编织带的柔软度、叠加系数及大小头比例等。

5）设置网格参数：包括设置网格精度，并设置是否使用“矩形网格”。

6）点击〖效果预览〗，观察编织带的效果，并完成编织带纹理构造。

7）点击〖确定〗，结束编织带的构造过程。

编织带纹理参数定义：

1）导航菜单与旋转、缩放、平移快捷方式： | 使用方法同“构造浮雕曲面”对话框中的使用方法相同。
2）效 果 库： | 提供了“自由类型、疏松的铁丝网、致密的编织带、篱笆墙、橡皮编织带、实心编织带”等五种基本编织带的构造效果图，并允许用户根据自己的需要调整编织带的参数后，储存新编织带的效果图。
3）编织方向： | 可通过选择“横向（黄色）、纵向（紫色）、全部”，对编织带水平和竖直方向上的截面线进行单独某个方向或全部方向的编辑。
4）单向条数： | 显示了所选择的“编织方向”上编织带的条数，并可以输入新的数值来改变此方向上的条数。
5）中心间距： | 所选择的“编织方向”上两条相邻编织带中心线之间的距离。如图1-58所示。

图1-58

6）截面形状：

可通过选择“三角截面、椭圆截面、样条截面”改变所选择“编织方向”上编织带的截面形状。如图1-59所示。

三角截面 椭圆截面 样条截面

图1-59

7）〖拾取〗按钮：

点击此按钮后，退出对话框，提示你“指定截面形状曲线”，用鼠标点击需要作为截面形状的曲线后又弹出对话框。你可以任意定义编织带的截面形状。

8）截面尺寸：

定义所选截面线的“宽、高、顶”参数，“顶”即顶部的平坦度，截面线尺寸的定义过程如图1-60所示。

截面线的“宽、高、顶”分别输入10、5、0时的效果预览

横向截面线的“宽、高、顶”分别输入15、5、10后的效果预览

图1-60

截面线的变化过程如图1-61所示。

图1-61

9）弯曲变化系数：

用于控制编织带在交错位置的弯曲程度，从而可以模仿带子的柔软程度，弯曲系数越大，带子的波浪效果越明显。弯曲变化系数的变化范围是0.0-1.0，调节下方的滑块的位置，可改变弯度变化系数，具体的数值显示在右边的数字编辑框中，如图1-62所示。

图1-62

10）厚度变化系数：

用于控制编织带的薄厚变化，系数等于1.0时薄厚不变；系数小于1.0时，凸起部分变厚凹下部分变薄；系数大于1.0时，凸起部分变薄凹下部分变厚。如图1-63所示。

图1-63

11）宽度变化系数：

用于控制编织带的宽窄变化效果，系数等于1.0时宽度不变；系数小于1.0时，凸起部分变宽凹下部分变窄；系数大于1.0时，凸起部分变窄凹下部分变宽。如图1-64所示。

图1-64

12）大小头比例：

每条编织带的两端截面线的大小比例系数，可通过改变比例系数构造如图1-65所示的编织带效果。

_________

__________

图1-65

当大小头比例大于1.00时，截面线放大，当大小头比例小于1.00时，截面线缩小。大小头比例为0.10时，截面线的变化情况如图1-66所示。

图1-66

注意：在构造编织带纹理时，可直接选用效果库中已经设计好的纹理，如：疏松的铁丝网、致密的编织带、篱笆墙、橡皮编织带、实心编织带，也可以对这些曲面效果重新进行设置参数，设置方法与上面讲解的相同。另外，还可以进行新建、保存、重命名、删除某个效果图的操作。


1.4.1.2 几何纹理>>缠绕结纹理

构造背景为缠绕结纹理的网格曲面。

* 操作步骤：

1）绘制一个相互缠绕的图形，并选择它：例如绘制如图1-67所示的一个图形。

图1-67

2）选中图形，点击“构造纹理曲面（T）”菜单命令，弹出“构造纹理曲面”对话框，设置纹理类型。

选择纹理类型为“缠绕结纹理”，使用效果库中的“自由类型”，如图1-68所示。

图1-68

3）选择需要被编辑的曲线：这里选图1-67中绘制的曲线。

4）设置被编辑曲线方向上截面线的参数：截面线参数包括：高低次序、截面形状、截面线尺寸、缠绕结的柔软度、叠加系数及大小头比例等。

5）设置网格参数：包括设置网格精度，并设置是否使用“矩形网格”。

6）点击〖效果预览〗，观察编织带的效果，并完成编织带纹理构造：点击〖确定〗，结束缠绕结纹理的构造过程。

缠绕结纹理参数定义：

1）效 果 库：

提供了“自由类型、中国结、万向结”三种构造方法，如图1-69所示，其中“自由类型”功能可按照自行绘制的图形进行缠绕结纹理的编辑。并允许用户根据自己的需要调整缠绕结的参数后，储存新缠绕结的效果图。

自由类型 中国结 万向结

图1-69

2）曲线条数：

显示组成缠绕结的曲线的条数，这个数值不可编辑。

3）高低次序：

分先高后低和先低后高，使用此功能可实现曲面叠加时高低位置的切换。如图1-70所示。

先高后低 先低后高

图1-70

4）当前曲线：

通过选择“全部或第几条曲线”，对这条曲线方向上的截面线进行全部或单独的编辑。

5）截面形状：

可通过选择“三角截面、椭圆截面、样条截面”改变所选择“缠绕方向”上缠绕结的截面形状。如图1-71所示。

三角截面 椭圆截面 样条截面

图1-71

6）〖拾取〗按钮：

与构造编织带纹理中的功能相同。

7）截面尺寸：

定义所选截面线的“宽、高、顶”参数，定义方法同构造编织带纹理，如图1-72所示。

c

图1-72 “宽、高、顶”分别为3、1.5、0和6、3、3时的效果预览

8）弯曲变化系数、厚度变化系数、宽度变化系数：

使用方法同构造编织带纹理。这里不再进行讲解。

注意：如果使用“中国结或万向结”生成缠绕结曲面，可以对这些曲面效果重新进行设置参数，设置方法与上面讲解的相同。另外，还可以进行新建、保存、重命名、删除某个效果图的操作。


1.4.1.3 几何纹理>>填充纹理

以填充单元填充目标图形形成填充纹理网格曲面。

* 操作步骤：

1）点击“构造纹理曲面（T）”菜单命令：在弹出“构造纹理曲面”对话框里选择纹理类型为“填充纹理”，如图1-73所示。

2）选择效果库中基本的填充方法：这里选择自由类型。

3）选择填充单元类型：有半球面、三棱锥、正反三棱锥、四棱锥、正反四棱锥、多面锥体等单元类型。

4）设置单元的几何尺寸：包括：单元高度、单元尺寸、侧面角度、横向个数、纵向个数等。

5）设置网格参数：包括设置网格精度，并设置是否使用“矩形网格”。

6）点击〖效果预览〗，观察编织带的效果，并完成编织带纹理构造：点击〖确定〗，结束缠绕结纹理的构造过程。

注意：如果填充单元选用“多面锥体”时，必须先选中被填充的图形，再启动“构造纹理曲面”对话框。

填充纹理参数定义：

1）效 果 库：

提供了“自由类型、球面车灯反射罩、棱锥车灯反射罩、五角星”等基本编织带的构造效果图，并允许用户根据自己的需要调整编织带的参数后，储存新编织带的效果图。

2）填充单元：

从中选择填充的单元类型，即半球面、三棱锥、正反三棱锥、四棱锥、正反四棱锥、多面锥体等。

3）单元形状：

填充单元的形状是通过单元高度、单元尺寸、侧面角度三个参数定义的。半球面、三棱锥、四棱锥的参数含义如图1-74所示.

图1-74 单元形状

对于正三棱锥和正四棱锥来说，根据单元尺寸和侧面角度便可计算出棱锥的高度，当用户设定的高度大于计算高度时，设定的高度无效；当设定的高度小于计算的高度时，会出现限高效果，如图1-75所示。

图1-75

4）单元个数：

填充单元的个数主要通过横向个数和纵向个数确定。

5）顶点：

对于多面锥体来说，锥体的边界是选择的封闭曲线，锥体顶点的高度是单元高度，而锥体顶点的XY坐标则是用户定义的，单击右边的〖 << 〗按钮，可捕捉屏幕的特征点作为顶点。多面锥体的顶点必须落在边界曲线内部。如图1-76所示。

图1-76

注意：在构造填充纹理时，可直接选用效果库中已经设计好的纹理，也可以对这些曲面效果重新进行设置参数，设置方法与上面讲解的相同。另外，还可以进行新建、保存、重命名、删除某个效果图的操作。


1.4.1.4 几何纹理>>腐蚀纹理

构造背景为腐蚀纹理的网格曲面。

* 操作步骤：

1）点击“构造纹理曲面（T）”菜单命令：在弹出“构造纹理曲面”对话框里选择纹理类型为“腐蚀纹理”，如图1-77所示。

图1-77 腐蚀纹理

2）选择效果库中基本的腐蚀效果：可以选择波浪效果或碎石效果。

3）选择填充效果类型：用户构造不同的效果并储存到系统中，以便以后使用。

4）设置腐蚀参数：包括：曲面高度、光滑系数、表面细节、边界类型、密度控制、随机数等。

5）设置网格参数：包括设置网格精度，并设置是否使用“矩形网格”。

6）点击〖效果预览〗，观察编织带的效果，并完成编织带纹理构造：点击〖确定〗，结束编织带的构造过程。

腐蚀纹理参数定义：

效 果 库 | 系统没有提供效果图，用户可以根据需求构造不同的效果，并储存到系统中，以便以后使用。
腐蚀效果 | 这里用户可以选择波浪效果或碎石效果，如图1-78所示。 碎石效果 波浪效果 图1-78 腐蚀效果
效果控制参数 | 从设定不同的控制参数可以获得不同的曲面外形，这些控制参数包括：曲面高度、光滑系数、表面细节、边界类型、密度控制、随机数等。
曲面高度 | 所获得曲面的实际高度。如图1-79所示。 图1-79 曲面高度
光滑系数 | 构造腐蚀纹理的光滑系数。系数越大，曲面越光滑，系数越小，曲面越粗糙，如图1-80所示。 光滑系数 = 0.1 光滑系数 = 0.9 图1-80
表面细节 | 用于控制表面的起伏细节的多少，系统提供的表面细节包括缺省、简单型、常用型、复杂型四种。细节越复杂，腐蚀纹理的表面细节越丰富。如图1-81所示。 表面细节（简单型） 表面细节（复杂型） 图 1-81
边界类型 | 设用于控制边界的变化，系统提供的边界类型包括平坦型和对称型两种。平坦型腐蚀纹理曲面的边界曲线高度相同，对称型腐蚀纹理曲面的左右边界、上下边界对称，如图1-82所示。 边界类型（对称型） 边界类型（平坦型） 图1-82
密度控制 | 用于控制腐蚀纹理内部的分块个数，左右编辑框分别表示X向和Y向的分块个数（还可以输入负值，代表是向下凹的）。个数越多，表面越致密，如图1-83所示。 密度控制（2 X 2） 密度控制（8 X 8 ） 图1-83
更新随机数 | 腐蚀纹理曲面属于随机生成的曲面，不同的随机数生成的曲面形状也不相同，如图1-84所示。 随机数= 1665 随机数 = 26671 图1-84


1.4.1.5 几何纹理>>编辑纹理曲面库

纹理曲面的类型较多，每种曲面包括不同的效果。为了便于以后设计，用户可以将获得的纹理曲面效果保存下来，形成不同的效果库。

系统提供的效果库编辑方法包括新图库、重命名、保存、删除等。

1、增加新图库

修改纹理曲面的构造参数后，用户可以将这张曲面效果保存在新的图库中。

* 操作步骤：

1）点击对话框中的〖编辑〗按钮：系统弹出浮动菜单，如图1-85所示。

图1-85

2）点击“新图库”菜单项：系统弹出对话框，如图1-86所示。

图1-86

3）在图库名称中输入恰当的名称，完成图库的增加：如“蛇形缠绕结”，点击〖确定〗按钮，系统自动更新不同的纹理曲面库，如图1-87所示。

图1-87

2、现有图库重命名

当图库的名称不能明确说明实际的效果时，可以进行曲面重命名。

* 操作步骤：

1）点击编辑按钮后，系统弹出浮动菜单，点击“重命名”菜单项，系统弹出对话框，如图1-88所示。

图1-88

2）图库名称中输入新名称，如“蛇身盘绕状”，点击〖确定〗按钮，系统自动更新纹理名称，如图1-89所示。

图1-89

注意：图库中的第一种效果“自由类型” 不能被重命名。

3、保存修改后的效果

用户可以保存修改后的纹理参数，点击编辑浮动菜单中的“保存”项，系统自动将自动更新当前纹理曲面的构造参数。

4、删除现有图库

用户可以删除不合适的纹理效果，点击编辑浮动菜单中的“删除”项，系统将从图库中删除当前的曲面效果。

需要注意的是图库中的第一种效果“自由类型”不能被删除。


1.4.10 随机分形纹理

随机分形纹理可以构造出如桔皮、粗布、地表等艺术效果的网格曲面（如图1-162－图1-166所示），以这些网格曲面为纹理网格曲面，再结合表面填充纹理命令，可以在目标网格曲面上填充纹理，形成丰富绚丽、具有艺术气息的各种曲面。

图 1-162桔皮纹理 图1-163 粗布纹理

图1-164雨后沙滩 图1-165 地表纹理

图1-166 Mandelbrot集

* 操作步骤：

1）选择随机分形纹理命令：在艺术菜单中选中随机分形纹理功能。

2）选择纹理，设定参数，点击确定按钮完成随机分形纹理的构造：

从纹理类型下拉框中选择需要的纹理，设置各项参数，然后点击确定按钮即可。

随机分形纹理参数定义：

纹理类型

包括桔皮纹理、粗布纹理、雨后沙滩、地表纹理和Mandelbrot集，以下分别介绍与这几种纹理相关的参数。

1、桔皮纹理

以下是跟桔皮纹理相关的参数：

纹理尺寸 | 定义整个网格纹理曲面的大小（长、宽和纹理高度）。
步长 | 网格沿X和Y方向划分的步长。步长越小，形成的网格曲面越精致。
高度分布 | 分为上、中和下。其意义同表面扰动纹理的相关参数。请参见表面扰动纹理的参数定义。
边界 | 分为边界可变和边界不可变。其意义同单线冲压的相关参数。请参见单线冲压的参数定义。
加密、磨光、细分 | 意义同“网格曲面加密/磨光/细分”，请参见“网格曲面加密/磨光/细分”的参数说明。

2、粗布纹理

以下是跟粗布纹理相关的参数：

纹理尺寸 | 定义整个网格纹理曲面的大小（长、宽和纹理高度）。
步长 | 网格沿X和Y方向划分的步长。步长越小，形成的网格曲面越精致。
图案系数 | 粗布纹理的纹理单元沿X和Y方向分布的个数，如图1-167（B）。
高度分布 | 分为上、中和下。其意义同表面扰动纹理的相关参数。请参见表面扰动纹理的参数定义。
边界 | 分为边界可变和边界不可变。其意义同单线冲压的相关参数。请参见单线冲压的参数定义。
加密、磨光、细分 | 意义同“网格曲面加密/磨光/细分”，请参见“网格曲面加密/磨光/细分”的参数说明。

图案系数为5 图案系数为10

图1-167（B）

3、雨后沙滩

以下是跟雨后沙滩纹理相关的参数：

纹理尺寸 | 定义整个网格纹理曲面的大小（长、宽和纹理高度）。
步长 | 网格沿X和Y方向划分的步长。步长越小，形成的网格曲面越精致。
雨滴百分比 | 雨滴颗粒的数目占整个网格曲面表面顶点数的百分比。该值越大，雨滴越多越密。
高度分布 | 分为上、中和下。其意义同表面扰动纹理的相关参数。请参见表面扰动纹理的参数定义。
边界 | 分为边界可变和边界不可变。其意义同单线冲压的相关参数。请参见单线冲压的参数定义。
加密、磨光和细分 | 意义同“网格曲面加密/磨光/细分”，请参见“网格曲面加密/磨光/细分”的参数说明。

4、地表纹理

以下是跟地表纹理相关的参数：

纹理尺寸 | 定义整个网格纹理曲面的大小（长、宽和纹理高度）。
地表纹理参数 | 包括平滑度和网格数。 1）平滑度：地表纹理的平滑程度，取值范围为0到1，该值越小，地表纹理越明显；反之，该值越大，纹理越模糊，表面更平滑。 2）网格数：构成地表纹理的网格数，在下拉框中选择，网格数越大，形成的网格曲面越精致、真实感越强。
高度分布 | 分为上、中和下。其意义同表面扰动纹理的相关参数。请参见表面扰动纹理的参数定义。
边界 | 分为边界可变和边界不可变。其意义同单线冲压的相关参数。请参见单线冲压的参数定义。
加密、磨光、细分 | 意义同“网格曲面加密/磨光/细分”，请参见“网格曲面加密/磨光/细分”的参数说明。

5、Mandelbrot集

以下是跟Mandelbrot集相关的参数：

纹理尺寸 | 定义整个网格纹理曲面的大小（长、宽和纹理高度）。
步长 | 网格沿X和Y方向划分的步长。步长越小，形成的网格曲面越精致。
图案系数 | 当纹理类型选择粗布纹理此选项才有效。
雨滴百分比 | 当纹理类型选择雨后沙滩此选项才有效，意为雨滴颗粒占网格曲面表面的百分比。该值越大，雨滴越多越密。
高度分布 | 分为上、中和下。其意义同表面扰动纹理的相关参数。请参见表面扰动纹理的参数定义。
边界 | 分为边界可变和边界不可变。其意义同单线冲压的相关参数。请参见单线冲压的参数定义。
加密、磨光和细分 | 意义同“网格曲面加密/磨光/细分”，请参见“网格曲面加密/磨光/细分”的参数说明。


1.4.2 Peano曲线

以一定的迭代次数在给定的范围里绘制Peano曲线，构造出的Peano曲线是多义线，如图1-90所示。

图1-90 Peano曲线

* 操作步骤：

选取Peano曲线命令，设置参数，点击确定按钮：在艺术菜单下选中Peano曲线命令，设置迭代和区域参数，点击确定按钮系统将绘制出Peano曲线，如图1-91所示。

Peano曲线参数定义：

迭代 | 迭代次数，可以取1到8之间的整数。
区域 | 用X轴的起点和终点以及Y轴的起点和终点来限定Peano曲线整个图形的区域

图1-91 Peano曲线参数设置


1.4.3 图形迭代曲线

图形迭代曲线：用选定的图形类型或者自定义初始元和生成元按照分形几何原理构造图形迭代曲线。图1-92－图1-96是常见的一些图形迭代曲线。

图1-92 koch曲线

图1-93 c曲线 图1-94 Peano-Hilbert曲线

图1-95 Peano七段雪花曲线 图1-96 Peano十一段雪花曲线

* 操作步骤：

选取图形迭代曲线命令，设置参数，点击确定按钮。

在艺术菜单下选中图形迭代曲线命令，设置参数，当曲线类型选择自定义时，需要构造初始元及生成元：初始元要画成一条水平直线，生成元的两端点与初始元的两端点要在一条竖直线上，然后拾取初始元和生成元（注意拾取的顺序）。点击确定按钮系统将绘制图形迭代曲线，如图1-100所示。

图形迭代曲线参数定义：

迭代 | 迭代次数，可以取1到8之间的整数。
XY起点 | 图形迭代曲线初始起点的X、Y坐标值，缺省值是都是50。
XY比例 | 图形迭代曲线在X和Y方向的放缩比例。可以用来改变、调节图形的拉伸效果，如图1-98、1-99所示。
曲线 | 可以从列表中选择koch曲线、c曲线、Peano-Hilbert曲线、Peano七段雪花曲线、Peano十一段雪花曲线和自定义曲线。

图1-98 XY比例为200,200 图1-99 XY比例为100,200

曲线类型选择自定义时，需要自己绘制构造初始元和生成元；当选择非自定义类型时，初始元和生成元为系统预定义好的，这两个参数此时不用处理。

自定义曲线类型情况下，初始元要画成一条水平直线，生成元为一条不闭合的折线（至少2段，至多31段），如图1-100和图1-101所示。

图1-100 初始元和生成元 图1-101 自定义的迭代曲线

说明：只有曲线类型选择自定义时，初始元及生成元参数才有意义。而且，一定要注意拾取的顺序，即先拾取水平的初始元，再拾取生成元，否则不能生成图形迭代曲线。


1.4.4 D0L系统曲线

L系统是基于符号重写的系统，意即使用一组重写规则（或者生成规则）逐次置换一个简单初始对象的各个部分来确定一个复杂的对象，其中初始对象为一个字符串（或者一个字母），可以按一组生成规则来取代字符串中的每一个字母。

D0L系统是确定性的上下文无关的系统，即生成过程中与前后相邻元素无关，是最简单的L系统。

D0L系统曲线整齐明了，可以用来做窗户的窗格、各种座垫以及装饰器具的背景图案；而且还经常和单线浮雕、单线冲压等功能结合，形成各种美观的艺术曲面。图1-102－图1-113是系统中绘出的D0L系统曲线。

图1-102 Koch曲线0

图1-103 Koch曲线1 图1-104 Koch曲线2

图1-105 Koch曲线3 图1-106 Koch曲线1

图1-107 Koch曲线5 图1-108 Koch曲线6

图1-109 Koch曲线7 图1-110 Koch曲线8

图1-111 龙曲线 图1-112 Peano曲线

图1-113 二次gosper曲线

* 操作步骤：

选取D0L系统曲线命令，设置参数，点击确定按钮，在艺术菜单下选中D0L系统曲线命令，设置参数（如图1-114所示），点击确定按钮系统将绘制出D0L系统曲线。

D0L系统曲线参数定义：

迭代 | 迭代次数。
规则 | 演变规则的个数。
长度 | 曲线的长度，该值越大，图形越大。
起点 | 图形曲线初始起点的X、Y坐标值。
比例 | 整个图形的放缩比例。可以用来改变、调节图形的放大、缩小效果。
初始角 | 图形动点的运动的初始角，是与水平线的夹角。
增量角 | 图形动点在运动过程中向左或者向右旋转的角度，左或者右根据运动方向判断。
初始图形 | 即初始对象，为一个字符串（或者一个字母），可以按一组生成规则来取代字符串中的每一个字母。 当初始图形为两个不同的字符的时候，需要用到规则一和规则二这两个参数。
规则 | ＋：逆时针向左旋转增量角（前进方向来判断左右）。 －：顺时针向右旋转增量角（前进方向来判断左右）。 F：向前移动一个步长，画一条直线。 E： 向前移动一个步长，但不画线。
曲线类型 | 包括Koch曲线0、Koch曲线1、Koch曲线2、Koch曲线3、Koch曲线4、Koch曲线5、Koch曲线6、Koch曲线7、Koch曲线8、龙曲线、Peano曲线和二次gosper曲线。

图1-115是按FFFF－FFF－FF－F+F+FFF－F－FFFFF规则画出的图形（初始角和旋转角都是90度），图中的小方格表示一个步长。

图1-115 FFFF－FFF－FF－F+F+FFF－F－FFFFF规则的对应图

说明：对于一种确定的曲线类型，形状都是大体定下来的。一般不主张修改初始图形和相应的生成规则。可以通过改变迭代次数来修改图形的疏密程度和视觉效果。


1.4.5 D2L系统植物

与D0L系统相比，D2L系统是上下文有关的L系统。D2L系统既可以用来模拟植物从根向叶子、茎杆的传播过程，也能用来模拟从叶子到茎和根的构造过程。图1-116－图1-120是一些D2L系统植物的分枝图。

图1-116 分枝结构1 图1-117 分枝结构2

图1-118 分枝结构3 图1-119 分枝结构1 图1-120 分枝结构5

系统植物参数定义：

迭代 | 迭代次数。
长度 | 曲线的长度，该值越大，图形越大。
起点 | 图形曲线初始起点的X、Y坐标值。
比例 | 整个图形的放缩比例。可以用来改变、调节图形的放缩效果。
初始角 | 图形动点的运动的初始角，是与水平线的夹角。
增量角 | 图形动点在运动过程中向左或者向右旋转的角度，左或者右根据运动方向判断。
植物类型 | 分枝结构1、分枝结构2、分枝结构3、分枝结构4和分枝结构5这5种类型，分别如图所示。


1.4.6 函数迭代树木

现实世界中的树木、叶子等物体是极不规则的，用传统方法是较难构造的，且构造出效果也不是很理想。函数迭代树木用函数迭代法生成树木、树叶和晶体等复杂形体，该命令形成的是网格曲面，生成的网格曲面可以再进行诸如纹理填充、直接进行曲面加工生成加工代码等后续操作。如图 1-122－图 1-128所示。

图 1-122 树 图1-123 枫树

图1-124 蕨叶 图1-125 迎客古松

图1-126 孪生圣诞树 图1-127 晶体结构一 图1-128 晶体结构二

函数迭代树木参数定义：

迭代 | 迭代次数。
起点 | 图形曲线初始起点的X、Y坐标值。
比例 | 整个图形的放缩比例。可以用来改变、调节图形的放缩效果。
步长 | 网格沿X和Y方向划分的步长。步长越小，形成的网格曲面越精致。
高度 | 网格曲面的高度。
树木类型 | 树木类型包括树、枫树、蕨叶、迎客古松、孪生圣诞树、晶体结构一、晶体结构二等类型，如图所示。


1.4.7 单线冲压

单线冲压就是将特征线（一个或者多个图形）按照一定的高度冲压形成网格曲面，如图1-130和图1-131所示。单线冲压只冲压特征线边界而对所围区域不进行处理，因此可以看作是区域浮雕的逆处理。单线冲压形成的曲面的边界往往有锯齿，因此单线冲压要进行曲面的磨光处理（如图1-132和图1-133所示）。

单线冲压的冲压宽度是一个步长。缺省状况下，单线冲压的冲压宽度较小，要增加冲压宽度，可以有以下几种方法：1可以通过适当加大步长来增加冲压宽度。但是，步长不能取的过大，否则冲压效果不好。2增加冲压深度，再进行磨光处理。3将特征线等距偏移（等距偏移量不宜太大，一般在一个步长以内）。

图1-130 文字的单线冲压

图1-131 艺术图形的单线冲压

图1-132 网格不进行磨光处理 图1-133 网格进行磨光处理

图1-134 单线冲压参数设置

单线冲压参数定义：

高度 | 即冲压的高度，该值越大，冲压效果越明显，如图1-135和图1-136所示。 图1-135 冲压高度0.5 图1-136 冲压高度1.5
步长 | 每个小网格的尺寸，可根据单线冲压宽度和曲面精度要求来设定。
高度分布 | 凸：在单线的地方冲压效果为向上凸起。 凹：在单线的地方冲压效果为向下凹陷。 如图1-137和图1-138所示为两种不同的高度分布。 图1-137 凸起冲压效果 图1-138 凹陷冲压效果
边界 | 边界处理包括可变和不可变两个选项。 边界可变：曲面边界处可以改变，冲压部分会比较完整、连续。 边界不变：曲面边界不可变，冲压部分会出现不连续现象。如图1-139和图1-140所示。
 | 图1-139边界可变 图1-140 边界不变
加密、磨光、细分 | 请参见网格加密/磨光/细分的说明。


1.4.8 表面填充纹理

在网格曲面上填充需要的纹理。我们可以从纹理库中提取图象纹理，将其转换为网格曲面，再使用自定义的方式将转换得到的纹理网格曲面填充到目标网格曲面上，如图1-141和图1-142所示。

表面填充纹理的时候，纹理类型为非自定义的情况其操作比较简单，选择一种纹理类型，然后设定纹理单元参数再拾取网格曲面点击确定按钮就可以了。以下是自定义纹理网格填充网格曲面的操作步骤：

图1-141 图象纹理 图1-142 图象纹理转化成网格纹理曲面

图1-143 网格曲面 图1-144 填充后的网格曲面

* 操作步骤：

1）构造网格曲面和纹理单元：纹理单元也是网格曲面。

2）选定网格曲面和纹理单元，设定参数，完成自定义纹理网格填充目标网格操作。

点击菜单命令“表面填充纹理”，选定网格曲面和纹理单元，设定参数，点击确定按钮。

图1-146 半球 图1-147 半椭球

图1-148 锥体/锥台 图1-149 棱锥体/棱锥台

表面填充纹理参数定义：

纹理类型 | 包括半球、半椭球、锥体/锥台、棱锥体/棱锥台和自定义这几种类型，如图1-146－图1-149所示。
单元尺寸 | 填充单元的尺寸大小。
单元间距 | 填充单元之间的距离。 X间距：填充单元的对应点在X方向上的距离。 Y间距：填充单元的对应点在Y方向上的距离。 行间错位：填充单元相邻行的对应点之间在X方向上的距离。 单元间距示意图如图1-150， 图1-151和图1-152所示为不同单元间距效果。 图1-150 单元间距示意图 图1-151 单元间距为(5,5,2.5) 图1-152 单元间距为(10,10,5)
拼合方式 | 包括叠加和切除。意义同“艺术曲面（A）→拼合（C）”，请参见网格拼合对应的参数说明。


1.4.9 表面扰动纹理

在网格曲面上扰动形成有扰动纹理的网格曲面，可以用表面扰动纹理对曲面进行艺术处理，形成表面的波纹、颗粒和微小跳动等效果, 如图1-153所示。

图1-153 表面扰动纹理

* 操作步骤：

拾取网格曲面，然后设定参数，再点击确定按钮就可以了。

图1-154 表面扰动纹理参数设置

表面扰动纹理参数定义：

高度 | 扰动的高度。高度越大，扰动颗粒越大，表面扰动纹理越明显。如图1-155和图1-156所示。 图1-155 高度为1 图1-156 高度为2.5（扰动颗粒明显）
高度分布 | 上：扰动颗粒在网格曲面上以扰动高度向上扰动。 中：扰动颗粒以曲面为界为中心线上下波动。 下：扰动颗粒在网格曲面上以扰动高度向下扰动。 如图1-157－图1-159所示为三种高度分布方式的网格图。 图1-157 向上扰动 图1-158 向中扰动 图1-159 向下扰动
边界 | 分为可变和不可变。
方向 | 此方向为扰动方向。 Z向：沿Z向扰动。曲面边界会形成一圈竖直面。 法向：沿法向扰动。曲面边界会沿曲面的法向倾斜，如果曲面的曲率比较大，则扰动效果会呈明显的放射状。如图1-160和图1-161分别为沿Z向扰动和沿法向扰动。 图1-160 沿Z向扰动 图1-161 沿法向扰动
加密、磨光、细分 | 意义同“网格曲面加密/磨光/细分“，请参见“网格曲面加密/磨光/细分”的参数说明。

说明：按ESC键，表面扰动纹理命令结束。


1.5 图象纹理

在雕塑行业、广告业等行业的实际运作中，常常会以一些图片、图象为背景，在此基础上进行编辑渲染等一系列处理。JDPaint5.0提供的图象纹理功能将这些操作和处理变得简单容易：将位图图片转化为网格曲面，而对网格曲面进行曲面的粗、精加工就可以高效地生成刀具路径，直接就可以投入雕刻加工生产；纹理填充用所选图象的纹理填充目标对象可以生成大小不一的新图象；纹理叠加则能将两个图象的纹理进行叠加，构造出多姿多彩的纹理图象。此外，图象纹理还提供了把图片转为灰度图象，把分辨率不同的图片变得相同的功能。

JDPaint5.0提供了丰富的纹理库，纹理库中包括编织、花、木纹、刷子、图案、艺术类、植物、纸纹、自然类等等（如图1-168所示），我们还可以自己构造不同大小和分辨率的图象纹理、把常用到的纹理图象和用这些纹理构造出的新纹理加入到纹理库中，这样能扩充纹理库、方便以后的操作。利用这些纹理资源，再配合图象纹理提供的功能，我们就可以构造出各种各样的图象和曲面。

下面就依次讲解这些有关图象纹理的功能。

图1-168 纹理库中的纹理图象

注意：图象纹理这些菜单命令在平面显示和填充显示环境下使用。


1.5.1 位图转网格

现实生活中有大量丰富多彩的图片图象，互联网上的位图资源更是比比皆是，JDPaint5.0也提供了各种丰富的纹理图象。图象纹理提供的位图转网格功能便可以充分利用这些位图资源，将这些位图图象转换为网格曲面（如图1-169和图1-170所示）。同时，直接构造具有较好的艺术效果的网格曲面，不但要求用户要有较高的艺术内涵，还需要有一定的CAD/CAM软件的操作能力，这不能不说对用户有些苛求。通过用位图转网格，我们可以直接、方便、快速、高效地把数不胜数的各式各样的位图图象转换为需要的网格曲面。

图1-169 位图图象 图1-170 对应的网格曲面

实现方法：

（1）打开位图文件；

（2）位图转换为网格曲面。

* 操作步骤：

1）打开一个位图图象。

点击“文件”菜单的“输入”命令，选择“所有文件类型”，在弹出的对话框中将文件类型改为Bitmap Files(*.bmp)，打开一个位图文件。如图1-171所示。

图1-171 图象显示

2）点击菜单命令“位图转网格”,设置参数。

点击菜单命令“位图转网格”，系统弹出如图1-172所示对话框。设定相应参数。

3）单击〖确定〗按钮，系统生成网格曲面。

单击〖确定〗按钮，系统生成网格曲面。用鼠标点选常用工具栏中〖显示模式〗中的〖渲染〗按钮，得到网格曲面的渲染效果，渲染效果如图1-172所示。

图1-172 转化的网格曲面渲染效果

位图转网格参数说明：

白色最高： | 图象中灰度值最大（211,即亮度最大）的象素点对应转换后曲面的最高点。
黑色最高： | 图象中灰度值最小（0,即亮度最小）的象素点对应转换后曲面的最高点。
曲面高度： | 设置图象转换所生成网格曲面的高度（单位为毫米）。系统的缺省值是1mm。
生成三维环 境网格曲面 | 选中此选项，可以生成三维环境下的网格曲面，在三维曲面造型环境下可以看到生成的网格曲面。

说明：

1）“黑色最高”与“白色最高”生成后网格曲面效果正好相反（凹凸互换），实际设置中要考虑到图象的凹凸效果。

2）灰度图象是使用256级的灰色来模拟颜色的层次，组成灰度图象的各个象素点的灰度值随着图象亮度的变化而变化，其中象素点灰度值为255时亮度最大；灰度值为0时亮度最小。图象其他各象素点灰度值在此范围内变化。


1.5.2 纹理填充

用给定的图象纹理来填充目标对象来得到一个位图图象（原目标对象被删除，如图1-174和图1-175所示）。纹理填充命令能够形成新的位图图象，还经常和位图转网格、圆柱面映射拼合等命令结合使用来设计各种纹理辊筒曲面，这在参数说明中会仔细说明。

需要说明的是，在结合位图转网格、圆柱面映射拼合等命令执行纹理填充操作的时候，一般要使目标对象的长度是纹理位图的长度整数倍，这样形成的纹理填充图象的左右边界对应点的象素值相等，用这样的纹理填充图象转换为网格、再进行圆柱面映射拼合，能使生成的辊筒边界刚好缝合，没有接痕。

图1-174 纹理位图和目标对象

图1-175 纹理填充

实现方法：

（1）打开位图文件；

（2）纹理填充目标对象。

* 操作步骤：

1）打开位图文件，并构造目标对象。

目标对象可以是任何图形、图象、曲面和位图。

2）纹理填充目标对象。

选择纹理填充命令，分别鼠标点选纹理位图和目标对象。

3）按ESC键，结束纹理填充命令。

纹理填充参数说明：

图1-176 纹理填充参数设置

左右边界相等：

填充目标对象后，左右边界点的象素值是否相等。

纹理位图 目标对象

图 1-177

若左右边界相等，则转换得到的图象左右边界上的点的象素值相等，在接下去进行的一些操作如位图转网格和圆柱面映射拼合中，因为左右边界的一致性，使得边界能很好地缝合，增强艺术曲面的精致性。如图1-178和图1-179分别是左右边界相等和不等的对比，可以看出，左右边界相等的情况下，图象的左边界和右边界的象素点相同都为黑色，而左右边界不相等时，图象的左边界象素点为黑色，右边界象素点有的地方为黑色、有的地方为白色。

图1-178 左边界和右边界相等（放大图）

图1-179 左边界和右边界不相等（放大图）

以下是纹理填充命令和位图转网格、圆柱面映射拼合等命令结合使用来形成艺术曲面辊筒的一些图例（关于圆柱面映射拼合的操作请参看其说明）。

图1-180 纹理填充（目标对象的长度是纹理位图的长度整数倍, 左右边界相等）

图1-181 位图转网格

图1-182 圆柱面映射拼合构造的带纹理辊筒（缝合左右边界）

说明：目标对象可以是图形、曲面，也可以是图象（位图），纹理填充是用所选图象的纹理填充目标对象的包围盒。


1.5.3 纹理叠加

将两个图象进行叠加，用所选纹理位图叠加到目标图象上形成新的图象。这样可以构造出多姿多彩的纹理图象，使纹理库得到大大的扩充。纹理叠加类似网格曲面拼合，所不同的是操作对象是位图图象。

纹理叠加常常和位图转网格、纹理曲面下的表面填充纹理等命令结合，来为网格曲面的表面填充上各式各样的纹理（如图1-183和图1-184所示）。

(a) 纹理位图和目标位图

(b) 纹理位图1和目标位图的叠加效果图 (c) 纹理位图2和目标位图的叠加效果图

图1-183 叠加效果

图1-184 叠加效果图转为网格曲面

* 操作步骤：

1）打开纹理位图和目标位图：方法同纹理填充。

2）点击菜单命令“纹理叠加”，选择上一步打开的纹理位图和目标位图，系统会弹出如图所示的对话框。设定参数，点击确定按钮。

参数主要包括颜色、饱和度、亮度（拉动滑动条可以动态查看叠加效果）以及边界处理。这在参数定义中将详细说明。

纹理叠加参数定义：

图1-185 纹理叠加参数设置

颜色、饱和度和亮度 | 代表纹理位图和目标位图的颜色、饱和度和亮度。 拖动颜色、饱和度和亮度滑动条，叠加效果随之改变，滑动条越往目的图象拖动，叠加效果越接近于原目标位图；反之，叠加效果越接近于原纹理位图。这样可以动态地改变、观察叠加效果，直到目标位图符合设计要求。
左右边界相等 | 将图象左右边界上点的象素值设置为相等。
上下边界相等 | 将图象上下边界点的象素值设置为相等。

以下为边界是否相等的图例。

图1-186 纹理位图 图1-187 目标位图

图1-188 左右、上下边界不相等 图1-189 左右边界相等

图1-190 上下边界相等 图1-191 左右、上下边界相等


1.5.4 转成灰度图象

将图象转换为灰度图象（如图1-192和图1-193所示），原来的图象将被删除。

图1-192 原位图图象 图1-193 转成的灰度图象

实现方法：

（1）打开位图文件；

（2）转成灰度图象。

* 操作步骤：

1）打开位图文件：方法同纹理填充。

2）点击菜单命令“转成灰度图象”，系统将位图图象转换为灰度位图。

3）按ESC键，结束转成灰度图象命令。

注意：原位图图象将被删除。


1.5.5 分辨率等同

图象的分辨率是指图象中单位尺寸内象素点数目，它反映了图象上点的密集程度，一般分辨率越高，图象的质量和效果越好。

分辨率等同是把两个分辨率不同的位图图象转换成分辨率相等的图象（基准位图不变，如图1-194所示）。在纹理叠加的时候，如果两个图象的分辨率不同，纹理单元会被放大或者缩小，叠加效果并不理想，这种情况下可以用分辨率等同命令先把位图图象的分辨率变为相同，再进行纹理叠加。

位图 基准位图

图1-194 分辨率等同

实现方法：

（1）打开两个分辨率不同位图文件；

（2）点选基准位图和目标位图。

* 操作步骤：

1）输入两个分辨率不同的位图图象，并选择分辨率等同命令。

可以通过“文件”菜单的“输入|所有文件类型”来打开位图文件。

2）选择基准位图和目标位图：鼠标点选，注意顺序。

3）按鼠标右键或者ESC键，结束分辨率等同命令。


1.6 标准曲面

物体是由基本形体构成的。看似复杂的物体其实都是由若干个简单、标准的小物体构成。“标准曲面”可以构造出长方体、球体、圆柱体、圆锥体和圆环这几种基本曲面。“艺术曲面”菜单下的标准曲面与“几何曲面”下的标准曲面命令不同，前者生成的是网格曲面，而后者生成的是几何曲面。


1.6.1 长方体

绘制出标准的长方体（网格曲面，如图1-195所示）

图1-195 标准长方体

* 操作步骤：

1）在艺术菜单中选中标准曲面的长方体功能。

2）设定参数，绘制出长方体：

注意设定参数（比如长、宽、高和基点位置）以满足设计需要。

长方体参数定义：

图1-196 长方体参数设置 图1-197 长方体参数（沿长度、宽度和高度方向的分割数为6）

长、宽和高 | 长方体的长度、宽度和高度，单位为毫米。
基点 | 长方体的中心所在点的位置。
分割 | 网格曲面是用若干的四边片和三角片来表示的，因此需要将曲面进行分割。分割数越大，网格越致密。如图所示的长方体沿长、宽和高方向的分割数都是6。

长方体的参数意义如图1-197所示。


1.6.2 球体

绘制出标准的球体（网格曲面，如图1-198所示）

* 操作步骤：

1）在艺术菜单中选中标准曲面的球体功能。

2）设定参数，绘制出球体：

注意设定参数（比如球半径和基点位置）以满足设计需要。

球体参数定义：

半径和基点位置 | 半径为球体的半径，基点为球心。
分割 | 意义同长方体，但方向是沿经度和纬度方向。


1.6.3 圆柱体

绘制出标准的圆柱体（网格曲面，如图1-200所示）

* 操作步骤：

1）在艺术菜单中选中标准曲面的圆柱体功能。

2）设定参数，绘制出圆柱体：注意设定参数（比如圆柱体长度、半径和基点位置）以满足设计需要。

圆柱体参数定义：

图1-201 圆柱体参数设置 图1-202 圆柱体参数意义

长度、半径 | 长度即为圆柱长度（高），半径为圆柱底（顶）半径。
分割 | 意义同长方体，但方向是长度方向（即圆柱高的方向）、圆周向和半径方向。
基点位置 | 基点为圆柱体底中心。

圆柱体各参数意义如图1-202所示：


1.6.4 圆锥体

绘制出标准的圆锥体（网格曲面，如图1-203所示）

* 操作步骤：

1）在艺术菜单中选中标准曲面的圆锥体功能。

2）设定参数，绘制出圆锥体：

注意设定参数（如顶半径、底半径、锥高和

基点位置）以满足设计需要。

圆锥体参数定义：

图1-204 圆锥体参数设置 图1-205 圆锥体参数意义

长度、顶半径和底半径 | 长度即为圆锥长度（高），顶半径和底半径分别为圆锥顶半径和圆锥底半径。
分割 | 意义同长方体，但方向是长度方向（即圆柱高的方向）、圆周向和半径方向。
基点位置 | 基点为锥底中心。

圆锥体各参数意义如图图1-205所示。


1.6.5 圆环

绘制出标准的圆环（网格曲面，如图1-206所示）

* 操作步骤：

1）在艺术菜单中选中标准曲面的圆环功能。

2）设定参数，绘制出圆环：

设定参数，绘制出圆环。

圆环参数定义：

大半径 | 环的大半径。（单位：毫米）
小半径 | 环的小半径。（单位：毫米）
分割 | 意义同长方体，但方向是沿大半径方向和小半径方向。
基点 | 圆环的中心点。

圆环各参数意义如图1-208所示：

图1-208 圆环参数意义


1.6.6 读取Obj文件

* 操作步骤：

1） 在艺术菜单中选中标准曲面的读取Obj文件的功能。

2） 在文件对话框中选择要读取的Obj文件。

3） 在弹出的对话框中输入缩放比例，确定。

图1-209 文件打开对话框和模型信息对话框。

图1-209 读入的文件。


1.6.7 艺术曲面方位调整

对于很多的扫描进入的曲面的方向并不理想，由于扫描曲面的基面往往不是水平面，对以后的操作带来很多不便，使用这个命令可以将曲面基面重新调整为水平面。注意：此命令同时将曲面调整到原点附近。

图1-210 方位调整前后的曲面.

* 操作步骤：

图 1-212 曲面调整中曲面与圆形区域的相对位置关系

1） 艺术菜单中选中标准曲面的调整曲面方位的功能。

2） 选择要调整方位的曲面（可以是一个曲面也可以是多个曲面，但必须是艺术曲面）。

3） 选择三个圆形区域（注意：圆形区域与被选曲面在Z向应当有重叠的部分）。

4） 点击确定。

图 1-211 曲面调整对话框


2 艺术曲面编辑

第二章 艺术曲面编辑


2.1 拼合

构造浮雕曲面功能只能构造一块块单张的曲面，这种单张的曲面结构简单、截面单一，是最基本的构造曲面的方法，对于较为复杂的造型是不能通过直接构造浮雕曲面就能达到设计要求的，但是我们可以把复杂的浮雕曲面分解为最基本的曲面，通过浮雕曲面功能构造出基本的曲面，然后把这些基本的曲面按照要求“拼合”起来，完成最终的造型。好比盖房子，要先备好料，比如砖、瓦等，然后把砖瓦按要求一块块“拼合”起来，然后装修一下，房子就盖成了。构造浮雕曲面就是造砖造瓦，提供原料，盖房子就是本节要讲的“网格拼合”功能，装修就是“曲面光滑和重构”功能。

网格拼合就是把一个或多个网格曲面拼合到基面上的过程，曲面拼合就象盖房子还得需要一个“地基”，有个“依靠”，不能把它盖到空中，基面就是我们选择的作为被拼合曲面的“依靠”—— “地基”。

拼合的方式包括叠加、切除、取高、取低、取代五种。我们制造的砖瓦是柔性的，可以根据基面的特点发生各种各样的变形，还可以与基面发生交差并的操作，灵活的使用这些叠加手段可以生成复杂、逼真的三维浮雕效果。

实现方法：

（1）根据需要构造被拼网格曲面和拼合网格基面。

（2）选中被拼网格曲面和拼合网格基面，设定拼合方式和其他参数，拼合网格曲面。

* 操作步骤：

1）构造被拼网格曲面和拼合网格基面

按照要求构造被拼网格曲面和拼合网格基面，注意要有相互重叠的部分。

2）选中网格拼合命令，选择被拼网格曲面和拼合网格基面

选中网格拼合命令，鼠标点选被拼网格曲面和拼合网格基面，右键切换。

3）设定参数，进行网格拼合

各参数意义见拼合参数定义。

拼合参数定义：

图2-1 曲面拼合参数设置

曲面融合：

“曲面融合”是网格曲面拼合中重要的参数，它直接决定了被拼合曲面和基面哪一个发生变形、是否融合为一个整体。

（1）选择“曲面融合”

选择“曲面融合”，基面发生变形，被拼合曲面按照拼合方式拼合在基面上，并与基面融合为一个整体。拼合后的曲面保留基面拼合前的轮廓范围，被拼合曲面与基面拼合后如果超出基面，超出部分自动消失。拼合后的曲面融合为一个整体，也就是说成为一张面，在融合时如果被拼合的曲面存在基高，或者曲面很小，由于拼合精度的存在，生成的曲面会非常粗糙或者在被拼合曲面的直侧面出现锯齿，不光滑。如图2-2所示。

解决粗糙有锯齿的方法有多种，这里只介绍以下几种：一是拼合时不使用“曲面融合”，这种情况在构造被拼合曲面在基面的上面时（凸模）可以使用；二是提高基面和被拼合曲面的网格精度（在构造时的精度）；三是使用剪裁基面这个选项。

（2）“曲面融合”、“裁剪拼合基面”和“裁剪被拼曲面”都不选

“曲面融合”、“裁剪拼合基面”和“裁剪被拼曲面”都不选的时候，被拼合曲面发生变形，基面保持不变。被拼合曲面按照拼合方式拼合在基面上，不和基面融合为一个整体，而是相互独立。拼合后被拼合曲面只是发生了变形，超出基面部分也不会消失，基面在整个拼合过程中只是作为被拼合曲面的“参照物”，自己“丝毫不损”。

（3）裁剪拼合基面

将拼合基面进行裁剪。不选中此项则不裁剪拼合基面。如图所示。执行剪裁拼合时间可能会稍长。

图7-3和7-4分别是不裁剪拼合基面和裁剪拼合基面。图2-3中，由于没有选裁剪拼合基面，执行操作后，拼合基面仍然是完整的曲面；而图2-4中，因为选了裁剪拼合基面，可以看到拼合基面中、拼合基面和被拼曲面的公共部分被裁剪掉了。

图2-3 不裁剪拼合基面（叠加） 图2-4 裁剪拼合基面（叠加）

（4）裁剪被拼曲面

将被拼曲面进行裁剪。不选中此项则不裁剪被拼曲面。裁剪被拼曲面只有在被拼曲面有部分在拼合基面外才有意义，如图2-5所示。

图2-5 裁剪被拼曲面（叠加）

基面形态：

基面形态有单调和非单调。如图2-6所示的长方体表面为非单调曲面。

图2-6 非单调曲面

单 调：基面和Z轴的任何一条平行线相交，最多只有一个交点。

非单调：基面和平行Z轴的线相交，交点大于一个，如长方体。

图2-7－2-9为非单调基面下的拼合图，注意图图7-8中是仰视图，这可以从旁边的坐标系中看出。

图2-7 拼合基面和被拼曲面 图2-8 非单调，拼高（叠加）

图2-9 非单调，拼低（切除）

拼合方式：

拼合的方式包括叠加、切除、取高、取低、取代五种。

（1）叠加

a、被拼合曲面上某一点的高度值（Z1）加上此点正上方（Z轴方向）对应的基面上一点的值（Z2），就是此点变形后的值（Z3），如图2-10所示，C点=Z3=Z1+Z2，被拼合曲面上所有的点按照这个规律变化，生成叠加后的曲面，即被拼合曲面与基面在投影方向（Z轴方向）高度相加。

A点=Z2 B点=Z1 C点=Z3=Z1+Z2

图2-10

b、自然叠加的曲面网格图和渲染效果图，如图2-11所示。

网格图 渲染图

图2-11

（2）切除

a、与自然叠加正好相反，被拼合曲面上某一点的高度值（Z1）减去此点正上方（Z轴方向）对应的基面上一点的值（Z2），就是此点变形后的值（Z3），如图2-12所示，C点=Z3=Z1–Z2，被拼合曲面上所有的点按照这个规律变化，生成自然切除后的曲面，即被拼合曲面与基面在投影方向（Z轴方向）高度相减。

A点=Z2 B点=Z1 C点=Z3=Z2–Z1

图2-12

b、自然切除的曲面网格图和渲染效果图，如图2-13所示。

图 2-13

（3）取高

a、取高的变化规律：

被拼合曲面上某一点的高度值（Z1）与此点投影方向（Z轴方向）上对应的基面上某一点的值（Z2）进行比较，哪一个点的高度值大，拼合后生成的曲面在此投影方向上对应的点就采用这个点的高度值，如图2-14所示，C点=Z3=Z1，被拼合曲面上所有的点按照这个规律变化，生成拼合后的曲面，即被拼合曲面与基面在投影方向（Z轴方向）取两个曲面中最高部分的曲面作为拼合后的曲面。

A点=Z2 B点=Z1 C点=Z3=Z1

图2-14

b、取高前的渲染效果图与取高后的渲染效果图，如图2-15所示。

拼合前的两个曲面 拼合（并融合）后的曲面

图2-15

（4）取低

a、取低的变化规律：

与取高正好相反，被拼合曲面上某一点的高度值（Z1）与此点投影方向（Z轴方向）上对应的基面上某一点的值（Z2）进行比较，哪一个点的高度值小，拼合后生成的曲面在此投影方向上对应的点就采用这个点的高度值，如图2-16所示，C点=Z3=Z2，被拼合曲面上所有的点按照这个规律变化，生成拼合后的曲面，即被拼合曲面与基面在投影方向（Z轴方向）取两个曲面中最低部分的曲面作为拼合后的曲面。

A点=Z2 B点=Z1 C点=Z3=Z2

图2-16

b、取低前的渲染效果图与取低后的渲染效果图，如图2-12所示。

拼合前的两个曲面 拼合（并融合）后的曲面

图2-12

（5）取代

有时进行拼合时，使用取高和取低都不能满足要求，如图1-26所示的两个曲面拼合成如图2-18所示的曲面，这时我们就可以使用取代，即用被拼合曲面完整的取代基面中的某一部分。

图2-18

拼合之前两个曲面中心对齐 拼合（并融合）后的曲面

图2-19

取代的变化规律：

顾名思义，取代就是用被拼合曲面完整的取代基面中的某一部分，如图2-20所示。

A点=Z2 B点=Z1 C点=Z3=Z2

图2-20


2.2 变形

网格曲面变形就是网格曲面按照给定的变形曲线的形状发生变化（平移或比例变形），变形曲线只能是一条，如果选择多个网格曲面进行变形，那么这些网格曲面都是按照同一种规律变形。如图2-21和2-22所示。

图2-21 原始网格曲面 图2-22 平移变形

* 操作步骤：

1） 构造变形曲线

构造如图2-23所示的两条直线，其中一条是基线，基线一般绘制成水平直线或坚直直线，另一条为变形线，变形线可为任意形状。这里绘制一条斜线。

图2-23 基线和变形线

2） 选择变形使命“艺术曲面-变形”

3） 分别选择被变形曲面、变形基线、变形曲线。（右键切换）

4） 选择变形方向。（X轴方向或Y轴方向）

5） 选择变形方式。

6） 输入精度。

7） 点击确定。

点击〖确定〗按钮，可生成如图2-25所示的曲面。

图2-24 变形前 图2-25 变形后

变形参数定义：

图2-26 变形参数设置

变形方向：

此命令提供的变形方向有两个即X轴方向与Y轴方向。

图2-27 X轴方向变形和Y轴方向变形方向

图2-28 基准曲线和变形曲线

变形方式：

包括平移和比例这两种变形方式。

（1）平移：平移是将网格曲面的每点以变形曲线与水平基线y方向的坐标差作为平移量（水平基线的长短没有影响）进行变形，变形起点是曲面最左边的点（即x坐标值最小的点），如图2-27所示。变形曲线可以在基准曲线底下方（网格变形效果为往下平移）。

图2-29 变形曲线为直线时的平移变形效果 图2-30 变形曲线为曲线时的平移变形效果

（2）比例：比例又分为相对底、相对顶和相对中心三种，分别如下图所示：

图2-31 基准曲线、变形曲线和原曲面 图2-32 相对底

图2-33 相对顶 图2-34相对中心

精度：

变形后曲面的拟和精度。缺省值是0.1。

说明：

1、变形曲线不能是封闭曲线。

2、变形范围是由变形曲线的起点与终点决定的，当沿X轴变形时，变形范围是过变形曲线起点与终点的两条竖直线所夹部分的曲面。同样，当沿Y轴变形时，变形范围是过变形曲线起点与终点的两条水平线所夹部分的曲面。

3、基准线所起的作用仅仅是变形的中心。


2.3 冲压

网格曲面冲压造型就是选定网格曲面上一部分曲面（以封闭曲线界定）按照给定的参数重新造型，利用此功能可以在网格曲面上构造诸如凸台、凹槽、锥台等造型，并且可以方便地构造与网格曲面上选定地这部分曲面地最低点、最高点或者最低点和最高点的中心点，如图2-35是在网格曲面上的由“小兰花“确定的区域内进行冲压的不同效果图。

均等 绝对 放缩比例0.7

高点 低点 中心

图2-35 冲压区域为“小兰花”在不同冲压方式下的冲压效果

实现方法：

（1）确定冲压造型的范围及形状。

（2）选定曲面和冲压区域，设定参数，进行冲压造型。

* 操作步骤：

1）确定冲压造型的范围及形状

按要求确定曲面上需要冲压造型的范围及其形状，但这个范围必须是闭合的区域。

2）依次选择网格曲面和冲压区域

鼠标点选，右键切换。

3）设置冲压类型和参数，进行冲压造型

设置冲压类型和参数，如图2-36所示。

冲压参数定义：

图2-36 冲压参数设置

边界处理 | 包括裁剪和不裁剪。裁剪使粗糙的侧面变得细致光滑一些。不裁剪则不进行侧面的光滑细致处理，图2-37和图2-38是边界不裁剪和裁剪的对比。 图2-37 不裁剪 图2-38 裁剪
冲压力 | 冲压后，冲压部分的曲面相对于曲面某一点的高度，冲压力可正（凸）可负（凹）。
放缩比例 | （1）一般输入1，生成上下一样大的凸台； （2）输入的参数大于0小于1：若冲压力大于0，冲压后冲压部分的曲面为上头小，下头大的凸台；若冲压力小于0，冲压后，冲压部分的曲面为上头大，下头小的凹槽； （3）输入的参数大于1：若冲压力大于0，冲压后冲压部分的曲面为上头大，下头小的凸台；若冲压力小于0，冲压后，冲压部分的曲面为上头小，下头大的凸台。这种情况一般不使用；
冲压效果 | 冲压效果分为5项，即：均等、绝对、高点、低点、中心。也就是冲压后，冲压部分的曲面与原始曲面之间的关系，如图2-39所示给出了这种关系的示意图。我们选定的需要被冲压的网格曲面部分，它有最高点、最低点、这两点之间的中心点，通过这三个点分别做三个水平面A、B、C，加上0水平面，这四个水平面分别是冲压后冲压部分的曲面的参照面。 图2-39 （1）均等：冲压部分曲面的上表面与原始曲面之间的距离（间隙）等于冲压力，冲压后的曲面部分与其相对应的原始曲面被冲压部分的形状相同。如图2-40所示。 （2）绝对：冲压部分曲面的上表面到0水平面之间的距离等于冲压力，冲压后的曲面部分为平面。如图2-41所示。 （3）高点：冲压部分曲面的上表面到A水平面之间的距离等于冲压力，冲压后的曲面部分为平面。如图2-42所示。 （4）低点：冲压部分曲面的上表面到B水平面之间的距离等于冲压力，冲压后的曲面部分为平面。如图2-43所示。 （5）中心：冲压部分曲面的上表面到C水平面之间的距离等于冲压力，冲压后的曲面部分为平面。如图2-44所示。
垂面等分 | 将冲压垂面等分。垂面等分数大，则冲压垂面细致光滑，立体感好，如图2-45和2-46所示。 图2-45 垂面2等分 图2-46 垂面5等分

说明：文字可以进行单线冲压，但不能直接作为冲压区域在网格曲面上冲压。若想将文字作为区域定义曲线来冲压，可以先将文字转化为图形，再将转成的图形作为区域进行冲压。


2.4 追加

网格曲面追加造型就是在网格曲面上在一定范围内按照给定的变形曲线的形状重新造型，如图2-47所示。变形曲线组中矩形框用来确定追加造型的范围，两组变形曲线分别对追加造型部分的曲面在X方向或Y方向进行变形。

图2-47

* 操作步骤（单方向变形）：

1）确定追加造型的范围及形状

按要求确定曲面上需要追加造型的范围及其形状，但这个范围必须是闭合的区域。例如在图3-47曲面上绘制一个矩形，如图2-48所示。

2）绘制变形曲线（这里只绘制水平方向的变形曲线）

按照要求绘制变形曲线，一般情况下把其中一条变形曲线绘制为水平直线段，另一条按照变形的截面形状绘制，如果这条曲线与水平直线段相切，追加造型后的曲面之间也是相切的。

绘制的水平方向的变形曲线如图2-49所示。

图2-48 图2-49

3）选取追加功能

依次选择（点选）曲面、追加造型范围框（矩形框）、水平变形曲线和变形形状曲线。注意点选的顺序。(右键在不同的选择框内切换)

4）设置参数，确定

这里采用系统默认参数，点击〖确定〗，即可生成如图2-50所示的曲面。

图2-50

* 操作步骤（两个方向变形）：

1）在图3-49的基础上绘制竖直方向的变形曲线

对竖直方向变形曲线的大小以及位置没有限制，变形曲线只是与曲面变形后的截面相似。如图2-51所示

2）点击追加功能，依次点选曲面、追加造型的范围、变形曲线

选择顺序为曲面、追加造型的范围、水平方向的变形曲线组（先直线后曲线）、竖直方向变形曲线组（先直线后曲线）。

3）设定参数。这里采用系统默认参数，点击〖确定〗

即可生成如图2-52所示的曲面。

图2-51 图2-52

说明：

1． 为了方便观察，我们把水平基线和水平方向变形曲线放到了变形区域的矩形框内（如图2-51所示），把垂直基线和垂直方向的变形曲线放到了变形区域旁边（其实可以放到变形区域外，如图2-53所示）。

2． 需要注意的是，水平变形的范围是与变形区域和水平变形曲线共同决定的，即同时在变形曲线的起点和终点的坚直直线之间且在矩形区域内的范围为实际的变形范围。追加效果跟坚直变形曲线、坚直基线与网格曲面和变形区域的位置无关。

3． 我们一般让水平方向变形曲线曲线不超过变形区域的范围，这样可以使追加效果更容易控制（若超出，则追加效果只在变形区域内起作用，变形曲线超出变形范围的部分不起作用，且追加后在变形区域边界处容易形成台阶）。

4． 水平基线和垂直基线的长短对追加效果没有影响，起作用的是变形曲线的长短，以及变形区域的范围。

5． 追加命令和变形命令很相似，但也有区别：追加命令是在变形命令的基础上，增加了垂直方向的变形，它沿变形方向的截面与垂直变形曲线的形状相似，因此突出了变形后的截面特性。此外，变形命令有多种变形方式（平移和比例），而追加命令则有放缩比例以及垂直侧面和边界裁剪的处理，这也是二者的区别之一。

追加参数定义：

本部分解释在追加中用到的参数变量（如图2-54所示）。

边界处理 | 包括裁剪和不裁剪两个选项。若选择裁剪，则将对边界进行裁剪处理，使粗糙的侧面变得细致光滑一些（在精度取的大的时候比较明显）。不裁剪则不进行侧面的光滑细致处理。
放缩比例 | 按此比例在变形区域内缩放。一般输入1。图2-55是放缩比分别为1.0和0.8追加后的网格曲面。
精度 | 追加造型后曲面的精度，系统缺省值是0.1。该值越小，曲面精度越高。
生成垂直侧面 | 在侧面上用小的四边片以一定的步长精构垂直侧面。当追加造型在变形区域边界处有垂面（台阶）生成时，为了提高曲面质量，这时通常选上此项。

(a) 放缩比1 (b) 放缩比0.8

图2-55 放缩比对追加效果的影响

注意：

（1）变形曲线必须有一组在水平方向绘制，如果只绘制竖直方向的变形曲线将无法使用追加造型功能。

（2）水平方向的变形曲线长度通常应小于在变形区域界定的范围，否则追加后生成的曲面容易出现台阶，超出变形区域的变形曲线不起作用。

（3）追加造型生成的曲面跟基线与变形曲线的相对位置有关，而跟它们与网格曲面的位置无关。

（4）注意曲面、追加范围、变形曲线的选择顺序。


2.5 修剪

在实际的设计中，有时为了满足造型的要求，或为了减少数据量，有必要对网格曲面进行剪裁，仅仅保留必须的部分。修剪包括二维闭环修剪、网格曲面修剪、平面修剪、曲面上线修剪。


2.5.1 二维闭环

将网格曲面与二维闭环按照一定的保留方式和边界重构参数进行裁剪形成新的网格曲面。如图2-56所示为外环加内环修剪。

图2-56 二维闭环修剪

* 操作步骤：

1）构造网格曲面和二维封闭线

裁剪封闭轮廓线一定要是闭合的，可以是单个图形，也可以是一组集合。

2）选中二维闭环修剪命令，选择被裁剪网格曲面和裁剪封闭轮廓

从艺术曲面菜单的修剪命令下选择二维闭环操作。

3）设定参数，进行修剪

注意哪些需要保留，哪些需要去掉。

图2-57 二维闭环修剪参数设置

二维闭环修剪参数定义：

本部分解释在二维闭环修剪中用到的参数变量：

保留 | （1）保留环内：只保留封闭轮廓内的网格曲面。 （2）保留环外：只保留封闭轮廓外的网格曲面。 如图2-58和2-59分别是保留环内和保留环外图。 图2-58 保留环内 图2-59 保留环外
边界重 构参数 | （1）闭 合：系统在修剪完重构边界的时候，要根据边上点间的距离来判断边界线是否闭合。如果一条边界剪掉的距离小于给定的闭合判定数值，则认为边界是闭合的；否则，便认为不闭合。缺省值是3。 （2）不同边：系统在修剪完要进行边界处理，此数值是是否同边的判断标准。如果相邻的两个边界顶点之间的距离大于给定的不同边判定数值，则认为不同边；否则，便认为同边。缺省值是5。 这两个参数一般取缺省值。

说明：边界曲线必须是封闭的轮廓线或者是封闭轮廓线的集合。


2.5.2 网格曲面

将被剪网格曲面和裁剪网格曲面进行修剪形成新的网格曲面，裁剪网格曲面不会发生变化。

实现方法：

（1）在艺术菜单中选中修剪的网格曲面功能。

（2）选择被剪网格曲面和裁剪网格曲面（右键切换）。

（3）设定参数，修剪网格曲面。

* 操作步骤：

1）构造被剪曲面和裁剪曲面：二者要有重叠部分。

2）在艺术菜单中选中网格曲面修剪功能，选择被剪网格

曲面和裁剪网格曲面，注意选择的顺序。

3）设定参数，修剪网格曲面

设定完参数，点击确定按钮，系统修剪网格曲面。

图2-60曲面修剪参数

顶视图

一般视角图

图2-61 被剪曲面和裁剪曲面

网格曲面修剪参数定义：

保留 | 保留鼠标指点的那一张曲面，如图2-62所示。 保留裁剪网格外的被剪网格曲面 保留裁剪网格内的被剪网格曲面 图2-62 保留裁剪网格内、外的被剪网格曲面
分裂 | 把被剪网沿与剪裁曲面的边线处一分为二。
删除 | 删除鼠标指点的那一张曲面，如图2-63所示。 图2-63 删除裁剪网格内的被剪网格曲面（网格和渲染图）
指点区域 | 在选择保留或者删除的条件下，可以指点要保留或者删除的区域：选择了被剪网格曲面和剪裁网格曲面后，点击“指点区域按钮”，系统提示“指点保留/删除区域”，此时用鼠标左键单击被剪网格曲面中的需要保留或者删除的区域（以被剪网格曲面和剪裁网格曲面的交线为界），然后点击“确定”按钮即可。
闭合，不同边 | 意义同修剪－二维闭环的参数，请参见其参数的说明。
曲面上线精度 | 曲面上线精度控制剪裁边界面片的细化程度。


2.5.3 平面修剪

平面修剪是用一个无限大的平面来修剪网格曲面形成新的网格曲面。如图2-64所示。

图2-64 用经过(0,0,1)的水平平面修剪网格曲面

* 操作步骤：

1）构造被剪曲面，选中平面修剪功能

在艺术菜单中选中平面修剪功能。

2）设定参数，修剪网格曲面

设定完参数，点击确定按钮，系统修剪网格曲面。

平面修剪参数定义：

如图2-65A为平面修剪参数设置界面，以下是平面修

剪中用到的参数。

修剪平面类型 | 包括XOY平面、YOZ平面、XOZ平面、基点/法矢平面和三点平面。
平面基点 | 平面基点为平面上的一点（其意义如图2-65B所示）。
平面法矢 | 平面的法向矢量。
三点平面 | 用三个点来确定修剪平面。
去留 | 意义同网格曲面修剪的参数，请参见其参数的说明
边界重建参数 | 意义同二维闭环修剪的参数，请参见其参数的说明

图2-65B 平面定义方式


2.5.4 曲面上线修剪

曲面上线修剪命令能按曲面上线对网格曲面进行修剪。曲面上线修剪命令常和网格曲面上画线命令结合使用，通过曲面上画线或求交、曲线投影等方法得到曲面上的曲线。如图2-66所示。

(a) 用封闭曲线修剪曲面

(b) 用贯穿曲面的曲线修剪曲面

图2-66 曲面上线修剪

* 操作步骤：

1）构造被剪曲面，在艺术菜单中选中曲面上线修剪功能，选择被剪网格曲面和曲面上线。

注意，曲面上线要是封闭的曲线或者贯穿网格曲面的曲线。

2）设定参数，修剪网格曲面

设定完参数，点击确定按钮，系统修剪网格曲面。

曲面上线修剪参数定义：

如图为曲面上线修剪参数设置界面，各参数的意义同网格曲面修剪，请参见网格曲面修剪的参数说明。

图2-67 曲面上线修剪参数设置


2.6 柱面/锥面辊筒

圆柱面和圆锥面是实际造型和加工中经常遇到的曲面。除了第一部分“艺术曲面生成”中提供了生成标准网格曲面的圆柱体、圆锥体外，本部分的“柱面/锥面辊筒”命令可以生成展平图和形成特定的网格曲面。以下分别介绍生成圆柱面展平图、生成圆锥面展平图、圆柱面映射拼合和圆锥面映射拼合。


2.6.1 生成圆柱面展平图

将圆柱面展开得到平面，如图2-68所示。

图 2-68 圆柱面展平

* 操作步骤：

1）在艺术菜单中选中标准曲面下柱面/锥面辊筒的生成圆柱面展平图功能。

2）设定参数，生成圆柱面展平图。

图2-69 圆柱面展平参数设置

生成圆柱面展平图参数定义：

圆锥体半径及长度 | 其意义同标准曲面中的圆柱体，请参见圆柱体参数的相关说明。
展平图基点位置 | 圆柱面展平图左下角那点为基点。


2.6.2 生成圆锥面展平图

将圆锥面展开得到平面，如图2-70所示。

图 2-70

* 操作步骤：

1）在艺术菜单中选中标准曲面下柱面/锥面辊筒的生成圆锥面展平图功能。

2）设定参数，生成圆锥面展平图。

图2-71 圆锥面展平参数设置 图2-72基点

生成圆锥面展平图参数定义：

圆锥体半径及长度 | 其意义同标准曲面中的圆锥体，请参见圆锥体参数的相关说明。
展平图基点位置 | 圆锥面展平图基点为展平图中两条母线的交点，如图2-72所示。


2.6.3 圆柱面映射拼合

利用“圆柱面的映射拼合”功能，可将在圆柱面曲面展平图上设计的网格曲面映射拼合到柱面上去（如图2-73所示）。例如，可以将狭长的一组网格曲面映射拼合到圆柱面展平面上形成弹簧。

在实际应用中，圆柱面映射拼合命令往往不是单独执行的，它常常和纹理填充、位图转网格等命令结合执行来生成我们需要的纹理的无接缝的辊筒曲面。

右箭头: 圆柱面映 射拼合

图2-73 圆柱面映射拼合

* 圆柱面映射拼合的一般步骤是：

1）首先构造网格曲面和展平图，展平图可以通过“生成圆柱面展平图”得到；

2）然后拾取网格曲面和展平图（鼠标点选，右键可以切换选择。）设置参数，以完成圆柱面映射拼合（设置拼合方式以及是否缝合左右边界）。

* 以下以构造弹簧为例，结合区域浮雕、二维闭环修剪网格曲面命令等功能来说明该方法的操作步骤：

1）构造圆柱面展平图，并在展平图上画一条斜线

圆柱面展平图可以通过“生成圆柱面展平图”命令得到（也可以直接画一个矩形，因为矩形都可以收拢为圆柱面）；

为了计算方便，本例所画的矩形长为50mm、宽为100mm，所画的斜线与水平方向成15度夹角。如图2-74所示。

图2-74 构造展平图和斜线 图2-75 斜线单线膨胀

2）选择斜线，进行单线膨胀操作

这里等距距离取为2，参数设置如图2-76所示，单线膨胀后如图2-75所示。

图2-76 单线膨胀参数设置

3）删掉斜线，对单线膨胀得到的区域进行区域浮雕

区域浮雕选择椭圆截面，构造出的浮雕曲面如图2-77所示。

4）对得到的浮雕曲面进行阵列变换来纵向复制网格曲面

选择矩形阵列命令。

这里需要特别注意的是，为了使生成的弹簧在连接处没有接缝，每个网格曲面的纵向距离：h＝50×tg15=13.397，矩形阵列参数设置如图2-78所示。

图2-77 区域浮雕形成网格曲面 图2-78 矩形阵列参数设置

图2-79 矩形阵列进行纵向等距复制 图2-80 二维闭环修剪

5）选取二维闭环修剪命令，把矩形展平图以外的曲面裁剪掉，如图2-80所示。

6）选中所有网格曲面，选择圆柱面映射拼合命令，设定参数，点击确定按钮完成。

选择拼合方式为叠加，点击确定按钮即可完成弹簧的构造（如图2-81所示）。

说明：应该使网格曲面的全部或部分在展平图中，如果不具备该条件，执行该命令无任何意义且不会有执行结果。

图2-81 形成的弹簧 图2-82 参数设置

圆柱面映射拼合参数定义：

本部分解释在圆柱面映射拼合中用到的参数变量（如图2-82所示）。

拼合方式：

圆柱面映射拼合的拼合方式分为叠加和切除两种。

（1）叠加：与网格曲面拼合中的自然叠加类似，只不过是将z方向变成了圆柱面法向，展平面上某一点的z向坐标值，加上此点在网格曲面上相对应点的Z向坐标值，就是此点变形后的圆柱面法向坐标值。图案为凸起效果。

（2）切除：展平面上某一点的z向坐标值，减去此点在网格曲面上相对应点的Z向坐标值，就是此点变形后的圆柱面法向坐标值。图案为凹陷效果。

图2-83和图2-84是两种拼合方式的对比。

图2-83 叠加（凸起） 图2-84 切除（凹下）

缝合左右边界：

将左右边界缝合成一条边界，网格磨光的时候不会在边界处出现棱。

说明：圆柱面映射拼合常常和纹理曲面下的表面填充纹理命令结合使用。在展平图表面填充纹理，形成的被拼网格曲面刚好在展平图内，位置紧凑，能恰好映射拼合，且可以缝合左右边界。


2.6.4 圆锥面映射拼合

将在圆锥面展平图上设计的网格曲面映射拼合到对应的三维圆锥面几何模型上去，如图2-85所示。

右箭头: 圆锥面 映射拼合

图2-85 圆锥面映射拼合

* 操作步骤：

圆锥面映射拼合的操作步骤和参数设置同圆柱面映射拼合，请参见圆柱面映射拼合的相关说明。

圆锥面映射拼合参数定义：

图2-86 圆锥面映射拼合

拼合方式：

拼合方式分为叠加和切除两种，其意义同圆柱面映射拼合，请参见圆柱面映射拼合参数的相关说明。


2.7 等距面

网格曲面向上沿着网格顶点的法线方向（垂直曲面切矢）移动等距距离形成等距面，如图2-87所示。等距距离可正可负。距离为正，表示沿曲面的法向偏移。距离为负，表示沿曲面法向的反向偏移。

图 2-87 等距面

实现方法：

（1）构造网格曲面。

（2）选中曲面进行等距变换。

* 操作步骤：

1）选择“等距面”命令：从“艺术曲面”菜单下选取。

2）点选网格曲面

选中曲面后，输入等距距离（缺省是5），可选择是否删除原曲面。点击〖确定〗按钮生成等距面。

说明：有时候曲面边界处网格质量太差，直接作等距面效果不好。这时可以先重构网格曲面（或者磨光），待边缘质量有所提高再等距。

等距面参数定义：

距离 | 等距面的等距距离，可以是负值。正值沿曲面上点法线方向正向等距；负值沿曲面上点法线方向负向等距。
删除原曲面 | 选中此项将删除原有的网格曲面。

图2-88 等距面参数设置


第三章?艺术曲面辅助功能


3.1 曲面上线

网格曲面边界信息在显示效果，定义加工区域，生成加工边界时至关重要，尤其在构造网格曲面边界的内延/外延曲面时操作对象必须有边界，否则是不能生成内延/外延曲面的。另一方面在对网格曲面的一系列操作过程中，如优化拼合，剪裁，映射拼合等，有可能丢失了边界信息，因此有必要提供一组网格曲面边界处理的功能。

此外，我们还经常需要在网格曲面上绘制线条，以完成各种造型设计的需要。曲面上线提供了删除边界、边界转为2D/3D曲线、网格曲面上画线和网格曲面/平面/曲线求交线、曲面上线等距偏移等功能，以下依次介绍这些功能的操作使用和相关参数。


3.1.1 删除边界]

删除边界可以将网格曲面的边界去掉，如图3-1所示。在前面的“圆柱/圆锥面映射拼合”时提到：如果被拼合曲面的一部分在展平图之外，此时网格曲面映射拼合会造成曲面边界混乱。此时，我们就可以调用“删除网格曲面”功能将已经混乱的边界删除。

图3-1 删除网格曲面的边界（线框显示）

* 操作步骤：

1）选择要删除边界的网格曲面：可同时选择多个网格曲面。

2）选择“删除边界”菜单项。

选择“艺术曲面（A）→曲面上线（Y）→删除边界（D）”菜单项，系统顺序删除选择集中各网格曲面的边界。

如图3-2为删除边界的操作界面。

图3-2 删除曲面边界界面


3.1.2 边界转为2D曲线

该命令的作用是将所选择的网格曲面的边界在XOY平面上投影变为二维多义线，如图3-3所示。有一点要注意，所选择的网格曲面必须是有边界的曲面才能生成其二维轮廓线。

* 操作步骤：

1）构造曲面，选择边界转换成2D曲线命令。

2）选中曲面进行转换：系统将边界进行转换。

说明：拾取网格曲面的时候，可以选取多个。这些网格曲面的边界在XOY平面上投影变为二维多义线。

边界转为2D曲线参数定义：

图3-4 边界转为2D曲线


3.1.3 边界转为3D曲线

在很多情况下，网格曲面的边界并不位于二维平面上。边界转为3D曲线的作用是将所选择的网格曲面的边界在三维空间上转换为三维曲线，如图3-5所示。要注意所选择的网格曲面必须是有边界的曲面才能生成其三维轮廓线。

图3-5 边界转为3D曲线

* 操作步骤：

1）构造曲面，选择边界转换成3D曲线命令。

2）选中曲面进行转换：系统将边界进行转换为3D曲线。

边界转为3D曲线参数定义：

图3-6为边界转为3D曲线参数设置界面。

边界线类型设置 | 包括三维折线和样条曲线两种类型。三维折线用一系列的三维小折线段来表示边界曲线；而样条曲线用样条曲线来表示边界曲线。
折线优化 | 边界线上的点一般都较多，点较密。在设计精度许可的条件下，可以适当减少边界线上的点，对3D折线进行优化。设此数值为n，则表示系统在采集曲线上点的时候每相邻n个点收录为一个曲线点。该值越大，所包含的曲线上的点越少。
样条采样点数 | 样条线上点太多会影响速度。样条采样点数表示在求出的样条线上进行采集的点数。系统缺省情况下取30个点来构造样条边界线。


3.1.4 网格曲面上画线

网格曲面上画线可以在曲面上绘制出各种形状的曲线，如图3-7所示。

图3-7 网格曲面上画线

* 操作步骤：

1）拾取网格曲面。

选中曲面上画线命令后，系统左下角状态栏会提示“请拾取网格曲面”（如图3-8(a)所示），鼠标左键单击拾取。

2）点取网格上曲线要经过的点。

选中网格曲面后，系统左下角状态栏会提示“在曲面上拾取点”（如图3-6(b)所示）。鼠标左键在网格曲面上点取。

(a) (b)

图3-8 操作中的系统提示

3）完成操作。

右键结束操作，绘制出曲面上线。

说明：网格曲面上画线在3D环境下使用，画出来的曲面是空间3D曲线。


3.1.5 网格曲面/平面/曲线求交线

该命令是求网格曲面与曲面、平面和曲线投影的交线，如图3-9所示。

(a) 网格曲面/网格曲面求交 (b) 网格曲面/平面求交

(c) 网格曲面/2D曲线投影求交 (d) 网格曲面/3D曲线投影求交

图3-9 网格曲面/平面/曲线求交线

* 操作步骤：

1）根据需要选择求交类型。

包括曲面/曲面、曲面/平面、2D曲线投影和3D曲线投影这几种类型。

2）拾取网格曲面：鼠标左键点取。

3）拾取求交对象。

求交对象是曲面和2D/3D曲线时，直接鼠标左键点取；求交对象为平面的时候，手工输入平面的基点和法矢构造平面。

4）求出交线：设定参数后，点击确定按钮。

网格曲面/平面/曲线求交线参数定义：

图3-10为网格曲面/平面/曲线求交线参数设置界面。

求交方式 | 包括曲面/曲面、曲面/平面、2D曲线投影和3D曲线投影这几种类型。2D/3D曲线投影是将2D/3D曲线沿Z方向投影到网格曲面上生成交线。
平面 | 在求交方式选择曲面/平面时有效。平面由基点和法式决定，缺省情况下，平面是经过(0,0,1)这点的水平平面（法式为（0,0,1））。关于平面的详细信息请参见平面修剪的相关参数定义。
边界线类型设置 | 意义同边界转为3D曲线，请参见边界转为3D曲线的参数定义。
折线优化 | 意义同边界转为3D曲线，请参见边界转为3D曲线的参数定义。
样条采样点数 | 意义同边界转为3D曲线，请参见边界转为3D曲线的参数定义。


3.1.6 曲面上线沿曲面等距偏移

曲面上线沿曲面等距偏移命令能按偏移距离将曲面上线进行等距偏移。曲面上线沿曲面等距偏移命令常和网格曲面上画线命令结合使用，通过曲面上画线来绘制曲面上的曲线从而得到曲面上线，再将该曲线沿曲面按一定的距离偏移。如图3-11所示。

图3-11 曲面上线沿曲面等距偏移

* 操作步骤：

1）构造网格曲面，选中曲面上线等距偏移功能：

在艺术曲面菜单中选中曲面上线沿曲面等距偏移命令。

2）拾取网格曲面：

鼠标左键点取。

3）点取曲面上线：

鼠标左键点取。

4）求出等距偏移线：

设定参数后，点击确定按钮。

曲面上线沿曲面等距偏移参数定义：

采样点数 | 曲线上的点一般都较多较密。在设计精度许可的条件下，可以对适当减少曲线上的点，对曲线进行优化。采样点数表示在求出的等距偏移线上进行采集的点数。
偏移距离 | 曲面上线沿曲面等距偏移的距离。
删除原曲线 | 选中此项，将删除原来的曲线。

图3-12 曲面上线沿曲面等距偏移参数设置


3.1.7 3D曲线投影到平面转为2D/3D曲线

该命令能将空间3D曲线投影到指定的平面，从而将3D曲线转化成2D/3D投影曲线。如图3-13所示。

图3-13 3D曲线投影到平面

* 操作步骤：

1）构造3D曲线：

可以用网格曲面上画线、几何曲面中的3维变换等命令构造3D曲线。

2）拾取3D曲线：

选中3D曲线投影到平面转为2D/3D曲线命令后，鼠标左键点取该曲线。

3）求出投影曲线：

设定各项参数后，点击确定按钮。

3D曲线投影到平面转为2D/3D曲线参数定义：

投影平面类型 | 包括XOY平面、YOZ平面、XOZ平面、基点/法矢平面和三点平面，其意义同平面修剪的相关参数，请参见平面修剪参数定义。
投影到XOY平面时投影线转为2D多义线 | 选中此项，投影平面为XOY平面时投影线自动转化为2D多义线；不选中此项，生成的投影曲线为3D曲线。
投影线类型 | 类型有折线和样条曲线两种。
折线优化 | 意义同边界转为3D曲线，请参见边界转为3D曲线的参数定义。
样条采样点数 | 意义同边界转为3D曲线，请参见边界转为3D曲线的参数定义。


3.1.8 2D曲线投影到网格曲面

该命令能将平面2D曲线投影到指定的网格曲面上，从而将2D曲线转化成3D投影曲线。如图3-15所示。

图3-15 2D曲线投影到曲面

* 操作步骤：

1） 选择艺术曲面-曲面上画线-2D曲线投影到网格曲面

2） 拾取曲面：

a) 选择曲面

3） 拾取2D曲线

选中绘制好的2D曲线投影到平面转为2D/3D曲线命令后，鼠标左键点取该曲线。

4） 选择选项折线或样条。

5） 输入参数。

2D曲线投影到网格曲面参数定义：

投影线类型 | 类型有折线和样条曲线两种。
折线优化 | 意义同边界转为3D曲线，请参见边界转为3D曲线的参数定义。
样条采样点数 | 意义同边界转为3D曲线，请参见边界转为3D曲线的参数定义。


3.2 网格优化

网格曲面造型形象直观，能满足大部分没有严格尺寸要求的物体的造型要求。但是，因为网格曲面直接用致密的点阵来描述被造型的物体，必然存在造型精度与数据量巨大这一对矛盾：为了满足精度要求，网格步长取的要小，从而导致数据量巨大；为了减少数据量而加大步长从而以丢失精度为代价。

网格曲面数据优化正是在这种背景下提出来的。考虑到被造型物体的不同部位在高度方向的变化率不一样，平坦的区域用较大的网格来描述，陡峭的区域用较小的网格来描述，网格合并的原则由用户输入的精度来控制（如图3-15和图3-16所示），这样可以在满足给定精度的条件下优化网格数据，提高网格面的处理速度。

图3-15 优化网格曲面（0.1）

(a) 优化前网格曲面 (b) 优化后网格曲面

图3-16 优化前后网格对比

* 操作步骤：

1）选取网格优化命令，再选择网格曲面。

2）设定网格精度，点击确定按钮完成网格优化。

网格优化参数

本部分解释在网格优化功能中用到的参数变量（如图3-17所示）。

图3-17 网格优化参数设置

精度

网格合并时，当用一个大一些的网格平面来代替原来的几个相邻的网格面时，各网格面顶点到新的网格面的距离不能大于此值。


3.3 网格合并

网格合并能将多个网格曲面合并为一个曲面。网格合并通常用于将纹理花纹、阵列花纹或其它大量设计好的花纹合并为一张曲面，以方便后续的选取等操作。

* 操作步骤：

1）打开网格合并命令，选择多个网格曲面；

2）设置参数，合并网格：

选择合并后的网格曲面中是否保留原来的边界。

网格合并参数：

本部分解释在网格合并功能中用到的参数变量（如图3-18所示）。

保留边界

选择该参数以确定合并后的网格曲面中是否保留原来的边界。


3.4 网格重构

网格重构通常用来将非矩形网格转化为矩形网格。此外，网格重构有时候也用来将网格曲面按照外环曲线和内环曲线以一定的网格划分重新构造网格曲面，如图3-19所示。网格重构可以根据实际设计的需要对网格曲面进行修改重构。在进行网格重构的时候，为了保持步长不变（有时保持步长不变很重要），网格曲面的长度和宽度可能会发生变化。

图3-19 非矩形网格重构为矩形网格

* 操作步骤：

1）选择网格曲面：

选中网格重构命令，再选择要重构的网格曲面。

2）选中网格重构命令，按照所选的网格划分来进行网格重构：

网格划分包括矩形、外环＋高点、外环＋低点、外环＋中点和外环＋内环这五种，这在参数定义中会详细说明。

3）点击确定按钮，完成网格重构。

网格重构参数：

X（曲线）向精度 | 用于设定网格沿X方向的精度，以毫米为单位。
Y（直径）向精度 | 用于设定网格沿直径方向的精度，以毫米为单位。
网格划分 | 分为矩形、外环＋高点、外环＋低点、外环＋中点和外环＋内环这五种，重构后的网格曲面分别如图3-21－图3-24所示。
矩形 | 以网格曲面的包围盒矩形来重构网格曲面为矩形网格曲面，这时外环和内环不起作用，不用选择外环和内环。
外环＋高点 | 以外环曲线和网格曲面上的最高点来重构曲面。
外环＋低点 | 以外环曲线和网格曲面上的最低点来重构曲面。
外环＋中点 | 以外环曲线和外环曲线的中心来重构曲面。
外环＋内环 | 以外环曲线和内环曲线为边界来重构曲面。

图3-21 矩形

图3-22 外环＋高点

图3-23 外环＋中点（放大图）

图3-24 外环＋内环

说明：

1. 在使用外环+内环方式进行网格重构的时候，要将外环和内环曲线的方向调整为一致（同为顺时针或者同为逆时针），再进行网格重构。如图3-25所示为内环和外环方向不一致时的处理方法。此外，涉及到内、外环的时候，都要注意它们的方向，在“网格转几何曲面”命令中也要注意内外环的方向是否相同，若不相同也要先调整为相同再进行该命令。

2. 在使用外环＋高点和外环＋低点进行网格重构的时候，我们构造外环的原则是使高点和低点要相应地位于外环之内，这样网格重构的效果容易控制。

3. 网格重构并不删除内外环曲线。

(a) 内环和外环方向不一致 (b) 调整内、外环方向为一致

(c) 内、外环方向一致后重构效果

图3-25 外环＋内环重构网格曲面


3.5 网格加密/磨光/细分

在实际操作中，有时候网格曲面的精度达不到设计的要求，如网格精度不够，网格表面和边

界有棱角以及网格曲面的交接处不够光滑，这时候可以使用网格加密/磨光/细分功能来改善网格曲面，以下将逐一介绍。

* 操作步骤：

网格加密/磨光/细分的操作比较简单，选中网格曲面，选择网格加密/磨光/细分命令，设定网格加密/磨光/细分值，再点击确定按钮即可。

网格加密/磨光/细分参数定义：

图3-26 网格加密/磨光/细分参数设置

加密 | 网格曲面是有密度的，这里的密度是指构造网格曲面时的网格精度；有时候要对一个已经构造好的网格曲面做拼合或裁剪等操作，这时，如果该曲面的步长太大就会在边界处产生较大的变形，为了避免这种情况的发生，需要将网格曲面加密。如图3-27所示。
磨光 | 将网格曲面的表面打磨抛光。磨光效果如图3-28和图3-29所示。
细分 | 将构成网格曲面的网格按照细分数值进一步分解为小的网格，相当于一次加密后再磨光，是加密和磨光操作的结合。如图3-30和图3-31所示

需要注意的是，网格加密一次，数据量会增加4倍；加密两次，数据量增加到16倍。若加密次数太大，数据量会增加很大，计算速度也会受到影响，因此，加密次数不宜取的太大，要根据网格精度要求和实际情况来决定加密次数，一般取一次。

(a) 加密前 (b) 加密后

图3-27 加密网格曲面

(a) 磨光前 (b) 磨光后

图3-28 非矩形网格曲面的磨光

(a) 磨光前 (b) 磨光后

图3-29 磨光矩形网格曲面

图3-30 细分立方体网格曲面

(a) 细分前 (b) 细分后

图3-31 细分网格曲面

说明：网格曲面加密/磨光/细分的效果和原有曲面的网格精度有关，如果原网格曲面的步长较大，则加密/磨光/细分的效果会比较明显。


3.6 网格转位图

将网格曲面转换为位图图象，如图3-32所示。

图3-32 网格转为位图

* 操作步骤：

1）构造网格曲面，选择网格转位图命令：

在艺术曲面菜单中选中网格转位图功能。

2）选中网格曲面，设定精度，系统将曲面转换为位图

图象：

选中网格曲面，设定X和Y向精度，确认是否删除原有的网格曲面，然后点击确定按钮完成网格曲面转位图命令。

网格转位图参数定义：

X向精度 Y向精度 | 用于设定网格的尺寸，即设置单位网格的长度和宽度的大小，以毫米为单位。
删除曲面 | 选中此项即删除原网格曲面。


3.7 网格转几何曲面

将网格曲面转化为几何曲面。如图3-34和图3-35所示。

图3-36和图3-37是转化前后对象的属性对比。

图3-34 网格曲面 图3-35 转成的几何曲面

图3-36 网格曲面属性 图3-37 几何曲面属性

* 操作步骤：

网格转几何曲面的操作步骤与网格重构类似，这里不再赘述。

网格转几何曲面参数定义：

网格划分分为矩形、外环＋高点、外环＋低点、外环＋中点和外环＋内环，这几项参数的意义同网格重构，请参见网格重构的参数定义。

说明：在使用外环+内环方式进行网格划分的时候，要将外环和内环曲线的方向调整为一致（同为顺时针或者同为逆时针），如图3-39所示。

(a) 方向调整前

(b) 方向调整为一致（同为顺时针方向）

(c) 外环＋内环方式转换后的几何曲面

图3-39 环状网格曲面转几何曲面


3.8 保存特征

在设计中，有时候会经常用到一些比较有特点的网格曲面，我们可以把这样的网格曲面作为特征保存下来，在需要的时候再加载到设计图中，这样可以大大地提高效率。作为特征的重要应用之一，我们经常把一些纹理网格、单元网格作为特征保存下来，然后在虚拟雕塑环境下的堆料、去料等命令、操作中把这些特征作为刷子、纹理等加载进来，在曲面上的特定区域内形成我们需要的图案和纹理。

保存特征可以将网格曲面作为特征保存到文件（*.bru）中，如图3-40所示。

图 3-40 保存特征

* 操作步骤：

1）选择保存特征命令：在艺术曲面菜单中选中保存特征功能。

2）选中网格曲面，设定精度，保存特征：

系统弹出保存特征对话框（如图所示），输入名称后保存特征。

注意：非矩形网格曲面作为特征保存的时候，系统将其转化为矩形网格曲面保存。


3.9 加载特征

将特征文件（*.bru）加载到系统中绘制出网格曲面。如图3-41所示。

图3-41 加载特征

* 操作步骤：

1）选择加载特征命令：在艺术曲面菜单中选中加载特征功能。

2）选中特征文件，加载特征：

这时系统会弹出加载特征对话框（如图3-41所示），选中并打开要加载的特征，系统就绘制出相应的网格曲面。


3

3.10 几何曲面磨光

对于很多由位图转换过来的几何曲面可能表面不光滑，这样我们可以使用此命令来使曲面表面变得光滑。这个命令对曲面的影响相当于虚拟雕塑中的整体磨光对曲面的影响。

图3-42 磨光前后的几何曲面

图3-43 几何曲面磨光对话框

* 操作步骤：

1. 选择几何曲面。

2. 选择命令“艺术曲面-几何曲面磨光”。

3. 填写磨光参数。

4. 确定。

* 参数定义

几何曲面磨光中的参数相当于虚拟浮雕中整体磨光的磨光次数。


3.11 几何曲面冲压

图3-44 冲压前后的几何曲面

* 操作步骤：

1. 选择几何曲面。

2. 选择命令“艺术曲面-几何曲面冲压”。

3. 选择冲压效果。

4. 填写冲压参数。

5. 选择冲压区域。

图3-45 几何曲面冲压对话框

* 参数的意义：

冲压效果>>均等 | 所选区域曲面高度相对最近一次固化升高冲压参数规定的高度，即实现曲面区域等距偏移，如图4-7所示。
冲压效果>>绝对 | 所选区域曲面高度都设置为冲压参数规定的高度，即出现一平台。
冲压效果>>高点 | 将所选区域内的曲面高度都转为区域内的最高点高度。
冲压效果>>低点 | 将所选区域内的曲面高度都转为区域内的最低点高度。
冲压效果>>中心 | 将所选区域内的曲面高度都转为区域内的中心点高度。
冲压力 | 冲压时，曲面上顶点相对基准升高或降低的高度数值。
缩放比例 | 冲压时，冲压顶区域相对冲压底区域的缩放比例。


3.12 几何曲面浮雕变形

图3-46 浮雕变形前后的几何曲面

* 操作步骤：

1. 选择几何曲面。

2. 选择命令“艺术曲面-几何曲面浮雕变形”。

3. 填写浮雕变形参数。

4. 选择浮雕变形区域。

* 参数的意义：

几何曲面浮雕变形中各参数的意义与区域浮雕中完全相同

图3-47 几何曲面浮雕变形对话框


3.13 矩形网格曲面的分割与合并

这两个命令主要是针对大数据量网格曲面（一般为500万个顶点以上）的处理速度缓慢，甚至受到物理存储量的限制而无法实现某些操作（如：无法生成路径等）而设计的。本小节将介绍该命令的使用条件、使用方法和使用其解决的最常见的问题。当然，只要满足它的使用条件，也可用其解决其它的一些本节没有提到的问题。

图3-48 分割前后的网格曲面。

* 网格曲面分割的操作步骤：

1. 选择要分割的曲面。（只能选择一张曲面）

2. 选择命令“艺术曲面-修剪-矩形网格分割”。

3. 选择分割类型。

4. 左键单击网格内的某点。

* 参数的意义：

图3-49 网格曲面分割对话框。

上下分割 | 被选曲面将沿鼠标左键单击点将曲面分成上下两张曲面。
左右分割 | 被选曲面将沿鼠标左键单击点将曲面分成左右两张曲面。
上下左右分割 | 被选曲面将沿鼠标左键单击点将曲面分成上下左右四张曲面。

注：要分割曲面必须为矩形网格曲面。

图3-50 同源网格曲面的合并。

* 网格曲面合并的操作步骤：

1． 择要合并的两张的曲面。

2． 选择命令“艺术曲面-修剪-同源矩形网格合并”

3． 选择合并类型。

4． 左键单击工作区内的任意一点。

* 参数的意义：

左右合并 | 将被选的左右相邻的两张曲面合并为一张曲面。
上下合并 | 将被选的上下相邻的两张曲面合并为一张曲面。

图3-51 同源网格曲面合并对话框。

注：被融合的两张曲面有如下限制。

1． 两张曲面都必须为矩形网格曲面。

2． 两张曲面的步长应当相等。

3． 两张曲面或左右相邻，或上下相邻。

4． 左右相邻的两张曲面Y方向的长度必须一至。

5． 上下相邻的两张曲面X方向的长度必须一至。

下面介绍这两个命令最常用的两个用途。

1． 在大数据量网格曲面加工或生成路径困难时，可使用此命令先将网格曲面分割成若干个小曲面，分别生成路径，在加工时分别对曲面的几个分割进行加工。

2． 在大数据量网格曲面进入虚拟雕塑困难时，可先将此网格曲面分割，然后选择其中的一个进入虚拟雕塑内修改，当所有的分割曲面修改完成时，再将曲面合并处理曲面相接的地方。

另注：由于这两个命令是针对大数据量网格曲面设计的，为节约内存及加快命令的执行速度，系统将删除所有的返回操作数据。


欢迎使用精雕软件

JDPaint是精雕科技多年来一直致力研制开发的、具有自主版权的、功能强大的专业雕刻CAD/CAM软件。JDPaint是精雕CNC数控雕刻系统正常运作的保证，也是有效提高CNC雕刻系统使用效率和产品质量的源泉。

JDPaint专业雕刻软件经过多年的发展完善，功能日趋丰富强大，不仅突破了如曲面浮雕、等量切削等多项关键雕刻设计及加工技术，也充分保证了软件产品的易用性和实用性，极大地增强了精雕CNC雕刻机的加工能力和对雕刻领域多样性的适应能力。在应用领域上，JDPaint软件已经彻底突破了适合标牌、广告、建筑模型等较为传统的雕刻应用范畴，在技术门槛更高的工业雕刻领域，如滴塑模、高频模、小五金、眼镜模、紫铜电极等制作业，表现同样出色，成为国内最优秀的雕刻软件。

目前，JDPaint已由较为单一的雕刻设计加工软件，逐步走向面向CNC产品加工的一整套解决方案。

产品服务:

精雕科技网址 www.jingdiao.com

问题反馈E-mail： soft@jingdiao.com

软件开发部电话：010-60803959, 010-60803960

精雕科技总机： 010-60801188

销售热线：010-51922006/7　　E-mail：market@jingdiao.com