第四章

第四章 艺术绘制功能

在许多浮雕的制作中，对曲线的精度要求不高，但可能有一些特殊的需求，如水平对称、中心对称等，艺术绘制中提供了一些十分方便的辅助绘制的功能。


4.1 水平对称曲线

图4-1 水平对称曲线（控制顶点表示）

绘制水平对称的曲线，在该命令中提供了生成闭合样条、开放样条两种生成方式，提供了控制点生成和插值点生成两种控制方式，别外提供增加节点，删除节点，移动节点几项节点操作用于控制曲线形状。

* 操作步骤：

1） 选择命令“艺术绘制→水平对称曲线

2） 绘制和编辑曲线

1. 在空白区域点击鼠标左键，即插入一节点。

2. 用鼠标托动节点，即移动控制点。

图4-2 水平对称曲线对话框。

* 参数的含意：

水平对称轴 | 系统默认为曲线关于X轴对称，也可以通过鼠标拾取一点，则曲线将关于过这一点且平行于X轴的直线平行。
样条曲线生成方式 | 提供有两种曲线生成方式，分别为控制顶点生成和插值点生成。
双击模式： 插入点 | 在控制点生成时，双击节点时将产生重节点。在插值点生成时不起作用。
双击模式：删除点 | 在控制点生成时，先将点的重复度减为1，再双击便将节点删除。 在插值点生成方式下，直接将该点删除。
闭曲线 | 选中则生成封闭曲线，否则生成开放曲线。


4.2 垂直对称曲线

此命令用于绘制垂直对称曲线，其使用方法与水平对称曲线的使用方法完全相同，这是就不再重复了。

图4-3 水平对称曲线


4.3 水平垂直对称曲线

此命令用于绘制水平垂直对称曲线，其使用方法与水平对称曲线和垂直对称曲线也基本相同，只是水平垂直对称曲线不能生成开曲线。

图4-4 水平垂直对称曲线。


4.4 旋转变形曲线

此命令用于绘制一条中心对称的曲线，生成的曲线形状类似于中心阵列得到的曲线，但此命令不同于中心阵列，此此命令仅生成一条曲线。

图4-5 旋转变形曲线。

* 操作步骤：

1. 点击“艺术曲线-旋转变形曲线”。

2. 填写参数：对称点、点数及样条生成方式。

图4-6 旋转变形曲线对话框

* 参数的含意：

对称点 | 对称点即曲线的对称中心，系统默认为坐标原点。也可以通过拾取点或手工输入点来确定。
点数 | 类似于中心阵列中的阵列个数
样条曲线的生成方式 | 可以选择由控制点生成或插值点生成曲线。


4.5 180度对称曲线

此命令生成一条中心对称曲线

图4-7 180度对称曲线

* 操作步骤：

1. 点击“艺术曲线-180度对称曲线”。

2. 填写参数：对称点及样条生成方式

图4-8 180度对称曲线对话框。

* 参数的含意：

对称点 | 对称点即曲线的对称中心，系统默认为坐标原点。也可以通过拾取点或手工输入点来确定。
样条曲线的生成方式 | 可以选择由控制点生成或插值点生成曲线。


4.6 延伸曲线

延伸曲线以将生成一条将输入控制顶点延直线阵列得到的点为控制顶点的样条曲线。

图4-9 延伸曲线。

* 操作步骤：

1. 点击“艺术曲线-延伸曲线”。

2. 填写参数：延伸点数、距离及水平夹角。

3. 选择生成方式。

4. 用鼠标输入点生成曲线。

图4-10 延伸曲线对话框。

* 参数的含意：

延伸点数 | 定义曲线阵列的次数。
距离 | 曲线相临两组相对点之间的距离
水平夹角 | 曲线各组相对点边线与水平直线之间的夹角
样条曲线的生成方式 | 控制点生成或插值点生成。


4.7 随手绘制曲线

随手绘制曲线提供了方便的绘制非精确样条曲线的一种方法。在虚拟雕塑中常可以用此命令来绘制一些简单的曲线，如发线、水流。也可以用于描图。

图4-11使用随手绘制曲线描绘出的荷叶的边缘与截面。

* 操作步骤：

1. 点击“艺术曲线-随手绘制曲线”。

2. 填写参数：点采样距离、曲线平滑度。

3. 选择曲线是否自动封闭及封闭的方式。

图4-12随手绘制曲线.对话框。

* 参数的含意：

点采样距离 | 输入的有效点中最近的相临两点之间的距离。
曲线平滑度 | 实际上由这个参数与点采样距离共同决定了曲线的拟合误差
曲线自动封闭 | 可选择生成曲线是开曲线还是闭曲线
样条封闭 | 生成曲线时将用样条曲线将曲线的首点与末点连接起来。
直线封闭 | 生成曲线时将用直线将曲线的首点与末点连接起来。


4.8 画笔绘制

画笔绘制可以模仿手式绘制的图画或书写的文字。

图4-13画笔绘制图形。

* 操作步骤：

1. 点击“艺术曲线-画笔绘制”。

2. 选择画笔样式。

3. 填写参数：画笔宽度、点采样距离、曲线平滑度及是否清除图形中的自交。

4. 绘制图形。

图4-14 画笔绘制对话框。

* 参数的含意：

点采样距离 | 输入的有效点中最近的相临两点之间的距离。
曲线平滑度 | 实际上由这个参数与点采样距离共同决定了曲线的拟合误差
清除图形中的自交段 | 将图形中有交叉的部分清除。
当前画笔形状 | 画笔的形状用来控制生成区域的形状


4.9 书法笔绘制

书法笔绘制实质上是一条直线延鼠标移动轨迹形成的区域，可以用来书写一些特殊的艺术字体，当然用书法笔写出的文字不一定完全满足要求，可以再进入节点编修工具中进行编修。

* 操作步骤：

1. 点击“艺术曲线-书法笔绘制”。

2. 填写参数：画笔宽度、点采样距离、曲线平滑度、曲线类型及是否清除图形中的自交。

3. 绘制图形。

图4-15 书法笔绘制对话框。

* 参数的含意：

点采样距离 | 输入的有效点中最近的相临两点之间的距离。
曲线平滑度 | 实际上由这个参数与点采样距离共同决定了曲线的拟合误差
清除图形中的自交段 | 将图形中有交叉的部分清除。
书法笔宽度 | 即直线的长度
笔尖角度 | 即直线与X轴夹角。
曲线类型 | 即生成曲线的类型可以生成两种曲线，一种是Bezier曲线，别一种是B-Spline曲线


4.9 压力笔绘制

压力笔绘制是在绘制过程中，可以控制笔尖的宽度进而达到不同的艺术效果。

* 操作步骤：

1. 点击“艺术曲线-书法笔绘制”。

2. 填写参数：是不固定笔宽绘图、压力笔宽度设置、端头处理、笔宽控制方式、曲线类型、采点距离。

3. 绘制图形。

图4-15 压力笔绘制对话框。

* 参数的含意：

固定笔宽绘图 | 决定在绘制过程中笔尖的宽度是否变化。
压力笔宽度设置 | 分别设定起始笔宽、最大笔宽、地小笔宽用来控制在书写过程中的笔宽。
端头处理 | 决定起始处与结尾处的笔的形状。
笔宽控制方式 | 鼠标移动速度控制，即随着鼠标运动速度的加快笔尖的宽度将加大。 上下方向键控制，即笔宽由方向键控制。
曲线类型 | 即生成曲线的类型可以生成两种曲线，一种是Bezier曲线，别一种是B-Spline曲线
点采样距离 | 输入的有效点中最近的相临两点之间的距离。


欢迎使用精雕软件

JDPaint是精雕科技多年来一直致力研制开发的、具有自主版权的、功能强大的专业雕刻CAD/CAM软件。JDPaint是精雕CNC数控雕刻系统正常运作的保证，也是有效提高CNC雕刻系统使用效率和产品质量的源泉。

JDPaint专业雕刻软件经过多年的发展完善，功能日趋丰富强大，不仅突破了如曲面浮雕、等量切削等多项关键雕刻设计及加工技术，也充分保证了软件产品的易用性和实用性，极大地增强了精雕CNC雕刻机的加工能力和对雕刻领域多样性的适应能力。在应用领域上，JDPaint软件已经彻底突破了适合标牌、广告、建筑模型等较为传统的雕刻应用范畴，在技术门槛更高的工业雕刻领域，如滴塑模、高频模、小五金、眼镜模、紫铜电极等制作业，表现同样出色，成为国内最优秀的雕刻软件。

目前，JDPaint已由较为单一的雕刻设计加工软件，逐步走向面向CNC产品加工的一整套解决方案。

产品服务:

精雕科技网址 www.jingdiao.com

问题反馈E-mail： soft@jingdiao.com

软件开发部电话：010-60803959, 010-60803960

精雕科技总机： 010-60801188

销售热线：010-51922006/7　　E-mail：market@jingdiao.com